Adf Namespace

Adf Documented Class Library
Adf Namespace

[Missing <summary> documentation for "N:Adf"]

Classes
 | Class | Description
Public class | AESHelper | 编码助手 使用此助手建议配置： AESHelper:Key 与 AESHelper:IV ,此两配置均为32位长度字符串
Public class | Arguments | 参数
Public class | AuthcodeHelper | 基本类型
Public class | Base36Helper | Base36 助手
Public class | Base62Helper | Base62 助手
Public class | Base64Helper | Base64 Helper
Public class | BinarySerializable | 二进制序例化处理器
Public class | ByteHelper | 字节助手
Public class | CacheValueT | 实例Cache类型
Public class | CollectionGenericT | 通用泛型集合基类
Public class | CompressHelper | 压缩助手
Public class | ConfigHelper | Setting Helper
Public class | ConsistentHashingT | Consistent Hashing 一致性哈希
Public class | ConvertHelper | convert helper, the convert is safe
Public class | CRCHelper | CRC Helper
Public class | DnsHelper | DNS HELPER
Public class | DnsMXRecord | Mx Record
Public class | DnsRecord | DNS Record
Public class | DynamicInvoke | 快速方法调用
Public class | EncodingHelper | 字符编码助手
Public class | EnumHelper | 枚举助手
Public class | ExceptionHelper | Obsolete. 异常管理器
Public class | ExceptionMail | 异常邮件发送器
Public class | HtmlHelper | Html助手
Public class | HttpServer | Simple Http Server
Public class | HttpServerContext | Http Server Context
Public class | HttpServerContextBase | Http Server Context base
Public class | HttpServerWebSocketContext | Http Server WebSocket Context
Public class | HttpServerWebSocketMessageEventArgs | 服务器消息事件
Public class | IpHelper | IP 助手
Public class | JsonBinarySerializable | Json 二进制序列化实例
Public class | JsonHelper | Json Helper
Public class | LogEventArgs | 日志事件
Public class | LogExceptionEventArgs | 记录异常事件数据
Public class | LogManager | 日志管理器,可通过Log:Disabled配置存储级别，以逗号分隔默认全开，当指定某项时则禁止, 若值为all则禁止所有日志
Public class | LogWriter | 日志书写器
Public class | MD5Helper | 编码助手
 | Memcache | Supports setting, adding, replacing, deleting compressed/uncompressed and serialized (can be stored as string if object is native class) objects to memcached.
Public class | MemcachePool | Memcache池
Public class | MemcachePoolMember | Memcache池成员
Public class | Mq | 任务队列管理器
Public class | MqException | TaskQueue Exception
Public class | MqReceiveT | 任务队列接收器
Public class | NumberHelper | 数字助手
Public class | ObjectConverter | 对象转换器
Public class | Pager | 页序处理
Public class | PasswordHelper | 编码助手
Public class | PathHelper | 路径处理
Public class | PoolT | Pool Manager
Public class | PoolException | Pool Item Info
Public class | PoolNewInstanceExceptionEventArgs | Pool Item New Element Info
Public class | PropertyAccessor | 属性访问器
Public class | PropertyAccessorPropertyAccessorItem | 属性访问项
Public class | RandomHelper | 随机数
Public class | RedisClient | Redis 客户端
Public class | RedisClientPool | Redis Cache 管理器
Public class | RedisClientPoolMember | Redis 池成员
Public class | RedisConnection | Redis 客户端
Public class | RedisHashes | Redis 哈希表
Public class | RedisLists | Redis 列表
Public class | RedisResponseException | Redis 响应异常
Public class | RedisSets | Redis 集合
Public class | RedisSortedSets | Redis 有序集合
Public class | RedisWriter | 命令写入工具
Public class | Regular | 常规正常表达式
Public class | ResourceHelper | 资源助手
Public class | RetryHelper | Retry Helper
Public class | SerializeHelper | 序列化数据处理
Public class | SingletonT | 单例
Public class | Smtp | Smtp Helper
Public class | SmtpHelper | Obsolete. Smtp Helper
Public class | SocketHelper | Socket
Public class | StreamHelper | Stream
Public class | StringHelper | 字符串扩展
Public class | TypeHelper | 公用类型引用
Public class | UnixTimestampHelper | UNIX 时间戳
Public class | UriHelper | Uri Helper
Public class | ValidateHelper | 校验助手
Public class | WebLogger | Web Log
Public class | WebSocketClient | WebSocket 客户端
Public class | WebSocketDataFrame | WebSocket 数据帧
Public class | WebSocketDataFrameHeader | WebSocket DataFrame Header 数据头
Public class | WebSocketMessageEventArgs | WebSocketMessageEvent Args
Public class | WindowsEventLog | Windows Event Log
Public class | XmlHelper | XML Helper
Interfaces
 | Interface | Description
Public interface | IBinarySerializable | 可序列化标记接口
Public interface | ICache | ICache
Public interface | IPoolInstance | Pool Element Interface 池实例
Public interface | IPoolMember | Pool Member Info 池成员
Public interface | ISmtp | Smtp Helper
Delegates
 | Delegate | Description
Public delegate | CFuncT, TResult | 带返回值的调用
Public delegate | CFuncT1, T2, TResult | 带返回值的调用
Public delegate | CFuncT1, T2, T3, TResult | 带返回值的调用
Public delegate | HttpServerAuthorizationCallback | Http Server Authorization Callback
Public delegate | HttpServerCallback | Http Server Callback
Public delegate | HttpServerWebSocketCallback | WebSocket Disconnection Callback
Public delegate | ObjectConverterConvertValueCallback | 定义对象转换器转换对象值时的回调，以便转换具有嵌套值时的自处理
Public delegate | RetryAction | Retry Action
Enumerations
 | Enumeration | Description
Public enumeration | HttpServerChunkStatus | 块输出状态
Public enumeration | HttpServerRequestType | HttpServerRequestType
Public enumeration | RedisAggregate | 集合类型
Public enumeration | RedisKeyType | Redis 键类型
Public enumeration | WebSocketOpcode | Contains the values of the opcode that indicates the type of a WebSocket frame.


AESHelper Class

AESHelper Class
编码助手 使用此助手建议配置： AESHelper:Key 与 AESHelper:IV ,此两配置均为32位长度字符串
Inheritance Hierarchy
SystemObject
AdfAESHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class AESHelper
Public NotInheritable Class AESHelper
public ref class AESHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AESHelper =  class end

The AESHelper type exposes the following members.

Methods
Name | Description
Decrypt(String, String) | DES 解密
Decrypt(String, Byte, Byte) | DES 解密
Decrypt(String, String, Encoding) | DES 解密
Decrypt(String, Byte, Byte, Encoding) | DES 解密
DecryptUrl(String) | AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）
DecryptUrl(String, String) | AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）
Encrypt(String, String) | AES 加密
Encrypt(String, Byte, Byte) | DES 加密
Encrypt(String, String, Encoding) | AES 加密
Encrypt(String, Byte, Byte, Encoding) | DES 加密
EncryptUrl(String) | AES 加密，输出成URL友好格式
EncryptUrl(String, String) | AES 加密，输出成URL友好格式
Top
Fields
Name | Description
Encoding | 默认字符编码，默认为 ASCII
IV | AES 加密向量
Key | AES 通用加密KEY
Top
See Also

Reference


AESHelper Fields

AESHelper Fields

The AESHelper type exposes the following members.

Fields
Name | Description
Encoding | 默认字符编码，默认为 ASCII
IV | AES 加密向量
Key | AES 通用加密KEY
Top
See Also

Reference

AESHelper Class


AESHelper.Encoding Field

AESHelperEncoding Field
默认字符编码，默认为 ASCII

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Encoding Encoding
Public Shared ReadOnly Encoding As Encoding
public:
static initonly Encoding^ Encoding
static val Encoding: Encoding

Field Value

Type: Encoding
See Also

Reference

AESHelper Class


AESHelper.IV Field

AESHelperIV Field
AES 加密向量

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly string IV
Public Shared ReadOnly IV As String
public:
static initonly String^ IV
static val IV: string

Field Value

Type: String
See Also

Reference

AESHelper Class


AESHelper.Key Field

AESHelperKey Field
AES 通用加密KEY

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly string Key
Public Shared ReadOnly Key As String
public:
static initonly String^ Key
static val Key: string

Field Value

Type: String
See Also

Reference

AESHelper Class


AESHelper Methods

AESHelper Methods
Methods
Name | Description
Decrypt(String, String) | DES 解密
Decrypt(String, Byte, Byte) | DES 解密
Decrypt(String, String, Encoding) | DES 解密
Decrypt(String, Byte, Byte, Encoding) | DES 解密
DecryptUrl(String) | AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）
DecryptUrl(String, String) | AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）
Encrypt(String, String) | AES 加密
Encrypt(String, Byte, Byte) | DES 加密
Encrypt(String, String, Encoding) | AES 加密
Encrypt(String, Byte, Byte, Encoding) | DES 加密
EncryptUrl(String) | AES 加密，输出成URL友好格式
EncryptUrl(String, String) | AES 加密，输出成URL友好格式
Top
See Also

Reference

AESHelper Class


AESHelper.Decrypt Method

AESHelperDecrypt Method
Overload List
Name | Description
Decrypt(String, String) | DES 解密
Decrypt(String, Byte, Byte) | DES 解密
Decrypt(String, String, Encoding) | DES 解密
Decrypt(String, Byte, Byte, Encoding) | DES 解密
Top
See Also

Reference

AESHelper Class


AESHelper.Decrypt Method (String, String)

AESHelperDecrypt Method (String, String)
DES 解密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Decrypt(
    string input,
    string key
)
Public Shared Function Decrypt (
    input As String,
    key As String
) As String
public:
static String^ Decrypt(
    String^ input,
    String^ key
)
static member Decrypt :
        input : string *
        key : string -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.String)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.String)"]

See Also

Reference

AESHelper Class
Decrypt Overload


AESHelper.Decrypt Method (String, Byte[], Byte[])

AESHelperDecrypt Method (String, Byte, Byte)
DES 解密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Decrypt(
    string input,
    byte[] key,
    byte[] iv
)
Public Shared Function Decrypt (
    input As String,
    key As Byte(),
    iv As Byte()
) As String
public:
static String^ Decrypt(
    String^ input,
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)
static member Decrypt :
        input : string *
        key : byte[] *
        iv : byte[] -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[])"]

key
Type: SystemByte

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[])"]

iv
Type: SystemByte

[Missing <param name="iv"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[])"]

See Also

Reference

AESHelper Class
Decrypt Overload


AESHelper.Decrypt Method (String, String, Encoding)

AESHelperDecrypt Method (String, String, Encoding)
DES 解密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Decrypt(
    string input,
    string key,
    Encoding encoding
)
Public Shared Function Decrypt (
    input As String,
    key As String,
    encoding As Encoding
) As String
public:
static String^ Decrypt(
    String^ input,
    String^ key,
    Encoding^ encoding
)
static member Decrypt :
        input : string *
        key : string *
        encoding : Encoding -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.String,System.Text.Encoding)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.String,System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.String,System.Text.Encoding)"]

See Also

Reference

AESHelper Class
Decrypt Overload


AESHelper.Decrypt Method (String, Byte[], Byte[], Encoding)

AESHelperDecrypt Method (String, Byte, Byte, Encoding)
DES 解密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Decrypt(
    string input,
    byte[] key,
    byte[] iv,
    Encoding encoding
)
Public Shared Function Decrypt (
    input As String,
    key As Byte(),
    iv As Byte(),
    encoding As Encoding
) As String
public:
static String^ Decrypt(
    String^ input,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    Encoding^ encoding
)
static member Decrypt :
        input : string *
        key : byte[] *
        iv : byte[] *
        encoding : Encoding -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

key
Type: SystemByte

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

iv
Type: SystemByte

[Missing <param name="iv"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Decrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

See Also

Reference

AESHelper Class
Decrypt Overload


AESHelper.DecryptUrl Method

AESHelperDecryptUrl Method
Overload List
Name | Description
DecryptUrl(String) | AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）
DecryptUrl(String, String) | AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）
Top
See Also

Reference

AESHelper Class


AESHelper.DecryptUrl Method (String)

AESHelperDecryptUrl Method (String)
AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string DecryptUrl(
    string input
)
Public Shared Function DecryptUrl (
    input As String
) As String
public:
static String^ DecryptUrl(
    String^ input
)
static member DecryptUrl :
        input : string -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.DecryptUrl(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.DecryptUrl(System.String)"]

See Also

Reference

AESHelper Class
DecryptUrl Overload


AESHelper.DecryptUrl Method (String, String)

AESHelperDecryptUrl Method (String, String)
AES 解密（注意，只能对用EncryptUrl方法进行加密的字符串使用）

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string DecryptUrl(
    string input,
    string key
)
Public Shared Function DecryptUrl (
    input As String,
    key As String
) As String
public:
static String^ DecryptUrl(
    String^ input,
    String^ key
)
static member DecryptUrl :
        input : string *
        key : string -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.DecryptUrl(System.String,System.String)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.DecryptUrl(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.DecryptUrl(System.String,System.String)"]

See Also

Reference

AESHelper Class
DecryptUrl Overload


AESHelper.Encrypt Method

AESHelperEncrypt Method
Overload List
Name | Description
Encrypt(String, String) | AES 加密
Encrypt(String, Byte, Byte) | DES 加密
Encrypt(String, String, Encoding) | AES 加密
Encrypt(String, Byte, Byte, Encoding) | DES 加密
Top
See Also

Reference

AESHelper Class


AESHelper.Encrypt Method (String, String)

AESHelperEncrypt Method (String, String)
AES 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Encrypt(
    string input,
    string key
)
Public Shared Function Encrypt (
    input As String,
    key As String
) As String
public:
static String^ Encrypt(
    String^ input,
    String^ key
)
static member Encrypt :
        input : string *
        key : string -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.String)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.String)"]

See Also

Reference

AESHelper Class
Encrypt Overload


AESHelper.Encrypt Method (String, Byte[], Byte[])

AESHelperEncrypt Method (String, Byte, Byte)
DES 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Encrypt(
    string input,
    byte[] key,
    byte[] iv
)
Public Shared Function Encrypt (
    input As String,
    key As Byte(),
    iv As Byte()
) As String
public:
static String^ Encrypt(
    String^ input,
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)
static member Encrypt :
        input : string *
        key : byte[] *
        iv : byte[] -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[])"]

key
Type: SystemByte

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[])"]

iv
Type: SystemByte

[Missing <param name="iv"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[])"]

See Also

Reference

AESHelper Class
Encrypt Overload


AESHelper.Encrypt Method (String, String, Encoding)

AESHelperEncrypt Method (String, String, Encoding)
AES 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Encrypt(
    string input,
    string key,
    Encoding encoding
)
Public Shared Function Encrypt (
    input As String,
    key As String,
    encoding As Encoding
) As String
public:
static String^ Encrypt(
    String^ input,
    String^ key,
    Encoding^ encoding
)
static member Encrypt :
        input : string *
        key : string *
        encoding : Encoding -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.String,System.Text.Encoding)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.String,System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.String,System.Text.Encoding)"]

See Also

Reference

AESHelper Class
Encrypt Overload


AESHelper.Encrypt Method (String, Byte[], Byte[], Encoding)

AESHelperEncrypt Method (String, Byte, Byte, Encoding)
DES 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Encrypt(
    string input,
    byte[] key,
    byte[] iv,
    Encoding encoding
)
Public Shared Function Encrypt (
    input As String,
    key As Byte(),
    iv As Byte(),
    encoding As Encoding
) As String
public:
static String^ Encrypt(
    String^ input,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    Encoding^ encoding
)
static member Encrypt :
        input : string *
        key : byte[] *
        iv : byte[] *
        encoding : Encoding -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

key
Type: SystemByte

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

iv
Type: SystemByte

[Missing <param name="iv"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.Encrypt(System.String,System.Byte[],System.Byte[],System.Text.Encoding)"]

See Also

Reference

AESHelper Class
Encrypt Overload


AESHelper.EncryptUrl Method

AESHelperEncryptUrl Method
Overload List
Name | Description
EncryptUrl(String) | AES 加密，输出成URL友好格式
EncryptUrl(String, String) | AES 加密，输出成URL友好格式
Top
See Also

Reference

AESHelper Class


AESHelper.EncryptUrl Method (String)

AESHelperEncryptUrl Method (String)
AES 加密，输出成URL友好格式

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncryptUrl(
    string input
)
Public Shared Function EncryptUrl (
    input As String
) As String
public:
static String^ EncryptUrl(
    String^ input
)
static member EncryptUrl :
        input : string -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.EncryptUrl(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.EncryptUrl(System.String)"]

See Also

Reference

AESHelper Class
EncryptUrl Overload


AESHelper.EncryptUrl Method (String, String)

AESHelperEncryptUrl Method (String, String)
AES 加密，输出成URL友好格式

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncryptUrl(
    string input,
    string key
)
Public Shared Function EncryptUrl (
    input As String,
    key As String
) As String
public:
static String^ EncryptUrl(
    String^ input,
    String^ key
)
static member EncryptUrl :
        input : string *
        key : string -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.AESHelper.EncryptUrl(System.String,System.String)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.AESHelper.EncryptUrl(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.AESHelper.EncryptUrl(System.String,System.String)"]

See Also

Reference

AESHelper Class
EncryptUrl Overload


Arguments Class

Arguments Class
参数
Inheritance Hierarchy
SystemObject
AdfArguments

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Arguments
Public Class Arguments
public ref class Arguments
type Arguments =  class end

The Arguments type exposes the following members.

Constructors
 | Name | Description
Public method | Arguments | Initializes a new instance of the Arguments class
Top
Methods
 | Name | Description
Public method | Add(String) | 添加一个参数
Public method | Add(String, String) | 添加一个参数
Public method | AddOption | 添加一个选项
Public method | AddWithQuote | 添加一个带符号包含的参数
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | Get Hash Code (Overrides ObjectGetHashCode.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Parse | 参数转换
Public method | ToString | 获取实例字符串形式 (Overrides ObjectToString.)
Top
See Also

Reference


Arguments Constructor

Arguments Constructor
Initializes a new instance of the Arguments class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Arguments()
Public Sub New
public:
Arguments()
new : unit -> Arguments
See Also

Reference

Arguments Class


Arguments Methods

Arguments Methods

The Arguments type exposes the following members.

Methods
 | Name | Description
Public method | Add(String) | 添加一个参数
Public method | Add(String, String) | 添加一个参数
Public method | AddOption | 添加一个选项
Public method | AddWithQuote | 添加一个带符号包含的参数
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | Get Hash Code (Overrides ObjectGetHashCode.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Parse | 参数转换
Public method | ToString | 获取实例字符串形式 (Overrides ObjectToString.)
Top
See Also

Reference

Arguments Class


Arguments.Add Method

ArgumentsAdd Method
Overload List
 | Name | Description
Public method | Add(String) | 添加一个参数
Public method | Add(String, String) | 添加一个参数
Top
See Also

Reference

Arguments Class


Arguments.Add Method (String)

ArgumentsAdd Method (String)
添加一个参数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string key
)
Public Sub Add (
    key As String
)
public:
void Add(
    String^ key
)
member Add :
        key : string -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.Arguments.Add(System.String)"]

See Also

Reference

Arguments Class
Add Overload


Arguments.Add Method (String, String)

ArgumentsAdd Method (String, String)
添加一个参数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Add(
    string key,
    string value
)
Public Sub Add (
    key As String,
    value As String
)
public:
void Add(
    String^ key,
    String^ value
)
member Add :
        key : string *
        value : string -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.Arguments.Add(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.Arguments.Add(System.String,System.String)"]

See Also

Reference

Arguments Class
Add Overload


Arguments.AddOption Method

ArgumentsAddOption Method
添加一个选项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void AddOption(
    string key
)
Public Sub AddOption (
    key As String
)
public:
void AddOption(
    String^ key
)
member AddOption :
        key : string -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.Arguments.AddOption(System.String)"]

See Also

Reference

Arguments Class


Arguments.AddWithQuote Method

ArgumentsAddWithQuote Method
添加一个带符号包含的参数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void AddWithQuote(
    string key,
    string value,
    char quoteChar
)
Public Sub AddWithQuote (
    key As String,
    value As String,
    quoteChar As Char
)
public:
void AddWithQuote(
    String^ key,
    String^ value,
    wchar_t quoteChar
)
member AddWithQuote :
        key : string *
        value : string *
        quoteChar : char -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.Arguments.AddWithQuote(System.String,System.String,System.Char)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.Arguments.AddWithQuote(System.String,System.String,System.Char)"]

quoteChar
Type: SystemChar

[Missing <param name="quoteChar"/> documentation for "M:Adf.Arguments.AddWithQuote(System.String,System.String,System.Char)"]

See Also

Reference

Arguments Class


Arguments.GetHashCode Method

ArgumentsGetHashCode Method
Get Hash Code

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Arguments.GetHashCode"]

See Also

Reference

Arguments Class


Arguments.Parse Method

ArgumentsParse Method
参数转换

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<string, string> Parse(
    string[] args
)
Public Shared Function Parse (
    args As String()
) As Dictionary(Of String, String)
public:
static Dictionary<String^, String^>^ Parse(
    array<String^>^ args
)
static member Parse :
        args : string[] -> Dictionary<string, string>

Parameters

args
Type: SystemString

[Missing <param name="args"/> documentation for "M:Adf.Arguments.Parse(System.String[])"]

Return Value

Type: Dictionary String, String

[Missing <returns> documentation for "M:Adf.Arguments.Parse(System.String[])"]

See Also

Reference

Arguments Class


Arguments.ToString Method

ArgumentsToString Method
获取实例字符串形式

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Arguments.ToString"]

See Also

Reference

Arguments Class


AuthcodeHelper Class

AuthcodeHelper Class
基本类型
Inheritance Hierarchy
SystemObject
AdfAuthcodeHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class AuthcodeHelper
Public Class AuthcodeHelper
public ref class AuthcodeHelper
type AuthcodeHelper =  class end

The AuthcodeHelper type exposes the following members.

Constructors
 | Name | Description
Public method | AuthcodeHelper | Initializes a new instance of the AuthcodeHelper class
Top
Methods
 | Name | Description
 | CreateImage(Stream, String, Int32, Int32, Int32) | 创建一个图片,图片类型Gif
 | CreateImage(Stream, String, Int32, Int32, Int32, Int32) | 创建一个图片,图片类型Gif
 | CreateImage2 | 创建一个图片,图片类型Gif
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


AuthcodeHelper Constructor

AuthcodeHelper Constructor
Initializes a new instance of the AuthcodeHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public AuthcodeHelper()
Public Sub New
public:
AuthcodeHelper()
new : unit -> AuthcodeHelper
See Also

Reference

AuthcodeHelper Class


AuthcodeHelper Methods

AuthcodeHelper Methods

The AuthcodeHelper type exposes the following members.

Methods
 | Name | Description
 | CreateImage(Stream, String, Int32, Int32, Int32) | 创建一个图片,图片类型Gif
 | CreateImage(Stream, String, Int32, Int32, Int32, Int32) | 创建一个图片,图片类型Gif
 | CreateImage2 | 创建一个图片,图片类型Gif
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

AuthcodeHelper Class


AuthcodeHelper.CreateImage Method

AuthcodeHelperCreateImage Method
Overload List
Name | Description
CreateImage(Stream, String, Int32, Int32, Int32) | 创建一个图片,图片类型Gif
CreateImage(Stream, String, Int32, Int32, Int32, Int32) | 创建一个图片,图片类型Gif
Top
See Also

Reference

AuthcodeHelper Class


AuthcodeHelper.CreateImage Method (Stream, String, Int32, Int32, Int32)

AuthcodeHelperCreateImage Method (Stream, String, Int32, Int32, Int32)
创建一个图片,图片类型Gif

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void CreateImage(
    Stream outputStream,
    string code,
    int width,
    int height,
    int fontSize
)
Public Shared Sub CreateImage (
    outputStream As Stream,
    code As String,
    width As Integer,
    height As Integer,
    fontSize As Integer
)
public:
static void CreateImage(
    Stream^ outputStream,
    String^ code,
    int width,
    int height,
    int fontSize
)
static member CreateImage :
        outputStream : Stream *
        code : string *
        width : int *
        height : int *
        fontSize : int -> unit

Parameters

outputStream
Type: System.IOStream

[Missing <param name="outputStream"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32)"]

code
Type: SystemString

[Missing <param name="code"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32)"]

width
Type: SystemInt32

[Missing <param name="width"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32)"]

height
Type: SystemInt32

[Missing <param name="height"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32)"]

fontSize
Type: SystemInt32

[Missing <param name="fontSize"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

AuthcodeHelper Class
CreateImage Overload


AuthcodeHelper.CreateImage Method (Stream, String, Int32, Int32, Int32, Int32)

AuthcodeHelperCreateImage Method (Stream, String, Int32, Int32, Int32, Int32)
创建一个图片,图片类型Gif

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void CreateImage(
    Stream outputStream,
    string code,
    int width,
    int height,
    int fontSize,
    int noiseCount = 25
)
Public Shared Sub CreateImage (
    outputStream As Stream,
    code As String,
    width As Integer,
    height As Integer,
    fontSize As Integer,
    Optional noiseCount As Integer = 25
)
public:
static void CreateImage(
    Stream^ outputStream,
    String^ code,
    int width,
    int height,
    int fontSize,
    int noiseCount = 25
)
static member CreateImage :
        outputStream : Stream *
        code : string *
        width : int *
        height : int *
        fontSize : int *
        ?noiseCount : int
(* Defaults:
        let _noiseCount = defaultArg noiseCount 25
*)
-> unit

Parameters

outputStream
Type: System.IOStream

[Missing <param name="outputStream"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

code
Type: SystemString

[Missing <param name="code"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

width
Type: SystemInt32

[Missing <param name="width"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

height
Type: SystemInt32

[Missing <param name="height"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

fontSize
Type: SystemInt32

[Missing <param name="fontSize"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

noiseCount (Optional)
Type: SystemInt32

[Missing <param name="noiseCount"/> documentation for "M:Adf.AuthcodeHelper.CreateImage(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

AuthcodeHelper Class
CreateImage Overload


AuthcodeHelper.CreateImage2 Method

AuthcodeHelperCreateImage2 Method
创建一个图片,图片类型Gif

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void CreateImage2(
    Stream outputStream,
    string code,
    int width,
    int height,
    int fontSize,
    int noiseCount = 25
)
Public Shared Sub CreateImage2 (
    outputStream As Stream,
    code As String,
    width As Integer,
    height As Integer,
    fontSize As Integer,
    Optional noiseCount As Integer = 25
)
public:
static void CreateImage2(
    Stream^ outputStream,
    String^ code,
    int width,
    int height,
    int fontSize,
    int noiseCount = 25
)
static member CreateImage2 :
        outputStream : Stream *
        code : string *
        width : int *
        height : int *
        fontSize : int *
        ?noiseCount : int
(* Defaults:
        let _noiseCount = defaultArg noiseCount 25
*)
-> unit

Parameters

outputStream
Type: System.IOStream

[Missing <param name="outputStream"/> documentation for "M:Adf.AuthcodeHelper.CreateImage2(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

code
Type: SystemString

[Missing <param name="code"/> documentation for "M:Adf.AuthcodeHelper.CreateImage2(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

width
Type: SystemInt32

[Missing <param name="width"/> documentation for "M:Adf.AuthcodeHelper.CreateImage2(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

height
Type: SystemInt32

[Missing <param name="height"/> documentation for "M:Adf.AuthcodeHelper.CreateImage2(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

fontSize
Type: SystemInt32

[Missing <param name="fontSize"/> documentation for "M:Adf.AuthcodeHelper.CreateImage2(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

noiseCount (Optional)
Type: SystemInt32

[Missing <param name="noiseCount"/> documentation for "M:Adf.AuthcodeHelper.CreateImage2(System.IO.Stream,System.String,System.Int32,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

AuthcodeHelper Class


Base36Helper Class

Base36Helper Class
Base36 助手
Inheritance Hierarchy
SystemObject
AdfBase36Helper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class Base36Helper
Public NotInheritable Class Base36Helper
public ref class Base36Helper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Base36Helper =  class end

The Base36Helper type exposes the following members.

Methods
Name | Description
Decode | 将已编码的36字符还原为数字
Encode | 将数字进行36字符编码
Top
See Also

Reference


Base36Helper Methods

Base36Helper Methods

The Base36Helper type exposes the following members.

Methods
Name | Description
Decode | 将已编码的36字符还原为数字
Encode | 将数字进行36字符编码
Top
See Also

Reference

Base36Helper Class


Base36Helper.Decode Method

Base36HelperDecode Method
将已编码的36字符还原为数字

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static long Decode(
    string encodeString
)
Public Shared Function Decode (
    encodeString As String
) As Long
public:
static long long Decode(
    String^ encodeString
)
static member Decode :
        encodeString : string -> int64

Parameters

encodeString
Type: SystemString

[Missing <param name="encodeString"/> documentation for "M:Adf.Base36Helper.Decode(System.String)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:Adf.Base36Helper.Decode(System.String)"]

See Also

Reference

Base36Helper Class


Base36Helper.Encode Method

Base36HelperEncode Method
将数字进行36字符编码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Encode(
    long value
)
Public Shared Function Encode (
    value As Long
) As String
public:
static String^ Encode(
    long long value
)
static member Encode :
        value : int64 -> string

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:Adf.Base36Helper.Encode(System.Int64)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Base36Helper.Encode(System.Int64)"]

See Also

Reference

Base36Helper Class


Base62Helper Class

Base62Helper Class
Base62 助手
Inheritance Hierarchy
SystemObject
AdfBase62Helper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class Base62Helper
Public NotInheritable Class Base62Helper
public ref class Base62Helper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Base62Helper =  class end

The Base62Helper type exposes the following members.

Methods
Name | Description
Decode | 将已编码的62字符还原为数字
Encode | 将数字进行62字符编码
Top
See Also

Reference


Base62Helper Methods

Base62Helper Methods

The Base62Helper type exposes the following members.

Methods
Name | Description
Decode | 将已编码的62字符还原为数字
Encode | 将数字进行62字符编码
Top
See Also

Reference

Base62Helper Class


Base62Helper.Decode Method

Base62HelperDecode Method
将已编码的62字符还原为数字

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static long Decode(
    string encodeString
)
Public Shared Function Decode (
    encodeString As String
) As Long
public:
static long long Decode(
    String^ encodeString
)
static member Decode :
        encodeString : string -> int64

Parameters

encodeString
Type: SystemString

[Missing <param name="encodeString"/> documentation for "M:Adf.Base62Helper.Decode(System.String)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:Adf.Base62Helper.Decode(System.String)"]

See Also

Reference

Base62Helper Class


Base62Helper.Encode Method

Base62HelperEncode Method
将数字进行62字符编码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Encode(
    long value
)
Public Shared Function Encode (
    value As Long
) As String
public:
static String^ Encode(
    long long value
)
static member Encode :
        value : int64 -> string

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:Adf.Base62Helper.Encode(System.Int64)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Base62Helper.Encode(System.Int64)"]

See Also

Reference

Base62Helper Class


Base64Helper Class

Base64Helper Class
Base64 Helper
Inheritance Hierarchy
SystemObject
AdfBase64Helper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class Base64Helper
Public NotInheritable Class Base64Helper
public ref class Base64Helper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Base64Helper =  class end

The Base64Helper type exposes the following members.

Methods
Name | Description
DecodeUrl(String) | 使用默认编码将UrlBase64编码串转换为源字符串
DecodeUrl(String, Encoding) | 将UrlBase64编码串转换为源字符串
EncodeUrl(String) | 使用默认的Base64编码可用的URL字符串
EncodeUrl(String, Encoding) | 使用Base64编码可用的URL字符串
Top
Fields
Name | Description
DefaultEncoding | 默认的字符编码,默认为ASCII
Top
See Also

Reference


Base64Helper Fields

Base64Helper Fields

The Base64Helper type exposes the following members.

Fields
Name | Description
DefaultEncoding | 默认的字符编码,默认为ASCII
Top
See Also

Reference

Base64Helper Class


Base64Helper.DefaultEncoding Field

Base64HelperDefaultEncoding Field
默认的字符编码,默认为ASCII

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Encoding DefaultEncoding
Public Shared ReadOnly DefaultEncoding As Encoding
public:
static initonly Encoding^ DefaultEncoding
static val DefaultEncoding: Encoding

Field Value

Type: Encoding
Remarks
可通过配置 Base64Helper:DefaultEncoding 设置
See Also

Reference

Base64Helper Class


Base64Helper Methods

Base64Helper Methods
Methods
Name | Description
DecodeUrl(String) | 使用默认编码将UrlBase64编码串转换为源字符串
DecodeUrl(String, Encoding) | 将UrlBase64编码串转换为源字符串
EncodeUrl(String) | 使用默认的Base64编码可用的URL字符串
EncodeUrl(String, Encoding) | 使用Base64编码可用的URL字符串
Top
See Also

Reference

Base64Helper Class


Base64Helper.DecodeUrl Method

Base64HelperDecodeUrl Method
Overload List
Name | Description
DecodeUrl(String) | 使用默认编码将UrlBase64编码串转换为源字符串
DecodeUrl(String, Encoding) | 将UrlBase64编码串转换为源字符串
Top
See Also

Reference

Base64Helper Class


Base64Helper.DecodeUrl Method (String)

Base64HelperDecodeUrl Method (String)
使用默认编码将UrlBase64编码串转换为源字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string DecodeUrl(
    string urlString
)
Public Shared Function DecodeUrl (
    urlString As String
) As String
public:
static String^ DecodeUrl(
    String^ urlString
)
static member DecodeUrl :
        urlString : string -> string

Parameters

urlString
Type: SystemString

[Missing <param name="urlString"/> documentation for "M:Adf.Base64Helper.DecodeUrl(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Base64Helper.DecodeUrl(System.String)"]

See Also

Reference

Base64Helper Class
DecodeUrl Overload


Base64Helper.DecodeUrl Method (String, Encoding)

Base64HelperDecodeUrl Method (String, Encoding)
将UrlBase64编码串转换为源字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string DecodeUrl(
    string urlString,
    Encoding encoding
)
Public Shared Function DecodeUrl (
    urlString As String,
    encoding As Encoding
) As String
public:
static String^ DecodeUrl(
    String^ urlString,
    Encoding^ encoding
)
static member DecodeUrl :
        urlString : string *
        encoding : Encoding -> string

Parameters

urlString
Type: SystemString

[Missing <param name="urlString"/> documentation for "M:Adf.Base64Helper.DecodeUrl(System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.Base64Helper.DecodeUrl(System.String,System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Base64Helper.DecodeUrl(System.String,System.Text.Encoding)"]

See Also

Reference

Base64Helper Class
DecodeUrl Overload


Base64Helper.EncodeUrl Method

Base64HelperEncodeUrl Method
Overload List
Name | Description
EncodeUrl(String) | 使用默认的Base64编码可用的URL字符串
EncodeUrl(String, Encoding) | 使用Base64编码可用的URL字符串
Top
See Also

Reference

Base64Helper Class


Base64Helper.EncodeUrl Method (String)

Base64HelperEncodeUrl Method (String)
使用默认的Base64编码可用的URL字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncodeUrl(
    string inputString
)
Public Shared Function EncodeUrl (
    inputString As String
) As String
public:
static String^ EncodeUrl(
    String^ inputString
)
static member EncodeUrl :
        inputString : string -> string

Parameters

inputString
Type: SystemString

[Missing <param name="inputString"/> documentation for "M:Adf.Base64Helper.EncodeUrl(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Base64Helper.EncodeUrl(System.String)"]

See Also

Reference

Base64Helper Class
EncodeUrl Overload


Base64Helper.EncodeUrl Method (String, Encoding)

Base64HelperEncodeUrl Method (String, Encoding)
使用Base64编码可用的URL字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncodeUrl(
    string inputString,
    Encoding encoding
)
Public Shared Function EncodeUrl (
    inputString As String,
    encoding As Encoding
) As String
public:
static String^ EncodeUrl(
    String^ inputString,
    Encoding^ encoding
)
static member EncodeUrl :
        inputString : string *
        encoding : Encoding -> string

Parameters

inputString
Type: SystemString

[Missing <param name="inputString"/> documentation for "M:Adf.Base64Helper.EncodeUrl(System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.Base64Helper.EncodeUrl(System.String,System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Base64Helper.EncodeUrl(System.String,System.Text.Encoding)"]

See Also

Reference

Base64Helper Class
EncodeUrl Overload


BinarySerializable Class

BinarySerializable Class
二进制序例化处理器
Inheritance Hierarchy
SystemObject
AdfBinarySerializable

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class BinarySerializable : IBinarySerializable
Public Class BinarySerializable
    Implements IBinarySerializable
public ref class BinarySerializable : IBinarySerializable
type BinarySerializable =
    class
        interface IBinarySerializable
    end

The BinarySerializable type exposes the following members.

Constructors
 | Name | Description
Public method | BinarySerializable | Initializes a new instance of the BinarySerializable class
Top
Methods
 | Name | Description
Public method | Deserialize | 将数组反序例化为对象
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Serialize | 将对象序例化为二进制
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Fields
Name | Description
Instance | 默认的实例
Top
See Also

Reference


BinarySerializable Constructor

BinarySerializable Constructor
Initializes a new instance of the BinarySerializable class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public BinarySerializable()
Public Sub New
public:
BinarySerializable()
new : unit -> BinarySerializable
See Also

Reference

BinarySerializable Class


BinarySerializable Fields

BinarySerializable Fields

The BinarySerializable type exposes the following members.

Fields
Name | Description
Instance | 默认的实例
Top
See Also

Reference

BinarySerializable Class


BinarySerializable.Instance Field

BinarySerializableInstance Field
默认的实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly BinarySerializable Instance
Public Shared ReadOnly Instance As BinarySerializable
public:
static initonly BinarySerializable^ Instance
static val Instance: BinarySerializable

Field Value

Type: BinarySerializable
See Also

Reference

BinarySerializable Class


BinarySerializable Methods

BinarySerializable Methods

The BinarySerializable type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | 将数组反序例化为对象
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Serialize | 将对象序例化为二进制
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

BinarySerializable Class


BinarySerializable.Deserialize Method

BinarySerializableDeserialize Method
将数组反序例化为对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Object Deserialize(
    Type type,
    byte[] data
)
Public Function Deserialize (
    type As Type,
    data As Byte()
) As Object
public:
virtual Object^ Deserialize(
    Type^ type,
    array<unsigned char>^ data
) sealed
abstract Deserialize :
        type : Type *
        data : byte[] -> Object
override Deserialize :
        type : Type *
        data : byte[] -> Object

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.BinarySerializable.Deserialize(System.Type,System.Byte[])"]

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.BinarySerializable.Deserialize(System.Type,System.Byte[])"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.BinarySerializable.Deserialize(System.Type,System.Byte[])"]

Implements

IBinarySerializableDeserialize(Type, Byte)
See Also

Reference

BinarySerializable Class


BinarySerializable.Serialize Method

BinarySerializableSerialize Method
将对象序例化为二进制

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] Serialize(
    Object value
)
Public Function Serialize (
    value As Object
) As Byte()
public:
virtual array<unsigned char>^ Serialize(
    Object^ value
) sealed
abstract Serialize :
        value : Object -> byte[]
override Serialize :
        value : Object -> byte[]

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.BinarySerializable.Serialize(System.Object)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.BinarySerializable.Serialize(System.Object)"]

Implements

IBinarySerializableSerialize(Object)
See Also

Reference

BinarySerializable Class


ByteHelper Class

ByteHelper Class
字节助手
Inheritance Hierarchy
SystemObject
AdfByteHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ByteHelper
Public Class ByteHelper
public ref class ByteHelper
type ByteHelper =  class end

The ByteHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ByteHelper | Initializes a new instance of the ByteHelper class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | FormatBytes | 格式化字节数字符串为K/M/G
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


ByteHelper Constructor

ByteHelper Constructor
Initializes a new instance of the ByteHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ByteHelper()
Public Sub New
public:
ByteHelper()
new : unit -> ByteHelper
See Also

Reference

ByteHelper Class


ByteHelper Methods

ByteHelper Methods

The ByteHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | FormatBytes | 格式化字节数字符串为K/M/G
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ByteHelper Class


ByteHelper.FormatBytes Method

ByteHelperFormatBytes Method
格式化字节数字符串为K/M/G

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string FormatBytes(
    int bytes
)
Public Shared Function FormatBytes (
    bytes As Integer
) As String
public:
static String^ FormatBytes(
    int bytes
)
static member FormatBytes :
        bytes : int -> string

Parameters

bytes
Type: SystemInt32
字节数

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ByteHelper.FormatBytes(System.Int32)"]

See Also

Reference

ByteHelper Class


CacheValue(T) Class

CacheValueT Class
实例Cache类型
Inheritance Hierarchy
SystemObject
AdfCacheValueT

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract class CacheValue<T>
where T : class

Public MustInherit Class CacheValue(Of T As Class)
generic<typename T>
where T : ref class
public ref class CacheValue abstract
[<AbstractClassAttribute>]
type CacheValue<'T when 'T : not struct> =  class end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Adf.CacheValue`1"]

The CacheValueT type exposes the following members.

Constructors
 | Name | Description
Protected method | CacheValueT | 实始化实例
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetValue | 获取值并指定是否验证过期
Protected method | Init | 初始化
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | OnInit | 触发初始化
Public method | Remove | 移除实例值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expire | 获取或设置失效时间
Public property | InitTime | 获取数据初始时间
Public property | IsNull | 获取结果是否为Null
Public property | Value | 获取值
Top
See Also

Reference


CacheValue(T) Constructor

CacheValueT Constructor
实始化实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected CacheValue()
Protected Sub New
protected:
CacheValue()
new : unit -> CacheValue
See Also

Reference

CacheValueT Class


CacheValue(T) Methods

CacheValueT Methods

The CacheValueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetValue | 获取值并指定是否验证过期
Protected method | Init | 初始化
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | OnInit | 触发初始化
Public method | Remove | 移除实例值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

CacheValueT Class


CacheValue(T).GetValue Method

CacheValueTGetValue Method
获取值并指定是否验证过期

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T GetValue(
    bool isValidExpire
)
Public Function GetValue (
    isValidExpire As Boolean
) As T
public:
T GetValue(
    bool isValidExpire
)
member GetValue :
        isValidExpire : bool -> 'T

Parameters

isValidExpire
Type: SystemBoolean
是否验证过期

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.CacheValue`1.GetValue(System.Boolean)"]

See Also

Reference

CacheValueT Class


CacheValue(T).Init Method

CacheValueTInit Method
初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected abstract T Init()
Protected MustOverride Function Init As T
protected:
virtual T Init() abstract
abstract Init : unit -> 'T

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.CacheValue`1.Init"]

See Also

Reference

CacheValueT Class


CacheValue(T).OnInit Method

CacheValueTOnInit Method
触发初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void OnInit()
Public Sub OnInit
public:
void OnInit()
member OnInit : unit -> unit
See Also

Reference

CacheValueT Class


CacheValue(T).Remove Method

CacheValueTRemove Method
移除实例值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Remove()
Public Overridable Sub Remove
public:
virtual void Remove()
abstract Remove : unit -> unit
override Remove : unit -> unit
See Also

Reference

CacheValueT Class


CacheValue(T) Properties

CacheValueT Properties

The CacheValueT generic type exposes the following members.

Properties
 | Name | Description
Public property | Expire | 获取或设置失效时间
Public property | InitTime | 获取数据初始时间
Public property | IsNull | 获取结果是否为Null
Public property | Value | 获取值
Top
See Also

Reference

CacheValueT Class


CacheValue(T).Expire Property

CacheValueTExpire Property
获取或设置失效时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DateTime Expire { get; set; }
Public Property Expire As DateTime
    Get
    Set
public:
property DateTime Expire {
    DateTime get ();
    void set (DateTime value);
}
member Expire : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

CacheValueT Class


CacheValue(T).InitTime Property

CacheValueTInitTime Property
获取数据初始时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DateTime InitTime { get; }
Public ReadOnly Property InitTime As DateTime
    Get
public:
property DateTime InitTime {
    DateTime get ();
}
member InitTime : DateTime with get

Property Value

Type: DateTime
See Also

Reference

CacheValueT Class


CacheValue(T).IsNull Property

CacheValueTIsNull Property
获取结果是否为Null

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool IsNull { get; }
Public ReadOnly Property IsNull As Boolean
    Get
public:
property bool IsNull {
    bool get ();
}
member IsNull : bool with get

Property Value

Type: Boolean
See Also

Reference

CacheValueT Class


CacheValue(T).Value Property

CacheValueTValue Property
获取值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T Value { get; }
Public ReadOnly Property Value As T
    Get
public:
property T Value {
    T get ();
}
member Value : 'T with get

Property Value

Type: T
See Also

Reference

CacheValueT Class


CFunc(T, TResult) Delegate

CFuncT, TResult Delegate
带返回值的调用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate TResult CFunc<in T, out TResult>(
    T arg
)

Public Delegate Function CFunc(Of In T, Out TResult) (
    arg As T
) As TResult
generic<typename T, typename TResult>
public delegate TResult CFunc(
    T arg
)
type CFunc =
    delegate of
        arg : 'T -> 'TResult

Parameters

arg
Type: T

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Adf.CFunc`2"]

TResult

[Missing <typeparam name="TResult"/> documentation for "T:Adf.CFunc`2"]

Return Value

Type: TResult
See Also

Reference


CFunc(T1, T2, TResult) Delegate

CFuncT1, T2, TResult Delegate
带返回值的调用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate TResult CFunc<in T1, in T2, out TResult>(
    T1 t1,
    T2 t2
)

Public Delegate Function CFunc(Of In T1, In T2, Out TResult) (
    t1 As T1,
    t2 As T2
) As TResult
generic<typename T1, typename T2, typename TResult>
public delegate TResult CFunc(
    T1 t1,
    T2 t2
)
type CFunc =
    delegate of
        t1 : 'T1 *
        t2 : 'T2 -> 'TResult

Parameters

t1
Type: T1
t2
Type: T2

Type Parameters

T1

[Missing <typeparam name="T1"/> documentation for "T:Adf.CFunc`3"]

T2

[Missing <typeparam name="T2"/> documentation for "T:Adf.CFunc`3"]

TResult

[Missing <typeparam name="TResult"/> documentation for "T:Adf.CFunc`3"]

Return Value

Type: TResult
See Also

Reference


CFunc(T1, T2, T3, TResult) Delegate

CFuncT1, T2, T3, TResult Delegate
带返回值的调用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate TResult CFunc<in T1, in T2, in T3, out TResult>(
    T1 t1,
    T2 t2,
    T3 t3
)

Public Delegate Function CFunc(Of In T1, In T2, In T3, Out TResult) (
    t1 As T1,
    t2 As T2,
    t3 As T3
) As TResult
generic<typename T1, typename T2, typename T3, typename TResult>
public delegate TResult CFunc(
    T1 t1,
    T2 t2,
    T3 t3
)
type CFunc =
    delegate of
        t1 : 'T1 *
        t2 : 'T2 *
        t3 : 'T3 -> 'TResult

Parameters

t1
Type: T1
t2
Type: T2
t3
Type: T3

Type Parameters

T1

[Missing <typeparam name="T1"/> documentation for "T:Adf.CFunc`4"]

T2

[Missing <typeparam name="T2"/> documentation for "T:Adf.CFunc`4"]

T3

[Missing <typeparam name="T3"/> documentation for "T:Adf.CFunc`4"]

TResult

[Missing <typeparam name="TResult"/> documentation for "T:Adf.CFunc`4"]

Return Value

Type: TResult
See Also

Reference


CollectionGeneric(T) Class

CollectionGenericT Class
通用泛型集合基类
Inheritance Hierarchy
SystemObject
System.CollectionsCollectionBase
AdfCollectionGenericT

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract class CollectionGeneric<T> : CollectionBase

Public MustInherit Class CollectionGeneric(Of T)
    Inherits CollectionBase
generic<typename T>
public ref class CollectionGeneric abstract : public CollectionBase
[<AbstractClassAttribute>]
type CollectionGeneric<'T> =
    class
        inherit CollectionBase
    end

Type Parameters

T
元素类型

The CollectionGenericT type exposes the following members.

Constructors
 | Name | Description
Protected method | CollectionGenericT | Initializes a new instance of the CollectionGenericT class
Top
Methods
 | Name | Description
Public method | Add | 添加一个新元素
Public method | AddRange | 添加一组新元素
Public method | Clear | 从 CollectionBase 实例移除所有对象。不能重写此方法。 (Inherited from CollectionBase.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetEnumerator | 返回循环访问 CollectionBase 实例的枚举数。 (Inherited from CollectionBase.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnClear | 当清除 CollectionBase 实例的内容时执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnClearComplete | 在清除 CollectionBase 实例的内容之后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnInsert | 在向 CollectionBase 实例中插入新元素之前执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnInsertComplete | 在向 CollectionBase 实例中插入新元素之后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnRemove | 当从 CollectionBase 实例移除元素时执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | 在从 CollectionBase 实例中移除元素之后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnSet | 当在 CollectionBase 实例中设置值之前执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnSetComplete | 当在 CollectionBase 实例中设置值后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnValidate | 当验证值时执行其他自定义进程。 (Inherited from CollectionBase.)
Public method | Remove(Int32) | 移除指定索引处的元素
Public method | Remove(T) | 移除指定的元素
Public method | RemoveAt | 移除 CollectionBase 实例的指定索引处的元素。此方法不可重写。 (Inherited from CollectionBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Capacity | 获取或设置 CollectionBase 可包含的元素数。 (Inherited from CollectionBase.)
Public property | Count | 获取包含在 CollectionBase 实例中的元素数。不能重写此属性。 (Inherited from CollectionBase.)
Protected property | InnerList | 获取一个 ArrayList，它包含 CollectionBase 实例中元素的列表。 (Inherited from CollectionBase.)
Public property | Item | 获取指定索引处的元素
Protected property | List | 获取一个 IList，它包含 CollectionBase 实例中元素的列表。 (Inherited from CollectionBase.)
Top
See Also

Reference


CollectionGeneric(T) Constructor

CollectionGenericT Constructor
Initializes a new instance of the CollectionGenericT class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected CollectionGeneric()
Protected Sub New
protected:
CollectionGeneric()
new : unit -> CollectionGeneric
See Also

Reference

CollectionGenericT Class


CollectionGeneric(T) Methods

CollectionGenericT Methods

The CollectionGenericT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | 添加一个新元素
Public method | AddRange | 添加一组新元素
Public method | Clear | 从 CollectionBase 实例移除所有对象。不能重写此方法。 (Inherited from CollectionBase.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetEnumerator | 返回循环访问 CollectionBase 实例的枚举数。 (Inherited from CollectionBase.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnClear | 当清除 CollectionBase 实例的内容时执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnClearComplete | 在清除 CollectionBase 实例的内容之后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnInsert | 在向 CollectionBase 实例中插入新元素之前执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnInsertComplete | 在向 CollectionBase 实例中插入新元素之后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnRemove | 当从 CollectionBase 实例移除元素时执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnRemoveComplete | 在从 CollectionBase 实例中移除元素之后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnSet | 当在 CollectionBase 实例中设置值之前执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnSetComplete | 当在 CollectionBase 实例中设置值后执行其他自定义进程。 (Inherited from CollectionBase.)
Protected method | OnValidate | 当验证值时执行其他自定义进程。 (Inherited from CollectionBase.)
Public method | Remove(Int32) | 移除指定索引处的元素
Public method | Remove(T) | 移除指定的元素
Public method | RemoveAt | 移除 CollectionBase 实例的指定索引处的元素。此方法不可重写。 (Inherited from CollectionBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

CollectionGenericT Class


CollectionGeneric(T).Add Method

CollectionGenericTAdd Method
添加一个新元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Add(
    T item
)
Public Overridable Sub Add (
    item As T
)
public:
virtual void Add(
    T item
)
abstract Add :
        item : 'T -> unit
override Add :
        item : 'T -> unit

Parameters

item
Type: T
元素
See Also

Reference

CollectionGenericT Class


CollectionGeneric(T).AddRange Method

CollectionGenericTAddRange Method
添加一组新元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void AddRange(
    T[] arritem
)
Public Overridable Sub AddRange (
    arritem As T()
)
public:
virtual void AddRange(
    array<T>^ arritem
)
abstract AddRange :
        arritem : 'T[] -> unit
override AddRange :
        arritem : 'T[] -> unit

Parameters

arritem
Type: T
元素组
See Also

Reference

CollectionGenericT Class


CollectionGeneric(T).Remove Method

CollectionGenericTRemove Method
Overload List
 | Name | Description
Public method | Remove(Int32) | 移除指定索引处的元素
Public method | Remove(T) | 移除指定的元素
Top
See Also

Reference

CollectionGenericT Class


CollectionGeneric(T).Remove Method (Int32)

CollectionGenericTRemove Method (Int32)
移除指定索引处的元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Remove(
    int index
)
Public Overridable Sub Remove (
    index As Integer
)
public:
virtual void Remove(
    int index
)
abstract Remove :
        index : int -> unit
override Remove :
        index : int -> unit

Parameters

index
Type: SystemInt32
移除指定索引处的元素
See Also

Reference

CollectionGenericT Class
Remove Overload


CollectionGeneric(T).Remove Method (T)

CollectionGenericTRemove Method (T)
移除指定的元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Remove(
    T item
)
Public Overridable Sub Remove (
    item As T
)
public:
virtual void Remove(
    T item
)
abstract Remove :
        item : 'T -> unit
override Remove :
        item : 'T -> unit

Parameters

item
Type: T
元素
See Also

Reference

CollectionGenericT Class
Remove Overload


CollectionGeneric(T) Properties

CollectionGenericT Properties

The CollectionGenericT generic type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | 获取或设置 CollectionBase 可包含的元素数。 (Inherited from CollectionBase.)
Public property | Count | 获取包含在 CollectionBase 实例中的元素数。不能重写此属性。 (Inherited from CollectionBase.)
Protected property | InnerList | 获取一个 ArrayList，它包含 CollectionBase 实例中元素的列表。 (Inherited from CollectionBase.)
Public property | Item | 获取指定索引处的元素
Protected property | List | 获取一个 IList，它包含 CollectionBase 实例中元素的列表。 (Inherited from CollectionBase.)
Top
See Also

Reference

CollectionGenericT Class


CollectionGeneric(T).Item Property

CollectionGenericTItem Property
获取指定索引处的元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As T
    Get
public:
property T default[int index] {
    T get (int index);
}
member Item : 'T with get

Parameters

index
Type: SystemInt32
索引

Property Value

Type: T
See Also

Reference

CollectionGenericT Class


CompressHelper Class

CompressHelper Class
压缩助手
Inheritance Hierarchy
SystemObject
AdfCompressHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class CompressHelper
Public NotInheritable Class CompressHelper
public ref class CompressHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CompressHelper =  class end

The CompressHelper type exposes the following members.

Methods
Name | Description
Compress | 压缩
Decompress | 解压
Top
See Also

Reference


CompressHelper Methods

CompressHelper Methods

The CompressHelper type exposes the following members.

Methods
Name | Description
Compress | 压缩
Decompress | 解压
Top
See Also

Reference

CompressHelper Class


CompressHelper.Compress Method

CompressHelperCompress Method
压缩

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] Compress(
    byte[] buffer
)
Public Shared Function Compress (
    buffer As Byte()
) As Byte()
public:
static array<unsigned char>^ Compress(
    array<unsigned char>^ buffer
)
static member Compress :
        buffer : byte[] -> byte[]

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:Adf.CompressHelper.Compress(System.Byte[])"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.CompressHelper.Compress(System.Byte[])"]

See Also

Reference

CompressHelper Class


CompressHelper.Decompress Method

CompressHelperDecompress Method
解压

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] Decompress(
    byte[] gzBuffer
)
Public Shared Function Decompress (
    gzBuffer As Byte()
) As Byte()
public:
static array<unsigned char>^ Decompress(
    array<unsigned char>^ gzBuffer
)
static member Decompress :
        gzBuffer : byte[] -> byte[]

Parameters

gzBuffer
Type: SystemByte

[Missing <param name="gzBuffer"/> documentation for "M:Adf.CompressHelper.Decompress(System.Byte[])"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.CompressHelper.Decompress(System.Byte[])"]

See Also

Reference

CompressHelper Class


ConfigHelper Class

ConfigHelper Class
Setting Helper
Inheritance Hierarchy
SystemObject
AdfConfigHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class ConfigHelper
Public NotInheritable Class ConfigHelper
public ref class ConfigHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConfigHelper =  class end

The ConfigHelper type exposes the following members.

Methods
Name | Description
GetSetting | 获取一项配置，若未配置则返回默认值
GetSettingAsBoolean | 获取一项配置，若未配置则返回默认值
GetSettingAsInt | 获取一项配置，若未配置则返回默认值
GetSettingAsInt64 | 获取一项配置，若未配置则返回默认值
Top
Properties
Name | Description
AppName | 应用名称,配置：AppName
Top
See Also

Reference


ConfigHelper Methods

ConfigHelper Methods

The ConfigHelper type exposes the following members.

Methods
Name | Description
GetSetting | 获取一项配置，若未配置则返回默认值
GetSettingAsBoolean | 获取一项配置，若未配置则返回默认值
GetSettingAsInt | 获取一项配置，若未配置则返回默认值
GetSettingAsInt64 | 获取一项配置，若未配置则返回默认值
Top
See Also

Reference

ConfigHelper Class


ConfigHelper.GetSetting Method

ConfigHelperGetSetting Method
获取一项配置，若未配置则返回默认值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string GetSetting(
    string key,
    string defaultValue = ""
)
Public Shared Function GetSetting (
    key As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ GetSetting(
    String^ key,
    String^ defaultValue = L""
)
static member GetSetting :
        key : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ConfigHelper.GetSetting(System.String,System.String)"]

defaultValue (Optional)
Type: SystemString

[Missing <param name="defaultValue"/> documentation for "M:Adf.ConfigHelper.GetSetting(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConfigHelper.GetSetting(System.String,System.String)"]

See Also

Reference

ConfigHelper Class


ConfigHelper.GetSettingAsBoolean Method

ConfigHelperGetSettingAsBoolean Method
获取一项配置，若未配置则返回默认值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool GetSettingAsBoolean(
    string key,
    bool defaultValue = false
)
Public Shared Function GetSettingAsBoolean (
    key As String,
    Optional defaultValue As Boolean = false
) As Boolean
public:
static bool GetSettingAsBoolean(
    String^ key,
    bool defaultValue = false
)
static member GetSettingAsBoolean :
        key : string *
        ?defaultValue : bool
(* Defaults:
        let _defaultValue = defaultArg defaultValue false
*)
-> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ConfigHelper.GetSettingAsBoolean(System.String,System.Boolean)"]

defaultValue (Optional)
Type: SystemBoolean

[Missing <param name="defaultValue"/> documentation for "M:Adf.ConfigHelper.GetSettingAsBoolean(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ConfigHelper.GetSettingAsBoolean(System.String,System.Boolean)"]

See Also

Reference

ConfigHelper Class


ConfigHelper.GetSettingAsInt Method

ConfigHelperGetSettingAsInt Method
获取一项配置，若未配置则返回默认值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int GetSettingAsInt(
    string key,
    int defaultValue = 0
)
Public Shared Function GetSettingAsInt (
    key As String,
    Optional defaultValue As Integer = 0
) As Integer
public:
static int GetSettingAsInt(
    String^ key,
    int defaultValue = 0
)
static member GetSettingAsInt :
        key : string *
        ?defaultValue : int
(* Defaults:
        let _defaultValue = defaultArg defaultValue 0
*)
-> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ConfigHelper.GetSettingAsInt(System.String,System.Int32)"]

defaultValue (Optional)
Type: SystemInt32

[Missing <param name="defaultValue"/> documentation for "M:Adf.ConfigHelper.GetSettingAsInt(System.String,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.ConfigHelper.GetSettingAsInt(System.String,System.Int32)"]

See Also

Reference

ConfigHelper Class


ConfigHelper.GetSettingAsInt64 Method

ConfigHelperGetSettingAsInt64 Method
获取一项配置，若未配置则返回默认值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static long GetSettingAsInt64(
    string key,
    long defaultValue = 0
)
Public Shared Function GetSettingAsInt64 (
    key As String,
    Optional defaultValue As Long = 0
) As Long
public:
static long long GetSettingAsInt64(
    String^ key,
    long long defaultValue = 0
)
static member GetSettingAsInt64 :
        key : string *
        ?defaultValue : int64
(* Defaults:
        let _defaultValue = defaultArg defaultValue 0
*)
-> int64

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ConfigHelper.GetSettingAsInt64(System.String,System.Int64)"]

defaultValue (Optional)
Type: SystemInt64

[Missing <param name="defaultValue"/> documentation for "M:Adf.ConfigHelper.GetSettingAsInt64(System.String,System.Int64)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:Adf.ConfigHelper.GetSettingAsInt64(System.String,System.Int64)"]

See Also

Reference

ConfigHelper Class


ConfigHelper Properties

ConfigHelper Properties

The ConfigHelper type exposes the following members.

Properties
Name | Description
AppName | 应用名称,配置：AppName
Top
See Also

Reference

ConfigHelper Class


ConfigHelper.AppName Property

ConfigHelperAppName Property
应用名称,配置：AppName

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string AppName { get; }
Public Shared ReadOnly Property AppName As String
    Get
public:
static property String^ AppName {
    String^ get ();
}
static member AppName : string with get

Property Value

Type: String
See Also

Reference

ConfigHelper Class


ConsistentHashing(T) Class

ConsistentHashingT Class
Consistent Hashing 一致性哈希
Inheritance Hierarchy
SystemObject
AdfConsistentHashingT

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ConsistentHashing<T>

Public Class ConsistentHashing(Of T)
generic<typename T>
public ref class ConsistentHashing
type ConsistentHashing<'T> =  class end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Adf.ConsistentHashing`1"]

The ConsistentHashingT type exposes the following members.

Constructors
 | Name | Description
Public method | ConsistentHashingT | 初始化新实例
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetPrimary | 获取一节点
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Hash | Hash
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NodeCount | 含虚拟节点的总节点数
Public property | Nodes | 实际节点
Top
See Also

Reference


ConsistentHashing(T) Constructor

ConsistentHashingT Constructor
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ConsistentHashing(
    T[] nodes,
    int vnodecount = 100
)
Public Sub New (
    nodes As T(),
    Optional vnodecount As Integer = 100
)
public:
ConsistentHashing(
    array<T>^ nodes,
    int vnodecount = 100
)
new :
        nodes : 'T[] *
        ?vnodecount : int
(* Defaults:
        let _vnodecount = defaultArg vnodecount 100
*)
-> ConsistentHashing

Parameters

nodes
Type: T
实际节点
vnodecount (Optional)
Type: SystemInt32
虚拟节点数,建议不低于 100
See Also

Reference

ConsistentHashingT Class


ConsistentHashing(T) Methods

ConsistentHashingT Methods

The ConsistentHashingT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetPrimary | 获取一节点
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Hash | Hash
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ConsistentHashingT Class


ConsistentHashing(T).GetPrimary Method

ConsistentHashingTGetPrimary Method
获取一节点

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T GetPrimary(
    string key
)
Public Function GetPrimary (
    key As String
) As T
public:
T GetPrimary(
    String^ key
)
member GetPrimary :
        key : string -> 'T

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ConsistentHashing`1.GetPrimary(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.ConsistentHashing`1.GetPrimary(System.String)"]

See Also

Reference

ConsistentHashingT Class


ConsistentHashing(T).Hash Method

ConsistentHashingTHash Method
Hash

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual uint Hash(
    string key
)
Protected Overridable Function Hash (
    key As String
) As UInteger
protected:
virtual unsigned int Hash(
    String^ key
)
abstract Hash :
        key : string -> uint32
override Hash :
        key : string -> uint32

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ConsistentHashing`1.Hash(System.String)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:Adf.ConsistentHashing`1.Hash(System.String)"]

See Also

Reference

ConsistentHashingT Class


ConsistentHashing(T) Properties

ConsistentHashingT Properties

The ConsistentHashingT generic type exposes the following members.

Properties
 | Name | Description
Public property | NodeCount | 含虚拟节点的总节点数
Public property | Nodes | 实际节点
Top
See Also

Reference

ConsistentHashingT Class


ConsistentHashing(T).NodeCount Property

ConsistentHashingTNodeCount Property
含虚拟节点的总节点数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int NodeCount { get; }
Public ReadOnly Property NodeCount As Integer
    Get
public:
property int NodeCount {
    int get ();
}
member NodeCount : int with get

Property Value

Type: Int32
See Also

Reference

ConsistentHashingT Class


ConsistentHashing(T).Nodes Property

ConsistentHashingTNodes Property
实际节点

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T[] Nodes { get; }
Public ReadOnly Property Nodes As T()
    Get
public:
property array<T>^ Nodes {
    array<T>^ get ();
}
member Nodes : 'T[] with get

Property Value

Type: T
See Also

Reference

ConsistentHashingT Class


ConvertHelper Class

ConvertHelper Class
convert helper, the convert is safe
Inheritance Hierarchy
SystemObject
AdfConvertHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class ConvertHelper
Public NotInheritable Class ConvertHelper
public ref class ConvertHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ConvertHelper =  class end

The ConvertHelper type exposes the following members.

Methods
Name | Description
ArrayCompartT | 数组转换为逗号单条限4000长度分隔字符串
ArrayCompartToStringT(IEnumerableT, Int32) | 数组转换为逗号限定长度分隔字符串
ArrayCompartToStringT(IEnumerableT, Char, Int32) | 数组转换为限定长度分隔字符串
ArrayToStringT(IEnumerableT, String) | 可列表对象转换为以指定字符分隔的字符串
ArrayToStringT(IEnumerableT, String, ConverterT, String) | 列表对象以指定方式转换为按指定分隔符分隔的字符串
ArrayToStringT(IEnumerable, String, ConverterT, String) | 列表对象以指定方式转换为按指定分隔符分隔的字符串
BinToHex | 将字符数组转换成16进制字符串 bin2hex
HexToBin | 将16进制字符串转换成字符数组 hex2bin
ListCompartToStringTFirst, TSecond(ListKeyValuePairTFirst, TSecond) | 将参数列表转换为单项院4000字符串数组
ListCompartToStringTFirst, TSecond(ListKeyValuePairTFirst, TSecond, Int32) | 将参数列表转换为字符串数组
StringToArray(String, Char) | string to array
StringToArrayT(String, ConverterString, T, Char) | string to array
ToBool | 将类型装换为bool类型
ToByte | 将类型转换为byte类型
ToDateTime | 将类型装换为DateTime类型
ToDecimal | 将类型装换为decimal类型
ToDouble | 将类型装换为double类型
ToEnumT | 转换为枚举
ToFloat | 将类型装换为float类型
ToGuid | 将类型装换为Guid类型
ToInt | 将类型装换为int类型
ToInt64 | 将类型装换为int64类型
ToString | 安全将类型装换为字符串
Top
See Also

Reference


ConvertHelper Methods

ConvertHelper Methods

The ConvertHelper type exposes the following members.

Methods
Name | Description
ArrayCompartT | 数组转换为逗号单条限4000长度分隔字符串
ArrayCompartToStringT(IEnumerableT, Int32) | 数组转换为逗号限定长度分隔字符串
ArrayCompartToStringT(IEnumerableT, Char, Int32) | 数组转换为限定长度分隔字符串
ArrayToStringT(IEnumerableT, String) | 可列表对象转换为以指定字符分隔的字符串
ArrayToStringT(IEnumerableT, String, ConverterT, String) | 列表对象以指定方式转换为按指定分隔符分隔的字符串
ArrayToStringT(IEnumerable, String, ConverterT, String) | 列表对象以指定方式转换为按指定分隔符分隔的字符串
BinToHex | 将字符数组转换成16进制字符串 bin2hex
HexToBin | 将16进制字符串转换成字符数组 hex2bin
ListCompartToStringTFirst, TSecond(ListKeyValuePairTFirst, TSecond) | 将参数列表转换为单项院4000字符串数组
ListCompartToStringTFirst, TSecond(ListKeyValuePairTFirst, TSecond, Int32) | 将参数列表转换为字符串数组
StringToArray(String, Char) | string to array
StringToArrayT(String, ConverterString, T, Char) | string to array
ToBool | 将类型装换为bool类型
ToByte | 将类型转换为byte类型
ToDateTime | 将类型装换为DateTime类型
ToDecimal | 将类型装换为decimal类型
ToDouble | 将类型装换为double类型
ToEnumT | 转换为枚举
ToFloat | 将类型装换为float类型
ToGuid | 将类型装换为Guid类型
ToInt | 将类型装换为int类型
ToInt64 | 将类型装换为int64类型
ToString | 安全将类型装换为字符串
Top
See Also

Reference

ConvertHelper Class


ConvertHelper.ArrayCompart(T) Method

ConvertHelperArrayCompartT Method
数组转换为逗号单条限4000长度分隔字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] ArrayCompart<T>(
    IEnumerable<T> inputs
)

Public Shared Function ArrayCompart(Of T) (
    inputs As IEnumerable(Of T)
) As String()
public:
generic<typename T>
static array<String^>^ ArrayCompart(
    IEnumerable<T>^ inputs
)
static member ArrayCompart :
        inputs : IEnumerable<'T> -> string[]

Parameters

inputs
Type: System.Collections.GenericIEnumerable T

[Missing <param name="inputs"/> documentation for "M:Adf.ConvertHelper.ArrayCompart``1(System.Collections.Generic.IEnumerable{``0})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.ArrayCompart``1(System.Collections.Generic.IEnumerable{``0})"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ArrayCompart``1(System.Collections.Generic.IEnumerable{``0})"]

See Also

Reference

ConvertHelper Class


ConvertHelper.ArrayCompartToString Method

ConvertHelperArrayCompartToString Method
Overload List
Name | Description
ArrayCompartToStringT(IEnumerableT, Int32) | 数组转换为逗号限定长度分隔字符串
ArrayCompartToStringT(IEnumerableT, Char, Int32) | 数组转换为限定长度分隔字符串
Top
See Also

Reference

ConvertHelper Class


ConvertHelper.ArrayCompartToString(T) Method (IEnumerable(T), Int32)

ConvertHelperArrayCompartToStringT Method (IEnumerableT, Int32)
数组转换为逗号限定长度分隔字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] ArrayCompartToString<T>(
    IEnumerable<T> inputs,
    int itemMaxLength
)

Public Shared Function ArrayCompartToString(Of T) (
    inputs As IEnumerable(Of T),
    itemMaxLength As Integer
) As String()
public:
generic<typename T>
static array<String^>^ ArrayCompartToString(
    IEnumerable<T>^ inputs,
    int itemMaxLength
)
static member ArrayCompartToString :
        inputs : IEnumerable<'T> *
        itemMaxLength : int -> string[]

Parameters

inputs
Type: System.Collections.GenericIEnumerable T

[Missing <param name="inputs"/> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Int32)"]

itemMaxLength
Type: SystemInt32

[Missing <param name="itemMaxLength"/> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Int32)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Int32)"]

See Also

Reference

ConvertHelper Class
ArrayCompartToString Overload


ConvertHelper.ArrayCompartToString(T) Method (IEnumerable(T), Char, Int32)

ConvertHelperArrayCompartToStringT Method (IEnumerableT, Char, Int32)
数组转换为限定长度分隔字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] ArrayCompartToString<T>(
    IEnumerable<T> inputs,
    char compart,
    int itemMaxLength
)

Public Shared Function ArrayCompartToString(Of T) (
    inputs As IEnumerable(Of T),
    compart As Char,
    itemMaxLength As Integer
) As String()
public:
generic<typename T>
static array<String^>^ ArrayCompartToString(
    IEnumerable<T>^ inputs,
    wchar_t compart,
    int itemMaxLength
)
static member ArrayCompartToString :
        inputs : IEnumerable<'T> *
        compart : char *
        itemMaxLength : int -> string[]

Parameters

inputs
Type: System.Collections.GenericIEnumerable T

[Missing <param name="inputs"/> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Char,System.Int32)"]

compart
Type: SystemChar

[Missing <param name="compart"/> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Char,System.Int32)"]

itemMaxLength
Type: SystemInt32

[Missing <param name="itemMaxLength"/> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Char,System.Int32)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Char,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ArrayCompartToString``1(System.Collections.Generic.IEnumerable{``0},System.Char,System.Int32)"]

See Also

Reference

ConvertHelper Class
ArrayCompartToString Overload


ConvertHelper.ArrayToString Method

ConvertHelperArrayToString Method
Overload List
Name | Description
ArrayToStringT(IEnumerableT, String) | 可列表对象转换为以指定字符分隔的字符串
ArrayToStringT(IEnumerableT, String, ConverterT, String) | 列表对象以指定方式转换为按指定分隔符分隔的字符串
ArrayToStringT(IEnumerable, String, ConverterT, String) | 列表对象以指定方式转换为按指定分隔符分隔的字符串
Top
See Also

Reference

ConvertHelper Class


ConvertHelper.ArrayToString(T) Method (IEnumerable(T), String)

ConvertHelperArrayToStringT Method (IEnumerableT, String)
可列表对象转换为以指定字符分隔的字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ArrayToString<T>(
    IEnumerable<T> inputs,
    string separator
)

Public Shared Function ArrayToString(Of T) (
    inputs As IEnumerable(Of T),
    separator As String
) As String
public:
generic<typename T>
static String^ ArrayToString(
    IEnumerable<T>^ inputs,
    String^ separator
)
static member ArrayToString :
        inputs : IEnumerable<'T> *
        separator : string -> string

Parameters

inputs
Type: System.Collections.GenericIEnumerable T

[Missing <param name="inputs"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String)"]

separator
Type: SystemString

[Missing <param name="separator"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String)"]

See Also

Reference

ConvertHelper Class
ArrayToString Overload


ConvertHelper.ArrayToString(T) Method (IEnumerable(T), String, Converter(T, String))

ConvertHelperArrayToStringT Method (IEnumerableT, String, ConverterT, String)
列表对象以指定方式转换为按指定分隔符分隔的字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ArrayToString<T>(
    IEnumerable<T> inputs,
    string separator,
    Converter<T, string> converter
)

Public Shared Function ArrayToString(Of T) (
    inputs As IEnumerable(Of T),
    separator As String,
    converter As Converter(Of T, String)
) As String
public:
generic<typename T>
static String^ ArrayToString(
    IEnumerable<T>^ inputs,
    String^ separator,
    Converter<T, String^>^ converter
)
static member ArrayToString :
        inputs : IEnumerable<'T> *
        separator : string *
        converter : Converter<'T, string> -> string

Parameters

inputs
Type: System.Collections.GenericIEnumerable T

[Missing <param name="inputs"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Converter{``0,System.String})"]

separator
Type: SystemString

[Missing <param name="separator"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Converter{``0,System.String})"]

converter
Type: SystemConverter T, String

[Missing <param name="converter"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Converter{``0,System.String})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Converter{``0,System.String})"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.Generic.IEnumerable{``0},System.String,System.Converter{``0,System.String})"]

See Also

Reference

ConvertHelper Class
ArrayToString Overload


ConvertHelper.ArrayToString(T) Method (IEnumerable, String, Converter(T, String))

ConvertHelperArrayToStringT Method (IEnumerable, String, ConverterT, String)
列表对象以指定方式转换为按指定分隔符分隔的字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ArrayToString<T>(
    IEnumerable inputs,
    string separator,
    Converter<T, string> converter
)

Public Shared Function ArrayToString(Of T) (
    inputs As IEnumerable,
    separator As String,
    converter As Converter(Of T, String)
) As String
public:
generic<typename T>
static String^ ArrayToString(
    IEnumerable^ inputs,
    String^ separator,
    Converter<T, String^>^ converter
)
static member ArrayToString :
        inputs : IEnumerable *
        separator : string *
        converter : Converter<'T, string> -> string

Parameters

inputs
Type: System.CollectionsIEnumerable

[Missing <param name="inputs"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.IEnumerable,System.String,System.Converter{``0,System.String})"]

separator
Type: SystemString

[Missing <param name="separator"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.IEnumerable,System.String,System.Converter{``0,System.String})"]

converter
Type: SystemConverter T, String

[Missing <param name="converter"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.IEnumerable,System.String,System.Converter{``0,System.String})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.IEnumerable,System.String,System.Converter{``0,System.String})"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ArrayToString``1(System.Collections.IEnumerable,System.String,System.Converter{``0,System.String})"]

See Also

Reference

ConvertHelper Class
ArrayToString Overload


ConvertHelper.BinToHex Method

ConvertHelperBinToHex Method
将字符数组转换成16进制字符串 bin2hex

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string BinToHex(
    byte[] bytes
)
Public Shared Function BinToHex (
    bytes As Byte()
) As String
public:
static String^ BinToHex(
    array<unsigned char>^ bytes
)
static member BinToHex :
        bytes : byte[] -> string

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:Adf.ConvertHelper.BinToHex(System.Byte[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.BinToHex(System.Byte[])"]

See Also

Reference

ConvertHelper Class


ConvertHelper.HexToBin Method

ConvertHelperHexToBin Method
将16进制字符串转换成字符数组 hex2bin

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] HexToBin(
    string hexString
)
Public Shared Function HexToBin (
    hexString As String
) As Byte()
public:
static array<unsigned char>^ HexToBin(
    String^ hexString
)
static member HexToBin :
        hexString : string -> byte[]

Parameters

hexString
Type: SystemString

[Missing <param name="hexString"/> documentation for "M:Adf.ConvertHelper.HexToBin(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.ConvertHelper.HexToBin(System.String)"]

See Also

Reference

ConvertHelper Class


ConvertHelper.ListCompartToString Method

ConvertHelperListCompartToString Method
Overload List
Name | Description
ListCompartToStringTFirst, TSecond(ListKeyValuePairTFirst, TSecond) | 将参数列表转换为单项院4000字符串数组
ListCompartToStringTFirst, TSecond(ListKeyValuePairTFirst, TSecond, Int32) | 将参数列表转换为字符串数组
Top
See Also

Reference

ConvertHelper Class


ConvertHelper.ListCompartToString(TFirst, TSecond) Method (List(KeyValuePair(TFirst, TSecond)))

ConvertHelperListCompartToStringTFirst, TSecond Method (ListKeyValuePairTFirst, TSecond)
将参数列表转换为单项院4000字符串数组

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] ListCompartToString<TFirst, TSecond>(
    List<KeyValuePair<TFirst, TSecond>> list
)

Public Shared Function ListCompartToString(Of TFirst, TSecond) (
    list As List(Of KeyValuePair(Of TFirst, TSecond))
) As String()
public:
generic<typename TFirst, typename TSecond>
static array<String^>^ ListCompartToString(
    List<KeyValuePair<TFirst, TSecond>>^ list
)
static member ListCompartToString :
        list : List<KeyValuePair<'TFirst, 'TSecond>> -> string[]

Parameters

list
Type: System.Collections.GenericList KeyValuePair TFirst, TSecond
列表

Type Parameters

TFirst

[Missing <typeparam name="TFirst"/> documentation for "M:Adf.ConvertHelper.ListCompartToString``2(System.Collections.Generic.List{System.Collections.Generic.KeyValuePair{``0,``1}})"]

TSecond

[Missing <typeparam name="TSecond"/> documentation for "M:Adf.ConvertHelper.ListCompartToString``2(System.Collections.Generic.List{System.Collections.Generic.KeyValuePair{``0,``1}})"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ListCompartToString``2(System.Collections.Generic.List{System.Collections.Generic.KeyValuePair{``0,``1}})"]

See Also

Reference

ConvertHelper Class
ListCompartToString Overload


ConvertHelper.ListCompartToString(TFirst, TSecond) Method (List(KeyValuePair(TFirst, TSecond)), Int32)

ConvertHelperListCompartToStringTFirst, TSecond Method (ListKeyValuePairTFirst, TSecond, Int32)
将参数列表转换为字符串数组

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] ListCompartToString<TFirst, TSecond>(
    List<KeyValuePair<TFirst, TSecond>> list,
    int itemMaxLength
)

Public Shared Function ListCompartToString(Of TFirst, TSecond) (
    list As List(Of KeyValuePair(Of TFirst, TSecond)),
    itemMaxLength As Integer
) As String()
public:
generic<typename TFirst, typename TSecond>
static array<String^>^ ListCompartToString(
    List<KeyValuePair<TFirst, TSecond>>^ list,
    int itemMaxLength
)
static member ListCompartToString :
        list : List<KeyValuePair<'TFirst, 'TSecond>> *
        itemMaxLength : int -> string[]

Parameters

list
Type: System.Collections.GenericList KeyValuePair TFirst, TSecond
列表
itemMaxLength
Type: SystemInt32
列表串单项最大长度

Type Parameters

TFirst

[Missing <typeparam name="TFirst"/> documentation for "M:Adf.ConvertHelper.ListCompartToString``2(System.Collections.Generic.List{System.Collections.Generic.KeyValuePair{``0,``1}},System.Int32)"]

TSecond

[Missing <typeparam name="TSecond"/> documentation for "M:Adf.ConvertHelper.ListCompartToString``2(System.Collections.Generic.List{System.Collections.Generic.KeyValuePair{``0,``1}},System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ConvertHelper.ListCompartToString``2(System.Collections.Generic.List{System.Collections.Generic.KeyValuePair{``0,``1}},System.Int32)"]

See Also

Reference

ConvertHelper Class
ListCompartToString Overload


ConvertHelper.StringToArray Method

ConvertHelperStringToArray Method
Overload List
Name | Description
StringToArray(String, Char) | string to array
StringToArrayT(String, ConverterString, T, Char) | string to array
Top
See Also

Reference

ConvertHelper Class


ConvertHelper.StringToArray Method (String, Char)

ConvertHelperStringToArray Method (String, Char)
string to array

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static List<string> StringToArray(
    string ids,
    char separator = ','
)
Public Shared Function StringToArray (
    ids As String,
    Optional separator As Char = ","C
) As List(Of String)
public:
static List<String^>^ StringToArray(
    String^ ids,
    wchar_t separator = L','
)
static member StringToArray :
        ids : string *
        ?separator : char
(* Defaults:
        let _separator = defaultArg separator ','
*)
-> List<string>

Parameters

ids
Type: SystemString

[Missing <param name="ids"/> documentation for "M:Adf.ConvertHelper.StringToArray(System.String,System.Char)"]

separator (Optional)
Type: SystemChar

[Missing <param name="separator"/> documentation for "M:Adf.ConvertHelper.StringToArray(System.String,System.Char)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:Adf.ConvertHelper.StringToArray(System.String,System.Char)"]

See Also

Reference

ConvertHelper Class
StringToArray Overload


ConvertHelper.StringToArray(T) Method (String, Converter(String, T), Char)

ConvertHelperStringToArrayT Method (String, ConverterString, T, Char)
string to array

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static List<T> StringToArray<T>(
    string ids,
    Converter<string, T> convert,
    char separator = ','
)

Public Shared Function StringToArray(Of T) (
    ids As String,
    convert As Converter(Of String, T),
    Optional separator As Char = ","C
) As List(Of T)
public:
generic<typename T>
static List<T>^ StringToArray(
    String^ ids,
    Converter<String^, T>^ convert,
    wchar_t separator = L','
)
static member StringToArray :
        ids : string *
        convert : Converter<string, 'T> *
        ?separator : char
(* Defaults:
        let _separator = defaultArg separator ','
*)
-> List<'T>

Parameters

ids
Type: SystemString

[Missing <param name="ids"/> documentation for "M:Adf.ConvertHelper.StringToArray``1(System.String,System.Converter{System.String,``0},System.Char)"]

convert
Type: SystemConverter String, T

[Missing <param name="convert"/> documentation for "M:Adf.ConvertHelper.StringToArray``1(System.String,System.Converter{System.String,``0},System.Char)"]

separator (Optional)
Type: SystemChar

[Missing <param name="separator"/> documentation for "M:Adf.ConvertHelper.StringToArray``1(System.String,System.Converter{System.String,``0},System.Char)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.StringToArray``1(System.String,System.Converter{System.String,``0},System.Char)"]

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.ConvertHelper.StringToArray``1(System.String,System.Converter{System.String,``0},System.Char)"]

See Also

Reference

ConvertHelper Class
StringToArray Overload


ConvertHelper.ToBool Method

ConvertHelperToBool Method
将类型装换为bool类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool ToBool(
    Object obj,
    bool defaultValue = false
)
Public Shared Function ToBool (
    obj As Object,
    Optional defaultValue As Boolean = false
) As Boolean
public:
static bool ToBool(
    Object^ obj,
    bool defaultValue = false
)
static member ToBool :
        obj : Object *
        ?defaultValue : bool
(* Defaults:
        let _defaultValue = defaultArg defaultValue false
*)
-> bool

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemBoolean
默认值

Return Value

Type: Boolean
bool类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToByte Method

ConvertHelperToByte Method
将类型转换为byte类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte ToByte(
    Object obj,
    byte defaultValue = 0
)
Public Shared Function ToByte (
    obj As Object,
    Optional defaultValue As Byte = 0
) As Byte
public:
static unsigned char ToByte(
    Object^ obj,
    unsigned char defaultValue = 0
)
static member ToByte :
        obj : Object *
        ?defaultValue : byte
(* Defaults:
        let _defaultValue = defaultArg defaultValue 0
*)
-> byte

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemByte
默认值

Return Value

Type: Byte
byte类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToDateTime Method

ConvertHelperToDateTime Method
将类型装换为DateTime类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static DateTime ToDateTime(
    Object obj,
    DateTime defaultValue
)
Public Shared Function ToDateTime (
    obj As Object,
    defaultValue As DateTime
) As DateTime
public:
static DateTime ToDateTime(
    Object^ obj,
    DateTime defaultValue
)
static member ToDateTime :
        obj : Object *
        defaultValue : DateTime -> DateTime

Parameters

obj
Type: SystemObject
object类型
defaultValue
Type: SystemDateTime
默认值,若无默认值可设置为 MinValue

Return Value

Type: DateTime
DateTime类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToDecimal Method

ConvertHelperToDecimal Method
将类型装换为decimal类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static decimal ToDecimal(
    Object obj,
    [OptionalAttribute] decimal defaultValue
)
Public Shared Function ToDecimal (
    obj As Object,
    <OptionalAttribute> defaultValue As Decimal
) As Decimal
public:
static Decimal ToDecimal(
    Object^ obj,
    [OptionalAttribute] Decimal defaultValue
)
static member ToDecimal :
        obj : Object *
        [<OptionalAttribute>] defaultValue : decimal -> decimal

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemDecimal
默认值

Return Value

Type: Decimal
decimal类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToDouble Method

ConvertHelperToDouble Method
将类型装换为double类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static double ToDouble(
    Object obj,
    double defaultValue = 0
)
Public Shared Function ToDouble (
    obj As Object,
    Optional defaultValue As Double = 0
) As Double
public:
static double ToDouble(
    Object^ obj,
    double defaultValue = 0
)
static member ToDouble :
        obj : Object *
        ?defaultValue : float
(* Defaults:
        let _defaultValue = defaultArg defaultValue 0
*)
-> float

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemDouble
默认值

Return Value

Type: Double
double类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToEnum(T) Method

ConvertHelperToEnumT Method
转换为枚举

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static T ToEnum<T>(
    string enumName,
    T defaultValue,
    bool ignoreCase = true
)
where T : struct, new()

Public Shared Function ToEnum(Of T As {Structure, New}) (
    enumName As String,
    defaultValue As T,
    Optional ignoreCase As Boolean = true
) As T
public:
generic<typename T>
where T : value class, gcnew()
static T ToEnum(
    String^ enumName,
    T defaultValue,
    bool ignoreCase = true
)
static member ToEnum :
        enumName : string *
        defaultValue : 'T *
        ?ignoreCase : bool
(* Defaults:
        let _ignoreCase = defaultArg ignoreCase true
*)
-> 'T  when 'T : struct, new()

Parameters

enumName
Type: SystemString

[Missing <param name="enumName"/> documentation for "M:Adf.ConvertHelper.ToEnum``1(System.String,``0,System.Boolean)"]

defaultValue
Type: T

[Missing <param name="defaultValue"/> documentation for "M:Adf.ConvertHelper.ToEnum``1(System.String,``0,System.Boolean)"]

ignoreCase (Optional)
Type: SystemBoolean

[Missing <param name="ignoreCase"/> documentation for "M:Adf.ConvertHelper.ToEnum``1(System.String,``0,System.Boolean)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ConvertHelper.ToEnum``1(System.String,``0,System.Boolean)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.ConvertHelper.ToEnum``1(System.String,``0,System.Boolean)"]

See Also

Reference

ConvertHelper Class


ConvertHelper.ToFloat Method

ConvertHelperToFloat Method
将类型装换为float类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static float ToFloat(
    Object obj,
    float defaultValue = 0f
)
Public Shared Function ToFloat (
    obj As Object,
    Optional defaultValue As Single = 0F
) As Single
public:
static float ToFloat(
    Object^ obj,
    float defaultValue = 0f
)
static member ToFloat :
        obj : Object *
        ?defaultValue : float32
(* Defaults:
        let _defaultValue = defaultArg defaultValue 0f
*)
-> float32

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemSingle
默认值

Return Value

Type: Single
float类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToGuid Method

ConvertHelperToGuid Method
将类型装换为Guid类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Guid ToGuid(
    Object obj,
    Guid defaultValue
)
Public Shared Function ToGuid (
    obj As Object,
    defaultValue As Guid
) As Guid
public:
static Guid ToGuid(
    Object^ obj,
    Guid defaultValue
)
static member ToGuid :
        obj : Object *
        defaultValue : Guid -> Guid

Parameters

obj
Type: SystemObject
object类型
defaultValue
Type: SystemGuid
默认值,若无请输入 Empty

Return Value

Type: Guid
int类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToInt Method

ConvertHelperToInt Method
将类型装换为int类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int ToInt(
    Object obj,
    int defaultValue = 0
)
Public Shared Function ToInt (
    obj As Object,
    Optional defaultValue As Integer = 0
) As Integer
public:
static int ToInt(
    Object^ obj,
    int defaultValue = 0
)
static member ToInt :
        obj : Object *
        ?defaultValue : int
(* Defaults:
        let _defaultValue = defaultArg defaultValue 0
*)
-> int

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemInt32
默认值

Return Value

Type: Int32
int类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToInt64 Method

ConvertHelperToInt64 Method
将类型装换为int64类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static long ToInt64(
    Object obj,
    long defaultValue = 0
)
Public Shared Function ToInt64 (
    obj As Object,
    Optional defaultValue As Long = 0
) As Long
public:
static long long ToInt64(
    Object^ obj,
    long long defaultValue = 0
)
static member ToInt64 :
        obj : Object *
        ?defaultValue : int64
(* Defaults:
        let _defaultValue = defaultArg defaultValue 0
*)
-> int64

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemInt64
默认值

Return Value

Type: Int64
int类型
See Also

Reference

ConvertHelper Class


ConvertHelper.ToString Method

ConvertHelperToString Method
安全将类型装换为字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ToString(
    Object obj,
    string defaultValue = ""
)
Public Shared Function ToString (
    obj As Object,
    Optional defaultValue As String = ""
) As String
public:
static String^ ToString(
    Object^ obj,
    String^ defaultValue = L""
)
static member ToString :
        obj : Object *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

obj
Type: SystemObject
object类型
defaultValue (Optional)
Type: SystemString
默认值

Return Value

Type: String
int类型
See Also

Reference

ConvertHelper Class


CRCHelper Class

CRCHelper Class
CRC Helper
Inheritance Hierarchy
SystemObject
AdfCRCHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public sealed class CRCHelper
Public NotInheritable Class CRCHelper
public ref class CRCHelper sealed
[<SealedAttribute>]
type CRCHelper =  class end

The CRCHelper type exposes the following members.

Constructors
 | Name | Description
Public method | CRCHelper | Initializes a new instance of the CRCHelper class
Top
Methods
 | Name | Description
 | CRC16(Byte) | CRC16 加密
 | CRC16(String, Encoding) | 按指定字符集 CRC16 加密
 | CRC32(Byte) | CRC32 加密
 | CRC32(String, Encoding) | 按指定字符集 CRC32 加密
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


CRCHelper Constructor

CRCHelper Constructor
Initializes a new instance of the CRCHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public CRCHelper()
Public Sub New
public:
CRCHelper()
new : unit -> CRCHelper
See Also

Reference

CRCHelper Class


CRCHelper Methods

CRCHelper Methods

The CRCHelper type exposes the following members.

Methods
 | Name | Description
 | CRC16(Byte) | CRC16 加密
 | CRC16(String, Encoding) | 按指定字符集 CRC16 加密
 | CRC32(Byte) | CRC32 加密
 | CRC32(String, Encoding) | 按指定字符集 CRC32 加密
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

CRCHelper Class


CRCHelper.CRC16 Method

CRCHelperCRC16 Method
Overload List
Name | Description
CRC16(Byte) | CRC16 加密
CRC16(String, Encoding) | 按指定字符集 CRC16 加密
Top
See Also

Reference

CRCHelper Class


CRCHelper.CRC16 Method (Byte[])

CRCHelperCRC16 Method (Byte)
CRC16 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static ushort CRC16(
    byte[] bytes
)
Public Shared Function CRC16 (
    bytes As Byte()
) As UShort
public:
static unsigned short CRC16(
    array<unsigned char>^ bytes
)
static member CRC16 :
        bytes : byte[] -> uint16

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:Adf.CRCHelper.CRC16(System.Byte[])"]

Return Value

Type: UInt16

[Missing <returns> documentation for "M:Adf.CRCHelper.CRC16(System.Byte[])"]

See Also

Reference

CRCHelper Class
CRC16 Overload


CRCHelper.CRC16 Method (String, Encoding)

CRCHelperCRC16 Method (String, Encoding)
按指定字符集 CRC16 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static ushort CRC16(
    string str,
    Encoding encoding
)
Public Shared Function CRC16 (
    str As String,
    encoding As Encoding
) As UShort
public:
static unsigned short CRC16(
    String^ str,
    Encoding^ encoding
)
static member CRC16 :
        str : string *
        encoding : Encoding -> uint16

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Adf.CRCHelper.CRC16(System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.CRCHelper.CRC16(System.String,System.Text.Encoding)"]

Return Value

Type: UInt16

[Missing <returns> documentation for "M:Adf.CRCHelper.CRC16(System.String,System.Text.Encoding)"]

See Also

Reference

CRCHelper Class
CRC16 Overload


CRCHelper.CRC32 Method

CRCHelperCRC32 Method
Overload List
Name | Description
CRC32(Byte) | CRC32 加密
CRC32(String, Encoding) | 按指定字符集 CRC32 加密
Top
See Also

Reference

CRCHelper Class


CRCHelper.CRC32 Method (Byte[])

CRCHelperCRC32 Method (Byte)
CRC32 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static uint CRC32(
    byte[] bytes
)
Public Shared Function CRC32 (
    bytes As Byte()
) As UInteger
public:
static unsigned int CRC32(
    array<unsigned char>^ bytes
)
static member CRC32 :
        bytes : byte[] -> uint32

Parameters

bytes
Type: SystemByte

[Missing <param name="bytes"/> documentation for "M:Adf.CRCHelper.CRC32(System.Byte[])"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:Adf.CRCHelper.CRC32(System.Byte[])"]

See Also

Reference

CRCHelper Class
CRC32 Overload


CRCHelper.CRC32 Method (String, Encoding)

CRCHelperCRC32 Method (String, Encoding)
按指定字符集 CRC32 加密

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static uint CRC32(
    string str,
    Encoding encoding
)
Public Shared Function CRC32 (
    str As String,
    encoding As Encoding
) As UInteger
public:
static unsigned int CRC32(
    String^ str,
    Encoding^ encoding
)
static member CRC32 :
        str : string *
        encoding : Encoding -> uint32

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Adf.CRCHelper.CRC32(System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.CRCHelper.CRC32(System.String,System.Text.Encoding)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:Adf.CRCHelper.CRC32(System.String,System.Text.Encoding)"]

See Also

Reference

CRCHelper Class
CRC32 Overload


DnsHelper Class

DnsHelper Class
DNS HELPER
Inheritance Hierarchy
SystemObject
AdfDnsHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DnsHelper
Public Class DnsHelper
public ref class DnsHelper
type DnsHelper =  class end

The DnsHelper type exposes the following members.

Constructors
 | Name | Description
Public method | DnsHelper | Initializes a new instance of the DnsHelper class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetMXRecordList | 获取Max记录列表
 | GetMXRecords | 获取Max记录列表,已按优先级排序
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


DnsHelper Constructor

DnsHelper Constructor
Initializes a new instance of the DnsHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DnsHelper()
Public Sub New
public:
DnsHelper()
new : unit -> DnsHelper
See Also

Reference

DnsHelper Class


DnsHelper Methods

DnsHelper Methods

The DnsHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetMXRecordList | 获取Max记录列表
 | GetMXRecords | 获取Max记录列表,已按优先级排序
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DnsHelper Class


DnsHelper.GetMXRecordList Method

DnsHelperGetMXRecordList Method
获取Max记录列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static List<DnsMXRecord> GetMXRecordList(
    string domain
)
Public Shared Function GetMXRecordList (
    domain As String
) As List(Of DnsMXRecord)
public:
static List<DnsMXRecord^>^ GetMXRecordList(
    String^ domain
)
static member GetMXRecordList :
        domain : string -> List<DnsMXRecord>

Parameters

domain
Type: SystemString

[Missing <param name="domain"/> documentation for "M:Adf.DnsHelper.GetMXRecordList(System.String)"]

Return Value

Type: List DnsMXRecord

[Missing <returns> documentation for "M:Adf.DnsHelper.GetMXRecordList(System.String)"]

See Also

Reference

DnsHelper Class


DnsHelper.GetMXRecords Method

DnsHelperGetMXRecords Method
获取Max记录列表,已按优先级排序

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] GetMXRecords(
    string domain
)
Public Shared Function GetMXRecords (
    domain As String
) As String()
public:
static array<String^>^ GetMXRecords(
    String^ domain
)
static member GetMXRecords :
        domain : string -> string[]

Parameters

domain
Type: SystemString

[Missing <param name="domain"/> documentation for "M:Adf.DnsHelper.GetMXRecords(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.DnsHelper.GetMXRecords(System.String)"]

See Also

Reference

DnsHelper Class


DnsMXRecord Class

DnsMXRecord Class
Mx Record
Inheritance Hierarchy
SystemObject
AdfDnsRecord
AdfDnsMXRecord

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DnsMXRecord : DnsRecord
Public Class DnsMXRecord
    Inherits DnsRecord
public ref class DnsMXRecord : public DnsRecord
type DnsMXRecord =
    class
        inherit DnsRecord
    end

The DnsMXRecord type exposes the following members.

Constructors
 | Name | Description
Public method | DnsMXRecord | Initializes a new instance of the DnsMXRecord class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | 记录名称 (Inherited from DnsRecord.)
Public property | Preference | 优先级
Public property | TTL | TTL (Inherited from DnsRecord.)
Public property | Value | 记录值 (Inherited from DnsRecord.)
Top
See Also

Reference


DnsMXRecord Constructor

DnsMXRecord Constructor
Initializes a new instance of the DnsMXRecord class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DnsMXRecord()
Public Sub New
public:
DnsMXRecord()
new : unit -> DnsMXRecord
See Also

Reference

DnsMXRecord Class


DnsMXRecord Methods

DnsMXRecord Methods

The DnsMXRecord type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DnsMXRecord Class


DnsMXRecord Properties

DnsMXRecord Properties

The DnsMXRecord type exposes the following members.

Properties
 | Name | Description
Public property | Name | 记录名称 (Inherited from DnsRecord.)
Public property | Preference | 优先级
Public property | TTL | TTL (Inherited from DnsRecord.)
Public property | Value | 记录值 (Inherited from DnsRecord.)
Top
See Also

Reference

DnsMXRecord Class


DnsMXRecord.Preference Property

DnsMXRecordPreference Property
优先级

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public short Preference { get; set; }
Public Property Preference As Short
    Get
    Set
public:
property short Preference {
    short get ();
    void set (short value);
}
member Preference : int16 with get, set

Property Value

Type: Int16
See Also

Reference

DnsMXRecord Class


DnsRecord Class

DnsRecord Class
DNS Record
Inheritance Hierarchy
SystemObject
AdfDnsRecord
AdfDnsMXRecord

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DnsRecord
Public Class DnsRecord
public ref class DnsRecord
type DnsRecord =  class end

The DnsRecord type exposes the following members.

Constructors
 | Name | Description
Public method | DnsRecord | Initializes a new instance of the DnsRecord class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Name | 记录名称
Public property | TTL | TTL
Public property | Value | 记录值
Top
See Also

Reference


DnsRecord Constructor

DnsRecord Constructor
Initializes a new instance of the DnsRecord class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DnsRecord()
Public Sub New
public:
DnsRecord()
new : unit -> DnsRecord
See Also

Reference

DnsRecord Class


DnsRecord Methods

DnsRecord Methods

The DnsRecord type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DnsRecord Class


DnsRecord Properties

DnsRecord Properties

The DnsRecord type exposes the following members.

Properties
 | Name | Description
Public property | Name | 记录名称
Public property | TTL | TTL
Public property | Value | 记录值
Top
See Also

Reference

DnsRecord Class


DnsRecord.Name Property

DnsRecordName Property
记录名称

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

DnsRecord Class


DnsRecord.TTL Property

DnsRecordTTL Property
TTL

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int TTL { get; set; }
Public Property TTL As Integer
    Get
    Set
public:
property int TTL {
    int get ();
    void set (int value);
}
member TTL : int with get, set

Property Value

Type: Int32
See Also

Reference

DnsRecord Class


DnsRecord.Value Property

DnsRecordValue Property
记录值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

DnsRecord Class


DynamicInvoke Class

DynamicInvoke Class
快速方法调用
Inheritance Hierarchy
SystemObject
AdfDynamicInvoke

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DynamicInvoke
Public Class DynamicInvoke
public ref class DynamicInvoke
type DynamicInvoke =  class end

The DynamicInvoke type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicInvoke | 初始实例
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Invoke | 调用
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | MethodInfo | 获取函数对象
Public property | Parameters | 获取函数对象参数列表
Top
See Also

Reference


DynamicInvoke Constructor

DynamicInvoke Constructor
初始实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DynamicInvoke(
    MethodInfo method
)
Public Sub New (
    method As MethodInfo
)
public:
DynamicInvoke(
    MethodInfo^ method
)
new :
        method : MethodInfo -> DynamicInvoke

Parameters

method
Type: System.ReflectionMethodInfo

[Missing <param name="method"/> documentation for "M:Adf.DynamicInvoke.#ctor(System.Reflection.MethodInfo)"]

See Also

Reference

DynamicInvoke Class


DynamicInvoke Methods

DynamicInvoke Methods

The DynamicInvoke type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Invoke | 调用
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DynamicInvoke Class


DynamicInvoke.Invoke Method

DynamicInvokeInvoke Method
调用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Object Invoke(
    Object target,
    params Object[] parameters
)
Public Function Invoke (
    target As Object,
    ParamArray parameters As Object()
) As Object
public:
Object^ Invoke(
    Object^ target,
    ... array<Object^>^ parameters
)
member Invoke :
        target : Object *
        parameters : Object[] -> Object

Parameters

target
Type: SystemObject
目标对象
parameters
Type: SystemObject
方法参数

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.DynamicInvoke.Invoke(System.Object,System.Object[])"]

See Also

Reference

DynamicInvoke Class


DynamicInvoke Properties

DynamicInvoke Properties

The DynamicInvoke type exposes the following members.

Properties
 | Name | Description
Public property | MethodInfo | 获取函数对象
Public property | Parameters | 获取函数对象参数列表
Top
See Also

Reference

DynamicInvoke Class


DynamicInvoke.MethodInfo Property

DynamicInvokeMethodInfo Property
获取函数对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MethodInfo MethodInfo { get; }
Public ReadOnly Property MethodInfo As MethodInfo
    Get
public:
property MethodInfo^ MethodInfo {
    MethodInfo^ get ();
}
member MethodInfo : MethodInfo with get

Property Value

Type: MethodInfo
See Also

Reference

DynamicInvoke Class


DynamicInvoke.Parameters Property

DynamicInvokeParameters Property
获取函数对象参数列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ParameterInfo[] Parameters { get; }
Public ReadOnly Property Parameters As ParameterInfo()
    Get
public:
property array<ParameterInfo^>^ Parameters {
    array<ParameterInfo^>^ get ();
}
member Parameters : ParameterInfo[] with get

Property Value

Type: ParameterInfo
See Also

Reference

DynamicInvoke Class


EncodingHelper Class

EncodingHelper Class
字符编码助手
Inheritance Hierarchy
SystemObject
AdfEncodingHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class EncodingHelper
Public NotInheritable Class EncodingHelper
public ref class EncodingHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EncodingHelper =  class end

The EncodingHelper type exposes the following members.

Methods
Name | Description
GetConfigEncoding | 获取配置中的字符编码
Top
Fields
Name | Description
GB2312Encoding | GB2312 Encoding
Top
See Also

Reference


EncodingHelper Fields

EncodingHelper Fields

The EncodingHelper type exposes the following members.

Fields
Name | Description
GB2312Encoding | GB2312 Encoding
Top
See Also

Reference

EncodingHelper Class


EncodingHelper.GB2312Encoding Field

EncodingHelperGB2312Encoding Field
GB2312 Encoding

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Encoding GB2312Encoding
Public Shared ReadOnly GB2312Encoding As Encoding
public:
static initonly Encoding^ GB2312Encoding
static val GB2312Encoding: Encoding

Field Value

Type: Encoding
See Also

Reference

EncodingHelper Class


EncodingHelper Methods

EncodingHelper Methods

The EncodingHelper type exposes the following members.

Methods
Name | Description
GetConfigEncoding | 获取配置中的字符编码
Top
See Also

Reference

EncodingHelper Class


EncodingHelper.GetConfigEncoding Method

EncodingHelperGetConfigEncoding Method
获取配置中的字符编码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Encoding GetConfigEncoding(
    string appSettingKey,
    Encoding defaultEncoding
)
Public Shared Function GetConfigEncoding (
    appSettingKey As String,
    defaultEncoding As Encoding
) As Encoding
public:
static Encoding^ GetConfigEncoding(
    String^ appSettingKey,
    Encoding^ defaultEncoding
)
static member GetConfigEncoding :
        appSettingKey : string *
        defaultEncoding : Encoding -> Encoding

Parameters

appSettingKey
Type: SystemString

[Missing <param name="appSettingKey"/> documentation for "M:Adf.EncodingHelper.GetConfigEncoding(System.String,System.Text.Encoding)"]

defaultEncoding
Type: System.TextEncoding

[Missing <param name="defaultEncoding"/> documentation for "M:Adf.EncodingHelper.GetConfigEncoding(System.String,System.Text.Encoding)"]

Return Value

Type: Encoding

[Missing <returns> documentation for "M:Adf.EncodingHelper.GetConfigEncoding(System.String,System.Text.Encoding)"]

See Also

Reference

EncodingHelper Class


EnumHelper Class

EnumHelper Class
枚举助手
Inheritance Hierarchy
SystemObject
AdfEnumHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class EnumHelper
Public NotInheritable Class EnumHelper
public ref class EnumHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EnumHelper =  class end

The EnumHelper type exposes the following members.

Methods
Name | Description
GetDescription | 获取枚举的描述(Description属性)
GetDescriptions | 获取枚举的描述列表
Top
See Also

Reference


EnumHelper Methods

EnumHelper Methods

The EnumHelper type exposes the following members.

Methods
Name | Description
GetDescription | 获取枚举的描述(Description属性)
GetDescriptions | 获取枚举的描述列表
Top
See Also

Reference

EnumHelper Class


EnumHelper.GetDescription Method

EnumHelperGetDescription Method
获取枚举的描述(Description属性)

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string GetDescription(
    Enum value
)
Public Shared Function GetDescription (
    value As Enum
) As String
public:
static String^ GetDescription(
    Enum^ value
)
static member GetDescription :
        value : Enum -> string

Parameters

value
Type: SystemEnum

[Missing <param name="value"/> documentation for "M:Adf.EnumHelper.GetDescription(System.Enum)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.EnumHelper.GetDescription(System.Enum)"]

Examples
Copy
System.Console.WriteLine(Utility.EnumHelper.GetDescritpion(EnumA.Value));
System.Console.WriteLine(Utility.EnumHelper.GetDescritpion(EnumB.Value));
See Also

Reference

EnumHelper Class


EnumHelper.GetDescriptions Method

EnumHelperGetDescriptions Method
获取枚举的描述列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<Enum, string> GetDescriptions(
    Type enumType
)
Public Shared Function GetDescriptions (
    enumType As Type
) As Dictionary(Of Enum, String)
public:
static Dictionary<Enum^, String^>^ GetDescriptions(
    Type^ enumType
)
static member GetDescriptions :
        enumType : Type -> Dictionary<Enum, string>

Parameters

enumType
Type: SystemType

[Missing <param name="enumType"/> documentation for "M:Adf.EnumHelper.GetDescriptions(System.Type)"]

Return Value

Type: Dictionary Enum, String

[Missing <returns> documentation for "M:Adf.EnumHelper.GetDescriptions(System.Type)"]

See Also

Reference

EnumHelper Class


ExceptionHelper Class

ExceptionHelper Class

Note: This API is now obsolete.

异常管理器
Inheritance Hierarchy
SystemObject
AdfExceptionHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("已过时, 请使用  ExceptionMail.Instance ", true)]
public class ExceptionHelper
<ObsoleteAttribute("已过时, 请使用  ExceptionMail.Instance ", true)>
Public Class ExceptionHelper
[ObsoleteAttribute(L"已过时, 请使用  ExceptionMail.Instance ", true)]
public ref class ExceptionHelper
[<ObsoleteAttribute("已过时, 请使用  ExceptionMail.Instance ", true)>]
type ExceptionHelper =  class end

The ExceptionHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionHelper | Initializes a new instance of the ExceptionHelper class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | SendMail | 发送邮件
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
Name | Description
Available | 是否可用
MailRecipients | 异常邮件接收人
Top
Remarks
配置： ExceptionMailRecipients, 以分号分隔的邮件接收人
See Also

Reference


ExceptionHelper Constructor

ExceptionHelper Constructor
Initializes a new instance of the ExceptionHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ExceptionHelper()
Public Sub New
public:
ExceptionHelper()
new : unit -> ExceptionHelper
See Also

Reference

ExceptionHelper Class


ExceptionHelper Methods

ExceptionHelper Methods

The ExceptionHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | SendMail | 发送邮件
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ExceptionHelper Class


ExceptionHelper.SendMail Method

ExceptionHelperSendMail Method
发送邮件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool SendMail(
    Exception exception
)
Public Shared Function SendMail (
    exception As Exception
) As Boolean
public:
static bool SendMail(
    Exception^ exception
)
static member SendMail :
        exception : Exception -> bool

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.ExceptionHelper.SendMail(System.Exception)"]

Return Value

Type: Boolean
返回是否执行了邮件发送
Exceptions
Exception | Condition
ArgumentNullException | exception
See Also

Reference

ExceptionHelper Class


ExceptionHelper Properties

ExceptionHelper Properties

The ExceptionHelper type exposes the following members.

Properties
Name | Description
Available | 是否可用
MailRecipients | 异常邮件接收人
Top
See Also

Reference

ExceptionHelper Class


ExceptionHelper.Available Property

ExceptionHelperAvailable Property
是否可用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool Available { get; }
Public Shared ReadOnly Property Available As Boolean
    Get
public:
static property bool Available {
    bool get ();
}
static member Available : bool with get

Property Value

Type: Boolean
See Also

Reference

ExceptionHelper Class


ExceptionHelper.MailRecipients Property

ExceptionHelperMailRecipients Property
异常邮件接收人

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] MailRecipients { get; }
Public Shared ReadOnly Property MailRecipients As String()
    Get
public:
static property array<String^>^ MailRecipients {
    array<String^>^ get ();
}
static member MailRecipients : string[] with get

Property Value

Type: String
See Also

Reference

ExceptionHelper Class


ExceptionMail Class

ExceptionMail Class
异常邮件发送器
Inheritance Hierarchy
SystemObject
AdfExceptionMail

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ExceptionMail
Public Class ExceptionMail
public ref class ExceptionMail
type ExceptionMail =  class end

The ExceptionMail type exposes the following members.

Constructors
 | Name | Description
Public method | ExceptionMail | Initializes a new instance of the ExceptionMail class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendMail | 发送邮件
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Fields
Name | Description
Instance | 默认实例
Top
Properties
 | Name | Description
Public property | Available | 是否可用
Public property | MailRecipients | 异常邮件接收人,配置： ExceptionMailRecipients, 以分号分隔的邮件接收人
Public property | Smtp | 获取当前发送SMTP实例, 通过ExceptionMailSmtp配置初始实例
Top
Remarks
配置： ExceptionMailRecipients, 以分号分隔的邮件接收人 配置： ExceptionMailSmtp, 指定发送邮件实例，此实例实现, ISmtp接口
See Also

Reference


ExceptionMail Constructor

ExceptionMail Constructor
Initializes a new instance of the ExceptionMail class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ExceptionMail()
Public Sub New
public:
ExceptionMail()
new : unit -> ExceptionMail
See Also

Reference

ExceptionMail Class


ExceptionMail Fields

ExceptionMail Fields

The ExceptionMail type exposes the following members.

Fields
Name | Description
Instance | 默认实例
Top
See Also

Reference

ExceptionMail Class


ExceptionMail.Instance Field

ExceptionMailInstance Field
默认实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly ExceptionMail Instance
Public Shared ReadOnly Instance As ExceptionMail
public:
static initonly ExceptionMail^ Instance
static val Instance: ExceptionMail

Field Value

Type: ExceptionMail
See Also

Reference

ExceptionMail Class


ExceptionMail Methods

ExceptionMail Methods

The ExceptionMail type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendMail | 发送邮件
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ExceptionMail Class


ExceptionMail.SendMail Method

ExceptionMailSendMail Method
发送邮件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SendMail(
    Exception exception
)
Public Function SendMail (
    exception As Exception
) As Boolean
public:
bool SendMail(
    Exception^ exception
)
member SendMail :
        exception : Exception -> bool

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.ExceptionMail.SendMail(System.Exception)"]

Return Value

Type: Boolean
返回是否执行了邮件发送
Exceptions
Exception | Condition
ArgumentNullException | exception
See Also

Reference

ExceptionMail Class


ExceptionMail Properties

ExceptionMail Properties

The ExceptionMail type exposes the following members.

Properties
 | Name | Description
Public property | Available | 是否可用
Public property | MailRecipients | 异常邮件接收人,配置： ExceptionMailRecipients, 以分号分隔的邮件接收人
Public property | Smtp | 获取当前发送SMTP实例, 通过ExceptionMailSmtp配置初始实例
Top
See Also

Reference

ExceptionMail Class


ExceptionMail.Available Property

ExceptionMailAvailable Property
是否可用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Available { get; }
Public ReadOnly Property Available As Boolean
    Get
public:
property bool Available {
    bool get ();
}
member Available : bool with get

Property Value

Type: Boolean
See Also

Reference

ExceptionMail Class


ExceptionMail.MailRecipients Property

ExceptionMailMailRecipients Property
异常邮件接收人,配置： ExceptionMailRecipients, 以分号分隔的邮件接收人

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] MailRecipients { get; }
Public ReadOnly Property MailRecipients As String()
    Get
public:
property array<String^>^ MailRecipients {
    array<String^>^ get ();
}
member MailRecipients : string[] with get

Property Value

Type: String
See Also

Reference

ExceptionMail Class


ExceptionMail.Smtp Property

ExceptionMailSmtp Property
获取当前发送SMTP实例, 通过ExceptionMailSmtp配置初始实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ISmtp Smtp { get; }
Public ReadOnly Property Smtp As ISmtp
    Get
public:
property ISmtp^ Smtp {
    ISmtp^ get ();
}
member Smtp : ISmtp with get

Property Value

Type: ISmtp
See Also

Reference

ExceptionMail Class


HtmlHelper Class

HtmlHelper Class
Html助手
Inheritance Hierarchy
SystemObject
AdfHtmlHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class HtmlHelper
Public NotInheritable Class HtmlHelper
public ref class HtmlHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HtmlHelper =  class end

The HtmlHelper type exposes the following members.

Methods
Name | Description
ArrayToTable | 数组转换为表格
DataTableToTable | 数据表转换为表格
GetNoArchorBody | 将字符串中href属性都替换为空
Top
See Also

Reference


HtmlHelper Methods

HtmlHelper Methods

The HtmlHelper type exposes the following members.

Methods
Name | Description
ArrayToTable | 数组转换为表格
DataTableToTable | 数据表转换为表格
GetNoArchorBody | 将字符串中href属性都替换为空
Top
See Also

Reference

HtmlHelper Class


HtmlHelper.ArrayToTable Method

HtmlHelperArrayToTable Method
数组转换为表格

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ArrayToTable(
    Array array,
    string id,
    string width,
    int border = 1,
    int cellpadding = 0,
    int cellspacing = 0
)
Public Shared Function ArrayToTable (
    array As Array,
    id As String,
    width As String,
    Optional border As Integer = 1,
    Optional cellpadding As Integer = 0,
    Optional cellspacing As Integer = 0
) As String
public:
static String^ ArrayToTable(
    Array^ array,
    String^ id,
    String^ width,
    int border = 1,
    int cellpadding = 0,
    int cellspacing = 0
)
static member ArrayToTable :
        array : Array *
        id : string *
        width : string *
        ?border : int *
        ?cellpadding : int *
        ?cellspacing : int
(* Defaults:
        let _border = defaultArg border 1
        let _cellpadding = defaultArg cellpadding 0
        let _cellspacing = defaultArg cellspacing 0
*)
-> string

Parameters

array
Type: SystemArray
数组
id
Type: SystemString
表格ID
width
Type: SystemString
表宽
border (Optional)
Type: SystemInt32
边框
cellpadding (Optional)
Type: SystemInt32
填充
cellspacing (Optional)
Type: SystemInt32
表间距

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.HtmlHelper.ArrayToTable(System.Array,System.String,System.String,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

HtmlHelper Class


HtmlHelper.DataTableToTable Method

HtmlHelperDataTableToTable Method
数据表转换为表格

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string DataTableToTable(
    DataTable dt,
    string id,
    string width,
    int border = 1,
    int cellpadding = 0,
    int cellspacing = 0
)
Public Shared Function DataTableToTable (
    dt As DataTable,
    id As String,
    width As String,
    Optional border As Integer = 1,
    Optional cellpadding As Integer = 0,
    Optional cellspacing As Integer = 0
) As String
public:
static String^ DataTableToTable(
    DataTable^ dt,
    String^ id,
    String^ width,
    int border = 1,
    int cellpadding = 0,
    int cellspacing = 0
)
static member DataTableToTable :
        dt : DataTable *
        id : string *
        width : string *
        ?border : int *
        ?cellpadding : int *
        ?cellspacing : int
(* Defaults:
        let _border = defaultArg border 1
        let _cellpadding = defaultArg cellpadding 0
        let _cellspacing = defaultArg cellspacing 0
*)
-> string

Parameters

dt
Type: System.DataDataTable
数据表
id
Type: SystemString
表格ID
width
Type: SystemString
表宽
border (Optional)
Type: SystemInt32
边框
cellpadding (Optional)
Type: SystemInt32
填充
cellspacing (Optional)
Type: SystemInt32
表间距

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.HtmlHelper.DataTableToTable(System.Data.DataTable,System.String,System.String,System.Int32,System.Int32,System.Int32)"]

See Also

Reference

HtmlHelper Class


HtmlHelper.GetNoArchorBody Method

HtmlHelperGetNoArchorBody Method
将字符串中href属性都替换为空

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string GetNoArchorBody(
    string html
)
Public Shared Function GetNoArchorBody (
    html As String
) As String
public:
static String^ GetNoArchorBody(
    String^ html
)
static member GetNoArchorBody :
        html : string -> string

Parameters

html
Type: SystemString

[Missing <param name="html"/> documentation for "M:Adf.HtmlHelper.GetNoArchorBody(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.HtmlHelper.GetNoArchorBody(System.String)"]

See Also

Reference

HtmlHelper Class


HttpServer Class

HttpServer Class
Simple Http Server
Inheritance Hierarchy
SystemObject
AdfHttpServer

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class HttpServer : IDisposable
Public Class HttpServer
    Implements IDisposable
public ref class HttpServer : IDisposable
type HttpServer =
    class
        interface IDisposable
    end

The HttpServer type exposes the following members.

Constructors
 | Name | Description
Public method | HttpServer(Int32, String) | Initialize new instance
Public method | HttpServer(HttpServerCallback, Int32, String) | Initialize new instance
Top
Methods
 | Name | Description
Public method | Dispose | Dispose
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWebSocket | 获取指定id websocket,未找到则返回null
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Start | start
Public method | Stop | Stop
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | WebSocketDisconnect | 断开连接
Public method | WebSocketDisconnectAll | 断开所有连接
Public method | WebSocketForEach | 遍历当前具有的WebSocket连接
Top
Properties
 | Name | Description
Public property | AddressFamily | tcp AddressFamily
Public property | AuthenticateRealm | WWW-Authenticate realm vaue
Public property | AuthorizationCallback | Authorization callback
Public property | Backlog | 获取或设置监听队列长度
Public property | Callback | callback
Public property | Encoding | Encoding, default utf-8
Public property | Ip | ip address
Public property | IsRuning | is Runing
Public property | Port | Server Port
Public property | ReadHeadTimeout | 头读取超时时间
Public property | ServerName | 获取或设置服务器名
Top
Events
 | Name | Description
Public event | WebSocketConnectioned | 获取或设置连接回调方法
Public event | WebSocketDisconnected | 获取或设置关闭回调方法
Top
See Also

Reference


HttpServer Constructor

HttpServer Constructor
Overload List
 | Name | Description
Public method | HttpServer(Int32, String) | Initialize new instance
Public method | HttpServer(HttpServerCallback, Int32, String) | Initialize new instance
Top
See Also

Reference

HttpServer Class


HttpServer Constructor (Int32, String)

HttpServer Constructor (Int32, String)
Initialize new instance

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServer(
    int port,
    string ip = "*"
)
Public Sub New (
    port As Integer,
    Optional ip As String = "*"
)
public:
HttpServer(
    int port,
    String^ ip = L"*"
)
new :
        port : int *
        ?ip : string
(* Defaults:
        let _ip = defaultArg ip "*"
*)
-> HttpServer

Parameters

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.HttpServer.#ctor(System.Int32,System.String)"]

ip (Optional)
Type: SystemString

[Missing <param name="ip"/> documentation for "M:Adf.HttpServer.#ctor(System.Int32,System.String)"]

See Also

Reference

HttpServer Class
HttpServer Overload


HttpServer Constructor (HttpServerCallback, Int32, String)

HttpServer Constructor (HttpServerCallback, Int32, String)
Initialize new instance

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServer(
    HttpServerCallback callback,
    int port,
    string ip = "*"
)
Public Sub New (
    callback As HttpServerCallback,
    port As Integer,
    Optional ip As String = "*"
)
public:
HttpServer(
    HttpServerCallback^ callback,
    int port,
    String^ ip = L"*"
)
new :
        callback : HttpServerCallback *
        port : int *
        ?ip : string
(* Defaults:
        let _ip = defaultArg ip "*"
*)
-> HttpServer

Parameters

callback
Type: AdfHttpServerCallback

[Missing <param name="callback"/> documentation for "M:Adf.HttpServer.#ctor(Adf.HttpServerCallback,System.Int32,System.String)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.HttpServer.#ctor(Adf.HttpServerCallback,System.Int32,System.String)"]

ip (Optional)
Type: SystemString

[Missing <param name="ip"/> documentation for "M:Adf.HttpServer.#ctor(Adf.HttpServerCallback,System.Int32,System.String)"]

See Also

Reference

HttpServer Class
HttpServer Overload


HttpServer Methods

HttpServer Methods

The HttpServer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Dispose
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWebSocket | 获取指定id websocket,未找到则返回null
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Start | start
Public method | Stop | Stop
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | WebSocketDisconnect | 断开连接
Public method | WebSocketDisconnectAll | 断开所有连接
Public method | WebSocketForEach | 遍历当前具有的WebSocket连接
Top
See Also

Reference

HttpServer Class


HttpServer.Dispose Method

HttpServerDispose Method
Dispose

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

HttpServer Class


HttpServer.GetWebSocket Method

HttpServerGetWebSocket Method
获取指定id websocket,未找到则返回null

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerWebSocketContext GetWebSocket(
    string id
)
Public Function GetWebSocket (
    id As String
) As HttpServerWebSocketContext
public:
HttpServerWebSocketContext^ GetWebSocket(
    String^ id
)
member GetWebSocket :
        id : string -> HttpServerWebSocketContext

Parameters

id
Type: SystemString

[Missing <param name="id"/> documentation for "M:Adf.HttpServer.GetWebSocket(System.String)"]

Return Value

Type: HttpServerWebSocketContext

[Missing <returns> documentation for "M:Adf.HttpServer.GetWebSocket(System.String)"]

See Also

Reference

HttpServer Class


HttpServer.Start Method

HttpServerStart Method
start

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Start()
Public Sub Start
public:
void Start()
member Start : unit -> unit
Exceptions
Exception | Condition
NotImplementedException | No Set Callback Property
See Also

Reference

HttpServer Class


HttpServer.Stop Method

HttpServerStop Method
Stop

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Stop()
Public Sub Stop
public:
void Stop()
member Stop : unit -> unit
See Also

Reference

HttpServer Class


HttpServer.WebSocketDisconnect Method

HttpServerWebSocketDisconnect Method
断开连接

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void WebSocketDisconnect(
    HttpServerWebSocketContext context
)
Public Sub WebSocketDisconnect (
    context As HttpServerWebSocketContext
)
public:
void WebSocketDisconnect(
    HttpServerWebSocketContext^ context
)
member WebSocketDisconnect :
        context : HttpServerWebSocketContext -> unit

Parameters

context
Type: AdfHttpServerWebSocketContext

[Missing <param name="context"/> documentation for "M:Adf.HttpServer.WebSocketDisconnect(Adf.HttpServerWebSocketContext)"]

See Also

Reference

HttpServer Class


HttpServer.WebSocketDisconnectAll Method

HttpServerWebSocketDisconnectAll Method
断开所有连接

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void WebSocketDisconnectAll()
Public Sub WebSocketDisconnectAll
public:
void WebSocketDisconnectAll()
member WebSocketDisconnectAll : unit -> unit
See Also

Reference

HttpServer Class


HttpServer.WebSocketForEach Method

HttpServerWebSocketForEach Method
遍历当前具有的WebSocket连接

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void WebSocketForEach(
    Action<HttpServerWebSocketContext> action
)
Public Sub WebSocketForEach (
    action As Action(Of HttpServerWebSocketContext)
)
public:
void WebSocketForEach(
    Action<HttpServerWebSocketContext^>^ action
)
member WebSocketForEach :
        action : Action<HttpServerWebSocketContext> -> unit

Parameters

action
Type: SystemAction HttpServerWebSocketContext

[Missing <param name="action"/> documentation for "M:Adf.HttpServer.WebSocketForEach(System.Action{Adf.HttpServerWebSocketContext})"]

See Also

Reference

HttpServer Class


HttpServer Properties

HttpServer Properties

The HttpServer type exposes the following members.

Properties
 | Name | Description
Public property | AddressFamily | tcp AddressFamily
Public property | AuthenticateRealm | WWW-Authenticate realm vaue
Public property | AuthorizationCallback | Authorization callback
Public property | Backlog | 获取或设置监听队列长度
Public property | Callback | callback
Public property | Encoding | Encoding, default utf-8
Public property | Ip | ip address
Public property | IsRuning | is Runing
Public property | Port | Server Port
Public property | ReadHeadTimeout | 头读取超时时间
Public property | ServerName | 获取或设置服务器名
Top
See Also

Reference

HttpServer Class


HttpServer.AddressFamily Property

HttpServerAddressFamily Property
tcp AddressFamily

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public AddressFamily AddressFamily { get; }
Public ReadOnly Property AddressFamily As AddressFamily
    Get
public:
property AddressFamily AddressFamily {
    AddressFamily get ();
}
member AddressFamily : AddressFamily with get

Property Value

Type: AddressFamily
See Also

Reference

HttpServer Class


HttpServer.AuthenticateRealm Property

HttpServerAuthenticateRealm Property
WWW-Authenticate realm vaue

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string AuthenticateRealm { get; set; }
Public Property AuthenticateRealm As String
    Get
    Set
public:
property String^ AuthenticateRealm {
    String^ get ();
    void set (String^ value);
}
member AuthenticateRealm : string with get, set

Property Value

Type: String
See Also

Reference

HttpServer Class


HttpServer.AuthorizationCallback Property

HttpServerAuthorizationCallback Property
Authorization callback

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerAuthorizationCallback AuthorizationCallback { get; set; }
Public Property AuthorizationCallback As HttpServerAuthorizationCallback
    Get
    Set
public:
property HttpServerAuthorizationCallback^ AuthorizationCallback {
    HttpServerAuthorizationCallback^ get ();
    void set (HttpServerAuthorizationCallback^ value);
}
member AuthorizationCallback : HttpServerAuthorizationCallback with get, set

Property Value

Type: HttpServerAuthorizationCallback
See Also

Reference

HttpServer Class


HttpServer.Backlog Property

HttpServerBacklog Property
获取或设置监听队列长度

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Backlog { get; set; }
Public Property Backlog As Integer
    Get
    Set
public:
property int Backlog {
    int get ();
    void set (int value);
}
member Backlog : int with get, set

Property Value

Type: Int32
See Also

Reference

HttpServer Class


HttpServer.Callback Property

HttpServerCallback Property
callback

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerCallback Callback { get; set; }
Public Property Callback As HttpServerCallback
    Get
    Set
public:
property HttpServerCallback^ Callback {
    HttpServerCallback^ get ();
    void set (HttpServerCallback^ value);
}
member Callback : HttpServerCallback with get, set

Property Value

Type: HttpServerCallback
See Also

Reference

HttpServer Class


HttpServer.Encoding Property

HttpServerEncoding Property
Encoding, default utf-8

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set

Property Value

Type: Encoding
See Also

Reference

HttpServer Class


HttpServer.Ip Property

HttpServerIp Property
ip address

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Ip { get; }
Public ReadOnly Property Ip As String
    Get
public:
property String^ Ip {
    String^ get ();
}
member Ip : string with get

Property Value

Type: String
See Also

Reference

HttpServer Class


HttpServer.IsRuning Property

HttpServerIsRuning Property
is Runing

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool IsRuning { get; }
Public ReadOnly Property IsRuning As Boolean
    Get
public:
property bool IsRuning {
    bool get ();
}
member IsRuning : bool with get

Property Value

Type: Boolean
See Also

Reference

HttpServer Class


HttpServer.Port Property

HttpServerPort Property
Server Port

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
member Port : int with get

Property Value

Type: Int32
See Also

Reference

HttpServer Class


HttpServer.ReadHeadTimeout Property

HttpServerReadHeadTimeout Property
头读取超时时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ReadHeadTimeout { get; set; }
Public Property ReadHeadTimeout As Integer
    Get
    Set
public:
property int ReadHeadTimeout {
    int get ();
    void set (int value);
}
member ReadHeadTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

HttpServer Class


HttpServer.ServerName Property

HttpServerServerName Property
获取或设置服务器名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
member ServerName : string with get, set

Property Value

Type: String
See Also

Reference

HttpServer Class


HttpServer Events

HttpServer Events

The HttpServer type exposes the following members.

Events
 | Name | Description
Public event | WebSocketConnectioned | 获取或设置连接回调方法
Public event | WebSocketDisconnected | 获取或设置关闭回调方法
Top
See Also

Reference

HttpServer Class


HttpServer.WebSocketConnectioned Event

HttpServerWebSocketConnectioned Event
获取或设置连接回调方法

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public event HttpServerWebSocketCallback WebSocketConnectioned
Public Event WebSocketConnectioned As HttpServerWebSocketCallback
public:
 event HttpServerWebSocketCallback^ WebSocketConnectioned {
    void add (HttpServerWebSocketCallback^ value);
    void remove (HttpServerWebSocketCallback^ value);
}
member WebSocketConnectioned : IEvent<HttpServerWebSocketCallback,
    EventArgs>

Value

Type: AdfHttpServerWebSocketCallback
See Also

Reference

HttpServer Class


HttpServer.WebSocketDisconnected Event

HttpServerWebSocketDisconnected Event
获取或设置关闭回调方法

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public event HttpServerWebSocketCallback WebSocketDisconnected
Public Event WebSocketDisconnected As HttpServerWebSocketCallback
public:
 event HttpServerWebSocketCallback^ WebSocketDisconnected {
    void add (HttpServerWebSocketCallback^ value);
    void remove (HttpServerWebSocketCallback^ value);
}
member WebSocketDisconnected : IEvent<HttpServerWebSocketCallback,
    EventArgs>

Value

Type: AdfHttpServerWebSocketCallback
See Also

Reference

HttpServer Class


HttpServerAuthorizationCallback Delegate

HttpServerAuthorizationCallback Delegate
Http Server Authorization Callback

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate bool HttpServerAuthorizationCallback(
    HttpServerContextBase context
)
Public Delegate Function HttpServerAuthorizationCallback (
    context As HttpServerContextBase
) As Boolean
public delegate bool HttpServerAuthorizationCallback(
    HttpServerContextBase^ context
)
type HttpServerAuthorizationCallback =
    delegate of
        context : HttpServerContextBase -> bool

Parameters

context
Type: AdfHttpServerContextBase

Return Value

Type: Boolean
See Also

Reference


HttpServerCallback Delegate

HttpServerCallback Delegate
Http Server Callback

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate HttpStatusCode HttpServerCallback(
    HttpServerContext context
)
Public Delegate Function HttpServerCallback (
    context As HttpServerContext
) As HttpStatusCode
public delegate HttpStatusCode HttpServerCallback(
    HttpServerContext^ context
)
type HttpServerCallback =
    delegate of
        context : HttpServerContext -> HttpStatusCode

Parameters

context
Type: AdfHttpServerContext

Return Value

Type: HttpStatusCode
See Also

Reference


HttpServerChunkStatus Enumeration

HttpServerChunkStatus Enumeration
块输出状态

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public enum HttpServerChunkStatus
Public Enumeration HttpServerChunkStatus
public enum class HttpServerChunkStatus
type HttpServerChunkStatus
Members
Member name | Value | Description
NoBegin | 0 | No Begin
Writing | 1 | In The Writing
End | 2 | ENd
See Also

Reference


HttpServerContext Class

HttpServerContext Class
Http Server Context
Inheritance Hierarchy
SystemObject
AdfHttpServerContextBase
AdfHttpServerContext

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class HttpServerContext : HttpServerContextBase
Public Class HttpServerContext
    Inherits HttpServerContextBase
public ref class HttpServerContext : public HttpServerContextBase
type HttpServerContext =
    class
        inherit HttpServerContextBase
    end

The HttpServerContext type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | Begin Async And Chunk Write, You Need Invoke EndWrite
Public method | EndWrite | End Write
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write | Write Chunk Content
Top
Properties
 | Name | Description
Public property | ChunkWriteStatus | 获取当前是否以区块输出
Public property | Content | Result
Public property | ContentBuffer | Result, override content
Public property | ContextType | get or set context-type, is default text/html
Public property | Encoding | get/or set encoding (Inherited from HttpServerContextBase.)
Public property | Form | Post Data
Public property | Method | Get Method (Inherited from HttpServerContextBase.)
Public property | Password | 密码 (Inherited from HttpServerContextBase.)
Public property | Path | Path (Inherited from HttpServerContextBase.)
Public property | Protocol | Protocol (Inherited from HttpServerContextBase.)
Public property | ProtocolVersion | protocol version (Inherited from HttpServerContextBase.)
Public property | QueryString | QueryString (Inherited from HttpServerContextBase.)
Public property | RequestHeader | RequestHeader (Inherited from HttpServerContextBase.)
Public property | RequestType | Request Type (Inherited from HttpServerContextBase.)
Public property | ResponseHeader | ResponseHeader (Inherited from HttpServerContextBase.)
Public property | Server | get server (Inherited from HttpServerContextBase.)
Public property | Socket | 当前连接对象
Public property | Url | Url (Inherited from HttpServerContextBase.)
Public property | UserName | 用户名 (Inherited from HttpServerContextBase.)
Top
See Also

Reference


HttpServerContext Methods

HttpServerContext Methods

The HttpServerContext type exposes the following members.

Methods
 | Name | Description
Public method | BeginWrite | Begin Async And Chunk Write, You Need Invoke EndWrite
Public method | EndWrite | End Write
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write | Write Chunk Content
Top
See Also

Reference

HttpServerContext Class


HttpServerContext.BeginWrite Method

HttpServerContextBeginWrite Method
Begin Async And Chunk Write, You Need Invoke EndWrite

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void BeginWrite()
Public Sub BeginWrite
public:
void BeginWrite()
member BeginWrite : unit -> unit
See Also

Reference

HttpServerContext Class


HttpServerContext.EndWrite Method

HttpServerContextEndWrite Method
End Write

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void EndWrite()
Public Sub EndWrite
public:
void EndWrite()
member EndWrite : unit -> unit
See Also

Reference

HttpServerContext Class


HttpServerContext.Write Method

HttpServerContextWrite Method
Write Chunk Content

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Write(
    string content,
    params Object[] args
)
Public Sub Write (
    content As String,
    ParamArray args As Object()
)
public:
void Write(
    String^ content,
    ... array<Object^>^ args
)
member Write :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.HttpServerContext.Write(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.HttpServerContext.Write(System.String,System.Object[])"]

See Also

Reference

HttpServerContext Class


HttpServerContext Properties

HttpServerContext Properties

The HttpServerContext type exposes the following members.

Properties
 | Name | Description
Public property | ChunkWriteStatus | 获取当前是否以区块输出
Public property | Content | Result
Public property | ContentBuffer | Result, override content
Public property | ContextType | get or set context-type, is default text/html
Public property | Encoding | get/or set encoding (Inherited from HttpServerContextBase.)
Public property | Form | Post Data
Public property | Method | Get Method (Inherited from HttpServerContextBase.)
Public property | Password | 密码 (Inherited from HttpServerContextBase.)
Public property | Path | Path (Inherited from HttpServerContextBase.)
Public property | Protocol | Protocol (Inherited from HttpServerContextBase.)
Public property | ProtocolVersion | protocol version (Inherited from HttpServerContextBase.)
Public property | QueryString | QueryString (Inherited from HttpServerContextBase.)
Public property | RequestHeader | RequestHeader (Inherited from HttpServerContextBase.)
Public property | RequestType | Request Type (Inherited from HttpServerContextBase.)
Public property | ResponseHeader | ResponseHeader (Inherited from HttpServerContextBase.)
Public property | Server | get server (Inherited from HttpServerContextBase.)
Public property | Socket | 当前连接对象
Public property | Url | Url (Inherited from HttpServerContextBase.)
Public property | UserName | 用户名 (Inherited from HttpServerContextBase.)
Top
See Also

Reference

HttpServerContext Class


HttpServerContext.ChunkWriteStatus Property

HttpServerContextChunkWriteStatus Property
获取当前是否以区块输出

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerChunkStatus ChunkWriteStatus { get; }
Public ReadOnly Property ChunkWriteStatus As HttpServerChunkStatus
    Get
public:
property HttpServerChunkStatus ChunkWriteStatus {
    HttpServerChunkStatus get ();
}
member ChunkWriteStatus : HttpServerChunkStatus with get

Property Value

Type: HttpServerChunkStatus
See Also

Reference

HttpServerContext Class


HttpServerContext.Content Property

HttpServerContextContent Property
Result

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Content { get; set; }
Public Property Content As String
    Get
    Set
public:
property String^ Content {
    String^ get ();
    void set (String^ value);
}
member Content : string with get, set

Property Value

Type: String
See Also

Reference

HttpServerContext Class


HttpServerContext.ContentBuffer Property

HttpServerContextContentBuffer Property
Result, override content

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] ContentBuffer { get; set; }
Public Property ContentBuffer As Byte()
    Get
    Set
public:
property array<unsigned char>^ ContentBuffer {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ContentBuffer : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

HttpServerContext Class


HttpServerContext.ContextType Property

HttpServerContextContextType Property
get or set context-type, is default text/html

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string ContextType { get; set; }
Public Property ContextType As String
    Get
    Set
public:
property String^ ContextType {
    String^ get ();
    void set (String^ value);
}
member ContextType : string with get, set

Property Value

Type: String
See Also

Reference

HttpServerContext Class


HttpServerContext.Form Property

HttpServerContextForm Property
Post Data

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public NameValueCollection Form { get; }
Public ReadOnly Property Form As NameValueCollection
    Get
public:
property NameValueCollection^ Form {
    NameValueCollection^ get ();
}
member Form : NameValueCollection with get

Property Value

Type: NameValueCollection
See Also

Reference

HttpServerContext Class


HttpServerContext.Socket Property

HttpServerContextSocket Property
当前连接对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Socket Socket { get; }
Public ReadOnly Property Socket As Socket
    Get
public:
property Socket^ Socket {
    Socket^ get ();
}
member Socket : Socket with get

Property Value

Type: Socket
See Also

Reference

HttpServerContext Class


HttpServerContextBase Class

HttpServerContextBase Class
Http Server Context base
Inheritance Hierarchy
SystemObject
AdfHttpServerContextBase
AdfHttpServerContext
AdfHttpServerWebSocketContext

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract class HttpServerContextBase
Public MustInherit Class HttpServerContextBase
public ref class HttpServerContextBase abstract
[<AbstractClassAttribute>]
type HttpServerContextBase =  class end

The HttpServerContextBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Encoding | get/or set encoding
Public property | Method | Get Method
Public property | Password | 密码
Public property | Path | Path
Public property | Protocol | Protocol
Public property | ProtocolVersion | protocol version
Public property | QueryString | QueryString
Public property | RequestHeader | RequestHeader
Public property | RequestType | Request Type
Public property | ResponseHeader | ResponseHeader
Public property | Server | get server
Public property | Url | Url
Public property | UserName | 用户名
Top
See Also

Reference


HttpServerContextBase Methods

HttpServerContextBase Methods

The HttpServerContextBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase Properties

HttpServerContextBase Properties

The HttpServerContextBase type exposes the following members.

Properties
 | Name | Description
Public property | Encoding | get/or set encoding
Public property | Method | Get Method
Public property | Password | 密码
Public property | Path | Path
Public property | Protocol | Protocol
Public property | ProtocolVersion | protocol version
Public property | QueryString | QueryString
Public property | RequestHeader | RequestHeader
Public property | RequestType | Request Type
Public property | ResponseHeader | ResponseHeader
Public property | Server | get server
Public property | Url | Url
Public property | UserName | 用户名
Top
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.Encoding Property

HttpServerContextBaseEncoding Property
get/or set encoding

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set

Property Value

Type: Encoding
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.Method Property

HttpServerContextBaseMethod Property
Get Method

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Method { get; }
Public ReadOnly Property Method As String
    Get
public:
property String^ Method {
    String^ get ();
}
member Method : string with get

Property Value

Type: String
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.Password Property

HttpServerContextBasePassword Property
密码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Password { get; }
Public ReadOnly Property Password As String
    Get
public:
property String^ Password {
    String^ get ();
}
member Password : string with get

Property Value

Type: String
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.Path Property

HttpServerContextBasePath Property
Path

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.Protocol Property

HttpServerContextBaseProtocol Property
Protocol

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Protocol { get; }
Public ReadOnly Property Protocol As String
    Get
public:
property String^ Protocol {
    String^ get ();
}
member Protocol : string with get

Property Value

Type: String
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.ProtocolVersion Property

HttpServerContextBaseProtocolVersion Property
protocol version

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string ProtocolVersion { get; protected set; }
Public Property ProtocolVersion As String
    Get
    Protected Set
public:
property String^ ProtocolVersion {
    String^ get ();
    protected: void set (String^ value);
}
member ProtocolVersion : string with get, set

Property Value

Type: String
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.QueryString Property

HttpServerContextBaseQueryString Property
QueryString

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public NameValueCollection QueryString { get; }
Public ReadOnly Property QueryString As NameValueCollection
    Get
public:
property NameValueCollection^ QueryString {
    NameValueCollection^ get ();
}
member QueryString : NameValueCollection with get

Property Value

Type: NameValueCollection
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.RequestHeader Property

HttpServerContextBaseRequestHeader Property
RequestHeader

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public NameValueCollection RequestHeader { get; }
Public ReadOnly Property RequestHeader As NameValueCollection
    Get
public:
property NameValueCollection^ RequestHeader {
    NameValueCollection^ get ();
}
member RequestHeader : NameValueCollection with get

Property Value

Type: NameValueCollection
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.RequestType Property

HttpServerContextBaseRequestType Property
Request Type

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerRequestType RequestType { get; protected set; }
Public Property RequestType As HttpServerRequestType
    Get
    Protected Set
public:
property HttpServerRequestType RequestType {
    HttpServerRequestType get ();
    protected: void set (HttpServerRequestType value);
}
member RequestType : HttpServerRequestType with get, set

Property Value

Type: HttpServerRequestType
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.ResponseHeader Property

HttpServerContextBaseResponseHeader Property
ResponseHeader

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public NameValueCollection ResponseHeader { get; }
Public ReadOnly Property ResponseHeader As NameValueCollection
    Get
public:
property NameValueCollection^ ResponseHeader {
    NameValueCollection^ get ();
}
member ResponseHeader : NameValueCollection with get

Property Value

Type: NameValueCollection
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.Server Property

HttpServerContextBaseServer Property
get server

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServer Server { get; }
Public ReadOnly Property Server As HttpServer
    Get
public:
property HttpServer^ Server {
    HttpServer^ get ();
}
member Server : HttpServer with get

Property Value

Type: HttpServer
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.Url Property

HttpServerContextBaseUrl Property
Url

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Url { get; }
Public ReadOnly Property Url As String
    Get
public:
property String^ Url {
    String^ get ();
}
member Url : string with get

Property Value

Type: String
See Also

Reference

HttpServerContextBase Class


HttpServerContextBase.UserName Property

HttpServerContextBaseUserName Property
用户名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
public:
property String^ UserName {
    String^ get ();
}
member UserName : string with get

Property Value

Type: String
See Also

Reference

HttpServerContextBase Class


HttpServerRequestType Enumeration

HttpServerRequestType Enumeration
HttpServerRequestType

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public enum HttpServerRequestType
Public Enumeration HttpServerRequestType
public enum class HttpServerRequestType
type HttpServerRequestType
Members
Member name | Value | Description
Http | 1 | Http
WebSocket | 2 | Web Socket
See Also

Reference


HttpServerWebSocketCallback Delegate

HttpServerWebSocketCallback Delegate
WebSocket Disconnection Callback

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate void HttpServerWebSocketCallback(
    HttpServerWebSocketContext context
)
Public Delegate Sub HttpServerWebSocketCallback (
    context As HttpServerWebSocketContext
)
public delegate void HttpServerWebSocketCallback(
    HttpServerWebSocketContext^ context
)
type HttpServerWebSocketCallback =
    delegate of
        context : HttpServerWebSocketContext -> unit

Parameters

context
Type: AdfHttpServerWebSocketContext

Return Value

Type:
See Also

Reference


HttpServerWebSocketContext Class

HttpServerWebSocketContext Class
Http Server WebSocket Context
Inheritance Hierarchy
SystemObject
AdfHttpServerContextBase
AdfHttpServerWebSocketContext

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class HttpServerWebSocketContext : HttpServerContextBase
Public Class HttpServerWebSocketContext
    Inherits HttpServerContextBase
public ref class HttpServerWebSocketContext : public HttpServerContextBase
type HttpServerWebSocketContext =
    class
        inherit HttpServerContextBase
    end

The HttpServerWebSocketContext type exposes the following members.

Constructors
 | Name | Description
Public method | HttpServerWebSocketContext | initialize new instance
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Send | 发送一个消息
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Continute | Get or set whether to continue receiving the message
Public property | Encoding | get/or set encoding (Inherited from HttpServerContextBase.)
Public property | Id | 获取连接ID
Public property | Method | Get Method (Inherited from HttpServerContextBase.)
Public property | Password | 密码 (Inherited from HttpServerContextBase.)
Public property | Path | Path (Inherited from HttpServerContextBase.)
Public property | Protocol | Protocol (Inherited from HttpServerContextBase.)
Public property | ProtocolVersion | protocol version (Inherited from HttpServerContextBase.)
Public property | QueryString | QueryString (Inherited from HttpServerContextBase.)
Public property | RequestHeader | RequestHeader (Inherited from HttpServerContextBase.)
Public property | RequestType | Request Type (Inherited from HttpServerContextBase.)
Public property | ResponseHeader | ResponseHeader (Inherited from HttpServerContextBase.)
Public property | Server | get server (Inherited from HttpServerContextBase.)
Public property | Socket | Socket
Public property | State | 自定义状态
Public property | Time | 获取连接创建时间
Public property | Url | Url (Inherited from HttpServerContextBase.)
Public property | UserName | 用户名 (Inherited from HttpServerContextBase.)
Top
Events
 | Name | Description
Public event | DataReceived | 获取或设置消息回调方法
Top
See Also

Reference


HttpServerWebSocketContext Constructor

HttpServerWebSocketContext Constructor
initialize new instance

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerWebSocketContext(
    Socket socket,
    NameValueCollection header,
    HttpServer server
)
Public Sub New (
    socket As Socket,
    header As NameValueCollection,
    server As HttpServer
)
public:
HttpServerWebSocketContext(
    Socket^ socket,
    NameValueCollection^ header,
    HttpServer^ server
)
new :
        socket : Socket *
        header : NameValueCollection *
        server : HttpServer -> HttpServerWebSocketContext

Parameters

socket
Type: System.Net.SocketsSocket

[Missing <param name="socket"/> documentation for "M:Adf.HttpServerWebSocketContext.#ctor(System.Net.Sockets.Socket,System.Collections.Specialized.NameValueCollection,Adf.HttpServer)"]

header
Type: System.Collections.SpecializedNameValueCollection

[Missing <param name="header"/> documentation for "M:Adf.HttpServerWebSocketContext.#ctor(System.Net.Sockets.Socket,System.Collections.Specialized.NameValueCollection,Adf.HttpServer)"]

server
Type: AdfHttpServer

[Missing <param name="server"/> documentation for "M:Adf.HttpServerWebSocketContext.#ctor(System.Net.Sockets.Socket,System.Collections.Specialized.NameValueCollection,Adf.HttpServer)"]

See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext Methods

HttpServerWebSocketContext Methods

The HttpServerWebSocketContext type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Send | 发送一个消息
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext.Send Method

HttpServerWebSocketContextSend Method
发送一个消息

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Send(
    string message
)
Public Sub Send (
    message As String
)
public:
void Send(
    String^ message
)
member Send :
        message : string -> unit

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Adf.HttpServerWebSocketContext.Send(System.String)"]

See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext Properties

HttpServerWebSocketContext Properties

The HttpServerWebSocketContext type exposes the following members.

Properties
 | Name | Description
Public property | Continute | Get or set whether to continue receiving the message
Public property | Encoding | get/or set encoding (Inherited from HttpServerContextBase.)
Public property | Id | 获取连接ID
Public property | Method | Get Method (Inherited from HttpServerContextBase.)
Public property | Password | 密码 (Inherited from HttpServerContextBase.)
Public property | Path | Path (Inherited from HttpServerContextBase.)
Public property | Protocol | Protocol (Inherited from HttpServerContextBase.)
Public property | ProtocolVersion | protocol version (Inherited from HttpServerContextBase.)
Public property | QueryString | QueryString (Inherited from HttpServerContextBase.)
Public property | RequestHeader | RequestHeader (Inherited from HttpServerContextBase.)
Public property | RequestType | Request Type (Inherited from HttpServerContextBase.)
Public property | ResponseHeader | ResponseHeader (Inherited from HttpServerContextBase.)
Public property | Server | get server (Inherited from HttpServerContextBase.)
Public property | Socket | Socket
Public property | State | 自定义状态
Public property | Time | 获取连接创建时间
Public property | Url | Url (Inherited from HttpServerContextBase.)
Public property | UserName | 用户名 (Inherited from HttpServerContextBase.)
Top
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext.Continute Property

HttpServerWebSocketContextContinute Property
Get or set whether to continue receiving the message

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Continute { get; set; }
Public Property Continute As Boolean
    Get
    Set
public:
property bool Continute {
    bool get ();
    void set (bool value);
}
member Continute : bool with get, set

Property Value

Type: Boolean
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext.Id Property

HttpServerWebSocketContextId Property
获取连接ID

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
public:
property String^ Id {
    String^ get ();
}
member Id : string with get

Property Value

Type: String
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext.Socket Property

HttpServerWebSocketContextSocket Property
Socket

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Socket Socket { get; }
Public ReadOnly Property Socket As Socket
    Get
public:
property Socket^ Socket {
    Socket^ get ();
}
member Socket : Socket with get

Property Value

Type: Socket
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext.State Property

HttpServerWebSocketContextState Property
自定义状态

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Object State { get; set; }
Public Property State As Object
    Get
    Set
public:
property Object^ State {
    Object^ get ();
    void set (Object^ value);
}
member State : Object with get, set

Property Value

Type: Object
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext.Time Property

HttpServerWebSocketContextTime Property
获取连接创建时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DateTime Time { get; }
Public ReadOnly Property Time As DateTime
    Get
public:
property DateTime Time {
    DateTime get ();
}
member Time : DateTime with get

Property Value

Type: DateTime
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext Events

HttpServerWebSocketContext Events

The HttpServerWebSocketContext type exposes the following members.

Events
 | Name | Description
Public event | DataReceived | 获取或设置消息回调方法
Top
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketContext.DataReceived Event

HttpServerWebSocketContextDataReceived Event
获取或设置消息回调方法

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<HttpServerWebSocketMessageEventArgs> DataReceived
Public Event DataReceived As EventHandler(Of HttpServerWebSocketMessageEventArgs)
public:
 event EventHandler<HttpServerWebSocketMessageEventArgs^>^ DataReceived {
    void add (EventHandler<HttpServerWebSocketMessageEventArgs^>^ value);
    void remove (EventHandler<HttpServerWebSocketMessageEventArgs^>^ value);
}
member DataReceived : IEvent<EventHandler<HttpServerWebSocketMessageEventArgs>,
    HttpServerWebSocketMessageEventArgs>

Value

Type: SystemEventHandler HttpServerWebSocketMessageEventArgs
See Also

Reference

HttpServerWebSocketContext Class


HttpServerWebSocketMessageEventArgs Class

HttpServerWebSocketMessageEventArgs Class
服务器消息事件
Inheritance Hierarchy
SystemObject
SystemEventArgs
AdfWebSocketMessageEventArgs
AdfHttpServerWebSocketMessageEventArgs

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class HttpServerWebSocketMessageEventArgs : WebSocketMessageEventArgs
Public Class HttpServerWebSocketMessageEventArgs
    Inherits WebSocketMessageEventArgs
public ref class HttpServerWebSocketMessageEventArgs : public WebSocketMessageEventArgs
type HttpServerWebSocketMessageEventArgs =
    class
        inherit WebSocketMessageEventArgs
    end

The HttpServerWebSocketMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | HttpServerWebSocketMessageEventArgs | 初始实例
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Buffer | 获取二进制传输时的二进制数据 (Inherited from WebSocketMessageEventArgs.)
Public property | Context | 获取上下文
Public property | Message | 获取消息体 (Inherited from WebSocketMessageEventArgs.)
Public property | Opcode | 获取消息体 Opcode (Inherited from WebSocketMessageEventArgs.)
Top
See Also

Reference


HttpServerWebSocketMessageEventArgs Constructor

HttpServerWebSocketMessageEventArgs Constructor
初始实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerWebSocketMessageEventArgs(
    HttpServerWebSocketContext context,
    WebSocketOpcode opcode
)
Public Sub New (
    context As HttpServerWebSocketContext,
    opcode As WebSocketOpcode
)
public:
HttpServerWebSocketMessageEventArgs(
    HttpServerWebSocketContext^ context,
    WebSocketOpcode opcode
)
new :
        context : HttpServerWebSocketContext *
        opcode : WebSocketOpcode -> HttpServerWebSocketMessageEventArgs

Parameters

context
Type: AdfHttpServerWebSocketContext

[Missing <param name="context"/> documentation for "M:Adf.HttpServerWebSocketMessageEventArgs.#ctor(Adf.HttpServerWebSocketContext,Adf.WebSocketOpcode)"]

opcode
Type: AdfWebSocketOpcode

[Missing <param name="opcode"/> documentation for "M:Adf.HttpServerWebSocketMessageEventArgs.#ctor(Adf.HttpServerWebSocketContext,Adf.WebSocketOpcode)"]

See Also

Reference

HttpServerWebSocketMessageEventArgs Class


HttpServerWebSocketMessageEventArgs Methods

HttpServerWebSocketMessageEventArgs Methods

The HttpServerWebSocketMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

HttpServerWebSocketMessageEventArgs Class


HttpServerWebSocketMessageEventArgs Properties

HttpServerWebSocketMessageEventArgs Properties

The HttpServerWebSocketMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | 获取二进制传输时的二进制数据 (Inherited from WebSocketMessageEventArgs.)
Public property | Context | 获取上下文
Public property | Message | 获取消息体 (Inherited from WebSocketMessageEventArgs.)
Public property | Opcode | 获取消息体 Opcode (Inherited from WebSocketMessageEventArgs.)
Top
See Also

Reference

HttpServerWebSocketMessageEventArgs Class


HttpServerWebSocketMessageEventArgs.Context Property

HttpServerWebSocketMessageEventArgsContext Property
获取上下文

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public HttpServerWebSocketContext Context { get; }
Public ReadOnly Property Context As HttpServerWebSocketContext
    Get
public:
property HttpServerWebSocketContext^ Context {
    HttpServerWebSocketContext^ get ();
}
member Context : HttpServerWebSocketContext with get

Property Value

Type: HttpServerWebSocketContext
See Also

Reference

HttpServerWebSocketMessageEventArgs Class


IBinarySerializable Interface

IBinarySerializable Interface
可序列化标记接口

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface IBinarySerializable
Public Interface IBinarySerializable
public interface class IBinarySerializable
type IBinarySerializable =  interface end

The IBinarySerializable type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | 返序例化
Public method | Serialize | 序例化
Top
See Also

Reference


IBinarySerializable Methods

IBinarySerializable Methods

The IBinarySerializable type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | 返序例化
Public method | Serialize | 序例化
Top
See Also

Reference

IBinarySerializable Interface


IBinarySerializable.Deserialize Method

IBinarySerializableDeserialize Method
返序例化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Object Deserialize(
    Type type,
    byte[] data
)
Function Deserialize (
    type As Type,
    data As Byte()
) As Object
Object^ Deserialize(
    Type^ type,
    array<unsigned char>^ data
)
abstract Deserialize :
        type : Type *
        data : byte[] -> Object

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.IBinarySerializable.Deserialize(System.Type,System.Byte[])"]

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.IBinarySerializable.Deserialize(System.Type,System.Byte[])"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.IBinarySerializable.Deserialize(System.Type,System.Byte[])"]

See Also

Reference

IBinarySerializable Interface


IBinarySerializable.Serialize Method

IBinarySerializableSerialize Method
序例化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
byte[] Serialize(
    Object value
)
Function Serialize (
    value As Object
) As Byte()
array<unsigned char>^ Serialize(
    Object^ value
)
abstract Serialize :
        value : Object -> byte[]

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.IBinarySerializable.Serialize(System.Object)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.IBinarySerializable.Serialize(System.Object)"]

See Also

Reference

IBinarySerializable Interface


ICache Interface

ICache Interface
ICache

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface ICache
Public Interface ICache
public interface class ICache
type ICache =  interface end

The ICache type exposes the following members.

Methods
 | Name | Description
Public method | Delete | delete cache
Public method | Get(String) | get cache
Public method | GetT(String) | get cache
Public method | Set | set cache
Top
See Also

Reference


ICache Methods

ICache Methods

The ICache type exposes the following members.

Methods
 | Name | Description
Public method | Delete | delete cache
Public method | Get(String) | get cache
Public method | GetT(String) | get cache
Public method | Set | set cache
Top
See Also

Reference

ICache Interface


ICache.Delete Method

ICacheDelete Method
delete cache

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
void Delete(
    string key
)
Sub Delete (
    key As String
)
void Delete(
    String^ key
)
abstract Delete :
        key : string -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ICache.Delete(System.String)"]

See Also

Reference

ICache Interface


ICache.Get Method

ICacheGet Method
Overload List
 | Name | Description
Public method | Get(String) | get cache
Public method | GetT(String) | get cache
Top
See Also

Reference

ICache Interface


ICache.Get Method (String)

ICacheGet Method (String)
get cache

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string Get(
    string key
)
Function Get (
    key As String
) As String
String^ Get(
    String^ key
)
abstract Get :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ICache.Get(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ICache.Get(System.String)"]

See Also

Reference

ICache Interface
Get Overload


ICache.Get(T) Method (String)

ICacheGetT Method (String)
get cache

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T Get<T>(
    string key
)

Function Get(Of T) (
    key As String
) As T
generic<typename T>
T Get(
    String^ key
)
abstract Get :
        key : string -> 'T

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ICache.Get``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.ICache.Get``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.ICache.Get``1(System.String)"]

See Also

Reference

ICache Interface
Get Overload


ICache.Set Method

ICacheSet Method
set cache

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
void Set(
    string key,
    Object value,
    int expires
)
Sub Set (
    key As String,
    value As Object,
    expires As Integer
)
void Set(
    String^ key,
    Object^ value,
    int expires
)
abstract Set :
        key : string *
        value : Object *
        expires : int -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.ICache.Set(System.String,System.Object,System.Int32)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.ICache.Set(System.String,System.Object,System.Int32)"]

expires
Type: SystemInt32

[Missing <param name="expires"/> documentation for "M:Adf.ICache.Set(System.String,System.Object,System.Int32)"]

See Also

Reference

ICache Interface


IpHelper Class

IpHelper Class
IP 助手
Inheritance Hierarchy
SystemObject
AdfIpHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class IpHelper
Public NotInheritable Class IpHelper
public ref class IpHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IpHelper =  class end

The IpHelper type exposes the following members.

Methods
Name | Description
IPv4ToNumber | 将IP地址转换为数值
MaskIPv4(String) | 将指定的IPv4，后两位替换为 *
MaskIPv4(String, Int32) | 将指定的IP，除指定长度外，按*显示
NumberToIPv4 | 将数值IP转换为IP地址
Top
See Also

Reference


IpHelper Methods

IpHelper Methods

The IpHelper type exposes the following members.

Methods
Name | Description
IPv4ToNumber | 将IP地址转换为数值
MaskIPv4(String) | 将指定的IPv4，后两位替换为 *
MaskIPv4(String, Int32) | 将指定的IP，除指定长度外，按*显示
NumberToIPv4 | 将数值IP转换为IP地址
Top
See Also

Reference

IpHelper Class


IpHelper.IPv4ToNumber Method

IpHelperIPv4ToNumber Method
将IP地址转换为数值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static long IPv4ToNumber(
    string ipAddress
)
Public Shared Function IPv4ToNumber (
    ipAddress As String
) As Long
public:
static long long IPv4ToNumber(
    String^ ipAddress
)
static member IPv4ToNumber :
        ipAddress : string -> int64

Parameters

ipAddress
Type: SystemString

[Missing <param name="ipAddress"/> documentation for "M:Adf.IpHelper.IPv4ToNumber(System.String)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:Adf.IpHelper.IPv4ToNumber(System.String)"]

See Also

Reference

IpHelper Class


IpHelper.MaskIPv4 Method

IpHelperMaskIPv4 Method
Overload List
Name | Description
MaskIPv4(String) | 将指定的IPv4，后两位替换为 *
MaskIPv4(String, Int32) | 将指定的IP，除指定长度外，按*显示
Top
See Also

Reference

IpHelper Class


IpHelper.MaskIPv4 Method (String)

IpHelperMaskIPv4 Method (String)
将指定的IPv4，后两位替换为 *

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string MaskIPv4(
    string ip
)
Public Shared Function MaskIPv4 (
    ip As String
) As String
public:
static String^ MaskIPv4(
    String^ ip
)
static member MaskIPv4 :
        ip : string -> string

Parameters

ip
Type: SystemString
IP地址

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.IpHelper.MaskIPv4(System.String)"]

See Also

Reference

IpHelper Class
MaskIPv4 Overload


IpHelper.MaskIPv4 Method (String, Int32)

IpHelperMaskIPv4 Method (String, Int32)
将指定的IP，除指定长度外，按*显示

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string MaskIPv4(
    string ip,
    int length
)
Public Shared Function MaskIPv4 (
    ip As String,
    length As Integer
) As String
public:
static String^ MaskIPv4(
    String^ ip,
    int length
)
static member MaskIPv4 :
        ip : string *
        length : int -> string

Parameters

ip
Type: SystemString
IP地址
length
Type: SystemInt32
显示长度

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.IpHelper.MaskIPv4(System.String,System.Int32)"]

See Also

Reference

IpHelper Class
MaskIPv4 Overload


IpHelper.NumberToIPv4 Method

IpHelperNumberToIPv4 Method
将数值IP转换为IP地址

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string NumberToIPv4(
    long ipCode
)
Public Shared Function NumberToIPv4 (
    ipCode As Long
) As String
public:
static String^ NumberToIPv4(
    long long ipCode
)
static member NumberToIPv4 :
        ipCode : int64 -> string

Parameters

ipCode
Type: SystemInt64

[Missing <param name="ipCode"/> documentation for "M:Adf.IpHelper.NumberToIPv4(System.Int64)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.IpHelper.NumberToIPv4(System.Int64)"]

See Also

Reference

IpHelper Class


IPoolInstance Interface

IPoolInstance Interface
Pool Element Interface 池实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface IPoolInstance : IDisposable
Public Interface IPoolInstance
    Inherits IDisposable
public interface class IPoolInstance : IDisposable
type IPoolInstance =
    interface
        interface IDisposable
    end

The IPoolInstance type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 执行与释放或重置非托管资源相关的应用程序定义的任务。 (Inherited from IDisposable.)
Top
Properties
 | Name | Description
Public property | PoolAbandon | 获取或设置是否废弃此实例
Top
See Also

Reference


IPoolInstance Methods

IPoolInstance Methods

The IPoolInstance type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 执行与释放或重置非托管资源相关的应用程序定义的任务。 (Inherited from IDisposable.)
Top
See Also

Reference

IPoolInstance Interface


IPoolInstance Properties

IPoolInstance Properties

The IPoolInstance type exposes the following members.

Properties
 | Name | Description
Public property | PoolAbandon | 获取或设置是否废弃此实例
Top
See Also

Reference

IPoolInstance Interface


IPoolInstance.PoolAbandon Property

IPoolInstancePoolAbandon Property
获取或设置是否废弃此实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
bool PoolAbandon { get; set; }
Property PoolAbandon As Boolean
    Get
    Set
property bool PoolAbandon {
    bool get ();
    void set (bool value);
}
abstract PoolAbandon : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPoolInstance Interface


IPoolMember Interface

IPoolMember Interface
Pool Member Info 池成员

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface IPoolMember
Public Interface IPoolMember
public interface class IPoolMember
type IPoolMember =  interface end

The IPoolMember type exposes the following members.

Methods
 | Name | Description
Public method | CreatePoolInstance | Create
Top
Properties
 | Name | Description
Public property | PoolActive | is active ,成员是否可用
Public property | PoolMemberId | Pool Member Identity
Top
See Also

Reference


IPoolMember Methods

IPoolMember Methods

The IPoolMember type exposes the following members.

Methods
 | Name | Description
Public method | CreatePoolInstance | Create
Top
See Also

Reference

IPoolMember Interface


IPoolMember.CreatePoolInstance Method

IPoolMemberCreatePoolInstance Method
Create

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
IPoolInstance CreatePoolInstance()
Function CreatePoolInstance As IPoolInstance
IPoolInstance^ CreatePoolInstance()
abstract CreatePoolInstance : unit -> IPoolInstance

Return Value

Type: IPoolInstance

[Missing <returns> documentation for "M:Adf.IPoolMember.CreatePoolInstance"]

See Also

Reference

IPoolMember Interface


IPoolMember Properties

IPoolMember Properties

The IPoolMember type exposes the following members.

Properties
 | Name | Description
Public property | PoolActive | is active ,成员是否可用
Public property | PoolMemberId | Pool Member Identity
Top
See Also

Reference

IPoolMember Interface


IPoolMember.PoolActive Property

IPoolMemberPoolActive Property
is active ,成员是否可用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
bool PoolActive { get; set; }
Property PoolActive As Boolean
    Get
    Set
property bool PoolActive {
    bool get ();
    void set (bool value);
}
abstract PoolActive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

IPoolMember Interface


IPoolMember.PoolMemberId Property

IPoolMemberPoolMemberId Property
Pool Member Identity

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string PoolMemberId { get; }
ReadOnly Property PoolMemberId As String
    Get
property String^ PoolMemberId {
    String^ get ();
}
abstract PoolMemberId : string with get

Property Value

Type: String
See Also

Reference

IPoolMember Interface


ISmtp Interface

ISmtp Interface
Smtp Helper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface ISmtp
Public Interface ISmtp
public interface class ISmtp
type ISmtp =  interface end

The ISmtp type exposes the following members.

Methods
 | Name | Description
Public method | Send | 发送邮件
Top
Properties
 | Name | Description
Public property | Account | Account
Public property | Enabled | 是否启用
Public property | Host | host
Public property | Name | Sender Name
Public property | Password | Password
Public property | Port | port
Public property | Sender | Sender
Top
See Also

Reference


ISmtp Methods

ISmtp Methods

The ISmtp type exposes the following members.

Methods
 | Name | Description
Public method | Send | 发送邮件
Top
See Also

Reference

ISmtp Interface


ISmtp.Send Method

ISmtpSend Method
发送邮件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
void Send(
    MailMessage message
)
Sub Send (
    message As MailMessage
)
void Send(
    MailMessage^ message
)
abstract Send :
        message : MailMessage -> unit

Parameters

message
Type: System.Net.MailMailMessage
消息体，若未填充From属性，则将以配置填充

Return Value

Type:
See Also

Reference

ISmtp Interface


ISmtp Properties

ISmtp Properties

The ISmtp type exposes the following members.

Properties
 | Name | Description
Public property | Account | Account
Public property | Enabled | 是否启用
Public property | Host | host
Public property | Name | Sender Name
Public property | Password | Password
Public property | Port | port
Public property | Sender | Sender
Top
See Also

Reference

ISmtp Interface


ISmtp.Account Property

ISmtpAccount Property
Account

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string Account { get; set; }
Property Account As String
    Get
    Set
property String^ Account {
    String^ get ();
    void set (String^ value);
}
abstract Account : string with get, set

Property Value

Type: String
See Also

Reference

ISmtp Interface


ISmtp.Enabled Property

ISmtpEnabled Property
是否启用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
bool Enabled { get; }
ReadOnly Property Enabled As Boolean
    Get
property bool Enabled {
    bool get ();
}
abstract Enabled : bool with get

Return Value

Type: Boolean
See Also

Reference

ISmtp Interface


ISmtp.Host Property

ISmtpHost Property
host

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string Host { get; set; }
Property Host As String
    Get
    Set
property String^ Host {
    String^ get ();
    void set (String^ value);
}
abstract Host : string with get, set

Property Value

Type: String
See Also

Reference

ISmtp Interface


ISmtp.Name Property

ISmtpName Property
Sender Name

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
property String^ Name {
    String^ get ();
    void set (String^ value);
}
abstract Name : string with get, set

Property Value

Type: String
See Also

Reference

ISmtp Interface


ISmtp.Password Property

ISmtpPassword Property
Password

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string Password { get; set; }
Property Password As String
    Get
    Set
property String^ Password {
    String^ get ();
    void set (String^ value);
}
abstract Password : string with get, set

Property Value

Type: String
See Also

Reference

ISmtp Interface


ISmtp.Port Property

ISmtpPort Property
port

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Port { get; set; }
Property Port As Integer
    Get
    Set
property int Port {
    int get ();
    void set (int value);
}
abstract Port : int with get, set

Property Value

Type: Int32
See Also

Reference

ISmtp Interface


ISmtp.Sender Property

ISmtpSender Property
Sender

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string Sender { get; set; }
Property Sender As String
    Get
    Set
property String^ Sender {
    String^ get ();
    void set (String^ value);
}
abstract Sender : string with get, set

Property Value

Type: String
See Also

Reference

ISmtp Interface


JsonBinarySerializable Class

JsonBinarySerializable Class
Json 二进制序列化实例
Inheritance Hierarchy
SystemObject
AdfJsonBinarySerializable

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class JsonBinarySerializable : IBinarySerializable
Public Class JsonBinarySerializable
    Implements IBinarySerializable
public ref class JsonBinarySerializable : IBinarySerializable
type JsonBinarySerializable =
    class
        interface IBinarySerializable
    end

The JsonBinarySerializable type exposes the following members.

Constructors
 | Name | Description
Public method | JsonBinarySerializable | 初始化新实例
Top
Methods
 | Name | Description
Public method | Deserialize | 返序列化JSON字节码为对象
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Serialize | 将指定对象转换为JSON字节码
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Encoding | 获取编码字符集
Top
See Also

Reference


JsonBinarySerializable Constructor

JsonBinarySerializable Constructor
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public JsonBinarySerializable(
    Encoding encoding
)
Public Sub New (
    encoding As Encoding
)
public:
JsonBinarySerializable(
    Encoding^ encoding
)
new :
        encoding : Encoding -> JsonBinarySerializable

Parameters

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.JsonBinarySerializable.#ctor(System.Text.Encoding)"]

See Also

Reference

JsonBinarySerializable Class


JsonBinarySerializable Methods

JsonBinarySerializable Methods

The JsonBinarySerializable type exposes the following members.

Methods
 | Name | Description
Public method | Deserialize | 返序列化JSON字节码为对象
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Serialize | 将指定对象转换为JSON字节码
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

JsonBinarySerializable Class


JsonBinarySerializable.Deserialize Method

JsonBinarySerializableDeserialize Method
返序列化JSON字节码为对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Object Deserialize(
    Type type,
    byte[] data
)
Public Function Deserialize (
    type As Type,
    data As Byte()
) As Object
public:
virtual Object^ Deserialize(
    Type^ type,
    array<unsigned char>^ data
) sealed
abstract Deserialize :
        type : Type *
        data : byte[] -> Object
override Deserialize :
        type : Type *
        data : byte[] -> Object

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.JsonBinarySerializable.Deserialize(System.Type,System.Byte[])"]

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.JsonBinarySerializable.Deserialize(System.Type,System.Byte[])"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.JsonBinarySerializable.Deserialize(System.Type,System.Byte[])"]

Implements

IBinarySerializableDeserialize(Type, Byte)
See Also

Reference

JsonBinarySerializable Class


JsonBinarySerializable.Serialize Method

JsonBinarySerializableSerialize Method
将指定对象转换为JSON字节码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] Serialize(
    Object value
)
Public Function Serialize (
    value As Object
) As Byte()
public:
virtual array<unsigned char>^ Serialize(
    Object^ value
) sealed
abstract Serialize :
        value : Object -> byte[]
override Serialize :
        value : Object -> byte[]

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.JsonBinarySerializable.Serialize(System.Object)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.JsonBinarySerializable.Serialize(System.Object)"]

Implements

IBinarySerializableSerialize(Object)
See Also

Reference

JsonBinarySerializable Class


JsonBinarySerializable Properties

JsonBinarySerializable Properties

The JsonBinarySerializable type exposes the following members.

Properties
 | Name | Description
Public property | Encoding | 获取编码字符集
Top
See Also

Reference

JsonBinarySerializable Class


JsonBinarySerializable.Encoding Property

JsonBinarySerializableEncoding Property
获取编码字符集

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; }
Public ReadOnly Property Encoding As Encoding
    Get
public:
property Encoding^ Encoding {
    Encoding^ get ();
}
member Encoding : Encoding with get

Property Value

Type: Encoding
See Also

Reference

JsonBinarySerializable Class


JsonHelper Class

JsonHelper Class
Json Helper
Inheritance Hierarchy
SystemObject
AdfJsonHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class JsonHelper
Public Class JsonHelper
public ref class JsonHelper
type JsonHelper =  class end

The JsonHelper type exposes the following members.

Constructors
 | Name | Description
Public method | JsonHelper | Initializes a new instance of the JsonHelper class
Top
Methods
 | Name | Description
 | Deserialize(String) | 返序列化
 | Deserialize(Type, String) | 返序列化为一个对象
 | DeserializeT(String) | 返序列化为一个对象
 | EncodeValue(Object, Boolean) | 编码一个值,仅支持基础数据类型
 | EncodeValue(String, Boolean) | 编码字符串
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Serialize(Object) | 序列化
 | Serialize(Object, Boolean) | 序列化
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


JsonHelper Constructor

JsonHelper Constructor
Initializes a new instance of the JsonHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public JsonHelper()
Public Sub New
public:
JsonHelper()
new : unit -> JsonHelper
See Also

Reference

JsonHelper Class


JsonHelper Methods

JsonHelper Methods

The JsonHelper type exposes the following members.

Methods
 | Name | Description
 | Deserialize(String) | 返序列化
 | Deserialize(Type, String) | 返序列化为一个对象
 | DeserializeT(String) | 返序列化为一个对象
 | EncodeValue(Object, Boolean) | 编码一个值,仅支持基础数据类型
 | EncodeValue(String, Boolean) | 编码字符串
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Serialize(Object) | 序列化
 | Serialize(Object, Boolean) | 序列化
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

JsonHelper Class


JsonHelper.Deserialize Method

JsonHelperDeserialize Method
Overload List
Name | Description
Deserialize(String) | 返序列化
DeserializeT(String) | 返序列化为一个对象
Deserialize(Type, String) | 返序列化为一个对象
Top
See Also

Reference

JsonHelper Class


JsonHelper.Deserialize Method (String)

JsonHelperDeserialize Method (String)
返序列化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Object Deserialize(
    string json
)
Public Shared Function Deserialize (
    json As String
) As Object
public:
static Object^ Deserialize(
    String^ json
)
static member Deserialize :
        json : string -> Object

Parameters

json
Type: SystemString

[Missing <param name="json"/> documentation for "M:Adf.JsonHelper.Deserialize(System.String)"]

Return Value

Type: Object
Dictionary,array
See Also

Reference

JsonHelper Class
Deserialize Overload


JsonHelper.Deserialize(T) Method (String)

JsonHelperDeserializeT Method (String)
返序列化为一个对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static T Deserialize<T>(
    string json
)

Public Shared Function Deserialize(Of T) (
    json As String
) As T
public:
generic<typename T>
static T Deserialize(
    String^ json
)
static member Deserialize :
        json : string -> 'T

Parameters

json
Type: SystemString

[Missing <param name="json"/> documentation for "M:Adf.JsonHelper.Deserialize``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.JsonHelper.Deserialize``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.JsonHelper.Deserialize``1(System.String)"]

See Also

Reference

JsonHelper Class
Deserialize Overload


JsonHelper.Deserialize Method (Type, String)

JsonHelperDeserialize Method (Type, String)
返序列化为一个对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Object Deserialize(
    Type type,
    string json
)
Public Shared Function Deserialize (
    type As Type,
    json As String
) As Object
public:
static Object^ Deserialize(
    Type^ type,
    String^ json
)
static member Deserialize :
        type : Type *
        json : string -> Object

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.JsonHelper.Deserialize(System.Type,System.String)"]

json
Type: SystemString

[Missing <param name="json"/> documentation for "M:Adf.JsonHelper.Deserialize(System.Type,System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.JsonHelper.Deserialize(System.Type,System.String)"]

See Also

Reference

JsonHelper Class
Deserialize Overload


JsonHelper.EncodeValue Method

JsonHelperEncodeValue Method
Overload List
Name | Description
EncodeValue(Object, Boolean) | 编码一个值,仅支持基础数据类型
EncodeValue(String, Boolean) | 编码字符串
Top
See Also

Reference

JsonHelper Class


JsonHelper.EncodeValue Method (Object, Boolean)

JsonHelperEncodeValue Method (Object, Boolean)
编码一个值,仅支持基础数据类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncodeValue(
    Object value,
    bool hex = true
)
Public Shared Function EncodeValue (
    value As Object,
    Optional hex As Boolean = true
) As String
public:
static String^ EncodeValue(
    Object^ value,
    bool hex = true
)
static member EncodeValue :
        value : Object *
        ?hex : bool
(* Defaults:
        let _hex = defaultArg hex true
*)
-> string

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.JsonHelper.EncodeValue(System.Object,System.Boolean)"]

hex (Optional)
Type: SystemBoolean

[Missing <param name="hex"/> documentation for "M:Adf.JsonHelper.EncodeValue(System.Object,System.Boolean)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.JsonHelper.EncodeValue(System.Object,System.Boolean)"]

See Also

Reference

JsonHelper Class
EncodeValue Overload


JsonHelper.EncodeValue Method (String, Boolean)

JsonHelperEncodeValue Method (String, Boolean)
编码字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncodeValue(
    string inputString,
    bool hex = true
)
Public Shared Function EncodeValue (
    inputString As String,
    Optional hex As Boolean = true
) As String
public:
static String^ EncodeValue(
    String^ inputString,
    bool hex = true
)
static member EncodeValue :
        inputString : string *
        ?hex : bool
(* Defaults:
        let _hex = defaultArg hex true
*)
-> string

Parameters

inputString
Type: SystemString

[Missing <param name="inputString"/> documentation for "M:Adf.JsonHelper.EncodeValue(System.String,System.Boolean)"]

hex (Optional)
Type: SystemBoolean

[Missing <param name="hex"/> documentation for "M:Adf.JsonHelper.EncodeValue(System.String,System.Boolean)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.JsonHelper.EncodeValue(System.String,System.Boolean)"]

See Also

Reference

JsonHelper Class
EncodeValue Overload


JsonHelper.Serialize Method

JsonHelperSerialize Method
Overload List
Name | Description
Serialize(Object) | 序列化
Serialize(Object, Boolean) | 序列化
Top
See Also

Reference

JsonHelper Class


JsonHelper.Serialize Method (Object)

JsonHelperSerialize Method (Object)
序列化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Serialize(
    Object value
)
Public Shared Function Serialize (
    value As Object
) As String
public:
static String^ Serialize(
    Object^ value
)
static member Serialize :
        value : Object -> string

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.JsonHelper.Serialize(System.Object)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.JsonHelper.Serialize(System.Object)"]

See Also

Reference

JsonHelper Class
Serialize Overload


JsonHelper.Serialize Method (Object, Boolean)

JsonHelperSerialize Method (Object, Boolean)
序列化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Serialize(
    Object value,
    bool hex
)
Public Shared Function Serialize (
    value As Object,
    hex As Boolean
) As String
public:
static String^ Serialize(
    Object^ value,
    bool hex
)
static member Serialize :
        value : Object *
        hex : bool -> string

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.JsonHelper.Serialize(System.Object,System.Boolean)"]

hex
Type: SystemBoolean

[Missing <param name="hex"/> documentation for "M:Adf.JsonHelper.Serialize(System.Object,System.Boolean)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.JsonHelper.Serialize(System.Object,System.Boolean)"]

See Also

Reference

JsonHelper Class
Serialize Overload


LogEventArgs Class

LogEventArgs Class
日志事件
Inheritance Hierarchy
SystemObject
SystemEventArgs
AdfLogEventArgs

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class LogEventArgs : EventArgs
Public Class LogEventArgs
    Inherits EventArgs
public ref class LogEventArgs : public EventArgs
type LogEventArgs =
    class
        inherit EventArgs
    end

The LogEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LogEventArgs | log event args
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Content | 内容
Top
See Also

Reference


LogEventArgs Constructor

LogEventArgs Constructor
log event args

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public LogEventArgs(
    string content
)
Public Sub New (
    content As String
)
public:
LogEventArgs(
    String^ content
)
new :
        content : string -> LogEventArgs

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogEventArgs.#ctor(System.String)"]

See Also

Reference

LogEventArgs Class


LogEventArgs Methods

LogEventArgs Methods

The LogEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

LogEventArgs Class


LogEventArgs Properties

LogEventArgs Properties

The LogEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Content | 内容
Top
See Also

Reference

LogEventArgs Class


LogEventArgs.Content Property

LogEventArgsContent Property
内容

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Content { get; }
Public ReadOnly Property Content As String
    Get
public:
property String^ Content {
    String^ get ();
}
member Content : string with get

Property Value

Type: String
See Also

Reference

LogEventArgs Class


LogExceptionEventArgs Class

LogExceptionEventArgs Class
记录异常事件数据
Inheritance Hierarchy
SystemObject
SystemEventArgs
AdfLogExceptionEventArgs

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class LogExceptionEventArgs : EventArgs
Public Class LogExceptionEventArgs
    Inherits EventArgs
public ref class LogExceptionEventArgs : public EventArgs
type LogExceptionEventArgs =
    class
        inherit EventArgs
    end

The LogExceptionEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | LogExceptionEventArgs | 初始化
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Exception | 异常
Top
See Also

Reference


LogExceptionEventArgs Constructor

LogExceptionEventArgs Constructor
初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public LogExceptionEventArgs(
    Exception exception
)
Public Sub New (
    exception As Exception
)
public:
LogExceptionEventArgs(
    Exception^ exception
)
new :
        exception : Exception -> LogExceptionEventArgs

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.LogExceptionEventArgs.#ctor(System.Exception)"]

See Also

Reference

LogExceptionEventArgs Class


LogExceptionEventArgs Methods

LogExceptionEventArgs Methods

The LogExceptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

LogExceptionEventArgs Class


LogExceptionEventArgs Properties

LogExceptionEventArgs Properties

The LogExceptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | 异常
Top
See Also

Reference

LogExceptionEventArgs Class


LogExceptionEventArgs.Exception Property

LogExceptionEventArgsException Property
异常

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}
member Exception : Exception with get

Property Value

Type: Exception
See Also

Reference

LogExceptionEventArgs Class


LogManager Class

LogManager Class
日志管理器,可通过Log:Disabled配置存储级别，以逗号分隔默认全开，当指定某项时则禁止, 若值为all则禁止所有日志
Inheritance Hierarchy
SystemObject
AdfLogManager
Adf.DbDbLogger

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class LogManager : IDisposable
Public Class LogManager
    Implements IDisposable
public ref class LogManager : IDisposable
type LogManager =
    class
        interface IDisposable
    end

The LogManager type exposes the following members.

Constructors
 | Name | Description
Public method | LogManager | 初始化新实例
Public method | LogManager(String) | 初始化新实例并指定名称
Top
Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Enable | 设置是否开启日志
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exception | 异常记录
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新并存储所有缓冲区内容，该方法一般在应用结束或需要批量将数据存储时使用
Protected method | ForEach | 循环当前每个日志写入器
Public method | GetExceptionWriter | get exception logmanager
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWriter | get name logwriter
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendExceptionMail | 发送异常邮件
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | WritingToConsole | console logger
Top
Properties
 | Name | Description
Public property | AllDisabled | 是否全部禁用，当配置Log:Disabled为all时此值为true
Public property | Error | 错误记录
Public property | IsOwnner | 是否具有所有者，当初始name为空时此值为false,否则为true
Public property | Message | 消息记录
Public property | Name | 名称
Public property | NewExceptionToMail | 记录新异常时是否发送至邮件（若邮件已配置）,默认开启
Public property | Path | 存储路径
Public property | ToConsole | 是否输出至Console
Public property | Warning | 警告记录
Top
Events
 | Name | Description
Public event | NewException | 新异常
Public event | Writing | 新写入事件
Top
See Also

Reference


LogManager Constructor

LogManager Constructor
Overload List
 | Name | Description
Public method | LogManager | 初始化新实例
Public method | LogManager(String) | 初始化新实例并指定名称
Top
See Also

Reference

LogManager Class


LogManager Constructor

LogManager Constructor
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public LogManager()
Public Sub New
public:
LogManager()
new : unit -> LogManager
See Also

Reference

LogManager Class
LogManager Overload


LogManager Constructor (String)

LogManager Constructor (String)
初始化新实例并指定名称

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public LogManager(
    string name
)
Public Sub New (
    name As String
)
public:
LogManager(
    String^ name
)
new :
        name : string -> LogManager

Parameters

name
Type: SystemString
名称
See Also

Reference

LogManager Class
LogManager Overload


LogManager Methods

LogManager Methods

The LogManager type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Enable | 设置是否开启日志
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exception | 异常记录
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新并存储所有缓冲区内容，该方法一般在应用结束或需要批量将数据存储时使用
Protected method | ForEach | 循环当前每个日志写入器
Public method | GetExceptionWriter | get exception logmanager
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWriter | get name logwriter
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendExceptionMail | 发送异常邮件
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | WritingToConsole | console logger
Top
See Also

Reference

LogManager Class


LogManager.Dispose Method

LogManagerDispose Method
资源释放

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LogManager Class


LogManager.Enable Method

LogManagerEnable Method
设置是否开启日志

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Enable(
    bool value
)
Public Overridable Sub Enable (
    value As Boolean
)
public:
virtual void Enable(
    bool value
)
abstract Enable :
        value : bool -> unit
override Enable :
        value : bool -> unit

Parameters

value
Type: SystemBoolean

[Missing <param name="value"/> documentation for "M:Adf.LogManager.Enable(System.Boolean)"]

See Also

Reference

LogManager Class


LogManager.Exception Method

LogManagerException Method
异常记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Exception(
    Exception exception
)
Public Overridable Sub Exception (
    exception As Exception
)
public:
virtual void Exception(
    Exception^ exception
)
abstract Exception :
        exception : Exception -> unit
override Exception :
        exception : Exception -> unit

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.LogManager.Exception(System.Exception)"]

See Also

Reference

LogManager Class


LogManager.Flush Method

LogManagerFlush Method
刷新并存储所有缓冲区内容，该方法一般在应用结束或需要批量将数据存储时使用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Flush()
Public Overridable Sub Flush
public:
virtual void Flush()
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also

Reference

LogManager Class


LogManager.ForEach Method

LogManagerForEach Method
循环当前每个日志写入器

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected void ForEach(
    Action<LogWriter> action
)
Protected Sub ForEach (
    action As Action(Of LogWriter)
)
protected:
void ForEach(
    Action<LogWriter^>^ action
)
member ForEach :
        action : Action<LogWriter> -> unit

Parameters

action
Type: SystemAction LogWriter

[Missing <param name="action"/> documentation for "M:Adf.LogManager.ForEach(System.Action{Adf.LogWriter})"]

See Also

Reference

LogManager Class


LogManager.GetExceptionWriter Method

LogManagerGetExceptionWriter Method
get exception logmanager

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual LogWriter GetExceptionWriter(
    Exception exception
)
Public Overridable Function GetExceptionWriter (
    exception As Exception
) As LogWriter
public:
virtual LogWriter^ GetExceptionWriter(
    Exception^ exception
)
abstract GetExceptionWriter :
        exception : Exception -> LogWriter
override GetExceptionWriter :
        exception : Exception -> LogWriter

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.LogManager.GetExceptionWriter(System.Exception)"]

Return Value

Type: LogWriter

[Missing <returns> documentation for "M:Adf.LogManager.GetExceptionWriter(System.Exception)"]

See Also

Reference

LogManager Class


LogManager.GetWriter Method

LogManagerGetWriter Method
get name logwriter

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual LogWriter GetWriter(
    string name
)
Public Overridable Function GetWriter (
    name As String
) As LogWriter
public:
virtual LogWriter^ GetWriter(
    String^ name
)
abstract GetWriter :
        name : string -> LogWriter
override GetWriter :
        name : string -> LogWriter

Parameters

name
Type: SystemString
No Equals(Exception Name)

Return Value

Type: LogWriter

[Missing <returns> documentation for "M:Adf.LogManager.GetWriter(System.String)"]

See Also

Reference

LogManager Class


LogManager.SendExceptionMail Method

LogManagerSendExceptionMail Method
发送异常邮件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void SendExceptionMail(
    Exception exception
)
Public Overridable Sub SendExceptionMail (
    exception As Exception
)
public:
virtual void SendExceptionMail(
    Exception^ exception
)
abstract SendExceptionMail :
        exception : Exception -> unit
override SendExceptionMail :
        exception : Exception -> unit

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.LogManager.SendExceptionMail(System.Exception)"]

See Also

Reference

LogManager Class


LogManager.WritingToConsole Method

LogManagerWritingToConsole Method
console logger

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void WritingToConsole(
    Object sender,
    LogEventArgs e
)
Protected Overridable Sub WritingToConsole (
    sender As Object,
    e As LogEventArgs
)
protected:
virtual void WritingToConsole(
    Object^ sender,
    LogEventArgs^ e
)
abstract WritingToConsole :
        sender : Object *
        e : LogEventArgs -> unit
override WritingToConsole :
        sender : Object *
        e : LogEventArgs -> unit

Parameters

sender
Type: SystemObject

[Missing <param name="sender"/> documentation for "M:Adf.LogManager.WritingToConsole(System.Object,Adf.LogEventArgs)"]

e
Type: AdfLogEventArgs

[Missing <param name="e"/> documentation for "M:Adf.LogManager.WritingToConsole(System.Object,Adf.LogEventArgs)"]

See Also

Reference

LogManager Class


LogManager Properties

LogManager Properties

The LogManager type exposes the following members.

Properties
 | Name | Description
Public property | AllDisabled | 是否全部禁用，当配置Log:Disabled为all时此值为true
Public property | Error | 错误记录
Public property | IsOwnner | 是否具有所有者，当初始name为空时此值为false,否则为true
Public property | Message | 消息记录
Public property | Name | 名称
Public property | NewExceptionToMail | 记录新异常时是否发送至邮件（若邮件已配置）,默认开启
Public property | Path | 存储路径
Public property | ToConsole | 是否输出至Console
Public property | Warning | 警告记录
Top
See Also

Reference

LogManager Class


LogManager.AllDisabled Property

LogManagerAllDisabled Property
是否全部禁用，当配置Log:Disabled为all时此值为true

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool AllDisabled { get; }
Public ReadOnly Property AllDisabled As Boolean
    Get
public:
property bool AllDisabled {
    bool get ();
}
member AllDisabled : bool with get

Property Value

Type: Boolean
See Also

Reference

LogManager Class


LogManager.Error Property

LogManagerError Property
错误记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual LogWriter Error { get; }
Public Overridable ReadOnly Property Error As LogWriter
    Get
public:
virtual property LogWriter^ Error {
    LogWriter^ get ();
}
abstract Error : LogWriter with get
override Error : LogWriter with get

Property Value

Type: LogWriter
See Also

Reference

LogManager Class


LogManager.IsOwnner Property

LogManagerIsOwnner Property
是否具有所有者，当初始name为空时此值为false,否则为true

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool IsOwnner { get; }
Public ReadOnly Property IsOwnner As Boolean
    Get
public:
property bool IsOwnner {
    bool get ();
}
member IsOwnner : bool with get

Property Value

Type: Boolean
See Also

Reference

LogManager Class


LogManager.Message Property

LogManagerMessage Property
消息记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual LogWriter Message { get; }
Public Overridable ReadOnly Property Message As LogWriter
    Get
public:
virtual property LogWriter^ Message {
    LogWriter^ get ();
}
abstract Message : LogWriter with get
override Message : LogWriter with get

Property Value

Type: LogWriter
See Also

Reference

LogManager Class


LogManager.Name Property

LogManagerName Property
名称

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get ();
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String
See Also

Reference

LogManager Class


LogManager.NewExceptionToMail Property

LogManagerNewExceptionToMail Property
记录新异常时是否发送至邮件（若邮件已配置）,默认开启

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool NewExceptionToMail { get; }
Public Overridable ReadOnly Property NewExceptionToMail As Boolean
    Get
public:
virtual property bool NewExceptionToMail {
    bool get ();
}
abstract NewExceptionToMail : bool with get
override NewExceptionToMail : bool with get

Property Value

Type: Boolean
See Also

Reference

LogManager Class


LogManager.Path Property

LogManagerPath Property
存储路径

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string Path { get; }
Public Overridable ReadOnly Property Path As String
    Get
public:
virtual property String^ Path {
    String^ get ();
}
abstract Path : string with get
override Path : string with get

Property Value

Type: String
See Also

Reference

LogManager Class


LogManager.ToConsole Property

LogManagerToConsole Property
是否输出至Console

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool ToConsole { get; set; }
Public Overridable Property ToConsole As Boolean
    Get
    Set
public:
virtual property bool ToConsole {
    bool get ();
    void set (bool value);
}
abstract ToConsole : bool with get, set
override ToConsole : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LogManager Class


LogManager.Warning Property

LogManagerWarning Property
警告记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual LogWriter Warning { get; }
Public Overridable ReadOnly Property Warning As LogWriter
    Get
public:
virtual property LogWriter^ Warning {
    LogWriter^ get ();
}
abstract Warning : LogWriter with get
override Warning : LogWriter with get

Property Value

Type: LogWriter
See Also

Reference

LogManager Class


LogManager Events

LogManager Events

The LogManager type exposes the following members.

Events
 | Name | Description
Public event | NewException | 新异常
Public event | Writing | 新写入事件
Top
See Also

Reference

LogManager Class


LogManager.NewException Event

LogManagerNewException Event
新异常

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual event EventHandler<LogExceptionEventArgs> NewException
Public Overridable Event NewException As EventHandler(Of LogExceptionEventArgs)
public:
virtual  event EventHandler<LogExceptionEventArgs^>^ NewException {
    void add (EventHandler<LogExceptionEventArgs^>^ value);
    void remove (EventHandler<LogExceptionEventArgs^>^ value);
}
abstract NewException : IEvent<EventHandler<LogExceptionEventArgs>,
    LogExceptionEventArgs>
override NewException : IEvent<EventHandler<LogExceptionEventArgs>,
    LogExceptionEventArgs>

Value

Type: SystemEventHandler LogExceptionEventArgs
See Also

Reference

LogManager Class


LogManager.Writing Event

LogManagerWriting Event
新写入事件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual event EventHandler<LogEventArgs> Writing
Public Overridable Event Writing As EventHandler(Of LogEventArgs)
public:
virtual  event EventHandler<LogEventArgs^>^ Writing {
    void add (EventHandler<LogEventArgs^>^ value);
    void remove (EventHandler<LogEventArgs^>^ value);
}
abstract Writing : IEvent<EventHandler<LogEventArgs>,
    LogEventArgs>
override Writing : IEvent<EventHandler<LogEventArgs>,
    LogEventArgs>

Value

Type: SystemEventHandler LogEventArgs
See Also

Reference

LogManager Class


LogWriter Class

LogWriter Class
日志书写器
Inheritance Hierarchy
SystemObject
AdfLogWriter

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class LogWriter : IDisposable
Public Class LogWriter
    Implements IDisposable
public ref class LogWriter : IDisposable
type LogWriter =
    class
        interface IDisposable
    end

The LogWriter type exposes the following members.

Constructors
 | Name | Description
Public method | LogWriter(String) | 初始化,若配置(AppSetting)Log:Path则为配置值，否则以当前应用程序目录下Log为目录
Public method | LogWriter(String, String) | 初始化
Top
Methods
 | Name | Description
Protected method | BuildPath | 获取日志路径
Protected method | BuildPath(String) | 获取日志路径
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新缓冲区
Protected method | Flush(String, String) | 刷新缓冲区
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Line | Obsolete. 写入空行
Public method | Line(String, Object) | Obsolete. 按行写入记录
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnWriting | 触发写入事件
Public method | Pack | Obsolete. 记录一个打包的格式化日志记录
Public method | TimeLine | Obsolete. 以时间起始的行
Protected method | TimerCallback | 缓冲区刷新回调
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write | 写入内容
Public method | WriteLine | 写入空行
Public method | WriteLine(String, Object) | 按行写入记录
Public method | WritePack | 记录一个打包的格式化日志记录
Public method | WriteTimeLine | 以时间起始的行
Top
Properties
 | Name | Description
Public property | Enable | 是否启用
Public property | Encoding | 字符编码, 默认UTF8
Public property | Extension | 日志文件扩展名,带点
Public property | FlushInterval | 存储时间间隔（秒:seconds),0 则实时flush, 默认配置： Log:FlushInterval
Public property | Manager | 管理器
Public property | Name | 日志名称
Public property | Path | 存储路径
Top
Events
 | Name | Description
Public event | Writing | 新写入事件
Top
See Also

Reference


LogWriter Constructor

LogWriter Constructor
Overload List
 | Name | Description
Public method | LogWriter(String) | 初始化,若配置(AppSetting)Log:Path则为配置值，否则以当前应用程序目录下Log为目录
Public method | LogWriter(String, String) | 初始化
Top
See Also

Reference

LogWriter Class


LogWriter Constructor (String)

LogWriter Constructor (String)
初始化,若配置(AppSetting)Log:Path则为配置值，否则以当前应用程序目录下Log为目录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public LogWriter(
    string name
)
Public Sub New (
    name As String
)
public:
LogWriter(
    String^ name
)
new :
        name : string -> LogWriter

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.LogWriter.#ctor(System.String)"]

See Also

Reference

LogWriter Class
LogWriter Overload


LogWriter Constructor (String, String)

LogWriter Constructor (String, String)
初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public LogWriter(
    string name,
    string path
)
Public Sub New (
    name As String,
    path As String
)
public:
LogWriter(
    String^ name,
    String^ path
)
new :
        name : string *
        path : string -> LogWriter

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.LogWriter.#ctor(System.String,System.String)"]

path
Type: SystemString
当为Null Or Empty时，若配置(AppSetting)Log:Path:name或Log:Path则为配置值，否则以当前应用程序目录下Log为目录
See Also

Reference

LogWriter Class
LogWriter Overload


LogWriter Methods

LogWriter Methods

The LogWriter type exposes the following members.

Methods
 | Name | Description
Protected method | BuildPath | 获取日志路径
Protected method | BuildPath(String) | 获取日志路径
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新缓冲区
Protected method | Flush(String, String) | 刷新缓冲区
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Line | Obsolete. 写入空行
Public method | Line(String, Object) | Obsolete. 按行写入记录
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnWriting | 触发写入事件
Public method | Pack | Obsolete. 记录一个打包的格式化日志记录
Public method | TimeLine | Obsolete. 以时间起始的行
Protected method | TimerCallback | 缓冲区刷新回调
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write | 写入内容
Public method | WriteLine | 写入空行
Public method | WriteLine(String, Object) | 按行写入记录
Public method | WritePack | 记录一个打包的格式化日志记录
Public method | WriteTimeLine | 以时间起始的行
Top
See Also

Reference

LogWriter Class


LogWriter.BuildPath Method

LogWriterBuildPath Method
Overload List
 | Name | Description
Protected method | BuildPath | 获取日志路径
Protected method | BuildPath(String) | 获取日志路径
Top
See Also

Reference

LogWriter Class


LogWriter.BuildPath Method

LogWriterBuildPath Method
获取日志路径

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual string BuildPath()
Protected Overridable Function BuildPath As String
protected:
virtual String^ BuildPath()
abstract BuildPath : unit -> string
override BuildPath : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.LogWriter.BuildPath"]

See Also

Reference

LogWriter Class
BuildPath Overload


LogWriter.BuildPath Method (String)

LogWriterBuildPath Method (String)
获取日志路径

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual string BuildPath(
    string name
)
Protected Overridable Function BuildPath (
    name As String
) As String
protected:
virtual String^ BuildPath(
    String^ name
)
abstract BuildPath :
        name : string -> string
override BuildPath :
        name : string -> string

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.LogWriter.BuildPath(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.LogWriter.BuildPath(System.String)"]

See Also

Reference

LogWriter Class
BuildPath Overload


LogWriter.Dispose Method

LogWriterDispose Method
资源释放

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Dispose()
Public Overridable Sub Dispose
public:
virtual void Dispose()
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

LogWriter Class


LogWriter.Flush Method

LogWriterFlush Method
Overload List
 | Name | Description
Public method | Flush | 刷新缓冲区
Protected method | Flush(String, String) | 刷新缓冲区
Top
See Also

Reference

LogWriter Class


LogWriter.Flush Method

LogWriterFlush Method
刷新缓冲区

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Flush()
Public Overridable Sub Flush
public:
virtual void Flush()
abstract Flush : unit -> unit
override Flush : unit -> unit
See Also

Reference

LogWriter Class
Flush Overload


LogWriter.Flush Method (String, String)

LogWriterFlush Method (String, String)
刷新缓冲区

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected void Flush(
    string path,
    string content
)
Protected Sub Flush (
    path As String,
    content As String
)
protected:
void Flush(
    String^ path,
    String^ content
)
member Flush :
        path : string *
        content : string -> unit

Parameters

path
Type: SystemString

[Missing <param name="path"/> documentation for "M:Adf.LogWriter.Flush(System.String,System.String)"]

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.Flush(System.String,System.String)"]

See Also

Reference

LogWriter Class
Flush Overload


LogWriter.Line Method

LogWriterLine Method
Overload List
 | Name | Description
Public method | Line | Obsolete. 写入空行
Public method | Line(String, Object) | Obsolete. 按行写入记录
Top
See Also

Reference

LogWriter Class


LogWriter.Line Method

LogWriterLine Method

Note: This API is now obsolete.

写入空行

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("方法已过时，请使用: WriteLine")]
public void Line()
<ObsoleteAttribute("方法已过时，请使用: WriteLine")>
Public Sub Line
public:
[ObsoleteAttribute(L"方法已过时，请使用: WriteLine")]
void Line()
[<ObsoleteAttribute("方法已过时，请使用: WriteLine")>]
member Line : unit -> unit
See Also

Reference

LogWriter Class
Line Overload


LogWriter.Line Method (String, Object[])

LogWriterLine Method (String, Object)

Note: This API is now obsolete.

按行写入记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("方法已过时，请使用: WriteLine")]
public virtual void Line(
    string content,
    params Object[] args
)
<ObsoleteAttribute("方法已过时，请使用: WriteLine")>
Public Overridable Sub Line (
    content As String,
    ParamArray args As Object()
)
public:
[ObsoleteAttribute(L"方法已过时，请使用: WriteLine")]
virtual void Line(
    String^ content,
    ... array<Object^>^ args
)
[<ObsoleteAttribute("方法已过时，请使用: WriteLine")>]
abstract Line :
        content : string *
        args : Object[] -> unit
[<ObsoleteAttribute("方法已过时，请使用: WriteLine")>]
override Line :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.Line(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.LogWriter.Line(System.String,System.Object[])"]

See Also

Reference

LogWriter Class
Line Overload


LogWriter.OnWriting Method

LogWriterOnWriting Method
触发写入事件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnWriting(
    string content
)
Protected Overridable Sub OnWriting (
    content As String
)
protected:
virtual void OnWriting(
    String^ content
)
abstract OnWriting :
        content : string -> unit
override OnWriting :
        content : string -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.OnWriting(System.String)"]

See Also

Reference

LogWriter Class


LogWriter.Pack Method

LogWriterPack Method

Note: This API is now obsolete.

记录一个打包的格式化日志记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("方法已过时，请使用: WritePack")]
public virtual void Pack(
    string content,
    params Object[] args
)
<ObsoleteAttribute("方法已过时，请使用: WritePack")>
Public Overridable Sub Pack (
    content As String,
    ParamArray args As Object()
)
public:
[ObsoleteAttribute(L"方法已过时，请使用: WritePack")]
virtual void Pack(
    String^ content,
    ... array<Object^>^ args
)
[<ObsoleteAttribute("方法已过时，请使用: WritePack")>]
abstract Pack :
        content : string *
        args : Object[] -> unit
[<ObsoleteAttribute("方法已过时，请使用: WritePack")>]
override Pack :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.Pack(System.String,System.Object[])"]

args
Type: SystemObject
内容格式化串
See Also

Reference

LogWriter Class


LogWriter.TimeLine Method

LogWriterTimeLine Method

Note: This API is now obsolete.

以时间起始的行

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("方法已过时，请使用: WriteTimeLine")]
public virtual void TimeLine(
    string content,
    params Object[] args
)
<ObsoleteAttribute("方法已过时，请使用: WriteTimeLine")>
Public Overridable Sub TimeLine (
    content As String,
    ParamArray args As Object()
)
public:
[ObsoleteAttribute(L"方法已过时，请使用: WriteTimeLine")]
virtual void TimeLine(
    String^ content,
    ... array<Object^>^ args
)
[<ObsoleteAttribute("方法已过时，请使用: WriteTimeLine")>]
abstract TimeLine :
        content : string *
        args : Object[] -> unit
[<ObsoleteAttribute("方法已过时，请使用: WriteTimeLine")>]
override TimeLine :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.TimeLine(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.LogWriter.TimeLine(System.String,System.Object[])"]

See Also

Reference

LogWriter Class


LogWriter.TimerCallback Method

LogWriterTimerCallback Method
缓冲区刷新回调

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void TimerCallback(
    Object obj
)
Protected Overridable Sub TimerCallback (
    obj As Object
)
protected:
virtual void TimerCallback(
    Object^ obj
)
abstract TimerCallback :
        obj : Object -> unit
override TimerCallback :
        obj : Object -> unit

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Adf.LogWriter.TimerCallback(System.Object)"]

See Also

Reference

LogWriter Class


LogWriter.Write Method

LogWriterWrite Method
写入内容

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Write(
    string content,
    params Object[] args
)
Public Overridable Sub Write (
    content As String,
    ParamArray args As Object()
)
public:
virtual void Write(
    String^ content,
    ... array<Object^>^ args
)
abstract Write :
        content : string *
        args : Object[] -> unit
override Write :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.Write(System.String,System.Object[])"]

args
Type: SystemObject
格式化数据
Exceptions
Exception | Condition
ObjectDisposedException |
See Also

Reference

LogWriter Class


LogWriter.WriteLine Method

LogWriterWriteLine Method
Overload List
 | Name | Description
Public method | WriteLine | 写入空行
Public method | WriteLine(String, Object) | 按行写入记录
Top
See Also

Reference

LogWriter Class


LogWriter.WriteLine Method

LogWriterWriteLine Method
写入空行

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void WriteLine()
Public Sub WriteLine
public:
void WriteLine()
member WriteLine : unit -> unit
See Also

Reference

LogWriter Class
WriteLine Overload


LogWriter.WriteLine Method (String, Object[])

LogWriterWriteLine Method (String, Object)
按行写入记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void WriteLine(
    string content,
    params Object[] args
)
Public Overridable Sub WriteLine (
    content As String,
    ParamArray args As Object()
)
public:
virtual void WriteLine(
    String^ content,
    ... array<Object^>^ args
)
abstract WriteLine :
        content : string *
        args : Object[] -> unit
override WriteLine :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.WriteLine(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.LogWriter.WriteLine(System.String,System.Object[])"]

See Also

Reference

LogWriter Class
WriteLine Overload


LogWriter.WritePack Method

LogWriterWritePack Method
记录一个打包的格式化日志记录

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void WritePack(
    string content,
    params Object[] args
)
Public Overridable Sub WritePack (
    content As String,
    ParamArray args As Object()
)
public:
virtual void WritePack(
    String^ content,
    ... array<Object^>^ args
)
abstract WritePack :
        content : string *
        args : Object[] -> unit
override WritePack :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.WritePack(System.String,System.Object[])"]

args
Type: SystemObject
内容格式化串
See Also

Reference

LogWriter Class


LogWriter.WriteTimeLine Method

LogWriterWriteTimeLine Method
以时间起始的行

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void WriteTimeLine(
    string content,
    params Object[] args
)
Public Overridable Sub WriteTimeLine (
    content As String,
    ParamArray args As Object()
)
public:
virtual void WriteTimeLine(
    String^ content,
    ... array<Object^>^ args
)
abstract WriteTimeLine :
        content : string *
        args : Object[] -> unit
override WriteTimeLine :
        content : string *
        args : Object[] -> unit

Parameters

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.LogWriter.WriteTimeLine(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.LogWriter.WriteTimeLine(System.String,System.Object[])"]

See Also

Reference

LogWriter Class


LogWriter Properties

LogWriter Properties

The LogWriter type exposes the following members.

Properties
 | Name | Description
Public property | Enable | 是否启用
Public property | Encoding | 字符编码, 默认UTF8
Public property | Extension | 日志文件扩展名,带点
Public property | FlushInterval | 存储时间间隔（秒:seconds),0 则实时flush, 默认配置： Log:FlushInterval
Public property | Manager | 管理器
Public property | Name | 日志名称
Public property | Path | 存储路径
Top
See Also

Reference

LogWriter Class


LogWriter.Enable Property

LogWriterEnable Property
是否启用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Enable { get; set; }
Public Property Enable As Boolean
    Get
    Set
public:
property bool Enable {
    bool get ();
    void set (bool value);
}
member Enable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

LogWriter Class


LogWriter.Encoding Property

LogWriterEncoding Property
字符编码, 默认UTF8

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set

Property Value

Type: Encoding
See Also

Reference

LogWriter Class


LogWriter.Extension Property

LogWriterExtension Property
日志文件扩展名,带点

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Extension { get; set; }
Public Property Extension As String
    Get
    Set
public:
property String^ Extension {
    String^ get ();
    void set (String^ value);
}
member Extension : string with get, set

Property Value

Type: String
See Also

Reference

LogWriter Class


LogWriter.FlushInterval Property

LogWriterFlushInterval Property
存储时间间隔（秒:seconds),0 则实时flush, 默认配置： Log:FlushInterval

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int FlushInterval { get; set; }
Public Property FlushInterval As Integer
    Get
    Set
public:
property int FlushInterval {
    int get ();
    void set (int value);
}
member FlushInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

LogWriter Class


LogWriter.Manager Property

LogWriterManager Property
管理器

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public LogManager Manager { get; }
Public ReadOnly Property Manager As LogManager
    Get
public:
property LogManager^ Manager {
    LogManager^ get ();
}
member Manager : LogManager with get

Property Value

Type: LogManager
See Also

Reference

LogWriter Class


LogWriter.Name Property

LogWriterName Property
日志名称

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

LogWriter Class


LogWriter.Path Property

LogWriterPath Property
存储路径

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

LogWriter Class


LogWriter Events

LogWriter Events

The LogWriter type exposes the following members.

Events
 | Name | Description
Public event | Writing | 新写入事件
Top
See Also

Reference

LogWriter Class


LogWriter.Writing Event

LogWriterWriting Event
新写入事件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<LogEventArgs> Writing
Public Event Writing As EventHandler(Of LogEventArgs)
public:
 event EventHandler<LogEventArgs^>^ Writing {
    void add (EventHandler<LogEventArgs^>^ value);
    void remove (EventHandler<LogEventArgs^>^ value);
}
member Writing : IEvent<EventHandler<LogEventArgs>,
    LogEventArgs>

Value

Type: SystemEventHandler LogEventArgs
See Also

Reference

LogWriter Class


MD5Helper Class

MD5Helper Class
编码助手
Inheritance Hierarchy
SystemObject
AdfMD5Helper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class MD5Helper
Public NotInheritable Class MD5Helper
public ref class MD5Helper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MD5Helper =  class end

The MD5Helper type exposes the following members.

Methods
Name | Description
MD5(String) | MD5 encodes the passed string
MD5(String, Encoding) | MD5 encodes the passed string
Top
Fields
Name | Description
Encoding | MD5默认字符编码，默认为 ASCII
Top
See Also

Reference


MD5Helper Fields

MD5Helper Fields

The MD5Helper type exposes the following members.

Fields
Name | Description
Encoding | MD5默认字符编码，默认为 ASCII
Top
See Also

Reference

MD5Helper Class


MD5Helper.Encoding Field

MD5HelperEncoding Field
MD5默认字符编码，默认为 ASCII

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Encoding Encoding
Public Shared ReadOnly Encoding As Encoding
public:
static initonly Encoding^ Encoding
static val Encoding: Encoding

Field Value

Type: Encoding
See Also

Reference

MD5Helper Class


MD5Helper Methods

MD5Helper Methods
Methods
Name | Description
MD5(String) | MD5 encodes the passed string
MD5(String, Encoding) | MD5 encodes the passed string
Top
See Also

Reference

MD5Helper Class


MD5Helper.MD5 Method

MD5HelperMD5 Method
Overload List
Name | Description
MD5(String) | MD5 encodes the passed string
MD5(String, Encoding) | MD5 encodes the passed string
Top
See Also

Reference

MD5Helper Class


MD5Helper.MD5 Method (String)

MD5HelperMD5 Method (String)
MD5 encodes the passed string

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string MD5(
    string input
)
Public Shared Function MD5 (
    input As String
) As String
public:
static String^ MD5(
    String^ input
)
static member MD5 :
        input : string -> string

Parameters

input
Type: SystemString
The string to encode.

Return Value

Type: String
An encoded string.
See Also

Reference

MD5Helper Class
MD5 Overload


MD5Helper.MD5 Method (String, Encoding)

MD5HelperMD5 Method (String, Encoding)
MD5 encodes the passed string

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string MD5(
    string input,
    Encoding encoding
)
Public Shared Function MD5 (
    input As String,
    encoding As Encoding
) As String
public:
static String^ MD5(
    String^ input,
    Encoding^ encoding
)
static member MD5 :
        input : string *
        encoding : Encoding -> string

Parameters

input
Type: SystemString
The string to encode.
encoding
Type: System.TextEncoding
encoding

Return Value

Type: String
An encoded string.
See Also

Reference

MD5Helper Class
MD5 Overload


Memcache Class

Memcache Class
Supports setting, adding, replacing, deleting compressed/uncompressed and serialized (can be stored as string if object is native class) objects to memcached.
Inheritance Hierarchy
SystemObject
AdfMemcache

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Memcache : ICache, IPoolInstance,
    IDisposable
Public Class Memcache
    Implements ICache, IPoolInstance, IDisposable
public ref class Memcache : ICache,
    IPoolInstance, IDisposable
type Memcache =
    class
        interface ICache
        interface IPoolInstance
        interface IDisposable
    end

The Memcache type exposes the following members.

Constructors
 | Name | Description
Public method | Memcache(String, Int32) | 初始化新实例
Public method | Memcache(String, Int32, Encoding) | 初始化新实例
Top
Methods
 | Name | Description
Public method | Add(String, Object) | Adds data to the server; only the key and the value are specified.
Public method | Add(String, Object, DateTime) | Adds data to the server; the key, value, and an expiration time are specified.
Public method | ClearEndOfLine | reads up to end of line and returns nothing
Public method | Decrement(String) | Decrement the value at the specified key by 1, and then return it.
Public method | Decrement(String, Int64) | Decrement the value at the specified key by passed in value, and then return it.
Public method | Delete(String) | Deletes an object from cache given cache key.
Public method | Delete(String, DateTime) | Deletes an object from cache given cache key, a delete time, and an optional hashcode. The item is immediately made non retrievable. Keep in mind: add(string, object) and replace(string, object) will fail when used with the same key will fail, until the server reaches the specified time. However, set(string, object) will succeed and the new value will not be deleted.
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | flushes output stream
Public method | FlushAll | Invalidates the entire cache. Will return true only if succeeds in clearing all servers.
Public method | Get(String) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | Get(String, Type) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | GetT(String) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | GetCounter | Returns value in counter at given key as long.
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Increment(String) | Increment the value at the specified key by 1, and then return it.
Public method | Increment(String, Int64) | Increment the value at the specified key by passed in val.
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Read | reads length bytes into the passed in byte array from stream
Public method | ReadLine | reads a line intentionally not using the deprecated readLine method from DataInputStream
Public method | Replace(String, Object) | Updates data on the server; only the key and the value are specified.
Public method | Replace(String, Object, DateTime) | Updates data on the server; the key, value, and an expiration time are specified.
Public method | Set(String, Object) | Stores data on the server; only the key and the value are specified.
Public method | Set(String, Object, DateTime) | Stores data on the server; the key, value, and an expiration time are specified.
Public method | Set(String, Object, Int32) | 设置数据
Public method | Stats | Retrieves stats for passed in servers (or all servers). Returns a map keyed on the servername. The value is another map which contains stats with stat name as key and value as value.
Public method | StoreCounter(String, Int64) | Store a counter to memcached given a key
Public method | StoreCounter(String, Int64, Int32) | Store a counter to memcached given a key
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write(Byte) | writes a byte array to the output stream
Public method | Write(Byte, Int32, Int32) | writes a byte array to the output stream
Top
Properties
 | Name | Description
Public property | BinarySerializable | 获取或设置二进制序列化器,默认 JsonBinarySerializable, 可通过在appsetting中配置 MemcacheBinarySerializable 来指定其它实例
Public property | CompressionThreshold | Sets the required length for data to be considered for compression. If the length of the data to be stored is not equal or larger than this value, it will not be compressed. This defaults to 15 KB.
Public property | EnableCompression | Enable storing compressed data, provided it meets the threshold requirements. If enabled, data will be stored in compressed form if it is longer than the threshold length set with setCompressThreshold(int) The default is that compression is enabled. Even if compression is disabled, compressed data will be automatically decompressed.
Public property | Encoding | Sets default string encoding when storing primitives as strings. Default is UTF-8.
Public property | Host | 主机
Public property | IsConnected | Gets whether or not the socket is connected. Returns true if it is.
Public property | PoolAbandon | 获取或设置是否放弃此实例
Public property | Port | 端口
Public property | SendTimeout | 发送超时
Top
Examples
//***To create cache client object and set params:***
Memcache mc = new Memcache();

// compression is enabled by default
mc.setCompressEnable(true);

// set compression threshhold to 4 KB (default: 15 KB)
mc.setCompressThreshold(4096);

//***To store an object:***
Memcache mc = new Memcache();
string key   = "cacheKey1";
object value = SomeClass.getObject();
mc.set(key, value);

//***To store an object using a custom server hashCode:***
//The set method shown here will always set the object in the cache.
//The add and replace methods do the same, but with a slight difference.
//  add -- will store the object only if the server does not have an entry for this key
//  replace -- will store the object only if the server already has an entry for this key
Memcache mc = new Memcache();
string key   = "cacheKey1";
object value = SomeClass.getObject();
int hash = 45;
mc.set(key, value, hash);

//***To delete a cache entry:***
Memcache mc = new Memcache();
string key   = "cacheKey1";
mc.delete(key);

//***To delete a cache entry using a custom hash code:***
Memcache mc = new Memcache();
string key   = "cacheKey1";
int hash = 45;
mc.delete(key, hashCode);

//***To store a counter and then increment or decrement that counter:***
Memcache mc = new Memcache();
string key   = "counterKey";
mc.storeCounter(key, 100);
Console.WriteLine("counter after adding      1: " mc.incr(key));
Console.WriteLine("counter after adding      5: " mc.incr(key, 5));
Console.WriteLine("counter after subtracting 4: " mc.decr(key, 4));
Console.WriteLine("counter after subtracting 1: " mc.decr(key));

//***To store a counter and then increment or decrement that counter with custom hash:***
Memcache mc = new Memcache();
string key   = "counterKey";
int hash = 45;
mc.storeCounter(key, 100, hash);
Console.WriteLine("counter after adding      1: " mc.incr(key, 1, hash));
Console.WriteLine("counter after adding      5: " mc.incr(key, 5, hash));
Console.WriteLine("counter after subtracting 4: " mc.decr(key, 4, hash));
Console.WriteLine("counter after subtracting 1: " mc.decr(key, 1, hash));

//***To retrieve an object from the cache:***
Memcache mc = new Memcache();
string key   = "key";
object value = mc.get(key);

//***To retrieve an object from the cache with custom hash:***
Memcache mc = new Memcache();
string key   = "key";
int hash = 45;
object value = mc.get(key, hash);

//***To retrieve an multiple objects from the cache***
Memcache mc = new Memcache();
string[] keys   = { "key", "key1", "key2" };
object value = mc.getMulti(keys);

//***To retrieve an multiple objects from the cache with custom hashing***
Memcache mc = new Memcache();
string[] keys    = { "key", "key1", "key2" };
int[] hashes = { 45, 32, 44 };
object value = mc.getMulti(keys, hashes);

//***To flush all items in server(s)***
Memcache mc = new Memcache();
mc.FlushAll();

//***To get stats from server(s)***
Memcache mc = new Memcache();
Hashtable stats = mc.stats();
See Also

Reference


Memcache Constructor

Memcache Constructor
Overload List
 | Name | Description
Public method | Memcache(String, Int32) | 初始化新实例
Public method | Memcache(String, Int32, Encoding) | 初始化新实例
Top
See Also

Reference

Memcache Class


Memcache Constructor (String, Int32)

Memcache Constructor (String, Int32)
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Memcache(
    string host,
    int port
)
Public Sub New (
    host As String,
    port As Integer
)
public:
Memcache(
    String^ host,
    int port
)
new :
        host : string *
        port : int -> Memcache

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.Memcache.#ctor(System.String,System.Int32)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.Memcache.#ctor(System.String,System.Int32)"]

See Also

Reference

Memcache Class
Memcache Overload


Memcache Constructor (String, Int32, Encoding)

Memcache Constructor (String, Int32, Encoding)
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Memcache(
    string host,
    int port,
    Encoding encoding
)
Public Sub New (
    host As String,
    port As Integer,
    encoding As Encoding
)
public:
Memcache(
    String^ host,
    int port,
    Encoding^ encoding
)
new :
        host : string *
        port : int *
        encoding : Encoding -> Memcache

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.Memcache.#ctor(System.String,System.Int32,System.Text.Encoding)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.Memcache.#ctor(System.String,System.Int32,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.Memcache.#ctor(System.String,System.Int32,System.Text.Encoding)"]

See Also

Reference

Memcache Class
Memcache Overload


Memcache Methods

Memcache Methods

The Memcache type exposes the following members.

Methods
 | Name | Description
Public method | Add(String, Object) | Adds data to the server; only the key and the value are specified.
Public method | Add(String, Object, DateTime) | Adds data to the server; the key, value, and an expiration time are specified.
Public method | ClearEndOfLine | reads up to end of line and returns nothing
Public method | Decrement(String) | Decrement the value at the specified key by 1, and then return it.
Public method | Decrement(String, Int64) | Decrement the value at the specified key by passed in value, and then return it.
Public method | Delete(String) | Deletes an object from cache given cache key.
Public method | Delete(String, DateTime) | Deletes an object from cache given cache key, a delete time, and an optional hashcode. The item is immediately made non retrievable. Keep in mind: add(string, object) and replace(string, object) will fail when used with the same key will fail, until the server reaches the specified time. However, set(string, object) will succeed and the new value will not be deleted.
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | flushes output stream
Public method | FlushAll | Invalidates the entire cache. Will return true only if succeeds in clearing all servers.
Public method | Get(String) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | Get(String, Type) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | GetT(String) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | GetCounter | Returns value in counter at given key as long.
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Increment(String) | Increment the value at the specified key by 1, and then return it.
Public method | Increment(String, Int64) | Increment the value at the specified key by passed in val.
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Read | reads length bytes into the passed in byte array from stream
Public method | ReadLine | reads a line intentionally not using the deprecated readLine method from DataInputStream
Public method | Replace(String, Object) | Updates data on the server; only the key and the value are specified.
Public method | Replace(String, Object, DateTime) | Updates data on the server; the key, value, and an expiration time are specified.
Public method | Set(String, Object) | Stores data on the server; only the key and the value are specified.
Public method | Set(String, Object, DateTime) | Stores data on the server; the key, value, and an expiration time are specified.
Public method | Set(String, Object, Int32) | 设置数据
Public method | Stats | Retrieves stats for passed in servers (or all servers). Returns a map keyed on the servername. The value is another map which contains stats with stat name as key and value as value.
Public method | StoreCounter(String, Int64) | Store a counter to memcached given a key
Public method | StoreCounter(String, Int64, Int32) | Store a counter to memcached given a key
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write(Byte) | writes a byte array to the output stream
Public method | Write(Byte, Int32, Int32) | writes a byte array to the output stream
Top
See Also

Reference

Memcache Class


Memcache.Add Method

MemcacheAdd Method
Overload List
 | Name | Description
Public method | Add(String, Object) | Adds data to the server; only the key and the value are specified.
Public method | Add(String, Object, DateTime) | Adds data to the server; the key, value, and an expiration time are specified.
Top
See Also

Reference

Memcache Class


Memcache.Add Method (String, Object)

MemcacheAdd Method (String, Object)
Adds data to the server; only the key and the value are specified.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    string key,
    Object value
)
Public Function Add (
    key As String,
    value As Object
) As Boolean
public:
bool Add(
    String^ key,
    Object^ value
)
member Add :
        key : string *
        value : Object -> bool

Parameters

key
Type: SystemString
key to store data under
value
Type: SystemObject
value to store

Return Value

Type: Boolean
true, if the data was successfully stored
See Also

Reference

Memcache Class
Add Overload


Memcache.Add Method (String, Object, DateTime)

MemcacheAdd Method (String, Object, DateTime)
Adds data to the server; the key, value, and an expiration time are specified.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Add(
    string key,
    Object value,
    DateTime expiry
)
Public Function Add (
    key As String,
    value As Object,
    expiry As DateTime
) As Boolean
public:
bool Add(
    String^ key,
    Object^ value,
    DateTime expiry
)
member Add :
        key : string *
        value : Object *
        expiry : DateTime -> bool

Parameters

key
Type: SystemString
key to store data under
value
Type: SystemObject
value to store
expiry
Type: SystemDateTime
when to expire the record

Return Value

Type: Boolean
true, if the data was successfully stored
See Also

Reference

Memcache Class
Add Overload


Memcache.ClearEndOfLine Method

MemcacheClearEndOfLine Method
reads up to end of line and returns nothing

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void ClearEndOfLine()
Public Sub ClearEndOfLine
public:
void ClearEndOfLine()
member ClearEndOfLine : unit -> unit
See Also

Reference

Memcache Class


Memcache.Decrement Method

MemcacheDecrement Method
Overload List
 | Name | Description
Public method | Decrement(String) | Decrement the value at the specified key by 1, and then return it.
Public method | Decrement(String, Int64) | Decrement the value at the specified key by passed in value, and then return it.
Top
See Also

Reference

Memcache Class


Memcache.Decrement Method (String)

MemcacheDecrement Method (String)
Decrement the value at the specified key by 1, and then return it.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long Decrement(
    string key
)
Public Function Decrement (
    key As String
) As Long
public:
long long Decrement(
    String^ key
)
member Decrement :
        key : string -> int64

Parameters

key
Type: SystemString
key where the data is stored

Return Value

Type: Int64
-1, if the key is not found, the value after incrementing otherwise
See Also

Reference

Memcache Class
Decrement Overload


Memcache.Decrement Method (String, Int64)

MemcacheDecrement Method (String, Int64)
Decrement the value at the specified key by passed in value, and then return it.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long Decrement(
    string key,
    long inc
)
Public Function Decrement (
    key As String,
    inc As Long
) As Long
public:
long long Decrement(
    String^ key,
    long long inc
)
member Decrement :
        key : string *
        inc : int64 -> int64

Parameters

key
Type: SystemString
key where the data is stored
inc
Type: SystemInt64
how much to increment by

Return Value

Type: Int64
-1, if the key is not found, the value after incrementing otherwise
See Also

Reference

Memcache Class
Decrement Overload


Memcache.Delete Method

MemcacheDelete Method
Overload List
 | Name | Description
Public method | Delete(String) | Deletes an object from cache given cache key.
Public method | Delete(String, DateTime) | Deletes an object from cache given cache key, a delete time, and an optional hashcode. The item is immediately made non retrievable. Keep in mind: add(string, object) and replace(string, object) will fail when used with the same key will fail, until the server reaches the specified time. However, set(string, object) will succeed and the new value will not be deleted.
Top
See Also

Reference

Memcache Class


Memcache.Delete Method (String)

MemcacheDelete Method (String)
Deletes an object from cache given cache key.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Delete(
    string key
)
Public Function Delete (
    key As String
) As Boolean
public:
bool Delete(
    String^ key
)
member Delete :
        key : string -> bool

Parameters

key
Type: SystemString
the key to be removed

Return Value

Type: Boolean
true, if the data was deleted successfully
See Also

Reference

Memcache Class
Delete Overload


Memcache.Delete Method (String, DateTime)

MemcacheDelete Method (String, DateTime)
Deletes an object from cache given cache key, a delete time, and an optional hashcode. The item is immediately made non retrievable.
Keep in mind: add(string, object) and replace(string, object) will fail when used with the same key will fail, until the server reaches the specified time. However, set(string, object) will succeed and the new value will not be deleted.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Delete(
    string key,
    DateTime expiry
)
Public Function Delete (
    key As String,
    expiry As DateTime
) As Boolean
public:
bool Delete(
    String^ key,
    DateTime expiry
)
member Delete :
        key : string *
        expiry : DateTime -> bool

Parameters

key
Type: SystemString
the key to be removed
expiry
Type: SystemDateTime
when to expire the record.

Return Value

Type: Boolean
true, if the data was deleted successfully
See Also

Reference

Memcache Class
Delete Overload


Memcache.Dispose Method

MemcacheDispose Method
资源释放

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Memcache Class


Memcache.Flush Method

MemcacheFlush Method
flushes output stream

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Flush()
Public Sub Flush
public:
void Flush()
member Flush : unit -> unit
See Also

Reference

Memcache Class


Memcache.FlushAll Method

MemcacheFlushAll Method
Invalidates the entire cache. Will return true only if succeeds in clearing all servers.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool FlushAll()
Public Function FlushAll As Boolean
public:
bool FlushAll()
member FlushAll : unit -> bool

Return Value

Type: Boolean
success true/false
See Also

Reference

Memcache Class


Memcache.Get Method

MemcacheGet Method
Overload List
 | Name | Description
Public method | Get(String) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | GetT(String) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Public method | Get(String, Type) | Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired
Top
See Also

Reference

Memcache Class


Memcache.Get Method (String)

MemcacheGet Method (String)
Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Get(
    string key
)
Public Function Get (
    key As String
) As String
public:
String^ Get(
    String^ key
)
member Get :
        key : string -> string

Parameters

key
Type: SystemString
key where data is stored

Return Value

Type: String
the object that was previously stored, or null if it was not previously stored
See Also

Reference

Memcache Class
Get Overload


Memcache.Get(T) Method (String)

MemcacheGetT Method (String)
Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T Get<T>(
    string key
)

Public Function Get(Of T) (
    key As String
) As T
public:
generic<typename T>
virtual T Get(
    String^ key
) sealed
abstract Get :
        key : string -> 'T
override Get :
        key : string -> 'T

Parameters

key
Type: SystemString
key where data is stored

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Memcache.Get``1(System.String)"]

Return Value

Type: T
the object that was previously stored, or null if it was not previously stored

Implements

ICacheGetT(String)
See Also

Reference

Memcache Class
Get Overload


Memcache.Get Method (String, Type)

MemcacheGet Method (String, Type)
Retrieve a key from the server, using a specific hash. If the data was compressed or serialized when compressed, it will automatically be decompressed or serialized, as appropriate. (Inclusive or) Non-serialized data will be returned as a string, so explicit conversion to numeric types will be necessary, if desired

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Object Get(
    string key,
    Type type
)
Public Function Get (
    key As String,
    type As Type
) As Object
public:
Object^ Get(
    String^ key,
    Type^ type
)
member Get :
        key : string *
        type : Type -> Object

Parameters

key
Type: SystemString
key where data is stored
type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.Memcache.Get(System.String,System.Type)"]

Return Value

Type: Object
the object that was previously stored, or null if it was not previously stored
See Also

Reference

Memcache Class
Get Overload


Memcache.GetCounter Method

MemcacheGetCounter Method
Returns value in counter at given key as long.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long GetCounter(
    string key
)
Public Function GetCounter (
    key As String
) As Long
public:
long long GetCounter(
    String^ key
)
member GetCounter :
        key : string -> int64

Parameters

key
Type: SystemString
cache ket

Return Value

Type: Int64
counter value or -1 if not found
See Also

Reference

Memcache Class


Memcache.Increment Method

MemcacheIncrement Method
Overload List
 | Name | Description
Public method | Increment(String) | Increment the value at the specified key by 1, and then return it.
Public method | Increment(String, Int64) | Increment the value at the specified key by passed in val.
Top
See Also

Reference

Memcache Class


Memcache.Increment Method (String)

MemcacheIncrement Method (String)
Increment the value at the specified key by 1, and then return it.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long Increment(
    string key
)
Public Function Increment (
    key As String
) As Long
public:
long long Increment(
    String^ key
)
member Increment :
        key : string -> int64

Parameters

key
Type: SystemString
key where the data is stored

Return Value

Type: Int64
-1, if the key is not found, the value after incrementing otherwise
See Also

Reference

Memcache Class
Increment Overload


Memcache.Increment Method (String, Int64)

MemcacheIncrement Method (String, Int64)
Increment the value at the specified key by passed in val.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long Increment(
    string key,
    long inc
)
Public Function Increment (
    key As String,
    inc As Long
) As Long
public:
long long Increment(
    String^ key,
    long long inc
)
member Increment :
        key : string *
        inc : int64 -> int64

Parameters

key
Type: SystemString
key where the data is stored
inc
Type: SystemInt64
how much to increment by

Return Value

Type: Int64
-1, if the key is not found, the value after incrementing otherwise
See Also

Reference

Memcache Class
Increment Overload


Memcache.Read Method

MemcacheRead Method
reads length bytes into the passed in byte array from stream

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Read(
    byte[] bytes
)
Public Sub Read (
    bytes As Byte()
)
public:
void Read(
    array<unsigned char>^ bytes
)
member Read :
        bytes : byte[] -> unit

Parameters

bytes
Type: SystemByte
byte array
See Also

Reference

Memcache Class


Memcache.ReadLine Method

MemcacheReadLine Method
reads a line intentionally not using the deprecated readLine method from DataInputStream

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string ReadLine()
Public Function ReadLine As String
public:
String^ ReadLine()
member ReadLine : unit -> string

Return Value

Type: String
String that was read in
See Also

Reference

Memcache Class


Memcache.Replace Method

MemcacheReplace Method
Overload List
 | Name | Description
Public method | Replace(String, Object) | Updates data on the server; only the key and the value are specified.
Public method | Replace(String, Object, DateTime) | Updates data on the server; the key, value, and an expiration time are specified.
Top
See Also

Reference

Memcache Class


Memcache.Replace Method (String, Object)

MemcacheReplace Method (String, Object)
Updates data on the server; only the key and the value are specified.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Replace(
    string key,
    Object value
)
Public Function Replace (
    key As String,
    value As Object
) As Boolean
public:
bool Replace(
    String^ key,
    Object^ value
)
member Replace :
        key : string *
        value : Object -> bool

Parameters

key
Type: SystemString
key to store data under
value
Type: SystemObject
value to store

Return Value

Type: Boolean
true, if the data was successfully stored
See Also

Reference

Memcache Class
Replace Overload


Memcache.Replace Method (String, Object, DateTime)

MemcacheReplace Method (String, Object, DateTime)
Updates data on the server; the key, value, and an expiration time are specified.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Replace(
    string key,
    Object value,
    DateTime expiry
)
Public Function Replace (
    key As String,
    value As Object,
    expiry As DateTime
) As Boolean
public:
bool Replace(
    String^ key,
    Object^ value,
    DateTime expiry
)
member Replace :
        key : string *
        value : Object *
        expiry : DateTime -> bool

Parameters

key
Type: SystemString
key to store data under
value
Type: SystemObject
value to store
expiry
Type: SystemDateTime
when to expire the record

Return Value

Type: Boolean
true, if the data was successfully stored
See Also

Reference

Memcache Class
Replace Overload


Memcache.Set Method

MemcacheSet Method
Overload List
 | Name | Description
Public method | Set(String, Object) | Stores data on the server; only the key and the value are specified.
Public method | Set(String, Object, DateTime) | Stores data on the server; the key, value, and an expiration time are specified.
Public method | Set(String, Object, Int32) | 设置数据
Top
See Also

Reference

Memcache Class


Memcache.Set Method (String, Object)

MemcacheSet Method (String, Object)
Stores data on the server; only the key and the value are specified.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    string key,
    Object value
)
Public Function Set (
    key As String,
    value As Object
) As Boolean
public:
bool Set(
    String^ key,
    Object^ value
)
member Set :
        key : string *
        value : Object -> bool

Parameters

key
Type: SystemString
key to store data under
value
Type: SystemObject
value to store

Return Value

Type: Boolean
true, if the data was successfully stored
See Also

Reference

Memcache Class
Set Overload


Memcache.Set Method (String, Object, DateTime)

MemcacheSet Method (String, Object, DateTime)
Stores data on the server; the key, value, and an expiration time are specified.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    string key,
    Object value,
    DateTime expiry
)
Public Function Set (
    key As String,
    value As Object,
    expiry As DateTime
) As Boolean
public:
bool Set(
    String^ key,
    Object^ value,
    DateTime expiry
)
member Set :
        key : string *
        value : Object *
        expiry : DateTime -> bool

Parameters

key
Type: SystemString
key to store data under
value
Type: SystemObject
value to store
expiry
Type: SystemDateTime
when to expire the record

Return Value

Type: Boolean
true, if the data was successfully stored
See Also

Reference

Memcache Class
Set Overload


Memcache.Set Method (String, Object, Int32)

MemcacheSet Method (String, Object, Int32)
设置数据

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Set(
    string key,
    Object value,
    int expires
)
Public Sub Set (
    key As String,
    value As Object,
    expires As Integer
)
public:
virtual void Set(
    String^ key,
    Object^ value,
    int expires
) sealed
abstract Set :
        key : string *
        value : Object *
        expires : int -> unit
override Set :
        key : string *
        value : Object *
        expires : int -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.Memcache.Set(System.String,System.Object,System.Int32)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.Memcache.Set(System.String,System.Object,System.Int32)"]

expires
Type: SystemInt32

[Missing <param name="expires"/> documentation for "M:Adf.Memcache.Set(System.String,System.Object,System.Int32)"]

Implements

ICacheSet(String, Object, Int32)
See Also

Reference

Memcache Class
Set Overload


Memcache.Stats Method

MemcacheStats Method
Retrieves stats for passed in servers (or all servers). Returns a map keyed on the servername. The value is another map which contains stats with stat name as key and value as value.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Hashtable Stats()
Public Function Stats As Hashtable
public:
Hashtable^ Stats()
member Stats : unit -> Hashtable

Return Value

Type: Hashtable
Stats map
See Also

Reference

Memcache Class


Memcache.StoreCounter Method

MemcacheStoreCounter Method
Overload List
 | Name | Description
Public method | StoreCounter(String, Int64) | Store a counter to memcached given a key
Public method | StoreCounter(String, Int64, Int32) | Store a counter to memcached given a key
Top
See Also

Reference

Memcache Class


Memcache.StoreCounter Method (String, Int64)

MemcacheStoreCounter Method (String, Int64)
Store a counter to memcached given a key

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool StoreCounter(
    string key,
    long counter
)
Public Function StoreCounter (
    key As String,
    counter As Long
) As Boolean
public:
bool StoreCounter(
    String^ key,
    long long counter
)
member StoreCounter :
        key : string *
        counter : int64 -> bool

Parameters

key
Type: SystemString
cache key
counter
Type: SystemInt64
number to store

Return Value

Type: Boolean
true/false indicating success
See Also

Reference

Memcache Class
StoreCounter Overload


Memcache.StoreCounter Method (String, Int64, Int32)

MemcacheStoreCounter Method (String, Int64, Int32)
Store a counter to memcached given a key

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool StoreCounter(
    string key,
    long counter,
    int hashCode
)
Public Function StoreCounter (
    key As String,
    counter As Long,
    hashCode As Integer
) As Boolean
public:
bool StoreCounter(
    String^ key,
    long long counter,
    int hashCode
)
member StoreCounter :
        key : string *
        counter : int64 *
        hashCode : int -> bool

Parameters

key
Type: SystemString
cache key
counter
Type: SystemInt64
number to store
hashCode
Type: SystemInt32
if not null, then the int hashcode to use

Return Value

Type: Boolean
true/false indicating success
See Also

Reference

Memcache Class
StoreCounter Overload


Memcache.Write Method

MemcacheWrite Method
Overload List
 | Name | Description
Public method | Write(Byte) | writes a byte array to the output stream
Public method | Write(Byte, Int32, Int32) | writes a byte array to the output stream
Top
See Also

Reference

Memcache Class


Memcache.Write Method (Byte[])

MemcacheWrite Method (Byte)
writes a byte array to the output stream

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Write(
    byte[] bytes
)
Public Sub Write (
    bytes As Byte()
)
public:
void Write(
    array<unsigned char>^ bytes
)
member Write :
        bytes : byte[] -> unit

Parameters

bytes
Type: SystemByte
byte array to write
See Also

Reference

Memcache Class
Write Overload


Memcache.Write Method (Byte[], Int32, Int32)

MemcacheWrite Method (Byte, Int32, Int32)
writes a byte array to the output stream

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Write(
    byte[] bytes,
    int offset,
    int count
)
Public Sub Write (
    bytes As Byte(),
    offset As Integer,
    count As Integer
)
public:
void Write(
    array<unsigned char>^ bytes,
    int offset,
    int count
)
member Write :
        bytes : byte[] *
        offset : int *
        count : int -> unit

Parameters

bytes
Type: SystemByte
byte array to write
offset
Type: SystemInt32
offset to begin writing from
count
Type: SystemInt32
count of bytes to write
See Also

Reference

Memcache Class
Write Overload


Memcache Properties

Memcache Properties

The Memcache type exposes the following members.

Properties
 | Name | Description
Public property | BinarySerializable | 获取或设置二进制序列化器,默认 JsonBinarySerializable, 可通过在appsetting中配置 MemcacheBinarySerializable 来指定其它实例
Public property | CompressionThreshold | Sets the required length for data to be considered for compression. If the length of the data to be stored is not equal or larger than this value, it will not be compressed. This defaults to 15 KB.
Public property | EnableCompression | Enable storing compressed data, provided it meets the threshold requirements. If enabled, data will be stored in compressed form if it is longer than the threshold length set with setCompressThreshold(int) The default is that compression is enabled. Even if compression is disabled, compressed data will be automatically decompressed.
Public property | Encoding | Sets default string encoding when storing primitives as strings. Default is UTF-8.
Public property | Host | 主机
Public property | IsConnected | Gets whether or not the socket is connected. Returns true if it is.
Public property | PoolAbandon | 获取或设置是否放弃此实例
Public property | Port | 端口
Public property | SendTimeout | 发送超时
Top
See Also

Reference

Memcache Class


Memcache.BinarySerializable Property

MemcacheBinarySerializable Property
获取或设置二进制序列化器,默认 JsonBinarySerializable, 可通过在appsetting中配置 MemcacheBinarySerializable 来指定其它实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IBinarySerializable BinarySerializable { get; set; }
Public Property BinarySerializable As IBinarySerializable
    Get
    Set
public:
property IBinarySerializable^ BinarySerializable {
    IBinarySerializable^ get ();
    void set (IBinarySerializable^ value);
}
member BinarySerializable : IBinarySerializable with get, set

Property Value

Type: IBinarySerializable
See Also

Reference

Memcache Class


Memcache.CompressionThreshold Property

MemcacheCompressionThreshold Property
Sets the required length for data to be considered for compression. If the length of the data to be stored is not equal or larger than this value, it will not be compressed. This defaults to 15 KB.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long CompressionThreshold { get; set; }
Public Property CompressionThreshold As Long
    Get
    Set
public:
property long long CompressionThreshold {
    long long get ();
    void set (long long value);
}
member CompressionThreshold : int64 with get, set

Property Value

Type: Int64
required length of data to consider compression
See Also

Reference

Memcache Class


Memcache.EnableCompression Property

MemcacheEnableCompression Property
Enable storing compressed data, provided it meets the threshold requirements. If enabled, data will be stored in compressed form if it is longer than the threshold length set with setCompressThreshold(int) The default is that compression is enabled. Even if compression is disabled, compressed data will be automatically decompressed.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool EnableCompression { get; set; }
Public Property EnableCompression As Boolean
    Get
    Set
public:
property bool EnableCompression {
    bool get ();
    void set (bool value);
}
member EnableCompression : bool with get, set

Property Value

Type: Boolean
true to enable compuression, false to disable compression
See Also

Reference

Memcache Class


Memcache.Encoding Property

MemcacheEncoding Property
Sets default string encoding when storing primitives as strings. Default is UTF-8.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; }
Public ReadOnly Property Encoding As Encoding
    Get
public:
property Encoding^ Encoding {
    Encoding^ get ();
}
member Encoding : Encoding with get

Property Value

Type: Encoding
See Also

Reference

Memcache Class


Memcache.Host Property

MemcacheHost Property
主机

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Host { get; }
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
member Host : string with get

Property Value

Type: String
See Also

Reference

Memcache Class


Memcache.IsConnected Property

MemcacheIsConnected Property
Gets whether or not the socket is connected. Returns true if it is.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
public:
property bool IsConnected {
    bool get ();
}
member IsConnected : bool with get

Property Value

Type: Boolean
See Also

Reference

Memcache Class


Memcache.PoolAbandon Property

MemcachePoolAbandon Property
获取或设置是否放弃此实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool PoolAbandon { get; set; }
Public Property PoolAbandon As Boolean
    Get
    Set
public:
virtual property bool PoolAbandon {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PoolAbandon : bool with get, set
override PoolAbandon : bool with get, set

Property Value

Type: Boolean

Implements

IPoolInstancePoolAbandon
See Also

Reference

Memcache Class


Memcache.Port Property

MemcachePort Property
端口

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
member Port : int with get

Property Value

Type: Int32
See Also

Reference

Memcache Class


Memcache.SendTimeout Property

MemcacheSendTimeout Property
发送超时

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int SendTimeout { get; set; }
Public Property SendTimeout As Integer
    Get
    Set
public:
property int SendTimeout {
    int get ();
    void set (int value);
}
member SendTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

Memcache Class


MemcachePool Class

MemcachePool Class
Memcache池
Inheritance Hierarchy
SystemObject
AdfMemcachePool

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class MemcachePool : ICache
Public Class MemcachePool
    Implements ICache
public ref class MemcachePool : ICache
type MemcachePool =
    class
        interface ICache
    end

The MemcachePool type exposes the following members.

Constructors
 | Name | Description
Public method | MemcachePool | 初始化新实例
Public method | MemcachePool(String) | 初始化新实例
Top
Methods
 | Name | Description
Public method | Delete | 移除一个键
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | 获取一个字符值
Public method | GetT(String) | 获取一个对象
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Set | 设置一个对象
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | MemberPoolSize | 获取每成员的最大实例数
Public property | Name | 配置节点名
Public property | Pool | 获取池管理对象
Top
See Also

Reference


MemcachePool Constructor

MemcachePool Constructor
Overload List
 | Name | Description
Public method | MemcachePool | 初始化新实例
Public method | MemcachePool(String) | 初始化新实例
Top
See Also

Reference

MemcachePool Class


MemcachePool Constructor

MemcachePool Constructor
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MemcachePool()
Public Sub New
public:
MemcachePool()
new : unit -> MemcachePool
See Also

Reference

MemcachePool Class
MemcachePool Overload


MemcachePool Constructor (String)

MemcachePool Constructor (String)
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MemcachePool(
    string configName
)
Public Sub New (
    configName As String
)
public:
MemcachePool(
    String^ configName
)
new :
        configName : string -> MemcachePool

Parameters

configName
Type: SystemString

[Missing <param name="configName"/> documentation for "M:Adf.MemcachePool.#ctor(System.String)"]

See Also

Reference

MemcachePool Class
MemcachePool Overload


MemcachePool Methods

MemcachePool Methods

The MemcachePool type exposes the following members.

Methods
 | Name | Description
Public method | Delete | 移除一个键
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | 获取一个字符值
Public method | GetT(String) | 获取一个对象
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Set | 设置一个对象
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

MemcachePool Class


MemcachePool.Delete Method

MemcachePoolDelete Method
移除一个键

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Delete(
    string key
)
Public Sub Delete (
    key As String
)
public:
virtual void Delete(
    String^ key
) sealed
abstract Delete :
        key : string -> unit
override Delete :
        key : string -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.MemcachePool.Delete(System.String)"]

Implements

ICacheDelete(String)
See Also

Reference

MemcachePool Class


MemcachePool.Get Method

MemcachePoolGet Method
Overload List
 | Name | Description
Public method | Get(String) | 获取一个字符值
Public method | GetT(String) | 获取一个对象
Top
See Also

Reference

MemcachePool Class


MemcachePool.Get Method (String)

MemcachePoolGet Method (String)
获取一个字符值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Get(
    string key
)
Public Function Get (
    key As String
) As String
public:
virtual String^ Get(
    String^ key
) sealed
abstract Get :
        key : string -> string
override Get :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.MemcachePool.Get(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.MemcachePool.Get(System.String)"]

Implements

ICacheGet(String)
See Also

Reference

MemcachePool Class
Get Overload


MemcachePool.Get(T) Method (String)

MemcachePoolGetT Method (String)
获取一个对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T Get<T>(
    string key
)

Public Function Get(Of T) (
    key As String
) As T
public:
generic<typename T>
virtual T Get(
    String^ key
) sealed
abstract Get :
        key : string -> 'T
override Get :
        key : string -> 'T

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.MemcachePool.Get``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.MemcachePool.Get``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.MemcachePool.Get``1(System.String)"]

Implements

ICacheGetT(String)
See Also

Reference

MemcachePool Class
Get Overload


MemcachePool.Set Method

MemcachePoolSet Method
设置一个对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Set(
    string key,
    Object value,
    int expires
)
Public Sub Set (
    key As String,
    value As Object,
    expires As Integer
)
public:
virtual void Set(
    String^ key,
    Object^ value,
    int expires
) sealed
abstract Set :
        key : string *
        value : Object *
        expires : int -> unit
override Set :
        key : string *
        value : Object *
        expires : int -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.MemcachePool.Set(System.String,System.Object,System.Int32)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.MemcachePool.Set(System.String,System.Object,System.Int32)"]

expires
Type: SystemInt32

[Missing <param name="expires"/> documentation for "M:Adf.MemcachePool.Set(System.String,System.Object,System.Int32)"]

Implements

ICacheSet(String, Object, Int32)
See Also

Reference

MemcachePool Class


MemcachePool Properties

MemcachePool Properties

The MemcachePool type exposes the following members.

Properties
 | Name | Description
Public property | MemberPoolSize | 获取每成员的最大实例数
Public property | Name | 配置节点名
Public property | Pool | 获取池管理对象
Top
See Also

Reference

MemcachePool Class


MemcachePool.MemberPoolSize Property

MemcachePoolMemberPoolSize Property
获取每成员的最大实例数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int MemberPoolSize { get; }
Public Overridable ReadOnly Property MemberPoolSize As Integer
    Get
public:
virtual property int MemberPoolSize {
    int get ();
}
abstract MemberPoolSize : int with get
override MemberPoolSize : int with get

Property Value

Type: Int32
See Also

Reference

MemcachePool Class


MemcachePool.Name Property

MemcachePoolName Property
配置节点名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

MemcachePool Class


MemcachePool.Pool Property

MemcachePoolPool Property
获取池管理对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Pool<Memcache> Pool { get; }
Public ReadOnly Property Pool As Pool(Of Memcache)
    Get
public:
property Pool<Memcache^>^ Pool {
    Pool<Memcache^>^ get ();
}
member Pool : Pool<Memcache> with get

Property Value

Type: Pool Memcache
See Also

Reference

MemcachePool Class


MemcachePoolMember Class

MemcachePoolMember Class
Memcache池成员
Inheritance Hierarchy
SystemObject
AdfMemcachePoolMember

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class MemcachePoolMember : IPoolMember
Public Class MemcachePoolMember
    Implements IPoolMember
public ref class MemcachePoolMember : IPoolMember
type MemcachePoolMember =
    class
        interface IPoolMember
    end

The MemcachePoolMember type exposes the following members.

Constructors
 | Name | Description
Public method | MemcachePoolMember | 初始一个新实例
Top
Methods
 | Name | Description
Public method | CreatePoolInstance | 创建新实例
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Host | 获取主机名
Public property | PoolActive | 是否活动可用
Public property | PoolMemberId | 池成员标识
Public property | Port | 获取主机端口
Top
See Also

Reference


MemcachePoolMember Constructor

MemcachePoolMember Constructor
初始一个新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MemcachePoolMember(
    string host,
    int port
)
Public Sub New (
    host As String,
    port As Integer
)
public:
MemcachePoolMember(
    String^ host,
    int port
)
new :
        host : string *
        port : int -> MemcachePoolMember

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.MemcachePoolMember.#ctor(System.String,System.Int32)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.MemcachePoolMember.#ctor(System.String,System.Int32)"]

See Also

Reference

MemcachePoolMember Class


MemcachePoolMember Methods

MemcachePoolMember Methods

The MemcachePoolMember type exposes the following members.

Methods
 | Name | Description
Public method | CreatePoolInstance | 创建新实例
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

MemcachePoolMember Class


MemcachePoolMember.CreatePoolInstance Method

MemcachePoolMemberCreatePoolInstance Method
创建新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IPoolInstance CreatePoolInstance()
Public Function CreatePoolInstance As IPoolInstance
public:
virtual IPoolInstance^ CreatePoolInstance() sealed
abstract CreatePoolInstance : unit -> IPoolInstance
override CreatePoolInstance : unit -> IPoolInstance

Return Value

Type: IPoolInstance

[Missing <returns> documentation for "M:Adf.MemcachePoolMember.CreatePoolInstance"]

Implements

IPoolMemberCreatePoolInstance
See Also

Reference

MemcachePoolMember Class


MemcachePoolMember Properties

MemcachePoolMember Properties

The MemcachePoolMember type exposes the following members.

Properties
 | Name | Description
Public property | Host | 获取主机名
Public property | PoolActive | 是否活动可用
Public property | PoolMemberId | 池成员标识
Public property | Port | 获取主机端口
Top
See Also

Reference

MemcachePoolMember Class


MemcachePoolMember.Host Property

MemcachePoolMemberHost Property
获取主机名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Host { get; }
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
member Host : string with get

Property Value

Type: String
See Also

Reference

MemcachePoolMember Class


MemcachePoolMember.PoolActive Property

MemcachePoolMemberPoolActive Property
是否活动可用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool PoolActive { get; set; }
Public Property PoolActive As Boolean
    Get
    Set
public:
virtual property bool PoolActive {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PoolActive : bool with get, set
override PoolActive : bool with get, set

Property Value

Type: Boolean

Implements

IPoolMemberPoolActive
See Also

Reference

MemcachePoolMember Class


MemcachePoolMember.PoolMemberId Property

MemcachePoolMemberPoolMemberId Property
池成员标识

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string PoolMemberId { get; }
Public ReadOnly Property PoolMemberId As String
    Get
public:
virtual property String^ PoolMemberId {
    String^ get () sealed;
}
abstract PoolMemberId : string with get
override PoolMemberId : string with get

Property Value

Type: String

Implements

IPoolMemberPoolMemberId
See Also

Reference

MemcachePoolMember Class


MemcachePoolMember.Port Property

MemcachePoolMemberPort Property
获取主机端口

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
member Port : int with get

Property Value

Type: Int32
See Also

Reference

MemcachePoolMember Class


Mq Class

Mq Class
任务队列管理器
Inheritance Hierarchy
SystemObject
AdfMq

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Mq : IDisposable
Public Class Mq
    Implements IDisposable
public ref class Mq : IDisposable
type Mq =
    class
        interface IDisposable
    end

The Mq type exposes the following members.

Constructors
 | Name | Description
Public method | Mq(String) | initialize a instance
Public method | Mq(String, LogManager) | initialize a instance
Top
Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetAvailableThread | 可用接收线程数
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ReceiveT | 异步接收
Public method | ReceiveCompletedT | 完成一个接收
Public method | SendT | 发送
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | AvailableThread | Obsolete. 可用接收线程数
Public property | Name | Name
Public property | Receiving | 是否正在接收
Public property | ReconnectInterval | 异常时重连间隔，单位：秒，默认:60seconds
Top
See Also

Reference


Mq Constructor

Mq Constructor
Overload List
 | Name | Description
Public method | Mq(String) | initialize a instance
Public method | Mq(String, LogManager) | initialize a instance
Top
See Also

Reference

Mq Class


Mq Constructor (String)

Mq Constructor (String)
initialize a instance

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Mq(
    string name
)
Public Sub New (
    name As String
)
public:
Mq(
    String^ name
)
new :
        name : string -> Mq

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Mq.#ctor(System.String)"]

See Also

Reference

Mq Class
Mq Overload


Mq Constructor (String, LogManager)

Mq Constructor (String, LogManager)
initialize a instance

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Mq(
    string name,
    LogManager logger
)
Public Sub New (
    name As String,
    logger As LogManager
)
public:
Mq(
    String^ name,
    LogManager^ logger
)
new :
        name : string *
        logger : LogManager -> Mq

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Mq.#ctor(System.String,Adf.LogManager)"]

logger
Type: AdfLogManager

[Missing <param name="logger"/> documentation for "M:Adf.Mq.#ctor(System.String,Adf.LogManager)"]

See Also

Reference

Mq Class
Mq Overload


Mq Methods

Mq Methods

The Mq type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetAvailableThread | 可用接收线程数
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ReceiveT | 异步接收
Public method | ReceiveCompletedT | 完成一个接收
Public method | SendT | 发送
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Mq Class


Mq.Dispose Method

MqDispose Method
资源释放

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

Mq Class


Mq.GetAvailableThread Method

MqGetAvailableThread Method
可用接收线程数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int GetAvailableThread()
Public Function GetAvailableThread As Integer
public:
int GetAvailableThread()
member GetAvailableThread : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Mq.GetAvailableThread"]

See Also

Reference

Mq Class


Mq.Receive(T) Method

MqReceiveT Method
异步接收

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Receive<T>(
    int maxThreadSize,
    Action<T> action
)

Public Sub Receive(Of T) (
    maxThreadSize As Integer,
    action As Action(Of T)
)
public:
generic<typename T>
void Receive(
    int maxThreadSize,
    Action<T>^ action
)
member Receive :
        maxThreadSize : int *
        action : Action<'T> -> unit

Parameters

maxThreadSize
Type: SystemInt32

[Missing <param name="maxThreadSize"/> documentation for "M:Adf.Mq.Receive``1(System.Int32,System.Action{``0})"]

action
Type: SystemAction T

[Missing <param name="action"/> documentation for "M:Adf.Mq.Receive``1(System.Int32,System.Action{``0})"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Mq.Receive``1(System.Int32,System.Action{``0})"]

Exceptions
Exception | Condition
MqException | MqException 已调用过 Receive了
MessageQueueException | System.Messaging.MessageQueueException
See Also

Reference

Mq Class


Mq.ReceiveCompleted(T) Method

MqReceiveCompletedT Method
完成一个接收

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void ReceiveCompleted<T>(
    Object sender,
    ReceiveCompletedEventArgs e
)

Public Sub ReceiveCompleted(Of T) (
    sender As Object,
    e As ReceiveCompletedEventArgs
)
public:
generic<typename T>
void ReceiveCompleted(
    Object^ sender,
    ReceiveCompletedEventArgs^ e
)
member ReceiveCompleted :
        sender : Object *
        e : ReceiveCompletedEventArgs -> unit

Parameters

sender
Type: SystemObject

[Missing <param name="sender"/> documentation for "M:Adf.Mq.ReceiveCompleted``1(System.Object,System.Messaging.ReceiveCompletedEventArgs)"]

e
Type: System.MessagingReceiveCompletedEventArgs

[Missing <param name="e"/> documentation for "M:Adf.Mq.ReceiveCompleted``1(System.Object,System.Messaging.ReceiveCompletedEventArgs)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Mq.ReceiveCompleted``1(System.Object,System.Messaging.ReceiveCompletedEventArgs)"]

See Also

Reference

Mq Class


Mq.Send(T) Method

MqSendT Method
发送

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Send<T>(
    T message
)

Public Sub Send(Of T) (
    message As T
)
public:
generic<typename T>
void Send(
    T message
)
member Send :
        message : 'T -> unit

Parameters

message
Type: T

[Missing <param name="message"/> documentation for "M:Adf.Mq.Send``1(``0)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Mq.Send``1(``0)"]

See Also

Reference

Mq Class


Mq Properties

Mq Properties

The Mq type exposes the following members.

Properties
 | Name | Description
Public property | AvailableThread | Obsolete. 可用接收线程数
Public property | Name | Name
Public property | Receiving | 是否正在接收
Public property | ReconnectInterval | 异常时重连间隔，单位：秒，默认:60seconds
Top
See Also

Reference

Mq Class


Mq.AvailableThread Property

MqAvailableThread Property

Note: This API is now obsolete.

可用接收线程数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("已过时，请使用 GetAvailableThread 方法", true)]
public int AvailableThread { get; }
<ObsoleteAttribute("已过时，请使用 GetAvailableThread 方法", true)>
Public ReadOnly Property AvailableThread As Integer
    Get
public:
[ObsoleteAttribute(L"已过时，请使用 GetAvailableThread 方法", true)]
property int AvailableThread {
    int get ();
}
[<ObsoleteAttribute("已过时，请使用 GetAvailableThread 方法", true)>]
member AvailableThread : int with get

Property Value

Type: Int32
See Also

Reference

Mq Class


Mq.Name Property

MqName Property
Name

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

Mq Class


Mq.Receiving Property

MqReceiving Property
是否正在接收

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Receiving { get; }
Public ReadOnly Property Receiving As Boolean
    Get
public:
property bool Receiving {
    bool get ();
}
member Receiving : bool with get

Property Value

Type: Boolean
See Also

Reference

Mq Class


Mq.ReconnectInterval Property

MqReconnectInterval Property
异常时重连间隔，单位：秒，默认:60seconds

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ReconnectInterval { get; }
Public ReadOnly Property ReconnectInterval As Integer
    Get
public:
property int ReconnectInterval {
    int get ();
}
member ReconnectInterval : int with get

Property Value

Type: Int32
See Also

Reference

Mq Class


MqException Class

MqException Class
TaskQueue Exception
Inheritance Hierarchy
SystemObject
SystemException
AdfMqException

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class MqException : Exception
Public Class MqException
    Inherits Exception
public ref class MqException : public Exception
type MqException =
    class
        inherit Exception
    end

The MqException type exposes the following members.

Constructors
 | Name | Description
Public method | MqException | 初始新实例
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference


MqException Constructor

MqException Constructor
初始新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MqException(
    string message
)
Public Sub New (
    message As String
)
public:
MqException(
    String^ message
)
new :
        message : string -> MqException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Adf.MqException.#ctor(System.String)"]

See Also

Reference

MqException Class


MqException Methods

MqException Methods

The MqException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
See Also

Reference

MqException Class


MqException Properties

MqException Properties

The MqException type exposes the following members.

Properties
 | Name | Description
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference

MqException Class


MqReceive(T) Class

MqReceiveT Class
任务队列接收器
Inheritance Hierarchy
SystemObject
AdfMqReceiveT

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract class MqReceive<T> : IDisposable

Public MustInherit Class MqReceive(Of T)
    Implements IDisposable
generic<typename T>
public ref class MqReceive abstract : IDisposable
[<AbstractClassAttribute>]
type MqReceive<'T> =
    class
        interface IDisposable
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Adf.MqReceive`1"]

The MqReceiveT type exposes the following members.

Constructors
 | Name | Description
Public method | MqReceiveT(String, Int32) | 初始化
Public method | MqReceiveT(String, Int32, LogManager) | 初始化
Top
Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | New | 新项
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Logger | 管理器
Protected property | Mq | MQ
Public property | Name | 名称
Top
See Also

Reference


MqReceive(T) Constructor

MqReceiveT Constructor
Overload List
 | Name | Description
Public method | MqReceiveT(String, Int32) | 初始化
Public method | MqReceiveT(String, Int32, LogManager) | 初始化
Top
See Also

Reference

MqReceiveT Class


MqReceive(T) Constructor (String, Int32)

MqReceiveT Constructor (String, Int32)
初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MqReceive(
    string name,
    int maxThreadSize
)
Public Sub New (
    name As String,
    maxThreadSize As Integer
)
public:
MqReceive(
    String^ name,
    int maxThreadSize
)
new :
        name : string *
        maxThreadSize : int -> MqReceive

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.MqReceive`1.#ctor(System.String,System.Int32)"]

maxThreadSize
Type: SystemInt32

[Missing <param name="maxThreadSize"/> documentation for "M:Adf.MqReceive`1.#ctor(System.String,System.Int32)"]

See Also

Reference

MqReceiveT Class
MqReceiveT Overload


MqReceive(T) Constructor (String, Int32, LogManager)

MqReceiveT Constructor (String, Int32, LogManager)
初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MqReceive(
    string name,
    int maxThreadSize,
    LogManager logManager
)
Public Sub New (
    name As String,
    maxThreadSize As Integer,
    logManager As LogManager
)
public:
MqReceive(
    String^ name,
    int maxThreadSize,
    LogManager^ logManager
)
new :
        name : string *
        maxThreadSize : int *
        logManager : LogManager -> MqReceive

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.MqReceive`1.#ctor(System.String,System.Int32,Adf.LogManager)"]

maxThreadSize
Type: SystemInt32

[Missing <param name="maxThreadSize"/> documentation for "M:Adf.MqReceive`1.#ctor(System.String,System.Int32,Adf.LogManager)"]

logManager
Type: AdfLogManager

[Missing <param name="logManager"/> documentation for "M:Adf.MqReceive`1.#ctor(System.String,System.Int32,Adf.LogManager)"]

See Also

Reference

MqReceiveT Class
MqReceiveT Overload


MqReceive(T) Methods

MqReceiveT Methods

The MqReceiveT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | New | 新项
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

MqReceiveT Class


MqReceive(T).Dispose Method

MqReceiveTDispose Method
资源释放

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

MqReceiveT Class


MqReceive(T).New Method

MqReceiveTNew Method
新项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected abstract void New(
    T item
)
Protected MustOverride Sub New (
    item As T
)
protected:
virtual void New(
    T item
) abstract
abstract New :
        item : 'T -> unit

Parameters

item
Type: T

[Missing <param name="item"/> documentation for "M:Adf.MqReceive`1.New(`0)"]

See Also

Reference

MqReceiveT Class


MqReceive(T) Properties

MqReceiveT Properties

The MqReceiveT generic type exposes the following members.

Properties
 | Name | Description
Public property | Logger | 管理器
Protected property | Mq | MQ
Public property | Name | 名称
Top
See Also

Reference

MqReceiveT Class


MqReceive(T).Logger Property

MqReceiveTLogger Property
管理器

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual LogManager Logger { get; protected set; }
Public Overridable Property Logger As LogManager
    Get
    Protected Set
public:
virtual property LogManager^ Logger {
    LogManager^ get ();
    protected: void set (LogManager^ value);
}
abstract Logger : LogManager with get, set
override Logger : LogManager with get, set

Property Value

Type: LogManager
See Also

Reference

MqReceiveT Class


MqReceive(T).Mq Property

MqReceiveTMq Property
MQ

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected Mq Mq { get; }
Protected ReadOnly Property Mq As Mq
    Get
protected:
property Mq^ Mq {
    Mq^ get ();
}
member Mq : Mq with get

Property Value

Type: Mq
See Also

Reference

MqReceiveT Class


MqReceive(T).Name Property

MqReceiveTName Property
名称

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

MqReceiveT Class


NumberHelper Class

NumberHelper Class
数字助手
Inheritance Hierarchy
SystemObject
AdfNumberHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class NumberHelper
Public NotInheritable Class NumberHelper
public ref class NumberHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NumberHelper =  class end

The NumberHelper type exposes the following members.

Methods
Name | Description
GetRating | 获得分数的整数部分和小数部分
Top
See Also

Reference


NumberHelper Methods

NumberHelper Methods

The NumberHelper type exposes the following members.

Methods
Name | Description
GetRating | 获得分数的整数部分和小数部分
Top
See Also

Reference

NumberHelper Class


NumberHelper.GetRating Method

NumberHelperGetRating Method
获得分数的整数部分和小数部分

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void GetRating(
    float rating,
    out int bigInt,
    out int smallInt
)
Public Shared Sub GetRating (
    rating As Single,
    <OutAttribute> ByRef bigInt As Integer,
    <OutAttribute> ByRef smallInt As Integer
)
public:
static void GetRating(
    float rating,
    [OutAttribute] int% bigInt,
    [OutAttribute] int% smallInt
)
static member GetRating :
        rating : float32 *
        bigInt : int byref *
        smallInt : int byref -> unit

Parameters

rating
Type: SystemSingle

[Missing <param name="rating"/> documentation for "M:Adf.NumberHelper.GetRating(System.Single,System.Int32@,System.Int32@)"]

bigInt
Type: SystemInt32

[Missing <param name="bigInt"/> documentation for "M:Adf.NumberHelper.GetRating(System.Single,System.Int32@,System.Int32@)"]

smallInt
Type: SystemInt32

[Missing <param name="smallInt"/> documentation for "M:Adf.NumberHelper.GetRating(System.Single,System.Int32@,System.Int32@)"]

See Also

Reference

NumberHelper Class


ObjectConverter Class

ObjectConverter Class
对象转换器
Inheritance Hierarchy
SystemObject
AdfObjectConverter

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ObjectConverter
Public Class ObjectConverter
public ref class ObjectConverter
type ObjectConverter =  class end

The ObjectConverter type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectConverter | Initializes a new instance of the ObjectConverter class
Top
Methods
 | Name | Description
 | ConvertValue(Object, Type) | 转换一个对象值
 | ConvertValue(Object, Type, ObjectConverterConvertValueCallback) | 转换一个对象值
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | ToDictionary | 将目标对象属性转换为键值列表
 | ToObject | 将键值表值转换为对象
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


ObjectConverter Constructor

ObjectConverter Constructor
Initializes a new instance of the ObjectConverter class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ObjectConverter()
Public Sub New
public:
ObjectConverter()
new : unit -> ObjectConverter
See Also

Reference

ObjectConverter Class


ObjectConverter Methods

ObjectConverter Methods

The ObjectConverter type exposes the following members.

Methods
 | Name | Description
 | ConvertValue(Object, Type) | 转换一个对象值
 | ConvertValue(Object, Type, ObjectConverterConvertValueCallback) | 转换一个对象值
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | ToDictionary | 将目标对象属性转换为键值列表
 | ToObject | 将键值表值转换为对象
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ObjectConverter Class


ObjectConverter.ConvertValue Method

ObjectConverterConvertValue Method
Overload List
Name | Description
ConvertValue(Object, Type) | 转换一个对象值
ConvertValue(Object, Type, ObjectConverterConvertValueCallback) | 转换一个对象值
Top
See Also

Reference

ObjectConverter Class


ObjectConverter.ConvertValue Method (Object, Type)

ObjectConverterConvertValue Method (Object, Type)
转换一个对象值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Object ConvertValue(
    Object value,
    Type objectType
)
Public Shared Function ConvertValue (
    value As Object,
    objectType As Type
) As Object
public:
static Object^ ConvertValue(
    Object^ value,
    Type^ objectType
)
static member ConvertValue :
        value : Object *
        objectType : Type -> Object

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.ObjectConverter.ConvertValue(System.Object,System.Type)"]

objectType
Type: SystemType

[Missing <param name="objectType"/> documentation for "M:Adf.ObjectConverter.ConvertValue(System.Object,System.Type)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.ObjectConverter.ConvertValue(System.Object,System.Type)"]

See Also

Reference

ObjectConverter Class
ConvertValue Overload


ObjectConverter.ConvertValue Method (Object, Type, ObjectConverter.ConvertValueCallback)

ObjectConverterConvertValue Method (Object, Type, ObjectConverterConvertValueCallback)
转换一个对象值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Object ConvertValue(
    Object value,
    Type objectType,
    ObjectConverterConvertValueCallback callback
)
Public Shared Function ConvertValue (
    value As Object,
    objectType As Type,
    callback As ObjectConverterConvertValueCallback
) As Object
public:
static Object^ ConvertValue(
    Object^ value,
    Type^ objectType,
    ObjectConverterConvertValueCallback^ callback
)
static member ConvertValue :
        value : Object *
        objectType : Type *
        callback : ObjectConverterConvertValueCallback -> Object

Parameters

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.ObjectConverter.ConvertValue(System.Object,System.Type,Adf.ObjectConverter.ConvertValueCallback)"]

objectType
Type: SystemType

[Missing <param name="objectType"/> documentation for "M:Adf.ObjectConverter.ConvertValue(System.Object,System.Type,Adf.ObjectConverter.ConvertValueCallback)"]

callback
Type: AdfObjectConverterConvertValueCallback
定义转换回调以及嵌套调用时自处理,返回值为true时，输出参数有效

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.ObjectConverter.ConvertValue(System.Object,System.Type,Adf.ObjectConverter.ConvertValueCallback)"]

See Also

Reference

ObjectConverter Class
ConvertValue Overload


ObjectConverter.ToDictionary Method

ObjectConverterToDictionary Method
将目标对象属性转换为键值列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Dictionary<string, Object> ToDictionary(
    Object targetObject,
    bool recursion = true
)
Public Shared Function ToDictionary (
    targetObject As Object,
    Optional recursion As Boolean = true
) As Dictionary(Of String, Object)
public:
static Dictionary<String^, Object^>^ ToDictionary(
    Object^ targetObject,
    bool recursion = true
)
static member ToDictionary :
        targetObject : Object *
        ?recursion : bool
(* Defaults:
        let _recursion = defaultArg recursion true
*)
-> Dictionary<string, Object>

Parameters

targetObject
Type: SystemObject

[Missing <param name="targetObject"/> documentation for "M:Adf.ObjectConverter.ToDictionary(System.Object,System.Boolean)"]

recursion (Optional)
Type: SystemBoolean

[Missing <param name="recursion"/> documentation for "M:Adf.ObjectConverter.ToDictionary(System.Object,System.Boolean)"]

Return Value

Type: Dictionary String, Object

[Missing <returns> documentation for "M:Adf.ObjectConverter.ToDictionary(System.Object,System.Boolean)"]

See Also

Reference

ObjectConverter Class


ObjectConverter.ToObject Method

ObjectConverterToObject Method
将键值表值转换为对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Object ToObject(
    Type objectType,
    IDictionary dictionary
)
Public Shared Function ToObject (
    objectType As Type,
    dictionary As IDictionary
) As Object
public:
static Object^ ToObject(
    Type^ objectType,
    IDictionary^ dictionary
)
static member ToObject :
        objectType : Type *
        dictionary : IDictionary -> Object

Parameters

objectType
Type: SystemType

[Missing <param name="objectType"/> documentation for "M:Adf.ObjectConverter.ToObject(System.Type,System.Collections.IDictionary)"]

dictionary
Type: System.CollectionsIDictionary

[Missing <param name="dictionary"/> documentation for "M:Adf.ObjectConverter.ToObject(System.Type,System.Collections.IDictionary)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.ObjectConverter.ToObject(System.Type,System.Collections.IDictionary)"]

See Also

Reference

ObjectConverter Class


ObjectConverter.ConvertValueCallback Delegate

ObjectConverterConvertValueCallback Delegate
定义对象转换器转换对象值时的回调，以便转换具有嵌套值时的自处理

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate bool ConvertValueCallback(
    Object value,
    Type objectType,
    out Object result
)
Public Delegate Function ConvertValueCallback (
    value As Object,
    objectType As Type,
    <OutAttribute> ByRef result As Object
) As Boolean
public delegate bool ConvertValueCallback(
    Object^ value,
    Type^ objectType,
    [OutAttribute] Object^% result
)
type ConvertValueCallback =
    delegate of
        value : Object *
        objectType : Type *
        result : Object byref -> bool

Parameters

value
Type: SystemObject
objectType
Type: SystemType
result
Type: SystemObject

Return Value

Type: Boolean
See Also

Reference


Pager Class

Pager Class
页序处理
Inheritance Hierarchy
SystemObject
AdfPager

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Pager
Public Class Pager
public ref class Pager
type Pager =  class end

The Pager type exposes the following members.

Constructors
 | Name | Description
Public method | Pager | 初始化新实例 --用法: var pager = new Pager(); --数据处理 pager.Compute('总数'); --获取值
Public method | Pager(Int32) | 初始化新实例
Top
Methods
 | Name | Description
Public method | Compute | 计算页序
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | LastIndex | 获取总页数
Public property | NextIndex | 获取下一页索引
Public property | PageIndex | 获取或设置索引
Public property | PageSize | 获取或设置页大小
Public property | PrevIndex | 获取上一页索引
Public property | RecordIndex | 获取索引开始记录数
Public property | TotalCount | 获取总数
Top
See Also

Reference


Pager Constructor

Pager Constructor
Overload List
 | Name | Description
Public method | Pager | 初始化新实例 --用法: var pager = new Pager(); --数据处理 pager.Compute('总数'); --获取值
Public method | Pager(Int32) | 初始化新实例
Top
See Also

Reference

Pager Class


Pager Constructor

Pager Constructor
初始化新实例 --用法: var pager = new Pager(); --数据处理 pager.Compute('总数'); --获取值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Pager()
Public Sub New
public:
Pager()
new : unit -> Pager
See Also

Reference

Pager Class
Pager Overload


Pager Constructor (Int32)

Pager Constructor (Int32)
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Pager(
    int pagesize
)
Public Sub New (
    pagesize As Integer
)
public:
Pager(
    int pagesize
)
new :
        pagesize : int -> Pager

Parameters

pagesize
Type: SystemInt32
页大小
See Also

Reference

Pager Class
Pager Overload


Pager Methods

Pager Methods

The Pager type exposes the following members.

Methods
 | Name | Description
Public method | Compute | 计算页序
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Pager Class


Pager.Compute Method

PagerCompute Method
计算页序

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Compute(
    int totalcount
)
Public Sub Compute (
    totalcount As Integer
)
public:
void Compute(
    int totalcount
)
member Compute :
        totalcount : int -> unit

Parameters

totalcount
Type: SystemInt32
总页数
See Also

Reference

Pager Class


Pager Properties

Pager Properties

The Pager type exposes the following members.

Properties
 | Name | Description
Public property | LastIndex | 获取总页数
Public property | NextIndex | 获取下一页索引
Public property | PageIndex | 获取或设置索引
Public property | PageSize | 获取或设置页大小
Public property | PrevIndex | 获取上一页索引
Public property | RecordIndex | 获取索引开始记录数
Public property | TotalCount | 获取总数
Top
See Also

Reference

Pager Class


Pager.LastIndex Property

PagerLastIndex Property
获取总页数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LastIndex { get; }
Public ReadOnly Property LastIndex As Integer
    Get
public:
property int LastIndex {
    int get ();
}
member LastIndex : int with get

Property Value

Type: Int32
See Also

Reference

Pager Class


Pager.NextIndex Property

PagerNextIndex Property
获取下一页索引

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int NextIndex { get; }
Public ReadOnly Property NextIndex As Integer
    Get
public:
property int NextIndex {
    int get ();
}
member NextIndex : int with get

Property Value

Type: Int32
See Also

Reference

Pager Class


Pager.PageIndex Property

PagerPageIndex Property
获取或设置索引

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int PageIndex { get; set; }
Public Property PageIndex As Integer
    Get
    Set
public:
property int PageIndex {
    int get ();
    void set (int value);
}
member PageIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

Pager Class


Pager.PageSize Property

PagerPageSize Property
获取或设置页大小

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int PageSize { get; set; }
Public Property PageSize As Integer
    Get
    Set
public:
property int PageSize {
    int get ();
    void set (int value);
}
member PageSize : int with get, set

Property Value

Type: Int32
See Also

Reference

Pager Class


Pager.PrevIndex Property

PagerPrevIndex Property
获取上一页索引

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int PrevIndex { get; }
Public ReadOnly Property PrevIndex As Integer
    Get
public:
property int PrevIndex {
    int get ();
}
member PrevIndex : int with get

Property Value

Type: Int32
See Also

Reference

Pager Class


Pager.RecordIndex Property

PagerRecordIndex Property
获取索引开始记录数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long RecordIndex { get; }
Public ReadOnly Property RecordIndex As Long
    Get
public:
property long long RecordIndex {
    long long get ();
}
member RecordIndex : int64 with get

Property Value

Type: Int64
See Also

Reference

Pager Class


Pager.TotalCount Property

PagerTotalCount Property
获取总数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int TotalCount { get; protected set; }
Public Property TotalCount As Integer
    Get
    Protected Set
public:
property int TotalCount {
    int get ();
    protected: void set (int value);
}
member TotalCount : int with get, set

Property Value

Type: Int32
See Also

Reference

Pager Class


PasswordHelper Class

PasswordHelper Class
编码助手
Inheritance Hierarchy
SystemObject
AdfPasswordHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class PasswordHelper
Public NotInheritable Class PasswordHelper
public ref class PasswordHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PasswordHelper =  class end

The PasswordHelper type exposes the following members.

Methods
Name | Description
AES(String, String) | AES Password, Charset UTF8
AES(String, String, Encoding) | AES Password
MD5Slat | MD5 encodes the passed string
MD5Strong | MD5 encodes the passed string
Top
Fields
Name | Description
IV_CHARS | IV CHARS
IV_CHARS_LENGTH | IV CHARS LENGTH
Top
See Also

Reference


PasswordHelper Fields

PasswordHelper Fields

The PasswordHelper type exposes the following members.

Fields
Name | Description
IV_CHARS | IV CHARS
IV_CHARS_LENGTH | IV CHARS LENGTH
Top
See Also

Reference

PasswordHelper Class


PasswordHelper.IV_CHARS Field

PasswordHelperIV_CHARS Field
IV CHARS

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public const string IV_CHARS
Public Const IV_CHARS As String
public:
literal String^ IV_CHARS
static val mutable IV_CHARS: string

Field Value

Type: String
See Also

Reference

PasswordHelper Class


PasswordHelper.IV_CHARS_LENGTH Field

PasswordHelperIV_CHARS_LENGTH Field
IV CHARS LENGTH

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public const int IV_CHARS_LENGTH
Public Const IV_CHARS_LENGTH As Integer
public:
literal int IV_CHARS_LENGTH
static val mutable IV_CHARS_LENGTH: int

Field Value

Type: Int32
See Also

Reference

PasswordHelper Class


PasswordHelper Methods

PasswordHelper Methods

The PasswordHelper type exposes the following members.

Methods
Name | Description
AES(String, String) | AES Password, Charset UTF8
AES(String, String, Encoding) | AES Password
MD5Slat | MD5 encodes the passed string
MD5Strong | MD5 encodes the passed string
Top
See Also

Reference

PasswordHelper Class


PasswordHelper.AES Method

PasswordHelperAES Method
Overload List
Name | Description
AES(String, String) | AES Password, Charset UTF8
AES(String, String, Encoding) | AES Password
Top
See Also

Reference

PasswordHelper Class


PasswordHelper.AES Method (String, String)

PasswordHelperAES Method (String, String)
AES Password, Charset UTF8

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string AES(
    string input,
    string key
)
Public Shared Function AES (
    input As String,
    key As String
) As String
public:
static String^ AES(
    String^ input,
    String^ key
)
static member AES :
        input : string *
        key : string -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.PasswordHelper.AES(System.String,System.String)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.PasswordHelper.AES(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.PasswordHelper.AES(System.String,System.String)"]

See Also

Reference

PasswordHelper Class
AES Overload


PasswordHelper.AES Method (String, String, Encoding)

PasswordHelperAES Method (String, String, Encoding)
AES Password

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string AES(
    string input,
    string key,
    Encoding encoding
)
Public Shared Function AES (
    input As String,
    key As String,
    encoding As Encoding
) As String
public:
static String^ AES(
    String^ input,
    String^ key,
    Encoding^ encoding
)
static member AES :
        input : string *
        key : string *
        encoding : Encoding -> string

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.PasswordHelper.AES(System.String,System.String,System.Text.Encoding)"]

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.PasswordHelper.AES(System.String,System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.PasswordHelper.AES(System.String,System.String,System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.PasswordHelper.AES(System.String,System.String,System.Text.Encoding)"]

See Also

Reference

PasswordHelper Class
AES Overload


PasswordHelper.MD5Slat Method

PasswordHelperMD5Slat Method
MD5 encodes the passed string

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string MD5Slat(
    string input,
    string salt
)
Public Shared Function MD5Slat (
    input As String,
    salt As String
) As String
public:
static String^ MD5Slat(
    String^ input,
    String^ salt
)
static member MD5Slat :
        input : string *
        salt : string -> string

Parameters

input
Type: SystemString
The string to encode.
salt
Type: SystemString

[Missing <param name="salt"/> documentation for "M:Adf.PasswordHelper.MD5Slat(System.String,System.String)"]

Return Value

Type: String
An encoded string.
See Also

Reference

PasswordHelper Class


PasswordHelper.MD5Strong Method

PasswordHelperMD5Strong Method
MD5 encodes the passed string

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string MD5Strong(
    string input
)
Public Shared Function MD5Strong (
    input As String
) As String
public:
static String^ MD5Strong(
    String^ input
)
static member MD5Strong :
        input : string -> string

Parameters

input
Type: SystemString
The string to encode.

Return Value

Type: String
An encoded string.
See Also

Reference

PasswordHelper Class


PathHelper Class

PathHelper Class
路径处理
Inheritance Hierarchy
SystemObject
AdfPathHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class PathHelper
Public NotInheritable Class PathHelper
public ref class PathHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PathHelper =  class end

The PathHelper type exposes the following members.

Methods
Name | Description
EndBackSlash | 验证指定的路径最后一位是否为反斜扛 / ,如果不是则自动增加一个
EndSlash | 将指定的路径进行判断，如果最后未有斜杠\，如果未有则自动增加一个
NumberPath(Int64, String, Int32) | 数字转路径，路径不包含当前目录下文件名
NumberPath(Int64, Int32, String, Int32) | 数字转路径,并返回当前目录下文件名
NumberPathFull | 数字转路径，路径包含当前目录下文件名称
Top
See Also

Reference


PathHelper Methods

PathHelper Methods

The PathHelper type exposes the following members.

Methods
Name | Description
EndBackSlash | 验证指定的路径最后一位是否为反斜扛 / ,如果不是则自动增加一个
EndSlash | 将指定的路径进行判断，如果最后未有斜杠\，如果未有则自动增加一个
NumberPath(Int64, String, Int32) | 数字转路径，路径不包含当前目录下文件名
NumberPath(Int64, Int32, String, Int32) | 数字转路径,并返回当前目录下文件名
NumberPathFull | 数字转路径，路径包含当前目录下文件名称
Top
See Also

Reference

PathHelper Class


PathHelper.EndBackSlash Method

PathHelperEndBackSlash Method
验证指定的路径最后一位是否为反斜扛 / ,如果不是则自动增加一个

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EndBackSlash(
    string path
)
Public Shared Function EndBackSlash (
    path As String
) As String
public:
static String^ EndBackSlash(
    String^ path
)
static member EndBackSlash :
        path : string -> string

Parameters

path
Type: SystemString
路径串

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.PathHelper.EndBackSlash(System.String)"]

See Also

Reference

PathHelper Class


PathHelper.EndSlash Method

PathHelperEndSlash Method
将指定的路径进行判断，如果最后未有斜杠\，如果未有则自动增加一个

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EndSlash(
    string path
)
Public Shared Function EndSlash (
    path As String
) As String
public:
static String^ EndSlash(
    String^ path
)
static member EndSlash :
        path : string -> string

Parameters

path
Type: SystemString
路径串

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.PathHelper.EndSlash(System.String)"]

See Also

Reference

PathHelper Class


PathHelper.NumberPath Method

PathHelperNumberPath Method
Overload List
Name | Description
NumberPath(Int64, String, Int32) | 数字转路径，路径不包含当前目录下文件名
NumberPath(Int64, Int32, String, Int32) | 数字转路径,并返回当前目录下文件名
Top
See Also

Reference

PathHelper Class


PathHelper.NumberPath Method (Int64, String, Int32)

PathHelperNumberPath Method (Int64, String, Int32)
数字转路径，路径不包含当前目录下文件名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string NumberPath(
    long number,
    string separateChar = "/",
    int value = 1000
)
Public Shared Function NumberPath (
    number As Long,
    Optional separateChar As String = "/",
    Optional value As Integer = 1000
) As String
public:
static String^ NumberPath(
    long long number,
    String^ separateChar = L"/",
    int value = 1000
)
static member NumberPath :
        number : int64 *
        ?separateChar : string *
        ?value : int
(* Defaults:
        let _separateChar = defaultArg separateChar "/"
        let _value = defaultArg value 1000
*)
-> string

Parameters

number
Type: SystemInt64

[Missing <param name="number"/> documentation for "M:Adf.PathHelper.NumberPath(System.Int64,System.String,System.Int32)"]

separateChar (Optional)
Type: SystemString
路径分隔符
value (Optional)
Type: SystemInt32
单目录最大值,此值不得小于100

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.PathHelper.NumberPath(System.Int64,System.String,System.Int32)"]

See Also

Reference

PathHelper Class
NumberPath Overload


PathHelper.NumberPath Method (Int64, Int32, String, Int32)

PathHelperNumberPath Method (Int64, Int32, String, Int32)
数字转路径,并返回当前目录下文件名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string NumberPath(
    long number,
    out int name,
    string separateChar = "/",
    int value = 1000
)
Public Shared Function NumberPath (
    number As Long,
    <OutAttribute> ByRef name As Integer,
    Optional separateChar As String = "/",
    Optional value As Integer = 1000
) As String
public:
static String^ NumberPath(
    long long number,
    [OutAttribute] int% name,
    String^ separateChar = L"/",
    int value = 1000
)
static member NumberPath :
        number : int64 *
        name : int byref *
        ?separateChar : string *
        ?value : int
(* Defaults:
        let _separateChar = defaultArg separateChar "/"
        let _value = defaultArg value 1000
*)
-> string

Parameters

number
Type: SystemInt64

[Missing <param name="number"/> documentation for "M:Adf.PathHelper.NumberPath(System.Int64,System.Int32@,System.String,System.Int32)"]

name
Type: SystemInt32
文件名
separateChar (Optional)
Type: SystemString
路径分隔符
value (Optional)
Type: SystemInt32
单目录最大值,此值不得小于100

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.PathHelper.NumberPath(System.Int64,System.Int32@,System.String,System.Int32)"]

See Also

Reference

PathHelper Class
NumberPath Overload


PathHelper.NumberPathFull Method

PathHelperNumberPathFull Method
数字转路径，路径包含当前目录下文件名称

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string NumberPathFull(
    long number,
    string separateChar = "/",
    int value = 1000
)
Public Shared Function NumberPathFull (
    number As Long,
    Optional separateChar As String = "/",
    Optional value As Integer = 1000
) As String
public:
static String^ NumberPathFull(
    long long number,
    String^ separateChar = L"/",
    int value = 1000
)
static member NumberPathFull :
        number : int64 *
        ?separateChar : string *
        ?value : int
(* Defaults:
        let _separateChar = defaultArg separateChar "/"
        let _value = defaultArg value 1000
*)
-> string

Parameters

number
Type: SystemInt64

[Missing <param name="number"/> documentation for "M:Adf.PathHelper.NumberPathFull(System.Int64,System.String,System.Int32)"]

separateChar (Optional)
Type: SystemString
路径分隔符
value (Optional)
Type: SystemInt32
单目录最大值,此值不得小于100

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.PathHelper.NumberPathFull(System.Int64,System.String,System.Int32)"]

See Also

Reference

PathHelper Class


Pool(T) Class

PoolT Class
Pool Manager
Inheritance Hierarchy
SystemObject
AdfPoolT

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Pool<T> : IDisposable
where T : IPoolInstance

Public Class Pool(Of T As IPoolInstance)
    Implements IDisposable
generic<typename T>
where T : IPoolInstance
public ref class Pool : IDisposable
type Pool<'T when 'T : IPoolInstance> =
    class
        interface IDisposable
    end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Adf.Pool`1"]

The PoolT type exposes the following members.

Constructors
 | Name | Description
Public method | PoolT(Int32, IPoolMember) | initialize
Public method | PoolT(Int32, IPoolMember, Int32) | initialize
Top
Methods
 | Name | Description
Public method | Call(ActionT) | call
Public method | Call(ActionT, String, String) | call
Protected method | CallExceptionIsAbandon | Call异常时指示该异常是否应禁止当前实例,默认处理 SocketException 异常，若有其它异常处理请自行重载判断
Public method | Dispose | Dispose
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnNewInstanceException | trigger NewInstanceException event
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ActiveCount | Active Instance Count
Public property | HashVNodeCount | hash vnode count, zero is disable hash
Public property | MemberInstanceSize | pool size to member
Public property | Members | Elements
Public property | ResumeCheckInterval | Instance Re check Seconds, Default 60, zero ignore 实例异常恢复检测间隔
Public property | SupportHash | is support hash
Public property | Timeout | full wait timeout,default zero, not timeout
Top
Events
 | Name | Description
Public event | NewInstanceException | new element exception
Top
See Also

Reference


Pool(T) Constructor

PoolT Constructor
Overload List
 | Name | Description
Public method | PoolT(Int32, IPoolMember) | initialize
Public method | PoolT(Int32, IPoolMember, Int32) | initialize
Top
See Also

Reference

PoolT Class


Pool(T) Constructor (Int32, IPoolMember[])

PoolT Constructor (Int32, IPoolMember)
initialize

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Pool(
    int memberInstanceSize,
    IPoolMember[] members
)
Public Sub New (
    memberInstanceSize As Integer,
    members As IPoolMember()
)
public:
Pool(
    int memberInstanceSize,
    array<IPoolMember^>^ members
)
new :
        memberInstanceSize : int *
        members : IPoolMember[] -> Pool

Parameters

memberInstanceSize
Type: SystemInt32

[Missing <param name="memberInstanceSize"/> documentation for "M:Adf.Pool`1.#ctor(System.Int32,Adf.IPoolMember[])"]

members
Type: AdfIPoolMember

[Missing <param name="members"/> documentation for "M:Adf.Pool`1.#ctor(System.Int32,Adf.IPoolMember[])"]

See Also

Reference

PoolT Class
PoolT Overload


Pool(T) Constructor (Int32, IPoolMember[], Int32)

PoolT Constructor (Int32, IPoolMember, Int32)
initialize

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Pool(
    int memberInstanceSize,
    IPoolMember[] members,
    int hashVNodeCount
)
Public Sub New (
    memberInstanceSize As Integer,
    members As IPoolMember(),
    hashVNodeCount As Integer
)
public:
Pool(
    int memberInstanceSize,
    array<IPoolMember^>^ members,
    int hashVNodeCount
)
new :
        memberInstanceSize : int *
        members : IPoolMember[] *
        hashVNodeCount : int -> Pool

Parameters

memberInstanceSize
Type: SystemInt32

[Missing <param name="memberInstanceSize"/> documentation for "M:Adf.Pool`1.#ctor(System.Int32,Adf.IPoolMember[],System.Int32)"]

members
Type: AdfIPoolMember

[Missing <param name="members"/> documentation for "M:Adf.Pool`1.#ctor(System.Int32,Adf.IPoolMember[],System.Int32)"]

hashVNodeCount
Type: SystemInt32

[Missing <param name="hashVNodeCount"/> documentation for "M:Adf.Pool`1.#ctor(System.Int32,Adf.IPoolMember[],System.Int32)"]

See Also

Reference

PoolT Class
PoolT Overload


Pool(T) Methods

PoolT Methods

The PoolT generic type exposes the following members.

Methods
 | Name | Description
Public method | Call(ActionT) | call
Public method | Call(ActionT, String, String) | call
Protected method | CallExceptionIsAbandon | Call异常时指示该异常是否应禁止当前实例,默认处理 SocketException 异常，若有其它异常处理请自行重载判断
Public method | Dispose | Dispose
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnNewInstanceException | trigger NewInstanceException event
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

PoolT Class


Pool(T).Call Method

PoolTCall Method
Overload List
 | Name | Description
Public method | Call(ActionT) | call
Public method | Call(ActionT, String, String) | call
Top
See Also

Reference

PoolT Class


Pool(T).Call Method (Action(T))

PoolTCall Method (ActionT)
call

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Call(
    Action<T> action
)
Public Sub Call (
    action As Action(Of T)
)
public:
void Call(
    Action<T>^ action
)
member Call :
        action : Action<'T> -> unit

Parameters

action
Type: SystemAction T

[Missing <param name="action"/> documentation for "M:Adf.Pool`1.Call(System.Action{`0})"]

See Also

Reference

PoolT Class
Call Overload


Pool(T).Call Method (Action(T), String, String)

PoolTCall Method (ActionT, String, String)
call

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Call(
    Action<T> action,
    string hashkey,
    string memberId
)
Public Sub Call (
    action As Action(Of T),
    hashkey As String,
    memberId As String
)
public:
void Call(
    Action<T>^ action,
    String^ hashkey,
    String^ memberId
)
member Call :
        action : Action<'T> *
        hashkey : string *
        memberId : string -> unit

Parameters

action
Type: SystemAction T

[Missing <param name="action"/> documentation for "M:Adf.Pool`1.Call(System.Action{`0},System.String,System.String)"]

hashkey
Type: SystemString
null is no hash
memberId
Type: SystemString
null is no memberid
See Also

Reference

PoolT Class
Call Overload


Pool(T).CallExceptionIsAbandon Method

PoolTCallExceptionIsAbandon Method
Call异常时指示该异常是否应禁止当前实例,默认处理 SocketException 异常，若有其它异常处理请自行重载判断

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual bool CallExceptionIsAbandon(
    Exception exception
)
Protected Overridable Function CallExceptionIsAbandon (
    exception As Exception
) As Boolean
protected:
virtual bool CallExceptionIsAbandon(
    Exception^ exception
)
abstract CallExceptionIsAbandon :
        exception : Exception -> bool
override CallExceptionIsAbandon :
        exception : Exception -> bool

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.Pool`1.CallExceptionIsAbandon(System.Exception)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Pool`1.CallExceptionIsAbandon(System.Exception)"]

See Also

Reference

PoolT Class


Pool(T).Dispose Method

PoolTDispose Method
Dispose

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

PoolT Class


Pool(T).OnNewInstanceException Method

PoolTOnNewInstanceException Method
trigger NewInstanceException event

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected void OnNewInstanceException(
    IPoolMember item,
    Exception exception
)
Protected Sub OnNewInstanceException (
    item As IPoolMember,
    exception As Exception
)
protected:
void OnNewInstanceException(
    IPoolMember^ item,
    Exception^ exception
)
member OnNewInstanceException :
        item : IPoolMember *
        exception : Exception -> unit

Parameters

item
Type: AdfIPoolMember

[Missing <param name="item"/> documentation for "M:Adf.Pool`1.OnNewInstanceException(Adf.IPoolMember,System.Exception)"]

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.Pool`1.OnNewInstanceException(Adf.IPoolMember,System.Exception)"]

See Also

Reference

PoolT Class


Pool(T) Properties

PoolT Properties

The PoolT generic type exposes the following members.

Properties
 | Name | Description
Public property | ActiveCount | Active Instance Count
Public property | HashVNodeCount | hash vnode count, zero is disable hash
Public property | MemberInstanceSize | pool size to member
Public property | Members | Elements
Public property | ResumeCheckInterval | Instance Re check Seconds, Default 60, zero ignore 实例异常恢复检测间隔
Public property | SupportHash | is support hash
Public property | Timeout | full wait timeout,default zero, not timeout
Top
See Also

Reference

PoolT Class


Pool(T).ActiveCount Property

PoolTActiveCount Property
Active Instance Count

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ActiveCount { get; }
Public ReadOnly Property ActiveCount As Integer
    Get
public:
property int ActiveCount {
    int get ();
}
member ActiveCount : int with get

Property Value

Type: Int32
See Also

Reference

PoolT Class


Pool(T).HashVNodeCount Property

PoolTHashVNodeCount Property
hash vnode count, zero is disable hash

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int HashVNodeCount { get; }
Public ReadOnly Property HashVNodeCount As Integer
    Get
public:
property int HashVNodeCount {
    int get ();
}
member HashVNodeCount : int with get

Property Value

Type: Int32
See Also

Reference

PoolT Class


Pool(T).MemberInstanceSize Property

PoolTMemberInstanceSize Property
pool size to member

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int MemberInstanceSize { get; }
Public ReadOnly Property MemberInstanceSize As Integer
    Get
public:
property int MemberInstanceSize {
    int get ();
}
member MemberInstanceSize : int with get

Property Value

Type: Int32
See Also

Reference

PoolT Class


Pool(T).Members Property

PoolTMembers Property
Elements

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IPoolMember[] Members { get; }
Public ReadOnly Property Members As IPoolMember()
    Get
public:
property array<IPoolMember^>^ Members {
    array<IPoolMember^>^ get ();
}
member Members : IPoolMember[] with get

Property Value

Type: IPoolMember
See Also

Reference

PoolT Class


Pool(T).ResumeCheckInterval Property

PoolTResumeCheckInterval Property
Instance Re check Seconds, Default 60, zero ignore 实例异常恢复检测间隔

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ResumeCheckInterval { get; set; }
Public Property ResumeCheckInterval As Integer
    Get
    Set
public:
property int ResumeCheckInterval {
    int get ();
    void set (int value);
}
member ResumeCheckInterval : int with get, set

Property Value

Type: Int32
See Also

Reference

PoolT Class


Pool(T).SupportHash Property

PoolTSupportHash Property
is support hash

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SupportHash { get; }
Public ReadOnly Property SupportHash As Boolean
    Get
public:
property bool SupportHash {
    bool get ();
}
member SupportHash : bool with get

Property Value

Type: Boolean
See Also

Reference

PoolT Class


Pool(T).Timeout Property

PoolTTimeout Property
full wait timeout,default zero, not timeout

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Timeout { get; set; }
Public Property Timeout As Integer
    Get
    Set
public:
property int Timeout {
    int get ();
    void set (int value);
}
member Timeout : int with get, set

Property Value

Type: Int32
See Also

Reference

PoolT Class


Pool(T) Events

PoolT Events

The PoolT generic type exposes the following members.

Events
 | Name | Description
Public event | NewInstanceException | new element exception
Top
See Also

Reference

PoolT Class


Pool(T).NewInstanceException Event

PoolTNewInstanceException Event
new element exception

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<PoolNewInstanceExceptionEventArgs> NewInstanceException
Public Event NewInstanceException As EventHandler(Of PoolNewInstanceExceptionEventArgs)
public:
 event EventHandler<PoolNewInstanceExceptionEventArgs^>^ NewInstanceException {
    void add (EventHandler<PoolNewInstanceExceptionEventArgs^>^ value);
    void remove (EventHandler<PoolNewInstanceExceptionEventArgs^>^ value);
}
member NewInstanceException : IEvent<EventHandler<PoolNewInstanceExceptionEventArgs>,
    PoolNewInstanceExceptionEventArgs>

Value

Type: SystemEventHandler PoolNewInstanceExceptionEventArgs
See Also

Reference

PoolT Class


PoolException Class

PoolException Class
Pool Item Info
Inheritance Hierarchy
SystemObject
SystemException
AdfPoolException

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class PoolException : Exception
Public Class PoolException
    Inherits Exception
public ref class PoolException : public Exception
type PoolException =
    class
        inherit Exception
    end

The PoolException type exposes the following members.

Constructors
 | Name | Description
Public method | PoolException | initialize
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference


PoolException Constructor

PoolException Constructor
initialize

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public PoolException(
    string message
)
Public Sub New (
    message As String
)
public:
PoolException(
    String^ message
)
new :
        message : string -> PoolException

Parameters

message
Type: SystemString

[Missing <param name="message"/> documentation for "M:Adf.PoolException.#ctor(System.String)"]

See Also

Reference

PoolException Class


PoolException Methods

PoolException Methods

The PoolException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
See Also

Reference

PoolException Class


PoolException Properties

PoolException Properties

The PoolException type exposes the following members.

Properties
 | Name | Description
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference

PoolException Class


PoolNewInstanceExceptionEventArgs Class

PoolNewInstanceExceptionEventArgs Class
Pool Item New Element Info
Inheritance Hierarchy
SystemObject
SystemEventArgs
AdfPoolNewInstanceExceptionEventArgs

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class PoolNewInstanceExceptionEventArgs : EventArgs
Public Class PoolNewInstanceExceptionEventArgs
    Inherits EventArgs
public ref class PoolNewInstanceExceptionEventArgs : public EventArgs
type PoolNewInstanceExceptionEventArgs =
    class
        inherit EventArgs
    end

The PoolNewInstanceExceptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Exception | exception
Public property | Item | item
Top
See Also

Reference


PoolNewInstanceExceptionEventArgs Methods

PoolNewInstanceExceptionEventArgs Methods

The PoolNewInstanceExceptionEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

PoolNewInstanceExceptionEventArgs Class


PoolNewInstanceExceptionEventArgs Properties

PoolNewInstanceExceptionEventArgs Properties

The PoolNewInstanceExceptionEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Exception | exception
Public property | Item | item
Top
See Also

Reference

PoolNewInstanceExceptionEventArgs Class


PoolNewInstanceExceptionEventArgs.Exception Property

PoolNewInstanceExceptionEventArgsException Property
exception

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Exception Exception { get; }
Public ReadOnly Property Exception As Exception
    Get
public:
property Exception^ Exception {
    Exception^ get ();
}
member Exception : Exception with get

Property Value

Type: Exception
See Also

Reference

PoolNewInstanceExceptionEventArgs Class


PoolNewInstanceExceptionEventArgs.Item Property

PoolNewInstanceExceptionEventArgsItem Property
item

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IPoolMember Item { get; }
Public ReadOnly Property Item As IPoolMember
    Get
public:
property IPoolMember^ Item {
    IPoolMember^ get ();
}
member Item : IPoolMember with get

Property Value

Type: IPoolMember
See Also

Reference

PoolNewInstanceExceptionEventArgs Class


PropertyAccessor Class

PropertyAccessor Class
属性访问器
Inheritance Hierarchy
SystemObject
AdfPropertyAccessor

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class PropertyAccessor
Public Class PropertyAccessor
public ref class PropertyAccessor
type PropertyAccessor =  class end

The PropertyAccessor type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyAccessor | Initializes a new instance of the PropertyAccessor class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | GetGets(Object) | 获取实例所有可读属性列表
 | GetGets(Type) | 获取目标类型所有可读属性列表
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetSets(Object) | 获取实例所有可写属性列表
 | GetSets(Type) | 获取目标类型所有可写属性列表
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetValue | 获取属性值
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | SetValue | 设置属性值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


PropertyAccessor Constructor

PropertyAccessor Constructor
Initializes a new instance of the PropertyAccessor class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public PropertyAccessor()
Public Sub New
public:
PropertyAccessor()
new : unit -> PropertyAccessor
See Also

Reference

PropertyAccessor Class


PropertyAccessor Methods

PropertyAccessor Methods

The PropertyAccessor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | GetGets(Object) | 获取实例所有可读属性列表
 | GetGets(Type) | 获取目标类型所有可读属性列表
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetSets(Object) | 获取实例所有可写属性列表
 | GetSets(Type) | 获取目标类型所有可写属性列表
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetValue | 获取属性值
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | SetValue | 设置属性值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

PropertyAccessor Class


PropertyAccessor.GetGets Method

PropertyAccessorGetGets Method
Overload List
Name | Description
GetGets(Object) | 获取实例所有可读属性列表
GetGets(Type) | 获取目标类型所有可读属性列表
Top
See Also

Reference

PropertyAccessor Class


PropertyAccessor.GetGets Method (Object)

PropertyAccessorGetGets Method (Object)
获取实例所有可读属性列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static PropertyAccessorPropertyAccessorItem[] GetGets(
    Object instance
)
Public Shared Function GetGets (
    instance As Object
) As PropertyAccessorPropertyAccessorItem()
public:
static array<PropertyAccessorPropertyAccessorItem^>^ GetGets(
    Object^ instance
)
static member GetGets :
        instance : Object -> PropertyAccessorPropertyAccessorItem[]

Parameters

instance
Type: SystemObject

[Missing <param name="instance"/> documentation for "M:Adf.PropertyAccessor.GetGets(System.Object)"]

Return Value

Type: PropertyAccessorPropertyAccessorItem

[Missing <returns> documentation for "M:Adf.PropertyAccessor.GetGets(System.Object)"]

See Also

Reference

PropertyAccessor Class
GetGets Overload


PropertyAccessor.GetGets Method (Type)

PropertyAccessorGetGets Method (Type)
获取目标类型所有可读属性列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static PropertyAccessorPropertyAccessorItem[] GetGets(
    Type type
)
Public Shared Function GetGets (
    type As Type
) As PropertyAccessorPropertyAccessorItem()
public:
static array<PropertyAccessorPropertyAccessorItem^>^ GetGets(
    Type^ type
)
static member GetGets :
        type : Type -> PropertyAccessorPropertyAccessorItem[]

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.PropertyAccessor.GetGets(System.Type)"]

Return Value

Type: PropertyAccessorPropertyAccessorItem

[Missing <returns> documentation for "M:Adf.PropertyAccessor.GetGets(System.Type)"]

See Also

Reference

PropertyAccessor Class
GetGets Overload


PropertyAccessor.GetSets Method

PropertyAccessorGetSets Method
Overload List
Name | Description
GetSets(Object) | 获取实例所有可写属性列表
GetSets(Type) | 获取目标类型所有可写属性列表
Top
See Also

Reference

PropertyAccessor Class


PropertyAccessor.GetSets Method (Object)

PropertyAccessorGetSets Method (Object)
获取实例所有可写属性列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static PropertyAccessorPropertyAccessorItem[] GetSets(
    Object instance
)
Public Shared Function GetSets (
    instance As Object
) As PropertyAccessorPropertyAccessorItem()
public:
static array<PropertyAccessorPropertyAccessorItem^>^ GetSets(
    Object^ instance
)
static member GetSets :
        instance : Object -> PropertyAccessorPropertyAccessorItem[]

Parameters

instance
Type: SystemObject

[Missing <param name="instance"/> documentation for "M:Adf.PropertyAccessor.GetSets(System.Object)"]

Return Value

Type: PropertyAccessorPropertyAccessorItem

[Missing <returns> documentation for "M:Adf.PropertyAccessor.GetSets(System.Object)"]

See Also

Reference

PropertyAccessor Class
GetSets Overload


PropertyAccessor.GetSets Method (Type)

PropertyAccessorGetSets Method (Type)
获取目标类型所有可写属性列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static PropertyAccessorPropertyAccessorItem[] GetSets(
    Type type
)
Public Shared Function GetSets (
    type As Type
) As PropertyAccessorPropertyAccessorItem()
public:
static array<PropertyAccessorPropertyAccessorItem^>^ GetSets(
    Type^ type
)
static member GetSets :
        type : Type -> PropertyAccessorPropertyAccessorItem[]

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.PropertyAccessor.GetSets(System.Type)"]

Return Value

Type: PropertyAccessorPropertyAccessorItem

[Missing <returns> documentation for "M:Adf.PropertyAccessor.GetSets(System.Type)"]

See Also

Reference

PropertyAccessor Class
GetSets Overload


PropertyAccessor.GetValue Method

PropertyAccessorGetValue Method
获取属性值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Object GetValue(
    Object instance,
    string memberName
)
Public Shared Function GetValue (
    instance As Object,
    memberName As String
) As Object
public:
static Object^ GetValue(
    Object^ instance,
    String^ memberName
)
static member GetValue :
        instance : Object *
        memberName : string -> Object

Parameters

instance
Type: SystemObject

[Missing <param name="instance"/> documentation for "M:Adf.PropertyAccessor.GetValue(System.Object,System.String)"]

memberName
Type: SystemString

[Missing <param name="memberName"/> documentation for "M:Adf.PropertyAccessor.GetValue(System.Object,System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.PropertyAccessor.GetValue(System.Object,System.String)"]

See Also

Reference

PropertyAccessor Class


PropertyAccessor.SetValue Method

PropertyAccessorSetValue Method
设置属性值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void SetValue(
    Object instance,
    string memberName,
    Object newValue
)
Public Shared Sub SetValue (
    instance As Object,
    memberName As String,
    newValue As Object
)
public:
static void SetValue(
    Object^ instance,
    String^ memberName,
    Object^ newValue
)
static member SetValue :
        instance : Object *
        memberName : string *
        newValue : Object -> unit

Parameters

instance
Type: SystemObject

[Missing <param name="instance"/> documentation for "M:Adf.PropertyAccessor.SetValue(System.Object,System.String,System.Object)"]

memberName
Type: SystemString

[Missing <param name="memberName"/> documentation for "M:Adf.PropertyAccessor.SetValue(System.Object,System.String,System.Object)"]

newValue
Type: SystemObject

[Missing <param name="newValue"/> documentation for "M:Adf.PropertyAccessor.SetValue(System.Object,System.String,System.Object)"]

See Also

Reference

PropertyAccessor Class


PropertyAccessor.PropertyAccessorItem Class

PropertyAccessorPropertyAccessorItem Class
属性访问项
Inheritance Hierarchy
SystemObject
AdfPropertyAccessorPropertyAccessorItem

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class PropertyAccessorItem
Public Class PropertyAccessorItem
public ref class PropertyAccessorItem
type PropertyAccessorItem =  class end

The PropertyAccessorPropertyAccessorItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Method | 相当方法
Public property | PropertyInfo | 属性
Top
See Also

Reference


PropertyAccessorItem Methods

PropertyAccessorItem Methods

The PropertyAccessorPropertyAccessorItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

PropertyAccessorPropertyAccessorItem Class


PropertyAccessorItem Properties

PropertyAccessorItem Properties

The PropertyAccessorPropertyAccessorItem type exposes the following members.

Properties
 | Name | Description
Public property | Method | 相当方法
Public property | PropertyInfo | 属性
Top
See Also

Reference

PropertyAccessorPropertyAccessorItem Class


PropertyAccessor.PropertyAccessorItem.Method Property

PropertyAccessorPropertyAccessorItemMethod Property
相当方法

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MethodInfo Method { get; }
Public ReadOnly Property Method As MethodInfo
    Get
public:
property MethodInfo^ Method {
    MethodInfo^ get ();
}
member Method : MethodInfo with get

Property Value

Type: MethodInfo
See Also

Reference

PropertyAccessorPropertyAccessorItem Class


PropertyAccessor.PropertyAccessorItem.PropertyInfo Property

PropertyAccessorPropertyAccessorItemPropertyInfo Property
属性

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public PropertyInfo PropertyInfo { get; }
Public ReadOnly Property PropertyInfo As PropertyInfo
    Get
public:
property PropertyInfo^ PropertyInfo {
    PropertyInfo^ get ();
}
member PropertyInfo : PropertyInfo with get

Property Value

Type: PropertyInfo
See Also

Reference

PropertyAccessorPropertyAccessorItem Class


RandomHelper Class

RandomHelper Class
随机数
Inheritance Hierarchy
SystemObject
AdfRandomHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class RandomHelper
Public NotInheritable Class RandomHelper
public ref class RandomHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RandomHelper =  class end

The RandomHelper type exposes the following members.

Methods
Name | Description
Letter | 生成字母组成的随机字符串
LetterAndNumber | 生成一个字母与数字随机字符串
LowerLetter | 生成一个小写字母组成的随机字符串
LowerLetterAndNumber | 生成一个小写字母与数字随机字符串
Number | 生成指定位数的随机0-9数字字符串
Top
See Also

Reference


RandomHelper Methods

RandomHelper Methods

The RandomHelper type exposes the following members.

Methods
Name | Description
Letter | 生成字母组成的随机字符串
LetterAndNumber | 生成一个字母与数字随机字符串
LowerLetter | 生成一个小写字母组成的随机字符串
LowerLetterAndNumber | 生成一个小写字母与数字随机字符串
Number | 生成指定位数的随机0-9数字字符串
Top
See Also

Reference

RandomHelper Class


RandomHelper.Letter Method

RandomHelperLetter Method
生成字母组成的随机字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Letter(
    int size
)
Public Shared Function Letter (
    size As Integer
) As String
public:
static String^ Letter(
    int size
)
static member Letter :
        size : int -> string

Parameters

size
Type: SystemInt32
随机字符串长度

Return Value

Type: String
返回生成的字符串
See Also

Reference

RandomHelper Class


RandomHelper.LetterAndNumber Method

RandomHelperLetterAndNumber Method
生成一个字母与数字随机字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string LetterAndNumber(
    int size
)
Public Shared Function LetterAndNumber (
    size As Integer
) As String
public:
static String^ LetterAndNumber(
    int size
)
static member LetterAndNumber :
        size : int -> string

Parameters

size
Type: SystemInt32
随机字符串长度

Return Value

Type: String
返回生成的字符串
See Also

Reference

RandomHelper Class


RandomHelper.LowerLetter Method

RandomHelperLowerLetter Method
生成一个小写字母组成的随机字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string LowerLetter(
    int size
)
Public Shared Function LowerLetter (
    size As Integer
) As String
public:
static String^ LowerLetter(
    int size
)
static member LowerLetter :
        size : int -> string

Parameters

size
Type: SystemInt32
随机字符串长度

Return Value

Type: String
返回生成的字符串
See Also

Reference

RandomHelper Class


RandomHelper.LowerLetterAndNumber Method

RandomHelperLowerLetterAndNumber Method
生成一个小写字母与数字随机字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string LowerLetterAndNumber(
    int size
)
Public Shared Function LowerLetterAndNumber (
    size As Integer
) As String
public:
static String^ LowerLetterAndNumber(
    int size
)
static member LowerLetterAndNumber :
        size : int -> string

Parameters

size
Type: SystemInt32
随机字符串长度

Return Value

Type: String
返回生成的字符串
See Also

Reference

RandomHelper Class


RandomHelper.Number Method

RandomHelperNumber Method
生成指定位数的随机0-9数字字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Number(
    int size
)
Public Shared Function Number (
    size As Integer
) As String
public:
static String^ Number(
    int size
)
static member Number :
        size : int -> string

Parameters

size
Type: SystemInt32
随机字符串长度

Return Value

Type: String
返回生成的字符串
See Also

Reference

RandomHelper Class


RedisAggregate Enumeration

RedisAggregate Enumeration
集合类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public enum RedisAggregate
Public Enumeration RedisAggregate
public enum class RedisAggregate
type RedisAggregate
Members
Member name | Value | Description
SUM | 0 | 和
MIN | 1 | 最小值
MAX | 2 | 最大值
See Also

Reference


RedisClient Class

RedisClient Class
Redis 客户端
Inheritance Hierarchy
SystemObject
AdfRedisClient

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisClient : ICache,
    IPoolInstance, IDisposable
Public Class RedisClient
    Implements ICache, IPoolInstance, IDisposable
public ref class RedisClient : ICache,
    IPoolInstance, IDisposable
type RedisClient =
    class
        interface ICache
        interface IPoolInstance
        interface IDisposable
    end

The RedisClient type exposes the following members.

Constructors
 | Name | Description
Public method | RedisClient | 初始化默认实例
Public method | RedisClient(String) | 初始化实例
Public method | RedisClient(String, Int32) | 初始化
Top
Methods
 | Name | Description
Public method | Append | 设置一个二进制值
Public method | BackgroundSave | 背景保存
Public method | Decrement(String) | 自减一
Public method | Decrement(String, Int32) | 自减指定数值
Public method | Delete | 删除一个缓存值
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 确认一个键是否存在
Public method | Expire | 设置键过期间隔
Public method | ExpireAt | 设置键绝对过期时间
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FlushAll | 清空数据
Public method | FlushDb | 清空当前DB
Public method | Get(String) | 获取字符串结果
Public method | GetT(String) | 获取一个对象
Public method | GetByteKeys | 获取键键值列表
Public method | GetBytes | 获取节字数组
Public method | GetDbSize | 获取数据库大小
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInfo | 获取服务器信息
Public method | GetKeys | 获取所有键列表
Public method | GetKeys(String) | 获取匹配的键列表
Public method | GetKeys(String) | 获取键的字符串值列表
Public method | GetSet(String, Byte) | 获取并设置一个新值
Public method | GetSet(String, String) | 获取并设置一个新值
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Increment(String) | 自加一
Public method | Increment(String, Int32) | 自加一个数值
Public method | LastSave | 获取最后保存时间
Public method | Length | 获取一个键值长度
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | RandomKey | 随机获取一个键
Public method | Remove(String) | 删除一个键
Public method | Remove(String) | 删除一批键
Public method | Rename | 重命名一个键
Public method | Save | 保存
Public method | Set(IDictionaryString, Byte) | 设置一组数据(MSET)
Public method | Set(IDictionaryString, String) | 设置一组字符串(MSET)
Public method | Set(String, Byte) | 设置一个二进制值
Public method | Set(String, String) | 设置一个字符串值
Public method | Set(String, Object, Int32) | 设置一个值
Public method | SetEX(String, Byte, Int32) | 设置一个值并指定过期时间
Public method | SetEX(String, String, Int32) | 设置一个值并指定过期时间
Public method | SetNX(String, Byte) | 设置一个值，当键已存在时则忽略
Public method | SetNX(String, String) | 设置一个值，当键已存在时则忽略
Public method | Shutdown | 关闭
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TTL | 获取一个键的TTL值
Public method | TypeOf | 获取键类型
Top
Properties
 | Name | Description
Public property | BinarySerializable | 获取或设置二进制序列化器,默认 JsonBinarySerializable, 可通过在appsetting中配置 RedisClientBinarySerializable 来指定其它实例
Protected property | Connection | 连接
Public property | Encoding | 字符编码
Public property | Hashs | 获取哈希表
Public property | Host |
Public property | Lists | 获取列表
Public property | Password |
Public property | PoolAbandon | 是否从池中废弃此实例
Public property | Port |
Public property | SendTimeout |
Public property | Sets | 获取集合
Public property | SortedSets | 获取有序集合
Top
See Also

Reference


RedisClient Constructor

RedisClient Constructor
Overload List
 | Name | Description
Public method | RedisClient | 初始化默认实例
Public method | RedisClient(String) | 初始化实例
Public method | RedisClient(String, Int32) | 初始化
Top
See Also

Reference

RedisClient Class


RedisClient Constructor

RedisClient Constructor
初始化默认实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisClient()
Public Sub New
public:
RedisClient()
new : unit -> RedisClient
See Also

Reference

RedisClient Class
RedisClient Overload


RedisClient Constructor (String)

RedisClient Constructor (String)
初始化实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisClient(
    string host
)
Public Sub New (
    host As String
)
public:
RedisClient(
    String^ host
)
new :
        host : string -> RedisClient

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.RedisClient.#ctor(System.String)"]

See Also

Reference

RedisClient Class
RedisClient Overload


RedisClient Constructor (String, Int32)

RedisClient Constructor (String, Int32)
初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisClient(
    string host,
    int port
)
Public Sub New (
    host As String,
    port As Integer
)
public:
RedisClient(
    String^ host,
    int port
)
new :
        host : string *
        port : int -> RedisClient

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.RedisClient.#ctor(System.String,System.Int32)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.RedisClient.#ctor(System.String,System.Int32)"]

See Also

Reference

RedisClient Class
RedisClient Overload


RedisClient Methods

RedisClient Methods

The RedisClient type exposes the following members.

Methods
 | Name | Description
Public method | Append | 设置一个二进制值
Public method | BackgroundSave | 背景保存
Public method | Decrement(String) | 自减一
Public method | Decrement(String, Int32) | 自减指定数值
Public method | Delete | 删除一个缓存值
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 确认一个键是否存在
Public method | Expire | 设置键过期间隔
Public method | ExpireAt | 设置键绝对过期时间
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FlushAll | 清空数据
Public method | FlushDb | 清空当前DB
Public method | Get(String) | 获取字符串结果
Public method | GetT(String) | 获取一个对象
Public method | GetByteKeys | 获取键键值列表
Public method | GetBytes | 获取节字数组
Public method | GetDbSize | 获取数据库大小
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInfo | 获取服务器信息
Public method | GetKeys | 获取所有键列表
Public method | GetKeys(String) | 获取匹配的键列表
Public method | GetKeys(String) | 获取键的字符串值列表
Public method | GetSet(String, Byte) | 获取并设置一个新值
Public method | GetSet(String, String) | 获取并设置一个新值
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Increment(String) | 自加一
Public method | Increment(String, Int32) | 自加一个数值
Public method | LastSave | 获取最后保存时间
Public method | Length | 获取一个键值长度
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | RandomKey | 随机获取一个键
Public method | Remove(String) | 删除一个键
Public method | Remove(String) | 删除一批键
Public method | Rename | 重命名一个键
Public method | Save | 保存
Public method | Set(IDictionaryString, Byte) | 设置一组数据(MSET)
Public method | Set(IDictionaryString, String) | 设置一组字符串(MSET)
Public method | Set(String, Byte) | 设置一个二进制值
Public method | Set(String, String) | 设置一个字符串值
Public method | Set(String, Object, Int32) | 设置一个值
Public method | SetEX(String, Byte, Int32) | 设置一个值并指定过期时间
Public method | SetEX(String, String, Int32) | 设置一个值并指定过期时间
Public method | SetNX(String, Byte) | 设置一个值，当键已存在时则忽略
Public method | SetNX(String, String) | 设置一个值，当键已存在时则忽略
Public method | Shutdown | 关闭
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TTL | 获取一个键的TTL值
Public method | TypeOf | 获取键类型
Top
See Also

Reference

RedisClient Class


RedisClient.Append Method

RedisClientAppend Method
设置一个二进制值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Append(
    string key,
    string value
)
Public Function Append (
    key As String,
    value As String
) As Integer
public:
int Append(
    String^ key,
    String^ value
)
member Append :
        key : string *
        value : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Append(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.Append(System.String,System.String)"]

Return Value

Type: Int32
返回文本新长度
See Also

Reference

RedisClient Class


RedisClient.BackgroundSave Method

RedisClientBackgroundSave Method
背景保存

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void BackgroundSave()
Public Sub BackgroundSave
public:
void BackgroundSave()
member BackgroundSave : unit -> unit
See Also

Reference

RedisClient Class


RedisClient.Decrement Method

RedisClientDecrement Method
Overload List
 | Name | Description
Public method | Decrement(String) | 自减一
Public method | Decrement(String, Int32) | 自减指定数值
Top
See Also

Reference

RedisClient Class


RedisClient.Decrement Method (String)

RedisClientDecrement Method (String)
自减一

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Decrement(
    string key
)
Public Function Decrement (
    key As String
) As Integer
public:
int Decrement(
    String^ key
)
member Decrement :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Decrement(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisClient.Decrement(System.String)"]

See Also

Reference

RedisClient Class
Decrement Overload


RedisClient.Decrement Method (String, Int32)

RedisClientDecrement Method (String, Int32)
自减指定数值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Decrement(
    string key,
    int count
)
Public Function Decrement (
    key As String,
    count As Integer
) As Integer
public:
int Decrement(
    String^ key,
    int count
)
member Decrement :
        key : string *
        count : int -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Decrement(System.String,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:Adf.RedisClient.Decrement(System.String,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisClient.Decrement(System.String,System.Int32)"]

See Also

Reference

RedisClient Class
Decrement Overload


RedisClient.Delete Method

RedisClientDelete Method
删除一个缓存值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Delete(
    string key
)
Public Sub Delete (
    key As String
)
public:
virtual void Delete(
    String^ key
) sealed
abstract Delete :
        key : string -> unit
override Delete :
        key : string -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Delete(System.String)"]

Implements

ICacheDelete(String)
See Also

Reference

RedisClient Class


RedisClient.Dispose Method

RedisClientDispose Method
资源释放

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RedisClient Class


RedisClient.Exists Method

RedisClientExists Method
确认一个键是否存在

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Exists(
    string key
)
Public Function Exists (
    key As String
) As Boolean
public:
bool Exists(
    String^ key
)
member Exists :
        key : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Exists(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Exists(System.String)"]

See Also

Reference

RedisClient Class


RedisClient.Expire Method

RedisClientExpire Method
设置键过期间隔

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Expire(
    string key,
    int seconds
)
Public Function Expire (
    key As String,
    seconds As Integer
) As Boolean
public:
bool Expire(
    String^ key,
    int seconds
)
member Expire :
        key : string *
        seconds : int -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Expire(System.String,System.Int32)"]

seconds
Type: SystemInt32

[Missing <param name="seconds"/> documentation for "M:Adf.RedisClient.Expire(System.String,System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Expire(System.String,System.Int32)"]

See Also

Reference

RedisClient Class


RedisClient.ExpireAt Method

RedisClientExpireAt Method
设置键绝对过期时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool ExpireAt(
    string key,
    int timestamp
)
Public Function ExpireAt (
    key As String,
    timestamp As Integer
) As Boolean
public:
bool ExpireAt(
    String^ key,
    int timestamp
)
member ExpireAt :
        key : string *
        timestamp : int -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.ExpireAt(System.String,System.Int32)"]

timestamp
Type: SystemInt32

[Missing <param name="timestamp"/> documentation for "M:Adf.RedisClient.ExpireAt(System.String,System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.ExpireAt(System.String,System.Int32)"]

See Also

Reference

RedisClient Class


RedisClient.FlushAll Method

RedisClientFlushAll Method
清空数据

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void FlushAll()
Public Sub FlushAll
public:
void FlushAll()
member FlushAll : unit -> unit
See Also

Reference

RedisClient Class


RedisClient.FlushDb Method

RedisClientFlushDb Method
清空当前DB

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void FlushDb()
Public Sub FlushDb
public:
void FlushDb()
member FlushDb : unit -> unit
See Also

Reference

RedisClient Class


RedisClient.Get Method

RedisClientGet Method
Overload List
 | Name | Description
Public method | Get(String) | 获取字符串结果
Public method | GetT(String) | 获取一个对象
Top
See Also

Reference

RedisClient Class


RedisClient.Get Method (String)

RedisClientGet Method (String)
获取字符串结果

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Get(
    string key
)
Public Function Get (
    key As String
) As String
public:
virtual String^ Get(
    String^ key
) sealed
abstract Get :
        key : string -> string
override Get :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Get(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisClient.Get(System.String)"]

Implements

ICacheGet(String)
See Also

Reference

RedisClient Class
Get Overload


RedisClient.Get(T) Method (String)

RedisClientGetT Method (String)
获取一个对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T Get<T>(
    string key
)

Public Function Get(Of T) (
    key As String
) As T
public:
generic<typename T>
virtual T Get(
    String^ key
) sealed
abstract Get :
        key : string -> 'T
override Get :
        key : string -> 'T

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Get``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.RedisClient.Get``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.RedisClient.Get``1(System.String)"]

Implements

ICacheGetT(String)
See Also

Reference

RedisClient Class
Get Overload


RedisClient.GetByteKeys Method

RedisClientGetByteKeys Method
获取键键值列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] GetByteKeys(
    params string[] keys
)
Public Function GetByteKeys (
    ParamArray keys As String()
) As Byte()()
public:
array<array<unsigned char>^>^ GetByteKeys(
    ... array<String^>^ keys
)
member GetByteKeys :
        keys : string[] -> byte[][]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisClient.GetByteKeys(System.String[])"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisClient.GetByteKeys(System.String[])"]

See Also

Reference

RedisClient Class


RedisClient.GetBytes Method

RedisClientGetBytes Method
获取节字数组

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ArraySegment<byte> GetBytes(
    string key
)
Public Function GetBytes (
    key As String
) As ArraySegment(Of Byte)
public:
ArraySegment<unsigned char> GetBytes(
    String^ key
)
member GetBytes :
        key : string -> ArraySegment<byte>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.GetBytes(System.String)"]

Return Value

Type: ArraySegment Byte

[Missing <returns> documentation for "M:Adf.RedisClient.GetBytes(System.String)"]

See Also

Reference

RedisClient Class


RedisClient.GetDbSize Method

RedisClientGetDbSize Method
获取数据库大小

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int GetDbSize()
Public Function GetDbSize As Integer
public:
int GetDbSize()
member GetDbSize : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisClient.GetDbSize"]

See Also

Reference

RedisClient Class


RedisClient.GetInfo Method

RedisClientGetInfo Method
获取服务器信息

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> GetInfo()
Public Function GetInfo As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ GetInfo()
member GetInfo : unit -> Dictionary<string, string>

Return Value

Type: Dictionary String, String

[Missing <returns> documentation for "M:Adf.RedisClient.GetInfo"]

See Also

Reference

RedisClient Class


RedisClient.GetKeys Method

RedisClientGetKeys Method
Overload List
 | Name | Description
Public method | GetKeys | 获取所有键列表
Public method | GetKeys(String) | 获取匹配的键列表
Public method | GetKeys(String) | 获取键的字符串值列表
Top
See Also

Reference

RedisClient Class


RedisClient.GetKeys Method

RedisClientGetKeys Method
获取所有键列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] GetKeys()
Public Function GetKeys As String()
public:
array<String^>^ GetKeys()
member GetKeys : unit -> string[]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisClient.GetKeys"]

See Also

Reference

RedisClient Class
GetKeys Overload


RedisClient.GetKeys Method (String)

RedisClientGetKeys Method (String)
获取匹配的键列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] GetKeys(
    string pattern
)
Public Function GetKeys (
    pattern As String
) As String()
public:
array<String^>^ GetKeys(
    String^ pattern
)
member GetKeys :
        pattern : string -> string[]

Parameters

pattern
Type: SystemString
匹配规则

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisClient.GetKeys(System.String)"]

See Also

Reference

RedisClient Class
GetKeys Overload


RedisClient.GetKeys Method (String[])

RedisClientGetKeys Method (String)
获取键的字符串值列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] GetKeys(
    params string[] keys
)
Public Function GetKeys (
    ParamArray keys As String()
) As String()
public:
array<String^>^ GetKeys(
    ... array<String^>^ keys
)
member GetKeys :
        keys : string[] -> string[]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisClient.GetKeys(System.String[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisClient.GetKeys(System.String[])"]

See Also

Reference

RedisClient Class
GetKeys Overload


RedisClient.GetSet Method

RedisClientGetSet Method
Overload List
 | Name | Description
Public method | GetSet(String, Byte) | 获取并设置一个新值
Public method | GetSet(String, String) | 获取并设置一个新值
Top
See Also

Reference

RedisClient Class


RedisClient.GetSet Method (String, Byte[])

RedisClientGetSet Method (String, Byte)
获取并设置一个新值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ArraySegment<byte> GetSet(
    string key,
    byte[] value
)
Public Function GetSet (
    key As String,
    value As Byte()
) As ArraySegment(Of Byte)
public:
ArraySegment<unsigned char> GetSet(
    String^ key,
    array<unsigned char>^ value
)
member GetSet :
        key : string *
        value : byte[] -> ArraySegment<byte>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.GetSet(System.String,System.Byte[])"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.GetSet(System.String,System.Byte[])"]

Return Value

Type: ArraySegment Byte

[Missing <returns> documentation for "M:Adf.RedisClient.GetSet(System.String,System.Byte[])"]

See Also

Reference

RedisClient Class
GetSet Overload


RedisClient.GetSet Method (String, String)

RedisClientGetSet Method (String, String)
获取并设置一个新值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string GetSet(
    string key,
    string value
)
Public Function GetSet (
    key As String,
    value As String
) As String
public:
String^ GetSet(
    String^ key,
    String^ value
)
member GetSet :
        key : string *
        value : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.GetSet(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.GetSet(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisClient.GetSet(System.String,System.String)"]

See Also

Reference

RedisClient Class
GetSet Overload


RedisClient.Increment Method

RedisClientIncrement Method
Overload List
 | Name | Description
Public method | Increment(String) | 自加一
Public method | Increment(String, Int32) | 自加一个数值
Top
See Also

Reference

RedisClient Class


RedisClient.Increment Method (String)

RedisClientIncrement Method (String)
自加一

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Increment(
    string key
)
Public Function Increment (
    key As String
) As Integer
public:
int Increment(
    String^ key
)
member Increment :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Increment(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisClient.Increment(System.String)"]

See Also

Reference

RedisClient Class
Increment Overload


RedisClient.Increment Method (String, Int32)

RedisClientIncrement Method (String, Int32)
自加一个数值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Increment(
    string key,
    int count
)
Public Function Increment (
    key As String,
    count As Integer
) As Integer
public:
int Increment(
    String^ key,
    int count
)
member Increment :
        key : string *
        count : int -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Increment(System.String,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:Adf.RedisClient.Increment(System.String,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisClient.Increment(System.String,System.Int32)"]

See Also

Reference

RedisClient Class
Increment Overload


RedisClient.LastSave Method

RedisClientLastSave Method
获取最后保存时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DateTime LastSave()
Public Function LastSave As DateTime
public:
DateTime LastSave()
member LastSave : unit -> DateTime

Return Value

Type: DateTime

[Missing <returns> documentation for "M:Adf.RedisClient.LastSave"]

See Also

Reference

RedisClient Class


RedisClient.Length Method

RedisClientLength Method
获取一个键值长度

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Length(
    string key
)
Public Function Length (
    key As String
) As Integer
public:
int Length(
    String^ key
)
member Length :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Length(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisClient.Length(System.String)"]

See Also

Reference

RedisClient Class


RedisClient.RandomKey Method

RedisClientRandomKey Method
随机获取一个键

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string RandomKey()
Public Function RandomKey As String
public:
String^ RandomKey()
member RandomKey : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisClient.RandomKey"]

See Also

Reference

RedisClient Class


RedisClient.Remove Method

RedisClientRemove Method
Overload List
 | Name | Description
Public method | Remove(String) | 删除一个键
Public method | Remove(String) | 删除一批键
Top
See Also

Reference

RedisClient Class


RedisClient.Remove Method (String)

RedisClientRemove Method (String)
删除一个键

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Remove(
    string key
)
Public Function Remove (
    key As String
) As Boolean
public:
bool Remove(
    String^ key
)
member Remove :
        key : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Remove(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Remove(System.String)"]

See Also

Reference

RedisClient Class
Remove Overload


RedisClient.Remove Method (String[])

RedisClientRemove Method (String)
删除一批键

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Remove(
    params string[] args
)
Public Function Remove (
    ParamArray args As String()
) As Integer
public:
int Remove(
    ... array<String^>^ args
)
member Remove :
        args : string[] -> int

Parameters

args
Type: SystemString

[Missing <param name="args"/> documentation for "M:Adf.RedisClient.Remove(System.String[])"]

Return Value

Type: Int32
返回删除的个数
See Also

Reference

RedisClient Class
Remove Overload


RedisClient.Rename Method

RedisClientRename Method
重命名一个键

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Rename(
    string oldKeyname,
    string newKeyname
)
Public Function Rename (
    oldKeyname As String,
    newKeyname As String
) As Boolean
public:
bool Rename(
    String^ oldKeyname,
    String^ newKeyname
)
member Rename :
        oldKeyname : string *
        newKeyname : string -> bool

Parameters

oldKeyname
Type: SystemString

[Missing <param name="oldKeyname"/> documentation for "M:Adf.RedisClient.Rename(System.String,System.String)"]

newKeyname
Type: SystemString

[Missing <param name="newKeyname"/> documentation for "M:Adf.RedisClient.Rename(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Rename(System.String,System.String)"]

See Also

Reference

RedisClient Class


RedisClient.Save Method

RedisClientSave Method
保存

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit

Return Value

Type:
See Also

Reference

RedisClient Class


RedisClient.Set Method

RedisClientSet Method
Overload List
 | Name | Description
Public method | Set(IDictionaryString, Byte) | 设置一组数据(MSET)
Public method | Set(IDictionaryString, String) | 设置一组字符串(MSET)
Public method | Set(String, Byte) | 设置一个二进制值
Public method | Set(String, String) | 设置一个字符串值
Public method | Set(String, Object, Int32) | 设置一个值
Top
See Also

Reference

RedisClient Class


RedisClient.Set Method (IDictionary(String, Byte[]))

RedisClientSet Method (IDictionaryString, Byte)
设置一组数据(MSET)

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    IDictionary<string, byte[]> dict
)
Public Function Set (
    dict As IDictionary(Of String, Byte())
) As Boolean
public:
bool Set(
    IDictionary<String^, array<unsigned char>^>^ dict
)
member Set :
        dict : IDictionary<string, byte[]> -> bool

Parameters

dict
Type: System.Collections.GenericIDictionary String, Byte

[Missing <param name="dict"/> documentation for "M:Adf.RedisClient.Set(System.Collections.Generic.IDictionary{System.String,System.Byte[]})"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Set(System.Collections.Generic.IDictionary{System.String,System.Byte[]})"]

See Also

Reference

RedisClient Class
Set Overload


RedisClient.Set Method (IDictionary(String, String))

RedisClientSet Method (IDictionaryString, String)
设置一组字符串(MSET)

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    IDictionary<string, string> dict
)
Public Function Set (
    dict As IDictionary(Of String, String)
) As Boolean
public:
bool Set(
    IDictionary<String^, String^>^ dict
)
member Set :
        dict : IDictionary<string, string> -> bool

Parameters

dict
Type: System.Collections.GenericIDictionary String, String

[Missing <param name="dict"/> documentation for "M:Adf.RedisClient.Set(System.Collections.Generic.IDictionary{System.String,System.String})"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Set(System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

Reference

RedisClient Class
Set Overload


RedisClient.Set Method (String, Byte[])

RedisClientSet Method (String, Byte)
设置一个二进制值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    string key,
    byte[] value
)
Public Function Set (
    key As String,
    value As Byte()
) As Boolean
public:
bool Set(
    String^ key,
    array<unsigned char>^ value
)
member Set :
        key : string *
        value : byte[] -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Set(System.String,System.Byte[])"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.Set(System.String,System.Byte[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Set(System.String,System.Byte[])"]

See Also

Reference

RedisClient Class
Set Overload


RedisClient.Set Method (String, String)

RedisClientSet Method (String, String)
设置一个字符串值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Set(
    string key,
    string value
)
Public Function Set (
    key As String,
    value As String
) As Boolean
public:
bool Set(
    String^ key,
    String^ value
)
member Set :
        key : string *
        value : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Set(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.Set(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.Set(System.String,System.String)"]

See Also

Reference

RedisClient Class
Set Overload


RedisClient.Set Method (String, Object, Int32)

RedisClientSet Method (String, Object, Int32)
设置一个值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Set(
    string key,
    Object value,
    int expires
)
Public Sub Set (
    key As String,
    value As Object,
    expires As Integer
)
public:
virtual void Set(
    String^ key,
    Object^ value,
    int expires
) sealed
abstract Set :
        key : string *
        value : Object *
        expires : int -> unit
override Set :
        key : string *
        value : Object *
        expires : int -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.Set(System.String,System.Object,System.Int32)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.Set(System.String,System.Object,System.Int32)"]

expires
Type: SystemInt32

[Missing <param name="expires"/> documentation for "M:Adf.RedisClient.Set(System.String,System.Object,System.Int32)"]

Implements

ICacheSet(String, Object, Int32)
See Also

Reference

RedisClient Class
Set Overload


RedisClient.SetEX Method

RedisClientSetEX Method
Overload List
 | Name | Description
Public method | SetEX(String, Byte, Int32) | 设置一个值并指定过期时间
Public method | SetEX(String, String, Int32) | 设置一个值并指定过期时间
Top
See Also

Reference

RedisClient Class


RedisClient.SetEX Method (String, Byte[], Int32)

RedisClientSetEX Method (String, Byte, Int32)
设置一个值并指定过期时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SetEX(
    string key,
    byte[] value,
    int expireSeconds
)
Public Function SetEX (
    key As String,
    value As Byte(),
    expireSeconds As Integer
) As Boolean
public:
bool SetEX(
    String^ key,
    array<unsigned char>^ value,
    int expireSeconds
)
member SetEX :
        key : string *
        value : byte[] *
        expireSeconds : int -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.SetEX(System.String,System.Byte[],System.Int32)"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.SetEX(System.String,System.Byte[],System.Int32)"]

expireSeconds
Type: SystemInt32

[Missing <param name="expireSeconds"/> documentation for "M:Adf.RedisClient.SetEX(System.String,System.Byte[],System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.SetEX(System.String,System.Byte[],System.Int32)"]

See Also

Reference

RedisClient Class
SetEX Overload


RedisClient.SetEX Method (String, String, Int32)

RedisClientSetEX Method (String, String, Int32)
设置一个值并指定过期时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SetEX(
    string key,
    string value,
    int expireSeconds
)
Public Function SetEX (
    key As String,
    value As String,
    expireSeconds As Integer
) As Boolean
public:
bool SetEX(
    String^ key,
    String^ value,
    int expireSeconds
)
member SetEX :
        key : string *
        value : string *
        expireSeconds : int -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.SetEX(System.String,System.String,System.Int32)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.SetEX(System.String,System.String,System.Int32)"]

expireSeconds
Type: SystemInt32

[Missing <param name="expireSeconds"/> documentation for "M:Adf.RedisClient.SetEX(System.String,System.String,System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.SetEX(System.String,System.String,System.Int32)"]

See Also

Reference

RedisClient Class
SetEX Overload


RedisClient.SetNX Method

RedisClientSetNX Method
Overload List
 | Name | Description
Public method | SetNX(String, Byte) | 设置一个值，当键已存在时则忽略
Public method | SetNX(String, String) | 设置一个值，当键已存在时则忽略
Top
See Also

Reference

RedisClient Class


RedisClient.SetNX Method (String, Byte[])

RedisClientSetNX Method (String, Byte)
设置一个值，当键已存在时则忽略

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SetNX(
    string key,
    byte[] value
)
Public Function SetNX (
    key As String,
    value As Byte()
) As Boolean
public:
bool SetNX(
    String^ key,
    array<unsigned char>^ value
)
member SetNX :
        key : string *
        value : byte[] -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.SetNX(System.String,System.Byte[])"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.SetNX(System.String,System.Byte[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.SetNX(System.String,System.Byte[])"]

See Also

Reference

RedisClient Class
SetNX Overload


RedisClient.SetNX Method (String, String)

RedisClientSetNX Method (String, String)
设置一个值，当键已存在时则忽略

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SetNX(
    string key,
    string value
)
Public Function SetNX (
    key As String,
    value As String
) As Boolean
public:
bool SetNX(
    String^ key,
    String^ value
)
member SetNX :
        key : string *
        value : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.SetNX(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisClient.SetNX(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisClient.SetNX(System.String,System.String)"]

See Also

Reference

RedisClient Class
SetNX Overload


RedisClient.Shutdown Method

RedisClientShutdown Method
关闭

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Shutdown()
Public Sub Shutdown
public:
void Shutdown()
member Shutdown : unit -> unit
See Also

Reference

RedisClient Class


RedisClient.TTL Method

RedisClientTTL Method
获取一个键的TTL值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int TTL(
    string key
)
Public Function TTL (
    key As String
) As Integer
public:
int TTL(
    String^ key
)
member TTL :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.TTL(System.String)"]

Return Value

Type: Int32
The command returns -2 if the key does not exist. The command returns -1 if the key exists but has no associated expire.
See Also

Reference

RedisClient Class


RedisClient.TypeOf Method

RedisClientTypeOf Method
获取键类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisKeyType TypeOf(
    string key
)
Public Function TypeOf (
    key As String
) As RedisKeyType
public:
RedisKeyType TypeOf(
    String^ key
)
member TypeOf :
        key : string -> RedisKeyType

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClient.TypeOf(System.String)"]

Return Value

Type: RedisKeyType

[Missing <returns> documentation for "M:Adf.RedisClient.TypeOf(System.String)"]

See Also

Reference

RedisClient Class


RedisClient Properties

RedisClient Properties

The RedisClient type exposes the following members.

Properties
 | Name | Description
Public property | BinarySerializable | 获取或设置二进制序列化器,默认 JsonBinarySerializable, 可通过在appsetting中配置 RedisClientBinarySerializable 来指定其它实例
Protected property | Connection | 连接
Public property | Encoding | 字符编码
Public property | Hashs | 获取哈希表
Public property | Host |
Public property | Lists | 获取列表
Public property | Password |
Public property | PoolAbandon | 是否从池中废弃此实例
Public property | Port |
Public property | SendTimeout |
Public property | Sets | 获取集合
Public property | SortedSets | 获取有序集合
Top
See Also

Reference

RedisClient Class


RedisClient.BinarySerializable Property

RedisClientBinarySerializable Property
获取或设置二进制序列化器,默认 JsonBinarySerializable, 可通过在appsetting中配置 RedisClientBinarySerializable 来指定其它实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IBinarySerializable BinarySerializable { get; set; }
Public Property BinarySerializable As IBinarySerializable
    Get
    Set
public:
property IBinarySerializable^ BinarySerializable {
    IBinarySerializable^ get ();
    void set (IBinarySerializable^ value);
}
member BinarySerializable : IBinarySerializable with get, set

Property Value

Type: IBinarySerializable
See Also

Reference

RedisClient Class


RedisClient.Connection Property

RedisClientConnection Property
连接

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected RedisConnection Connection { get; }
Protected ReadOnly Property Connection As RedisConnection
    Get
protected:
property RedisConnection^ Connection {
    RedisConnection^ get ();
}
member Connection : RedisConnection with get

Property Value

Type: RedisConnection
See Also

Reference

RedisClient Class


RedisClient.Encoding Property

RedisClientEncoding Property
字符编码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; }
Public ReadOnly Property Encoding As Encoding
    Get
public:
property Encoding^ Encoding {
    Encoding^ get ();
}
member Encoding : Encoding with get

Property Value

Type: Encoding
See Also

Reference

RedisClient Class


RedisClient.Hashs Property

RedisClientHashs Property
获取哈希表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisHashes Hashs { get; }
Public ReadOnly Property Hashs As RedisHashes
    Get
public:
property RedisHashes^ Hashs {
    RedisHashes^ get ();
}
member Hashs : RedisHashes with get

Property Value

Type: RedisHashes
See Also

Reference

RedisClient Class


RedisClient.Host Property

RedisClientHost Property

[Missing <summary> documentation for "P:Adf.RedisClient.Host"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Host { get; }
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
member Host : string with get

Property Value

Type: String
See Also

Reference

RedisClient Class


RedisClient.Lists Property

RedisClientLists Property
获取列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisLists Lists { get; }
Public ReadOnly Property Lists As RedisLists
    Get
public:
property RedisLists^ Lists {
    RedisLists^ get ();
}
member Lists : RedisLists with get

Property Value

Type: RedisLists
See Also

Reference

RedisClient Class


RedisClient.Password Property

RedisClientPassword Property

[Missing <summary> documentation for "P:Adf.RedisClient.Password"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

RedisClient Class


RedisClient.PoolAbandon Property

RedisClientPoolAbandon Property
是否从池中废弃此实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool PoolAbandon { get; set; }
Public Property PoolAbandon As Boolean
    Get
    Set
public:
virtual property bool PoolAbandon {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PoolAbandon : bool with get, set
override PoolAbandon : bool with get, set

Property Value

Type: Boolean

Implements

IPoolInstancePoolAbandon
See Also

Reference

RedisClient Class


RedisClient.Port Property

RedisClientPort Property

[Missing <summary> documentation for "P:Adf.RedisClient.Port"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
member Port : int with get

Property Value

Type: Int32
See Also

Reference

RedisClient Class


RedisClient.SendTimeout Property

RedisClientSendTimeout Property

[Missing <summary> documentation for "P:Adf.RedisClient.SendTimeout"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int SendTimeout { get; set; }
Public Property SendTimeout As Integer
    Get
    Set
public:
property int SendTimeout {
    int get ();
    void set (int value);
}
member SendTimeout : int with get, set

Property Value

Type: Int32
See Also

Reference

RedisClient Class


RedisClient.Sets Property

RedisClientSets Property
获取集合

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisSets Sets { get; }
Public ReadOnly Property Sets As RedisSets
    Get
public:
property RedisSets^ Sets {
    RedisSets^ get ();
}
member Sets : RedisSets with get

Property Value

Type: RedisSets
See Also

Reference

RedisClient Class


RedisClient.SortedSets Property

RedisClientSortedSets Property
获取有序集合

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisSortedSets SortedSets { get; }
Public ReadOnly Property SortedSets As RedisSortedSets
    Get
public:
property RedisSortedSets^ SortedSets {
    RedisSortedSets^ get ();
}
member SortedSets : RedisSortedSets with get

Property Value

Type: RedisSortedSets
See Also

Reference

RedisClient Class


RedisClientPool Class

RedisClientPool Class
Redis Cache 管理器
Inheritance Hierarchy
SystemObject
AdfRedisClientPool

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisClientPool : ICache
Public Class RedisClientPool
    Implements ICache
public ref class RedisClientPool : ICache
type RedisClientPool =
    class
        interface ICache
    end

The RedisClientPool type exposes the following members.

Constructors
 | Name | Description
Public method | RedisClientPool | 初始化新实例
Public method | RedisClientPool(String) | 初始化新实例
Top
Methods
 | Name | Description
Public method | Delete | 移除一个键
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | 获取一个字符值
Public method | GetT(String) | 获取一个对象
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Set(String, Object, Int32) | 设置一个字符值
Public method | Set(String, String, Int32) | 设置一个字符值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | MemberPoolSize | 获取每成员的最大实例数
Public property | Name | 配置节点名
Public property | Pool | 获取池管理对象
Top
See Also

Reference


RedisClientPool Constructor

RedisClientPool Constructor
Overload List
 | Name | Description
Public method | RedisClientPool | 初始化新实例
Public method | RedisClientPool(String) | 初始化新实例
Top
See Also

Reference

RedisClientPool Class


RedisClientPool Constructor

RedisClientPool Constructor
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisClientPool()
Public Sub New
public:
RedisClientPool()
new : unit -> RedisClientPool
See Also

Reference

RedisClientPool Class
RedisClientPool Overload


RedisClientPool Constructor (String)

RedisClientPool Constructor (String)
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisClientPool(
    string configName
)
Public Sub New (
    configName As String
)
public:
RedisClientPool(
    String^ configName
)
new :
        configName : string -> RedisClientPool

Parameters

configName
Type: SystemString

[Missing <param name="configName"/> documentation for "M:Adf.RedisClientPool.#ctor(System.String)"]

See Also

Reference

RedisClientPool Class
RedisClientPool Overload


RedisClientPool Methods

RedisClientPool Methods

The RedisClientPool type exposes the following members.

Methods
 | Name | Description
Public method | Delete | 移除一个键
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | 获取一个字符值
Public method | GetT(String) | 获取一个对象
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Set(String, Object, Int32) | 设置一个字符值
Public method | Set(String, String, Int32) | 设置一个字符值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

RedisClientPool Class


RedisClientPool.Delete Method

RedisClientPoolDelete Method
移除一个键

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Delete(
    string key
)
Public Sub Delete (
    key As String
)
public:
virtual void Delete(
    String^ key
) sealed
abstract Delete :
        key : string -> unit
override Delete :
        key : string -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClientPool.Delete(System.String)"]

Implements

ICacheDelete(String)
See Also

Reference

RedisClientPool Class


RedisClientPool.Get Method

RedisClientPoolGet Method
Overload List
 | Name | Description
Public method | Get(String) | 获取一个字符值
Public method | GetT(String) | 获取一个对象
Top
See Also

Reference

RedisClientPool Class


RedisClientPool.Get Method (String)

RedisClientPoolGet Method (String)
获取一个字符值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Get(
    string key
)
Public Function Get (
    key As String
) As String
public:
virtual String^ Get(
    String^ key
) sealed
abstract Get :
        key : string -> string
override Get :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClientPool.Get(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisClientPool.Get(System.String)"]

Implements

ICacheGet(String)
See Also

Reference

RedisClientPool Class
Get Overload


RedisClientPool.Get(T) Method (String)

RedisClientPoolGetT Method (String)
获取一个对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T Get<T>(
    string key
)

Public Function Get(Of T) (
    key As String
) As T
public:
generic<typename T>
virtual T Get(
    String^ key
) sealed
abstract Get :
        key : string -> 'T
override Get :
        key : string -> 'T

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClientPool.Get``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.RedisClientPool.Get``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.RedisClientPool.Get``1(System.String)"]

Implements

ICacheGetT(String)
See Also

Reference

RedisClientPool Class
Get Overload


RedisClientPool.Init Method

RedisClientPoolInit Method
初始化

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void Init(
    string configName
)
Protected Overridable Sub Init (
    configName As String
)
protected:
virtual void Init(
    String^ configName
)
abstract Init :
        configName : string -> unit
override Init :
        configName : string -> unit

Parameters

configName
Type: SystemString

[Missing <param name="configName"/> documentation for "M:Adf.RedisClientPool.Init(System.String)"]

See Also

Reference

RedisClientPool Class


RedisClientPool.Set Method

RedisClientPoolSet Method
Overload List
 | Name | Description
Public method | Set(String, Object, Int32) | 设置一个字符值
Public method | Set(String, String, Int32) | 设置一个字符值
Top
See Also

Reference

RedisClientPool Class


RedisClientPool.Set Method (String, Object, Int32)

RedisClientPoolSet Method (String, Object, Int32)
设置一个字符值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Set(
    string key,
    Object value,
    int expires
)
Public Sub Set (
    key As String,
    value As Object,
    expires As Integer
)
public:
virtual void Set(
    String^ key,
    Object^ value,
    int expires
) sealed
abstract Set :
        key : string *
        value : Object *
        expires : int -> unit
override Set :
        key : string *
        value : Object *
        expires : int -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClientPool.Set(System.String,System.Object,System.Int32)"]

value
Type: SystemObject

[Missing <param name="value"/> documentation for "M:Adf.RedisClientPool.Set(System.String,System.Object,System.Int32)"]

expires
Type: SystemInt32

[Missing <param name="expires"/> documentation for "M:Adf.RedisClientPool.Set(System.String,System.Object,System.Int32)"]

Implements

ICacheSet(String, Object, Int32)
See Also

Reference

RedisClientPool Class
Set Overload


RedisClientPool.Set Method (String, String, Int32)

RedisClientPoolSet Method (String, String, Int32)
设置一个字符值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Set(
    string key,
    string value,
    int expires
)
Public Sub Set (
    key As String,
    value As String,
    expires As Integer
)
public:
void Set(
    String^ key,
    String^ value,
    int expires
)
member Set :
        key : string *
        value : string *
        expires : int -> unit

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisClientPool.Set(System.String,System.String,System.Int32)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisClientPool.Set(System.String,System.String,System.Int32)"]

expires
Type: SystemInt32

[Missing <param name="expires"/> documentation for "M:Adf.RedisClientPool.Set(System.String,System.String,System.Int32)"]

See Also

Reference

RedisClientPool Class
Set Overload


RedisClientPool Properties

RedisClientPool Properties

The RedisClientPool type exposes the following members.

Properties
 | Name | Description
Public property | MemberPoolSize | 获取每成员的最大实例数
Public property | Name | 配置节点名
Public property | Pool | 获取池管理对象
Top
See Also

Reference

RedisClientPool Class


RedisClientPool.MemberPoolSize Property

RedisClientPoolMemberPoolSize Property
获取每成员的最大实例数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int MemberPoolSize { get; }
Public Overridable ReadOnly Property MemberPoolSize As Integer
    Get
public:
virtual property int MemberPoolSize {
    int get ();
}
abstract MemberPoolSize : int with get
override MemberPoolSize : int with get

Property Value

Type: Int32
See Also

Reference

RedisClientPool Class


RedisClientPool.Name Property

RedisClientPoolName Property
配置节点名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
public:
property String^ Name {
    String^ get ();
}
member Name : string with get

Property Value

Type: String
See Also

Reference

RedisClientPool Class


RedisClientPool.Pool Property

RedisClientPoolPool Property
获取池管理对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Pool<RedisClient> Pool { get; }
Public ReadOnly Property Pool As Pool(Of RedisClient)
    Get
public:
property Pool<RedisClient^>^ Pool {
    Pool<RedisClient^>^ get ();
}
member Pool : Pool<RedisClient> with get

Property Value

Type: Pool RedisClient
See Also

Reference

RedisClientPool Class


RedisClientPoolMember Class

RedisClientPoolMember Class
Redis 池成员
Inheritance Hierarchy
SystemObject
AdfRedisClientPoolMember

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisClientPoolMember : IPoolMember
Public Class RedisClientPoolMember
    Implements IPoolMember
public ref class RedisClientPoolMember : IPoolMember
type RedisClientPoolMember =
    class
        interface IPoolMember
    end

The RedisClientPoolMember type exposes the following members.

Constructors
 | Name | Description
Public method | RedisClientPoolMember | 初始一个新实例
Top
Methods
 | Name | Description
Public method | CreatePoolInstance | 创建一个实例
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Host | 获取主机名
Public property | PoolActive | 成员是否可用
Public property | PoolMemberId | 池成员标识
Public property | Port | 获取主机端口
Top
See Also

Reference


RedisClientPoolMember Constructor

RedisClientPoolMember Constructor
初始一个新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisClientPoolMember(
    string host,
    int port
)
Public Sub New (
    host As String,
    port As Integer
)
public:
RedisClientPoolMember(
    String^ host,
    int port
)
new :
        host : string *
        port : int -> RedisClientPoolMember

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.RedisClientPoolMember.#ctor(System.String,System.Int32)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.RedisClientPoolMember.#ctor(System.String,System.Int32)"]

See Also

Reference

RedisClientPoolMember Class


RedisClientPoolMember Methods

RedisClientPoolMember Methods

The RedisClientPoolMember type exposes the following members.

Methods
 | Name | Description
Public method | CreatePoolInstance | 创建一个实例
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

RedisClientPoolMember Class


RedisClientPoolMember.CreatePoolInstance Method

RedisClientPoolMemberCreatePoolInstance Method
创建一个实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IPoolInstance CreatePoolInstance()
Public Function CreatePoolInstance As IPoolInstance
public:
virtual IPoolInstance^ CreatePoolInstance() sealed
abstract CreatePoolInstance : unit -> IPoolInstance
override CreatePoolInstance : unit -> IPoolInstance

Return Value

Type: IPoolInstance

[Missing <returns> documentation for "M:Adf.RedisClientPoolMember.CreatePoolInstance"]

Implements

IPoolMemberCreatePoolInstance
See Also

Reference

RedisClientPoolMember Class


RedisClientPoolMember Properties

RedisClientPoolMember Properties

The RedisClientPoolMember type exposes the following members.

Properties
 | Name | Description
Public property | Host | 获取主机名
Public property | PoolActive | 成员是否可用
Public property | PoolMemberId | 池成员标识
Public property | Port | 获取主机端口
Top
See Also

Reference

RedisClientPoolMember Class


RedisClientPoolMember.Host Property

RedisClientPoolMemberHost Property
获取主机名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Host { get; }
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
member Host : string with get

Property Value

Type: String
See Also

Reference

RedisClientPoolMember Class


RedisClientPoolMember.PoolActive Property

RedisClientPoolMemberPoolActive Property
成员是否可用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool PoolActive { get; set; }
Public Property PoolActive As Boolean
    Get
    Set
public:
virtual property bool PoolActive {
    bool get () sealed;
    void set (bool value) sealed;
}
abstract PoolActive : bool with get, set
override PoolActive : bool with get, set

Property Value

Type: Boolean

Implements

IPoolMemberPoolActive
See Also

Reference

RedisClientPoolMember Class


RedisClientPoolMember.PoolMemberId Property

RedisClientPoolMemberPoolMemberId Property
池成员标识

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string PoolMemberId { get; }
Public ReadOnly Property PoolMemberId As String
    Get
public:
virtual property String^ PoolMemberId {
    String^ get () sealed;
}
abstract PoolMemberId : string with get
override PoolMemberId : string with get

Property Value

Type: String

Implements

IPoolMemberPoolMemberId
See Also

Reference

RedisClientPoolMember Class


RedisClientPoolMember.Port Property

RedisClientPoolMemberPort Property
获取主机端口

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
member Port : int with get

Property Value

Type: Int32
See Also

Reference

RedisClientPoolMember Class


RedisConnection Class

RedisConnection Class
Redis 客户端
Inheritance Hierarchy
SystemObject
AdfRedisConnection

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisConnection : IDisposable
Public Class RedisConnection
    Implements IDisposable
public ref class RedisConnection : IDisposable
type RedisConnection =
    class
        interface IDisposable
    end

The RedisConnection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all resources used by the RedisConnection
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | ExpectByte |
Public method | ExpectData |
Public method | ExpectDouble |
Public method | ExpectInt |
Public method | ExpectMultiBulkReply |
Public method | ExpectString |
Public method | ExpectSuccess |
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendCommand(Byte, Int32, Int32) |
Public method | SendCommand(Byte, String, Object) |
Public method | SendCommand(Byte, Int32, Int32, String, Object) |
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | ToStringArray |
Top
Fields
Name | Description
CRLF | CRLF
Top
See Also

Reference


RedisConnection Fields

RedisConnection Fields

The RedisConnection type exposes the following members.

Fields
Name | Description
CRLF | CRLF
Top
See Also

Reference

RedisConnection Class


RedisConnection.CRLF Field

RedisConnectionCRLF Field
CRLF

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] CRLF
Public Shared CRLF As Byte()
public:
static array<unsigned char>^ CRLF
static val mutable CRLF: byte[]

Field Value

Type: Byte
See Also

Reference

RedisConnection Class


RedisConnection Methods

RedisConnection Methods

The RedisConnection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose |
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | ExpectByte |
Public method | ExpectData |
Public method | ExpectDouble |
Public method | ExpectInt |
Public method | ExpectMultiBulkReply |
Public method | ExpectString |
Public method | ExpectSuccess |
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendCommand(Byte, Int32, Int32) |
Public method | SendCommand(Byte, String, Object) |
Public method | SendCommand(Byte, Int32, Int32, String, Object) |
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | ToStringArray |
Top
See Also

Reference

RedisConnection Class


RedisConnection.Dispose Method

RedisConnectionDispose Method
Releases all resources used by the RedisConnection

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

RedisConnection Class


RedisConnection.ExpectByte Method

RedisConnectionExpectByte Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ExpectByte"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ArraySegment<byte> ExpectByte()
Public Function ExpectByte As ArraySegment(Of Byte)
public:
ArraySegment<unsigned char> ExpectByte()
member ExpectByte : unit -> ArraySegment<byte>

Return Value

Type: ArraySegment Byte

[Missing <returns> documentation for "M:Adf.RedisConnection.ExpectByte"]

See Also

Reference

RedisConnection Class


RedisConnection.ExpectData Method

RedisConnectionExpectData Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ExpectData"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] ExpectData()
Public Function ExpectData As Byte()
public:
array<unsigned char>^ ExpectData()
member ExpectData : unit -> byte[]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisConnection.ExpectData"]

See Also

Reference

RedisConnection Class


RedisConnection.ExpectDouble Method

RedisConnectionExpectDouble Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ExpectDouble"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ExpectDouble()
Public Function ExpectDouble As Double
public:
double ExpectDouble()
member ExpectDouble : unit -> float

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisConnection.ExpectDouble"]

See Also

Reference

RedisConnection Class


RedisConnection.ExpectInt Method

RedisConnectionExpectInt Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ExpectInt"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ExpectInt()
Public Function ExpectInt As Integer
public:
int ExpectInt()
member ExpectInt : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisConnection.ExpectInt"]

See Also

Reference

RedisConnection Class


RedisConnection.ExpectMultiBulkReply Method

RedisConnectionExpectMultiBulkReply Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ExpectMultiBulkReply"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] ExpectMultiBulkReply()
Public Function ExpectMultiBulkReply As Byte()()
public:
array<array<unsigned char>^>^ ExpectMultiBulkReply()
member ExpectMultiBulkReply : unit -> byte[][]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisConnection.ExpectMultiBulkReply"]

See Also

Reference

RedisConnection Class


RedisConnection.ExpectString Method

RedisConnectionExpectString Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ExpectString"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string ExpectString()
Public Function ExpectString As String
public:
String^ ExpectString()
member ExpectString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisConnection.ExpectString"]

See Also

Reference

RedisConnection Class


RedisConnection.ExpectSuccess Method

RedisConnectionExpectSuccess Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ExpectSuccess"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool ExpectSuccess()
Public Function ExpectSuccess As Boolean
public:
bool ExpectSuccess()
member ExpectSuccess : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisConnection.ExpectSuccess"]

See Also

Reference

RedisConnection Class


RedisConnection.SendCommand Method

RedisConnectionSendCommand Method
Overload List
 | Name | Description
Public method | SendCommand(Byte, Int32, Int32) |
Public method | SendCommand(Byte, String, Object) |
Public method | SendCommand(Byte, Int32, Int32, String, Object) |
Top
See Also

Reference

RedisConnection Class


RedisConnection.SendCommand Method (Byte[], Int32, Int32)

RedisConnectionSendCommand Method (Byte, Int32, Int32)

[Missing <summary> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32)"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void SendCommand(
    byte[] data,
    int offset,
    int count
)
Public Sub SendCommand (
    data As Byte(),
    offset As Integer,
    count As Integer
)
public:
void SendCommand(
    array<unsigned char>^ data,
    int offset,
    int count
)
member SendCommand :
        data : byte[] *
        offset : int *
        count : int -> unit

Parameters

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

RedisConnection Class
SendCommand Overload


RedisConnection.SendCommand Method (Byte[], String, Object[])

RedisConnectionSendCommand Method (Byte, String, Object)

[Missing <summary> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.String,System.Object[])"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void SendCommand(
    byte[] data,
    string cmd,
    params Object[] args
)
Public Sub SendCommand (
    data As Byte(),
    cmd As String,
    ParamArray args As Object()
)
public:
void SendCommand(
    array<unsigned char>^ data,
    String^ cmd,
    ... array<Object^>^ args
)
member SendCommand :
        data : byte[] *
        cmd : string *
        args : Object[] -> unit

Parameters

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.String,System.Object[])"]

cmd
Type: SystemString

[Missing <param name="cmd"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.String,System.Object[])"]

See Also

Reference

RedisConnection Class
SendCommand Overload


RedisConnection.SendCommand Method (Byte[], Int32, Int32, String, Object[])

RedisConnectionSendCommand Method (Byte, Int32, Int32, String, Object)

[Missing <summary> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32,System.String,System.Object[])"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void SendCommand(
    byte[] data,
    int offset,
    int count,
    string cmd,
    params Object[] args
)
Public Sub SendCommand (
    data As Byte(),
    offset As Integer,
    count As Integer,
    cmd As String,
    ParamArray args As Object()
)
public:
void SendCommand(
    array<unsigned char>^ data,
    int offset,
    int count,
    String^ cmd,
    ... array<Object^>^ args
)
member SendCommand :
        data : byte[] *
        offset : int *
        count : int *
        cmd : string *
        args : Object[] -> unit

Parameters

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32,System.String,System.Object[])"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32,System.String,System.Object[])"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32,System.String,System.Object[])"]

cmd
Type: SystemString

[Missing <param name="cmd"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32,System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.RedisConnection.SendCommand(System.Byte[],System.Int32,System.Int32,System.String,System.Object[])"]

See Also

Reference

RedisConnection Class
SendCommand Overload


RedisConnection.ToStringArray Method

RedisConnectionToStringArray Method

[Missing <summary> documentation for "M:Adf.RedisConnection.ToStringArray(System.Byte[][])"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] ToStringArray(
    byte[][] data
)
Public Function ToStringArray (
    data As Byte()()
) As String()
public:
array<String^>^ ToStringArray(
    array<array<unsigned char>^>^ data
)
member ToStringArray :
        data : byte[][] -> string[]

Parameters

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.RedisConnection.ToStringArray(System.Byte[][])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisConnection.ToStringArray(System.Byte[][])"]

See Also

Reference

RedisConnection Class


RedisHashes Class

RedisHashes Class
Redis 哈希表
Inheritance Hierarchy
SystemObject
AdfRedisHashes

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisHashes
Public Class RedisHashes
public ref class RedisHashes
type RedisHashes =  class end

The RedisHashes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | HDEL | 删除一个项
Public method | HEXISTS | 判断一个项是否存在
Public method | HGET | 获取一个项
Public method | HGETALL | 获取一个项
Public method | HGETALLByte | 获取一个项
Public method | HGETALLDict | 获取一个项
Public method | HGETByte | 获取一个项
Public method | HINCRBY | 对某项自增一数值
Public method | HINCRBYFLOAT | 对某项自增一浮点数值
Public method | HKEYS | 获取元素的键项列表
Public method | HLEN | 获取哈希表元素个数
Public method | HMGET | 获取元素的键项列表
Public method | HMSET(String, IDictionaryString, Byte) | 设置一组元素值
Public method | HMSET(String, IDictionaryString, String) | 设置一组元素值
Public method | HSET(String, String, Byte) | 设置一个元素项
Public method | HSET(String, String, String) | 设置一个元素项
Public method | HSETNX(String, String, Byte) | 设置一个元素项,如果元素项不存在则成功，否则设置失败
Public method | HSETNX(String, String, String) | 设置一个元素项,如果元素项不存在则成功，否则设置失败
Public method | HVALS | 获取元素的键项列表
Public method | HVALSByte | 获取元素的键项列表
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


RedisHashes Methods

RedisHashes Methods

The RedisHashes type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | HDEL | 删除一个项
Public method | HEXISTS | 判断一个项是否存在
Public method | HGET | 获取一个项
Public method | HGETALL | 获取一个项
Public method | HGETALLByte | 获取一个项
Public method | HGETALLDict | 获取一个项
Public method | HGETByte | 获取一个项
Public method | HINCRBY | 对某项自增一数值
Public method | HINCRBYFLOAT | 对某项自增一浮点数值
Public method | HKEYS | 获取元素的键项列表
Public method | HLEN | 获取哈希表元素个数
Public method | HMGET | 获取元素的键项列表
Public method | HMSET(String, IDictionaryString, Byte) | 设置一组元素值
Public method | HMSET(String, IDictionaryString, String) | 设置一组元素值
Public method | HSET(String, String, Byte) | 设置一个元素项
Public method | HSET(String, String, String) | 设置一个元素项
Public method | HSETNX(String, String, Byte) | 设置一个元素项,如果元素项不存在则成功，否则设置失败
Public method | HSETNX(String, String, String) | 设置一个元素项,如果元素项不存在则成功，否则设置失败
Public method | HVALS | 获取元素的键项列表
Public method | HVALSByte | 获取元素的键项列表
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

RedisHashes Class


RedisHashes.HDEL Method

RedisHashesHDEL Method
删除一个项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool HDEL(
    string key,
    string field
)
Public Function HDEL (
    key As String,
    field As String
) As Boolean
public:
bool HDEL(
    String^ key,
    String^ field
)
member HDEL :
        key : string *
        field : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HDEL(System.String,System.String)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HDEL(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisHashes.HDEL(System.String,System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HEXISTS Method

RedisHashesHEXISTS Method
判断一个项是否存在

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool HEXISTS(
    string key,
    string field
)
Public Function HEXISTS (
    key As String,
    field As String
) As Boolean
public:
bool HEXISTS(
    String^ key,
    String^ field
)
member HEXISTS :
        key : string *
        field : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HEXISTS(System.String,System.String)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HEXISTS(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisHashes.HEXISTS(System.String,System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HGET Method

RedisHashesHGET Method
获取一个项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string HGET(
    string key,
    string field
)
Public Function HGET (
    key As String,
    field As String
) As String
public:
String^ HGET(
    String^ key,
    String^ field
)
member HGET :
        key : string *
        field : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HGET(System.String,System.String)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HGET(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisHashes.HGET(System.String,System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HGETALL Method

RedisHashesHGETALL Method
获取一个项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> HGETALL(
    string key
)
Public Function HGETALL (
    key As String
) As Dictionary(Of String, String)
public:
Dictionary<String^, String^>^ HGETALL(
    String^ key
)
member HGETALL :
        key : string -> Dictionary<string, string>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HGETALL(System.String)"]

Return Value

Type: Dictionary String, String

[Missing <returns> documentation for "M:Adf.RedisHashes.HGETALL(System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HGETALLByte Method

RedisHashesHGETALLByte Method
获取一个项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] HGETALLByte(
    string key
)
Public Function HGETALLByte (
    key As String
) As Byte()()
public:
array<array<unsigned char>^>^ HGETALLByte(
    String^ key
)
member HGETALLByte :
        key : string -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HGETALLByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisHashes.HGETALLByte(System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HGETALLDict Method

RedisHashesHGETALLDict Method
获取一个项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, byte[]> HGETALLDict(
    string key
)
Public Function HGETALLDict (
    key As String
) As Dictionary(Of String, Byte())
public:
Dictionary<String^, array<unsigned char>^>^ HGETALLDict(
    String^ key
)
member HGETALLDict :
        key : string -> Dictionary<string, byte[]>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HGETALLDict(System.String)"]

Return Value

Type: Dictionary String, Byte

[Missing <returns> documentation for "M:Adf.RedisHashes.HGETALLDict(System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HGETByte Method

RedisHashesHGETByte Method
获取一个项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ArraySegment<byte> HGETByte(
    string key,
    string field
)
Public Function HGETByte (
    key As String,
    field As String
) As ArraySegment(Of Byte)
public:
ArraySegment<unsigned char> HGETByte(
    String^ key,
    String^ field
)
member HGETByte :
        key : string *
        field : string -> ArraySegment<byte>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HGETByte(System.String,System.String)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HGETByte(System.String,System.String)"]

Return Value

Type: ArraySegment Byte

[Missing <returns> documentation for "M:Adf.RedisHashes.HGETByte(System.String,System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HINCRBY Method

RedisHashesHINCRBY Method
对某项自增一数值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int HINCRBY(
    string key,
    string field,
    int increment
)
Public Function HINCRBY (
    key As String,
    field As String,
    increment As Integer
) As Integer
public:
int HINCRBY(
    String^ key,
    String^ field,
    int increment
)
member HINCRBY :
        key : string *
        field : string *
        increment : int -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HINCRBY(System.String,System.String,System.Int32)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HINCRBY(System.String,System.String,System.Int32)"]

increment
Type: SystemInt32

[Missing <param name="increment"/> documentation for "M:Adf.RedisHashes.HINCRBY(System.String,System.String,System.Int32)"]

Return Value

Type: Int32
自增后的数值
See Also

Reference

RedisHashes Class


RedisHashes.HINCRBYFLOAT Method

RedisHashesHINCRBYFLOAT Method
对某项自增一浮点数值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double HINCRBYFLOAT(
    string key,
    string field,
    double increment
)
Public Function HINCRBYFLOAT (
    key As String,
    field As String,
    increment As Double
) As Double
public:
double HINCRBYFLOAT(
    String^ key,
    String^ field,
    double increment
)
member HINCRBYFLOAT :
        key : string *
        field : string *
        increment : float -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HINCRBYFLOAT(System.String,System.String,System.Double)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HINCRBYFLOAT(System.String,System.String,System.Double)"]

increment
Type: SystemDouble

[Missing <param name="increment"/> documentation for "M:Adf.RedisHashes.HINCRBYFLOAT(System.String,System.String,System.Double)"]

Return Value

Type: Double
自增后的数值,服务端版本要求:Available since 2.6.0.
See Also

Reference

RedisHashes Class


RedisHashes.HKEYS Method

RedisHashesHKEYS Method
获取元素的键项列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] HKEYS(
    string key
)
Public Function HKEYS (
    key As String
) As String()
public:
array<String^>^ HKEYS(
    String^ key
)
member HKEYS :
        key : string -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HKEYS(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisHashes.HKEYS(System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HLEN Method

RedisHashesHLEN Method
获取哈希表元素个数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int HLEN(
    string key
)
Public Function HLEN (
    key As String
) As Integer
public:
int HLEN(
    String^ key
)
member HLEN :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HLEN(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisHashes.HLEN(System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HMGET Method

RedisHashesHMGET Method
获取元素的键项列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] HMGET(
    string key,
    params string[] fields
)
Public Function HMGET (
    key As String,
    ParamArray fields As String()
) As String()
public:
array<String^>^ HMGET(
    String^ key,
    ... array<String^>^ fields
)
member HMGET :
        key : string *
        fields : string[] -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HMGET(System.String,System.String[])"]

fields
Type: SystemString

[Missing <param name="fields"/> documentation for "M:Adf.RedisHashes.HMGET(System.String,System.String[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisHashes.HMGET(System.String,System.String[])"]

See Also

Reference

RedisHashes Class


RedisHashes.HMSET Method

RedisHashesHMSET Method
Overload List
 | Name | Description
Public method | HMSET(String, IDictionaryString, Byte) | 设置一组元素值
Public method | HMSET(String, IDictionaryString, String) | 设置一组元素值
Top
See Also

Reference

RedisHashes Class


RedisHashes.HMSET Method (String, IDictionary(String, Byte[]))

RedisHashesHMSET Method (String, IDictionaryString, Byte)
设置一组元素值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool HMSET(
    string key,
    IDictionary<string, byte[]> dictionary
)
Public Function HMSET (
    key As String,
    dictionary As IDictionary(Of String, Byte())
) As Boolean
public:
bool HMSET(
    String^ key,
    IDictionary<String^, array<unsigned char>^>^ dictionary
)
member HMSET :
        key : string *
        dictionary : IDictionary<string, byte[]> -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HMSET(System.String,System.Collections.Generic.IDictionary{System.String,System.Byte[]})"]

dictionary
Type: System.Collections.GenericIDictionary String, Byte

[Missing <param name="dictionary"/> documentation for "M:Adf.RedisHashes.HMSET(System.String,System.Collections.Generic.IDictionary{System.String,System.Byte[]})"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisHashes.HMSET(System.String,System.Collections.Generic.IDictionary{System.String,System.Byte[]})"]

See Also

Reference

RedisHashes Class
HMSET Overload


RedisHashes.HMSET Method (String, IDictionary(String, String))

RedisHashesHMSET Method (String, IDictionaryString, String)
设置一组元素值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool HMSET(
    string key,
    IDictionary<string, string> dictionary
)
Public Function HMSET (
    key As String,
    dictionary As IDictionary(Of String, String)
) As Boolean
public:
bool HMSET(
    String^ key,
    IDictionary<String^, String^>^ dictionary
)
member HMSET :
        key : string *
        dictionary : IDictionary<string, string> -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HMSET(System.String,System.Collections.Generic.IDictionary{System.String,System.String})"]

dictionary
Type: System.Collections.GenericIDictionary String, String

[Missing <param name="dictionary"/> documentation for "M:Adf.RedisHashes.HMSET(System.String,System.Collections.Generic.IDictionary{System.String,System.String})"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisHashes.HMSET(System.String,System.Collections.Generic.IDictionary{System.String,System.String})"]

See Also

Reference

RedisHashes Class
HMSET Overload


RedisHashes.HSET Method

RedisHashesHSET Method
Overload List
 | Name | Description
Public method | HSET(String, String, Byte) | 设置一个元素项
Public method | HSET(String, String, String) | 设置一个元素项
Top
See Also

Reference

RedisHashes Class


RedisHashes.HSET Method (String, String, Byte[])

RedisHashesHSET Method (String, String, Byte)
设置一个元素项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int HSET(
    string key,
    string field,
    byte[] value
)
Public Function HSET (
    key As String,
    field As String,
    value As Byte()
) As Integer
public:
int HSET(
    String^ key,
    String^ field,
    array<unsigned char>^ value
)
member HSET :
        key : string *
        field : string *
        value : byte[] -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HSET(System.String,System.String,System.Byte[])"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HSET(System.String,System.String,System.Byte[])"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisHashes.HSET(System.String,System.String,System.Byte[])"]

Return Value

Type: Int32
1 if field is a new field in the hash and value was set. 0 if field already exists in the hash and the value was updated.
See Also

Reference

RedisHashes Class
HSET Overload


RedisHashes.HSET Method (String, String, String)

RedisHashesHSET Method (String, String, String)
设置一个元素项

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int HSET(
    string key,
    string field,
    string value
)
Public Function HSET (
    key As String,
    field As String,
    value As String
) As Integer
public:
int HSET(
    String^ key,
    String^ field,
    String^ value
)
member HSET :
        key : string *
        field : string *
        value : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HSET(System.String,System.String,System.String)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HSET(System.String,System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisHashes.HSET(System.String,System.String,System.String)"]

Return Value

Type: Int32
1 if field is a new field in the hash and value was set. 0 if field already exists in the hash and the value was updated.
See Also

Reference

RedisHashes Class
HSET Overload


RedisHashes.HSETNX Method

RedisHashesHSETNX Method
Overload List
 | Name | Description
Public method | HSETNX(String, String, Byte) | 设置一个元素项,如果元素项不存在则成功，否则设置失败
Public method | HSETNX(String, String, String) | 设置一个元素项,如果元素项不存在则成功，否则设置失败
Top
See Also

Reference

RedisHashes Class


RedisHashes.HSETNX Method (String, String, Byte[])

RedisHashesHSETNX Method (String, String, Byte)
设置一个元素项,如果元素项不存在则成功，否则设置失败

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int HSETNX(
    string key,
    string field,
    byte[] value
)
Public Function HSETNX (
    key As String,
    field As String,
    value As Byte()
) As Integer
public:
int HSETNX(
    String^ key,
    String^ field,
    array<unsigned char>^ value
)
member HSETNX :
        key : string *
        field : string *
        value : byte[] -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HSETNX(System.String,System.String,System.Byte[])"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HSETNX(System.String,System.String,System.Byte[])"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisHashes.HSETNX(System.String,System.String,System.Byte[])"]

Return Value

Type: Int32
1 if field is a new field in the hash and value was set. 0 if field already exists in the hash and the value was updated.
See Also

Reference

RedisHashes Class
HSETNX Overload


RedisHashes.HSETNX Method (String, String, String)

RedisHashesHSETNX Method (String, String, String)
设置一个元素项,如果元素项不存在则成功，否则设置失败

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int HSETNX(
    string key,
    string field,
    string value
)
Public Function HSETNX (
    key As String,
    field As String,
    value As String
) As Integer
public:
int HSETNX(
    String^ key,
    String^ field,
    String^ value
)
member HSETNX :
        key : string *
        field : string *
        value : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HSETNX(System.String,System.String,System.String)"]

field
Type: SystemString

[Missing <param name="field"/> documentation for "M:Adf.RedisHashes.HSETNX(System.String,System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisHashes.HSETNX(System.String,System.String,System.String)"]

Return Value

Type: Int32
1 if field is a new field in the hash and value was set. 0 if field already exists in the hash and the value was updated.
See Also

Reference

RedisHashes Class
HSETNX Overload


RedisHashes.HVALS Method

RedisHashesHVALS Method
获取元素的键项列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] HVALS(
    string key
)
Public Function HVALS (
    key As String
) As String()
public:
array<String^>^ HVALS(
    String^ key
)
member HVALS :
        key : string -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HVALS(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisHashes.HVALS(System.String)"]

See Also

Reference

RedisHashes Class


RedisHashes.HVALSByte Method

RedisHashesHVALSByte Method
获取元素的键项列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] HVALSByte(
    string key
)
Public Function HVALSByte (
    key As String
) As Byte()()
public:
array<array<unsigned char>^>^ HVALSByte(
    String^ key
)
member HVALSByte :
        key : string -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisHashes.HVALSByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisHashes.HVALSByte(System.String)"]

See Also

Reference

RedisHashes Class


RedisKeyType Enumeration

RedisKeyType Enumeration
Redis 键类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public enum RedisKeyType
Public Enumeration RedisKeyType
public enum class RedisKeyType
type RedisKeyType
Members
Member name | Value | Description
None | 0 |
String | 1 |
List | 2 |
Set | 3 |
See Also

Reference


RedisLists Class

RedisLists Class
Redis 列表
Inheritance Hierarchy
SystemObject
AdfRedisLists

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisLists
Public Class RedisLists
public ref class RedisLists
type RedisLists =  class end

The RedisLists type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | LIndex | 获取指定索引元素
Public method | LIndexByte | 获取指定索引元素
Public method | LInsert(String, Byte, Byte, Boolean) | 在指定位置添加元素
Public method | LInsert(String, String, String, Boolean) | 在指定位置添加元素
Public method | LLen | 获取列表长度
Public method | LPop | 取出列表第一元素
Public method | LPopByte | 取出列表第一元素
Public method | LPush(String, Byte) | 在列表左侧添加元素
Public method | LPush(String, String) | 在列表左侧添加元素
Public method | LRange | 获取列表中指定位置元素
Public method | LRangeByte | 获取列表中指定位置元素
Public method | LRem(String, Byte, Int32) | 移除元素后的一个列表范围
Public method | LRem(String, String, Int32) | 移除元素后的一个列表范围
Public method | LSet | 设置指定索引元素值
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | RPop | 取出列表最后一个元素
Public method | RPopByte | 取出列表最后一个元素
Public method | RPush(String, Byte) | 在列表右侧添加元素
Public method | RPush(String, String) | 在列表右侧添加元素
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


RedisLists Methods

RedisLists Methods

The RedisLists type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | LIndex | 获取指定索引元素
Public method | LIndexByte | 获取指定索引元素
Public method | LInsert(String, Byte, Byte, Boolean) | 在指定位置添加元素
Public method | LInsert(String, String, String, Boolean) | 在指定位置添加元素
Public method | LLen | 获取列表长度
Public method | LPop | 取出列表第一元素
Public method | LPopByte | 取出列表第一元素
Public method | LPush(String, Byte) | 在列表左侧添加元素
Public method | LPush(String, String) | 在列表左侧添加元素
Public method | LRange | 获取列表中指定位置元素
Public method | LRangeByte | 获取列表中指定位置元素
Public method | LRem(String, Byte, Int32) | 移除元素后的一个列表范围
Public method | LRem(String, String, Int32) | 移除元素后的一个列表范围
Public method | LSet | 设置指定索引元素值
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | RPop | 取出列表最后一个元素
Public method | RPopByte | 取出列表最后一个元素
Public method | RPush(String, Byte) | 在列表右侧添加元素
Public method | RPush(String, String) | 在列表右侧添加元素
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

RedisLists Class


RedisLists.LIndex Method

RedisListsLIndex Method
获取指定索引元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string LIndex(
    string key,
    int index
)
Public Function LIndex (
    key As String,
    index As Integer
) As String
public:
String^ LIndex(
    String^ key,
    int index
)
member LIndex :
        key : string *
        index : int -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LIndex(System.String,System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Adf.RedisLists.LIndex(System.String,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisLists.LIndex(System.String,System.Int32)"]

See Also

Reference

RedisLists Class


RedisLists.LIndexByte Method

RedisListsLIndexByte Method
获取指定索引元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] LIndexByte(
    string key,
    int index
)
Public Function LIndexByte (
    key As String,
    index As Integer
) As Byte()
public:
array<unsigned char>^ LIndexByte(
    String^ key,
    int index
)
member LIndexByte :
        key : string *
        index : int -> byte[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LIndexByte(System.String,System.Int32)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Adf.RedisLists.LIndexByte(System.String,System.Int32)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisLists.LIndexByte(System.String,System.Int32)"]

See Also

Reference

RedisLists Class


RedisLists.LInsert Method

RedisListsLInsert Method
Overload List
 | Name | Description
Public method | LInsert(String, Byte, Byte, Boolean) | 在指定位置添加元素
Public method | LInsert(String, String, String, Boolean) | 在指定位置添加元素
Top
See Also

Reference

RedisLists Class


RedisLists.LInsert Method (String, Byte[], Byte[], Boolean)

RedisListsLInsert Method (String, Byte, Byte, Boolean)
在指定位置添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LInsert(
    string key,
    byte[] value,
    byte[] pivot,
    bool before
)
Public Function LInsert (
    key As String,
    value As Byte(),
    pivot As Byte(),
    before As Boolean
) As Integer
public:
int LInsert(
    String^ key,
    array<unsigned char>^ value,
    array<unsigned char>^ pivot,
    bool before
)
member LInsert :
        key : string *
        value : byte[] *
        pivot : byte[] *
        before : bool -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LInsert(System.String,System.Byte[],System.Byte[],System.Boolean)"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.LInsert(System.String,System.Byte[],System.Byte[],System.Boolean)"]

pivot
Type: SystemByte
位置元素
before
Type: SystemBoolean
是否在前,true before,false after

Return Value

Type: Int32
添加后元素数
See Also

Reference

RedisLists Class
LInsert Overload


RedisLists.LInsert Method (String, String, String, Boolean)

RedisListsLInsert Method (String, String, String, Boolean)
在指定位置添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LInsert(
    string key,
    string value,
    string pivot,
    bool before
)
Public Function LInsert (
    key As String,
    value As String,
    pivot As String,
    before As Boolean
) As Integer
public:
int LInsert(
    String^ key,
    String^ value,
    String^ pivot,
    bool before
)
member LInsert :
        key : string *
        value : string *
        pivot : string *
        before : bool -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LInsert(System.String,System.String,System.String,System.Boolean)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.LInsert(System.String,System.String,System.String,System.Boolean)"]

pivot
Type: SystemString
位置元素
before
Type: SystemBoolean
是否在前,true before,false after

Return Value

Type: Int32
添加后元素数
See Also

Reference

RedisLists Class
LInsert Overload


RedisLists.LLen Method

RedisListsLLen Method
获取列表长度

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LLen(
    string key
)
Public Function LLen (
    key As String
) As Integer
public:
int LLen(
    String^ key
)
member LLen :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LLen(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisLists.LLen(System.String)"]

See Also

Reference

RedisLists Class


RedisLists.LPop Method

RedisListsLPop Method
取出列表第一元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string LPop(
    string key
)
Public Function LPop (
    key As String
) As String
public:
String^ LPop(
    String^ key
)
member LPop :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LPop(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisLists.LPop(System.String)"]

See Also

Reference

RedisLists Class


RedisLists.LPopByte Method

RedisListsLPopByte Method
取出列表第一元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] LPopByte(
    string key
)
Public Function LPopByte (
    key As String
) As Byte()
public:
array<unsigned char>^ LPopByte(
    String^ key
)
member LPopByte :
        key : string -> byte[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LPopByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisLists.LPopByte(System.String)"]

See Also

Reference

RedisLists Class


RedisLists.LPush Method

RedisListsLPush Method
Overload List
 | Name | Description
Public method | LPush(String, Byte) | 在列表左侧添加元素
Public method | LPush(String, String) | 在列表左侧添加元素
Top
See Also

Reference

RedisLists Class


RedisLists.LPush Method (String, Byte[])

RedisListsLPush Method (String, Byte)
在列表左侧添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LPush(
    string key,
    byte[] value
)
Public Function LPush (
    key As String,
    value As Byte()
) As Integer
public:
int LPush(
    String^ key,
    array<unsigned char>^ value
)
member LPush :
        key : string *
        value : byte[] -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LPush(System.String,System.Byte[])"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.LPush(System.String,System.Byte[])"]

Return Value

Type: Int32
添加后元素数
See Also

Reference

RedisLists Class
LPush Overload


RedisLists.LPush Method (String, String)

RedisListsLPush Method (String, String)
在列表左侧添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LPush(
    string key,
    string value
)
Public Function LPush (
    key As String,
    value As String
) As Integer
public:
int LPush(
    String^ key,
    String^ value
)
member LPush :
        key : string *
        value : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LPush(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.LPush(System.String,System.String)"]

Return Value

Type: Int32
添加后元素数
See Also

Reference

RedisLists Class
LPush Overload


RedisLists.LRange Method

RedisListsLRange Method
获取列表中指定位置元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] LRange(
    string key,
    int start,
    int end
)
Public Function LRange (
    key As String,
    start As Integer,
    end As Integer
) As String()
public:
array<String^>^ LRange(
    String^ key,
    int start,
    int end
)
member LRange :
        key : string *
        start : int *
        end : int -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LRange(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisLists.LRange(System.String,System.Int32,System.Int32)"]

end
Type: SystemInt32

[Missing <param name="end"/> documentation for "M:Adf.RedisLists.LRange(System.String,System.Int32,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisLists.LRange(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisLists Class


RedisLists.LRangeByte Method

RedisListsLRangeByte Method
获取列表中指定位置元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] LRangeByte(
    string key,
    int start,
    int end
)
Public Function LRangeByte (
    key As String,
    start As Integer,
    end As Integer
) As Byte()()
public:
array<array<unsigned char>^>^ LRangeByte(
    String^ key,
    int start,
    int end
)
member LRangeByte :
        key : string *
        start : int *
        end : int -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LRangeByte(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisLists.LRangeByte(System.String,System.Int32,System.Int32)"]

end
Type: SystemInt32

[Missing <param name="end"/> documentation for "M:Adf.RedisLists.LRangeByte(System.String,System.Int32,System.Int32)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisLists.LRangeByte(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisLists Class


RedisLists.LRem Method

RedisListsLRem Method
Overload List
 | Name | Description
Public method | LRem(String, Byte, Int32) | 移除元素后的一个列表范围
Public method | LRem(String, String, Int32) | 移除元素后的一个列表范围
Top
See Also

Reference

RedisLists Class


RedisLists.LRem Method (String, Byte[], Int32)

RedisListsLRem Method (String, Byte, Int32)
移除元素后的一个列表范围

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LRem(
    string key,
    byte[] value,
    int count
)
Public Function LRem (
    key As String,
    value As Byte(),
    count As Integer
) As Integer
public:
int LRem(
    String^ key,
    array<unsigned char>^ value,
    int count
)
member LRem :
        key : string *
        value : byte[] *
        count : int -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LRem(System.String,System.Byte[],System.Int32)"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.LRem(System.String,System.Byte[],System.Int32)"]

count
Type: SystemInt32
count < 0: Remove elements equal to value moving from head to tail. count > 0: Remove elements equal to value moving from tail to head. count = 0: Remove all elements equal to value.

Return Value

Type: Int32
Integer reply: the number of removed elements.
See Also

Reference

RedisLists Class
LRem Overload


RedisLists.LRem Method (String, String, Int32)

RedisListsLRem Method (String, String, Int32)
移除元素后的一个列表范围

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int LRem(
    string key,
    string value,
    int count
)
Public Function LRem (
    key As String,
    value As String,
    count As Integer
) As Integer
public:
int LRem(
    String^ key,
    String^ value,
    int count
)
member LRem :
        key : string *
        value : string *
        count : int -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LRem(System.String,System.String,System.Int32)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.LRem(System.String,System.String,System.Int32)"]

count
Type: SystemInt32
count < 0: Remove elements equal to value moving from head to tail. count > 0: Remove elements equal to value moving from tail to head. count = 0: Remove all elements equal to value.

Return Value

Type: Int32
Integer reply: the number of removed elements.
See Also

Reference

RedisLists Class
LRem Overload


RedisLists.LSet Method

RedisListsLSet Method
设置指定索引元素值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool LSet(
    string key,
    int index,
    string value
)
Public Function LSet (
    key As String,
    index As Integer,
    value As String
) As Boolean
public:
bool LSet(
    String^ key,
    int index,
    String^ value
)
member LSet :
        key : string *
        index : int *
        value : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.LSet(System.String,System.Int32,System.String)"]

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:Adf.RedisLists.LSet(System.String,System.Int32,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.LSet(System.String,System.Int32,System.String)"]

Return Value

Type: Boolean
Integer reply: the number of removed elements.
See Also

Reference

RedisLists Class


RedisLists.RPop Method

RedisListsRPop Method
取出列表最后一个元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string RPop(
    string key
)
Public Function RPop (
    key As String
) As String
public:
String^ RPop(
    String^ key
)
member RPop :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.RPop(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisLists.RPop(System.String)"]

See Also

Reference

RedisLists Class


RedisLists.RPopByte Method

RedisListsRPopByte Method
取出列表最后一个元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] RPopByte(
    string key
)
Public Function RPopByte (
    key As String
) As Byte()
public:
array<unsigned char>^ RPopByte(
    String^ key
)
member RPopByte :
        key : string -> byte[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.RPopByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisLists.RPopByte(System.String)"]

See Also

Reference

RedisLists Class


RedisLists.RPush Method

RedisListsRPush Method
Overload List
 | Name | Description
Public method | RPush(String, Byte) | 在列表右侧添加元素
Public method | RPush(String, String) | 在列表右侧添加元素
Top
See Also

Reference

RedisLists Class


RedisLists.RPush Method (String, Byte[])

RedisListsRPush Method (String, Byte)
在列表右侧添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int RPush(
    string key,
    byte[] value
)
Public Function RPush (
    key As String,
    value As Byte()
) As Integer
public:
int RPush(
    String^ key,
    array<unsigned char>^ value
)
member RPush :
        key : string *
        value : byte[] -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.RPush(System.String,System.Byte[])"]

value
Type: SystemByte

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.RPush(System.String,System.Byte[])"]

Return Value

Type: Int32
添加后元素数
See Also

Reference

RedisLists Class
RPush Overload


RedisLists.RPush Method (String, String)

RedisListsRPush Method (String, String)
在列表右侧添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int RPush(
    string key,
    string value
)
Public Function RPush (
    key As String,
    value As String
) As Integer
public:
int RPush(
    String^ key,
    String^ value
)
member RPush :
        key : string *
        value : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisLists.RPush(System.String,System.String)"]

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.RedisLists.RPush(System.String,System.String)"]

Return Value

Type: Int32
添加后元素数
See Also

Reference

RedisLists Class
RPush Overload


RedisResponseException Class

RedisResponseException Class
Redis 响应异常
Inheritance Hierarchy
SystemObject
SystemException
AdfRedisResponseException

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisResponseException : Exception
Public Class RedisResponseException
    Inherits Exception
public ref class RedisResponseException : public Exception
type RedisResponseException =
    class
        inherit Exception
    end

The RedisResponseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Code |
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference


RedisResponseException Methods

RedisResponseException Methods

The RedisResponseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
See Also

Reference

RedisResponseException Class


RedisResponseException Properties

RedisResponseException Properties

The RedisResponseException type exposes the following members.

Properties
 | Name | Description
Public property | Code |
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference

RedisResponseException Class


RedisResponseException.Code Property

RedisResponseExceptionCode Property

[Missing <summary> documentation for "P:Adf.RedisResponseException.Code"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Code { get; }
Public ReadOnly Property Code As String
    Get
public:
property String^ Code {
    String^ get ();
}
member Code : string with get

Property Value

Type: String
See Also

Reference

RedisResponseException Class


RedisSets Class

RedisSets Class
Redis 集合
Inheritance Hierarchy
SystemObject
AdfRedisSets

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisSets
Public Class RedisSets
public ref class RedisSets
type RedisSets =  class end

The RedisSets type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | REM | 移除元素
Public method | REMByte | 移除元素
Public method | SAdd(String, Byte) | 添加一个元素
Public method | SAdd(String, String) | 添加元素
Public method | SCARD | 返回集合数
Public method | SDIFF | 返回多个集合差集
Public method | SDIFFByte | 返回多个集合差集
Public method | SDIFFSTORE |
Public method | SINTER | 返回多个集合交集
Public method | SINTERByte | 返回多个集合交集
Public method | SINTERSTORE |
Public method | SISMEMBER(String, Byte) | 判断是否存在元素
Public method | SISMEMBER(String, String) | 判断是否存在元素
Public method | SMEMBERS | 获取集合内容
Public method | SMEMBERSByte | 获取集合内容
Public method | SMOVE(String, String, Byte) | 移动元素至指定集合
Public method | SMOVE(String, String, String) | 移动元素至指定集合
Public method | SPOP | 移除并返回元素
Public method | SPOPByte | 移除并返回元素
Public method | SRANDMEMBER(String) | 随机返回指定数量元素
Public method | SRANDMEMBER(String, Int32) | 随机返回指定数量元素
Public method | SRANDMEMBERByte(String) | 随机返回指定数量元素
Public method | SRANDMEMBERByte(String, Int32) | 随机返回指定数量元素
Public method | SUNION | 合并返回指定的集合
Public method | SUNIONByte | 合并返回指定的集合
Public method | SUNIONSTORE | 合并元素至目标键
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


RedisSets Methods

RedisSets Methods

The RedisSets type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | REM | 移除元素
Public method | REMByte | 移除元素
Public method | SAdd(String, Byte) | 添加一个元素
Public method | SAdd(String, String) | 添加元素
Public method | SCARD | 返回集合数
Public method | SDIFF | 返回多个集合差集
Public method | SDIFFByte | 返回多个集合差集
Public method | SDIFFSTORE |
Public method | SINTER | 返回多个集合交集
Public method | SINTERByte | 返回多个集合交集
Public method | SINTERSTORE |
Public method | SISMEMBER(String, Byte) | 判断是否存在元素
Public method | SISMEMBER(String, String) | 判断是否存在元素
Public method | SMEMBERS | 获取集合内容
Public method | SMEMBERSByte | 获取集合内容
Public method | SMOVE(String, String, Byte) | 移动元素至指定集合
Public method | SMOVE(String, String, String) | 移动元素至指定集合
Public method | SPOP | 移除并返回元素
Public method | SPOPByte | 移除并返回元素
Public method | SRANDMEMBER(String) | 随机返回指定数量元素
Public method | SRANDMEMBER(String, Int32) | 随机返回指定数量元素
Public method | SRANDMEMBERByte(String) | 随机返回指定数量元素
Public method | SRANDMEMBERByte(String, Int32) | 随机返回指定数量元素
Public method | SUNION | 合并返回指定的集合
Public method | SUNIONByte | 合并返回指定的集合
Public method | SUNIONSTORE | 合并元素至目标键
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

RedisSets Class


RedisSets.REM Method

RedisSetsREM Method
移除元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool REM(
    string key,
    string member
)
Public Function REM (
    key As String,
    member As String
) As Boolean
public:
bool REM(
    String^ key,
    String^ member
)
member REM :
        key : string *
        member : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.REM(System.String,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.REM(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.REM(System.String,System.String)"]

See Also

Reference

RedisSets Class


RedisSets.REMByte Method

RedisSetsREMByte Method
移除元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool REMByte(
    string key,
    byte[] member
)
Public Function REMByte (
    key As String,
    member As Byte()
) As Boolean
public:
bool REMByte(
    String^ key,
    array<unsigned char>^ member
)
member REMByte :
        key : string *
        member : byte[] -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.REMByte(System.String,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.REMByte(System.String,System.Byte[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.REMByte(System.String,System.Byte[])"]

See Also

Reference

RedisSets Class


RedisSets.SAdd Method

RedisSetsSAdd Method
Overload List
 | Name | Description
Public method | SAdd(String, Byte) | 添加一个元素
Public method | SAdd(String, String) | 添加元素
Top
See Also

Reference

RedisSets Class


RedisSets.SAdd Method (String, Byte[])

RedisSetsSAdd Method (String, Byte)
添加一个元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SAdd(
    string key,
    byte[] member
)
Public Function SAdd (
    key As String,
    member As Byte()
) As Boolean
public:
bool SAdd(
    String^ key,
    array<unsigned char>^ member
)
member SAdd :
        key : string *
        member : byte[] -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SAdd(System.String,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.SAdd(System.String,System.Byte[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.SAdd(System.String,System.Byte[])"]

See Also

Reference

RedisSets Class
SAdd Overload


RedisSets.SAdd Method (String, String)

RedisSetsSAdd Method (String, String)
添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SAdd(
    string key,
    string member
)
Public Function SAdd (
    key As String,
    member As String
) As Boolean
public:
bool SAdd(
    String^ key,
    String^ member
)
member SAdd :
        key : string *
        member : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SAdd(System.String,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.SAdd(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.SAdd(System.String,System.String)"]

See Also

Reference

RedisSets Class
SAdd Overload


RedisSets.SCARD Method

RedisSetsSCARD Method
返回集合数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int SCARD(
    string key
)
Public Function SCARD (
    key As String
) As Integer
public:
int SCARD(
    String^ key
)
member SCARD :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SCARD(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSets.SCARD(System.String)"]

See Also

Reference

RedisSets Class


RedisSets.SDIFF Method

RedisSetsSDIFF Method
返回多个集合差集

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] SDIFF(
    params string[] keys
)
Public Function SDIFF (
    ParamArray keys As String()
) As String()
public:
array<String^>^ SDIFF(
    ... array<String^>^ keys
)
member SDIFF :
        keys : string[] -> string[]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SDIFF(System.String[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSets.SDIFF(System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SDIFFByte Method

RedisSetsSDIFFByte Method
返回多个集合差集

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] SDIFFByte(
    params string[] keys
)
Public Function SDIFFByte (
    ParamArray keys As String()
) As Byte()()
public:
array<array<unsigned char>^>^ SDIFFByte(
    ... array<String^>^ keys
)
member SDIFFByte :
        keys : string[] -> byte[][]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SDIFFByte(System.String[])"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSets.SDIFFByte(System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SDIFFSTORE Method

RedisSetsSDIFFSTORE Method

[Missing <summary> documentation for "M:Adf.RedisSets.SDIFFSTORE(System.String,System.String[])"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int SDIFFSTORE(
    string destKey,
    params string[] keys
)
Public Function SDIFFSTORE (
    destKey As String,
    ParamArray keys As String()
) As Integer
public:
int SDIFFSTORE(
    String^ destKey,
    ... array<String^>^ keys
)
member SDIFFSTORE :
        destKey : string *
        keys : string[] -> int

Parameters

destKey
Type: SystemString

[Missing <param name="destKey"/> documentation for "M:Adf.RedisSets.SDIFFSTORE(System.String,System.String[])"]

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SDIFFSTORE(System.String,System.String[])"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSets.SDIFFSTORE(System.String,System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SINTER Method

RedisSetsSINTER Method
返回多个集合交集

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] SINTER(
    params string[] keys
)
Public Function SINTER (
    ParamArray keys As String()
) As String()
public:
array<String^>^ SINTER(
    ... array<String^>^ keys
)
member SINTER :
        keys : string[] -> string[]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SINTER(System.String[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSets.SINTER(System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SINTERByte Method

RedisSetsSINTERByte Method
返回多个集合交集

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] SINTERByte(
    params string[] keys
)
Public Function SINTERByte (
    ParamArray keys As String()
) As Byte()()
public:
array<array<unsigned char>^>^ SINTERByte(
    ... array<String^>^ keys
)
member SINTERByte :
        keys : string[] -> byte[][]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SINTERByte(System.String[])"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSets.SINTERByte(System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SINTERSTORE Method

RedisSetsSINTERSTORE Method

[Missing <summary> documentation for "M:Adf.RedisSets.SINTERSTORE(System.String,System.String[])"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int SINTERSTORE(
    string destKey,
    params string[] keys
)
Public Function SINTERSTORE (
    destKey As String,
    ParamArray keys As String()
) As Integer
public:
int SINTERSTORE(
    String^ destKey,
    ... array<String^>^ keys
)
member SINTERSTORE :
        destKey : string *
        keys : string[] -> int

Parameters

destKey
Type: SystemString

[Missing <param name="destKey"/> documentation for "M:Adf.RedisSets.SINTERSTORE(System.String,System.String[])"]

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SINTERSTORE(System.String,System.String[])"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSets.SINTERSTORE(System.String,System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SISMEMBER Method

RedisSetsSISMEMBER Method
Overload List
 | Name | Description
Public method | SISMEMBER(String, Byte) | 判断是否存在元素
Public method | SISMEMBER(String, String) | 判断是否存在元素
Top
See Also

Reference

RedisSets Class


RedisSets.SISMEMBER Method (String, Byte[])

RedisSetsSISMEMBER Method (String, Byte)
判断是否存在元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SISMEMBER(
    string key,
    byte[] member
)
Public Function SISMEMBER (
    key As String,
    member As Byte()
) As Boolean
public:
bool SISMEMBER(
    String^ key,
    array<unsigned char>^ member
)
member SISMEMBER :
        key : string *
        member : byte[] -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SISMEMBER(System.String,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.SISMEMBER(System.String,System.Byte[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.SISMEMBER(System.String,System.Byte[])"]

See Also

Reference

RedisSets Class
SISMEMBER Overload


RedisSets.SISMEMBER Method (String, String)

RedisSetsSISMEMBER Method (String, String)
判断是否存在元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SISMEMBER(
    string key,
    string member
)
Public Function SISMEMBER (
    key As String,
    member As String
) As Boolean
public:
bool SISMEMBER(
    String^ key,
    String^ member
)
member SISMEMBER :
        key : string *
        member : string -> bool

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SISMEMBER(System.String,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.SISMEMBER(System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.SISMEMBER(System.String,System.String)"]

See Also

Reference

RedisSets Class
SISMEMBER Overload


RedisSets.SMEMBERS Method

RedisSetsSMEMBERS Method
获取集合内容

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] SMEMBERS(
    string key
)
Public Function SMEMBERS (
    key As String
) As String()
public:
array<String^>^ SMEMBERS(
    String^ key
)
member SMEMBERS :
        key : string -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SMEMBERS(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSets.SMEMBERS(System.String)"]

See Also

Reference

RedisSets Class


RedisSets.SMEMBERSByte Method

RedisSetsSMEMBERSByte Method
获取集合内容

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] SMEMBERSByte(
    string key
)
Public Function SMEMBERSByte (
    key As String
) As Byte()()
public:
array<array<unsigned char>^>^ SMEMBERSByte(
    String^ key
)
member SMEMBERSByte :
        key : string -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SMEMBERSByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSets.SMEMBERSByte(System.String)"]

See Also

Reference

RedisSets Class


RedisSets.SMOVE Method

RedisSetsSMOVE Method
Overload List
 | Name | Description
Public method | SMOVE(String, String, Byte) | 移动元素至指定集合
Public method | SMOVE(String, String, String) | 移动元素至指定集合
Top
See Also

Reference

RedisSets Class


RedisSets.SMOVE Method (String, String, Byte[])

RedisSetsSMOVE Method (String, String, Byte)
移动元素至指定集合

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SMOVE(
    string srcKey,
    string destKey,
    byte[] member
)
Public Function SMOVE (
    srcKey As String,
    destKey As String,
    member As Byte()
) As Boolean
public:
bool SMOVE(
    String^ srcKey,
    String^ destKey,
    array<unsigned char>^ member
)
member SMOVE :
        srcKey : string *
        destKey : string *
        member : byte[] -> bool

Parameters

srcKey
Type: SystemString

[Missing <param name="srcKey"/> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.Byte[])"]

destKey
Type: SystemString

[Missing <param name="destKey"/> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.Byte[])"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.Byte[])"]

See Also

Reference

RedisSets Class
SMOVE Overload


RedisSets.SMOVE Method (String, String, String)

RedisSetsSMOVE Method (String, String, String)
移动元素至指定集合

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool SMOVE(
    string srcKey,
    string destKey,
    string member
)
Public Function SMOVE (
    srcKey As String,
    destKey As String,
    member As String
) As Boolean
public:
bool SMOVE(
    String^ srcKey,
    String^ destKey,
    String^ member
)
member SMOVE :
        srcKey : string *
        destKey : string *
        member : string -> bool

Parameters

srcKey
Type: SystemString

[Missing <param name="srcKey"/> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.String)"]

destKey
Type: SystemString

[Missing <param name="destKey"/> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.RedisSets.SMOVE(System.String,System.String,System.String)"]

See Also

Reference

RedisSets Class
SMOVE Overload


RedisSets.SPOP Method

RedisSetsSPOP Method
移除并返回元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string SPOP(
    string key
)
Public Function SPOP (
    key As String
) As String
public:
String^ SPOP(
    String^ key
)
member SPOP :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SPOP(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSets.SPOP(System.String)"]

See Also

Reference

RedisSets Class


RedisSets.SPOPByte Method

RedisSetsSPOPByte Method
移除并返回元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] SPOPByte(
    string key
)
Public Function SPOPByte (
    key As String
) As Byte()
public:
array<unsigned char>^ SPOPByte(
    String^ key
)
member SPOPByte :
        key : string -> byte[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SPOPByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSets.SPOPByte(System.String)"]

See Also

Reference

RedisSets Class


RedisSets.SRANDMEMBER Method

RedisSetsSRANDMEMBER Method
Overload List
 | Name | Description
Public method | SRANDMEMBER(String) | 随机返回指定数量元素
Public method | SRANDMEMBER(String, Int32) | 随机返回指定数量元素
Top
See Also

Reference

RedisSets Class


RedisSets.SRANDMEMBER Method (String)

RedisSetsSRANDMEMBER Method (String)
随机返回指定数量元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string SRANDMEMBER(
    string key
)
Public Function SRANDMEMBER (
    key As String
) As String
public:
String^ SRANDMEMBER(
    String^ key
)
member SRANDMEMBER :
        key : string -> string

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SRANDMEMBER(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSets.SRANDMEMBER(System.String)"]

See Also

Reference

RedisSets Class
SRANDMEMBER Overload


RedisSets.SRANDMEMBER Method (String, Int32)

RedisSetsSRANDMEMBER Method (String, Int32)
随机返回指定数量元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] SRANDMEMBER(
    string key,
    int count
)
Public Function SRANDMEMBER (
    key As String,
    count As Integer
) As String()
public:
array<String^>^ SRANDMEMBER(
    String^ key,
    int count
)
member SRANDMEMBER :
        key : string *
        count : int -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SRANDMEMBER(System.String,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:Adf.RedisSets.SRANDMEMBER(System.String,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSets.SRANDMEMBER(System.String,System.Int32)"]

See Also

Reference

RedisSets Class
SRANDMEMBER Overload


RedisSets.SRANDMEMBERByte Method

RedisSetsSRANDMEMBERByte Method
Overload List
 | Name | Description
Public method | SRANDMEMBERByte(String) | 随机返回指定数量元素
Public method | SRANDMEMBERByte(String, Int32) | 随机返回指定数量元素
Top
See Also

Reference

RedisSets Class


RedisSets.SRANDMEMBERByte Method (String)

RedisSetsSRANDMEMBERByte Method (String)
随机返回指定数量元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] SRANDMEMBERByte(
    string key
)
Public Function SRANDMEMBERByte (
    key As String
) As Byte()
public:
array<unsigned char>^ SRANDMEMBERByte(
    String^ key
)
member SRANDMEMBERByte :
        key : string -> byte[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SRANDMEMBERByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSets.SRANDMEMBERByte(System.String)"]

See Also

Reference

RedisSets Class
SRANDMEMBERByte Overload


RedisSets.SRANDMEMBERByte Method (String, Int32)

RedisSetsSRANDMEMBERByte Method (String, Int32)
随机返回指定数量元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] SRANDMEMBERByte(
    string key,
    int count
)
Public Function SRANDMEMBERByte (
    key As String,
    count As Integer
) As Byte()()
public:
array<array<unsigned char>^>^ SRANDMEMBERByte(
    String^ key,
    int count
)
member SRANDMEMBERByte :
        key : string *
        count : int -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSets.SRANDMEMBERByte(System.String,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:Adf.RedisSets.SRANDMEMBERByte(System.String,System.Int32)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSets.SRANDMEMBERByte(System.String,System.Int32)"]

See Also

Reference

RedisSets Class
SRANDMEMBERByte Overload


RedisSets.SUNION Method

RedisSetsSUNION Method
合并返回指定的集合

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] SUNION(
    params string[] keys
)
Public Function SUNION (
    ParamArray keys As String()
) As String()
public:
array<String^>^ SUNION(
    ... array<String^>^ keys
)
member SUNION :
        keys : string[] -> string[]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SUNION(System.String[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSets.SUNION(System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SUNIONByte Method

RedisSetsSUNIONByte Method
合并返回指定的集合

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] SUNIONByte(
    params string[] keys
)
Public Function SUNIONByte (
    ParamArray keys As String()
) As Byte()()
public:
array<array<unsigned char>^>^ SUNIONByte(
    ... array<String^>^ keys
)
member SUNIONByte :
        keys : string[] -> byte[][]

Parameters

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SUNIONByte(System.String[])"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSets.SUNIONByte(System.String[])"]

See Also

Reference

RedisSets Class


RedisSets.SUNIONSTORE Method

RedisSetsSUNIONSTORE Method
合并元素至目标键

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void SUNIONSTORE(
    string destKey,
    params string[] keys
)
Public Sub SUNIONSTORE (
    destKey As String,
    ParamArray keys As String()
)
public:
void SUNIONSTORE(
    String^ destKey,
    ... array<String^>^ keys
)
member SUNIONSTORE :
        destKey : string *
        keys : string[] -> unit

Parameters

destKey
Type: SystemString

[Missing <param name="destKey"/> documentation for "M:Adf.RedisSets.SUNIONSTORE(System.String,System.String[])"]

keys
Type: SystemString

[Missing <param name="keys"/> documentation for "M:Adf.RedisSets.SUNIONSTORE(System.String,System.String[])"]

See Also

Reference

RedisSets Class


RedisSortedSets Class

RedisSortedSets Class
Redis 有序集合
Inheritance Hierarchy
SystemObject
AdfRedisSortedSets

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisSortedSets
Public Class RedisSortedSets
public ref class RedisSortedSets
type RedisSortedSets =  class end

The RedisSortedSets type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | ZAdd(String, Double, Byte) | 添加一个元素
Public method | ZAdd(String, Double, String) | 添加元素
Public method | ZCARD(String) | 返回集合数
Public method | ZCARD(String, Double, Double) | 返回给定范围间的元素数
Public method | ZINCRBY(String, Int32, Byte) | 给指定元素添加自增值
Public method | ZINCRBY(String, Int32, String) | 给指定元素添加自增值
Public method | ZINTERSTORE | 计算给定的一个或多个有序集的交集，其中给定 key 的数量必须以 numkeys 参数指定，并将该交集(结果集)储存到 destination 。 默认情况下，结果集中某个成员的 score 值是所有给定集下该成员 score 值之和. 关于 WEIGHTS 和 AGGREGATE 选项的描述，参见 ZUNIONSTORE 命令
Public method | ZRANGE | 返回给定的分值范围元素内容列表
Public method | ZRANGEBYSCORE | 返回给定的分值范围元素列表
Public method | ZRANGEBYSCOREByte(String, Double, Double, Int32, Int32) | 返回给定的分值范围元素列表
Public method | ZRANGEBYSCOREByte(String, Double, Double, Boolean, Int32, Int32) | 返回给定的分值范围元素列表
Public method | ZRANGEBYSCOREValues | 返回给定的分值范围元素列表
Public method | ZRANGEByte(String, Int32, Int32) | 返回给定的分值范围元素内容列表
Public method | ZRANGEByte(String, Int32, Int32, Boolean) | 返回给定的分值范围元素列表
Public method | ZRANGEValues | 返回给定的分值范围元素内容列表
Public method | ZRANK(String, Byte) | 获取元素排名
Public method | ZRANK(String, String) | 获取元素排名
Public method | ZREM(String, Byte) | 删除元素
Public method | ZREM(String, String) | 删除元素
Public method | ZREMRANGEBYRANK | 删除一个范围元素
Public method | ZREMRANGEBYSCORE | 删除一个积分范围元素
Public method | ZREVRANGE | 返回给定的区间元素列表
Public method | ZREVRANGEBYSCORE | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEBYSCOREByte(String, Double, Double, Int32, Int32) | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEBYSCOREByte(String, Double, Double, Boolean, Int32, Int32) | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEBYSCOREValues | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEByte(String, Int32, Int32) | 返回给定的区间元素列表
Public method | ZREVRANGEByte(String, Int32, Int32, Boolean) | 返回给定的区间元素列表
Public method | ZREVRANGEValues | 返回给定的区间元素列表
Public method | ZREVRANK(String, Byte) | 返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。
Public method | ZREVRANK(String, String) | 返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。
Public method | ZSCORE(String, Byte) | 返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。
Public method | ZSCORE(String, String) | 返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。
Public method | ZUNIONSTORE | 计算给定的一个或多个有序集的并集，其中给定 key 的数量必须以 numkeys 参数指定，并将该并集(结果集)储存到 destination 。 默认情况下，结果集中某个成员的 score 值是所有给定集下该成员 score 值之 和 。
Top
See Also

Reference


RedisSortedSets Methods

RedisSortedSets Methods

The RedisSortedSets type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | ZAdd(String, Double, Byte) | 添加一个元素
Public method | ZAdd(String, Double, String) | 添加元素
Public method | ZCARD(String) | 返回集合数
Public method | ZCARD(String, Double, Double) | 返回给定范围间的元素数
Public method | ZINCRBY(String, Int32, Byte) | 给指定元素添加自增值
Public method | ZINCRBY(String, Int32, String) | 给指定元素添加自增值
Public method | ZINTERSTORE | 计算给定的一个或多个有序集的交集，其中给定 key 的数量必须以 numkeys 参数指定，并将该交集(结果集)储存到 destination 。 默认情况下，结果集中某个成员的 score 值是所有给定集下该成员 score 值之和. 关于 WEIGHTS 和 AGGREGATE 选项的描述，参见 ZUNIONSTORE 命令
Public method | ZRANGE | 返回给定的分值范围元素内容列表
Public method | ZRANGEBYSCORE | 返回给定的分值范围元素列表
Public method | ZRANGEBYSCOREByte(String, Double, Double, Int32, Int32) | 返回给定的分值范围元素列表
Public method | ZRANGEBYSCOREByte(String, Double, Double, Boolean, Int32, Int32) | 返回给定的分值范围元素列表
Public method | ZRANGEBYSCOREValues | 返回给定的分值范围元素列表
Public method | ZRANGEByte(String, Int32, Int32) | 返回给定的分值范围元素内容列表
Public method | ZRANGEByte(String, Int32, Int32, Boolean) | 返回给定的分值范围元素列表
Public method | ZRANGEValues | 返回给定的分值范围元素内容列表
Public method | ZRANK(String, Byte) | 获取元素排名
Public method | ZRANK(String, String) | 获取元素排名
Public method | ZREM(String, Byte) | 删除元素
Public method | ZREM(String, String) | 删除元素
Public method | ZREMRANGEBYRANK | 删除一个范围元素
Public method | ZREMRANGEBYSCORE | 删除一个积分范围元素
Public method | ZREVRANGE | 返回给定的区间元素列表
Public method | ZREVRANGEBYSCORE | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEBYSCOREByte(String, Double, Double, Int32, Int32) | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEBYSCOREByte(String, Double, Double, Boolean, Int32, Int32) | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEBYSCOREValues | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEByte(String, Int32, Int32) | 返回给定的区间元素列表
Public method | ZREVRANGEByte(String, Int32, Int32, Boolean) | 返回给定的区间元素列表
Public method | ZREVRANGEValues | 返回给定的区间元素列表
Public method | ZREVRANK(String, Byte) | 返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。
Public method | ZREVRANK(String, String) | 返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。
Public method | ZSCORE(String, Byte) | 返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。
Public method | ZSCORE(String, String) | 返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。
Public method | ZUNIONSTORE | 计算给定的一个或多个有序集的并集，其中给定 key 的数量必须以 numkeys 参数指定，并将该并集(结果集)储存到 destination 。 默认情况下，结果集中某个成员的 score 值是所有给定集下该成员 score 值之 和 。
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZAdd Method

RedisSortedSetsZAdd Method
Overload List
 | Name | Description
Public method | ZAdd(String, Double, Byte) | 添加一个元素
Public method | ZAdd(String, Double, String) | 添加元素
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZAdd Method (String, Double, Byte[])

RedisSortedSetsZAdd Method (String, Double, Byte)
添加一个元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZAdd(
    string key,
    double score,
    byte[] member
)
Public Function ZAdd (
    key As String,
    score As Double,
    member As Byte()
) As Double
public:
double ZAdd(
    String^ key,
    double score,
    array<unsigned char>^ member
)
member ZAdd :
        key : string *
        score : float *
        member : byte[] -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZAdd(System.String,System.Double,System.Byte[])"]

score
Type: SystemDouble

[Missing <param name="score"/> documentation for "M:Adf.RedisSortedSets.ZAdd(System.String,System.Double,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZAdd(System.String,System.Double,System.Byte[])"]

Return Value

Type: Double
排序
See Also

Reference

RedisSortedSets Class
ZAdd Overload


RedisSortedSets.ZAdd Method (String, Double, String)

RedisSortedSetsZAdd Method (String, Double, String)
添加元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZAdd(
    string key,
    double score,
    string member
)
Public Function ZAdd (
    key As String,
    score As Double,
    member As String
) As Double
public:
double ZAdd(
    String^ key,
    double score,
    String^ member
)
member ZAdd :
        key : string *
        score : float *
        member : string -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZAdd(System.String,System.Double,System.String)"]

score
Type: SystemDouble

[Missing <param name="score"/> documentation for "M:Adf.RedisSortedSets.ZAdd(System.String,System.Double,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZAdd(System.String,System.Double,System.String)"]

Return Value

Type: Double
排序
See Also

Reference

RedisSortedSets Class
ZAdd Overload


RedisSortedSets.ZCARD Method

RedisSortedSetsZCARD Method
Overload List
 | Name | Description
Public method | ZCARD(String) | 返回集合数
Public method | ZCARD(String, Double, Double) | 返回给定范围间的元素数
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZCARD Method (String)

RedisSortedSetsZCARD Method (String)
返回集合数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZCARD(
    string key
)
Public Function ZCARD (
    key As String
) As Integer
public:
int ZCARD(
    String^ key
)
member ZCARD :
        key : string -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZCARD(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZCARD(System.String)"]

See Also

Reference

RedisSortedSets Class
ZCARD Overload


RedisSortedSets.ZCARD Method (String, Double, Double)

RedisSortedSetsZCARD Method (String, Double, Double)
返回给定范围间的元素数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZCARD(
    string key,
    double min,
    double max
)
Public Function ZCARD (
    key As String,
    min As Double,
    max As Double
) As Integer
public:
int ZCARD(
    String^ key,
    double min,
    double max
)
member ZCARD :
        key : string *
        min : float *
        max : float -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZCARD(System.String,System.Double,System.Double)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZCARD(System.String,System.Double,System.Double)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZCARD(System.String,System.Double,System.Double)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZCARD(System.String,System.Double,System.Double)"]

See Also

Reference

RedisSortedSets Class
ZCARD Overload


RedisSortedSets.ZINCRBY Method

RedisSortedSetsZINCRBY Method
Overload List
 | Name | Description
Public method | ZINCRBY(String, Int32, Byte) | 给指定元素添加自增值
Public method | ZINCRBY(String, Int32, String) | 给指定元素添加自增值
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZINCRBY Method (String, Int32, Byte[])

RedisSortedSetsZINCRBY Method (String, Int32, Byte)
给指定元素添加自增值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZINCRBY(
    string key,
    int increment,
    byte[] member
)
Public Function ZINCRBY (
    key As String,
    increment As Integer,
    member As Byte()
) As Double
public:
double ZINCRBY(
    String^ key,
    int increment,
    array<unsigned char>^ member
)
member ZINCRBY :
        key : string *
        increment : int *
        member : byte[] -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.Byte[])"]

increment
Type: SystemInt32

[Missing <param name="increment"/> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.Byte[])"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.Byte[])"]

See Also

Reference

RedisSortedSets Class
ZINCRBY Overload


RedisSortedSets.ZINCRBY Method (String, Int32, String)

RedisSortedSetsZINCRBY Method (String, Int32, String)
给指定元素添加自增值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZINCRBY(
    string key,
    int increment,
    string member
)
Public Function ZINCRBY (
    key As String,
    increment As Integer,
    member As String
) As Double
public:
double ZINCRBY(
    String^ key,
    int increment,
    String^ member
)
member ZINCRBY :
        key : string *
        increment : int *
        member : string -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.String)"]

increment
Type: SystemInt32

[Missing <param name="increment"/> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZINCRBY(System.String,System.Int32,System.String)"]

See Also

Reference

RedisSortedSets Class
ZINCRBY Overload


RedisSortedSets.ZINTERSTORE Method

RedisSortedSetsZINTERSTORE Method
计算给定的一个或多个有序集的交集，其中给定 key 的数量必须以 numkeys 参数指定，并将该交集(结果集)储存到 destination 。 默认情况下，结果集中某个成员的 score 值是所有给定集下该成员 score 值之和. 关于 WEIGHTS 和 AGGREGATE 选项的描述，参见 ZUNIONSTORE 命令

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZINTERSTORE(
    string destinationKey,
    IDictionary<string, int> keyWeights,
    RedisAggregate aggregate
)
Public Function ZINTERSTORE (
    destinationKey As String,
    keyWeights As IDictionary(Of String, Integer),
    aggregate As RedisAggregate
) As Integer
public:
int ZINTERSTORE(
    String^ destinationKey,
    IDictionary<String^, int>^ keyWeights,
    RedisAggregate aggregate
)
member ZINTERSTORE :
        destinationKey : string *
        keyWeights : IDictionary<string, int> *
        aggregate : RedisAggregate -> int

Parameters

destinationKey
Type: SystemString
目标键
keyWeights
Type: System.Collections.GenericIDictionary String, Int32
键与乘法因子
aggregate
Type: AdfRedisAggregate
聚合方式

Return Value

Type: Int32
保存到 destination 的结果集的基数
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANGE Method

RedisSortedSetsZRANGE Method
返回给定的分值范围元素内容列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, string> ZRANGE(
    string key,
    int start,
    int stop
)
Public Function ZRANGE (
    key As String,
    start As Integer,
    stop As Integer
) As SortedList(Of Double, String)
public:
SortedList<double, String^>^ ZRANGE(
    String^ key,
    int start,
    int stop
)
member ZRANGE :
        key : string *
        start : int *
        stop : int -> SortedList<float, string>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGE(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZRANGE(System.String,System.Int32,System.Int32)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZRANGE(System.String,System.Int32,System.Int32)"]

Return Value

Type: SortedList Double, String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGE(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANGEBYSCORE Method

RedisSortedSetsZRANGEBYSCORE Method
返回给定的分值范围元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, string> ZRANGEBYSCORE(
    string key,
    double min,
    double max,
    int offset,
    int count
)
Public Function ZRANGEBYSCORE (
    key As String,
    min As Double,
    max As Double,
    offset As Integer,
    count As Integer
) As SortedList(Of Double, String)
public:
SortedList<double, String^>^ ZRANGEBYSCORE(
    String^ key,
    double min,
    double max,
    int offset,
    int count
)
member ZRANGEBYSCORE :
        key : string *
        min : float *
        max : float *
        offset : int *
        count : int -> SortedList<float, string>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: SortedList Double, String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANGEBYSCOREByte Method

RedisSortedSetsZRANGEBYSCOREByte Method
Overload List
 | Name | Description
Public method | ZRANGEBYSCOREByte(String, Double, Double, Int32, Int32) | 返回给定的分值范围元素列表
Public method | ZRANGEBYSCOREByte(String, Double, Double, Boolean, Int32, Int32) | 返回给定的分值范围元素列表
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANGEBYSCOREByte Method (String, Double, Double, Int32, Int32)

RedisSortedSetsZRANGEBYSCOREByte Method (String, Double, Double, Int32, Int32)
返回给定的分值范围元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, byte[]> ZRANGEBYSCOREByte(
    string key,
    double min,
    double max,
    int offset,
    int count
)
Public Function ZRANGEBYSCOREByte (
    key As String,
    min As Double,
    max As Double,
    offset As Integer,
    count As Integer
) As SortedList(Of Double, Byte())
public:
SortedList<double, array<unsigned char>^>^ ZRANGEBYSCOREByte(
    String^ key,
    double min,
    double max,
    int offset,
    int count
)
member ZRANGEBYSCOREByte :
        key : string *
        min : float *
        max : float *
        offset : int *
        count : int -> SortedList<float, byte[]>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: SortedList Double, Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class
ZRANGEBYSCOREByte Overload


RedisSortedSets.ZRANGEBYSCOREByte Method (String, Double, Double, Boolean, Int32, Int32)

RedisSortedSetsZRANGEBYSCOREByte Method (String, Double, Double, Boolean, Int32, Int32)
返回给定的分值范围元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] ZRANGEBYSCOREByte(
    string key,
    double min,
    double max,
    bool withscores,
    int offset,
    int count
)
Public Function ZRANGEBYSCOREByte (
    key As String,
    min As Double,
    max As Double,
    withscores As Boolean,
    offset As Integer,
    count As Integer
) As Byte()()
public:
array<array<unsigned char>^>^ ZRANGEBYSCOREByte(
    String^ key,
    double min,
    double max,
    bool withscores,
    int offset,
    int count
)
member ZRANGEBYSCOREByte :
        key : string *
        min : float *
        max : float *
        withscores : bool *
        offset : int *
        count : int -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

withscores
Type: SystemBoolean
是否返回分值
offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class
ZRANGEBYSCOREByte Overload


RedisSortedSets.ZRANGEBYSCOREValues Method

RedisSortedSetsZRANGEBYSCOREValues Method
返回给定的分值范围元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] ZRANGEBYSCOREValues(
    string key,
    double min,
    double max,
    int offset,
    int count
)
Public Function ZRANGEBYSCOREValues (
    key As String,
    min As Double,
    max As Double,
    offset As Integer,
    count As Integer
) As String()
public:
array<String^>^ ZRANGEBYSCOREValues(
    String^ key,
    double min,
    double max,
    int offset,
    int count
)
member ZRANGEBYSCOREValues :
        key : string *
        min : float *
        max : float *
        offset : int *
        count : int -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANGEByte Method

RedisSortedSetsZRANGEByte Method
Overload List
 | Name | Description
Public method | ZRANGEByte(String, Int32, Int32) | 返回给定的分值范围元素内容列表
Public method | ZRANGEByte(String, Int32, Int32, Boolean) | 返回给定的分值范围元素列表
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANGEByte Method (String, Int32, Int32)

RedisSortedSetsZRANGEByte Method (String, Int32, Int32)
返回给定的分值范围元素内容列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, byte[]> ZRANGEByte(
    string key,
    int start,
    int stop
)
Public Function ZRANGEByte (
    key As String,
    start As Integer,
    stop As Integer
) As SortedList(Of Double, Byte())
public:
SortedList<double, array<unsigned char>^>^ ZRANGEByte(
    String^ key,
    int start,
    int stop
)
member ZRANGEByte :
        key : string *
        start : int *
        stop : int -> SortedList<float, byte[]>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32)"]

Return Value

Type: SortedList Double, Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class
ZRANGEByte Overload


RedisSortedSets.ZRANGEByte Method (String, Int32, Int32, Boolean)

RedisSortedSetsZRANGEByte Method (String, Int32, Int32, Boolean)
返回给定的分值范围元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] ZRANGEByte(
    string key,
    int start,
    int stop,
    bool withscores
)
Public Function ZRANGEByte (
    key As String,
    start As Integer,
    stop As Integer,
    withscores As Boolean
) As Byte()()
public:
array<array<unsigned char>^>^ ZRANGEByte(
    String^ key,
    int start,
    int stop,
    bool withscores
)
member ZRANGEByte :
        key : string *
        start : int *
        stop : int *
        withscores : bool -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

withscores
Type: SystemBoolean
是否返回分值

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

RedisSortedSets Class
ZRANGEByte Overload


RedisSortedSets.ZRANGEValues Method

RedisSortedSetsZRANGEValues Method
返回给定的分值范围元素内容列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] ZRANGEValues(
    string key,
    int start,
    int stop
)
Public Function ZRANGEValues (
    key As String,
    start As Integer,
    stop As Integer
) As String()
public:
array<String^>^ ZRANGEValues(
    String^ key,
    int start,
    int stop
)
member ZRANGEValues :
        key : string *
        start : int *
        stop : int -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANGEValues(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZRANGEValues(System.String,System.Int32,System.Int32)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZRANGEValues(System.String,System.Int32,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANGEValues(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANK Method

RedisSortedSetsZRANK Method
Overload List
 | Name | Description
Public method | ZRANK(String, Byte) | 获取元素排名
Public method | ZRANK(String, String) | 获取元素排名
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZRANK Method (String, Byte[])

RedisSortedSetsZRANK Method (String, Byte)
获取元素排名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZRANK(
    string key,
    byte[] member
)
Public Function ZRANK (
    key As String,
    member As Byte()
) As Double
public:
double ZRANK(
    String^ key,
    array<unsigned char>^ member
)
member ZRANK :
        key : string *
        member : byte[] -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANK(System.String,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZRANK(System.String,System.Byte[])"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANK(System.String,System.Byte[])"]

See Also

Reference

RedisSortedSets Class
ZRANK Overload


RedisSortedSets.ZRANK Method (String, String)

RedisSortedSetsZRANK Method (String, String)
获取元素排名

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZRANK(
    string key,
    string member
)
Public Function ZRANK (
    key As String,
    member As String
) As Double
public:
double ZRANK(
    String^ key,
    String^ member
)
member ZRANK :
        key : string *
        member : string -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZRANK(System.String,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZRANK(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZRANK(System.String,System.String)"]

See Also

Reference

RedisSortedSets Class
ZRANK Overload


RedisSortedSets.ZREM Method

RedisSortedSetsZREM Method
Overload List
 | Name | Description
Public method | ZREM(String, Byte) | 删除元素
Public method | ZREM(String, String) | 删除元素
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREM Method (String, Byte[][])

RedisSortedSetsZREM Method (String, Byte)
删除元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZREM(
    string key,
    params byte[][] members
)
Public Function ZREM (
    key As String,
    ParamArray members As Byte()()
) As Integer
public:
int ZREM(
    String^ key,
    ... array<array<unsigned char>^>^ members
)
member ZREM :
        key : string *
        members : byte[][] -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREM(System.String,System.Byte[][])"]

members
Type: SystemByte

[Missing <param name="members"/> documentation for "M:Adf.RedisSortedSets.ZREM(System.String,System.Byte[][])"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREM(System.String,System.Byte[][])"]

See Also

Reference

RedisSortedSets Class
ZREM Overload


RedisSortedSets.ZREM Method (String, String[])

RedisSortedSetsZREM Method (String, String)
删除元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZREM(
    string key,
    params string[] members
)
Public Function ZREM (
    key As String,
    ParamArray members As String()
) As Integer
public:
int ZREM(
    String^ key,
    ... array<String^>^ members
)
member ZREM :
        key : string *
        members : string[] -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREM(System.String,System.String[])"]

members
Type: SystemString

[Missing <param name="members"/> documentation for "M:Adf.RedisSortedSets.ZREM(System.String,System.String[])"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREM(System.String,System.String[])"]

See Also

Reference

RedisSortedSets Class
ZREM Overload


RedisSortedSets.ZREMRANGEBYRANK Method

RedisSortedSetsZREMRANGEBYRANK Method
删除一个范围元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZREMRANGEBYRANK(
    string key,
    int start,
    int stop
)
Public Function ZREMRANGEBYRANK (
    key As String,
    start As Integer,
    stop As Integer
) As Integer
public:
int ZREMRANGEBYRANK(
    String^ key,
    int start,
    int stop
)
member ZREMRANGEBYRANK :
        key : string *
        start : int *
        stop : int -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYRANK(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYRANK(System.String,System.Int32,System.Int32)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYRANK(System.String,System.Int32,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYRANK(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREMRANGEBYSCORE Method

RedisSortedSetsZREMRANGEBYSCORE Method
删除一个积分范围元素

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZREMRANGEBYSCORE(
    string key,
    int min,
    int max
)
Public Function ZREMRANGEBYSCORE (
    key As String,
    min As Integer,
    max As Integer
) As Integer
public:
int ZREMRANGEBYSCORE(
    String^ key,
    int min,
    int max
)
member ZREMRANGEBYSCORE :
        key : string *
        min : int *
        max : int -> int

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYSCORE(System.String,System.Int32,System.Int32)"]

min
Type: SystemInt32

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYSCORE(System.String,System.Int32,System.Int32)"]

max
Type: SystemInt32

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYSCORE(System.String,System.Int32,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREMRANGEBYSCORE(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANGE Method

RedisSortedSetsZREVRANGE Method
返回给定的区间元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, string> ZREVRANGE(
    string key,
    int start,
    int stop
)
Public Function ZREVRANGE (
    key As String,
    start As Integer,
    stop As Integer
) As SortedList(Of Double, String)
public:
SortedList<double, String^>^ ZREVRANGE(
    String^ key,
    int start,
    int stop
)
member ZREVRANGE :
        key : string *
        start : int *
        stop : int -> SortedList<float, string>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGE(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGE(System.String,System.Int32,System.Int32)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGE(System.String,System.Int32,System.Int32)"]

Return Value

Type: SortedList Double, String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGE(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANGEBYSCORE Method

RedisSortedSetsZREVRANGEBYSCORE Method
返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, string> ZREVRANGEBYSCORE(
    string key,
    double min,
    double max,
    int offset,
    int count
)
Public Function ZREVRANGEBYSCORE (
    key As String,
    min As Double,
    max As Double,
    offset As Integer,
    count As Integer
) As SortedList(Of Double, String)
public:
SortedList<double, String^>^ ZREVRANGEBYSCORE(
    String^ key,
    double min,
    double max,
    int offset,
    int count
)
member ZREVRANGEBYSCORE :
        key : string *
        min : float *
        max : float *
        offset : int *
        count : int -> SortedList<float, string>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: SortedList Double, String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCORE(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANGEBYSCOREByte Method

RedisSortedSetsZREVRANGEBYSCOREByte Method
Overload List
 | Name | Description
Public method | ZREVRANGEBYSCOREByte(String, Double, Double, Int32, Int32) | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Public method | ZREVRANGEBYSCOREByte(String, Double, Double, Boolean, Int32, Int32) | 返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANGEBYSCOREByte Method (String, Double, Double, Int32, Int32)

RedisSortedSetsZREVRANGEBYSCOREByte Method (String, Double, Double, Int32, Int32)
返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, byte[]> ZREVRANGEBYSCOREByte(
    string key,
    double min,
    double max,
    int offset,
    int count
)
Public Function ZREVRANGEBYSCOREByte (
    key As String,
    min As Double,
    max As Double,
    offset As Integer,
    count As Integer
) As SortedList(Of Double, Byte())
public:
SortedList<double, array<unsigned char>^>^ ZREVRANGEBYSCOREByte(
    String^ key,
    double min,
    double max,
    int offset,
    int count
)
member ZREVRANGEBYSCOREByte :
        key : string *
        min : float *
        max : float *
        offset : int *
        count : int -> SortedList<float, byte[]>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: SortedList Double, Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class
ZREVRANGEBYSCOREByte Overload


RedisSortedSets.ZREVRANGEBYSCOREByte Method (String, Double, Double, Boolean, Int32, Int32)

RedisSortedSetsZREVRANGEBYSCOREByte Method (String, Double, Double, Boolean, Int32, Int32)
返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] ZREVRANGEBYSCOREByte(
    string key,
    double min,
    double max,
    bool withscores,
    int offset,
    int count
)
Public Function ZREVRANGEBYSCOREByte (
    key As String,
    min As Double,
    max As Double,
    withscores As Boolean,
    offset As Integer,
    count As Integer
) As Byte()()
public:
array<array<unsigned char>^>^ ZREVRANGEBYSCOREByte(
    String^ key,
    double min,
    double max,
    bool withscores,
    int offset,
    int count
)
member ZREVRANGEBYSCOREByte :
        key : string *
        min : float *
        max : float *
        withscores : bool *
        offset : int *
        count : int -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

withscores
Type: SystemBoolean
是否返回分值
offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREByte(System.String,System.Double,System.Double,System.Boolean,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class
ZREVRANGEBYSCOREByte Overload


RedisSortedSets.ZREVRANGEBYSCOREValues Method

RedisSortedSetsZREVRANGEBYSCOREValues Method
返回有序集 key 中， score 值介于 max 和 min 之间(默认包括等于 max 或 min )的所有的成员。有序集成员按 score 值递减(从大到小)的次序排列。 具有相同 score 值的成员按字典序的逆序(reverse lexicographical order )排列。 除了成员按 score 值递减的次序排列这一点外， ZREVRANGEBYSCORE 命令的其他方面和 ZRANGEBYSCORE 命令一样

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] ZREVRANGEBYSCOREValues(
    string key,
    double min,
    double max,
    int offset,
    int count
)
Public Function ZREVRANGEBYSCOREValues (
    key As String,
    min As Double,
    max As Double,
    offset As Integer,
    count As Integer
) As String()
public:
array<String^>^ ZREVRANGEBYSCOREValues(
    String^ key,
    double min,
    double max,
    int offset,
    int count
)
member ZREVRANGEBYSCOREValues :
        key : string *
        min : float *
        max : float *
        offset : int *
        count : int -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

min
Type: SystemDouble

[Missing <param name="min"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

max
Type: SystemDouble

[Missing <param name="max"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

offset
Type: SystemInt32
取出偏移量,需设置count有效
count
Type: SystemInt32
设置数量则offset有产效

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGEBYSCOREValues(System.String,System.Double,System.Double,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANGEByte Method

RedisSortedSetsZREVRANGEByte Method
Overload List
 | Name | Description
Public method | ZREVRANGEByte(String, Int32, Int32) | 返回给定的区间元素列表
Public method | ZREVRANGEByte(String, Int32, Int32, Boolean) | 返回给定的区间元素列表
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANGEByte Method (String, Int32, Int32)

RedisSortedSetsZREVRANGEByte Method (String, Int32, Int32)
返回给定的区间元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SortedList<double, byte[]> ZREVRANGEByte(
    string key,
    int start,
    int stop
)
Public Function ZREVRANGEByte (
    key As String,
    start As Integer,
    stop As Integer
) As SortedList(Of Double, Byte())
public:
SortedList<double, array<unsigned char>^>^ ZREVRANGEByte(
    String^ key,
    int start,
    int stop
)
member ZREVRANGEByte :
        key : string *
        start : int *
        stop : int -> SortedList<float, byte[]>

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32)"]

Return Value

Type: SortedList Double, Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class
ZREVRANGEByte Overload


RedisSortedSets.ZREVRANGEByte Method (String, Int32, Int32, Boolean)

RedisSortedSetsZREVRANGEByte Method (String, Int32, Int32, Boolean)
返回给定的区间元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[][] ZREVRANGEByte(
    string key,
    int start,
    int stop,
    bool withscores
)
Public Function ZREVRANGEByte (
    key As String,
    start As Integer,
    stop As Integer,
    withscores As Boolean
) As Byte()()
public:
array<array<unsigned char>^>^ ZREVRANGEByte(
    String^ key,
    int start,
    int stop,
    bool withscores
)
member ZREVRANGEByte :
        key : string *
        start : int *
        stop : int *
        withscores : bool -> byte[][]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

withscores
Type: SystemBoolean
是否返回分值

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGEByte(System.String,System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

RedisSortedSets Class
ZREVRANGEByte Overload


RedisSortedSets.ZREVRANGEValues Method

RedisSortedSetsZREVRANGEValues Method
返回给定的区间元素列表

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] ZREVRANGEValues(
    string key,
    int start,
    int stop
)
Public Function ZREVRANGEValues (
    key As String,
    start As Integer,
    stop As Integer
) As String()
public:
array<String^>^ ZREVRANGEValues(
    String^ key,
    int start,
    int stop
)
member ZREVRANGEValues :
        key : string *
        start : int *
        stop : int -> string[]

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEValues(System.String,System.Int32,System.Int32)"]

start
Type: SystemInt32

[Missing <param name="start"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEValues(System.String,System.Int32,System.Int32)"]

stop
Type: SystemInt32

[Missing <param name="stop"/> documentation for "M:Adf.RedisSortedSets.ZREVRANGEValues(System.String,System.Int32,System.Int32)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANGEValues(System.String,System.Int32,System.Int32)"]

See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANK Method

RedisSortedSetsZREVRANK Method
Overload List
 | Name | Description
Public method | ZREVRANK(String, Byte) | 返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。
Public method | ZREVRANK(String, String) | 返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZREVRANK Method (String, Byte[])

RedisSortedSetsZREVRANK Method (String, Byte)
返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZREVRANK(
    string key,
    byte[] member
)
Public Function ZREVRANK (
    key As String,
    member As Byte()
) As Double
public:
double ZREVRANK(
    String^ key,
    array<unsigned char>^ member
)
member ZREVRANK :
        key : string *
        member : byte[] -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANK(System.String,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZREVRANK(System.String,System.Byte[])"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANK(System.String,System.Byte[])"]

See Also

Reference

RedisSortedSets Class
ZREVRANK Overload


RedisSortedSets.ZREVRANK Method (String, String)

RedisSortedSetsZREVRANK Method (String, String)
返回有序集 key 中成员 member 的排名。其中有序集成员按 score 值递减(从大到小)排序。 排名以 0 为底，也就是说， score 值最大的成员排名为 0 。 使用 ZRANK 命令可以获得成员按 score 值递增(从小到大)排列的排名。

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZREVRANK(
    string key,
    string member
)
Public Function ZREVRANK (
    key As String,
    member As String
) As Double
public:
double ZREVRANK(
    String^ key,
    String^ member
)
member ZREVRANK :
        key : string *
        member : string -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZREVRANK(System.String,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZREVRANK(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZREVRANK(System.String,System.String)"]

See Also

Reference

RedisSortedSets Class
ZREVRANK Overload


RedisSortedSets.ZSCORE Method

RedisSortedSetsZSCORE Method
Overload List
 | Name | Description
Public method | ZSCORE(String, Byte) | 返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。
Public method | ZSCORE(String, String) | 返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。
Top
See Also

Reference

RedisSortedSets Class


RedisSortedSets.ZSCORE Method (String, Byte[])

RedisSortedSetsZSCORE Method (String, Byte)
返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZSCORE(
    string key,
    byte[] member
)
Public Function ZSCORE (
    key As String,
    member As Byte()
) As Double
public:
double ZSCORE(
    String^ key,
    array<unsigned char>^ member
)
member ZSCORE :
        key : string *
        member : byte[] -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZSCORE(System.String,System.Byte[])"]

member
Type: SystemByte

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZSCORE(System.String,System.Byte[])"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZSCORE(System.String,System.Byte[])"]

See Also

Reference

RedisSortedSets Class
ZSCORE Overload


RedisSortedSets.ZSCORE Method (String, String)

RedisSortedSetsZSCORE Method (String, String)
返回有序集 key 中，成员 member 的 score 值。如果 member 元素不是有序集 key 的成员，或 key 不存在，返回 nil 。

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double ZSCORE(
    string key,
    string member
)
Public Function ZSCORE (
    key As String,
    member As String
) As Double
public:
double ZSCORE(
    String^ key,
    String^ member
)
member ZSCORE :
        key : string *
        member : string -> float

Parameters

key
Type: SystemString

[Missing <param name="key"/> documentation for "M:Adf.RedisSortedSets.ZSCORE(System.String,System.String)"]

member
Type: SystemString

[Missing <param name="member"/> documentation for "M:Adf.RedisSortedSets.ZSCORE(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.RedisSortedSets.ZSCORE(System.String,System.String)"]

See Also

Reference

RedisSortedSets Class
ZSCORE Overload


RedisSortedSets.ZUNIONSTORE Method

RedisSortedSetsZUNIONSTORE Method
计算给定的一个或多个有序集的并集，其中给定 key 的数量必须以 numkeys 参数指定，并将该并集(结果集)储存到 destination 。 默认情况下，结果集中某个成员的 score 值是所有给定集下该成员 score 值之 和 。

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int ZUNIONSTORE(
    string destinationKey,
    IDictionary<string, int> keyWeights,
    RedisAggregate aggregate
)
Public Function ZUNIONSTORE (
    destinationKey As String,
    keyWeights As IDictionary(Of String, Integer),
    aggregate As RedisAggregate
) As Integer
public:
int ZUNIONSTORE(
    String^ destinationKey,
    IDictionary<String^, int>^ keyWeights,
    RedisAggregate aggregate
)
member ZUNIONSTORE :
        destinationKey : string *
        keyWeights : IDictionary<string, int> *
        aggregate : RedisAggregate -> int

Parameters

destinationKey
Type: SystemString
目标键
keyWeights
Type: System.Collections.GenericIDictionary String, Int32
键与乘法因子
aggregate
Type: AdfRedisAggregate
聚合方式

Return Value

Type: Int32
保存到 destination 的结果集的基数
See Also

Reference

RedisSortedSets Class


RedisWriter Class

RedisWriter Class
命令写入工具
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
System.IOMemoryStream
AdfRedisWriter

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RedisWriter : MemoryStream
Public Class RedisWriter
    Inherits MemoryStream
public ref class RedisWriter : public MemoryStream
type RedisWriter =
    class
        inherit MemoryStream
    end

The RedisWriter type exposes the following members.

Constructors
 | Name | Description
Public method | RedisWriter | 初始化新实例
Top
Methods
 | Name | Description
Public method | BeginRead | 开始异步读操作。 (Inherited from Stream.)
Public method | BeginWrite | 开始异步写操作。 (Inherited from Stream.)
Public method | Close | 关闭当前流并释放与之关联的所有资源（如套接字和文件句柄）。 (Inherited from Stream.)
Public method | CreateObjRef | 创建一个对象，该对象包含生成用于与远程对象进行通信的代理所需的全部相关信息。 (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. 分配 WaitHandle 对象。 (Inherited from Stream.)
Public method | Dispose | 释放由 Stream 使用的所有资源。 (Inherited from Stream.)
Protected method | Dispose(Boolean) | 释放 MemoryStream 类使用的非托管资源，并可以选择释放托管资源。 (Inherited from MemoryStream.)
Public method | EndRead | 等待挂起的异步读取完成。 (Inherited from Stream.)
Public method | EndWrite | 结束异步写操作。 (Inherited from Stream.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 重写 Flush 以便不执行任何操作。 (Inherited from MemoryStream.)
Public method | GetBuffer | 返回从其创建此流的无符号字节数组。 (Inherited from MemoryStream.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetLifetimeService | 检索控制此实例的生存期策略的当前生存期服务对象。 (Inherited from MarshalByRefObject.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InitializeLifetimeService | 获取控制此实例的生存期策略的生存期服务对象。 (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | 创建当前 MarshalByRefObject 对象的浅表副本。 (Inherited from MarshalByRefObject.)
Public method | Read | 从当前流中读取字节块并将数据写入 buffer 中。 (Inherited from MemoryStream.)
Public method | ReadByte | 从当前流中读取一个字节。 (Inherited from MemoryStream.)
Public method | Seek | 将当前流中的位置设置为指定值。 (Inherited from MemoryStream.)
Public method | SetLength | 将当前流的长度设为指定值。 (Inherited from MemoryStream.)
Public method | ToArray | 将流内容写入字节数组，而与 Position 属性无关。 (Inherited from MemoryStream.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write | 使用从缓冲区读取的数据将字节块写入当前流。 (Inherited from MemoryStream.)
Public method | WriteByte | 将一个字节写入当前流中的当前位置。 (Inherited from MemoryStream.)
Public method | WriteData | 写入数据
Public method | WriteTo | 将此内存流的整个内容写入另一个流中。 (Inherited from MemoryStream.)
Top
Properties
 | Name | Description
Public property | CanRead | 获取一个值，该值指示当前流是否支持读取。 (Inherited from MemoryStream.)
Public property | CanSeek | 获取一个值，该值指示当前流是否支持查找。 (Inherited from MemoryStream.)
Public property | CanTimeout | 获取一个值，该值确定当前流是否可以超时。 (Inherited from Stream.)
Public property | CanWrite | 获取一个值，该值指示当前流是否支持写入。 (Inherited from MemoryStream.)
Public property | Capacity | 获取或设置分配给该流的字节数。 (Inherited from MemoryStream.)
Public property | Length | 获取用字节表示的流长度。 (Inherited from MemoryStream.)
Public property | Position | 获取或设置流中的当前位置。 (Inherited from MemoryStream.)
Public property | ReadTimeout | 获取或设置一个值（以毫秒为单位），该值确定流在超时前尝试读取多长时间。 (Inherited from Stream.)
Public property | WriteTimeout | 获取或设置一个值（以毫秒为单位），该值确定流在超时前尝试写入多长时间。 (Inherited from Stream.)
Top
See Also

Reference


RedisWriter Constructor

RedisWriter Constructor
初始化新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RedisWriter(
    RedisClient client,
    string command,
    params Object[] commandArgs
)
Public Sub New (
    client As RedisClient,
    command As String,
    ParamArray commandArgs As Object()
)
public:
RedisWriter(
    RedisClient^ client,
    String^ command,
    ... array<Object^>^ commandArgs
)
new :
        client : RedisClient *
        command : string *
        commandArgs : Object[] -> RedisWriter

Parameters

client
Type: AdfRedisClient

[Missing <param name="client"/> documentation for "M:Adf.RedisWriter.#ctor(Adf.RedisClient,System.String,System.Object[])"]

command
Type: SystemString

[Missing <param name="command"/> documentation for "M:Adf.RedisWriter.#ctor(Adf.RedisClient,System.String,System.Object[])"]

commandArgs
Type: SystemObject

[Missing <param name="commandArgs"/> documentation for "M:Adf.RedisWriter.#ctor(Adf.RedisClient,System.String,System.Object[])"]

See Also

Reference

RedisWriter Class


RedisWriter Methods

RedisWriter Methods

The RedisWriter type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | 开始异步读操作。 (Inherited from Stream.)
Public method | BeginWrite | 开始异步写操作。 (Inherited from Stream.)
Public method | Close | 关闭当前流并释放与之关联的所有资源（如套接字和文件句柄）。 (Inherited from Stream.)
Public method | CreateObjRef | 创建一个对象，该对象包含生成用于与远程对象进行通信的代理所需的全部相关信息。 (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. 分配 WaitHandle 对象。 (Inherited from Stream.)
Public method | Dispose | 释放由 Stream 使用的所有资源。 (Inherited from Stream.)
Protected method | Dispose(Boolean) | 释放 MemoryStream 类使用的非托管资源，并可以选择释放托管资源。 (Inherited from MemoryStream.)
Public method | EndRead | 等待挂起的异步读取完成。 (Inherited from Stream.)
Public method | EndWrite | 结束异步写操作。 (Inherited from Stream.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 重写 Flush 以便不执行任何操作。 (Inherited from MemoryStream.)
Public method | GetBuffer | 返回从其创建此流的无符号字节数组。 (Inherited from MemoryStream.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetLifetimeService | 检索控制此实例的生存期策略的当前生存期服务对象。 (Inherited from MarshalByRefObject.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InitializeLifetimeService | 获取控制此实例的生存期策略的生存期服务对象。 (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | 创建当前 MarshalByRefObject 对象的浅表副本。 (Inherited from MarshalByRefObject.)
Public method | Read | 从当前流中读取字节块并将数据写入 buffer 中。 (Inherited from MemoryStream.)
Public method | ReadByte | 从当前流中读取一个字节。 (Inherited from MemoryStream.)
Public method | Seek | 将当前流中的位置设置为指定值。 (Inherited from MemoryStream.)
Public method | SetLength | 将当前流的长度设为指定值。 (Inherited from MemoryStream.)
Public method | ToArray | 将流内容写入字节数组，而与 Position 属性无关。 (Inherited from MemoryStream.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Write | 使用从缓冲区读取的数据将字节块写入当前流。 (Inherited from MemoryStream.)
Public method | WriteByte | 将一个字节写入当前流中的当前位置。 (Inherited from MemoryStream.)
Public method | WriteData | 写入数据
Public method | WriteTo | 将此内存流的整个内容写入另一个流中。 (Inherited from MemoryStream.)
Top
See Also

Reference

RedisWriter Class


RedisWriter.WriteData Method

RedisWriterWriteData Method
写入数据

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void WriteData(
    byte[] data
)
Public Sub WriteData (
    data As Byte()
)
public:
void WriteData(
    array<unsigned char>^ data
)
member WriteData :
        data : byte[] -> unit

Parameters

data
Type: SystemByte

[Missing <param name="data"/> documentation for "M:Adf.RedisWriter.WriteData(System.Byte[])"]

See Also

Reference

RedisWriter Class


RedisWriter Properties

RedisWriter Properties

The RedisWriter type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | 获取一个值，该值指示当前流是否支持读取。 (Inherited from MemoryStream.)
Public property | CanSeek | 获取一个值，该值指示当前流是否支持查找。 (Inherited from MemoryStream.)
Public property | CanTimeout | 获取一个值，该值确定当前流是否可以超时。 (Inherited from Stream.)
Public property | CanWrite | 获取一个值，该值指示当前流是否支持写入。 (Inherited from MemoryStream.)
Public property | Capacity | 获取或设置分配给该流的字节数。 (Inherited from MemoryStream.)
Public property | Length | 获取用字节表示的流长度。 (Inherited from MemoryStream.)
Public property | Position | 获取或设置流中的当前位置。 (Inherited from MemoryStream.)
Public property | ReadTimeout | 获取或设置一个值（以毫秒为单位），该值确定流在超时前尝试读取多长时间。 (Inherited from Stream.)
Public property | WriteTimeout | 获取或设置一个值（以毫秒为单位），该值确定流在超时前尝试写入多长时间。 (Inherited from Stream.)
Top
See Also

Reference

RedisWriter Class


Regular Class

Regular Class
常规正常表达式
Inheritance Hierarchy
SystemObject
AdfRegular

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class Regular
Public NotInheritable Class Regular
public ref class Regular abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Regular =  class end

The Regular type exposes the following members.

Fields
Name | Description
HAS_CHINESESTRING | has chinese language
HAS_EMAIL | has email
HAS_IPV4 | has ipv4
HAS_IPV6 | has ipv6
IS_CHINESESTRING | has mobile of china
IS_EMAIL | is email
IS_IPV4 | is ipv4
IS_IPV6 | is ipv6
IS_MOBILEOFCHINA | is mobile of china
IS_NORMAL | is normal chr
IS_NUMBER | is all number
IS_NUMBERORFLOAT | is number or float number
IS_PHONEOFCHINA | is phone of china
IS_POSTCODEOFCHINA | is post code of china
Top
See Also

Reference


Regular Fields

Regular Fields

The Regular type exposes the following members.

Fields
Name | Description
HAS_CHINESESTRING | has chinese language
HAS_EMAIL | has email
HAS_IPV4 | has ipv4
HAS_IPV6 | has ipv6
IS_CHINESESTRING | has mobile of china
IS_EMAIL | is email
IS_IPV4 | is ipv4
IS_IPV6 | is ipv6
IS_MOBILEOFCHINA | is mobile of china
IS_NORMAL | is normal chr
IS_NUMBER | is all number
IS_NUMBERORFLOAT | is number or float number
IS_PHONEOFCHINA | is phone of china
IS_POSTCODEOFCHINA | is post code of china
Top
See Also

Reference

Regular Class


Regular.HAS_CHINESESTRING Field

RegularHAS_CHINESESTRING Field
has chinese language

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex HAS_CHINESESTRING
Public Shared ReadOnly HAS_CHINESESTRING As Regex
public:
static initonly Regex^ HAS_CHINESESTRING
static val HAS_CHINESESTRING: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.HAS_EMAIL Field

RegularHAS_EMAIL Field
has email

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex HAS_EMAIL
Public Shared ReadOnly HAS_EMAIL As Regex
public:
static initonly Regex^ HAS_EMAIL
static val HAS_EMAIL: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.HAS_IPV4 Field

RegularHAS_IPV4 Field
has ipv4

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex HAS_IPV4
Public Shared ReadOnly HAS_IPV4 As Regex
public:
static initonly Regex^ HAS_IPV4
static val HAS_IPV4: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.HAS_IPV6 Field

RegularHAS_IPV6 Field
has ipv6

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex HAS_IPV6
Public Shared ReadOnly HAS_IPV6 As Regex
public:
static initonly Regex^ HAS_IPV6
static val HAS_IPV6: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_CHINESESTRING Field

RegularIS_CHINESESTRING Field
has mobile of china

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_CHINESESTRING
Public Shared ReadOnly IS_CHINESESTRING As Regex
public:
static initonly Regex^ IS_CHINESESTRING
static val IS_CHINESESTRING: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_EMAIL Field

RegularIS_EMAIL Field
is email

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_EMAIL
Public Shared ReadOnly IS_EMAIL As Regex
public:
static initonly Regex^ IS_EMAIL
static val IS_EMAIL: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_IPV4 Field

RegularIS_IPV4 Field
is ipv4

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_IPV4
Public Shared ReadOnly IS_IPV4 As Regex
public:
static initonly Regex^ IS_IPV4
static val IS_IPV4: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_IPV6 Field

RegularIS_IPV6 Field
is ipv6

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_IPV6
Public Shared ReadOnly IS_IPV6 As Regex
public:
static initonly Regex^ IS_IPV6
static val IS_IPV6: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_MOBILEOFCHINA Field

RegularIS_MOBILEOFCHINA Field
is mobile of china

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_MOBILEOFCHINA
Public Shared ReadOnly IS_MOBILEOFCHINA As Regex
public:
static initonly Regex^ IS_MOBILEOFCHINA
static val IS_MOBILEOFCHINA: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_NORMAL Field

RegularIS_NORMAL Field
is normal chr

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_NORMAL
Public Shared ReadOnly IS_NORMAL As Regex
public:
static initonly Regex^ IS_NORMAL
static val IS_NORMAL: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_NUMBER Field

RegularIS_NUMBER Field
is all number

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_NUMBER
Public Shared ReadOnly IS_NUMBER As Regex
public:
static initonly Regex^ IS_NUMBER
static val IS_NUMBER: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_NUMBERORFLOAT Field

RegularIS_NUMBERORFLOAT Field
is number or float number

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_NUMBERORFLOAT
Public Shared ReadOnly IS_NUMBERORFLOAT As Regex
public:
static initonly Regex^ IS_NUMBERORFLOAT
static val IS_NUMBERORFLOAT: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_PHONEOFCHINA Field

RegularIS_PHONEOFCHINA Field
is phone of china

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_PHONEOFCHINA
Public Shared ReadOnly IS_PHONEOFCHINA As Regex
public:
static initonly Regex^ IS_PHONEOFCHINA
static val IS_PHONEOFCHINA: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


Regular.IS_POSTCODEOFCHINA Field

RegularIS_POSTCODEOFCHINA Field
is post code of china

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Regex IS_POSTCODEOFCHINA
Public Shared ReadOnly IS_POSTCODEOFCHINA As Regex
public:
static initonly Regex^ IS_POSTCODEOFCHINA
static val IS_POSTCODEOFCHINA: Regex

Field Value

Type: Regex
See Also

Reference

Regular Class


ResourceHelper Class

ResourceHelper Class
资源助手
Inheritance Hierarchy
SystemObject
AdfResourceHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class ResourceHelper
Public NotInheritable Class ResourceHelper
public ref class ResourceHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ResourceHelper =  class end
Methods
Name | Description
GetBytes(String) | 获取当前程序集资源字节数组
GetBytes(String, Assembly) | 获取当前程序集资源字节数组
GetText(String) | 获取当前程序集文本资源
GetText(String, Assembly) | 获取指定程序集文本资源
Top
See Also

Reference


ResourceHelper Methods

ResourceHelper Methods
Methods
Name | Description
GetBytes(String) | 获取当前程序集资源字节数组
GetBytes(String, Assembly) | 获取当前程序集资源字节数组
GetText(String) | 获取当前程序集文本资源
GetText(String, Assembly) | 获取指定程序集文本资源
Top
See Also

Reference

ResourceHelper Class


ResourceHelper.GetBytes Method

ResourceHelperGetBytes Method
Overload List
Name | Description
GetBytes(String) | 获取当前程序集资源字节数组
GetBytes(String, Assembly) | 获取当前程序集资源字节数组
Top
See Also

Reference

ResourceHelper Class


ResourceHelper.GetBytes Method (String)

ResourceHelperGetBytes Method (String)
获取当前程序集资源字节数组

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] GetBytes(
    string name
)
Public Shared Function GetBytes (
    name As String
) As Byte()
public:
static array<unsigned char>^ GetBytes(
    String^ name
)
static member GetBytes :
        name : string -> byte[]

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.ResourceHelper.GetBytes(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.ResourceHelper.GetBytes(System.String)"]

See Also

Reference

ResourceHelper Class
GetBytes Overload


ResourceHelper.GetBytes Method (String, Assembly)

ResourceHelperGetBytes Method (String, Assembly)
获取当前程序集资源字节数组

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] GetBytes(
    string name,
    Assembly assembly
)
Public Shared Function GetBytes (
    name As String,
    assembly As Assembly
) As Byte()
public:
static array<unsigned char>^ GetBytes(
    String^ name,
    Assembly^ assembly
)
static member GetBytes :
        name : string *
        assembly : Assembly -> byte[]

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.ResourceHelper.GetBytes(System.String,System.Reflection.Assembly)"]

assembly
Type: System.ReflectionAssembly

[Missing <param name="assembly"/> documentation for "M:Adf.ResourceHelper.GetBytes(System.String,System.Reflection.Assembly)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.ResourceHelper.GetBytes(System.String,System.Reflection.Assembly)"]

See Also

Reference

ResourceHelper Class
GetBytes Overload


ResourceHelper.GetText Method

ResourceHelperGetText Method
Overload List
Name | Description
GetText(String) | 获取当前程序集文本资源
GetText(String, Assembly) | 获取指定程序集文本资源
Top
See Also

Reference

ResourceHelper Class


ResourceHelper.GetText Method (String)

ResourceHelperGetText Method (String)
获取当前程序集文本资源

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string GetText(
    string name
)
Public Shared Function GetText (
    name As String
) As String
public:
static String^ GetText(
    String^ name
)
static member GetText :
        name : string -> string

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.ResourceHelper.GetText(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ResourceHelper.GetText(System.String)"]

See Also

Reference

ResourceHelper Class
GetText Overload


ResourceHelper.GetText Method (String, Assembly)

ResourceHelperGetText Method (String, Assembly)
获取指定程序集文本资源

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string GetText(
    string name,
    Assembly assembly
)
Public Shared Function GetText (
    name As String,
    assembly As Assembly
) As String
public:
static String^ GetText(
    String^ name,
    Assembly^ assembly
)
static member GetText :
        name : string *
        assembly : Assembly -> string

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.ResourceHelper.GetText(System.String,System.Reflection.Assembly)"]

assembly
Type: System.ReflectionAssembly

[Missing <param name="assembly"/> documentation for "M:Adf.ResourceHelper.GetText(System.String,System.Reflection.Assembly)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.ResourceHelper.GetText(System.String,System.Reflection.Assembly)"]

See Also

Reference

ResourceHelper Class
GetText Overload


RetryAction Delegate

RetryAction Delegate
Retry Action

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public delegate void RetryAction()
Public Delegate Sub RetryAction
public delegate void RetryAction()
type RetryAction =
    delegate of unit -> unit
See Also

Reference


RetryHelper Class

RetryHelper Class
Retry Helper
Inheritance Hierarchy
SystemObject
AdfRetryHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class RetryHelper
Public NotInheritable Class RetryHelper
public ref class RetryHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type RetryHelper =  class end

The RetryHelper type exposes the following members.

Methods
Name | Description
Retry | Retry
Top
See Also

Reference


RetryHelper Methods

RetryHelper Methods

The RetryHelper type exposes the following members.

Methods
Name | Description
Retry | Retry
Top
See Also

Reference

RetryHelper Class


RetryHelper.Retry Method

RetryHelperRetry Method
Retry

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void Retry(
    int retryCount,
    TimeSpan interval,
    bool throwIfFail,
    RetryAction action
)
Public Shared Sub Retry (
    retryCount As Integer,
    interval As TimeSpan,
    throwIfFail As Boolean,
    action As RetryAction
)
public:
static void Retry(
    int retryCount,
    TimeSpan interval,
    bool throwIfFail,
    RetryAction^ action
)
static member Retry :
        retryCount : int *
        interval : TimeSpan *
        throwIfFail : bool *
        action : RetryAction -> unit

Parameters

retryCount
Type: SystemInt32

[Missing <param name="retryCount"/> documentation for "M:Adf.RetryHelper.Retry(System.Int32,System.TimeSpan,System.Boolean,Adf.RetryAction)"]

interval
Type: SystemTimeSpan

[Missing <param name="interval"/> documentation for "M:Adf.RetryHelper.Retry(System.Int32,System.TimeSpan,System.Boolean,Adf.RetryAction)"]

throwIfFail
Type: SystemBoolean

[Missing <param name="throwIfFail"/> documentation for "M:Adf.RetryHelper.Retry(System.Int32,System.TimeSpan,System.Boolean,Adf.RetryAction)"]

action
Type: AdfRetryAction

[Missing <param name="action"/> documentation for "M:Adf.RetryHelper.Retry(System.Int32,System.TimeSpan,System.Boolean,Adf.RetryAction)"]

See Also

Reference

RetryHelper Class


SerializeHelper Class

SerializeHelper Class
序列化数据处理
Inheritance Hierarchy
SystemObject
AdfSerializeHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class SerializeHelper
Public Class SerializeHelper
public ref class SerializeHelper
type SerializeHelper =  class end

The SerializeHelper type exposes the following members.

Constructors
 | Name | Description
Public method | SerializeHelper | Initializes a new instance of the SerializeHelper class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetSerialize | 读取一个序列数据，文件不存在则返回为null
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetXmlSerializeT | 读取一个序列数据，文件不存在则返回为null
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | SetSerialize | 设置一个序列数据
 | SetXmlSerialize | 设置一个序列数据
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference


SerializeHelper Constructor

SerializeHelper Constructor
Initializes a new instance of the SerializeHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SerializeHelper()
Public Sub New
public:
SerializeHelper()
new : unit -> SerializeHelper
See Also

Reference

SerializeHelper Class


SerializeHelper Methods

SerializeHelper Methods

The SerializeHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetSerialize | 读取一个序列数据，文件不存在则返回为null
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetXmlSerializeT | 读取一个序列数据，文件不存在则返回为null
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | SetSerialize | 设置一个序列数据
 | SetXmlSerialize | 设置一个序列数据
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

SerializeHelper Class


SerializeHelper.GetSerialize Method

SerializeHelperGetSerialize Method
读取一个序列数据，文件不存在则返回为null

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Object GetSerialize(
    string path
)
Public Shared Function GetSerialize (
    path As String
) As Object
public:
static Object^ GetSerialize(
    String^ path
)
static member GetSerialize :
        path : string -> Object

Parameters

path
Type: SystemString
路径

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.SerializeHelper.GetSerialize(System.String)"]

See Also

Reference

SerializeHelper Class


SerializeHelper.GetXmlSerialize(T) Method

SerializeHelperGetXmlSerializeT Method
读取一个序列数据，文件不存在则返回为null

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static T GetXmlSerialize<T>(
    string path
)

Public Shared Function GetXmlSerialize(Of T) (
    path As String
) As T
public:
generic<typename T>
static T GetXmlSerialize(
    String^ path
)
static member GetXmlSerialize :
        path : string -> 'T

Parameters

path
Type: SystemString
路径

Type Parameters

T
要序列化的类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.SerializeHelper.GetXmlSerialize``1(System.String)"]

See Also

Reference

SerializeHelper Class


SerializeHelper.SetSerialize Method

SerializeHelperSetSerialize Method
设置一个序列数据

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void SetSerialize(
    string path,
    Object data
)
Public Shared Sub SetSerialize (
    path As String,
    data As Object
)
public:
static void SetSerialize(
    String^ path,
    Object^ data
)
static member SetSerialize :
        path : string *
        data : Object -> unit

Parameters

path
Type: SystemString
路径
data
Type: SystemObject
数据

Return Value

Type:
是否成功
See Also

Reference

SerializeHelper Class


SerializeHelper.SetXmlSerialize Method

SerializeHelperSetXmlSerialize Method
设置一个序列数据

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void SetXmlSerialize(
    string path,
    Object data
)
Public Shared Sub SetXmlSerialize (
    path As String,
    data As Object
)
public:
static void SetXmlSerialize(
    String^ path,
    Object^ data
)
static member SetXmlSerialize :
        path : string *
        data : Object -> unit

Parameters

path
Type: SystemString
路径
data
Type: SystemObject
数据

Return Value

Type:
是否成功
See Also

Reference

SerializeHelper Class


Singleton(T) Class

SingletonT Class
单例
Inheritance Hierarchy
SystemObject
AdfSingletonT

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Singleton<T>
where T : new()

Public Class Singleton(Of T As New)
generic<typename T>
where T : gcnew()
public ref class Singleton
type Singleton<'T when 'T : new()> =  class end

Type Parameters

T

The SingletonT type exposes the following members.

Constructors
 | Name | Description
Public method | SingletonT | Initializes a new instance of the SingletonT class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Fields
Name | Description
Instance | 实例
Top
See Also

Reference


Singleton(T) Constructor

SingletonT Constructor
Initializes a new instance of the SingletonT class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Singleton()
Public Sub New
public:
Singleton()
new : unit -> Singleton
See Also

Reference

SingletonT Class


Singleton(T) Fields

SingletonT Fields

The SingletonT generic type exposes the following members.

Fields
Name | Description
Instance | 实例
Top
See Also

Reference

SingletonT Class


Singleton(T).Instance Field

SingletonTInstance Field
实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly T Instance
Public Shared ReadOnly Instance As T
public:
static initonly T Instance
static val Instance: 'T

Field Value

Type: T
See Also

Reference

SingletonT Class


Singleton(T) Methods

SingletonT Methods

The SingletonT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

SingletonT Class


Smtp Class

Smtp Class
Smtp Helper
Inheritance Hierarchy
SystemObject
AdfSmtp

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Smtp : ISmtp
Public Class Smtp
    Implements ISmtp
public ref class Smtp : ISmtp
type Smtp =
    class
        interface ISmtp
    end

The Smtp type exposes the following members.

Constructors
 | Name | Description
Public method | Smtp | 初始一个新实例
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetSenderAddress | 获取根据规则处理后的发送者地址
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | InitConfig | 初始化配置
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Send | 发送邮件
 | SendNoPorxy | 无代理发送（暂不支持一个Message多域发送）
Public method | SetSenderRandom | 设置发送者随机域
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Fields
Name | Description
Instance | 默认实例
Top
Properties
 | Name | Description
Public property | Account | Account ,config:SmtpAccount
Public property | Enabled | 是否可用,config:SmtpEnabled
Public property | Host | host, config:SmtpHost
Public property | IsSenderRandom | 发送者地址是否随机
Public property | Name | Sender Name ,config: SmtpName
Public property | Password | Password, config:SmtpPassword
Public property | Port | port, config:SmtpPort
Public property | Sender | Sender, config:SmtpSender
Public property | SenderRandomDomain | 发送者地址随机域名,config:SmtpSenderRandomDomain
Top
Remarks
Smtp配置, 可配置于应用配置或GlobalConfig, 应用配置优先于GlobalConfig
See Also

Reference


Smtp Constructor

Smtp Constructor
初始一个新实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Smtp()
Public Sub New
public:
Smtp()
new : unit -> Smtp
See Also

Reference

Smtp Class


Smtp Fields

Smtp Fields

The Smtp type exposes the following members.

Fields
Name | Description
Instance | 默认实例
Top
See Also

Reference

Smtp Class


Smtp.Instance Field

SmtpInstance Field
默认实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly Smtp Instance
Public Shared ReadOnly Instance As Smtp
public:
static initonly Smtp^ Instance
static val Instance: Smtp

Field Value

Type: Smtp
See Also

Reference

Smtp Class


Smtp Methods

Smtp Methods

The Smtp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetSenderAddress | 获取根据规则处理后的发送者地址
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | InitConfig | 初始化配置
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Send | 发送邮件
 | SendNoPorxy | 无代理发送（暂不支持一个Message多域发送）
Public method | SetSenderRandom | 设置发送者随机域
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Smtp Class


Smtp.GetSenderAddress Method

SmtpGetSenderAddress Method
获取根据规则处理后的发送者地址

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string GetSenderAddress()
Public Function GetSenderAddress As String
public:
String^ GetSenderAddress()
member GetSenderAddress : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Smtp.GetSenderAddress"]

See Also

Reference

Smtp Class


Smtp.InitConfig Method

SmtpInitConfig Method
初始化配置

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void InitConfig()
Protected Overridable Sub InitConfig
protected:
virtual void InitConfig()
abstract InitConfig : unit -> unit
override InitConfig : unit -> unit
See Also

Reference

Smtp Class


Smtp.Send Method

SmtpSend Method
发送邮件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Send(
    MailMessage message
)
Public Overridable Sub Send (
    message As MailMessage
)
public:
virtual void Send(
    MailMessage^ message
)
abstract Send :
        message : MailMessage -> unit
override Send :
        message : MailMessage -> unit

Parameters

message
Type: System.Net.MailMailMessage
消息体，若未填充From属性，则将以配置填充

Return Value

Type:

Implements

ISmtpSend(MailMessage)
See Also

Reference

Smtp Class


Smtp.SendNoPorxy Method

SmtpSendNoPorxy Method
无代理发送（暂不支持一个Message多域发送）

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void SendNoPorxy(
    MailMessage message
)
Public Shared Sub SendNoPorxy (
    message As MailMessage
)
public:
static void SendNoPorxy(
    MailMessage^ message
)
static member SendNoPorxy :
        message : MailMessage -> unit

Parameters

message
Type: System.Net.MailMailMessage

[Missing <param name="message"/> documentation for "M:Adf.Smtp.SendNoPorxy(System.Net.Mail.MailMessage)"]

See Also

Reference

Smtp Class


Smtp.SetSenderRandom Method

SmtpSetSenderRandom Method
设置发送者随机域

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void SetSenderRandom(
    string domain
)
Public Sub SetSenderRandom (
    domain As String
)
public:
void SetSenderRandom(
    String^ domain
)
member SetSenderRandom :
        domain : string -> unit

Parameters

domain
Type: SystemString

[Missing <param name="domain"/> documentation for "M:Adf.Smtp.SetSenderRandom(System.String)"]

See Also

Reference

Smtp Class


Smtp Properties

Smtp Properties

The Smtp type exposes the following members.

Properties
 | Name | Description
Public property | Account | Account ,config:SmtpAccount
Public property | Enabled | 是否可用,config:SmtpEnabled
Public property | Host | host, config:SmtpHost
Public property | IsSenderRandom | 发送者地址是否随机
Public property | Name | Sender Name ,config: SmtpName
Public property | Password | Password, config:SmtpPassword
Public property | Port | port, config:SmtpPort
Public property | Sender | Sender, config:SmtpSender
Public property | SenderRandomDomain | 发送者地址随机域名,config:SmtpSenderRandomDomain
Top
See Also

Reference

Smtp Class


Smtp.Account Property

SmtpAccount Property
Account ,config:SmtpAccount

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Account { get; set; }
Public Property Account As String
    Get
    Set
public:
virtual property String^ Account {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Account : string with get, set
override Account : string with get, set

Property Value

Type: String

Implements

ISmtpAccount
See Also

Reference

Smtp Class


Smtp.Enabled Property

SmtpEnabled Property
是否可用,config:SmtpEnabled

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; protected set; }
Public Property Enabled As Boolean
    Get
    Protected Set
public:
virtual property bool Enabled {
    bool get () sealed;
    protected: void set (bool value) sealed;
}
abstract Enabled : bool with get, set
override Enabled : bool with get, set

Return Value

Type: Boolean

Implements

ISmtpEnabled
See Also

Reference

Smtp Class


Smtp.Host Property

SmtpHost Property
host, config:SmtpHost

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Host { get; set; }
Public Property Host As String
    Get
    Set
public:
virtual property String^ Host {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Host : string with get, set
override Host : string with get, set

Property Value

Type: String

Implements

ISmtpHost
See Also

Reference

Smtp Class


Smtp.IsSenderRandom Property

SmtpIsSenderRandom Property
发送者地址是否随机

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool IsSenderRandom { get; }
Public ReadOnly Property IsSenderRandom As Boolean
    Get
public:
property bool IsSenderRandom {
    bool get ();
}
member IsSenderRandom : bool with get

Property Value

Type: Boolean
See Also

Reference

Smtp Class


Smtp.Name Property

SmtpName Property
Sender Name ,config: SmtpName

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Name : string with get, set
override Name : string with get, set

Property Value

Type: String

Implements

ISmtpName
See Also

Reference

Smtp Class


Smtp.Password Property

SmtpPassword Property
Password, config:SmtpPassword

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
virtual property String^ Password {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Password : string with get, set
override Password : string with get, set

Property Value

Type: String

Implements

ISmtpPassword
See Also

Reference

Smtp Class


Smtp.Port Property

SmtpPort Property
port, config:SmtpPort

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
virtual property int Port {
    int get () sealed;
    void set (int value) sealed;
}
abstract Port : int with get, set
override Port : int with get, set

Property Value

Type: Int32

Implements

ISmtpPort
See Also

Reference

Smtp Class


Smtp.Sender Property

SmtpSender Property
Sender, config:SmtpSender

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Sender { get; set; }
Public Property Sender As String
    Get
    Set
public:
virtual property String^ Sender {
    String^ get () sealed;
    void set (String^ value) sealed;
}
abstract Sender : string with get, set
override Sender : string with get, set

Property Value

Type: String

Implements

ISmtpSender
See Also

Reference

Smtp Class


Smtp.SenderRandomDomain Property

SmtpSenderRandomDomain Property
发送者地址随机域名,config:SmtpSenderRandomDomain

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string SenderRandomDomain { get; }
Public ReadOnly Property SenderRandomDomain As String
    Get
public:
property String^ SenderRandomDomain {
    String^ get ();
}
member SenderRandomDomain : string with get

Property Value

Type: String
See Also

Reference

Smtp Class


SmtpHelper Class

SmtpHelper Class

Note: This API is now obsolete.

Smtp Helper
Inheritance Hierarchy
SystemObject
AdfSmtpHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("已过时，请使用 Smtp.Instance ", true)]
public static class SmtpHelper
<ObsoleteAttribute("已过时，请使用 Smtp.Instance ", true)>
Public NotInheritable Class SmtpHelper
[ObsoleteAttribute(L"已过时，请使用 Smtp.Instance ", true)]
public ref class SmtpHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("已过时，请使用 Smtp.Instance ", true)>]
type SmtpHelper =  class end

The SmtpHelper type exposes the following members.

Methods
Name | Description
Send | 发送邮件
Top
Properties
Name | Description
Account | Account
Available | 是否可用
Host | host
Name | Sender Name
Password | Password
Port | port
Sender | Sender
Top
See Also

Reference


SmtpHelper Methods

SmtpHelper Methods

The SmtpHelper type exposes the following members.

Methods
Name | Description
Send | 发送邮件
Top
See Also

Reference

SmtpHelper Class


SmtpHelper.Send Method

SmtpHelperSend Method
发送邮件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void Send(
    MailMessage message
)
Public Shared Sub Send (
    message As MailMessage
)
public:
static void Send(
    MailMessage^ message
)
static member Send :
        message : MailMessage -> unit

Parameters

message
Type: System.Net.MailMailMessage
消息体，若未填充From属性，则将以配置填充

Return Value

Type:
See Also

Reference

SmtpHelper Class


SmtpHelper Properties

SmtpHelper Properties

The SmtpHelper type exposes the following members.

Properties
Name | Description
Account | Account
Available | 是否可用
Host | host
Name | Sender Name
Password | Password
Port | port
Sender | Sender
Top
See Also

Reference

SmtpHelper Class


SmtpHelper.Account Property

SmtpHelperAccount Property
Account

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Account { get; }
Public Shared ReadOnly Property Account As String
    Get
public:
static property String^ Account {
    String^ get ();
}
static member Account : string with get

Property Value

Type: String
See Also

Reference

SmtpHelper Class


SmtpHelper.Available Property

SmtpHelperAvailable Property
是否可用

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool Available { get; }
Public Shared ReadOnly Property Available As Boolean
    Get
public:
static property bool Available {
    bool get ();
}
static member Available : bool with get

Return Value

Type: Boolean
See Also

Reference

SmtpHelper Class


SmtpHelper.Host Property

SmtpHelperHost Property
host

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Host { get; }
Public Shared ReadOnly Property Host As String
    Get
public:
static property String^ Host {
    String^ get ();
}
static member Host : string with get

Property Value

Type: String
See Also

Reference

SmtpHelper Class


SmtpHelper.Name Property

SmtpHelperName Property
Sender Name

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Name { get; }
Public Shared ReadOnly Property Name As String
    Get
public:
static property String^ Name {
    String^ get ();
}
static member Name : string with get

Property Value

Type: String
See Also

Reference

SmtpHelper Class


SmtpHelper.Password Property

SmtpHelperPassword Property
Password

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Password { get; }
Public Shared ReadOnly Property Password As String
    Get
public:
static property String^ Password {
    String^ get ();
}
static member Password : string with get

Property Value

Type: String
See Also

Reference

SmtpHelper Class


SmtpHelper.Port Property

SmtpHelperPort Property
port

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int Port { get; }
Public Shared ReadOnly Property Port As Integer
    Get
public:
static property int Port {
    int get ();
}
static member Port : int with get

Property Value

Type: Int32
See Also

Reference

SmtpHelper Class


SmtpHelper.Sender Property

SmtpHelperSender Property
Sender

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Sender { get; }
Public Shared ReadOnly Property Sender As String
    Get
public:
static property String^ Sender {
    String^ get ();
}
static member Sender : string with get

Property Value

Type: String
See Also

Reference

SmtpHelper Class


SocketHelper Class

SocketHelper Class
Socket
Inheritance Hierarchy
SystemObject
AdfSocketHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class SocketHelper
Public NotInheritable Class SocketHelper
public ref class SocketHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SocketHelper =  class end

The SocketHelper type exposes the following members.

Methods
Name | Description
IsClose | 是否为关闭
ReadLine(Socket) | reads a line
ReadLine(Socket, Encoding) | reads a line
Receive(Socket, Int32) | 读取指定字节数
Receive(Socket, Int32, Int32) | 读取
Receive(MemoryStream, Socket, Int32, Int32) | 读取
Top
See Also

Reference


SocketHelper Methods

SocketHelper Methods

The SocketHelper type exposes the following members.

Methods
Name | Description
IsClose | 是否为关闭
ReadLine(Socket) | reads a line
ReadLine(Socket, Encoding) | reads a line
Receive(Socket, Int32) | 读取指定字节数
Receive(Socket, Int32, Int32) | 读取
Receive(MemoryStream, Socket, Int32, Int32) | 读取
Top
See Also

Reference

SocketHelper Class


SocketHelper.IsClose Method

SocketHelperIsClose Method
是否为关闭

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsClose(
    SocketException e
)
Public Shared Function IsClose (
    e As SocketException
) As Boolean
public:
static bool IsClose(
    SocketException^ e
)
static member IsClose :
        e : SocketException -> bool

Parameters

e
Type: System.Net.SocketsSocketException

[Missing <param name="e"/> documentation for "M:Adf.SocketHelper.IsClose(System.Net.Sockets.SocketException)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.SocketHelper.IsClose(System.Net.Sockets.SocketException)"]

See Also

Reference

SocketHelper Class


SocketHelper.ReadLine Method

SocketHelperReadLine Method
Overload List
Name | Description
ReadLine(Socket) | reads a line
ReadLine(Socket, Encoding) | reads a line
Top
See Also

Reference

SocketHelper Class


SocketHelper.ReadLine Method (Socket)

SocketHelperReadLine Method (Socket)
reads a line

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static ArraySegment<byte> ReadLine(
    Socket socket
)
Public Shared Function ReadLine (
    socket As Socket
) As ArraySegment(Of Byte)
public:
static ArraySegment<unsigned char> ReadLine(
    Socket^ socket
)
static member ReadLine :
        socket : Socket -> ArraySegment<byte>

Parameters

socket
Type: System.Net.SocketsSocket

[Missing <param name="socket"/> documentation for "M:Adf.SocketHelper.ReadLine(System.Net.Sockets.Socket)"]

Return Value

Type: ArraySegment Byte
String that was read in
See Also

Reference

SocketHelper Class
ReadLine Overload


SocketHelper.ReadLine Method (Socket, Encoding)

SocketHelperReadLine Method (Socket, Encoding)
reads a line

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ReadLine(
    Socket socket,
    Encoding encoding
)
Public Shared Function ReadLine (
    socket As Socket,
    encoding As Encoding
) As String
public:
static String^ ReadLine(
    Socket^ socket,
    Encoding^ encoding
)
static member ReadLine :
        socket : Socket *
        encoding : Encoding -> string

Parameters

socket
Type: System.Net.SocketsSocket

[Missing <param name="socket"/> documentation for "M:Adf.SocketHelper.ReadLine(System.Net.Sockets.Socket,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.SocketHelper.ReadLine(System.Net.Sockets.Socket,System.Text.Encoding)"]

Return Value

Type: String
String that was read in
See Also

Reference

SocketHelper Class
ReadLine Overload


SocketHelper.Receive Method

SocketHelperReceive Method
Overload List
Name | Description
Receive(Socket, Int32) | 读取指定字节数
Receive(Socket, Int32, Int32) | 读取
Receive(MemoryStream, Socket, Int32, Int32) | 读取
Top
See Also

Reference

SocketHelper Class


SocketHelper.Receive Method (Socket, Int32)

SocketHelperReceive Method (Socket, Int32)
读取指定字节数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] Receive(
    Socket socket,
    int readSize
)
Public Shared Function Receive (
    socket As Socket,
    readSize As Integer
) As Byte()
public:
static array<unsigned char>^ Receive(
    Socket^ socket,
    int readSize
)
static member Receive :
        socket : Socket *
        readSize : int -> byte[]

Parameters

socket
Type: System.Net.SocketsSocket

[Missing <param name="socket"/> documentation for "M:Adf.SocketHelper.Receive(System.Net.Sockets.Socket,System.Int32)"]

readSize
Type: SystemInt32

[Missing <param name="readSize"/> documentation for "M:Adf.SocketHelper.Receive(System.Net.Sockets.Socket,System.Int32)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.SocketHelper.Receive(System.Net.Sockets.Socket,System.Int32)"]

Exceptions
Exception | Condition
SocketException | errorCode= SocketError.Shutdown
See Also

Reference

SocketHelper Class
Receive Overload


SocketHelper.Receive Method (Socket, Int32, Int32)

SocketHelperReceive Method (Socket, Int32, Int32)
读取

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static MemoryStream Receive(
    Socket socket,
    int readSize,
    int bufferSize
)
Public Shared Function Receive (
    socket As Socket,
    readSize As Integer,
    bufferSize As Integer
) As MemoryStream
public:
static MemoryStream^ Receive(
    Socket^ socket,
    int readSize,
    int bufferSize
)
static member Receive :
        socket : Socket *
        readSize : int *
        bufferSize : int -> MemoryStream

Parameters

socket
Type: System.Net.SocketsSocket

[Missing <param name="socket"/> documentation for "M:Adf.SocketHelper.Receive(System.Net.Sockets.Socket,System.Int32,System.Int32)"]

readSize
Type: SystemInt32

[Missing <param name="readSize"/> documentation for "M:Adf.SocketHelper.Receive(System.Net.Sockets.Socket,System.Int32,System.Int32)"]

bufferSize
Type: SystemInt32

[Missing <param name="bufferSize"/> documentation for "M:Adf.SocketHelper.Receive(System.Net.Sockets.Socket,System.Int32,System.Int32)"]

Return Value

Type: MemoryStream

[Missing <returns> documentation for "M:Adf.SocketHelper.Receive(System.Net.Sockets.Socket,System.Int32,System.Int32)"]

Exceptions
Exception | Condition
SocketException | errorCode= SocketError.Shutdown
See Also

Reference

SocketHelper Class
Receive Overload


SocketHelper.Receive Method (MemoryStream, Socket, Int32, Int32)

SocketHelperReceive Method (MemoryStream, Socket, Int32, Int32)
读取

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void Receive(
    MemoryStream memoryStream,
    Socket socket,
    int readSize,
    int bufferSize
)
Public Shared Sub Receive (
    memoryStream As MemoryStream,
    socket As Socket,
    readSize As Integer,
    bufferSize As Integer
)
public:
static void Receive(
    MemoryStream^ memoryStream,
    Socket^ socket,
    int readSize,
    int bufferSize
)
static member Receive :
        memoryStream : MemoryStream *
        socket : Socket *
        readSize : int *
        bufferSize : int -> unit

Parameters

memoryStream
Type: System.IOMemoryStream

[Missing <param name="memoryStream"/> documentation for "M:Adf.SocketHelper.Receive(System.IO.MemoryStream,System.Net.Sockets.Socket,System.Int32,System.Int32)"]

socket
Type: System.Net.SocketsSocket

[Missing <param name="socket"/> documentation for "M:Adf.SocketHelper.Receive(System.IO.MemoryStream,System.Net.Sockets.Socket,System.Int32,System.Int32)"]

readSize
Type: SystemInt32

[Missing <param name="readSize"/> documentation for "M:Adf.SocketHelper.Receive(System.IO.MemoryStream,System.Net.Sockets.Socket,System.Int32,System.Int32)"]

bufferSize
Type: SystemInt32

[Missing <param name="bufferSize"/> documentation for "M:Adf.SocketHelper.Receive(System.IO.MemoryStream,System.Net.Sockets.Socket,System.Int32,System.Int32)"]

Exceptions
Exception | Condition
SocketException | errorCode= SocketError.Shutdown
See Also

Reference

SocketHelper Class
Receive Overload


StreamHelper Class

StreamHelper Class
Stream
Inheritance Hierarchy
SystemObject
AdfStreamHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class StreamHelper
Public NotInheritable Class StreamHelper
public ref class StreamHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StreamHelper =  class end
Methods
Name | Description
ReadLine(Stream) | reads a line
ReadLine(Stream, Encoding) | reads a line
Receive(Stream, Int32) | 读取指定字节数
Receive(Stream, Int32, Int32) | 读取
Receive(MemoryStream, Stream, Int32, Int32) | 读取
Top
See Also

Reference


StreamHelper Methods

StreamHelper Methods
Methods
Name | Description
ReadLine(Stream) | reads a line
ReadLine(Stream, Encoding) | reads a line
Receive(Stream, Int32) | 读取指定字节数
Receive(Stream, Int32, Int32) | 读取
Receive(MemoryStream, Stream, Int32, Int32) | 读取
Top
See Also

Reference

StreamHelper Class


StreamHelper.ReadLine Method

StreamHelperReadLine Method
Overload List
Name | Description
ReadLine(Stream) | reads a line
ReadLine(Stream, Encoding) | reads a line
Top
See Also

Reference

StreamHelper Class


StreamHelper.ReadLine Method (Stream)

StreamHelperReadLine Method (Stream)
reads a line

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static ArraySegment<byte> ReadLine(
    Stream stream
)
Public Shared Function ReadLine (
    stream As Stream
) As ArraySegment(Of Byte)
public:
static ArraySegment<unsigned char> ReadLine(
    Stream^ stream
)
static member ReadLine :
        stream : Stream -> ArraySegment<byte>

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Adf.StreamHelper.ReadLine(System.IO.Stream)"]

Return Value

Type: ArraySegment Byte
String that was read in
See Also

Reference

StreamHelper Class
ReadLine Overload


StreamHelper.ReadLine Method (Stream, Encoding)

StreamHelperReadLine Method (Stream, Encoding)
reads a line

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ReadLine(
    Stream stream,
    Encoding encoding
)
Public Shared Function ReadLine (
    stream As Stream,
    encoding As Encoding
) As String
public:
static String^ ReadLine(
    Stream^ stream,
    Encoding^ encoding
)
static member ReadLine :
        stream : Stream *
        encoding : Encoding -> string

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Adf.StreamHelper.ReadLine(System.IO.Stream,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.StreamHelper.ReadLine(System.IO.Stream,System.Text.Encoding)"]

Return Value

Type: String
String that was read in
See Also

Reference

StreamHelper Class
ReadLine Overload


StreamHelper.Receive Method

StreamHelperReceive Method
Overload List
Name | Description
Receive(Stream, Int32) | 读取指定字节数
Receive(Stream, Int32, Int32) | 读取
Receive(MemoryStream, Stream, Int32, Int32) | 读取
Top
See Also

Reference

StreamHelper Class


StreamHelper.Receive Method (Stream, Int32)

StreamHelperReceive Method (Stream, Int32)
读取指定字节数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static byte[] Receive(
    Stream stream,
    int readSize
)
Public Shared Function Receive (
    stream As Stream,
    readSize As Integer
) As Byte()
public:
static array<unsigned char>^ Receive(
    Stream^ stream,
    int readSize
)
static member Receive :
        stream : Stream *
        readSize : int -> byte[]

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.Stream,System.Int32)"]

readSize
Type: SystemInt32

[Missing <param name="readSize"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.Stream,System.Int32)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.StreamHelper.Receive(System.IO.Stream,System.Int32)"]

Exceptions
Exception | Condition
IOException |
See Also

Reference

StreamHelper Class
Receive Overload


StreamHelper.Receive Method (Stream, Int32, Int32)

StreamHelperReceive Method (Stream, Int32, Int32)
读取

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static MemoryStream Receive(
    Stream stream,
    int readSize,
    int bufferSize
)
Public Shared Function Receive (
    stream As Stream,
    readSize As Integer,
    bufferSize As Integer
) As MemoryStream
public:
static MemoryStream^ Receive(
    Stream^ stream,
    int readSize,
    int bufferSize
)
static member Receive :
        stream : Stream *
        readSize : int *
        bufferSize : int -> MemoryStream

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.Stream,System.Int32,System.Int32)"]

readSize
Type: SystemInt32

[Missing <param name="readSize"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.Stream,System.Int32,System.Int32)"]

bufferSize
Type: SystemInt32

[Missing <param name="bufferSize"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.Stream,System.Int32,System.Int32)"]

Return Value

Type: MemoryStream

[Missing <returns> documentation for "M:Adf.StreamHelper.Receive(System.IO.Stream,System.Int32,System.Int32)"]

Exceptions
Exception | Condition
SocketException | errorCode= SocketError.Shutdown
See Also

Reference

StreamHelper Class
Receive Overload


StreamHelper.Receive Method (MemoryStream, Stream, Int32, Int32)

StreamHelperReceive Method (MemoryStream, Stream, Int32, Int32)
读取

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void Receive(
    MemoryStream memoryStream,
    Stream receiveStream,
    int readSize,
    int bufferSize
)
Public Shared Sub Receive (
    memoryStream As MemoryStream,
    receiveStream As Stream,
    readSize As Integer,
    bufferSize As Integer
)
public:
static void Receive(
    MemoryStream^ memoryStream,
    Stream^ receiveStream,
    int readSize,
    int bufferSize
)
static member Receive :
        memoryStream : MemoryStream *
        receiveStream : Stream *
        readSize : int *
        bufferSize : int -> unit

Parameters

memoryStream
Type: System.IOMemoryStream

[Missing <param name="memoryStream"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.MemoryStream,System.IO.Stream,System.Int32,System.Int32)"]

receiveStream
Type: System.IOStream

[Missing <param name="receiveStream"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.MemoryStream,System.IO.Stream,System.Int32,System.Int32)"]

readSize
Type: SystemInt32

[Missing <param name="readSize"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.MemoryStream,System.IO.Stream,System.Int32,System.Int32)"]

bufferSize
Type: SystemInt32

[Missing <param name="bufferSize"/> documentation for "M:Adf.StreamHelper.Receive(System.IO.MemoryStream,System.IO.Stream,System.Int32,System.Int32)"]

Exceptions
Exception | Condition
IOException |
See Also

Reference

StreamHelper Class
Receive Overload


StringHelper Class

StringHelper Class
字符串扩展
Inheritance Hierarchy
SystemObject
AdfStringHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class StringHelper
Public NotInheritable Class StringHelper
public ref class StringHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringHelper =  class end

The StringHelper type exposes the following members.

Methods
Name | Description
Compart | 以分隔符拆分字符串
Count | 判断字符串compare 在 input字符串中出现的次数
DecodeHtmlTag | 将字符串进行Html解码，是EncodeHtmlTag(String)的反编辑
DecodeHtmlTagChar | 对字符串中的大于号及小于号进行Html解码
EncodeHtmlTag | 将字符串进行Html简单编码，空格、大小于、换行、双引号、单引号、正反括号
EncodeHtmlTagChar | 对字符串中的大于号及小于号进行Html编码
GetMultiByteLength | 取得字符串多字节长度
Join | 串连
Page | 文本分页
RemoveCrLf | 清除给定字符串中的回车及换行符
RemoveHtmlTag | 过滤掉html数据标记
Sub | 取得传入字符串中指定多字节长度的字符串
Top
See Also

Reference


StringHelper Methods

StringHelper Methods

The StringHelper type exposes the following members.

Methods
Name | Description
Compart | 以分隔符拆分字符串
Count | 判断字符串compare 在 input字符串中出现的次数
DecodeHtmlTag | 将字符串进行Html解码，是EncodeHtmlTag(String)的反编辑
DecodeHtmlTagChar | 对字符串中的大于号及小于号进行Html解码
EncodeHtmlTag | 将字符串进行Html简单编码，空格、大小于、换行、双引号、单引号、正反括号
EncodeHtmlTagChar | 对字符串中的大于号及小于号进行Html编码
GetMultiByteLength | 取得字符串多字节长度
Join | 串连
Page | 文本分页
RemoveCrLf | 清除给定字符串中的回车及换行符
RemoveHtmlTag | 过滤掉html数据标记
Sub | 取得传入字符串中指定多字节长度的字符串
Top
See Also

Reference

StringHelper Class


StringHelper.Compart Method

StringHelperCompart Method
以分隔符拆分字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string[] Compart(
    string ids,
    int itemMaxLength,
    char splitChar
)
Public Shared Function Compart (
    ids As String,
    itemMaxLength As Integer,
    splitChar As Char
) As String()
public:
static array<String^>^ Compart(
    String^ ids,
    int itemMaxLength,
    wchar_t splitChar
)
static member Compart :
        ids : string *
        itemMaxLength : int *
        splitChar : char -> string[]

Parameters

ids
Type: SystemString

[Missing <param name="ids"/> documentation for "M:Adf.StringHelper.Compart(System.String,System.Int32,System.Char)"]

itemMaxLength
Type: SystemInt32
单字符串最大长度
splitChar
Type: SystemChar
拆分符

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.StringHelper.Compart(System.String,System.Int32,System.Char)"]

See Also

Reference

StringHelper Class


StringHelper.Count Method

StringHelperCount Method
判断字符串compare 在 input字符串中出现的次数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int Count(
    string input,
    string compare
)
Public Shared Function Count (
    input As String,
    compare As String
) As Integer
public:
static int Count(
    String^ input,
    String^ compare
)
static member Count :
        input : string *
        compare : string -> int

Parameters

input
Type: SystemString
源字符串
compare
Type: SystemString
用于比较的字符串

Return Value

Type: Int32
字符串compare 在 input字符串中出现的次数
See Also

Reference

StringHelper Class


StringHelper.DecodeHtmlTag Method

StringHelperDecodeHtmlTag Method
将字符串进行Html解码，是EncodeHtmlTag(String)的反编辑

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string DecodeHtmlTag(
    string input
)
Public Shared Function DecodeHtmlTag (
    input As String
) As String
public:
static String^ DecodeHtmlTag(
    String^ input
)
static member DecodeHtmlTag :
        input : string -> string

Parameters

input
Type: SystemString
要进行解码的字符串

Return Value

Type: String
返回解码后的字符串
See Also

Reference

StringHelper Class


StringHelper.DecodeHtmlTagChar Method

StringHelperDecodeHtmlTagChar Method
对字符串中的大于号及小于号进行Html解码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string DecodeHtmlTagChar(
    string input
)
Public Shared Function DecodeHtmlTagChar (
    input As String
) As String
public:
static String^ DecodeHtmlTagChar(
    String^ input
)
static member DecodeHtmlTagChar :
        input : string -> string

Parameters

input
Type: SystemString
要进行解辑的字符串

Return Value

Type: String
返回解码后的字符串
See Also

Reference

StringHelper Class


StringHelper.EncodeHtmlTag Method

StringHelperEncodeHtmlTag Method
将字符串进行Html简单编码，空格、大小于、换行、双引号、单引号、正反括号

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncodeHtmlTag(
    string input
)
Public Shared Function EncodeHtmlTag (
    input As String
) As String
public:
static String^ EncodeHtmlTag(
    String^ input
)
static member EncodeHtmlTag :
        input : string -> string

Parameters

input
Type: SystemString
要进行编码的字符串

Return Value

Type: String
返回编码后的字符串
See Also

Reference

StringHelper Class


StringHelper.EncodeHtmlTagChar Method

StringHelperEncodeHtmlTagChar Method
对字符串中的大于号及小于号进行Html编码

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string EncodeHtmlTagChar(
    string input
)
Public Shared Function EncodeHtmlTagChar (
    input As String
) As String
public:
static String^ EncodeHtmlTagChar(
    String^ input
)
static member EncodeHtmlTagChar :
        input : string -> string

Parameters

input
Type: SystemString
要进行编辑的字符串

Return Value

Type: String
返回加码后的字符串
See Also

Reference

StringHelper Class


StringHelper.GetMultiByteLength Method

StringHelperGetMultiByteLength Method
取得字符串多字节长度

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int GetMultiByteLength(
    string input
)
Public Shared Function GetMultiByteLength (
    input As String
) As Integer
public:
static int GetMultiByteLength(
    String^ input
)
static member GetMultiByteLength :
        input : string -> int

Parameters

input
Type: SystemString

[Missing <param name="input"/> documentation for "M:Adf.StringHelper.GetMultiByteLength(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.StringHelper.GetMultiByteLength(System.String)"]

See Also

Reference

StringHelper Class


StringHelper.Join Method

StringHelperJoin Method
串连

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Join(
    string splitChar,
    params Object[] args
)
Public Shared Function Join (
    splitChar As String,
    ParamArray args As Object()
) As String
public:
static String^ Join(
    String^ splitChar,
    ... array<Object^>^ args
)
static member Join :
        splitChar : string *
        args : Object[] -> string

Parameters

splitChar
Type: SystemString

[Missing <param name="splitChar"/> documentation for "M:Adf.StringHelper.Join(System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.StringHelper.Join(System.String,System.Object[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.StringHelper.Join(System.String,System.Object[])"]

See Also

Reference

StringHelper Class


StringHelper.Page Method

StringHelperPage Method
文本分页

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static List<string> Page(
    string text,
    string pageToken
)
Public Shared Function Page (
    text As String,
    pageToken As String
) As List(Of String)
public:
static List<String^>^ Page(
    String^ text,
    String^ pageToken
)
static member Page :
        text : string *
        pageToken : string -> List<string>

Parameters

text
Type: SystemString

[Missing <param name="text"/> documentation for "M:Adf.StringHelper.Page(System.String,System.String)"]

pageToken
Type: SystemString

[Missing <param name="pageToken"/> documentation for "M:Adf.StringHelper.Page(System.String,System.String)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:Adf.StringHelper.Page(System.String,System.String)"]

See Also

Reference

StringHelper Class


StringHelper.RemoveCrLf Method

StringHelperRemoveCrLf Method
清除给定字符串中的回车及换行符

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string RemoveCrLf(
    string input
)
Public Shared Function RemoveCrLf (
    input As String
) As String
public:
static String^ RemoveCrLf(
    String^ input
)
static member RemoveCrLf :
        input : string -> string

Parameters

input
Type: SystemString
要清除的字符串

Return Value

Type: String
清除后返回的字符串
See Also

Reference

StringHelper Class


StringHelper.RemoveHtmlTag Method

StringHelperRemoveHtmlTag Method
过滤掉html数据标记

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string RemoveHtmlTag(
    string input
)
Public Shared Function RemoveHtmlTag (
    input As String
) As String
public:
static String^ RemoveHtmlTag(
    String^ input
)
static member RemoveHtmlTag :
        input : string -> string

Parameters

input
Type: SystemString
过滤信息

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.StringHelper.RemoveHtmlTag(System.String)"]

See Also

Reference

StringHelper Class


StringHelper.Sub Method

StringHelperSub Method
取得传入字符串中指定多字节长度的字符串

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Sub(
    string input,
    int len,
    string append = null
)
Public Shared Function Sub (
    input As String,
    len As Integer,
    Optional append As String = Nothing
) As String
public:
static String^ Sub(
    String^ input,
    int len,
    String^ append = nullptr
)
static member Sub :
        input : string *
        len : int *
        ?append : string
(* Defaults:
        let _append = defaultArg append null
*)
-> string

Parameters

input
Type: SystemString
要进行截取的字符串
len
Type: SystemInt32
字符长度,多字节字符按2个字符计算
append (Optional)
Type: SystemString
须在其尾增加的字符串，当为Null或Empty时则不进行添加

Return Value

Type: String
返回截取后的字符串
Examples
一个中文按两个单位计算
See Also

Reference

StringHelper Class


TypeHelper Class

TypeHelper Class
公用类型引用
Inheritance Hierarchy
SystemObject
AdfTypeHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class TypeHelper
Public Class TypeHelper
public ref class TypeHelper
type TypeHelper =  class end

The TypeHelper type exposes the following members.

Constructors
 | Name | Description
Public method | TypeHelper | Initializes a new instance of the TypeHelper class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | GetGenericCollectionType | 获取泛型集合的元素类型
 | GetGenericDictionaryTypes | 获取泛型字典元素类型
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | IsNumber(Object) | 是否为数值
 | IsNumber(Type) | 是否为数值
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Fields
Name | Description
BOOLEAN | Boolean类型
BYTE | Byte类型
CHAR | CHAR类型
DATETIME | DateTime类型
DOUBLE | Double类型
GUID | GUID类型
IDICTIONARY | 字曲项，IDictionary
IENUMERABLE | 玫举项, IEnumerable
ILIST | 列表项, ILIST
INT16 | INT16类型
INT32 | INT32类型
INT64 | INT64类型
SBYTE | SByte类型
SINGLE | Single类型
STRING | String类型
UINT16 | UINT16类型
UINT32 | UINT32类型
UINT64 | UINT64类型
Top
See Also

Reference


TypeHelper Constructor

TypeHelper Constructor
Initializes a new instance of the TypeHelper class

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public TypeHelper()
Public Sub New
public:
TypeHelper()
new : unit -> TypeHelper
See Also

Reference

TypeHelper Class


TypeHelper Fields

TypeHelper Fields

The TypeHelper type exposes the following members.

Fields
Name | Description
BOOLEAN | Boolean类型
BYTE | Byte类型
CHAR | CHAR类型
DATETIME | DateTime类型
DOUBLE | Double类型
GUID | GUID类型
IDICTIONARY | 字曲项，IDictionary
IENUMERABLE | 玫举项, IEnumerable
ILIST | 列表项, ILIST
INT16 | INT16类型
INT32 | INT32类型
INT64 | INT64类型
SBYTE | SByte类型
SINGLE | Single类型
STRING | String类型
UINT16 | UINT16类型
UINT32 | UINT32类型
UINT64 | UINT64类型
Top
See Also

Reference

TypeHelper Class


TypeHelper.BOOLEAN Field

TypeHelperBOOLEAN Field
Boolean类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type BOOLEAN
Public Shared BOOLEAN As Type
public:
static Type^ BOOLEAN
static val mutable BOOLEAN: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.BYTE Field

TypeHelperBYTE Field
Byte类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type BYTE
Public Shared BYTE As Type
public:
static Type^ BYTE
static val mutable BYTE: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.CHAR Field

TypeHelperCHAR Field
CHAR类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type CHAR
Public Shared CHAR As Type
public:
static Type^ CHAR
static val mutable CHAR: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.DATETIME Field

TypeHelperDATETIME Field
DateTime类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type DATETIME
Public Shared DATETIME As Type
public:
static Type^ DATETIME
static val mutable DATETIME: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.DOUBLE Field

TypeHelperDOUBLE Field
Double类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type DOUBLE
Public Shared DOUBLE As Type
public:
static Type^ DOUBLE
static val mutable DOUBLE: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.GUID Field

TypeHelperGUID Field
GUID类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type GUID
Public Shared GUID As Type
public:
static Type^ GUID
static val mutable GUID: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.IDICTIONARY Field

TypeHelperIDICTIONARY Field
字曲项，IDictionary

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type IDICTIONARY
Public Shared IDICTIONARY As Type
public:
static Type^ IDICTIONARY
static val mutable IDICTIONARY: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.IENUMERABLE Field

TypeHelperIENUMERABLE Field
玫举项, IEnumerable

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type IENUMERABLE
Public Shared IENUMERABLE As Type
public:
static Type^ IENUMERABLE
static val mutable IENUMERABLE: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.ILIST Field

TypeHelperILIST Field
列表项, ILIST

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type ILIST
Public Shared ILIST As Type
public:
static Type^ ILIST
static val mutable ILIST: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.INT16 Field

TypeHelperINT16 Field
INT16类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type INT16
Public Shared INT16 As Type
public:
static Type^ INT16
static val mutable INT16: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.INT32 Field

TypeHelperINT32 Field
INT32类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type INT32
Public Shared INT32 As Type
public:
static Type^ INT32
static val mutable INT32: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.INT64 Field

TypeHelperINT64 Field
INT64类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type INT64
Public Shared INT64 As Type
public:
static Type^ INT64
static val mutable INT64: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.SBYTE Field

TypeHelperSBYTE Field
SByte类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type SBYTE
Public Shared SBYTE As Type
public:
static Type^ SBYTE
static val mutable SBYTE: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.SINGLE Field

TypeHelperSINGLE Field
Single类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type SINGLE
Public Shared SINGLE As Type
public:
static Type^ SINGLE
static val mutable SINGLE: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.STRING Field

TypeHelperSTRING Field
String类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type STRING
Public Shared STRING As Type
public:
static Type^ STRING
static val mutable STRING: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.UINT16 Field

TypeHelperUINT16 Field
UINT16类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type UINT16
Public Shared UINT16 As Type
public:
static Type^ UINT16
static val mutable UINT16: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.UINT32 Field

TypeHelperUINT32 Field
UINT32类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type UINT32
Public Shared UINT32 As Type
public:
static Type^ UINT32
static val mutable UINT32: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper.UINT64 Field

TypeHelperUINT64 Field
UINT64类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type UINT64
Public Shared UINT64 As Type
public:
static Type^ UINT64
static val mutable UINT64: Type

Field Value

Type: Type
See Also

Reference

TypeHelper Class


TypeHelper Methods

TypeHelper Methods

The TypeHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | GetGenericCollectionType | 获取泛型集合的元素类型
 | GetGenericDictionaryTypes | 获取泛型字典元素类型
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | IsNumber(Object) | 是否为数值
 | IsNumber(Type) | 是否为数值
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

TypeHelper Class


TypeHelper.GetGenericCollectionType Method

TypeHelperGetGenericCollectionType Method
获取泛型集合的元素类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type GetGenericCollectionType(
    Type type
)
Public Shared Function GetGenericCollectionType (
    type As Type
) As Type
public:
static Type^ GetGenericCollectionType(
    Type^ type
)
static member GetGenericCollectionType :
        type : Type -> Type

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.TypeHelper.GetGenericCollectionType(System.Type)"]

Return Value

Type: Type
非泛型将返回NULL
See Also

Reference

TypeHelper Class


TypeHelper.GetGenericDictionaryTypes Method

TypeHelperGetGenericDictionaryTypes Method
获取泛型字典元素类型

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static Type[] GetGenericDictionaryTypes(
    Type type
)
Public Shared Function GetGenericDictionaryTypes (
    type As Type
) As Type()
public:
static array<Type^>^ GetGenericDictionaryTypes(
    Type^ type
)
static member GetGenericDictionaryTypes :
        type : Type -> Type[]

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.TypeHelper.GetGenericDictionaryTypes(System.Type)"]

Return Value

Type: Type
类型数组,0:key,1:value, 非泛型字典返回null
See Also

Reference

TypeHelper Class


TypeHelper.IsNumber Method

TypeHelperIsNumber Method
Overload List
Name | Description
IsNumber(Object) | 是否为数值
IsNumber(Type) | 是否为数值
Top
See Also

Reference

TypeHelper Class


TypeHelper.IsNumber Method (Object)

TypeHelperIsNumber Method (Object)
是否为数值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumber(
    Object obj
)
Public Shared Function IsNumber (
    obj As Object
) As Boolean
public:
static bool IsNumber(
    Object^ obj
)
static member IsNumber :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Adf.TypeHelper.IsNumber(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.TypeHelper.IsNumber(System.Object)"]

See Also

Reference

TypeHelper Class
IsNumber Overload


TypeHelper.IsNumber Method (Type)

TypeHelperIsNumber Method (Type)
是否为数值

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumber(
    Type type
)
Public Shared Function IsNumber (
    type As Type
) As Boolean
public:
static bool IsNumber(
    Type^ type
)
static member IsNumber :
        type : Type -> bool

Parameters

type
Type: SystemType

[Missing <param name="type"/> documentation for "M:Adf.TypeHelper.IsNumber(System.Type)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.TypeHelper.IsNumber(System.Type)"]

See Also

Reference

TypeHelper Class
IsNumber Overload


UnixTimestampHelper Class

UnixTimestampHelper Class
UNIX 时间戳
Inheritance Hierarchy
SystemObject
AdfUnixTimestampHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class UnixTimestampHelper
Public NotInheritable Class UnixTimestampHelper
public ref class UnixTimestampHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UnixTimestampHelper =  class end

The UnixTimestampHelper type exposes the following members.

Methods
Name | Description
ToDateTime | 根据UNIX时间戳返回本地时间
ToTimestamp | 根据指定的本地时间返回当前时间的Unix时间戳
ToTimestamp(DateTime) | 根据指定的本地时间返回Unix时间戳
ToTimestamp(Int64) | 根据.net时间戳转为unix时间戳
Top
Fields
Name | Description
UNIXTIMESTAMP_BASE | UNIX TIMESTAMP
UNIXTIMESTAMP_BASETICK | UNIX TIMESTAMP TICK
Top
See Also

Reference


UnixTimestampHelper Fields

UnixTimestampHelper Fields

The UnixTimestampHelper type exposes the following members.

Fields
Name | Description
UNIXTIMESTAMP_BASE | UNIX TIMESTAMP
UNIXTIMESTAMP_BASETICK | UNIX TIMESTAMP TICK
Top
See Also

Reference

UnixTimestampHelper Class


UnixTimestampHelper.UNIXTIMESTAMP_BASE Field

UnixTimestampHelperUNIXTIMESTAMP_BASE Field
UNIX TIMESTAMP

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly DateTime UNIXTIMESTAMP_BASE
Public Shared ReadOnly UNIXTIMESTAMP_BASE As DateTime
public:
static initonly DateTime UNIXTIMESTAMP_BASE
static val UNIXTIMESTAMP_BASE: DateTime

Field Value

Type: DateTime
See Also

Reference

UnixTimestampHelper Class


UnixTimestampHelper.UNIXTIMESTAMP_BASETICK Field

UnixTimestampHelperUNIXTIMESTAMP_BASETICK Field
UNIX TIMESTAMP TICK

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly long UNIXTIMESTAMP_BASETICK
Public Shared ReadOnly UNIXTIMESTAMP_BASETICK As Long
public:
static initonly long long UNIXTIMESTAMP_BASETICK
static val UNIXTIMESTAMP_BASETICK: int64

Field Value

Type: Int64
See Also

Reference

UnixTimestampHelper Class


UnixTimestampHelper Methods

UnixTimestampHelper Methods

The UnixTimestampHelper type exposes the following members.

Methods
Name | Description
ToDateTime | 根据UNIX时间戳返回本地时间
ToTimestamp | 根据指定的本地时间返回当前时间的Unix时间戳
ToTimestamp(DateTime) | 根据指定的本地时间返回Unix时间戳
ToTimestamp(Int64) | 根据.net时间戳转为unix时间戳
Top
See Also

Reference

UnixTimestampHelper Class


UnixTimestampHelper.ToDateTime Method

UnixTimestampHelperToDateTime Method
根据UNIX时间戳返回本地时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static DateTime ToDateTime(
    int timestamp
)
Public Shared Function ToDateTime (
    timestamp As Integer
) As DateTime
public:
static DateTime ToDateTime(
    int timestamp
)
static member ToDateTime :
        timestamp : int -> DateTime

Parameters

timestamp
Type: SystemInt32
时间戳

Return Value

Type: DateTime

[Missing <returns> documentation for "M:Adf.UnixTimestampHelper.ToDateTime(System.Int32)"]

See Also

Reference

UnixTimestampHelper Class


UnixTimestampHelper.ToTimestamp Method

UnixTimestampHelperToTimestamp Method
Overload List
Name | Description
ToTimestamp | 根据指定的本地时间返回当前时间的Unix时间戳
ToTimestamp(DateTime) | 根据指定的本地时间返回Unix时间戳
ToTimestamp(Int64) | 根据.net时间戳转为unix时间戳
Top
See Also

Reference

UnixTimestampHelper Class


UnixTimestampHelper.ToTimestamp Method

UnixTimestampHelperToTimestamp Method
根据指定的本地时间返回当前时间的Unix时间戳

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int ToTimestamp()
Public Shared Function ToTimestamp As Integer
public:
static int ToTimestamp()
static member ToTimestamp : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.UnixTimestampHelper.ToTimestamp"]

See Also

Reference

UnixTimestampHelper Class
ToTimestamp Overload


UnixTimestampHelper.ToTimestamp Method (DateTime)

UnixTimestampHelperToTimestamp Method (DateTime)
根据指定的本地时间返回Unix时间戳

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int ToTimestamp(
    DateTime time
)
Public Shared Function ToTimestamp (
    time As DateTime
) As Integer
public:
static int ToTimestamp(
    DateTime time
)
static member ToTimestamp :
        time : DateTime -> int

Parameters

time
Type: SystemDateTime
要返回的基础时间

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.UnixTimestampHelper.ToTimestamp(System.DateTime)"]

See Also

Reference

UnixTimestampHelper Class
ToTimestamp Overload


UnixTimestampHelper.ToTimestamp Method (Int64)

UnixTimestampHelperToTimestamp Method (Int64)
根据.net时间戳转为unix时间戳

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int ToTimestamp(
    long ticks
)
Public Shared Function ToTimestamp (
    ticks As Long
) As Integer
public:
static int ToTimestamp(
    long long ticks
)
static member ToTimestamp :
        ticks : int64 -> int

Parameters

ticks
Type: SystemInt64

[Missing <param name="ticks"/> documentation for "M:Adf.UnixTimestampHelper.ToTimestamp(System.Int64)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.UnixTimestampHelper.ToTimestamp(System.Int64)"]

See Also

Reference

UnixTimestampHelper Class
ToTimestamp Overload


UriHelper Class

UriHelper Class
Uri Helper
Inheritance Hierarchy
SystemObject
AdfUriHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class UriHelper
Public NotInheritable Class UriHelper
public ref class UriHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UriHelper =  class end

The UriHelper type exposes the following members.

Methods
Name | Description
HexToInt | HexToInt
IntToHex | IntToHex
IsUrlSafeChar | IsUrlSafeChar
ParseQueryString(String, Encoding) | Parse QueryString In Url
ParseQueryString(String, Encoding, NameValueCollection) | Parse QueryString In Url
ParseQueryString(String, Encoding, NameValueCollection, String) | Parse QueryString In Url
QueryStringToString | QueryString to String
UrlDecode | UrlDecode
UrlEncode | UrlEncode
Top
See Also

Reference


UriHelper Methods

UriHelper Methods

The UriHelper type exposes the following members.

Methods
Name | Description
HexToInt | HexToInt
IntToHex | IntToHex
IsUrlSafeChar | IsUrlSafeChar
ParseQueryString(String, Encoding) | Parse QueryString In Url
ParseQueryString(String, Encoding, NameValueCollection) | Parse QueryString In Url
ParseQueryString(String, Encoding, NameValueCollection, String) | Parse QueryString In Url
QueryStringToString | QueryString to String
UrlDecode | UrlDecode
UrlEncode | UrlEncode
Top
See Also

Reference

UriHelper Class


UriHelper.HexToInt Method

UriHelperHexToInt Method
HexToInt

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static int HexToInt(
    char h
)
Public Shared Function HexToInt (
    h As Char
) As Integer
public:
static int HexToInt(
    wchar_t h
)
static member HexToInt :
        h : char -> int

Parameters

h
Type: SystemChar

[Missing <param name="h"/> documentation for "M:Adf.UriHelper.HexToInt(System.Char)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.UriHelper.HexToInt(System.Char)"]

See Also

Reference

UriHelper Class


UriHelper.IntToHex Method

UriHelperIntToHex Method
IntToHex

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static char IntToHex(
    int n
)
Public Shared Function IntToHex (
    n As Integer
) As Char
public:
static wchar_t IntToHex(
    int n
)
static member IntToHex :
        n : int -> char

Parameters

n
Type: SystemInt32

[Missing <param name="n"/> documentation for "M:Adf.UriHelper.IntToHex(System.Int32)"]

Return Value

Type: Char

[Missing <returns> documentation for "M:Adf.UriHelper.IntToHex(System.Int32)"]

See Also

Reference

UriHelper Class


UriHelper.IsUrlSafeChar Method

UriHelperIsUrlSafeChar Method
IsUrlSafeChar

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsUrlSafeChar(
    char ch
)
Public Shared Function IsUrlSafeChar (
    ch As Char
) As Boolean
public:
static bool IsUrlSafeChar(
    wchar_t ch
)
static member IsUrlSafeChar :
        ch : char -> bool

Parameters

ch
Type: SystemChar

[Missing <param name="ch"/> documentation for "M:Adf.UriHelper.IsUrlSafeChar(System.Char)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.UriHelper.IsUrlSafeChar(System.Char)"]

See Also

Reference

UriHelper Class


UriHelper.ParseQueryString Method

UriHelperParseQueryString Method
Overload List
Name | Description
ParseQueryString(String, Encoding) | Parse QueryString In Url
ParseQueryString(String, Encoding, NameValueCollection) | Parse QueryString In Url
ParseQueryString(String, Encoding, NameValueCollection, String) | Parse QueryString In Url
Top
See Also

Reference

UriHelper Class


UriHelper.ParseQueryString Method (String, Encoding)

UriHelperParseQueryString Method (String, Encoding)
Parse QueryString In Url

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static NameValueCollection ParseQueryString(
    string url,
    Encoding encoding
)
Public Shared Function ParseQueryString (
    url As String,
    encoding As Encoding
) As NameValueCollection
public:
static NameValueCollection^ ParseQueryString(
    String^ url,
    Encoding^ encoding
)
static member ParseQueryString :
        url : string *
        encoding : Encoding -> NameValueCollection

Parameters

url
Type: SystemString

[Missing <param name="url"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding)"]

Return Value

Type: NameValueCollection

[Missing <returns> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding)"]

See Also

Reference

UriHelper Class
ParseQueryString Overload


UriHelper.ParseQueryString Method (String, Encoding, NameValueCollection)

UriHelperParseQueryString Method (String, Encoding, NameValueCollection)
Parse QueryString In Url

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static NameValueCollection ParseQueryString(
    string url,
    Encoding encoding,
    NameValueCollection queryString
)
Public Shared Function ParseQueryString (
    url As String,
    encoding As Encoding,
    queryString As NameValueCollection
) As NameValueCollection
public:
static NameValueCollection^ ParseQueryString(
    String^ url,
    Encoding^ encoding,
    NameValueCollection^ queryString
)
static member ParseQueryString :
        url : string *
        encoding : Encoding *
        queryString : NameValueCollection -> NameValueCollection

Parameters

url
Type: SystemString

[Missing <param name="url"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection)"]

queryString
Type: System.Collections.SpecializedNameValueCollection

[Missing <param name="queryString"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection)"]

Return Value

Type: NameValueCollection

[Missing <returns> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection)"]

See Also

Reference

UriHelper Class
ParseQueryString Overload


UriHelper.ParseQueryString Method (String, Encoding, NameValueCollection, String)

UriHelperParseQueryString Method (String, Encoding, NameValueCollection, String)
Parse QueryString In Url

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static NameValueCollection ParseQueryString(
    string url,
    Encoding encoding,
    NameValueCollection queryString,
    out string path
)
Public Shared Function ParseQueryString (
    url As String,
    encoding As Encoding,
    queryString As NameValueCollection,
    <OutAttribute> ByRef path As String
) As NameValueCollection
public:
static NameValueCollection^ ParseQueryString(
    String^ url,
    Encoding^ encoding,
    NameValueCollection^ queryString,
    [OutAttribute] String^% path
)
static member ParseQueryString :
        url : string *
        encoding : Encoding *
        queryString : NameValueCollection *
        path : string byref -> NameValueCollection

Parameters

url
Type: SystemString

[Missing <param name="url"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection,System.String@)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection,System.String@)"]

queryString
Type: System.Collections.SpecializedNameValueCollection

[Missing <param name="queryString"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection,System.String@)"]

path
Type: SystemString

[Missing <param name="path"/> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection,System.String@)"]

Return Value

Type: NameValueCollection

[Missing <returns> documentation for "M:Adf.UriHelper.ParseQueryString(System.String,System.Text.Encoding,System.Collections.Specialized.NameValueCollection,System.String@)"]

See Also

Reference

UriHelper Class
ParseQueryString Overload


UriHelper.QueryStringToString Method

UriHelperQueryStringToString Method
QueryString to String

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string QueryStringToString(
    NameValueCollection queryString
)
Public Shared Function QueryStringToString (
    queryString As NameValueCollection
) As String
public:
static String^ QueryStringToString(
    NameValueCollection^ queryString
)
static member QueryStringToString :
        queryString : NameValueCollection -> string

Parameters

queryString
Type: System.Collections.SpecializedNameValueCollection

[Missing <param name="queryString"/> documentation for "M:Adf.UriHelper.QueryStringToString(System.Collections.Specialized.NameValueCollection)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.UriHelper.QueryStringToString(System.Collections.Specialized.NameValueCollection)"]

See Also

Reference

UriHelper Class


UriHelper.UrlDecode Method

UriHelperUrlDecode Method
UrlDecode

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string UrlDecode(
    string value,
    Encoding encoding
)
Public Shared Function UrlDecode (
    value As String,
    encoding As Encoding
) As String
public:
static String^ UrlDecode(
    String^ value,
    Encoding^ encoding
)
static member UrlDecode :
        value : string *
        encoding : Encoding -> string

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Adf.UriHelper.UrlDecode(System.String,System.Text.Encoding)"]

encoding
Type: System.TextEncoding

[Missing <param name="encoding"/> documentation for "M:Adf.UriHelper.UrlDecode(System.String,System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.UriHelper.UrlDecode(System.String,System.Text.Encoding)"]

See Also

Reference

UriHelper Class


UriHelper.UrlEncode Method

UriHelperUrlEncode Method
UrlEncode

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string UrlEncode(
    string str,
    Encoding e
)
Public Shared Function UrlEncode (
    str As String,
    e As Encoding
) As String
public:
static String^ UrlEncode(
    String^ str,
    Encoding^ e
)
static member UrlEncode :
        str : string *
        e : Encoding -> string

Parameters

str
Type: SystemString

[Missing <param name="str"/> documentation for "M:Adf.UriHelper.UrlEncode(System.String,System.Text.Encoding)"]

e
Type: System.TextEncoding

[Missing <param name="e"/> documentation for "M:Adf.UriHelper.UrlEncode(System.String,System.Text.Encoding)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.UriHelper.UrlEncode(System.String,System.Text.Encoding)"]

See Also

Reference

UriHelper Class


ValidateHelper Class

ValidateHelper Class
校验助手
Inheritance Hierarchy
SystemObject
AdfValidateHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class ValidateHelper
Public NotInheritable Class ValidateHelper
public ref class ValidateHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ValidateHelper =  class end

The ValidateHelper type exposes the following members.

Methods
Name | Description
HasChinese | 是否包含中文
HasEmail | 是否包含邮箱
HasIP | 是否含 有Ipv4 或 IPv6 IP
HasIPv4 | 是否含 有Ipv4 IP
HasIPv6 | 是否含 有Ipv6 IP
IsChinese | 是否为中文
IsDateTime | 是否为时间
IsDBNull | 判断对象是否为数据空对象
IsEmail | 是否为邮箱
IsInt32 | 是否为Int32字符
IsInt64 | 是否为Int64字符
IsIP | 是否为IPV4 或 IPv6 IP
IsIPv4 | 是否为IPV4 IP
IsIPv6 | 是否为IPV6 IP
IsMobileOfChina | 是否为中国手机号
IsNormal | 验证是不是否为常规字符 字母，数字，下划线的组合
IsNull | 判断对象是否为空
IsNullOrDBNull | 判断是否为数据空对象或空对象
IsNumber | 是否为非负纯数字
IsNumberOrFloat | 是否为整数或浮点数
IsPhoneOfChina | 是不是中国电话，格式010-88888888
IsPostcodeOfChina | 是否为中国邮政编码 6个数字
Top
See Also

Reference


ValidateHelper Methods

ValidateHelper Methods

The ValidateHelper type exposes the following members.

Methods
Name | Description
HasChinese | 是否包含中文
HasEmail | 是否包含邮箱
HasIP | 是否含 有Ipv4 或 IPv6 IP
HasIPv4 | 是否含 有Ipv4 IP
HasIPv6 | 是否含 有Ipv6 IP
IsChinese | 是否为中文
IsDateTime | 是否为时间
IsDBNull | 判断对象是否为数据空对象
IsEmail | 是否为邮箱
IsInt32 | 是否为Int32字符
IsInt64 | 是否为Int64字符
IsIP | 是否为IPV4 或 IPv6 IP
IsIPv4 | 是否为IPV4 IP
IsIPv6 | 是否为IPV6 IP
IsMobileOfChina | 是否为中国手机号
IsNormal | 验证是不是否为常规字符 字母，数字，下划线的组合
IsNull | 判断对象是否为空
IsNullOrDBNull | 判断是否为数据空对象或空对象
IsNumber | 是否为非负纯数字
IsNumberOrFloat | 是否为整数或浮点数
IsPhoneOfChina | 是不是中国电话，格式010-88888888
IsPostcodeOfChina | 是否为中国邮政编码 6个数字
Top
See Also

Reference

ValidateHelper Class


ValidateHelper.HasChinese Method

ValidateHelperHasChinese Method
是否包含中文

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool HasChinese(
    string source
)
Public Shared Function HasChinese (
    source As String
) As Boolean
public:
static bool HasChinese(
    String^ source
)
static member HasChinese :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.HasChinese(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.HasChinese(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.HasEmail Method

ValidateHelperHasEmail Method
是否包含邮箱

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool HasEmail(
    string source
)
Public Shared Function HasEmail (
    source As String
) As Boolean
public:
static bool HasEmail(
    String^ source
)
static member HasEmail :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.HasEmail(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.HasEmail(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.HasIP Method

ValidateHelperHasIP Method
是否含 有Ipv4 或 IPv6 IP

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool HasIP(
    string source
)
Public Shared Function HasIP (
    source As String
) As Boolean
public:
static bool HasIP(
    String^ source
)
static member HasIP :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.HasIP(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.HasIP(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.HasIPv4 Method

ValidateHelperHasIPv4 Method
是否含 有Ipv4 IP

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool HasIPv4(
    string source
)
Public Shared Function HasIPv4 (
    source As String
) As Boolean
public:
static bool HasIPv4(
    String^ source
)
static member HasIPv4 :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.HasIPv4(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.HasIPv4(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.HasIPv6 Method

ValidateHelperHasIPv6 Method
是否含 有Ipv6 IP

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool HasIPv6(
    string source
)
Public Shared Function HasIPv6 (
    source As String
) As Boolean
public:
static bool HasIPv6(
    String^ source
)
static member HasIPv6 :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.HasIPv6(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.HasIPv6(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsChinese Method

ValidateHelperIsChinese Method
是否为中文

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsChinese(
    string source
)
Public Shared Function IsChinese (
    source As String
) As Boolean
public:
static bool IsChinese(
    String^ source
)
static member IsChinese :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsChinese(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsChinese(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsDateTime Method

ValidateHelperIsDateTime Method
是否为时间

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsDateTime(
    string source
)
Public Shared Function IsDateTime (
    source As String
) As Boolean
public:
static bool IsDateTime(
    String^ source
)
static member IsDateTime :
        source : string -> bool

Parameters

source
Type: SystemString
字符串

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsDateTime(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsDBNull Method

ValidateHelperIsDBNull Method
判断对象是否为数据空对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsDBNull(
    Object obj
)
Public Shared Function IsDBNull (
    obj As Object
) As Boolean
public:
static bool IsDBNull(
    Object^ obj
)
static member IsDBNull :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
object类型

Return Value

Type: Boolean
bool类型
See Also

Reference

ValidateHelper Class


ValidateHelper.IsEmail Method

ValidateHelperIsEmail Method
是否为邮箱

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsEmail(
    string source
)
Public Shared Function IsEmail (
    source As String
) As Boolean
public:
static bool IsEmail(
    String^ source
)
static member IsEmail :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsEmail(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsEmail(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsInt32 Method

ValidateHelperIsInt32 Method
是否为Int32字符

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsInt32(
    string source
)
Public Shared Function IsInt32 (
    source As String
) As Boolean
public:
static bool IsInt32(
    String^ source
)
static member IsInt32 :
        source : string -> bool

Parameters

source
Type: SystemString
字符串

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsInt32(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsInt64 Method

ValidateHelperIsInt64 Method
是否为Int64字符

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsInt64(
    string source
)
Public Shared Function IsInt64 (
    source As String
) As Boolean
public:
static bool IsInt64(
    String^ source
)
static member IsInt64 :
        source : string -> bool

Parameters

source
Type: SystemString
字符串

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsInt64(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsIP Method

ValidateHelperIsIP Method
是否为IPV4 或 IPv6 IP

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsIP(
    string source
)
Public Shared Function IsIP (
    source As String
) As Boolean
public:
static bool IsIP(
    String^ source
)
static member IsIP :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsIP(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsIP(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsIPv4 Method

ValidateHelperIsIPv4 Method
是否为IPV4 IP

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsIPv4(
    string source
)
Public Shared Function IsIPv4 (
    source As String
) As Boolean
public:
static bool IsIPv4(
    String^ source
)
static member IsIPv4 :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsIPv4(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsIPv4(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsIPv6 Method

ValidateHelperIsIPv6 Method
是否为IPV6 IP

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsIPv6(
    string source,
    bool hasIPv4 = false
)
Public Shared Function IsIPv6 (
    source As String,
    Optional hasIPv4 As Boolean = false
) As Boolean
public:
static bool IsIPv6(
    String^ source,
    bool hasIPv4 = false
)
static member IsIPv6 :
        source : string *
        ?hasIPv4 : bool
(* Defaults:
        let _hasIPv4 = defaultArg hasIPv4 false
*)
-> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsIPv6(System.String,System.Boolean)"]

hasIPv4 (Optional)
Type: SystemBoolean

[Missing <param name="hasIPv4"/> documentation for "M:Adf.ValidateHelper.IsIPv6(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsIPv6(System.String,System.Boolean)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsMobileOfChina Method

ValidateHelperIsMobileOfChina Method
是否为中国手机号

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsMobileOfChina(
    string source
)
Public Shared Function IsMobileOfChina (
    source As String
) As Boolean
public:
static bool IsMobileOfChina(
    String^ source
)
static member IsMobileOfChina :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsMobileOfChina(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsMobileOfChina(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsNormal Method

ValidateHelperIsNormal Method
验证是不是否为常规字符 字母，数字，下划线的组合

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsNormal(
    string source
)
Public Shared Function IsNormal (
    source As String
) As Boolean
public:
static bool IsNormal(
    String^ source
)
static member IsNormal :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsNormal(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsNormal(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsNull Method

ValidateHelperIsNull Method
判断对象是否为空

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsNull(
    Object obj
)
Public Shared Function IsNull (
    obj As Object
) As Boolean
public:
static bool IsNull(
    Object^ obj
)
static member IsNull :
        obj : Object -> bool

Parameters

obj
Type: SystemObject
object类型

Return Value

Type: Boolean
bool类型
See Also

Reference

ValidateHelper Class


ValidateHelper.IsNullOrDBNull Method

ValidateHelperIsNullOrDBNull Method
判断是否为数据空对象或空对象

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsNullOrDBNull(
    Object obj
)
Public Shared Function IsNullOrDBNull (
    obj As Object
) As Boolean
public:
static bool IsNullOrDBNull(
    Object^ obj
)
static member IsNullOrDBNull :
        obj : Object -> bool

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Adf.ValidateHelper.IsNullOrDBNull(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsNullOrDBNull(System.Object)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsNumber Method

ValidateHelperIsNumber Method
是否为非负纯数字

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumber(
    string source,
    bool isNegative = false
)
Public Shared Function IsNumber (
    source As String,
    Optional isNegative As Boolean = false
) As Boolean
public:
static bool IsNumber(
    String^ source,
    bool isNegative = false
)
static member IsNumber :
        source : string *
        ?isNegative : bool
(* Defaults:
        let _isNegative = defaultArg isNegative false
*)
-> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsNumber(System.String,System.Boolean)"]

isNegative (Optional)
Type: SystemBoolean
是否允许为负数

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsNumber(System.String,System.Boolean)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsNumberOrFloat Method

ValidateHelperIsNumberOrFloat Method
是否为整数或浮点数

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsNumberOrFloat(
    string source,
    bool isNegative = false
)
Public Shared Function IsNumberOrFloat (
    source As String,
    Optional isNegative As Boolean = false
) As Boolean
public:
static bool IsNumberOrFloat(
    String^ source,
    bool isNegative = false
)
static member IsNumberOrFloat :
        source : string *
        ?isNegative : bool
(* Defaults:
        let _isNegative = defaultArg isNegative false
*)
-> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsNumberOrFloat(System.String,System.Boolean)"]

isNegative (Optional)
Type: SystemBoolean
是否允许为负数

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsNumberOrFloat(System.String,System.Boolean)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsPhoneOfChina Method

ValidateHelperIsPhoneOfChina Method
是不是中国电话，格式010-88888888

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsPhoneOfChina(
    string source
)
Public Shared Function IsPhoneOfChina (
    source As String
) As Boolean
public:
static bool IsPhoneOfChina(
    String^ source
)
static member IsPhoneOfChina :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsPhoneOfChina(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsPhoneOfChina(System.String)"]

See Also

Reference

ValidateHelper Class


ValidateHelper.IsPostcodeOfChina Method

ValidateHelperIsPostcodeOfChina Method
是否为中国邮政编码 6个数字

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool IsPostcodeOfChina(
    string source
)
Public Shared Function IsPostcodeOfChina (
    source As String
) As Boolean
public:
static bool IsPostcodeOfChina(
    String^ source
)
static member IsPostcodeOfChina :
        source : string -> bool

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:Adf.ValidateHelper.IsPostcodeOfChina(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.ValidateHelper.IsPostcodeOfChina(System.String)"]

See Also

Reference

ValidateHelper Class


WebLogger Class

WebLogger Class
Web Log
Inheritance Hierarchy
SystemObject
AdfLogManager
AdfWebLogger

Namespace: Adf
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class WebLogger : LogManager
Public Class WebLogger
    Inherits LogManager
public ref class WebLogger : public LogManager
type WebLogger =
    class
        inherit LogManager
    end

The WebLogger type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 资源释放 (Inherited from LogManager.)
Public method | Enable | 设置是否开启日志 (Inherited from LogManager.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exception | Exception (Overrides LogManagerException(Exception).)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新并存储所有缓冲区内容，该方法一般在应用结束或需要批量将数据存储时使用 (Inherited from LogManager.)
Protected method | ForEach | 循环当前每个日志写入器 (Inherited from LogManager.)
Public method | GetExceptionWriter | get exception logmanager (Inherited from LogManager.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWriter | get name logwriter (Inherited from LogManager.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendExceptionMail | 发送异常邮件 (Inherited from LogManager.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | WritingToConsole | console logger (Inherited from LogManager.)
Top
Properties
 | Name | Description
Public property | AllDisabled | 是否全部禁用，当配置Log:Disabled为all时此值为true (Inherited from LogManager.)
Public property | Error | 错误记录 (Inherited from LogManager.)
Public property | IsOwnner | 是否具有所有者，当初始name为空时此值为false,否则为true (Inherited from LogManager.)
Public property | Message | 消息记录 (Inherited from LogManager.)
Public property | Name | 名称 (Inherited from LogManager.)
Public property | NewExceptionToMail | 记录新异常时是否发送至邮件（若邮件已配置）,默认开启 (Inherited from LogManager.)
Public property | Path | 存储路径 (Inherited from LogManager.)
Public property | ToConsole | 是否输出至Console (Inherited from LogManager.)
Public property | Warning | 警告记录 (Inherited from LogManager.)
Top
Events
 | Name | Description
Public event | NewException | 新异常 (Inherited from LogManager.)
Public event | Writing | 新写入事件 (Inherited from LogManager.)
Top
See Also

Reference


WebLogger Methods

WebLogger Methods

The WebLogger type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 资源释放 (Inherited from LogManager.)
Public method | Enable | 设置是否开启日志 (Inherited from LogManager.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exception | Exception (Overrides LogManagerException(Exception).)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新并存储所有缓冲区内容，该方法一般在应用结束或需要批量将数据存储时使用 (Inherited from LogManager.)
Protected method | ForEach | 循环当前每个日志写入器 (Inherited from LogManager.)
Public method | GetExceptionWriter | get exception logmanager (Inherited from LogManager.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWriter | get name logwriter (Inherited from LogManager.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendExceptionMail | 发送异常邮件 (Inherited from LogManager.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | WritingToConsole | console logger (Inherited from LogManager.)
Top
See Also

Reference

WebLogger Class


WebLogger.Exception Method

WebLoggerException Method
Exception

Namespace: Adf
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override void Exception(
    Exception exception
)
Public Overrides Sub Exception (
    exception As Exception
)
public:
virtual void Exception(
    Exception^ exception
) override
abstract Exception :
        exception : Exception -> unit
override Exception :
        exception : Exception -> unit

Parameters

exception
Type: SystemException

[Missing <param name="exception"/> documentation for "M:Adf.WebLogger.Exception(System.Exception)"]

See Also

Reference

WebLogger Class


WebLogger Properties

WebLogger Properties

The WebLogger type exposes the following members.

Properties
 | Name | Description
Public property | AllDisabled | 是否全部禁用，当配置Log:Disabled为all时此值为true (Inherited from LogManager.)
Public property | Error | 错误记录 (Inherited from LogManager.)
Public property | IsOwnner | 是否具有所有者，当初始name为空时此值为false,否则为true (Inherited from LogManager.)
Public property | Message | 消息记录 (Inherited from LogManager.)
Public property | Name | 名称 (Inherited from LogManager.)
Public property | NewExceptionToMail | 记录新异常时是否发送至邮件（若邮件已配置）,默认开启 (Inherited from LogManager.)
Public property | Path | 存储路径 (Inherited from LogManager.)
Public property | ToConsole | 是否输出至Console (Inherited from LogManager.)
Public property | Warning | 警告记录 (Inherited from LogManager.)
Top
See Also

Reference

WebLogger Class


WebLogger Events

WebLogger Events

The WebLogger type exposes the following members.

Events
 | Name | Description
Public event | NewException | 新异常 (Inherited from LogManager.)
Public event | Writing | 新写入事件 (Inherited from LogManager.)
Top
See Also

Reference

WebLogger Class


WebSocketClient Class

WebSocketClient Class
WebSocket 客户端
Inheritance Hierarchy
SystemObject
AdfWebSocketClient

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class WebSocketClient : IDisposable
Public Class WebSocketClient
    Implements IDisposable
public ref class WebSocketClient : IDisposable
type WebSocketClient =
    class
        interface IDisposable
    end

The WebSocketClient type exposes the following members.

Constructors
 | Name | Description
Public method | WebSocketClient(String, Int32) | 以指定主机初始化实例
Public method | WebSocketClient(String, Int32, String) | 以指定主机初始化实例
Top
Methods
 | Name | Description
Public method | Close | 资源释放
Public method | Connection | 连接
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Send | 消息发送
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Connectioned | 获取是否已连接至主机
Public property | Encoding | 获取或设置字符解释编码,默认UTF8
Public property | Header | 获取或设置请求头
Public property | Host | 主机
Public property | LocalEndPoint | 获取本地端口
Public property | Path | 获取当前连接请求路径
Public property | Port | 端口
Public property | ResponseHeader | 获取响应头
Top
Events
 | Name | Description
Public event | OnClose | 关闭事件
Public event | OnMessage | 消息事件
Top
See Also

Reference


WebSocketClient Constructor

WebSocketClient Constructor
Overload List
 | Name | Description
Public method | WebSocketClient(String, Int32) | 以指定主机初始化实例
Public method | WebSocketClient(String, Int32, String) | 以指定主机初始化实例
Top
See Also

Reference

WebSocketClient Class


WebSocketClient Constructor (String, Int32)

WebSocketClient Constructor (String, Int32)
以指定主机初始化实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketClient(
    string host,
    int port
)
Public Sub New (
    host As String,
    port As Integer
)
public:
WebSocketClient(
    String^ host,
    int port
)
new :
        host : string *
        port : int -> WebSocketClient

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.WebSocketClient.#ctor(System.String,System.Int32)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.WebSocketClient.#ctor(System.String,System.Int32)"]

See Also

Reference

WebSocketClient Class
WebSocketClient Overload


WebSocketClient Constructor (String, Int32, String)

WebSocketClient Constructor (String, Int32, String)
以指定主机初始化实例

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketClient(
    string host,
    int port,
    string path
)
Public Sub New (
    host As String,
    port As Integer,
    path As String
)
public:
WebSocketClient(
    String^ host,
    int port,
    String^ path
)
new :
        host : string *
        port : int *
        path : string -> WebSocketClient

Parameters

host
Type: SystemString

[Missing <param name="host"/> documentation for "M:Adf.WebSocketClient.#ctor(System.String,System.Int32,System.String)"]

port
Type: SystemInt32

[Missing <param name="port"/> documentation for "M:Adf.WebSocketClient.#ctor(System.String,System.Int32,System.String)"]

path
Type: SystemString

[Missing <param name="path"/> documentation for "M:Adf.WebSocketClient.#ctor(System.String,System.Int32,System.String)"]

See Also

Reference

WebSocketClient Class
WebSocketClient Overload


WebSocketClient Methods

WebSocketClient Methods

The WebSocketClient type exposes the following members.

Methods
 | Name | Description
Public method | Close | 资源释放
Public method | Connection | 连接
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Send | 消息发送
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

WebSocketClient Class


WebSocketClient.Close Method

WebSocketClientClose Method
资源释放

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Close()
Public Sub Close
public:
void Close()
member Close : unit -> unit
See Also

Reference

WebSocketClient Class


WebSocketClient.Connection Method

WebSocketClientConnection Method
连接

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Connection()
Public Sub Connection
public:
void Connection()
member Connection : unit -> unit

Return Value

Type:
See Also

Reference

WebSocketClient Class


WebSocketClient.Send Method

WebSocketClientSend Method
消息发送

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Send(
    string message
)
Public Sub Send (
    message As String
)
public:
void Send(
    String^ message
)
member Send :
        message : string -> unit

Parameters

message
Type: SystemString
allow empty,no support null
See Also

Reference

WebSocketClient Class


WebSocketClient Properties

WebSocketClient Properties

The WebSocketClient type exposes the following members.

Properties
 | Name | Description
Public property | Connectioned | 获取是否已连接至主机
Public property | Encoding | 获取或设置字符解释编码,默认UTF8
Public property | Header | 获取或设置请求头
Public property | Host | 主机
Public property | LocalEndPoint | 获取本地端口
Public property | Path | 获取当前连接请求路径
Public property | Port | 端口
Public property | ResponseHeader | 获取响应头
Top
See Also

Reference

WebSocketClient Class


WebSocketClient.Connectioned Property

WebSocketClientConnectioned Property
获取是否已连接至主机

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Connectioned { get; }
Public ReadOnly Property Connectioned As Boolean
    Get
public:
property bool Connectioned {
    bool get ();
}
member Connectioned : bool with get

Property Value

Type: Boolean
See Also

Reference

WebSocketClient Class


WebSocketClient.Encoding Property

WebSocketClientEncoding Property
获取或设置字符解释编码,默认UTF8

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}
member Encoding : Encoding with get, set

Property Value

Type: Encoding
See Also

Reference

WebSocketClient Class


WebSocketClient.Header Property

WebSocketClientHeader Property
获取或设置请求头

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> Header { get; }
Public ReadOnly Property Header As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ Header {
    Dictionary<String^, String^>^ get ();
}
member Header : Dictionary<string, string> with get

Property Value

Type: Dictionary String, String
See Also

Reference

WebSocketClient Class


WebSocketClient.Host Property

WebSocketClientHost Property
主机

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Host { get; }
Public ReadOnly Property Host As String
    Get
public:
property String^ Host {
    String^ get ();
}
member Host : string with get

Property Value

Type: String
See Also

Reference

WebSocketClient Class


WebSocketClient.LocalEndPoint Property

WebSocketClientLocalEndPoint Property
获取本地端口

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IPEndPoint LocalEndPoint { get; }
Public ReadOnly Property LocalEndPoint As IPEndPoint
    Get
public:
property IPEndPoint^ LocalEndPoint {
    IPEndPoint^ get ();
}
member LocalEndPoint : IPEndPoint with get

Property Value

Type: IPEndPoint
See Also

Reference

WebSocketClient Class


WebSocketClient.Path Property

WebSocketClientPath Property
获取当前连接请求路径

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

WebSocketClient Class


WebSocketClient.Port Property

WebSocketClientPort Property
端口

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; }
Public ReadOnly Property Port As Integer
    Get
public:
property int Port {
    int get ();
}
member Port : int with get

Property Value

Type: Int32
See Also

Reference

WebSocketClient Class


WebSocketClient.ResponseHeader Property

WebSocketClientResponseHeader Property
获取响应头

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, string> ResponseHeader { get; }
Public ReadOnly Property ResponseHeader As Dictionary(Of String, String)
    Get
public:
property Dictionary<String^, String^>^ ResponseHeader {
    Dictionary<String^, String^>^ get ();
}
member ResponseHeader : Dictionary<string, string> with get

Property Value

Type: Dictionary String, String
See Also

Reference

WebSocketClient Class


WebSocketClient Events

WebSocketClient Events

The WebSocketClient type exposes the following members.

Events
 | Name | Description
Public event | OnClose | 关闭事件
Public event | OnMessage | 消息事件
Top
See Also

Reference

WebSocketClient Class


WebSocketClient.OnClose Event

WebSocketClientOnClose Event
关闭事件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public event EventHandler OnClose
Public Event OnClose As EventHandler
public:
 event EventHandler^ OnClose {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}
member OnClose : IEvent<EventHandler,
    EventArgs>

Value

Type: SystemEventHandler
See Also

Reference

WebSocketClient Class


WebSocketClient.OnMessage Event

WebSocketClientOnMessage Event
消息事件

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public event EventHandler<WebSocketMessageEventArgs> OnMessage
Public Event OnMessage As EventHandler(Of WebSocketMessageEventArgs)
public:
 event EventHandler<WebSocketMessageEventArgs^>^ OnMessage {
    void add (EventHandler<WebSocketMessageEventArgs^>^ value);
    void remove (EventHandler<WebSocketMessageEventArgs^>^ value);
}
member OnMessage : IEvent<EventHandler<WebSocketMessageEventArgs>,
    WebSocketMessageEventArgs>

Value

Type: SystemEventHandler WebSocketMessageEventArgs
See Also

Reference

WebSocketClient Class


WebSocketDataFrame Class

WebSocketDataFrame Class
WebSocket 数据帧
Inheritance Hierarchy
SystemObject
AdfWebSocketDataFrame

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class WebSocketDataFrame
Public Class WebSocketDataFrame
public ref class WebSocketDataFrame
type WebSocketDataFrame =  class end

The WebSocketDataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | WebSocketDataFrame(Byte, Boolean) | 初始一个输出内容帧
Public method | WebSocketDataFrame(NetworkStream, Byte) | 初始化一个NetworkStream数据帧
Public method | WebSocketDataFrame(Socket, Byte) | 初始化一个Socket数据帧
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetFrameBytes | 返回完整帧字节数组
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Content | 获取内容
Public property | Opcode | 获取当前内容Opcode
Top
See Also

Reference


WebSocketDataFrame Constructor

WebSocketDataFrame Constructor
Overload List
 | Name | Description
Public method | WebSocketDataFrame(Byte, Boolean) | 初始一个输出内容帧
Public method | WebSocketDataFrame(NetworkStream, Byte) | 初始化一个NetworkStream数据帧
Public method | WebSocketDataFrame(Socket, Byte) | 初始化一个Socket数据帧
Top
See Also

Reference

WebSocketDataFrame Class


WebSocketDataFrame Constructor (Byte[], Boolean)

WebSocketDataFrame Constructor (Byte, Boolean)
初始一个输出内容帧

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketDataFrame(
    byte[] content,
    bool isMask
)
Public Sub New (
    content As Byte(),
    isMask As Boolean
)
public:
WebSocketDataFrame(
    array<unsigned char>^ content,
    bool isMask
)
new :
        content : byte[] *
        isMask : bool -> WebSocketDataFrame

Parameters

content
Type: SystemByte

[Missing <param name="content"/> documentation for "M:Adf.WebSocketDataFrame.#ctor(System.Byte[],System.Boolean)"]

isMask
Type: SystemBoolean

[Missing <param name="isMask"/> documentation for "M:Adf.WebSocketDataFrame.#ctor(System.Byte[],System.Boolean)"]

See Also

Reference

WebSocketDataFrame Class
WebSocketDataFrame Overload


WebSocketDataFrame Constructor (NetworkStream, Byte[])

WebSocketDataFrame Constructor (NetworkStream, Byte)
初始化一个NetworkStream数据帧

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketDataFrame(
    NetworkStream stream,
    byte[] headerBuffer
)
Public Sub New (
    stream As NetworkStream,
    headerBuffer As Byte()
)
public:
WebSocketDataFrame(
    NetworkStream^ stream,
    array<unsigned char>^ headerBuffer
)
new :
        stream : NetworkStream *
        headerBuffer : byte[] -> WebSocketDataFrame

Parameters

stream
Type: System.Net.SocketsNetworkStream

[Missing <param name="stream"/> documentation for "M:Adf.WebSocketDataFrame.#ctor(System.Net.Sockets.NetworkStream,System.Byte[])"]

headerBuffer
Type: SystemByte

[Missing <param name="headerBuffer"/> documentation for "M:Adf.WebSocketDataFrame.#ctor(System.Net.Sockets.NetworkStream,System.Byte[])"]

See Also

Reference

WebSocketDataFrame Class
WebSocketDataFrame Overload


WebSocketDataFrame Constructor (Socket, Byte[])

WebSocketDataFrame Constructor (Socket, Byte)
初始化一个Socket数据帧

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketDataFrame(
    Socket socket,
    byte[] headerBuffer
)
Public Sub New (
    socket As Socket,
    headerBuffer As Byte()
)
public:
WebSocketDataFrame(
    Socket^ socket,
    array<unsigned char>^ headerBuffer
)
new :
        socket : Socket *
        headerBuffer : byte[] -> WebSocketDataFrame

Parameters

socket
Type: System.Net.SocketsSocket

[Missing <param name="socket"/> documentation for "M:Adf.WebSocketDataFrame.#ctor(System.Net.Sockets.Socket,System.Byte[])"]

headerBuffer
Type: SystemByte

[Missing <param name="headerBuffer"/> documentation for "M:Adf.WebSocketDataFrame.#ctor(System.Net.Sockets.Socket,System.Byte[])"]

See Also

Reference

WebSocketDataFrame Class
WebSocketDataFrame Overload


WebSocketDataFrame Methods

WebSocketDataFrame Methods

The WebSocketDataFrame type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetFrameBytes | 返回完整帧字节数组
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

WebSocketDataFrame Class


WebSocketDataFrame.GetFrameBytes Method

WebSocketDataFrameGetFrameBytes Method
返回完整帧字节数组

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] GetFrameBytes()
Public Function GetFrameBytes As Byte()
public:
array<unsigned char>^ GetFrameBytes()
member GetFrameBytes : unit -> byte[]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.WebSocketDataFrame.GetFrameBytes"]

See Also

Reference

WebSocketDataFrame Class


WebSocketDataFrame Properties

WebSocketDataFrame Properties

The WebSocketDataFrame type exposes the following members.

Properties
 | Name | Description
Public property | Content | 获取内容
Public property | Opcode | 获取当前内容Opcode
Top
See Also

Reference

WebSocketDataFrame Class


WebSocketDataFrame.Content Property

WebSocketDataFrameContent Property
获取内容

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] Content { get; }
Public ReadOnly Property Content As Byte()
    Get
public:
property array<unsigned char>^ Content {
    array<unsigned char>^ get ();
}
member Content : byte[] with get

Property Value

Type: Byte
See Also

Reference

WebSocketDataFrame Class


WebSocketDataFrame.Opcode Property

WebSocketDataFrameOpcode Property
获取当前内容Opcode

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketOpcode Opcode { get; }
Public ReadOnly Property Opcode As WebSocketOpcode
    Get
public:
property WebSocketOpcode Opcode {
    WebSocketOpcode get ();
}
member Opcode : WebSocketOpcode with get

Property Value

Type: WebSocketOpcode
See Also

Reference

WebSocketDataFrame Class


WebSocketDataFrameHeader Class

WebSocketDataFrameHeader Class
WebSocket DataFrame Header 数据头
Inheritance Hierarchy
SystemObject
AdfWebSocketDataFrameHeader

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class WebSocketDataFrameHeader
Public Class WebSocketDataFrameHeader
public ref class WebSocketDataFrameHeader
type WebSocketDataFrameHeader =  class end

The WebSocketDataFrameHeader type exposes the following members.

Constructors
 | Name | Description
Public method | WebSocketDataFrameHeader(Byte) | 根据字节组初始头
Public method | WebSocketDataFrameHeader(Boolean, Boolean, Boolean, Boolean, SByte, Boolean, Int32) | 初始并封装一个数据头
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBytes | 返回当前帧字节
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | FIN |
Public property | HasMask |
Public property | Length |
Public property | OpCode |
Public property | RSV1 |
Public property | RSV2 |
Public property | RSV3 |
Top
See Also

Reference


WebSocketDataFrameHeader Constructor

WebSocketDataFrameHeader Constructor
Overload List
 | Name | Description
Public method | WebSocketDataFrameHeader(Byte) | 根据字节组初始头
Public method | WebSocketDataFrameHeader(Boolean, Boolean, Boolean, Boolean, SByte, Boolean, Int32) | 初始并封装一个数据头
Top
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader Constructor (Byte[])

WebSocketDataFrameHeader Constructor (Byte)
根据字节组初始头

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketDataFrameHeader(
    byte[] buffer
)
Public Sub New (
    buffer As Byte()
)
public:
WebSocketDataFrameHeader(
    array<unsigned char>^ buffer
)
new :
        buffer : byte[] -> WebSocketDataFrameHeader

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Byte[])"]

See Also

Reference

WebSocketDataFrameHeader Class
WebSocketDataFrameHeader Overload


WebSocketDataFrameHeader Constructor (Boolean, Boolean, Boolean, Boolean, SByte, Boolean, Int32)

WebSocketDataFrameHeader Constructor (Boolean, Boolean, Boolean, Boolean, SByte, Boolean, Int32)
初始并封装一个数据头

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketDataFrameHeader(
    bool fin,
    bool rsv1,
    bool rsv2,
    bool rsv3,
    sbyte opcode,
    bool hasmask,
    int length
)
Public Sub New (
    fin As Boolean,
    rsv1 As Boolean,
    rsv2 As Boolean,
    rsv3 As Boolean,
    opcode As SByte,
    hasmask As Boolean,
    length As Integer
)
public:
WebSocketDataFrameHeader(
    bool fin,
    bool rsv1,
    bool rsv2,
    bool rsv3,
    signed char opcode,
    bool hasmask,
    int length
)
new :
        fin : bool *
        rsv1 : bool *
        rsv2 : bool *
        rsv3 : bool *
        opcode : sbyte *
        hasmask : bool *
        length : int -> WebSocketDataFrameHeader

Parameters

fin
Type: SystemBoolean

[Missing <param name="fin"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.SByte,System.Boolean,System.Int32)"]

rsv1
Type: SystemBoolean

[Missing <param name="rsv1"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.SByte,System.Boolean,System.Int32)"]

rsv2
Type: SystemBoolean

[Missing <param name="rsv2"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.SByte,System.Boolean,System.Int32)"]

rsv3
Type: SystemBoolean

[Missing <param name="rsv3"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.SByte,System.Boolean,System.Int32)"]

opcode
Type: SystemSByte

[Missing <param name="opcode"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.SByte,System.Boolean,System.Int32)"]

hasmask
Type: SystemBoolean

[Missing <param name="hasmask"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.SByte,System.Boolean,System.Int32)"]

length
Type: SystemInt32

[Missing <param name="length"/> documentation for "M:Adf.WebSocketDataFrameHeader.#ctor(System.Boolean,System.Boolean,System.Boolean,System.Boolean,System.SByte,System.Boolean,System.Int32)"]

See Also

Reference

WebSocketDataFrameHeader Class
WebSocketDataFrameHeader Overload


WebSocketDataFrameHeader Methods

WebSocketDataFrameHeader Methods

The WebSocketDataFrameHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBytes | 返回当前帧字节
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.GetBytes Method

WebSocketDataFrameHeaderGetBytes Method
返回当前帧字节

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] GetBytes()
Public Function GetBytes As Byte()
public:
array<unsigned char>^ GetBytes()
member GetBytes : unit -> byte[]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.WebSocketDataFrameHeader.GetBytes"]

See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader Properties

WebSocketDataFrameHeader Properties

The WebSocketDataFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | FIN |
Public property | HasMask |
Public property | Length |
Public property | OpCode |
Public property | RSV1 |
Public property | RSV2 |
Public property | RSV3 |
Top
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.FIN Property

WebSocketDataFrameHeaderFIN Property

[Missing <summary> documentation for "P:Adf.WebSocketDataFrameHeader.FIN"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool FIN { get; }
Public ReadOnly Property FIN As Boolean
    Get
public:
property bool FIN {
    bool get ();
}
member FIN : bool with get

Property Value

Type: Boolean
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.HasMask Property

WebSocketDataFrameHeaderHasMask Property

[Missing <summary> documentation for "P:Adf.WebSocketDataFrameHeader.HasMask"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool HasMask { get; }
Public ReadOnly Property HasMask As Boolean
    Get
public:
property bool HasMask {
    bool get ();
}
member HasMask : bool with get

Property Value

Type: Boolean
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.Length Property

WebSocketDataFrameHeaderLength Property

[Missing <summary> documentation for "P:Adf.WebSocketDataFrameHeader.Length"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public sbyte Length { get; }
Public ReadOnly Property Length As SByte
    Get
public:
property signed char Length {
    signed char get ();
}
member Length : sbyte with get

Property Value

Type: SByte
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.OpCode Property

WebSocketDataFrameHeaderOpCode Property

[Missing <summary> documentation for "P:Adf.WebSocketDataFrameHeader.OpCode"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public sbyte OpCode { get; }
Public ReadOnly Property OpCode As SByte
    Get
public:
property signed char OpCode {
    signed char get ();
}
member OpCode : sbyte with get

Property Value

Type: SByte
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.RSV1 Property

WebSocketDataFrameHeaderRSV1 Property

[Missing <summary> documentation for "P:Adf.WebSocketDataFrameHeader.RSV1"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool RSV1 { get; }
Public ReadOnly Property RSV1 As Boolean
    Get
public:
property bool RSV1 {
    bool get ();
}
member RSV1 : bool with get

Property Value

Type: Boolean
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.RSV2 Property

WebSocketDataFrameHeaderRSV2 Property

[Missing <summary> documentation for "P:Adf.WebSocketDataFrameHeader.RSV2"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool RSV2 { get; }
Public ReadOnly Property RSV2 As Boolean
    Get
public:
property bool RSV2 {
    bool get ();
}
member RSV2 : bool with get

Property Value

Type: Boolean
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketDataFrameHeader.RSV3 Property

WebSocketDataFrameHeaderRSV3 Property

[Missing <summary> documentation for "P:Adf.WebSocketDataFrameHeader.RSV3"]

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool RSV3 { get; }
Public ReadOnly Property RSV3 As Boolean
    Get
public:
property bool RSV3 {
    bool get ();
}
member RSV3 : bool with get

Property Value

Type: Boolean
See Also

Reference

WebSocketDataFrameHeader Class


WebSocketMessageEventArgs Class

WebSocketMessageEventArgs Class
WebSocketMessageEvent Args
Inheritance Hierarchy
SystemObject
SystemEventArgs
AdfWebSocketMessageEventArgs
AdfHttpServerWebSocketMessageEventArgs

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class WebSocketMessageEventArgs : EventArgs
Public Class WebSocketMessageEventArgs
    Inherits EventArgs
public ref class WebSocketMessageEventArgs : public EventArgs
type WebSocketMessageEventArgs =
    class
        inherit EventArgs
    end

The WebSocketMessageEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | WebSocketMessageEventArgs | 初始数据
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Buffer | 获取二进制传输时的二进制数据
Public property | Message | 获取消息体
Public property | Opcode | 获取消息体 Opcode
Top
See Also

Reference


WebSocketMessageEventArgs Constructor

WebSocketMessageEventArgs Constructor
初始数据

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketMessageEventArgs(
    WebSocketOpcode opcode
)
Public Sub New (
    opcode As WebSocketOpcode
)
public:
WebSocketMessageEventArgs(
    WebSocketOpcode opcode
)
new :
        opcode : WebSocketOpcode -> WebSocketMessageEventArgs

Parameters

opcode
Type: AdfWebSocketOpcode

[Missing <param name="opcode"/> documentation for "M:Adf.WebSocketMessageEventArgs.#ctor(Adf.WebSocketOpcode)"]

See Also

Reference

WebSocketMessageEventArgs Class


WebSocketMessageEventArgs Methods

WebSocketMessageEventArgs Methods

The WebSocketMessageEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

WebSocketMessageEventArgs Class


WebSocketMessageEventArgs Properties

WebSocketMessageEventArgs Properties

The WebSocketMessageEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | 获取二进制传输时的二进制数据
Public property | Message | 获取消息体
Public property | Opcode | 获取消息体 Opcode
Top
See Also

Reference

WebSocketMessageEventArgs Class


WebSocketMessageEventArgs.Buffer Property

WebSocketMessageEventArgsBuffer Property
获取二进制传输时的二进制数据

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte[] Buffer { get; }
Public ReadOnly Property Buffer As Byte()
    Get
public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
}
member Buffer : byte[] with get

Property Value

Type: Byte
See Also

Reference

WebSocketMessageEventArgs Class


WebSocketMessageEventArgs.Message Property

WebSocketMessageEventArgsMessage Property
获取消息体

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
public:
property String^ Message {
    String^ get ();
}
member Message : string with get

Property Value

Type: String
See Also

Reference

WebSocketMessageEventArgs Class


WebSocketMessageEventArgs.Opcode Property

WebSocketMessageEventArgsOpcode Property
获取消息体 Opcode

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WebSocketOpcode Opcode { get; }
Public ReadOnly Property Opcode As WebSocketOpcode
    Get
public:
property WebSocketOpcode Opcode {
    WebSocketOpcode get ();
}
member Opcode : WebSocketOpcode with get

Property Value

Type: WebSocketOpcode
See Also

Reference

WebSocketMessageEventArgs Class


WebSocketOpcode Enumeration

WebSocketOpcode Enumeration
Contains the values of the opcode that indicates the type of a WebSocket frame.

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public enum WebSocketOpcode
Public Enumeration WebSocketOpcode
public enum class WebSocketOpcode
type WebSocketOpcode
Members
Member name | Value | Description
Cont | 0 | Equivalent to numeric value 0. Indicates a continuation frame.
Text | 1 | Equivalent to numeric value 1. Indicates a text frame.
Binary | 2 | Equivalent to numeric value 2. Indicates a binary frame.
Close | 8 | Equivalent to numeric value 8. Indicates a connection close frame.
Ping | 9 | Equivalent to numeric value 9. Indicates a ping frame.
Pong | 10 | Equivalent to numeric value 10. Indicates a pong frame.
Remarks
The values of the opcode are defined in Section 5.2 of RFC 6455.
See Also

Reference


WindowsEventLog Class

WindowsEventLog Class
Windows Event Log
Inheritance Hierarchy
SystemObject
AdfWindowsEventLog

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class WindowsEventLog
Public NotInheritable Class WindowsEventLog
public ref class WindowsEventLog abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WindowsEventLog =  class end

The WindowsEventLog type exposes the following members.

Methods
Name | Description
NewLog | New Log
Top
See Also

Reference


WindowsEventLog Methods

WindowsEventLog Methods

The WindowsEventLog type exposes the following members.

Methods
Name | Description
NewLog | New Log
Top
See Also

Reference

WindowsEventLog Class


WindowsEventLog.NewLog Method

WindowsEventLogNewLog Method
New Log

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void NewLog(
    EventLogEntryType type,
    string content,
    params Object[] args
)
Public Shared Sub NewLog (
    type As EventLogEntryType,
    content As String,
    ParamArray args As Object()
)
public:
static void NewLog(
    EventLogEntryType type,
    String^ content,
    ... array<Object^>^ args
)
static member NewLog :
        type : EventLogEntryType *
        content : string *
        args : Object[] -> unit

Parameters

type
Type: System.DiagnosticsEventLogEntryType

[Missing <param name="type"/> documentation for "M:Adf.WindowsEventLog.NewLog(System.Diagnostics.EventLogEntryType,System.String,System.Object[])"]

content
Type: SystemString

[Missing <param name="content"/> documentation for "M:Adf.WindowsEventLog.NewLog(System.Diagnostics.EventLogEntryType,System.String,System.Object[])"]

args
Type: SystemObject

[Missing <param name="args"/> documentation for "M:Adf.WindowsEventLog.NewLog(System.Diagnostics.EventLogEntryType,System.String,System.Object[])"]

See Also

Reference

WindowsEventLog Class


XmlHelper Class

XmlHelper Class
XML Helper
Inheritance Hierarchy
SystemObject
AdfXmlHelper

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static class XmlHelper
Public NotInheritable Class XmlHelper
public ref class XmlHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlHelper =  class end

The XmlHelper type exposes the following members.

Methods
Name | Description
FromFileT | Object From XML File
GetAttribute | get xmlnode attribute
ToFile | Object To File
Top
See Also

Reference


XmlHelper Methods

XmlHelper Methods

The XmlHelper type exposes the following members.

Methods
Name | Description
FromFileT | Object From XML File
GetAttribute | get xmlnode attribute
ToFile | Object To File
Top
See Also

Reference

XmlHelper Class


XmlHelper.FromFile(T) Method

XmlHelperFromFileT Method
Object From XML File

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static T FromFile<T>(
    string xmlfilepath
)

Public Shared Function FromFile(Of T) (
    xmlfilepath As String
) As T
public:
generic<typename T>
static T FromFile(
    String^ xmlfilepath
)
static member FromFile :
        xmlfilepath : string -> 'T

Parameters

xmlfilepath
Type: SystemString

[Missing <param name="xmlfilepath"/> documentation for "M:Adf.XmlHelper.FromFile``1(System.String)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.XmlHelper.FromFile``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.XmlHelper.FromFile``1(System.String)"]

See Also

Reference

XmlHelper Class


XmlHelper.GetAttribute Method

XmlHelperGetAttribute Method
get xmlnode attribute

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string GetAttribute(
    XmlNode node,
    string name,
    string defaultValue = ""
)
Public Shared Function GetAttribute (
    node As XmlNode,
    name As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ GetAttribute(
    XmlNode^ node,
    String^ name,
    String^ defaultValue = L""
)
static member GetAttribute :
        node : XmlNode *
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:Adf.XmlHelper.GetAttribute(System.Xml.XmlNode,System.String,System.String)"]

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.XmlHelper.GetAttribute(System.Xml.XmlNode,System.String,System.String)"]

defaultValue (Optional)
Type: SystemString

[Missing <param name="defaultValue"/> documentation for "M:Adf.XmlHelper.GetAttribute(System.Xml.XmlNode,System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.XmlHelper.GetAttribute(System.Xml.XmlNode,System.String,System.String)"]

See Also

Reference

XmlHelper Class


XmlHelper.ToFile Method

XmlHelperToFile Method
Object To File

Namespace: Adf
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static void ToFile(
    Object obj,
    string xmlFilePath
)
Public Shared Sub ToFile (
    obj As Object,
    xmlFilePath As String
)
public:
static void ToFile(
    Object^ obj,
    String^ xmlFilePath
)
static member ToFile :
        obj : Object *
        xmlFilePath : string -> unit

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Adf.XmlHelper.ToFile(System.Object,System.String)"]

xmlFilePath
Type: SystemString

[Missing <param name="xmlFilePath"/> documentation for "M:Adf.XmlHelper.ToFile(System.Object,System.String)"]

See Also

Reference

XmlHelper Class


Adf.Config Namespace

Adf.Config Namespace

[Missing <summary> documentation for "N:Adf.Config"]

Classes
 | Class | Description
Public class | ConfigBaseT | 配置基类
Public class | ConfigValue | 字符型配置项
Public class | GlobalConfig | 配置管理器员
Public class | IpGroupCollection | IP组配置集合
Public class | IpGroupElement | IP组客户端配置元素
Public class | IpGroupSection | IP组配置节解释器
Public class | RegularConfig | 正则配置
Public class | ServerConfig | Server Config Item
Public class | ServerConfigItem | Server Config Item


ConfigBase(T) Class

ConfigBaseT Class
配置基类
Inheritance Hierarchy
SystemObject
Adf.ConfigConfigBaseT
Adf.ConfigConfigValue
Adf.ConfigServerConfig

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract class ConfigBase<T>

Public MustInherit Class ConfigBase(Of T)
generic<typename T>
public ref class ConfigBase abstract
[<AbstractClassAttribute>]
type ConfigBase<'T> =  class end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Adf.Config.ConfigBase`1"]

The ConfigBaseT type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigBaseT | 初始化
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置
Protected method | FileLoad | load config
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取
Top
Fields
Name | Description
GlobalDirectoryName | 全局配置目录名
PATH_ROOT | 配置文件根目录
Top
Properties
 | Name | Description
Public property | FileExist | 文件是否存在
Public property | FileName | 配置文件名称
Public property | FilePath | 配置文件路径
Public property | Item | 获取指定名称配置
Protected property | Items | 配置项
Public property | LocalFileExist | 本地文件是否存在
Public property | LocalFilePath | 本地文件路径配置
Top
See Also

Reference

Adf.Config Namespace


ConfigBase(T) Constructor

ConfigBaseT Constructor
初始化

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ConfigBase()
Public Sub New
public:
ConfigBase()
new : unit -> ConfigBase
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T) Fields

ConfigBaseT Fields

The ConfigBaseT generic type exposes the following members.

Fields
Name | Description
GlobalDirectoryName | 全局配置目录名
PATH_ROOT | 配置文件根目录
Top
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).GlobalDirectoryName Field

ConfigBaseTGlobalDirectoryName Field
全局配置目录名

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public const string GlobalDirectoryName
Public Const GlobalDirectoryName As String
public:
literal String^ GlobalDirectoryName
static val mutable GlobalDirectoryName: string

Field Value

Type: String
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).PATH_ROOT Field

ConfigBaseTPATH_ROOT Field
配置文件根目录

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly string PATH_ROOT
Public Shared ReadOnly PATH_ROOT As String
public:
static initonly String^ PATH_ROOT
static val PATH_ROOT: string

Field Value

Type: String
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T) Methods

ConfigBaseT Methods

The ConfigBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置
Protected method | FileLoad | load config
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取
Top
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).Exists Method

ConfigBaseTExists Method
是否存在某一配置

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool Exists(
    string name
)
Public Function Exists (
    name As String
) As Boolean
public:
bool Exists(
    String^ name
)
member Exists :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Config.ConfigBase`1.Exists(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Config.ConfigBase`1.Exists(System.String)"]

See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).FileLoad Method

ConfigBaseTFileLoad Method
load config

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void FileLoad(
    XmlDocument document
)
Protected Overridable Sub FileLoad (
    document As XmlDocument
)
protected:
virtual void FileLoad(
    XmlDocument^ document
)
abstract FileLoad :
        document : XmlDocument -> unit
override FileLoad :
        document : XmlDocument -> unit

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:Adf.Config.ConfigBase`1.FileLoad(System.Xml.XmlDocument)"]

See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).GetItem Method

ConfigBaseTGetItem Method
get config

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T GetItem(
    string name,
    T defaultValue
)
Public Function GetItem (
    name As String,
    defaultValue As T
) As T
public:
T GetItem(
    String^ name,
    T defaultValue
)
member GetItem :
        name : string *
        defaultValue : 'T -> 'T

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Config.ConfigBase`1.GetItem(System.String,`0)"]

defaultValue
Type: T

[Missing <param name="defaultValue"/> documentation for "M:Adf.Config.ConfigBase`1.GetItem(System.String,`0)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Config.ConfigBase`1.GetItem(System.String,`0)"]

See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).Init Method

ConfigBaseTInit Method
初始化

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void Init()
Protected Overridable Sub Init
protected:
virtual void Init()
abstract Init : unit -> unit
override Init : unit -> unit
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).NewItem Method

ConfigBaseTNewItem Method
新项

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected abstract T NewItem(
    XmlNode node
)
Protected MustOverride Function NewItem (
    node As XmlNode
) As T
protected:
virtual T NewItem(
    XmlNode^ node
) abstract
abstract NewItem :
        node : XmlNode -> 'T

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:Adf.Config.ConfigBase`1.NewItem(System.Xml.XmlNode)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Config.ConfigBase`1.NewItem(System.Xml.XmlNode)"]

See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).TryGet Method

ConfigBaseTTryGet Method
尝试获取

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool TryGet(
    string name,
    out T value
)
Public Function TryGet (
    name As String,
    <OutAttribute> ByRef value As T
) As Boolean
public:
bool TryGet(
    String^ name,
    [OutAttribute] T% value
)
member TryGet :
        name : string *
        value : 'T byref -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Config.ConfigBase`1.TryGet(System.String,`0@)"]

value
Type: T

[Missing <param name="value"/> documentation for "M:Adf.Config.ConfigBase`1.TryGet(System.String,`0@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Config.ConfigBase`1.TryGet(System.String,`0@)"]

See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T) Properties

ConfigBaseT Properties

The ConfigBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | FileExist | 文件是否存在
Public property | FileName | 配置文件名称
Public property | FilePath | 配置文件路径
Public property | Item | 获取指定名称配置
Protected property | Items | 配置项
Public property | LocalFileExist | 本地文件是否存在
Public property | LocalFilePath | 本地文件路径配置
Top
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).FileExist Property

ConfigBaseTFileExist Property
文件是否存在

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool FileExist { get; protected set; }
Public Property FileExist As Boolean
    Get
    Protected Set
public:
property bool FileExist {
    bool get ();
    protected: void set (bool value);
}
member FileExist : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).FileName Property

ConfigBaseTFileName Property
配置文件名称

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract string FileName { get; }
Public MustOverride ReadOnly Property FileName As String
    Get
public:
virtual property String^ FileName {
    String^ get () abstract;
}
abstract FileName : string with get

Property Value

Type: String
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).FilePath Property

ConfigBaseTFilePath Property
配置文件路径

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; protected set; }
Public Property FilePath As String
    Get
    Protected Set
public:
property String^ FilePath {
    String^ get ();
    protected: void set (String^ value);
}
member FilePath : string with get, set

Property Value

Type: String
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).Item Property

ConfigBaseTItem Property
获取指定名称配置

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As T
    Get
public:
property T default[String^ name] {
    T get (String^ name);
}
member Item : 'T with get

Parameters

name
Type: SystemString

Return Value

Type: T
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).Items Property

ConfigBaseTItems Property
配置项

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected Dictionary<string, T> Items { get; }
Protected ReadOnly Property Items As Dictionary(Of String, T)
    Get
protected:
property Dictionary<String^, T>^ Items {
    Dictionary<String^, T>^ get ();
}
member Items : Dictionary<string, 'T> with get

Property Value

Type: Dictionary String, T
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).LocalFileExist Property

ConfigBaseTLocalFileExist Property
本地文件是否存在

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool LocalFileExist { get; protected set; }
Public Property LocalFileExist As Boolean
    Get
    Protected Set
public:
property bool LocalFileExist {
    bool get ();
    protected: void set (bool value);
}
member LocalFileExist : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigBase(T).LocalFilePath Property

ConfigBaseTLocalFilePath Property
本地文件路径配置

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string LocalFilePath { get; protected set; }
Public Property LocalFilePath As String
    Get
    Protected Set
public:
property String^ LocalFilePath {
    String^ get ();
    protected: void set (String^ value);
}
member LocalFilePath : string with get, set

Property Value

Type: String
See Also

Reference

ConfigBaseT Class
Adf.Config Namespace


ConfigValue Class

ConfigValue Class
字符型配置项
Inheritance Hierarchy
SystemObject
Adf.ConfigConfigBase String
Adf.ConfigConfigValue
Adf.ConfigGlobalConfig
Adf.ConfigRegularConfig

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract class ConfigValue : ConfigBase<string>
Public MustInherit Class ConfigValue
    Inherits ConfigBase(Of String)
public ref class ConfigValue abstract : public ConfigBase<String^>
[<AbstractClassAttribute>]
type ConfigValue =
    class
        inherit ConfigBase<string>
    end

The ConfigValue type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigValue | Initializes a new instance of the ConfigValue class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | load config (Inherited from ConfigBaseT.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项 (Overrides ConfigBaseTNewItem(XmlNode).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | 配置文件名称 (Inherited from ConfigBaseT.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | ItemString | 获取指定名称配置 (Inherited from ConfigBaseT.)
Public property | ItemString, Object | 获取指定的项并格式化串
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

Adf.Config Namespace


ConfigValue Constructor

ConfigValue Constructor
Initializes a new instance of the ConfigValue class

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected ConfigValue()
Protected Sub New
protected:
ConfigValue()
new : unit -> ConfigValue
See Also

Reference

ConfigValue Class
Adf.Config Namespace


ConfigValue Methods

ConfigValue Methods

The ConfigValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | load config (Inherited from ConfigBaseT.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项 (Overrides ConfigBaseTNewItem(XmlNode).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
See Also

Reference

ConfigValue Class
Adf.Config Namespace


ConfigValue.NewItem Method

ConfigValueNewItem Method
新项

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected override string NewItem(
    XmlNode node
)
Protected Overrides Function NewItem (
    node As XmlNode
) As String
protected:
virtual String^ NewItem(
    XmlNode^ node
) override
abstract NewItem :
        node : XmlNode -> string
override NewItem :
        node : XmlNode -> string

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:Adf.Config.ConfigValue.NewItem(System.Xml.XmlNode)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Config.ConfigValue.NewItem(System.Xml.XmlNode)"]

See Also

Reference

ConfigValue Class
Adf.Config Namespace


ConfigValue Properties

ConfigValue Properties

The ConfigValue type exposes the following members.

Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | 配置文件名称 (Inherited from ConfigBaseT.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | ItemString | 获取指定名称配置 (Inherited from ConfigBaseT.)
Public property | ItemString, Object | 获取指定的项并格式化串
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

ConfigValue Class
Adf.Config Namespace


ConfigValue.Item Property

ConfigValueItem Property
Overload List
 | Name | Description
Public property | ItemString | 获取指定名称配置 (Inherited from ConfigBaseT.)
Public property | ItemString, Object | 获取指定的项并格式化串
Top
See Also

Reference

ConfigValue Class
Adf.Config Namespace


ConfigValue.Item Property (String, Object[])

ConfigValueItem Property (String, Object)
获取指定的项并格式化串

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string this[
    string name,
    params Object[] valueArgs
] { get; }
Public ReadOnly Default Property Item (
    name As String,
    ParamArray valueArgs As Object()
) As String
    Get
public:
property String^ default[String^ name, ... array<Object^>^ valueArgs] {
    String^ get (String^ name, ... array<Object^>^ valueArgs);
}
member Item : string with get

Parameters

name
Type: SystemString
valueArgs
Type: SystemObject

Return Value

Type: String
See Also

Reference

ConfigValue Class
Item Overload
Adf.Config Namespace


GlobalConfig Class

GlobalConfig Class
配置管理器员
Inheritance Hierarchy
SystemObject
Adf.ConfigConfigBase String
Adf.ConfigConfigValue
Adf.ConfigGlobalConfig

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class GlobalConfig : ConfigValue
Public Class GlobalConfig
    Inherits ConfigValue
public ref class GlobalConfig : public ConfigValue
type GlobalConfig =
    class
        inherit ConfigValue
    end

The GlobalConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | load config (Inherited from ConfigBaseT.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项 (Inherited from ConfigValue.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
Fields
Name | Description
Instance | 获取配置实例
Top
Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | 配置文件名称 (Overrides ConfigBaseTFileName.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | ItemString | 获取指定名称配置 (Inherited from ConfigBaseT.)
Public property | ItemString, Object | 获取指定的项并格式化串 (Inherited from ConfigValue.)
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

Adf.Config Namespace


GlobalConfig Fields

GlobalConfig Fields

The GlobalConfig type exposes the following members.

Fields
Name | Description
Instance | 获取配置实例
Top
See Also

Reference

GlobalConfig Class
Adf.Config Namespace


GlobalConfig.Instance Field

GlobalConfigInstance Field
获取配置实例

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly GlobalConfig Instance
Public Shared ReadOnly Instance As GlobalConfig
public:
static initonly GlobalConfig^ Instance
static val Instance: GlobalConfig

Field Value

Type: GlobalConfig
See Also

Reference

GlobalConfig Class
Adf.Config Namespace


GlobalConfig Methods

GlobalConfig Methods

The GlobalConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | load config (Inherited from ConfigBaseT.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项 (Inherited from ConfigValue.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
See Also

Reference

GlobalConfig Class
Adf.Config Namespace


GlobalConfig Properties

GlobalConfig Properties

The GlobalConfig type exposes the following members.

Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | 配置文件名称 (Overrides ConfigBaseTFileName.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | ItemString | 获取指定名称配置 (Inherited from ConfigBaseT.)
Public property | ItemString, Object | 获取指定的项并格式化串 (Inherited from ConfigValue.)
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

GlobalConfig Class
Adf.Config Namespace


GlobalConfig.FileName Property

GlobalConfigFileName Property
配置文件名称

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string FileName { get; }
Public Overrides ReadOnly Property FileName As String
    Get
public:
virtual property String^ FileName {
    String^ get () override;
}
abstract FileName : string with get
override FileName : string with get

Property Value

Type: String
See Also

Reference

GlobalConfig Class
Adf.Config Namespace


IpGroupCollection Class

IpGroupCollection Class
IP组配置集合
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
Adf.ConfigIpGroupCollection

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class IpGroupCollection : ConfigurationElementCollection
Public Class IpGroupCollection
    Inherits ConfigurationElementCollection
public ref class IpGroupCollection : public ConfigurationElementCollection
type IpGroupCollection =
    class
        inherit ConfigurationElementCollection
    end

The IpGroupCollection type exposes the following members.

Constructors
 | Name | Description
Public method | IpGroupCollection | Initializes a new instance of the IpGroupCollection class
Top
Methods
 | Name | Description
Protected method | BaseAdd(ConfigurationElement) | 向 ConfigurationElementCollection 添加配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | 向配置元素集合添加配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | 向配置元素集合添加配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | 从集合中移除所有配置元素对象。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | 返回具有指定键的配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | 获取位于指定索引位置的配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | 返回 ConfigurationElementCollection 中包含的所有配置元素的键数组。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | 获取位于指定索引位置的 ConfigurationElement 的键。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | 指定 ConfigurationElement 的索引。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | 获取一个值，该值指示是否已从 ConfigurationElementCollection 中移除具有指定键的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | 从集合中移除 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | 移除位于指定索引位置的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Public method | CopyTo | 将 ConfigurationElementCollection 的内容复制到数组。 (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | 创建新元素 (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | 在派生的类中重写时，创建新的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | 读取配置文件中的 XML。 (Inherited from ConfigurationElement.)
Public method | Equals | 将 ConfigurationElementCollection 与指定的对象进行比较。 (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Protected method | GetElementKey | 获取键 (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | 获取用于循环访问 ConfigurationElementCollection 的 IEnumerator。 (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | 获取表示 ConfigurationElementCollection 实例的唯一值。 (Inherited from ConfigurationElementCollection.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 将 ConfigurationElement 对象设置为其初始状态。 (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | 用于初始化 ConfigurationElement 对象的默认值集。 (Inherited from ConfigurationElement.)
Protected method | IsElementName | 指示指定的 ConfigurationElement 是否存在于 ConfigurationElementCollection 中。 (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | 获取一个值，该值指示是否可从 ConfigurationElementCollection 中移除指定的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | 在派生的类中重写时，指示从最后一次保存或加载此 ConfigurationElementCollection 后是否对其进行了修改。 (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | 获取一个值，该值指示 ConfigurationElementCollection 对象是否为只读。 (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | 将此 ConfigurationElement 对象以及所有子元素中无效属性的错误添加到传递的列表中。 (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | 获取一个值，该值指示反序列化过程中是否遇到未知属性。 (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | 导致配置系统引发异常。 (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | 未找到所需属性时引发异常。 (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | 反序列化后调用。 (Inherited from ConfigurationElement.)
Protected method | PreSerialize | 序列化前调用。 (Inherited from ConfigurationElement.)
Protected method | Reset | 在派生的类中重写时，将 ConfigurationElementCollection 重置为其未被修改时的状态。 (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | 在派生的类中重写时，将 IsModified 属性的值重置为 false。 (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | 在派生的类中重写时，将配置数据写入配置文件中的 XML 元素。 (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | 当在派生类中实现后，将此配置元素的外部标记写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | 将属性设置为指定值。 (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | 为 ConfigurationElementCollection 对象和所有子元素设置 IsReadOnly 属性。 (Inherited from ConfigurationElementCollection.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | Unmerge | 反转将配置层次结构的不同级别配置的信息合并在一起的效果 (Inherited from ConfigurationElementCollection.)
Top
Properties
 | Name | Description
Protected property | AddElementName | 在派生的类中重写时，获取或设置 ConfigurationElement 的名称，以便在 ConfigurationElementCollection 中与添加操作关联。 (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | 在派生的类中重写时，获取或设置 ConfigurationElement 的名称，以便在 ConfigurationElementCollection 中与清除操作关联。 (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | 获取 ConfigurationElementCollection 的类型。 (Inherited from ConfigurationElementCollection.)
Public property | Count | 获取集合中的元素数。 (Inherited from ConfigurationElementCollection.)
Public property | ElementInformation | 获取包含 ConfigurationElement 对象的不可自定义的信息和功能的 ElementInformation 对象。 (Inherited from ConfigurationElement.)
Protected property | ElementName | 获取在派生的类中重写时用于标识配置文件中此元素集合的名称。 (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | 获取本身表示 ConfigurationElement 对象的 ConfigurationElementProperty 对象。 (Inherited from ConfigurationElement.)
Public property | EmitClear | 获取或设置一个值，该值指定是否已清除集合。 (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | 获取 ConfigurationElement 对象的 ContextInformation 对象。 (Inherited from ConfigurationElement.)
Public property | IsSynchronized | 获取一个值，该值指示对集合的访问是否为同步的（线程安全）。 (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | 获取或设置此配置元素的属性 (Property) 或属性 (Attribute)。 (Inherited from ConfigurationElement.)
Protected property | ItemString | 获取或设置此配置元素的属性 (Property) 、属性 (Attribute) 或子元素。 (Inherited from ConfigurationElement.)
Public property | ItemInt32 | 获取指定索引的元素
Public property | LockAllAttributesExcept | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockAttributes | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockElements | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockItem | 获取或设置一个值，该值指示是否已锁定该元素。 (Inherited from ConfigurationElement.)
Protected property | Properties | 获取属性的集合。 (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | 在派生的类中重写时，获取或设置 ConfigurationElement 的名称，以便在 ConfigurationElementCollection 中与移除操作关联。 (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | 获取用于同步对 ConfigurationElementCollection 的访问的对象。 (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | 获取一个值，该值指示尝试向 ConfigurationElementCollection 添加重复的 ConfigurationElement 是否会导致引发异常。 (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

Adf.Config Namespace


IpGroupCollection Constructor

IpGroupCollection Constructor
Initializes a new instance of the IpGroupCollection class

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IpGroupCollection()
Public Sub New
public:
IpGroupCollection()
new : unit -> IpGroupCollection
See Also

Reference

IpGroupCollection Class
Adf.Config Namespace


IpGroupCollection Methods

IpGroupCollection Methods

The IpGroupCollection type exposes the following members.

Methods
 | Name | Description
Protected method | BaseAdd(ConfigurationElement) | 向 ConfigurationElementCollection 添加配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | 向配置元素集合添加配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | 向配置元素集合添加配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | 从集合中移除所有配置元素对象。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | 返回具有指定键的配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | 获取位于指定索引位置的配置元素。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | 返回 ConfigurationElementCollection 中包含的所有配置元素的键数组。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | 获取位于指定索引位置的 ConfigurationElement 的键。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | 指定 ConfigurationElement 的索引。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | 获取一个值，该值指示是否已从 ConfigurationElementCollection 中移除具有指定键的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | 从集合中移除 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | 移除位于指定索引位置的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Public method | CopyTo | 将 ConfigurationElementCollection 的内容复制到数组。 (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | 创建新元素 (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | 在派生的类中重写时，创建新的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | DeserializeElement | 读取配置文件中的 XML。 (Inherited from ConfigurationElement.)
Public method | Equals | 将 ConfigurationElementCollection 与指定的对象进行比较。 (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Protected method | GetElementKey | 获取键 (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | 获取用于循环访问 ConfigurationElementCollection 的 IEnumerator。 (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | 获取表示 ConfigurationElementCollection 实例的唯一值。 (Inherited from ConfigurationElementCollection.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 将 ConfigurationElement 对象设置为其初始状态。 (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | 用于初始化 ConfigurationElement 对象的默认值集。 (Inherited from ConfigurationElement.)
Protected method | IsElementName | 指示指定的 ConfigurationElement 是否存在于 ConfigurationElementCollection 中。 (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | 获取一个值，该值指示是否可从 ConfigurationElementCollection 中移除指定的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | 在派生的类中重写时，指示从最后一次保存或加载此 ConfigurationElementCollection 后是否对其进行了修改。 (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | 获取一个值，该值指示 ConfigurationElementCollection 对象是否为只读。 (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | 将此 ConfigurationElement 对象以及所有子元素中无效属性的错误添加到传递的列表中。 (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | 获取一个值，该值指示反序列化过程中是否遇到未知属性。 (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | 导致配置系统引发异常。 (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | 未找到所需属性时引发异常。 (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | 反序列化后调用。 (Inherited from ConfigurationElement.)
Protected method | PreSerialize | 序列化前调用。 (Inherited from ConfigurationElement.)
Protected method | Reset | 在派生的类中重写时，将 ConfigurationElementCollection 重置为其未被修改时的状态。 (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | 在派生的类中重写时，将 IsModified 属性的值重置为 false。 (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | 在派生的类中重写时，将配置数据写入配置文件中的 XML 元素。 (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | 当在派生类中实现后，将此配置元素的外部标记写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | 将属性设置为指定值。 (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | 为 ConfigurationElementCollection 对象和所有子元素设置 IsReadOnly 属性。 (Inherited from ConfigurationElementCollection.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | Unmerge | 反转将配置层次结构的不同级别配置的信息合并在一起的效果 (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

IpGroupCollection Class
Adf.Config Namespace


IpGroupCollection.CreateNewElement Method

IpGroupCollectionCreateNewElement Method
Overload List
 | Name | Description
Protected method | CreateNewElement | 创建新元素 (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | 在派生的类中重写时，创建新的 ConfigurationElement。 (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

IpGroupCollection Class
Adf.Config Namespace


IpGroupCollection.CreateNewElement Method

IpGroupCollectionCreateNewElement Method
创建新元素

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected override ConfigurationElement CreateNewElement()
Protected Overrides Function CreateNewElement As ConfigurationElement
protected:
virtual ConfigurationElement^ CreateNewElement() override
abstract CreateNewElement : unit -> ConfigurationElement
override CreateNewElement : unit -> ConfigurationElement

Return Value

Type: ConfigurationElement

[Missing <returns> documentation for "M:Adf.Config.IpGroupCollection.CreateNewElement"]

See Also

Reference

IpGroupCollection Class
CreateNewElement Overload
Adf.Config Namespace


IpGroupCollection.GetElementKey Method

IpGroupCollectionGetElementKey Method
获取键

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected override Object GetElementKey(
    ConfigurationElement element
)
Protected Overrides Function GetElementKey (
    element As ConfigurationElement
) As Object
protected:
virtual Object^ GetElementKey(
    ConfigurationElement^ element
) override
abstract GetElementKey :
        element : ConfigurationElement -> Object
override GetElementKey :
        element : ConfigurationElement -> Object

Parameters

element
Type: System.ConfigurationConfigurationElement

[Missing <param name="element"/> documentation for "M:Adf.Config.IpGroupCollection.GetElementKey(System.Configuration.ConfigurationElement)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Config.IpGroupCollection.GetElementKey(System.Configuration.ConfigurationElement)"]

See Also

Reference

IpGroupCollection Class
Adf.Config Namespace


IpGroupCollection Properties

IpGroupCollection Properties

The IpGroupCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AddElementName | 在派生的类中重写时，获取或设置 ConfigurationElement 的名称，以便在 ConfigurationElementCollection 中与添加操作关联。 (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | 在派生的类中重写时，获取或设置 ConfigurationElement 的名称，以便在 ConfigurationElementCollection 中与清除操作关联。 (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | 获取 ConfigurationElementCollection 的类型。 (Inherited from ConfigurationElementCollection.)
Public property | Count | 获取集合中的元素数。 (Inherited from ConfigurationElementCollection.)
Public property | ElementInformation | 获取包含 ConfigurationElement 对象的不可自定义的信息和功能的 ElementInformation 对象。 (Inherited from ConfigurationElement.)
Protected property | ElementName | 获取在派生的类中重写时用于标识配置文件中此元素集合的名称。 (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | 获取本身表示 ConfigurationElement 对象的 ConfigurationElementProperty 对象。 (Inherited from ConfigurationElement.)
Public property | EmitClear | 获取或设置一个值，该值指定是否已清除集合。 (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | 获取 ConfigurationElement 对象的 ContextInformation 对象。 (Inherited from ConfigurationElement.)
Public property | IsSynchronized | 获取一个值，该值指示对集合的访问是否为同步的（线程安全）。 (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | 获取或设置此配置元素的属性 (Property) 或属性 (Attribute)。 (Inherited from ConfigurationElement.)
Protected property | ItemString | 获取或设置此配置元素的属性 (Property) 、属性 (Attribute) 或子元素。 (Inherited from ConfigurationElement.)
Public property | ItemInt32 | 获取指定索引的元素
Public property | LockAllAttributesExcept | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockAttributes | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockElements | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockItem | 获取或设置一个值，该值指示是否已锁定该元素。 (Inherited from ConfigurationElement.)
Protected property | Properties | 获取属性的集合。 (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | 在派生的类中重写时，获取或设置 ConfigurationElement 的名称，以便在 ConfigurationElementCollection 中与移除操作关联。 (Inherited from ConfigurationElementCollection.)
Public property | SyncRoot | 获取用于同步对 ConfigurationElementCollection 的访问的对象。 (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | 获取一个值，该值指示尝试向 ConfigurationElementCollection 添加重复的 ConfigurationElement 是否会导致引发异常。 (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

IpGroupCollection Class
Adf.Config Namespace


IpGroupCollection.Item Property

IpGroupCollectionItem Property
Overload List
 | Name | Description
Protected property | ItemConfigurationProperty | 获取或设置此配置元素的属性 (Property) 或属性 (Attribute)。 (Inherited from ConfigurationElement.)
Protected property | ItemString | 获取或设置此配置元素的属性 (Property) 、属性 (Attribute) 或子元素。 (Inherited from ConfigurationElement.)
Public property | ItemInt32 | 获取指定索引的元素
Top
See Also

Reference

IpGroupCollection Class
Adf.Config Namespace


IpGroupCollection.Item Property (Int32)

IpGroupCollectionItem Property (Int32)
获取指定索引的元素

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IpGroupElement this[
    int index
] { get; }
Public ReadOnly Default Property Item (
    index As Integer
) As IpGroupElement
    Get
public:
property IpGroupElement^ default[int index] {
    IpGroupElement^ get (int index);
}
member Item : IpGroupElement with get

Parameters

index
Type: SystemInt32
索引

Property Value

Type: IpGroupElement
See Also

Reference

IpGroupCollection Class
Item Overload
Adf.Config Namespace


IpGroupElement Class

IpGroupElement Class
IP组客户端配置元素
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
Adf.ConfigIpGroupElement

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class IpGroupElement : ConfigurationElement
Public Class IpGroupElement
    Inherits ConfigurationElement
public ref class IpGroupElement : public ConfigurationElement
type IpGroupElement =
    class
        inherit ConfigurationElement
    end

The IpGroupElement type exposes the following members.

Constructors
 | Name | Description
Public method | IpGroupElement | Initializes a new instance of the IpGroupElement class
Top
Methods
 | Name | Description
Protected method | DeserializeElement | 读取配置文件中的 XML。 (Inherited from ConfigurationElement.)
Public method | Equals | 将当前 ConfigurationElement 实例与指定的对象进行比较。 (Inherited from ConfigurationElement.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 获取一个唯一值，表示当前 ConfigurationElement 实例。 (Inherited from ConfigurationElement.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 将 ConfigurationElement 对象设置为其初始状态。 (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | 用于初始化 ConfigurationElement 对象的默认值集。 (Inherited from ConfigurationElement.)
Protected method | IsModified | 指示此配置元素自上次被保存或加载后，直到在派生类中被实现时，是否已经更改。 (Inherited from ConfigurationElement.)
Public method | IsReadOnly | 获取一个值，该值指示 ConfigurationElement 对象是否为只读。 (Inherited from ConfigurationElement.)
Protected method | ListErrors | 将此 ConfigurationElement 对象以及所有子元素中无效属性的错误添加到传递的列表中。 (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | 获取一个值，该值指示反序列化过程中是否遇到未知属性。 (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | 获取一个值，该值指示反序列化过程中是否遇到未知元素。 (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | 未找到所需属性时引发异常。 (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | 反序列化后调用。 (Inherited from ConfigurationElement.)
Protected method | PreSerialize | 序列化前调用。 (Inherited from ConfigurationElement.)
Protected method | Reset | 重置 ConfigurationElement 对象的内部状态，包括锁和属性集合。 (Inherited from ConfigurationElement.)
Protected method | ResetModified | 在派生类中实现时，将 IsModified 方法的值重置为 false。 (Inherited from ConfigurationElement.)
Protected method | SerializeElement | 当在派生类中实现后，将此配置元素的内容写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | 当在派生类中实现后，将此配置元素的外部标记写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | 将属性设置为指定值。 (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | 设置 ConfigurationElement 对象及所有子元素的 IsReadOnly 属性。 (Inherited from ConfigurationElement.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | Unmerge | 修改 ConfigurationElement 对象以移除所有将不被保存的值。 (Inherited from ConfigurationElement.)
Top
Properties
 | Name | Description
Public property | Description | 描述
Public property | ElementInformation | 获取包含 ConfigurationElement 对象的不可自定义的信息和功能的 ElementInformation 对象。 (Inherited from ConfigurationElement.)
Protected property | ElementProperty | 获取本身表示 ConfigurationElement 对象的 ConfigurationElementProperty 对象。 (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | 获取 ConfigurationElement 对象的 ContextInformation 对象。 (Inherited from ConfigurationElement.)
Public property | Ip | Ip Address
Protected property | ItemConfigurationProperty | 获取或设置此配置元素的属性 (Property) 或属性 (Attribute)。 (Inherited from ConfigurationElement.)
Protected property | ItemString | 获取或设置此配置元素的属性 (Property) 、属性 (Attribute) 或子元素。 (Inherited from ConfigurationElement.)
Public property | Level | 级别
Public property | LockAllAttributesExcept | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockAttributes | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockElements | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockItem | 获取或设置一个值，该值指示是否已锁定该元素。 (Inherited from ConfigurationElement.)
Public property | Port | 端口
Protected property | Properties | 获取属性的集合。 (Inherited from ConfigurationElement.)
Top
See Also

Reference

Adf.Config Namespace


IpGroupElement Constructor

IpGroupElement Constructor
Initializes a new instance of the IpGroupElement class

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IpGroupElement()
Public Sub New
public:
IpGroupElement()
new : unit -> IpGroupElement
See Also

Reference

IpGroupElement Class
Adf.Config Namespace


IpGroupElement Methods

IpGroupElement Methods

The IpGroupElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | 读取配置文件中的 XML。 (Inherited from ConfigurationElement.)
Public method | Equals | 将当前 ConfigurationElement 实例与指定的对象进行比较。 (Inherited from ConfigurationElement.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 获取一个唯一值，表示当前 ConfigurationElement 实例。 (Inherited from ConfigurationElement.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 将 ConfigurationElement 对象设置为其初始状态。 (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | 用于初始化 ConfigurationElement 对象的默认值集。 (Inherited from ConfigurationElement.)
Protected method | IsModified | 指示此配置元素自上次被保存或加载后，直到在派生类中被实现时，是否已经更改。 (Inherited from ConfigurationElement.)
Public method | IsReadOnly | 获取一个值，该值指示 ConfigurationElement 对象是否为只读。 (Inherited from ConfigurationElement.)
Protected method | ListErrors | 将此 ConfigurationElement 对象以及所有子元素中无效属性的错误添加到传递的列表中。 (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | 获取一个值，该值指示反序列化过程中是否遇到未知属性。 (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | 获取一个值，该值指示反序列化过程中是否遇到未知元素。 (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | 未找到所需属性时引发异常。 (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | 反序列化后调用。 (Inherited from ConfigurationElement.)
Protected method | PreSerialize | 序列化前调用。 (Inherited from ConfigurationElement.)
Protected method | Reset | 重置 ConfigurationElement 对象的内部状态，包括锁和属性集合。 (Inherited from ConfigurationElement.)
Protected method | ResetModified | 在派生类中实现时，将 IsModified 方法的值重置为 false。 (Inherited from ConfigurationElement.)
Protected method | SerializeElement | 当在派生类中实现后，将此配置元素的内容写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | 当在派生类中实现后，将此配置元素的外部标记写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | 将属性设置为指定值。 (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | 设置 ConfigurationElement 对象及所有子元素的 IsReadOnly 属性。 (Inherited from ConfigurationElement.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | Unmerge | 修改 ConfigurationElement 对象以移除所有将不被保存的值。 (Inherited from ConfigurationElement.)
Top
See Also

Reference

IpGroupElement Class
Adf.Config Namespace


IpGroupElement Properties

IpGroupElement Properties

The IpGroupElement type exposes the following members.

Properties
 | Name | Description
Public property | Description | 描述
Public property | ElementInformation | 获取包含 ConfigurationElement 对象的不可自定义的信息和功能的 ElementInformation 对象。 (Inherited from ConfigurationElement.)
Protected property | ElementProperty | 获取本身表示 ConfigurationElement 对象的 ConfigurationElementProperty 对象。 (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | 获取 ConfigurationElement 对象的 ContextInformation 对象。 (Inherited from ConfigurationElement.)
Public property | Ip | Ip Address
Protected property | ItemConfigurationProperty | 获取或设置此配置元素的属性 (Property) 或属性 (Attribute)。 (Inherited from ConfigurationElement.)
Protected property | ItemString | 获取或设置此配置元素的属性 (Property) 、属性 (Attribute) 或子元素。 (Inherited from ConfigurationElement.)
Public property | Level | 级别
Public property | LockAllAttributesExcept | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockAttributes | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockElements | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockItem | 获取或设置一个值，该值指示是否已锁定该元素。 (Inherited from ConfigurationElement.)
Public property | Port | 端口
Protected property | Properties | 获取属性的集合。 (Inherited from ConfigurationElement.)
Top
See Also

Reference

IpGroupElement Class
Adf.Config Namespace


IpGroupElement.Description Property

IpGroupElementDescription Property
描述

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

IpGroupElement Class
Adf.Config Namespace


IpGroupElement.Ip Property

IpGroupElementIp Property
Ip Address

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Ip { get; set; }
Public Property Ip As String
    Get
    Set
public:
property String^ Ip {
    String^ get ();
    void set (String^ value);
}
member Ip : string with get, set

Property Value

Type: String
See Also

Reference

IpGroupElement Class
Adf.Config Namespace


IpGroupElement.Level Property

IpGroupElementLevel Property
级别

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set
public:
property int Level {
    int get ();
    void set (int value);
}
member Level : int with get, set

Property Value

Type: Int32
See Also

Reference

IpGroupElement Class
Adf.Config Namespace


IpGroupElement.Port Property

IpGroupElementPort Property
端口

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

IpGroupElement Class
Adf.Config Namespace


IpGroupSection Class

IpGroupSection Class
IP组配置节解释器
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
Adf.ConfigIpGroupSection

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class IpGroupSection : ConfigurationSection
Public Class IpGroupSection
    Inherits ConfigurationSection
public ref class IpGroupSection : public ConfigurationSection
type IpGroupSection =
    class
        inherit ConfigurationSection
    end

The IpGroupSection type exposes the following members.

Constructors
 | Name | Description
Public method | IpGroupSection | Initializes a new instance of the IpGroupSection class
Top
Methods
 | Name | Description
Protected method | DeserializeElement | 读取配置文件中的 XML。 (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | 读取配置文件中的 XML。 (Inherited from ConfigurationSection.)
Public method | Equals | 将当前 ConfigurationElement 实例与指定的对象进行比较。 (Inherited from ConfigurationElement.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 获取一个唯一值，表示当前 ConfigurationElement 实例。 (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | 在派生的类中重写时返回自定义对象。 (Inherited from ConfigurationSection.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 将 ConfigurationElement 对象设置为其初始状态。 (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | 用于初始化 ConfigurationElement 对象的默认值集。 (Inherited from ConfigurationElement.)
Protected method | IsModified | 指示自上次在派生类中实现此配置元素时保存或加载以来是否对其进行过修改。 (Inherited from ConfigurationSection.)
Public method | IsReadOnly | 获取一个值，该值指示 ConfigurationElement 对象是否为只读。 (Inherited from ConfigurationElement.)
Protected method | ListErrors | 将此 ConfigurationElement 对象以及所有子元素中无效属性的错误添加到传递的列表中。 (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | 获取一个值，该值指示反序列化过程中是否遇到未知属性。 (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | 获取一个值，该值指示反序列化过程中是否遇到未知元素。 (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | 未找到所需属性时引发异常。 (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | 反序列化后调用。 (Inherited from ConfigurationElement.)
Protected method | PreSerialize | 序列化前调用。 (Inherited from ConfigurationElement.)
Protected method | Reset | 重置 ConfigurationElement 对象的内部状态，包括锁和属性集合。 (Inherited from ConfigurationElement.)
Protected method | ResetModified | 在派生类中实现时，将 IsModified 方法的值重置为 false。 (Inherited from ConfigurationSection.)
Protected method | SerializeElement | 当在派生类中实现后，将此配置元素的内容写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SerializeSection | 创建一个包含 ConfigurationSection 对象的分离视图的 XML 字符串，作为单独的节写入到文件中。 (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | 当在派生类中实现后，将此配置元素的外部标记写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | 将属性设置为指定值。 (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | 设置 ConfigurationElement 对象及所有子元素的 IsReadOnly 属性。 (Inherited from ConfigurationElement.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | Unmerge | 修改 ConfigurationElement 对象以移除所有将不被保存的值。 (Inherited from ConfigurationElement.)
Top
Properties
 | Name | Description
Public property | Check | 检测间隔(秒)
Public property | Description | 本地描述
Public property | ElementInformation | 获取包含 ConfigurationElement 对象的不可自定义的信息和功能的 ElementInformation 对象。 (Inherited from ConfigurationElement.)
Protected property | ElementProperty | 获取本身表示 ConfigurationElement 对象的 ConfigurationElementProperty 对象。 (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | 获取 ConfigurationElement 对象的 ContextInformation 对象。 (Inherited from ConfigurationElement.)
Public property | Hash | 哈希获取时的虚拟节点数
Public property | IpList | Ip列表
Protected property | ItemConfigurationProperty | 获取或设置此配置元素的属性 (Property) 或属性 (Attribute)。 (Inherited from ConfigurationElement.)
Protected property | ItemString | 获取或设置此配置元素的属性 (Property) 、属性 (Attribute) 或子元素。 (Inherited from ConfigurationElement.)
Public property | Level | 本地级别
Public property | LockAllAttributesExcept | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockAttributes | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockElements | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockItem | 获取或设置一个值，该值指示是否已锁定该元素。 (Inherited from ConfigurationElement.)
Protected property | Properties | 获取属性的集合。 (Inherited from ConfigurationElement.)
Public property | SectionInformation | 获取一个 SectionInformation 对象，该对象包含 ConfigurationSection 对象的不可自定义的信息和功能。 (Inherited from ConfigurationSection.)
Top
See Also

Reference

Adf.Config Namespace


IpGroupSection Constructor

IpGroupSection Constructor
Initializes a new instance of the IpGroupSection class

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IpGroupSection()
Public Sub New
public:
IpGroupSection()
new : unit -> IpGroupSection
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


IpGroupSection Methods

IpGroupSection Methods

The IpGroupSection type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | 读取配置文件中的 XML。 (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | 读取配置文件中的 XML。 (Inherited from ConfigurationSection.)
Public method | Equals | 将当前 ConfigurationElement 实例与指定的对象进行比较。 (Inherited from ConfigurationElement.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 获取一个唯一值，表示当前 ConfigurationElement 实例。 (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | 在派生的类中重写时返回自定义对象。 (Inherited from ConfigurationSection.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 将 ConfigurationElement 对象设置为其初始状态。 (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | 用于初始化 ConfigurationElement 对象的默认值集。 (Inherited from ConfigurationElement.)
Protected method | IsModified | 指示自上次在派生类中实现此配置元素时保存或加载以来是否对其进行过修改。 (Inherited from ConfigurationSection.)
Public method | IsReadOnly | 获取一个值，该值指示 ConfigurationElement 对象是否为只读。 (Inherited from ConfigurationElement.)
Protected method | ListErrors | 将此 ConfigurationElement 对象以及所有子元素中无效属性的错误添加到传递的列表中。 (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | 获取一个值，该值指示反序列化过程中是否遇到未知属性。 (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | 获取一个值，该值指示反序列化过程中是否遇到未知元素。 (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | 未找到所需属性时引发异常。 (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | 反序列化后调用。 (Inherited from ConfigurationElement.)
Protected method | PreSerialize | 序列化前调用。 (Inherited from ConfigurationElement.)
Protected method | Reset | 重置 ConfigurationElement 对象的内部状态，包括锁和属性集合。 (Inherited from ConfigurationElement.)
Protected method | ResetModified | 在派生类中实现时，将 IsModified 方法的值重置为 false。 (Inherited from ConfigurationSection.)
Protected method | SerializeElement | 当在派生类中实现后，将此配置元素的内容写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SerializeSection | 创建一个包含 ConfigurationSection 对象的分离视图的 XML 字符串，作为单独的节写入到文件中。 (Inherited from ConfigurationSection.)
Protected method | SerializeToXmlElement | 当在派生类中实现后，将此配置元素的外部标记写入配置文件。 (Inherited from ConfigurationElement.)
Protected method | SetPropertyValue | 将属性设置为指定值。 (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | 设置 ConfigurationElement 对象及所有子元素的 IsReadOnly 属性。 (Inherited from ConfigurationElement.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | Unmerge | 修改 ConfigurationElement 对象以移除所有将不被保存的值。 (Inherited from ConfigurationElement.)
Top
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


IpGroupSection Properties

IpGroupSection Properties

The IpGroupSection type exposes the following members.

Properties
 | Name | Description
Public property | Check | 检测间隔(秒)
Public property | Description | 本地描述
Public property | ElementInformation | 获取包含 ConfigurationElement 对象的不可自定义的信息和功能的 ElementInformation 对象。 (Inherited from ConfigurationElement.)
Protected property | ElementProperty | 获取本身表示 ConfigurationElement 对象的 ConfigurationElementProperty 对象。 (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | 获取 ConfigurationElement 对象的 ContextInformation 对象。 (Inherited from ConfigurationElement.)
Public property | Hash | 哈希获取时的虚拟节点数
Public property | IpList | Ip列表
Protected property | ItemConfigurationProperty | 获取或设置此配置元素的属性 (Property) 或属性 (Attribute)。 (Inherited from ConfigurationElement.)
Protected property | ItemString | 获取或设置此配置元素的属性 (Property) 、属性 (Attribute) 或子元素。 (Inherited from ConfigurationElement.)
Public property | Level | 本地级别
Public property | LockAllAttributesExcept | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockAttributes | 获取被锁定的属性的集合。 (Inherited from ConfigurationElement.)
Public property | LockElements | 获取被锁定的元素的集合。 (Inherited from ConfigurationElement.)
Public property | LockItem | 获取或设置一个值，该值指示是否已锁定该元素。 (Inherited from ConfigurationElement.)
Protected property | Properties | 获取属性的集合。 (Inherited from ConfigurationElement.)
Public property | SectionInformation | 获取一个 SectionInformation 对象，该对象包含 ConfigurationSection 对象的不可自定义的信息和功能。 (Inherited from ConfigurationSection.)
Top
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


IpGroupSection.Check Property

IpGroupSectionCheck Property
检测间隔(秒)

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Check { get; set; }
Public Property Check As Integer
    Get
    Set
public:
property int Check {
    int get ();
    void set (int value);
}
member Check : int with get, set

Property Value

Type: Int32
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


IpGroupSection.Description Property

IpGroupSectionDescription Property
本地描述

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


IpGroupSection.Hash Property

IpGroupSectionHash Property
哈希获取时的虚拟节点数

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Hash { get; set; }
Public Property Hash As Integer
    Get
    Set
public:
property int Hash {
    int get ();
    void set (int value);
}
member Hash : int with get, set

Property Value

Type: Int32
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


IpGroupSection.IpList Property

IpGroupSectionIpList Property
Ip列表

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IpGroupCollection IpList { get; }
Public ReadOnly Property IpList As IpGroupCollection
    Get
public:
property IpGroupCollection^ IpList {
    IpGroupCollection^ get ();
}
member IpList : IpGroupCollection with get

Property Value

Type: IpGroupCollection
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


IpGroupSection.Level Property

IpGroupSectionLevel Property
本地级别

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set
public:
property int Level {
    int get ();
    void set (int value);
}
member Level : int with get, set

Property Value

Type: Int32
See Also

Reference

IpGroupSection Class
Adf.Config Namespace


RegularConfig Class

RegularConfig Class
正则配置
Inheritance Hierarchy
SystemObject
Adf.ConfigConfigBase String
Adf.ConfigConfigValue
Adf.ConfigRegularConfig

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class RegularConfig : ConfigValue
Public Class RegularConfig
    Inherits ConfigValue
public ref class RegularConfig : public ConfigValue
type RegularConfig =
    class
        inherit ConfigValue
    end

The RegularConfig type exposes the following members.

Constructors
 | Name | Description
Public method | RegularConfig | Initializes a new instance of the RegularConfig class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | load config (Inherited from ConfigBaseT.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项 (Inherited from ConfigValue.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
Fields
Name | Description
Instance | 获取配置实例
Top
Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | 配置文件名称 (Overrides ConfigBaseTFileName.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | ItemString | 获取指定名称配置 (Inherited from ConfigBaseT.)
Public property | ItemString, Object | 获取指定的项并格式化串 (Inherited from ConfigValue.)
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

Adf.Config Namespace


RegularConfig Constructor

RegularConfig Constructor
Initializes a new instance of the RegularConfig class

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public RegularConfig()
Public Sub New
public:
RegularConfig()
new : unit -> RegularConfig
See Also

Reference

RegularConfig Class
Adf.Config Namespace


RegularConfig Fields

RegularConfig Fields

The RegularConfig type exposes the following members.

Fields
Name | Description
Instance | 获取配置实例
Top
See Also

Reference

RegularConfig Class
Adf.Config Namespace


RegularConfig.Instance Field

RegularConfigInstance Field
获取配置实例

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly RegularConfig Instance
Public Shared ReadOnly Instance As RegularConfig
public:
static initonly RegularConfig^ Instance
static val Instance: RegularConfig

Field Value

Type: RegularConfig
See Also

Reference

RegularConfig Class
Adf.Config Namespace


RegularConfig Methods

RegularConfig Methods

The RegularConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | load config (Inherited from ConfigBaseT.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | 新项 (Inherited from ConfigValue.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
See Also

Reference

RegularConfig Class
Adf.Config Namespace


RegularConfig Properties

RegularConfig Properties

The RegularConfig type exposes the following members.

Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | 配置文件名称 (Overrides ConfigBaseTFileName.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | ItemString | 获取指定名称配置 (Inherited from ConfigBaseT.)
Public property | ItemString, Object | 获取指定的项并格式化串 (Inherited from ConfigValue.)
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

RegularConfig Class
Adf.Config Namespace


RegularConfig.FileName Property

RegularConfigFileName Property
配置文件名称

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string FileName { get; }
Public Overrides ReadOnly Property FileName As String
    Get
public:
virtual property String^ FileName {
    String^ get () override;
}
abstract FileName : string with get
override FileName : string with get

Property Value

Type: String
See Also

Reference

RegularConfig Class
Adf.Config Namespace


ServerConfig Class

ServerConfig Class
Server Config Item
Inheritance Hierarchy
SystemObject
Adf.ConfigConfigBase ServerConfigItem
Adf.ConfigServerConfig

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ServerConfig : ConfigBase<ServerConfigItem>
Public Class ServerConfig
    Inherits ConfigBase(Of ServerConfigItem)
public ref class ServerConfig : public ConfigBase<ServerConfigItem^>
type ServerConfig =
    class
        inherit ConfigBase<ServerConfigItem>
    end

The ServerConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | override root init (Overrides ConfigBaseTFileLoad(XmlDocument).)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | new config (Overrides ConfigBaseTNewItem(XmlNode).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
Fields
Name | Description
Instance | 获取配置实例
Top
Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | config file name (Overrides ConfigBaseTFileName.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | Item | 获取指定名称配置 (Inherited from ConfigBaseT.)
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

Adf.Config Namespace


ServerConfig Fields

ServerConfig Fields

The ServerConfig type exposes the following members.

Fields
Name | Description
Instance | 获取配置实例
Top
See Also

Reference

ServerConfig Class
Adf.Config Namespace


ServerConfig.Instance Field

ServerConfigInstance Field
获取配置实例

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly ServerConfig Instance
Public Shared ReadOnly Instance As ServerConfig
public:
static initonly ServerConfig^ Instance
static val Instance: ServerConfig

Field Value

Type: ServerConfig
See Also

Reference

ServerConfig Class
Adf.Config Namespace


ServerConfig Methods

ServerConfig Methods

The ServerConfig type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exists | 是否存在某一配置 (Inherited from ConfigBaseT.)
Protected method | FileLoad | override root init (Overrides ConfigBaseTFileLoad(XmlDocument).)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetItem | get config (Inherited from ConfigBaseT.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Init | 初始化 (Inherited from ConfigBaseT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | NewItem | new config (Overrides ConfigBaseTNewItem(XmlNode).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | TryGet | 尝试获取 (Inherited from ConfigBaseT.)
Top
See Also

Reference

ServerConfig Class
Adf.Config Namespace


ServerConfig.FileLoad Method

ServerConfigFileLoad Method
override root init

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected override void FileLoad(
    XmlDocument document
)
Protected Overrides Sub FileLoad (
    document As XmlDocument
)
protected:
virtual void FileLoad(
    XmlDocument^ document
) override
abstract FileLoad :
        document : XmlDocument -> unit
override FileLoad :
        document : XmlDocument -> unit

Parameters

document
Type: System.XmlXmlDocument

[Missing <param name="document"/> documentation for "M:Adf.Config.ServerConfig.FileLoad(System.Xml.XmlDocument)"]

See Also

Reference

ServerConfig Class
Adf.Config Namespace


ServerConfig.NewItem Method

ServerConfigNewItem Method
new config

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected override ServerConfigItem NewItem(
    XmlNode node
)
Protected Overrides Function NewItem (
    node As XmlNode
) As ServerConfigItem
protected:
virtual ServerConfigItem^ NewItem(
    XmlNode^ node
) override
abstract NewItem :
        node : XmlNode -> ServerConfigItem
override NewItem :
        node : XmlNode -> ServerConfigItem

Parameters

node
Type: System.XmlXmlNode

[Missing <param name="node"/> documentation for "M:Adf.Config.ServerConfig.NewItem(System.Xml.XmlNode)"]

Return Value

Type: ServerConfigItem

[Missing <returns> documentation for "M:Adf.Config.ServerConfig.NewItem(System.Xml.XmlNode)"]

See Also

Reference

ServerConfig Class
Adf.Config Namespace


ServerConfig Properties

ServerConfig Properties

The ServerConfig type exposes the following members.

Properties
 | Name | Description
Public property | FileExist | 文件是否存在 (Inherited from ConfigBaseT.)
Public property | FileName | config file name (Overrides ConfigBaseTFileName.)
Public property | FilePath | 配置文件路径 (Inherited from ConfigBaseT.)
Public property | Item | 获取指定名称配置 (Inherited from ConfigBaseT.)
Protected property | Items | 配置项 (Inherited from ConfigBaseT.)
Public property | LocalFileExist | 本地文件是否存在 (Inherited from ConfigBaseT.)
Public property | LocalFilePath | 本地文件路径配置 (Inherited from ConfigBaseT.)
Top
See Also

Reference

ServerConfig Class
Adf.Config Namespace


ServerConfig.FileName Property

ServerConfigFileName Property
config file name

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string FileName { get; }
Public Overrides ReadOnly Property FileName As String
    Get
public:
virtual property String^ FileName {
    String^ get () override;
}
abstract FileName : string with get
override FileName : string with get

Property Value

Type: String
See Also

Reference

ServerConfig Class
Adf.Config Namespace


ServerConfigItem Class

ServerConfigItem Class
Server Config Item
Inheritance Hierarchy
SystemObject
Adf.ConfigServerConfigItem

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ServerConfigItem
Public Class ServerConfigItem
public ref class ServerConfigItem
type ServerConfigItem =  class end

The ServerConfigItem type exposes the following members.

Constructors
 | Name | Description
Public method | ServerConfigItem | Initializes a new instance of the ServerConfigItem class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Description | description
Public property | Ip | Ip Address
Public property | Level | config level
Public property | Port | port
Top
See Also

Reference

Adf.Config Namespace


ServerConfigItem Constructor

ServerConfigItem Constructor
Initializes a new instance of the ServerConfigItem class

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ServerConfigItem()
Public Sub New
public:
ServerConfigItem()
new : unit -> ServerConfigItem
See Also

Reference

ServerConfigItem Class
Adf.Config Namespace


ServerConfigItem Methods

ServerConfigItem Methods

The ServerConfigItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ServerConfigItem Class
Adf.Config Namespace


ServerConfigItem Properties

ServerConfigItem Properties

The ServerConfigItem type exposes the following members.

Properties
 | Name | Description
Public property | Description | description
Public property | Ip | Ip Address
Public property | Level | config level
Public property | Port | port
Top
See Also

Reference

ServerConfigItem Class
Adf.Config Namespace


ServerConfigItem.Description Property

ServerConfigItemDescription Property
description

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigItem Class
Adf.Config Namespace


ServerConfigItem.Ip Property

ServerConfigItemIp Property
Ip Address

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Ip { get; set; }
Public Property Ip As String
    Get
    Set
public:
property String^ Ip {
    String^ get ();
    void set (String^ value);
}
member Ip : string with get, set

Property Value

Type: String
See Also

Reference

ServerConfigItem Class
Adf.Config Namespace


ServerConfigItem.Level Property

ServerConfigItemLevel Property
config level

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set
public:
property int Level {
    int get ();
    void set (int value);
}
member Level : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerConfigItem Class
Adf.Config Namespace


ServerConfigItem.Port Property

ServerConfigItemPort Property
port

Namespace: Adf.Config
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerConfigItem Class
Adf.Config Namespace


Adf.Db Namespace

Adf.Db Namespace

[Missing <summary> documentation for "N:Adf.Db"]

Classes
 | Class | Description
Public class | Access | Access数据库操作对象
Public class | AccessSqlBuilder | ACCESS 资源产生类
Public class | DbEntity | 对象基类
Public class | DbException | 异常基础类
Public class | DbFactory | 数据操作基类
Public class | DbHelper | DB助手
Public class | DbLogger | 数据库日志管理器
Public class | DbReader | Public Reader
Public class | MySql | MySql 数据操作类
Public class | MySqlBuilder | MySql专用语句生成
Public class | SqlBuilder | 将指定的对象转换为SQL语句
Public class | Sqlite | Sqlite 数据操作类
Public class | SqliteBuilder | Sqlite专用语句生成
Public class | SqlServer | MSSQL数据库基础操作
Interfaces
 | Interface | Description
Public interface | IDbEntity | Support Reader Import Flag
Public interface | IDbFactory | 数据工厂接口
Public interface | IDbReader | Data Object Reader Interface
Enumerations
 | Enumeration | Description
Public enumeration | WhereRelation | 查询关系


Access Class

Access Class
Access数据库操作对象
Inheritance Hierarchy
SystemObject
Adf.DbDbFactory
Adf.DbAccess

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Access : DbFactory, IDbFactory,
    IDisposable
Public Class Access
    Inherits DbFactory
    Implements IDbFactory, IDisposable
public ref class Access : public DbFactory,
    IDbFactory, IDisposable
type Access =
    class
        inherit DbFactory
        interface IDbFactory
        interface IDisposable
    end

The Access type exposes the following members.

Constructors
 | Name | Description
Public method | Access(OleDbConnection) | 创建新的实例
Public method | Access(String) | 根据数据连接字符串创建一个新的数据实列
Top
Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Inherited from DbFactory.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据类型返回可直接用于SQL语句的安全字符串 (Overrides DbFactoryToSafeString(Object, Type).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取数据库连接
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Inherited from DbFactory.)
Public property | SqlBuilder | 已重载 (Overrides DbFactorySqlBuilder.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

Adf.Db Namespace


Access Constructor

Access Constructor
Overload List
 | Name | Description
Public method | Access(OleDbConnection) | 创建新的实例
Public method | Access(String) | 根据数据连接字符串创建一个新的数据实列
Top
See Also

Reference

Access Class
Adf.Db Namespace


Access Constructor (OleDbConnection)

Access Constructor (OleDbConnection)
创建新的实例

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Access(
    OleDbConnection connection
)
Public Sub New (
    connection As OleDbConnection
)
public:
Access(
    OleDbConnection^ connection
)
new :
        connection : OleDbConnection -> Access

Parameters

connection
Type: System.Data.OleDbOleDbConnection
数据库连接
See Also

Reference

Access Class
Access Overload
Adf.Db Namespace


Access Constructor (String)

Access Constructor (String)
根据数据连接字符串创建一个新的数据实列

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Access(
    string connectionstring
)
Public Sub New (
    connectionstring As String
)
public:
Access(
    String^ connectionstring
)
new :
        connectionstring : string -> Access

Parameters

connectionstring
Type: SystemString
数据连接字符串
See Also

Reference

Access Class
Access Overload
Adf.Db Namespace


Access Methods

Access Methods

The Access type exposes the following members.

Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Inherited from DbFactory.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据类型返回可直接用于SQL语句的安全字符串 (Overrides DbFactoryToSafeString(Object, Type).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
See Also

Reference

Access Class
Adf.Db Namespace


Access.ToSafeString Method

AccessToSafeString Method
Overload List
 | Name | Description
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据类型返回可直接用于SQL语句的安全字符串 (Overrides DbFactoryToSafeString(Object, Type).)
Top
See Also

Reference

Access Class
Adf.Db Namespace


Access.ToSafeString Method (Object, Type)

AccessToSafeString Method (Object, Type)
根据类型返回可直接用于SQL语句的安全字符串

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string ToSafeString(
    Object value,
    Type type
)
Public Overrides Function ToSafeString (
    value As Object,
    type As Type
) As String
public:
virtual String^ ToSafeString(
    Object^ value,
    Type^ type
) override
abstract ToSafeString :
        value : Object *
        type : Type -> string
override ToSafeString :
        value : Object *
        type : Type -> string

Parameters

value
Type: SystemObject
数据
type
Type: SystemType
类型

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.Access.ToSafeString(System.Object,System.Type)"]

Implements

IDbFactoryToSafeString(Object, Type)
IDbFactoryToSafeString(Object, Type)
See Also

Reference

Access Class
ToSafeString Overload
Adf.Db Namespace


Access Properties

Access Properties

The Access type exposes the following members.

Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取数据库连接
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Inherited from DbFactory.)
Public property | SqlBuilder | 已重载 (Overrides DbFactorySqlBuilder.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

Access Class
Adf.Db Namespace


Access.Connection Property

AccessConnection Property
获取数据库连接

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public OleDbConnection Connection { get; }
Public ReadOnly Property Connection As OleDbConnection
    Get
public:
property OleDbConnection^ Connection {
    OleDbConnection^ get ();
}
member Connection : OleDbConnection with get

Property Value

Type: OleDbConnection
See Also

Reference

Access Class
Adf.Db Namespace


Access.Name Property

AccessName Property
获取当前操作对象的名称描述

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDbFactoryName
IDbFactoryName
See Also

Reference

Access Class
Adf.Db Namespace


Access.SqlBuilder Property

AccessSqlBuilder Property
已重载

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override SqlBuilder SqlBuilder { get; }
Public Overrides ReadOnly Property SqlBuilder As SqlBuilder
    Get
public:
virtual property SqlBuilder^ SqlBuilder {
    SqlBuilder^ get () override;
}
abstract SqlBuilder : SqlBuilder with get
override SqlBuilder : SqlBuilder with get

Return Value

Type: SqlBuilder

Implements

IDbFactorySqlBuilder
IDbFactorySqlBuilder
See Also

Reference

Access Class
Adf.Db Namespace


AccessSqlBuilder Class

AccessSqlBuilder Class
ACCESS 资源产生类
Inheritance Hierarchy
SystemObject
Adf.DbSqlBuilder
Adf.DbAccessSqlBuilder

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class AccessSqlBuilder : SqlBuilder
Public Class AccessSqlBuilder
    Inherits SqlBuilder
public ref class AccessSqlBuilder : public SqlBuilder
type AccessSqlBuilder =
    class
        inherit SqlBuilder
    end

The AccessSqlBuilder type exposes the following members.

Constructors
 | Name | Description
Protected method | AccessSqlBuilder | 初始化新对象
Top
Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句 (Inherited from SqlBuilder.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql (Inherited from SqlBuilder.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql (Overrides SqlBuilderGetInsert(DbEntity, IDbDataParameter).)
Public method | GetSelect | get select sql (Inherited from SqlBuilder.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql (Overrides SqlBuilderGetUpdate(DbEntity, DbEntity, IDbDataParameter).)
Public method | GetWhere | 获取查询条件 (Overrides SqlBuilderGetWhere(DbEntity, IDbDataParameter).)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句 (Overrides SqlBuilderPageSql(Int32, Int32, String, String, String, String, String, String, Boolean).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | Factory | 工厂对象 (Inherited from SqlBuilder.)
Top
See Also

Reference

Adf.Db Namespace


AccessSqlBuilder Constructor

AccessSqlBuilder Constructor
初始化新对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected AccessSqlBuilder(
    DbFactory factory
)
Protected Sub New (
    factory As DbFactory
)
protected:
AccessSqlBuilder(
    DbFactory^ factory
)
new :
        factory : DbFactory -> AccessSqlBuilder

Parameters

factory
Type: Adf.DbDbFactory
当前操作对象
See Also

Reference

AccessSqlBuilder Class
Adf.Db Namespace


AccessSqlBuilder Methods

AccessSqlBuilder Methods

The AccessSqlBuilder type exposes the following members.

Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句 (Inherited from SqlBuilder.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql (Inherited from SqlBuilder.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql (Overrides SqlBuilderGetInsert(DbEntity, IDbDataParameter).)
Public method | GetSelect | get select sql (Inherited from SqlBuilder.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql (Overrides SqlBuilderGetUpdate(DbEntity, DbEntity, IDbDataParameter).)
Public method | GetWhere | 获取查询条件 (Overrides SqlBuilderGetWhere(DbEntity, IDbDataParameter).)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句 (Overrides SqlBuilderPageSql(Int32, Int32, String, String, String, String, String, String, Boolean).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

AccessSqlBuilder Class
Adf.Db Namespace


AccessSqlBuilder.GetInsert Method

AccessSqlBuilderGetInsert Method
get insert sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string GetInsert(
    DbEntity entity,
    out IDbDataParameter[] parameters
)
Public Overrides Function GetInsert (
    entity As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetInsert(
    DbEntity^ entity,
    [OutAttribute] array<IDbDataParameter^>^% parameters
) override
abstract GetInsert :
        entity : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetInsert :
        entity : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

entity
Type: Adf.DbDbEntity

[Missing <param name="entity"/> documentation for "M:Adf.Db.AccessSqlBuilder.GetInsert(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.AccessSqlBuilder.GetInsert(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.AccessSqlBuilder.GetInsert(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

AccessSqlBuilder Class
Adf.Db Namespace


AccessSqlBuilder.GetUpdate Method

AccessSqlBuilderGetUpdate Method
get update sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string GetUpdate(
    DbEntity update,
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overrides Function GetUpdate (
    update As DbEntity,
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetUpdate(
    DbEntity^ update,
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
) override
abstract GetUpdate :
        update : DbEntity *
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetUpdate :
        update : DbEntity *
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

update
Type: Adf.DbDbEntity

[Missing <param name="update"/> documentation for "M:Adf.Db.AccessSqlBuilder.GetUpdate(Adf.Db.DbEntity,Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

where
Type: Adf.DbDbEntity
更新条件
parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.AccessSqlBuilder.GetUpdate(Adf.Db.DbEntity,Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.AccessSqlBuilder.GetUpdate(Adf.Db.DbEntity,Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

AccessSqlBuilder Class
Adf.Db Namespace


AccessSqlBuilder.GetWhere Method

AccessSqlBuilderGetWhere Method
获取查询条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string GetWhere(
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overrides Function GetWhere (
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetWhere(
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
) override
abstract GetWhere :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetWhere :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

where
Type: Adf.DbDbEntity
指定的条件生成对象
parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.AccessSqlBuilder.GetWhere(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.AccessSqlBuilder.GetWhere(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

AccessSqlBuilder Class
Adf.Db Namespace


AccessSqlBuilder.PageSql Method

AccessSqlBuilderPageSql Method
生成分页用Sql语句

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string PageSql(
    int pageindex,
    int pagesize,
    string fields,
    string tablename,
    string condition,
    string orderby,
    string key = "",
    string groupby = "",
    bool distinct = false
)
Public Overrides Function PageSql (
    pageindex As Integer,
    pagesize As Integer,
    fields As String,
    tablename As String,
    condition As String,
    orderby As String,
    Optional key As String = "",
    Optional groupby As String = "",
    Optional distinct As Boolean = false
) As String
public:
virtual String^ PageSql(
    int pageindex,
    int pagesize,
    String^ fields,
    String^ tablename,
    String^ condition,
    String^ orderby,
    String^ key = L"",
    String^ groupby = L"",
    bool distinct = false
) override
abstract PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string
override PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string

Parameters

pageindex
Type: SystemInt32
页序
pagesize
Type: SystemInt32
页大小
fields
Type: SystemString
字段值,前后不带空格,位于 Select 与 From 之间的字段部表示
tablename
Type: SystemString
要进行查询的数据表,可为多个
condition
Type: SystemString
要进行查询的查询串,Where的后缀,如果未有,请设置为 null
orderby
Type: SystemString
排序方法,如果未有排序则为null
key (Optional)
Type: SystemString
键
groupby (Optional)
Type: SystemString
分组,分组请设置为null
distinct (Optional)
Type: SystemBoolean

[Missing <param name="distinct"/> documentation for "M:Adf.Db.AccessSqlBuilder.PageSql(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Type: String
返回生成后的Sql语句
See Also

Reference

AccessSqlBuilder Class
Adf.Db Namespace


AccessSqlBuilder Properties

AccessSqlBuilder Properties

The AccessSqlBuilder type exposes the following members.

Properties
 | Name | Description
Protected property | Factory | 工厂对象 (Inherited from SqlBuilder.)
Top
See Also

Reference

AccessSqlBuilder Class
Adf.Db Namespace


DbEntity Class

DbEntity Class
对象基类
Inheritance Hierarchy
SystemObject
Adf.DbDbEntity

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
[SerializableAttribute]
public class DbEntity : IDbEntity
<SerializableAttribute>
Public Class DbEntity
    Implements IDbEntity
[SerializableAttribute]
public ref class DbEntity : IDbEntity
[<SerializableAttribute>]
type DbEntity =
    class
        interface IDbEntity
    end

The DbEntity type exposes the following members.

Constructors
 | Name | Description
Protected method | DbEntity | 初始化一实例
Top
Methods
 | Name | Description
Public method | Contains | 返回一个值,表示是否已初始或设置过指定名称的属性值
Public method | CopyTo | 将本对象数据复制到指定的对象
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | 获取指定的属性名,如未找到值,则会抛出异常。
Public method | GetT(String) | 获取指定的属性值。
Public method | GetT(String, T) | 获取指定的属性值。
Public method | GetEnumerator | 返回属性玫举值
Public method | GetFieldLength | 获取已设置查询字段长度
Public method | GetFields | 获取要处理的字段列表,零长度则表示处理全部
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInitializePropertyCount | 返回已初始属性个数,包念标量定义与隐含定义
Public method | GetOrderBy | 获取已设置的排序条件
Public method | GetPropertyNames | 返回属性名称集合
Public method | GetSelectSize | 获取已设置的查询条件
Public method | GetString | 获取指定项的字符串格式
Public method | GetTableName | 获取表名
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWhere | 获取已设置的查询条件
Public method | GetWhereRelation | 获取已设置的查询条件
Public method | Initialize | 初始化数据
Public method | IsNull | 判断指定的属性是否为null值
Public method | IsSetFieldLength | 获取是否已有字段查询长度设置
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Remove | 移除指定的已设置属性
Public method | Set | 添加或设置指定的属性
Public method | SetFieldLength | 设置查询字段长度,一般仅在参数查询时需要指定长时才设置该值
Public method | SetFields | 设置要处理的字段列表
Public method | SetOrderBy | 设置排序条件
Public method | SetSelectSize | 设置排序条件
Public method | SetTableName | 设置表名
Public method | SetWhere | 设置排序条件
Public method | SetWhereRelation | 设置查询时的条件关第 未设置查询条件SetWhere(String)时有效，默认为AND关系
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Fields
 | Name | Description
Protected field | TYPE | 当前对象实例
Top
See Also

Reference

Adf.Db Namespace


DbEntity Constructor

DbEntity Constructor
初始化一实例

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected DbEntity()
Protected Sub New
protected:
DbEntity()
new : unit -> DbEntity
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity Fields

DbEntity Fields

The DbEntity type exposes the following members.

Fields
 | Name | Description
Protected field | TYPE | 当前对象实例
Top
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.TYPE Field

DbEntityTYPE Field
当前对象实例

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected readonly Type TYPE
Protected ReadOnly TYPE As Type
protected:
initonly Type^ TYPE
val TYPE: Type

Field Value

Type: Type
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity Methods

DbEntity Methods

The DbEntity type exposes the following members.

Methods
 | Name | Description
Public method | Contains | 返回一个值,表示是否已初始或设置过指定名称的属性值
Public method | CopyTo | 将本对象数据复制到指定的对象
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | 获取指定的属性名,如未找到值,则会抛出异常。
Public method | GetT(String) | 获取指定的属性值。
Public method | GetT(String, T) | 获取指定的属性值。
Public method | GetEnumerator | 返回属性玫举值
Public method | GetFieldLength | 获取已设置查询字段长度
Public method | GetFields | 获取要处理的字段列表,零长度则表示处理全部
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInitializePropertyCount | 返回已初始属性个数,包念标量定义与隐含定义
Public method | GetOrderBy | 获取已设置的排序条件
Public method | GetPropertyNames | 返回属性名称集合
Public method | GetSelectSize | 获取已设置的查询条件
Public method | GetString | 获取指定项的字符串格式
Public method | GetTableName | 获取表名
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWhere | 获取已设置的查询条件
Public method | GetWhereRelation | 获取已设置的查询条件
Public method | Initialize | 初始化数据
Public method | IsNull | 判断指定的属性是否为null值
Public method | IsSetFieldLength | 获取是否已有字段查询长度设置
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Remove | 移除指定的已设置属性
Public method | Set | 添加或设置指定的属性
Public method | SetFieldLength | 设置查询字段长度,一般仅在参数查询时需要指定长时才设置该值
Public method | SetFields | 设置要处理的字段列表
Public method | SetOrderBy | 设置排序条件
Public method | SetSelectSize | 设置排序条件
Public method | SetTableName | 设置表名
Public method | SetWhere | 设置排序条件
Public method | SetWhereRelation | 设置查询时的条件关第 未设置查询条件SetWhere(String)时有效，默认为AND关系
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.Contains Method

DbEntityContains Method
返回一个值,表示是否已初始或设置过指定名称的属性值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool Contains(
    string Name
)
Public Overridable Function Contains (
    Name As String
) As Boolean
public:
virtual bool Contains(
    String^ Name
)
abstract Contains :
        Name : string -> bool
override Contains :
        Name : string -> bool

Parameters

Name
Type: SystemString
属性名称

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Db.DbEntity.Contains(System.String)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.CopyTo Method

DbEntityCopyTo Method
将本对象数据复制到指定的对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void CopyTo(
    DbEntity target
)
Public Overridable Sub CopyTo (
    target As DbEntity
)
public:
virtual void CopyTo(
    DbEntity^ target
)
abstract CopyTo :
        target : DbEntity -> unit
override CopyTo :
        target : DbEntity -> unit

Parameters

target
Type: Adf.DbDbEntity
接收数据的对象
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.Get Method

DbEntityGet Method
Overload List
 | Name | Description
Public method | Get(String) | 获取指定的属性名,如未找到值,则会抛出异常。
Public method | GetT(String) | 获取指定的属性值。
Public method | GetT(String, T) | 获取指定的属性值。
Top
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.Get Method (String)

DbEntityGet Method (String)
获取指定的属性名,如未找到值,则会抛出异常。

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual Object Get(
    string Name
)
Public Overridable Function Get (
    Name As String
) As Object
public:
virtual Object^ Get(
    String^ Name
)
abstract Get :
        Name : string -> Object
override Get :
        Name : string -> Object

Parameters

Name
Type: SystemString
属性名

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.DbEntity.Get(System.String)"]

See Also

Reference

DbEntity Class
Get Overload
Adf.Db Namespace


DbEntity.Get(T) Method (String)

DbEntityGetT Method (String)
获取指定的属性值。

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T Get<T>(
    string name
)

Public Overridable Function Get(Of T) (
    name As String
) As T
public:
generic<typename T>
virtual T Get(
    String^ name
)
abstract Get :
        name : string -> 'T
override Get :
        name : string -> 'T

Parameters

name
Type: SystemString
属性名

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Db.DbEntity.Get``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbEntity.Get``1(System.String)"]

See Also

Reference

DbEntity Class
Get Overload
Adf.Db Namespace


DbEntity.Get(T) Method (String, T)

DbEntityGetT Method (String, T)
获取指定的属性值。

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T Get<T>(
    string name,
    T defaultValue
)

Public Overridable Function Get(Of T) (
    name As String,
    defaultValue As T
) As T
public:
generic<typename T>
virtual T Get(
    String^ name,
    T defaultValue
)
abstract Get :
        name : string *
        defaultValue : 'T -> 'T
override Get :
        name : string *
        defaultValue : 'T -> 'T

Parameters

name
Type: SystemString
属性名
defaultValue
Type: T
为null时或未设置时的默认值

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Db.DbEntity.Get``1(System.String,``0)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbEntity.Get``1(System.String,``0)"]

See Also

Reference

DbEntity Class
Get Overload
Adf.Db Namespace


DbEntity.GetEnumerator Method

DbEntityGetEnumerator Method
返回属性玫举值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DictionaryTKey, TValueEnumerator GetEnumerator()
Public Overridable Function GetEnumerator As DictionaryTKey, TValueEnumerator
public:
virtual DictionaryTKey, TValueEnumerator GetEnumerator()
abstract GetEnumerator : unit -> DictionaryTKey, TValueEnumerator
override GetEnumerator : unit -> DictionaryTKey, TValueEnumerator

Return Value

Type: DictionaryTKey, TValueEnumerator

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetEnumerator"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetFieldLength Method

DbEntityGetFieldLength Method
获取已设置查询字段长度

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int GetFieldLength(
    string fieldName
)
Public Function GetFieldLength (
    fieldName As String
) As Integer
public:
int GetFieldLength(
    String^ fieldName
)
member GetFieldLength :
        fieldName : string -> int

Parameters

fieldName
Type: SystemString
字段名称

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetFieldLength(System.String)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetFields Method

DbEntityGetFields Method
获取要处理的字段列表,零长度则表示处理全部

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string[] GetFields()
Public Function GetFields As String()
public:
array<String^>^ GetFields()
member GetFields : unit -> string[]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetFields"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetInitializePropertyCount Method

DbEntityGetInitializePropertyCount Method
返回已初始属性个数,包念标量定义与隐含定义

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int GetInitializePropertyCount()
Public Overridable Function GetInitializePropertyCount As Integer
public:
virtual int GetInitializePropertyCount()
abstract GetInitializePropertyCount : unit -> int
override GetInitializePropertyCount : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetInitializePropertyCount"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetOrderBy Method

DbEntityGetOrderBy Method
获取已设置的排序条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string GetOrderBy()
Public Function GetOrderBy As String
public:
String^ GetOrderBy()
member GetOrderBy : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetOrderBy"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetPropertyNames Method

DbEntityGetPropertyNames Method
返回属性名称集合

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DictionaryTKey, TValueKeyCollection GetPropertyNames()
Public Overridable Function GetPropertyNames As DictionaryTKey, TValueKeyCollection
public:
virtual DictionaryTKey, TValueKeyCollection^ GetPropertyNames()
abstract GetPropertyNames : unit -> DictionaryTKey, TValueKeyCollection
override GetPropertyNames : unit -> DictionaryTKey, TValueKeyCollection

Return Value

Type: DictionaryTKey, TValueKeyCollection

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetPropertyNames"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetSelectSize Method

DbEntityGetSelectSize Method
获取已设置的查询条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int GetSelectSize()
Public Function GetSelectSize As Integer
public:
int GetSelectSize()
member GetSelectSize : unit -> int

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetSelectSize"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetString Method

DbEntityGetString Method
获取指定项的字符串格式

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string GetString(
    string name
)
Public Overridable Function GetString (
    name As String
) As String
public:
virtual String^ GetString(
    String^ name
)
abstract GetString :
        name : string -> string
override GetString :
        name : string -> string

Parameters

name
Type: SystemString
属性名

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetString(System.String)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetTableName Method

DbEntityGetTableName Method
获取表名

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string GetTableName()
Public Function GetTableName As String
public:
String^ GetTableName()
member GetTableName : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetTableName"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetWhere Method

DbEntityGetWhere Method
获取已设置的查询条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string GetWhere()
Public Function GetWhere As String
public:
String^ GetWhere()
member GetWhere : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetWhere"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.GetWhereRelation Method

DbEntityGetWhereRelation Method
获取已设置的查询条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public WhereRelation GetWhereRelation()
Public Function GetWhereRelation As WhereRelation
public:
WhereRelation GetWhereRelation()
member GetWhereRelation : unit -> WhereRelation

Return Value

Type: WhereRelation

[Missing <returns> documentation for "M:Adf.Db.DbEntity.GetWhereRelation"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.Initialize Method

DbEntityInitialize Method
初始化数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Initialize(
    IDbReader reader
)
Public Overridable Sub Initialize (
    reader As IDbReader
)
public:
virtual void Initialize(
    IDbReader^ reader
)
abstract Initialize :
        reader : IDbReader -> unit
override Initialize :
        reader : IDbReader -> unit

Parameters

reader
Type: Adf.DbIDbReader

[Missing <param name="reader"/> documentation for "M:Adf.Db.DbEntity.Initialize(Adf.Db.IDbReader)"]

Implements

IDbEntityInitialize(IDbReader)
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.IsNull Method

DbEntityIsNull Method
判断指定的属性是否为null值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsNull(
    string name
)
Public Overridable Function IsNull (
    name As String
) As Boolean
public:
virtual bool IsNull(
    String^ name
)
abstract IsNull :
        name : string -> bool
override IsNull :
        name : string -> bool

Parameters

name
Type: SystemString
属性名称

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Db.DbEntity.IsNull(System.String)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.IsSetFieldLength Method

DbEntityIsSetFieldLength Method
获取是否已有字段查询长度设置

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool IsSetFieldLength()
Public Function IsSetFieldLength As Boolean
public:
bool IsSetFieldLength()
member IsSetFieldLength : unit -> bool

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Db.DbEntity.IsSetFieldLength"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.Remove Method

DbEntityRemove Method
移除指定的已设置属性

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Remove(
    string Name
)
Public Overridable Sub Remove (
    Name As String
)
public:
virtual void Remove(
    String^ Name
)
abstract Remove :
        Name : string -> unit
override Remove :
        Name : string -> unit

Parameters

Name
Type: SystemString
属性名称
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.Set Method

DbEntitySet Method
添加或设置指定的属性

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Set(
    string Name,
    Object Value
)
Public Overridable Sub Set (
    Name As String,
    Value As Object
)
public:
virtual void Set(
    String^ Name,
    Object^ Value
)
abstract Set :
        Name : string *
        Value : Object -> unit
override Set :
        Name : string *
        Value : Object -> unit

Parameters

Name
Type: SystemString
参数名称
Value
Type: SystemObject
属性值
See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.SetFieldLength Method

DbEntitySetFieldLength Method
设置查询字段长度,一般仅在参数查询时需要指定长时才设置该值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbEntity SetFieldLength(
    string fieldName,
    int length
)
Public Function SetFieldLength (
    fieldName As String,
    length As Integer
) As DbEntity
public:
DbEntity^ SetFieldLength(
    String^ fieldName,
    int length
)
member SetFieldLength :
        fieldName : string *
        length : int -> DbEntity

Parameters

fieldName
Type: SystemString

[Missing <param name="fieldName"/> documentation for "M:Adf.Db.DbEntity.SetFieldLength(System.String,System.Int32)"]

length
Type: SystemInt32
长度

Return Value

Type: DbEntity

[Missing <returns> documentation for "M:Adf.Db.DbEntity.SetFieldLength(System.String,System.Int32)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.SetFields Method

DbEntitySetFields Method
设置要处理的字段列表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbEntity SetFields(
    params string[] fields
)
Public Function SetFields (
    ParamArray fields As String()
) As DbEntity
public:
DbEntity^ SetFields(
    ... array<String^>^ fields
)
member SetFields :
        fields : string[] -> DbEntity

Parameters

fields
Type: SystemString
处理全部则不传入或设置为零长度

Return Value

Type: DbEntity

[Missing <returns> documentation for "M:Adf.Db.DbEntity.SetFields(System.String[])"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.SetOrderBy Method

DbEntitySetOrderBy Method
设置排序条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbEntity SetOrderBy(
    string orderBy
)
Public Function SetOrderBy (
    orderBy As String
) As DbEntity
public:
DbEntity^ SetOrderBy(
    String^ orderBy
)
member SetOrderBy :
        orderBy : string -> DbEntity

Parameters

orderBy
Type: SystemString
不含 ORDER BY 关键字

Return Value

Type: DbEntity

[Missing <returns> documentation for "M:Adf.Db.DbEntity.SetOrderBy(System.String)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.SetSelectSize Method

DbEntitySetSelectSize Method
设置排序条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbEntity SetSelectSize(
    int size
)
Public Function SetSelectSize (
    size As Integer
) As DbEntity
public:
DbEntity^ SetSelectSize(
    int size
)
member SetSelectSize :
        size : int -> DbEntity

Parameters

size
Type: SystemInt32
0则不限

Return Value

Type: DbEntity

[Missing <returns> documentation for "M:Adf.Db.DbEntity.SetSelectSize(System.Int32)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.SetTableName Method

DbEntitySetTableName Method
设置表名

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbEntity SetTableName(
    string tableName
)
Public Function SetTableName (
    tableName As String
) As DbEntity
public:
DbEntity^ SetTableName(
    String^ tableName
)
member SetTableName :
        tableName : string -> DbEntity

Parameters

tableName
Type: SystemString

[Missing <param name="tableName"/> documentation for "M:Adf.Db.DbEntity.SetTableName(System.String)"]

Return Value

Type: DbEntity

[Missing <returns> documentation for "M:Adf.Db.DbEntity.SetTableName(System.String)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.SetWhere Method

DbEntitySetWhere Method
设置排序条件

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbEntity SetWhere(
    string where
)
Public Function SetWhere (
    where As String
) As DbEntity
public:
DbEntity^ SetWhere(
    String^ where
)
member SetWhere :
        where : string -> DbEntity

Parameters

where
Type: SystemString
设置查询条件

Return Value

Type: DbEntity

[Missing <returns> documentation for "M:Adf.Db.DbEntity.SetWhere(System.String)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbEntity.SetWhereRelation Method

DbEntitySetWhereRelation Method
设置查询时的条件关第 未设置查询条件SetWhere(String)时有效，默认为AND关系

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbEntity SetWhereRelation(
    WhereRelation whereRelation
)
Public Function SetWhereRelation (
    whereRelation As WhereRelation
) As DbEntity
public:
DbEntity^ SetWhereRelation(
    WhereRelation whereRelation
)
member SetWhereRelation :
        whereRelation : WhereRelation -> DbEntity

Parameters

whereRelation
Type: Adf.DbWhereRelation

Return Value

Type: DbEntity

[Missing <returns> documentation for "M:Adf.Db.DbEntity.SetWhereRelation(Adf.Db.WhereRelation)"]

See Also

Reference

DbEntity Class
Adf.Db Namespace


DbException Class

DbException Class
异常基础类
Inheritance Hierarchy
SystemObject
SystemException
Adf.DbDbException

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DbException : Exception
Public Class DbException
    Inherits Exception
public ref class DbException : public Exception
type DbException =
    class
        inherit Exception
    end

The DbException type exposes the following members.

Constructors
 | Name | Description
Public method | DbException | 初始化新的异常实体
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
Properties
 | Name | Description
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference

Adf.Db Namespace


DbException Constructor

DbException Constructor
初始化新的异常实体

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbException(
    string message
)
Public Sub New (
    message As String
)
public:
DbException(
    String^ message
)
new :
        message : string -> DbException

Parameters

message
Type: SystemString
消息
See Also

Reference

DbException Class
Adf.Db Namespace


DbException Methods

DbException Methods

The DbException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetBaseException | 当在派生类中重写时，返回 Exception，它是一个或多个并发的异常的根源。 (Inherited from Exception.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetObjectData | 当在派生类中重写时，用关于异常的信息设置 SerializationInfo。 (Inherited from Exception.)
Public method | GetType | 获取当前实例的运行时类型。 (Inherited from Exception.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 创建并返回当前异常的字符串表示形式。 (Inherited from Exception.)
Top
See Also

Reference

DbException Class
Adf.Db Namespace


DbException Properties

DbException Properties

The DbException type exposes the following members.

Properties
 | Name | Description
Public property | Data | 获取一个提供用户定义的其他异常信息的键/值对的集合。 (Inherited from Exception.)
Public property | HelpLink | 获取或设置指向此异常所关联帮助文件的链接。 (Inherited from Exception.)
Protected property | HResult | 获取或设置 HRESULT，它是分配给特定异常的编码数值。 (Inherited from Exception.)
Public property | InnerException | 获取导致当前异常的 Exception 实例。 (Inherited from Exception.)
Public property | Message | 获取描述当前异常的消息。 (Inherited from Exception.)
Public property | Source | 获取或设置导致错误的应用程序或对象的名称。 (Inherited from Exception.)
Public property | StackTrace | 获取当前异常发生时调用堆栈上的帧的字符串表示形式。 (Inherited from Exception.)
Public property | TargetSite | 获取引发当前异常的方法。 (Inherited from Exception.)
Top
See Also

Reference

DbException Class
Adf.Db Namespace


DbFactory Class

DbFactory Class
数据操作基类
Inheritance Hierarchy
SystemObject
Adf.DbDbFactory
Adf.DbAccess
Adf.DbMySql
Adf.DbSqlite
Adf.DbSqlServer

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract class DbFactory : IDbFactory,
    IDisposable
Public MustInherit Class DbFactory
    Implements IDbFactory, IDisposable
public ref class DbFactory abstract : IDbFactory,
    IDisposable
[<AbstractClassAttribute>]
type DbFactory =
    class
        interface IDbFactory
        interface IDisposable
    end

The DbFactory type exposes the following members.

Constructors
 | Name | Description
Public method | DbFactory | initialize
Top
Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过
Public method | Commit(Boolean) | 提交一个事务执行
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀
Public method | CreateParameter(String, Object, Int32) | 创建一个参数
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数
Public method | Delete | 执行数据对象删除处理
Public method | Dispose | 释放所占用的资源
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程
Public method | Execute(DbEntity, String) | 执行一个语句或过程
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(DbEntity) | 获取指定对象的记录数
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数
Public method | GetDataSet(String) | 返回一个数据集
Public method | GetDataSet(DbEntity) | 返回一个数据集
Public method | GetDataSet(DbEntity, String) | 返回一个数据集
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集
Public method | GetDataTable(String) | 返回一个数据表
Public method | GetDataTable(DbEntity) | 返回一个数据表
Public method | GetDataTable(DbEntity, String) | 返回一个数据表
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentity | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetListT(String) | 返回一个数据对象集
Public method | GetListT(DbEntity) | 返回一个数据对象集
Public method | GetListT(DbEntity, String) | 返回一个数据对象集
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Public method | GetListsT(String) | 返回一个数据对象集
Public method | GetListsT(DbEntity) | 返回一个数据对象集
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Public method | GetRowT(String) | 返回一个数据对象
Public method | GetRowT(DbEntity) | 返回一个数据对象
Public method | GetRowT(DbEntity, String) | 返回一个数据对象
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象
Public method | GetScalar(String) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetScalarT(String) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalarT(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤
Public method | Insert | 执行数据对象插入请求
Protected method | LogBuilder | 日志添加
Protected method | LogManagerInitialize | 日志管理器初始
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改
Top
Fields
Name | Description
CALLBACK_LIST_CAPACITY | 默认的LIST返回集合大小
LOG_ENABLE | 是否开启日志，配置名：Adf:Db:LogEnable
SAFESTRING_DEFAULT | SafeString 默认值
Top
Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作
Public property | Connection | 获取当前数据库连接串
Protected property | DbProviderFactory | 获取当前数据数据处理方法集
Public property | LastSql | 获取最后一个查询SQL
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新
Public property | Name | 获取当前操作对象的名称描述
Public property | NestedTransaction | 获取是否为并行（嵌套）事务
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性
Public property | SqlBuilder | 返回可用的SqlBuilder对象
Public property | Transaction | 获取当前正在执行的事务
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级
Top
See Also

Reference

Adf.Db Namespace


DbFactory Constructor

DbFactory Constructor
initialize

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbFactory(
    DbProviderFactory factory,
    IDbConnection connection
)
Public Sub New (
    factory As DbProviderFactory,
    connection As IDbConnection
)
public:
DbFactory(
    DbProviderFactory^ factory,
    IDbConnection^ connection
)
new :
        factory : DbProviderFactory *
        connection : IDbConnection -> DbFactory

Parameters

factory
Type: System.Data.CommonDbProviderFactory
工厂
connection
Type: System.DataIDbConnection
对象连接
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory Fields

DbFactory Fields

The DbFactory type exposes the following members.

Fields
Name | Description
CALLBACK_LIST_CAPACITY | 默认的LIST返回集合大小
LOG_ENABLE | 是否开启日志，配置名：Adf:Db:LogEnable
SAFESTRING_DEFAULT | SafeString 默认值
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.CALLBACK_LIST_CAPACITY Field

DbFactoryCALLBACK_LIST_CAPACITY Field
默认的LIST返回集合大小

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public const int CALLBACK_LIST_CAPACITY
Public Const CALLBACK_LIST_CAPACITY As Integer
public:
literal int CALLBACK_LIST_CAPACITY
static val mutable CALLBACK_LIST_CAPACITY: int

Field Value

Type: Int32
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.LOG_ENABLE Field

DbFactoryLOG_ENABLE Field
是否开启日志，配置名：Adf:Db:LogEnable

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static bool LOG_ENABLE
Public Shared LOG_ENABLE As Boolean
public:
static bool LOG_ENABLE
static val mutable LOG_ENABLE: bool

Field Value

Type: Boolean
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.SAFESTRING_DEFAULT Field

DbFactorySAFESTRING_DEFAULT Field
SafeString 默认值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected const string SAFESTRING_DEFAULT
Protected Const SAFESTRING_DEFAULT As String
protected:
literal String^ SAFESTRING_DEFAULT
static val mutable SAFESTRING_DEFAULT: string

Field Value

Type: String
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory Methods

DbFactory Methods

The DbFactory type exposes the following members.

Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过
Public method | Commit(Boolean) | 提交一个事务执行
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀
Public method | CreateParameter(String, Object, Int32) | 创建一个参数
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数
Public method | Delete | 执行数据对象删除处理
Public method | Dispose | 释放所占用的资源
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程
Public method | Execute(DbEntity, String) | 执行一个语句或过程
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(DbEntity) | 获取指定对象的记录数
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数
Public method | GetDataSet(String) | 返回一个数据集
Public method | GetDataSet(DbEntity) | 返回一个数据集
Public method | GetDataSet(DbEntity, String) | 返回一个数据集
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集
Public method | GetDataTable(String) | 返回一个数据表
Public method | GetDataTable(DbEntity) | 返回一个数据表
Public method | GetDataTable(DbEntity, String) | 返回一个数据表
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentity | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetListT(String) | 返回一个数据对象集
Public method | GetListT(DbEntity) | 返回一个数据对象集
Public method | GetListT(DbEntity, String) | 返回一个数据对象集
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Public method | GetListsT(String) | 返回一个数据对象集
Public method | GetListsT(DbEntity) | 返回一个数据对象集
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Public method | GetRowT(String) | 返回一个数据对象
Public method | GetRowT(DbEntity) | 返回一个数据对象
Public method | GetRowT(DbEntity, String) | 返回一个数据对象
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象
Public method | GetScalar(String) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetScalarT(String) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalarT(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤
Public method | Insert | 执行数据对象插入请求
Protected method | LogBuilder | 日志添加
Protected method | LogManagerInitialize | 日志管理器初始
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Begin Method

DbFactoryBegin Method
开始一个事务执行,当多个事务并行时，以最外层有效

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int Begin()
Public Overridable Function Begin As Integer
public:
virtual int Begin()
abstract Begin : unit -> int
override Begin : unit -> int

Return Value

Type: Int32
事务嵌套层级

Implements

IDbFactoryBegin
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Commit Method

DbFactoryCommit Method
Overload List
 | Name | Description
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过
Public method | Commit(Boolean) | 提交一个事务执行
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Commit Method

DbFactoryCommit Method
提交一个事务执行,并行事务时非最外层则跳过

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Commit()
Public Overridable Sub Commit
public:
virtual void Commit()
abstract Commit : unit -> unit
override Commit : unit -> unit

Implements

IDbFactoryCommit
See Also

Reference

DbFactory Class
Commit Overload
Adf.Db Namespace


DbFactory.Commit Method (Boolean)

DbFactoryCommit Method (Boolean)
提交一个事务执行

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Commit(
    bool endNested
)
Public Overridable Sub Commit (
    endNested As Boolean
)
public:
virtual void Commit(
    bool endNested
)
abstract Commit :
        endNested : bool -> unit
override Commit :
        endNested : bool -> unit

Parameters

endNested
Type: SystemBoolean
是否直接完成并行事务,注意：当值为Boolean时你必需重新启用新事务，否则外围提交将无效.

Implements

IDbFactoryCommit(Boolean)
See Also

Reference

DbFactory Class
Commit Overload
Adf.Db Namespace


DbFactory.CreateCommand Method

DbFactoryCreateCommand Method
根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual IDbCommand CreateCommand(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
Public Overridable Function CreateCommand (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As IDbCommand
public:
virtual IDbCommand^ CreateCommand(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract CreateCommand :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> IDbCommand
override CreateCommand :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> IDbCommand

Parameters

sqlString
Type: SystemString
执行串
storedProcedure
Type: SystemBoolean
是否以存储过程执行
parames
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: IDbCommand

[Missing <returns> documentation for "M:Adf.Db.DbFactory.CreateCommand(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryCreateCommand(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.CreateParameter Method

DbFactoryCreateParameter Method
Overload List
 | Name | Description
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀
Public method | CreateParameter(String, Object, Int32) | 创建一个参数
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.CreateParameter Method (DbEntity)

DbFactoryCreateParameter Method (DbEntity)
根据对象创建参数列表,使用ParameterChar所指定的参数前缀

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual List<IDbDataParameter> CreateParameter(
    DbEntity entity
)
Protected Overridable Function CreateParameter (
    entity As DbEntity
) As List(Of IDbDataParameter)
protected:
virtual List<IDbDataParameter^>^ CreateParameter(
    DbEntity^ entity
)
abstract CreateParameter :
        entity : DbEntity -> List<IDbDataParameter>
override CreateParameter :
        entity : DbEntity -> List<IDbDataParameter>

Parameters

entity
Type: Adf.DbDbEntity
对象

Return Value

Type: List IDbDataParameter

[Missing <returns> documentation for "M:Adf.Db.DbFactory.CreateParameter(Adf.Db.DbEntity)"]

See Also

Reference

DbFactory Class
CreateParameter Overload
Adf.Db Namespace


DbFactory.CreateParameter Method (String, Object, Int32)

DbFactoryCreateParameter Method (String, Object, Int32)
创建一个参数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual IDbDataParameter CreateParameter(
    string name,
    Object value,
    int length = 0
)
Public Overridable Function CreateParameter (
    name As String,
    value As Object,
    Optional length As Integer = 0
) As IDbDataParameter
public:
virtual IDbDataParameter^ CreateParameter(
    String^ name,
    Object^ value,
    int length = 0
)
abstract CreateParameter :
        name : string *
        value : Object *
        ?length : int
(* Defaults:
        let _length = defaultArg length 0
*)
-> IDbDataParameter
override CreateParameter :
        name : string *
        value : Object *
        ?length : int
(* Defaults:
        let _length = defaultArg length 0
*)
-> IDbDataParameter

Parameters

name
Type: SystemString
参数
value
Type: SystemObject
参数值
length (Optional)
Type: SystemInt32
长度 >0 有效

Return Value

Type: IDbDataParameter

[Missing <returns> documentation for "M:Adf.Db.DbFactory.CreateParameter(System.String,System.Object,System.Int32)"]

Implements

IDbFactoryCreateParameter(String, Object, Int32)
See Also

Reference

DbFactory Class
CreateParameter Overload
Adf.Db Namespace


DbFactory.CreateParameter Method (String, Object, DbType, Int32)

DbFactoryCreateParameter Method (String, Object, DbType, Int32)
创建一个参数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual IDbDataParameter CreateParameter(
    string name,
    Object value,
    DbType dbType,
    int length = 0
)
Public Overridable Function CreateParameter (
    name As String,
    value As Object,
    dbType As DbType,
    Optional length As Integer = 0
) As IDbDataParameter
public:
virtual IDbDataParameter^ CreateParameter(
    String^ name,
    Object^ value,
    DbType dbType,
    int length = 0
)
abstract CreateParameter :
        name : string *
        value : Object *
        dbType : DbType *
        ?length : int
(* Defaults:
        let _length = defaultArg length 0
*)
-> IDbDataParameter
override CreateParameter :
        name : string *
        value : Object *
        dbType : DbType *
        ?length : int
(* Defaults:
        let _length = defaultArg length 0
*)
-> IDbDataParameter

Parameters

name
Type: SystemString
参数
value
Type: SystemObject
参数值
dbType
Type: System.DataDbType
参数类型
length (Optional)
Type: SystemInt32
长度 >0 有效

Return Value

Type: IDbDataParameter

[Missing <returns> documentation for "M:Adf.Db.DbFactory.CreateParameter(System.String,System.Object,System.Data.DbType,System.Int32)"]

Implements

IDbFactoryCreateParameter(String, Object, DbType, Int32)
See Also

Reference

DbFactory Class
CreateParameter Overload
Adf.Db Namespace


DbFactory.Delete Method

DbFactoryDelete Method
执行数据对象删除处理

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int Delete(
    DbEntity where
)
Public Overridable Function Delete (
    where As DbEntity
) As Integer
public:
virtual int Delete(
    DbEntity^ where
)
abstract Delete :
        where : DbEntity -> int
override Delete :
        where : DbEntity -> int

Parameters

where
Type: Adf.DbDbEntity
对象

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.Delete(Adf.Db.DbEntity)"]

Implements

IDbFactoryDelete(DbEntity)
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Dispose Method

DbFactoryDispose Method
释放所占用的资源

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Execute Method

DbFactoryExecute Method
Overload List
 | Name | Description
Public method | Execute(String) | 执行一个语句或过程
Public method | Execute(DbEntity, String) | 执行一个语句或过程
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Execute Method (String)

DbFactoryExecute Method (String)
执行一个语句或过程

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int Execute(
    string sqlString
)
Public Overridable Function Execute (
    sqlString As String
) As Integer
public:
virtual int Execute(
    String^ sqlString
)
abstract Execute :
        sqlString : string -> int
override Execute :
        sqlString : string -> int

Parameters

sqlString
Type: SystemString
要执行的操作语句

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.Execute(System.String)"]

Implements

IDbFactoryExecute(String)
See Also

Reference

DbFactory Class
Execute Overload
Adf.Db Namespace


DbFactory.Execute Method (DbEntity, String)

DbFactoryExecute Method (DbEntity, String)
执行一个语句或过程

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int Execute(
    DbEntity entity,
    string storedProcedure
)
Public Overridable Function Execute (
    entity As DbEntity,
    storedProcedure As String
) As Integer
public:
virtual int Execute(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract Execute :
        entity : DbEntity *
        storedProcedure : string -> int
override Execute :
        entity : DbEntity *
        storedProcedure : string -> int

Parameters

entity
Type: Adf.DbDbEntity
实体
storedProcedure
Type: SystemString
存储过程名

Return Value

Type: Int32
受影响行数

Implements

IDbFactoryExecute(DbEntity, String)
See Also

Reference

DbFactory Class
Execute Overload
Adf.Db Namespace


DbFactory.Execute Method (String, Boolean, IDbDataParameter[])

DbFactoryExecute Method (String, Boolean, IDbDataParameter)
执行一个语句或过程

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int Execute(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
Public Overridable Function Execute (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As Integer
public:
virtual int Execute(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract Execute :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> int
override Execute :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> int

Parameters

sqlString
Type: SystemString
要执行的操作语句
storedProcedure
Type: SystemBoolean
是否以存储过程执行
parames
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.Execute(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryExecute(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
Execute Overload
Adf.Db Namespace


DbFactory.GetCount Method

DbFactoryGetCount Method
Overload List
 | Name | Description
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(DbEntity) | 获取指定对象的记录数
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetCount Method (String)

DbFactoryGetCount Method (String)
获取指定语句第一行第一例的Int类型数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int GetCount(
    string sqlString
)
Public Overridable Function GetCount (
    sqlString As String
) As Integer
public:
virtual int GetCount(
    String^ sqlString
)
abstract GetCount :
        sqlString : string -> int
override GetCount :
        sqlString : string -> int

Parameters

sqlString
Type: SystemString
执行语句

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetCount(System.String)"]

Implements

IDbFactoryGetCount(String)
See Also

Reference

DbFactory Class
GetCount Overload
Adf.Db Namespace


DbFactory.GetCount Method (DbEntity)

DbFactoryGetCount Method (DbEntity)
获取指定对象的记录数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int GetCount(
    DbEntity entity
)
Public Overridable Function GetCount (
    entity As DbEntity
) As Integer
public:
virtual int GetCount(
    DbEntity^ entity
)
abstract GetCount :
        entity : DbEntity -> int
override GetCount :
        entity : DbEntity -> int

Parameters

entity
Type: Adf.DbDbEntity
对象

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetCount(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetCount(DbEntity)
See Also

Reference

DbFactory Class
GetCount Overload
Adf.Db Namespace


DbFactory.GetCount Method (String, Boolean)

DbFactoryGetCount Method (String, Boolean)
获取指定语句第一行第一例的Int类型数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int GetCount(
    string sqlString,
    bool storedProcedure
)
Public Overridable Function GetCount (
    sqlString As String,
    storedProcedure As Boolean
) As Integer
public:
virtual int GetCount(
    String^ sqlString,
    bool storedProcedure
)
abstract GetCount :
        sqlString : string *
        storedProcedure : bool -> int
override GetCount :
        sqlString : string *
        storedProcedure : bool -> int

Parameters

sqlString
Type: SystemString
执行语句
storedProcedure
Type: SystemBoolean
是否以过程执行

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetCount(System.String,System.Boolean)"]

Implements

IDbFactoryGetCount(String, Boolean)
See Also

Reference

DbFactory Class
GetCount Overload
Adf.Db Namespace


DbFactory.GetCount Method (String, String)

DbFactoryGetCount Method (String, String)
根据表与条件返回一个COUNT值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int GetCount(
    string tablename,
    string condition
)
Public Overridable Function GetCount (
    tablename As String,
    condition As String
) As Integer
public:
virtual int GetCount(
    String^ tablename,
    String^ condition
)
abstract GetCount :
        tablename : string *
        condition : string -> int
override GetCount :
        tablename : string *
        condition : string -> int

Parameters

tablename
Type: SystemString
表名
condition
Type: SystemString
条件

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetCount(System.String,System.String)"]

Implements

IDbFactoryGetCount(String, String)
See Also

Reference

DbFactory Class
GetCount Overload
Adf.Db Namespace


DbFactory.GetCount Method (DbEntity, String)

DbFactoryGetCount Method (DbEntity, String)
获取指定对象的记录数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int GetCount(
    DbEntity entity,
    string storedProcedure
)
Public Overridable Function GetCount (
    entity As DbEntity,
    storedProcedure As String
) As Integer
public:
virtual int GetCount(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetCount :
        entity : DbEntity *
        storedProcedure : string -> int
override GetCount :
        entity : DbEntity *
        storedProcedure : string -> int

Parameters

entity
Type: Adf.DbDbEntity
对象
storedProcedure
Type: SystemString
要执行的存储过程名

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetCount(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetCount(DbEntity, String)
See Also

Reference

DbFactory Class
GetCount Overload
Adf.Db Namespace


DbFactory.GetDataSet Method

DbFactoryGetDataSet Method
Overload List
 | Name | Description
Public method | GetDataSet(String) | 返回一个数据集
Public method | GetDataSet(DbEntity) | 返回一个数据集
Public method | GetDataSet(DbEntity, String) | 返回一个数据集
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetDataSet Method (String)

DbFactoryGetDataSet Method (String)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataSet GetDataSet(
    string sqlString
)
Public Overridable Function GetDataSet (
    sqlString As String
) As DataSet
public:
virtual DataSet^ GetDataSet(
    String^ sqlString
)
abstract GetDataSet :
        sqlString : string -> DataSet
override GetDataSet :
        sqlString : string -> DataSet

Parameters

sqlString
Type: SystemString
要执行的语句

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataSet(System.String)"]

Implements

IDbFactoryGetDataSet(String)
See Also

Reference

DbFactory Class
GetDataSet Overload
Adf.Db Namespace


DbFactory.GetDataSet Method (DbEntity)

DbFactoryGetDataSet Method (DbEntity)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataSet GetDataSet(
    DbEntity entity
)
Public Overridable Function GetDataSet (
    entity As DbEntity
) As DataSet
public:
virtual DataSet^ GetDataSet(
    DbEntity^ entity
)
abstract GetDataSet :
        entity : DbEntity -> DataSet
override GetDataSet :
        entity : DbEntity -> DataSet

Parameters

entity
Type: Adf.DbDbEntity
数据对象

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataSet(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetDataSet(DbEntity)
See Also

Reference

DbFactory Class
GetDataSet Overload
Adf.Db Namespace


DbFactory.GetDataSet Method (DbEntity, String)

DbFactoryGetDataSet Method (DbEntity, String)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataSet GetDataSet(
    DbEntity entity,
    string storedProcedure
)
Public Overridable Function GetDataSet (
    entity As DbEntity,
    storedProcedure As String
) As DataSet
public:
virtual DataSet^ GetDataSet(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetDataSet :
        entity : DbEntity *
        storedProcedure : string -> DataSet
override GetDataSet :
        entity : DbEntity *
        storedProcedure : string -> DataSet

Parameters

entity
Type: Adf.DbDbEntity
数据对象
storedProcedure
Type: SystemString
要执行的存储过程名

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataSet(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetDataSet(DbEntity, String)
See Also

Reference

DbFactory Class
GetDataSet Overload
Adf.Db Namespace


DbFactory.GetDataSet Method (String, Boolean, IDbDataParameter[])

DbFactoryGetDataSet Method (String, Boolean, IDbDataParameter)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataSet GetDataSet(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
Public Overridable Function GetDataSet (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As DataSet
public:
virtual DataSet^ GetDataSet(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract GetDataSet :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> DataSet
override GetDataSet :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> DataSet

Parameters

sqlString
Type: SystemString
要执行的语句或过程
storedProcedure
Type: SystemBoolean
是否为存储过程
parames
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataSet(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryGetDataSet(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
GetDataSet Overload
Adf.Db Namespace


DbFactory.GetDataTable Method

DbFactoryGetDataTable Method
Overload List
 | Name | Description
Public method | GetDataTable(String) | 返回一个数据表
Public method | GetDataTable(DbEntity) | 返回一个数据表
Public method | GetDataTable(DbEntity, String) | 返回一个数据表
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetDataTable Method (String)

DbFactoryGetDataTable Method (String)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataTable GetDataTable(
    string sqlString
)
Public Overridable Function GetDataTable (
    sqlString As String
) As DataTable
public:
virtual DataTable^ GetDataTable(
    String^ sqlString
)
abstract GetDataTable :
        sqlString : string -> DataTable
override GetDataTable :
        sqlString : string -> DataTable

Parameters

sqlString
Type: SystemString
要执行的语句

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataTable(System.String)"]

Implements

IDbFactoryGetDataTable(String)
See Also

Reference

DbFactory Class
GetDataTable Overload
Adf.Db Namespace


DbFactory.GetDataTable Method (DbEntity)

DbFactoryGetDataTable Method (DbEntity)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataTable GetDataTable(
    DbEntity entity
)
Public Overridable Function GetDataTable (
    entity As DbEntity
) As DataTable
public:
virtual DataTable^ GetDataTable(
    DbEntity^ entity
)
abstract GetDataTable :
        entity : DbEntity -> DataTable
override GetDataTable :
        entity : DbEntity -> DataTable

Parameters

entity
Type: Adf.DbDbEntity
数据对象

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataTable(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetDataTable(DbEntity)
See Also

Reference

DbFactory Class
GetDataTable Overload
Adf.Db Namespace


DbFactory.GetDataTable Method (DbEntity, String)

DbFactoryGetDataTable Method (DbEntity, String)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataTable GetDataTable(
    DbEntity entity,
    string storedProcedure
)
Public Overridable Function GetDataTable (
    entity As DbEntity,
    storedProcedure As String
) As DataTable
public:
virtual DataTable^ GetDataTable(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetDataTable :
        entity : DbEntity *
        storedProcedure : string -> DataTable
override GetDataTable :
        entity : DbEntity *
        storedProcedure : string -> DataTable

Parameters

entity
Type: Adf.DbDbEntity
数据对象
storedProcedure
Type: SystemString
要执行的存储过程名

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataTable(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetDataTable(DbEntity, String)
See Also

Reference

DbFactory Class
GetDataTable Overload
Adf.Db Namespace


DbFactory.GetDataTable Method (String, Boolean, IDbDataParameter[])

DbFactoryGetDataTable Method (String, Boolean, IDbDataParameter)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual DataTable GetDataTable(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
Public Overridable Function GetDataTable (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As DataTable
public:
virtual DataTable^ GetDataTable(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetDataTable :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> DataTable
override GetDataTable :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> DataTable

Parameters

sqlString
Type: SystemString
要执行的语句或过程
storedProcedure
Type: SystemBoolean
是否为存储过程
parameters
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetDataTable(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryGetDataTable(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
GetDataTable Overload
Adf.Db Namespace


DbFactory.GetIdentity Method

DbFactoryGetIdentity Method
Overload List
 | Name | Description
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetIdentity | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetIdentity(T) Method

DbFactoryGetIdentityT Method
获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T GetIdentity<T>()

Public Overridable Function GetIdentity(Of T) As T
public:
generic<typename T>
virtual T GetIdentity()
abstract GetIdentity : unit -> 'T
override GetIdentity : unit -> 'T

Type Parameters

T
返回的数据类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetIdentity``1"]

Implements

IDbFactoryGetIdentityT
See Also

Reference

DbFactory Class
GetIdentity Overload
Adf.Db Namespace


DbFactory.GetIdentity Method

DbFactoryGetIdentity Method
获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetIdentity()
Public Overridable Function GetIdentity As Object
public:
virtual Object^ GetIdentity()
abstract GetIdentity : unit -> Object
override GetIdentity : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetIdentity"]

Implements

IDbFactoryGetIdentity
See Also

Reference

DbFactory Class
GetIdentity Overload
Adf.Db Namespace


DbFactory.GetList Method

DbFactoryGetList Method
Overload List
 | Name | Description
Public method | GetListT(String) | 返回一个数据对象集
Public method | GetListT(DbEntity) | 返回一个数据对象集
Public method | GetListT(DbEntity, String) | 返回一个数据对象集
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetList(T) Method (String)

DbFactoryGetListT Method (String)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual List<T> GetList<T>(
    string sqlString
)
where T : IDbEntity

Public Overridable Function GetList(Of T As IDbEntity) (
    sqlString As String
) As List(Of T)
public:
generic<typename T>
where T : IDbEntity
virtual List<T>^ GetList(
    String^ sqlString
)
abstract GetList :
        sqlString : string -> List<'T>  when 'T : IDbEntity
override GetList :
        sqlString : string -> List<'T>  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetList``1(System.String)"]

Implements

IDbFactoryGetListT(String)
See Also

Reference

DbFactory Class
GetList Overload
Adf.Db Namespace


DbFactory.GetList(T) Method (DbEntity)

DbFactoryGetListT Method (DbEntity)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public List<T> GetList<T>(
    DbEntity entity
)
where T : IDbEntity

Public Function GetList(Of T As IDbEntity) (
    entity As DbEntity
) As List(Of T)
public:
generic<typename T>
where T : IDbEntity
virtual List<T>^ GetList(
    DbEntity^ entity
) sealed
abstract GetList :
        entity : DbEntity -> List<'T>  when 'T : IDbEntity
override GetList :
        entity : DbEntity -> List<'T>  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetList``1(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetListT(DbEntity)
See Also

Reference

DbFactory Class
GetList Overload
Adf.Db Namespace


DbFactory.GetList(T) Method (DbEntity, String)

DbFactoryGetListT Method (DbEntity, String)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public List<T> GetList<T>(
    DbEntity entity,
    string storedProcedure
)
where T : IDbEntity

Public Function GetList(Of T As IDbEntity) (
    entity As DbEntity,
    storedProcedure As String
) As List(Of T)
public:
generic<typename T>
where T : IDbEntity
virtual List<T>^ GetList(
    DbEntity^ entity,
    String^ storedProcedure
) sealed
abstract GetList :
        entity : DbEntity *
        storedProcedure : string -> List<'T>  when 'T : IDbEntity
override GetList :
        entity : DbEntity *
        storedProcedure : string -> List<'T>  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象
storedProcedure
Type: SystemString
要执行的存储过程名

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetList``1(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetListT(DbEntity, String)
See Also

Reference

DbFactory Class
GetList Overload
Adf.Db Namespace


DbFactory.GetList(T) Method (String, Boolean, IDbDataParameter[])

DbFactoryGetListT Method (String, Boolean, IDbDataParameter)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual List<T> GetList<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
where T : IDbEntity

Public Overridable Function GetList(Of T As IDbEntity) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As List(Of T)
public:
generic<typename T>
where T : IDbEntity
virtual List<T>^ GetList(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract GetList :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> List<'T>  when 'T : IDbEntity
override GetList :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> List<'T>  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parames
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetList``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryGetListT(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
GetList Overload
Adf.Db Namespace


DbFactory.GetLists Method

DbFactoryGetLists Method
Overload List
 | Name | Description
Public method | GetListsT(String) | 返回一个数据对象集
Public method | GetListsT(DbEntity) | 返回一个数据对象集
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetLists(T) Method (String)

DbFactoryGetListsT Method (String)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual List<T>[] GetLists<T>(
    string sqlString
)
where T : IDbEntity

Public Overridable Function GetLists(Of T As IDbEntity) (
    sqlString As String
) As List(Of T)()
public:
generic<typename T>
where T : IDbEntity
virtual array<List<T>^>^ GetLists(
    String^ sqlString
)
abstract GetLists :
        sqlString : string -> List<'T>[]  when 'T : IDbEntity
override GetLists :
        sqlString : string -> List<'T>[]  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetLists``1(System.String)"]

Implements

IDbFactoryGetListsT(String)
See Also

Reference

DbFactory Class
GetLists Overload
Adf.Db Namespace


DbFactory.GetLists(T) Method (DbEntity)

DbFactoryGetListsT Method (DbEntity)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public List<T>[] GetLists<T>(
    DbEntity entity
)
where T : IDbEntity

Public Function GetLists(Of T As IDbEntity) (
    entity As DbEntity
) As List(Of T)()
public:
generic<typename T>
where T : IDbEntity
virtual array<List<T>^>^ GetLists(
    DbEntity^ entity
) sealed
abstract GetLists :
        entity : DbEntity -> List<'T>[]  when 'T : IDbEntity
override GetLists :
        entity : DbEntity -> List<'T>[]  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetLists``1(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetListsT(DbEntity)
See Also

Reference

DbFactory Class
GetLists Overload
Adf.Db Namespace


DbFactory.GetLists(T) Method (DbEntity, String)

DbFactoryGetListsT Method (DbEntity, String)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public List<T>[] GetLists<T>(
    DbEntity entity,
    string storedProcedure
)
where T : IDbEntity

Public Function GetLists(Of T As IDbEntity) (
    entity As DbEntity,
    storedProcedure As String
) As List(Of T)()
public:
generic<typename T>
where T : IDbEntity
virtual array<List<T>^>^ GetLists(
    DbEntity^ entity,
    String^ storedProcedure
) sealed
abstract GetLists :
        entity : DbEntity *
        storedProcedure : string -> List<'T>[]  when 'T : IDbEntity
override GetLists :
        entity : DbEntity *
        storedProcedure : string -> List<'T>[]  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象
storedProcedure
Type: SystemString
要执行的存储过程名

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetLists``1(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetListsT(DbEntity, String)
See Also

Reference

DbFactory Class
GetLists Overload
Adf.Db Namespace


DbFactory.GetLists(T) Method (String, Boolean, IDbDataParameter[])

DbFactoryGetListsT Method (String, Boolean, IDbDataParameter)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual List<T>[] GetLists<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
where T : IDbEntity

Public Overridable Function GetLists(Of T As IDbEntity) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As List(Of T)()
public:
generic<typename T>
where T : IDbEntity
virtual array<List<T>^>^ GetLists(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract GetLists :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> List<'T>[]  when 'T : IDbEntity
override GetLists :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> List<'T>[]  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parames
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetLists``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryGetListsT(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
GetLists Overload
Adf.Db Namespace


DbFactory.GetRow Method

DbFactoryGetRow Method
Overload List
 | Name | Description
Public method | GetRowT(String) | 返回一个数据对象
Public method | GetRowT(DbEntity) | 返回一个数据对象
Public method | GetRowT(DbEntity, String) | 返回一个数据对象
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetRow(T) Method (String)

DbFactoryGetRowT Method (String)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T GetRow<T>(
    string SqlString
)
where T : IDbEntity

Public Function GetRow(Of T As IDbEntity) (
    SqlString As String
) As T
public:
generic<typename T>
where T : IDbEntity
virtual T GetRow(
    String^ SqlString
) sealed
abstract GetRow :
        SqlString : string -> 'T  when 'T : IDbEntity
override GetRow :
        SqlString : string -> 'T  when 'T : IDbEntity

Parameters

SqlString
Type: SystemString
查询语句

Type Parameters

T
数据对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetRow``1(System.String)"]

Implements

IDbFactoryGetRowT(String)
See Also

Reference

DbFactory Class
GetRow Overload
Adf.Db Namespace


DbFactory.GetRow(T) Method (DbEntity)

DbFactoryGetRowT Method (DbEntity)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T GetRow<T>(
    DbEntity entity
)
where T : IDbEntity

Public Function GetRow(Of T As IDbEntity) (
    entity As DbEntity
) As T
public:
generic<typename T>
where T : IDbEntity
virtual T GetRow(
    DbEntity^ entity
) sealed
abstract GetRow :
        entity : DbEntity -> 'T  when 'T : IDbEntity
override GetRow :
        entity : DbEntity -> 'T  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询对象

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetRow``1(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetRowT(DbEntity)
See Also

Reference

DbFactory Class
GetRow Overload
Adf.Db Namespace


DbFactory.GetRow(T) Method (DbEntity, String)

DbFactoryGetRowT Method (DbEntity, String)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T GetRow<T>(
    DbEntity entity,
    string storedProcedure
)
where T : IDbEntity

Public Function GetRow(Of T As IDbEntity) (
    entity As DbEntity,
    storedProcedure As String
) As T
public:
generic<typename T>
where T : IDbEntity
virtual T GetRow(
    DbEntity^ entity,
    String^ storedProcedure
) sealed
abstract GetRow :
        entity : DbEntity *
        storedProcedure : string -> 'T  when 'T : IDbEntity
override GetRow :
        entity : DbEntity *
        storedProcedure : string -> 'T  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询对象
storedProcedure
Type: SystemString
要执行的存储过程名

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetRow``1(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetRowT(DbEntity, String)
See Also

Reference

DbFactory Class
GetRow Overload
Adf.Db Namespace


DbFactory.GetRow(T) Method (String, Boolean, IDbDataParameter[])

DbFactoryGetRowT Method (String, Boolean, IDbDataParameter)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public T GetRow<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
where T : IDbEntity

Public Function GetRow(Of T As IDbEntity) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As T
public:
generic<typename T>
where T : IDbEntity
virtual T GetRow(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
) sealed
abstract GetRow :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> 'T  when 'T : IDbEntity
override GetRow :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> 'T  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句或过程
storedProcedure
Type: SystemBoolean
是否以存储过程执行
parames
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
数据对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetRow``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryGetRowT(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
GetRow Overload
Adf.Db Namespace


DbFactory.GetScalar Method

DbFactoryGetScalar Method
Overload List
 | Name | Description
Public method | GetScalar(String) | 获取第一行第一列的数据
Public method | GetScalarT(String) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetScalarT(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.GetScalar Method (String)

DbFactoryGetScalar Method (String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetScalar(
    string sqlString
)
Public Overridable Function GetScalar (
    sqlString As String
) As Object
public:
virtual Object^ GetScalar(
    String^ sqlString
)
abstract GetScalar :
        sqlString : string -> Object
override GetScalar :
        sqlString : string -> Object

Parameters

sqlString
Type: SystemString
要执行的语句

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar(System.String)"]

Implements

IDbFactoryGetScalar(String)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.GetScalar(T) Method (String)

DbFactoryGetScalarT Method (String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T GetScalar<T>(
    string sqlString
)

Public Overridable Function GetScalar(Of T) (
    sqlString As String
) As T
public:
generic<typename T>
virtual T GetScalar(
    String^ sqlString
)
abstract GetScalar :
        sqlString : string -> 'T
override GetScalar :
        sqlString : string -> 'T

Parameters

sqlString
Type: SystemString
要执行的语句

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar``1(System.String)"]

Implements

IDbFactoryGetScalarT(String)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.GetScalar Method (DbEntity)

DbFactoryGetScalar Method (DbEntity)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetScalar(
    DbEntity entity
)
Public Overridable Function GetScalar (
    entity As DbEntity
) As Object
public:
virtual Object^ GetScalar(
    DbEntity^ entity
)
abstract GetScalar :
        entity : DbEntity -> Object
override GetScalar :
        entity : DbEntity -> Object

Parameters

entity
Type: Adf.DbDbEntity
对象

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetScalar(DbEntity)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.GetScalar(T) Method (DbEntity)

DbFactoryGetScalarT Method (DbEntity)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T GetScalar<T>(
    DbEntity entity
)

Public Overridable Function GetScalar(Of T) (
    entity As DbEntity
) As T
public:
generic<typename T>
virtual T GetScalar(
    DbEntity^ entity
)
abstract GetScalar :
        entity : DbEntity -> 'T
override GetScalar :
        entity : DbEntity -> 'T

Parameters

entity
Type: Adf.DbDbEntity
对象

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar``1(Adf.Db.DbEntity)"]

Implements

IDbFactoryGetScalarT(DbEntity)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.GetScalar Method (DbEntity, String)

DbFactoryGetScalar Method (DbEntity, String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetScalar(
    DbEntity entity,
    string storedProcedure
)
Public Overridable Function GetScalar (
    entity As DbEntity,
    storedProcedure As String
) As Object
public:
virtual Object^ GetScalar(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetScalar :
        entity : DbEntity *
        storedProcedure : string -> Object
override GetScalar :
        entity : DbEntity *
        storedProcedure : string -> Object

Parameters

entity
Type: Adf.DbDbEntity
对象
storedProcedure
Type: SystemString
要执行的存储过程名

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetScalar(DbEntity, String)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.GetScalar(T) Method (DbEntity, String)

DbFactoryGetScalarT Method (DbEntity, String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T GetScalar<T>(
    DbEntity entity,
    string storedProcedure
)

Public Overridable Function GetScalar(Of T) (
    entity As DbEntity,
    storedProcedure As String
) As T
public:
generic<typename T>
virtual T GetScalar(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetScalar :
        entity : DbEntity *
        storedProcedure : string -> 'T
override GetScalar :
        entity : DbEntity *
        storedProcedure : string -> 'T

Parameters

entity
Type: Adf.DbDbEntity
对象
storedProcedure
Type: SystemString
要执行的存储过程名

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar``1(Adf.Db.DbEntity,System.String)"]

Implements

IDbFactoryGetScalarT(DbEntity, String)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.GetScalar Method (String, Boolean, IDbDataParameter[])

DbFactoryGetScalar Method (String, Boolean, IDbDataParameter)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual Object GetScalar(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
Public Overridable Function GetScalar (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As Object
public:
virtual Object^ GetScalar(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract GetScalar :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> Object
override GetScalar :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> Object

Parameters

sqlString
Type: SystemString
要执行的语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parames
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryGetScalar(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.GetScalar(T) Method (String, Boolean, IDbDataParameter[])

DbFactoryGetScalarT Method (String, Boolean, IDbDataParameter)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T GetScalar<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)

Public Overridable Function GetScalar(Of T) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As T
public:
generic<typename T>
virtual T GetScalar(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract GetScalar :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> 'T
override GetScalar :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> 'T

Parameters

sqlString
Type: SystemString
要执行的语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parames
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.DbFactory.GetScalar``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

Implements

IDbFactoryGetScalarT(String, Boolean, IDbDataParameter)
See Also

Reference

DbFactory Class
GetScalar Overload
Adf.Db Namespace


DbFactory.InjectReplace Method

DbFactoryInjectReplace Method
SQL注入过滤

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string InjectReplace(
    string input
)
Public Overridable Function InjectReplace (
    input As String
) As String
public:
virtual String^ InjectReplace(
    String^ input
)
abstract InjectReplace :
        input : string -> string
override InjectReplace :
        input : string -> string

Parameters

input
Type: SystemString
要过滤的数据

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbFactory.InjectReplace(System.String)"]

Implements

IDbFactoryInjectReplace(String)
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Insert Method

DbFactoryInsert Method
执行数据对象插入请求

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int Insert(
    DbEntity entity
)
Public Overridable Function Insert (
    entity As DbEntity
) As Integer
public:
virtual int Insert(
    DbEntity^ entity
)
abstract Insert :
        entity : DbEntity -> int
override Insert :
        entity : DbEntity -> int

Parameters

entity
Type: Adf.DbDbEntity
数据对象

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.Insert(Adf.Db.DbEntity)"]

Implements

IDbFactoryInsert(DbEntity)
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.LogBuilder Method

DbFactoryLogBuilder Method
日志添加

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual string LogBuilder(
    string sql,
    IDbDataParameter[] parames,
    bool storedProcedure
)
Protected Overridable Function LogBuilder (
    sql As String,
    parames As IDbDataParameter(),
    storedProcedure As Boolean
) As String
protected:
virtual String^ LogBuilder(
    String^ sql,
    array<IDbDataParameter^>^ parames,
    bool storedProcedure
)
abstract LogBuilder :
        sql : string *
        parames : IDbDataParameter[] *
        storedProcedure : bool -> string
override LogBuilder :
        sql : string *
        parames : IDbDataParameter[] *
        storedProcedure : bool -> string

Parameters

sql
Type: SystemString
内容
parames
Type: System.DataIDbDataParameter
参数列表
storedProcedure
Type: SystemBoolean
是否以过程运行

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbFactory.LogBuilder(System.String,System.Data.IDbDataParameter[],System.Boolean)"]

See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.LogManagerInitialize Method

DbFactoryLogManagerInitialize Method
日志管理器初始

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual void LogManagerInitialize()
Protected Overridable Sub LogManagerInitialize
protected:
virtual void LogManagerInitialize()
abstract LogManagerInitialize : unit -> unit
override LogManagerInitialize : unit -> unit
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.PageSql(T) Method

DbFactoryPageSqlT Method
返回一个分页列表对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual List<T> PageSql<T>(
    int pageindex,
    int pagesize,
    string fields,
    string tablename,
    string condition,
    string orderby,
    string key = "",
    string groupby = "",
    bool distinct = false
)
where T : IDbEntity

Public Overridable Function PageSql(Of T As IDbEntity) (
    pageindex As Integer,
    pagesize As Integer,
    fields As String,
    tablename As String,
    condition As String,
    orderby As String,
    Optional key As String = "",
    Optional groupby As String = "",
    Optional distinct As Boolean = false
) As List(Of T)
public:
generic<typename T>
where T : IDbEntity
virtual List<T>^ PageSql(
    int pageindex,
    int pagesize,
    String^ fields,
    String^ tablename,
    String^ condition,
    String^ orderby,
    String^ key = L"",
    String^ groupby = L"",
    bool distinct = false
)
abstract PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> List<'T>  when 'T : IDbEntity
override PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> List<'T>  when 'T : IDbEntity

Parameters

pageindex
Type: SystemInt32
页序
pagesize
Type: SystemInt32
页大小
fields
Type: SystemString
字段值,前后不带空格,位于 Select 与 From 之间的字段部表示
tablename
Type: SystemString
要进行查询的数据表,可为多个
condition
Type: SystemString
要进行查询的查询串,Where的后缀,如果未有,请设置为 null
orderby
Type: SystemString
排序方法,如果未有排序则为null
key (Optional)
Type: SystemString
键
groupby (Optional)
Type: SystemString
分组,分组请设置为null
distinct (Optional)
Type: SystemBoolean

[Missing <param name="distinct"/> documentation for "M:Adf.Db.DbFactory.PageSql``1(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Db.DbFactory.PageSql``1(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Type: List T
返回生成后的Sql语句

Implements

IDbFactoryPageSqlT(Int32, Int32, String, String, String, String, String, String, Boolean)
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Rollback Method

DbFactoryRollback Method
回滚事务,当并行事务已回滚时则跳过

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void Rollback()
Public Overridable Sub Rollback
public:
virtual void Rollback()
abstract Rollback : unit -> unit
override Rollback : unit -> unit

Return Value

Type:
当并行事务时反回是否执行了回滚操作，非并行事务返回固定Boolean

Implements

IDbFactoryRollback
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.ToSafeString Method

DbFactoryToSafeString Method
Overload List
 | Name | Description
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.ToSafeString Method (Object)

DbFactoryToSafeString Method (Object)
根据数据类型返回一个可以直接应用于SQL语句的安全字符串

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string ToSafeString(
    Object value
)
Public Overridable Function ToSafeString (
    value As Object
) As String
public:
virtual String^ ToSafeString(
    Object^ value
)
abstract ToSafeString :
        value : Object -> string
override ToSafeString :
        value : Object -> string

Parameters

value
Type: SystemObject
要添加的值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbFactory.ToSafeString(System.Object)"]

Implements

IDbFactoryToSafeString(Object)
See Also

Reference

DbFactory Class
ToSafeString Overload
Adf.Db Namespace


DbFactory.ToSafeString Method (Object, Type)

DbFactoryToSafeString Method (Object, Type)
根据数据类型返回一个可以直接应用于SQL语句的安全字符串

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string ToSafeString(
    Object value,
    Type type
)
Public Overridable Function ToSafeString (
    value As Object,
    type As Type
) As String
public:
virtual String^ ToSafeString(
    Object^ value,
    Type^ type
)
abstract ToSafeString :
        value : Object *
        type : Type -> string
override ToSafeString :
        value : Object *
        type : Type -> string

Parameters

value
Type: SystemObject
要添加的值
type
Type: SystemType
类型

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbFactory.ToSafeString(System.Object,System.Type)"]

Implements

IDbFactoryToSafeString(Object, Type)
See Also

Reference

DbFactory Class
ToSafeString Overload
Adf.Db Namespace


DbFactory.Update Method

DbFactoryUpdate Method
执行数据对象修改

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int Update(
    DbEntity update,
    DbEntity where
)
Public Overridable Function Update (
    update As DbEntity,
    where As DbEntity
) As Integer
public:
virtual int Update(
    DbEntity^ update,
    DbEntity^ where
)
abstract Update :
        update : DbEntity *
        where : DbEntity -> int
override Update :
        update : DbEntity *
        where : DbEntity -> int

Parameters

update
Type: Adf.DbDbEntity
数据对象
where
Type: Adf.DbDbEntity
条件对像

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbFactory.Update(Adf.Db.DbEntity,Adf.Db.DbEntity)"]

Implements

IDbFactoryUpdate(DbEntity, DbEntity)
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory Properties

DbFactory Properties

The DbFactory type exposes the following members.

Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作
Public property | Connection | 获取当前数据库连接串
Protected property | DbProviderFactory | 获取当前数据数据处理方法集
Public property | LastSql | 获取最后一个查询SQL
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新
Public property | Name | 获取当前操作对象的名称描述
Public property | NestedTransaction | 获取是否为并行（嵌套）事务
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性
Public property | SqlBuilder | 返回可用的SqlBuilder对象
Public property | Transaction | 获取当前正在执行的事务
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级
Top
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.CommandCount Property

DbFactoryCommandCount Property
获取Command数，间接反应了执行了多少次数据操作

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int CommandCount { get; }
Public ReadOnly Property CommandCount As Integer
    Get
public:
virtual property int CommandCount {
    int get () sealed;
}
abstract CommandCount : int with get
override CommandCount : int with get

Property Value

Type: Int32

Implements

IDbFactoryCommandCount
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Connection Property

DbFactoryConnection Property
获取当前数据库连接串

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual IDbConnection Connection { get; protected set; }
Public Overridable Property Connection As IDbConnection
    Get
    Protected Set
public:
virtual property IDbConnection^ Connection {
    IDbConnection^ get ();
    protected: void set (IDbConnection^ value);
}
abstract Connection : IDbConnection with get, set
override Connection : IDbConnection with get, set

Property Value

Type: IDbConnection

Implements

IDbFactoryConnection
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.DbProviderFactory Property

DbFactoryDbProviderFactory Property
获取当前数据数据处理方法集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected DbProviderFactory DbProviderFactory { get; }
Protected ReadOnly Property DbProviderFactory As DbProviderFactory
    Get
protected:
property DbProviderFactory^ DbProviderFactory {
    DbProviderFactory^ get ();
}
member DbProviderFactory : DbProviderFactory with get

Property Value

Type: DbProviderFactory
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.LastSql Property

DbFactoryLastSql Property
获取最后一个查询SQL

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string LastSql { get; }
Public Overridable ReadOnly Property LastSql As String
    Get
public:
virtual property String^ LastSql {
    String^ get ();
}
abstract LastSql : string with get
override LastSql : string with get

Property Value

Type: String

Implements

IDbFactoryLastSql
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Logger Property

DbFactoryLogger Property
日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbLogger Logger { get; }
Public ReadOnly Property Logger As DbLogger
    Get
public:
property DbLogger^ Logger {
    DbLogger^ get ();
}
member Logger : DbLogger with get

Property Value

Type: DbLogger
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Name Property

DbFactoryName Property
获取当前操作对象的名称描述

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public abstract string Name { get; }
Public MustOverride ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () abstract;
}
abstract Name : string with get

Property Value

Type: String

Implements

IDbFactoryName
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.NestedTransaction Property

DbFactoryNestedTransaction Property
获取是否为并行（嵌套）事务

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool NestedTransaction { get; }
Public Overridable ReadOnly Property NestedTransaction As Boolean
    Get
public:
virtual property bool NestedTransaction {
    bool get ();
}
abstract NestedTransaction : bool with get
override NestedTransaction : bool with get

Property Value

Type: Boolean

Implements

IDbFactoryNestedTransaction
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.ParameterChar Property

DbFactoryParameterChar Property
获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual string ParameterChar { get; }
Protected Overridable ReadOnly Property ParameterChar As String
    Get
protected:
virtual property String^ ParameterChar {
    String^ get ();
}
abstract ParameterChar : string with get
override ParameterChar : string with get

Property Value

Type: String
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.SqlBuilder Property

DbFactorySqlBuilder Property
返回可用的SqlBuilder对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual SqlBuilder SqlBuilder { get; }
Public Overridable ReadOnly Property SqlBuilder As SqlBuilder
    Get
public:
virtual property SqlBuilder^ SqlBuilder {
    SqlBuilder^ get ();
}
abstract SqlBuilder : SqlBuilder with get
override SqlBuilder : SqlBuilder with get

Return Value

Type: SqlBuilder

Implements

IDbFactorySqlBuilder
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.Transaction Property

DbFactoryTransaction Property
获取当前正在执行的事务

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual IDbTransaction Transaction { get; }
Public Overridable ReadOnly Property Transaction As IDbTransaction
    Get
public:
virtual property IDbTransaction^ Transaction {
    IDbTransaction^ get ();
}
abstract Transaction : IDbTransaction with get
override Transaction : IDbTransaction with get

Property Value

Type: IDbTransaction

Implements

IDbFactoryTransaction
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbFactory.TransactionLayer Property

DbFactoryTransactionLayer Property
获取为并行(嵌套)事务时的当前事务层级

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual int TransactionLayer { get; }
Public Overridable ReadOnly Property TransactionLayer As Integer
    Get
public:
virtual property int TransactionLayer {
    int get ();
}
abstract TransactionLayer : int with get
override TransactionLayer : int with get

Property Value

Type: Int32

Implements

IDbFactoryTransactionLayer
See Also

Reference

DbFactory Class
Adf.Db Namespace


DbHelper Class

DbHelper Class
DB助手
Inheritance Hierarchy
SystemObject
Adf.DbDbHelper

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DbHelper
Public Class DbHelper
public ref class DbHelper
type DbHelper =  class end

The DbHelper type exposes the following members.

Constructors
 | Name | Description
Public method | DbHelper | Initializes a new instance of the DbHelper class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | IDataReaderToDataTable | 将读取器转换为DataTable
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Replace | 进行数据的安全串过滤,防止常规SQL注入
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Adf.Db Namespace


DbHelper Constructor

DbHelper Constructor
Initializes a new instance of the DbHelper class

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbHelper()
Public Sub New
public:
DbHelper()
new : unit -> DbHelper
See Also

Reference

DbHelper Class
Adf.Db Namespace


DbHelper Methods

DbHelper Methods

The DbHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | IDataReaderToDataTable | 将读取器转换为DataTable
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Replace | 进行数据的安全串过滤,防止常规SQL注入
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DbHelper Class
Adf.Db Namespace


DbHelper.IDataReaderToDataTable Method

DbHelperIDataReaderToDataTable Method
将读取器转换为DataTable

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static DataTable IDataReaderToDataTable(
    IDataReader reader
)
Public Shared Function IDataReaderToDataTable (
    reader As IDataReader
) As DataTable
public:
static DataTable^ IDataReaderToDataTable(
    IDataReader^ reader
)
static member IDataReaderToDataTable :
        reader : IDataReader -> DataTable

Parameters

reader
Type: System.DataIDataReader
数据读取器

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.DbHelper.IDataReaderToDataTable(System.Data.IDataReader)"]

See Also

Reference

DbHelper Class
Adf.Db Namespace


DbHelper.Replace Method

DbHelperReplace Method
进行数据的安全串过滤,防止常规SQL注入

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string Replace(
    string input
)
Public Shared Function Replace (
    input As String
) As String
public:
static String^ Replace(
    String^ input
)
static member Replace :
        input : string -> string

Parameters

input
Type: SystemString
要进行过滤的数据串

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbHelper.Replace(System.String)"]

See Also

Reference

DbHelper Class
Adf.Db Namespace


DbLogger Class

DbLogger Class
数据库日志管理器
Inheritance Hierarchy
SystemObject
AdfLogManager
Adf.DbDbLogger

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DbLogger : LogManager
Public Class DbLogger
    Inherits LogManager
public ref class DbLogger : public LogManager
type DbLogger =
    class
        inherit LogManager
    end

The DbLogger type exposes the following members.

Constructors
 | Name | Description
Public method | DbLogger | 初始新实例
Top
Methods
 | Name | Description
Public method | Dispose | 资源释放 (Inherited from LogManager.)
Public method | Enable | 设置是否开启日志 (Inherited from LogManager.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exception | 异常记录 (Inherited from LogManager.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新并存储所有缓冲区内容，该方法一般在应用结束或需要批量将数据存储时使用 (Inherited from LogManager.)
Protected method | ForEach | 循环当前每个日志写入器 (Inherited from LogManager.)
Public method | GetExceptionWriter | get exception logmanager (Inherited from LogManager.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWriter | get name logwriter (Inherited from LogManager.)
Protected method | LogBuilder | 日志添加
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendExceptionMail | 发送异常邮件 (Inherited from LogManager.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | WriteCommand | 构造日志
Protected method | WritingToConsole | console logger (Inherited from LogManager.)
Top
Fields
Name | Description
Instance | 默认实例
Top
Properties
 | Name | Description
Public property | AllDisabled | 是否全部禁用，当配置Log:Disabled为all时此值为true (Inherited from LogManager.)
Public property | Error | 错误记录 (Inherited from LogManager.)
Public property | IsOwnner | 是否具有所有者，当初始name为空时此值为false,否则为true (Inherited from LogManager.)
Public property | Message | 消息记录 (Inherited from LogManager.)
Public property | Name | 名称 (Inherited from LogManager.)
Public property | NewExceptionToMail | 记录新异常时是否发送至邮件（若邮件已配置）,默认开启 (Inherited from LogManager.)
Public property | Path | 存储路径 (Inherited from LogManager.)
Public property | ToConsole | 是否输出至Console (Inherited from LogManager.)
Public property | Warning | 警告记录 (Inherited from LogManager.)
Top
Events
 | Name | Description
Public event | NewException | 新异常 (Inherited from LogManager.)
Public event | Writing | 新写入事件 (Inherited from LogManager.)
Top
See Also

Reference

Adf.Db Namespace


DbLogger Constructor

DbLogger Constructor
初始新实例

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbLogger()
Public Sub New
public:
DbLogger()
new : unit -> DbLogger
See Also

Reference

DbLogger Class
Adf.Db Namespace


DbLogger Fields

DbLogger Fields

The DbLogger type exposes the following members.

Fields
Name | Description
Instance | 默认实例
Top
See Also

Reference

DbLogger Class
Adf.Db Namespace


DbLogger.Instance Field

DbLoggerInstance Field
默认实例

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static readonly DbLogger Instance
Public Shared ReadOnly Instance As DbLogger
public:
static initonly DbLogger^ Instance
static val Instance: DbLogger

Field Value

Type: DbLogger
See Also

Reference

DbLogger Class
Adf.Db Namespace


DbLogger Methods

DbLogger Methods

The DbLogger type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 资源释放 (Inherited from LogManager.)
Public method | Enable | 设置是否开启日志 (Inherited from LogManager.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Exception | 异常记录 (Inherited from LogManager.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Flush | 刷新并存储所有缓冲区内容，该方法一般在应用结束或需要批量将数据存储时使用 (Inherited from LogManager.)
Protected method | ForEach | 循环当前每个日志写入器 (Inherited from LogManager.)
Public method | GetExceptionWriter | get exception logmanager (Inherited from LogManager.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetWriter | get name logwriter (Inherited from LogManager.)
Protected method | LogBuilder | 日志添加
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | SendExceptionMail | 发送异常邮件 (Inherited from LogManager.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | WriteCommand | 构造日志
Protected method | WritingToConsole | console logger (Inherited from LogManager.)
Top
See Also

Reference

DbLogger Class
Adf.Db Namespace


DbLogger.LogBuilder Method

DbLoggerLogBuilder Method
日志添加

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual string LogBuilder(
    IDbCommand command
)
Protected Overridable Function LogBuilder (
    command As IDbCommand
) As String
protected:
virtual String^ LogBuilder(
    IDbCommand^ command
)
abstract LogBuilder :
        command : IDbCommand -> string
override LogBuilder :
        command : IDbCommand -> string

Parameters

command
Type: System.DataIDbCommand

[Missing <param name="command"/> documentation for "M:Adf.Db.DbLogger.LogBuilder(System.Data.IDbCommand)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbLogger.LogBuilder(System.Data.IDbCommand)"]

See Also

Reference

DbLogger Class
Adf.Db Namespace


DbLogger.WriteCommand Method

DbLoggerWriteCommand Method
构造日志

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual void WriteCommand(
    DbFactory factory,
    IDbCommand command
)
Public Overridable Sub WriteCommand (
    factory As DbFactory,
    command As IDbCommand
)
public:
virtual void WriteCommand(
    DbFactory^ factory,
    IDbCommand^ command
)
abstract WriteCommand :
        factory : DbFactory *
        command : IDbCommand -> unit
override WriteCommand :
        factory : DbFactory *
        command : IDbCommand -> unit

Parameters

factory
Type: Adf.DbDbFactory

[Missing <param name="factory"/> documentation for "M:Adf.Db.DbLogger.WriteCommand(Adf.Db.DbFactory,System.Data.IDbCommand)"]

command
Type: System.DataIDbCommand

[Missing <param name="command"/> documentation for "M:Adf.Db.DbLogger.WriteCommand(Adf.Db.DbFactory,System.Data.IDbCommand)"]

See Also

Reference

DbLogger Class
Adf.Db Namespace


DbLogger Properties

DbLogger Properties

The DbLogger type exposes the following members.

Properties
 | Name | Description
Public property | AllDisabled | 是否全部禁用，当配置Log:Disabled为all时此值为true (Inherited from LogManager.)
Public property | Error | 错误记录 (Inherited from LogManager.)
Public property | IsOwnner | 是否具有所有者，当初始name为空时此值为false,否则为true (Inherited from LogManager.)
Public property | Message | 消息记录 (Inherited from LogManager.)
Public property | Name | 名称 (Inherited from LogManager.)
Public property | NewExceptionToMail | 记录新异常时是否发送至邮件（若邮件已配置）,默认开启 (Inherited from LogManager.)
Public property | Path | 存储路径 (Inherited from LogManager.)
Public property | ToConsole | 是否输出至Console (Inherited from LogManager.)
Public property | Warning | 警告记录 (Inherited from LogManager.)
Top
See Also

Reference

DbLogger Class
Adf.Db Namespace


DbLogger Events

DbLogger Events

The DbLogger type exposes the following members.

Events
 | Name | Description
Public event | NewException | 新异常 (Inherited from LogManager.)
Public event | Writing | 新写入事件 (Inherited from LogManager.)
Top
See Also

Reference

DbLogger Class
Adf.Db Namespace


DbReader Class

DbReader Class
Public Reader
Inheritance Hierarchy
SystemObject
Adf.DbDbReader

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class DbReader : IDbReader
Public Class DbReader
    Implements IDbReader
public ref class DbReader : IDbReader
type DbReader =
    class
        interface IDbReader
    end

The DbReader type exposes the following members.

Constructors
 | Name | Description
Public method | DbReader | initialize new instance
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | get value
Public method | GetT(String) | get value
Public method | GetAsBoolean | Get To Boolean
Public method | GetAsByte | Get To Byte
Public method | GetAsDateTime | Get To DateTime
Public method | GetAsDecimail | Get To Decimal
Public method | GetAsDouble | Get To Double
Public method | GetAsInt16 | Get To Int16
Public method | GetAsInt32 | Get To Int32
Public method | GetAsInt64 | Get To Int64
Public method | GetAsSByte | Get To SByte
Public method | GetAsString | Get To String
Public method | GetAsUInt16 | Get To Uint16
Public method | GetAsUInt32 | Get To Uint32
Public method | GetAsUInt64 | Get To Uint64
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | NameIndex | data
Public property | Reader | get reader object
Top
See Also

Reference

Adf.Db Namespace


DbReader Constructor

DbReader Constructor
initialize new instance

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DbReader(
    IDataReader reader
)
Public Sub New (
    reader As IDataReader
)
public:
DbReader(
    IDataReader^ reader
)
new :
        reader : IDataReader -> DbReader

Parameters

reader
Type: System.DataIDataReader

[Missing <param name="reader"/> documentation for "M:Adf.Db.DbReader.#ctor(System.Data.IDataReader)"]

See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader Methods

DbReader Methods

The DbReader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | Get(String) | get value
Public method | GetT(String) | get value
Public method | GetAsBoolean | Get To Boolean
Public method | GetAsByte | Get To Byte
Public method | GetAsDateTime | Get To DateTime
Public method | GetAsDecimail | Get To Decimal
Public method | GetAsDouble | Get To Double
Public method | GetAsInt16 | Get To Int16
Public method | GetAsInt32 | Get To Int32
Public method | GetAsInt64 | Get To Int64
Public method | GetAsSByte | Get To SByte
Public method | GetAsString | Get To String
Public method | GetAsUInt16 | Get To Uint16
Public method | GetAsUInt32 | Get To Uint32
Public method | GetAsUInt64 | Get To Uint64
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.Get Method

DbReaderGet Method
Overload List
 | Name | Description
Public method | GetT(String) | get value
Public method | Get(String) | get value
Top
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.Get(T) Method (String)

DbReaderGetT Method (String)
get value

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual T Get<T>(
    string name
)

Public Overridable Function Get(Of T) (
    name As String
) As T
public:
generic<typename T>
virtual T Get(
    String^ name
)
abstract Get :
        name : string -> 'T
override Get :
        name : string -> 'T

Parameters

name
Type: SystemString
field name

Type Parameters

T
value type

Return Value

Type: T
is T type value

Implements

IDbReaderGetT(String)
See Also

Reference

DbReader Class
Get Overload
Adf.Db Namespace


DbReader.Get Method (String)

DbReaderGet Method (String)
get value

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Object Get(
    string name
)
Public Function Get (
    name As String
) As Object
public:
virtual Object^ Get(
    String^ name
) sealed
abstract Get :
        name : string -> Object
override Get :
        name : string -> Object

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.Get(System.String)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.DbReader.Get(System.String)"]

Implements

IDbReaderGet(String)
See Also

Reference

DbReader Class
Get Overload
Adf.Db Namespace


DbReader.GetAsBoolean Method

DbReaderGetAsBoolean Method
Get To Boolean

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public bool GetAsBoolean(
    string name
)
Public Function GetAsBoolean (
    name As String
) As Boolean
public:
virtual bool GetAsBoolean(
    String^ name
) sealed
abstract GetAsBoolean :
        name : string -> bool
override GetAsBoolean :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsBoolean(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsBoolean(System.String)"]

Implements

IDbReaderGetAsBoolean(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsByte Method

DbReaderGetAsByte Method
Get To Byte

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public byte GetAsByte(
    string name
)
Public Function GetAsByte (
    name As String
) As Byte
public:
virtual unsigned char GetAsByte(
    String^ name
) sealed
abstract GetAsByte :
        name : string -> byte
override GetAsByte :
        name : string -> byte

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsByte(System.String)"]

Implements

IDbReaderGetAsByte(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsDateTime Method

DbReaderGetAsDateTime Method
Get To DateTime

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public DateTime GetAsDateTime(
    string name
)
Public Function GetAsDateTime (
    name As String
) As DateTime
public:
virtual DateTime GetAsDateTime(
    String^ name
) sealed
abstract GetAsDateTime :
        name : string -> DateTime
override GetAsDateTime :
        name : string -> DateTime

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsDateTime(System.String)"]

Return Value

Type: DateTime

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsDateTime(System.String)"]

Implements

IDbReaderGetAsDateTime(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsDecimail Method

DbReaderGetAsDecimail Method
Get To Decimal

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public decimal GetAsDecimail(
    string name
)
Public Function GetAsDecimail (
    name As String
) As Decimal
public:
virtual Decimal GetAsDecimail(
    String^ name
) sealed
abstract GetAsDecimail :
        name : string -> decimal
override GetAsDecimail :
        name : string -> decimal

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsDecimail(System.String)"]

Return Value

Type: Decimal

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsDecimail(System.String)"]

Implements

IDbReaderGetAsDecimail(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsDouble Method

DbReaderGetAsDouble Method
Get To Double

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public double GetAsDouble(
    string name
)
Public Function GetAsDouble (
    name As String
) As Double
public:
virtual double GetAsDouble(
    String^ name
) sealed
abstract GetAsDouble :
        name : string -> float
override GetAsDouble :
        name : string -> float

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsDouble(System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsDouble(System.String)"]

Implements

IDbReaderGetAsDouble(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsInt16 Method

DbReaderGetAsInt16 Method
Get To Int16

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public short GetAsInt16(
    string name
)
Public Function GetAsInt16 (
    name As String
) As Short
public:
virtual short GetAsInt16(
    String^ name
) sealed
abstract GetAsInt16 :
        name : string -> int16
override GetAsInt16 :
        name : string -> int16

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsInt16(System.String)"]

Return Value

Type: Int16

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsInt16(System.String)"]

Implements

IDbReaderGetAsInt16(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsInt32 Method

DbReaderGetAsInt32 Method
Get To Int32

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int GetAsInt32(
    string name
)
Public Function GetAsInt32 (
    name As String
) As Integer
public:
virtual int GetAsInt32(
    String^ name
) sealed
abstract GetAsInt32 :
        name : string -> int
override GetAsInt32 :
        name : string -> int

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsInt32(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsInt32(System.String)"]

Implements

IDbReaderGetAsInt32(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsInt64 Method

DbReaderGetAsInt64 Method
Get To Int64

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public long GetAsInt64(
    string name
)
Public Function GetAsInt64 (
    name As String
) As Long
public:
virtual long long GetAsInt64(
    String^ name
) sealed
abstract GetAsInt64 :
        name : string -> int64
override GetAsInt64 :
        name : string -> int64

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsInt64(System.String)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsInt64(System.String)"]

Implements

IDbReaderGetAsInt64(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsSByte Method

DbReaderGetAsSByte Method
Get To SByte

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public sbyte GetAsSByte(
    string name
)
Public Function GetAsSByte (
    name As String
) As SByte
public:
virtual signed char GetAsSByte(
    String^ name
) sealed
abstract GetAsSByte :
        name : string -> sbyte
override GetAsSByte :
        name : string -> sbyte

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsSByte(System.String)"]

Return Value

Type: SByte

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsSByte(System.String)"]

Implements

IDbReaderGetAsSByte(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsString Method

DbReaderGetAsString Method
Get To String

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string GetAsString(
    string name
)
Public Function GetAsString (
    name As String
) As String
public:
virtual String^ GetAsString(
    String^ name
) sealed
abstract GetAsString :
        name : string -> string
override GetAsString :
        name : string -> string

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsString(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsString(System.String)"]

Implements

IDbReaderGetAsString(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsUInt16 Method

DbReaderGetAsUInt16 Method
Get To Uint16

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ushort GetAsUInt16(
    string name
)
Public Function GetAsUInt16 (
    name As String
) As UShort
public:
virtual unsigned short GetAsUInt16(
    String^ name
) sealed
abstract GetAsUInt16 :
        name : string -> uint16
override GetAsUInt16 :
        name : string -> uint16

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsUInt16(System.String)"]

Return Value

Type: UInt16

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsUInt16(System.String)"]

Implements

IDbReaderGetAsUInt16(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsUInt32 Method

DbReaderGetAsUInt32 Method
Get To Uint32

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public uint GetAsUInt32(
    string name
)
Public Function GetAsUInt32 (
    name As String
) As UInteger
public:
virtual unsigned int GetAsUInt32(
    String^ name
) sealed
abstract GetAsUInt32 :
        name : string -> uint32
override GetAsUInt32 :
        name : string -> uint32

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsUInt32(System.String)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsUInt32(System.String)"]

Implements

IDbReaderGetAsUInt32(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.GetAsUInt64 Method

DbReaderGetAsUInt64 Method
Get To Uint64

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ulong GetAsUInt64(
    string name
)
Public Function GetAsUInt64 (
    name As String
) As ULong
public:
virtual unsigned long long GetAsUInt64(
    String^ name
) sealed
abstract GetAsUInt64 :
        name : string -> uint64
override GetAsUInt64 :
        name : string -> uint64

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.DbReader.GetAsUInt64(System.String)"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:Adf.Db.DbReader.GetAsUInt64(System.String)"]

Implements

IDbReaderGetAsUInt64(String)
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader Properties

DbReader Properties

The DbReader type exposes the following members.

Properties
 | Name | Description
Public property | NameIndex | data
Public property | Reader | get reader object
Top
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.NameIndex Property

DbReaderNameIndex Property
data

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Dictionary<string, int> NameIndex { get; }
Public ReadOnly Property NameIndex As Dictionary(Of String, Integer)
    Get
public:
virtual property Dictionary<String^, int>^ NameIndex {
    Dictionary<String^, int>^ get () sealed;
}
abstract NameIndex : Dictionary<string, int> with get
override NameIndex : Dictionary<string, int> with get

Property Value

Type: Dictionary String, Int32

Implements

IDbReaderNameIndex
See Also

Reference

DbReader Class
Adf.Db Namespace


DbReader.Reader Property

DbReaderReader Property
get reader object

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public IDataReader Reader { get; }
Public ReadOnly Property Reader As IDataReader
    Get
public:
virtual property IDataReader^ Reader {
    IDataReader^ get () sealed;
}
abstract Reader : IDataReader with get
override Reader : IDataReader with get

Property Value

Type: IDataReader

Implements

IDbReaderReader
See Also

Reference

DbReader Class
Adf.Db Namespace


IDbEntity Interface

IDbEntity Interface
Support Reader Import Flag

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface IDbEntity
Public Interface IDbEntity
public interface class IDbEntity
type IDbEntity =  interface end

The IDbEntity type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | import reader
Top
See Also

Reference

Adf.Db Namespace


IDbEntity Methods

IDbEntity Methods

The IDbEntity type exposes the following members.

Methods
 | Name | Description
Public method | Initialize | import reader
Top
See Also

Reference

IDbEntity Interface
Adf.Db Namespace


IDbEntity.Initialize Method

IDbEntityInitialize Method
import reader

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
void Initialize(
    IDbReader reader
)
Sub Initialize (
    reader As IDbReader
)
void Initialize(
    IDbReader^ reader
)
abstract Initialize :
        reader : IDbReader -> unit

Parameters

reader
Type: Adf.DbIDbReader

[Missing <param name="reader"/> documentation for "M:Adf.Db.IDbEntity.Initialize(Adf.Db.IDbReader)"]

See Also

Reference

IDbEntity Interface
Adf.Db Namespace


IDbFactory Interface

IDbFactory Interface
数据工厂接口

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface IDbFactory : IDisposable
Public Interface IDbFactory
    Inherits IDisposable
public interface class IDbFactory : IDisposable
type IDbFactory =
    interface
        interface IDisposable
    end

The IDbFactory type exposes the following members.

Methods
 | Name | Description
Public method | Begin | 开始一个事务执行
Public method | Commit | 提交一个事务执行
Public method | Commit(Boolean) | 提交一个事务执行
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象
Public method | CreateParameter(String, Object, Int32) | 创建一个参数
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数
Public method | Delete | 执行数据对象删除处理
Public method | Dispose | 执行与释放或重置非托管资源相关的应用程序定义的任务。 (Inherited from IDisposable.)
Public method | Execute(String) | 执行一个语句或过程
Public method | Execute(DbEntity, String) | 执行一个语句或过程
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(DbEntity) | 获取指定对象的记录数
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数
Public method | GetDataSet(String) | 返回一个数据集
Public method | GetDataSet(DbEntity) | 返回一个数据集
Public method | GetDataSet(DbEntity, String) | 返回一个数据集
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集
Public method | GetDataTable(String) | 返回一个数据表
Public method | GetDataTable(DbEntity) | 返回一个数据表
Public method | GetDataTable(DbEntity, String) | 返回一个数据表
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表
Public method | GetIdentity | 返回最后一次产生的键值
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetListT(String) | 返回一个数据对象集
Public method | GetListT(DbEntity) | 返回一个数据对象集
Public method | GetListT(DbEntity, String) | 返回一个数据对象集
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Public method | GetListsT(String) | 返回一个多数据对象集
Public method | GetListsT(DbEntity) | 返回一个多数据对象集
Public method | GetListsT(DbEntity, String) | 返回一个多数据对象集
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个多数据对象集
Public method | GetRowT(String) | 返回一个数据对象
Public method | GetRowT(DbEntity) | 返回一个数据对象
Public method | GetRowT(DbEntity, String) | 返回一个数据对象
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象
Public method | GetScalar(String) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetScalarT(String) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalarT(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | InjectReplace | SQL注入过滤
Public method | Insert | 执行数据对象插入请求
Public method | PageSqlT | 返回一个分页列表对象
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | Update | 执行数据对象修改
Top
Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作
Public property | Connection | 获取当前数据库连接串
Public property | LastSql | 最后一个Command SQL
Public property | Name | 获取当前工厂名称描述
Public property | NestedTransaction | 获取是否为并行（嵌套）事务
Public property | SqlBuilder | 返回可用的SqlBuilder对象
Public property | Transaction | 获取当前正在执行的事务
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级
Top
See Also

Reference

Adf.Db Namespace


IDbFactory Methods

IDbFactory Methods

The IDbFactory type exposes the following members.

Methods
 | Name | Description
Public method | Begin | 开始一个事务执行
Public method | Commit | 提交一个事务执行
Public method | Commit(Boolean) | 提交一个事务执行
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象
Public method | CreateParameter(String, Object, Int32) | 创建一个参数
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数
Public method | Delete | 执行数据对象删除处理
Public method | Dispose | 执行与释放或重置非托管资源相关的应用程序定义的任务。 (Inherited from IDisposable.)
Public method | Execute(String) | 执行一个语句或过程
Public method | Execute(DbEntity, String) | 执行一个语句或过程
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(DbEntity) | 获取指定对象的记录数
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数
Public method | GetDataSet(String) | 返回一个数据集
Public method | GetDataSet(DbEntity) | 返回一个数据集
Public method | GetDataSet(DbEntity, String) | 返回一个数据集
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集
Public method | GetDataTable(String) | 返回一个数据表
Public method | GetDataTable(DbEntity) | 返回一个数据表
Public method | GetDataTable(DbEntity, String) | 返回一个数据表
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表
Public method | GetIdentity | 返回最后一次产生的键值
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetListT(String) | 返回一个数据对象集
Public method | GetListT(DbEntity) | 返回一个数据对象集
Public method | GetListT(DbEntity, String) | 返回一个数据对象集
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Public method | GetListsT(String) | 返回一个多数据对象集
Public method | GetListsT(DbEntity) | 返回一个多数据对象集
Public method | GetListsT(DbEntity, String) | 返回一个多数据对象集
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个多数据对象集
Public method | GetRowT(String) | 返回一个数据对象
Public method | GetRowT(DbEntity) | 返回一个数据对象
Public method | GetRowT(DbEntity, String) | 返回一个数据对象
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象
Public method | GetScalar(String) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetScalarT(String) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalarT(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | InjectReplace | SQL注入过滤
Public method | Insert | 执行数据对象插入请求
Public method | PageSqlT | 返回一个分页列表对象
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | Update | 执行数据对象修改
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Begin Method

IDbFactoryBegin Method
开始一个事务执行

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Begin()
Function Begin As Integer
int Begin()
abstract Begin : unit -> int

Return Value

Type: Int32
事务嵌套层级
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Commit Method

IDbFactoryCommit Method
Overload List
 | Name | Description
Public method | Commit | 提交一个事务执行
Public method | Commit(Boolean) | 提交一个事务执行
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Commit Method

IDbFactoryCommit Method
提交一个事务执行

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
void Commit()
Sub Commit
void Commit()
abstract Commit : unit -> unit
See Also

Reference

IDbFactory Interface
Commit Overload
Adf.Db Namespace


IDbFactory.Commit Method (Boolean)

IDbFactoryCommit Method (Boolean)
提交一个事务执行

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
void Commit(
    bool endNested
)
Sub Commit (
    endNested As Boolean
)
void Commit(
    bool endNested
)
abstract Commit :
        endNested : bool -> unit

Parameters

endNested
Type: SystemBoolean
是否直接完成并行事务,注意：当值为Boolean时你必需重新启用新事务，否则外围提交将无效.
See Also

Reference

IDbFactory Interface
Commit Overload
Adf.Db Namespace


IDbFactory.CreateCommand Method

IDbFactoryCreateCommand Method
根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
IDbCommand CreateCommand(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parames
)
Function CreateCommand (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parames As IDbDataParameter()
) As IDbCommand
IDbCommand^ CreateCommand(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parames
)
abstract CreateCommand :
        sqlString : string *
        storedProcedure : bool *
        parames : IDbDataParameter[] -> IDbCommand

Parameters

sqlString
Type: SystemString
执行串
storedProcedure
Type: SystemBoolean
是否以存储过程执行
parames
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: IDbCommand

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.CreateCommand(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.CreateParameter Method

IDbFactoryCreateParameter Method
Overload List
 | Name | Description
Public method | CreateParameter(String, Object, Int32) | 创建一个参数
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.CreateParameter Method (String, Object, Int32)

IDbFactoryCreateParameter Method (String, Object, Int32)
创建一个参数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
IDbDataParameter CreateParameter(
    string Name,
    Object Value,
    int length = 0
)
Function CreateParameter (
    Name As String,
    Value As Object,
    Optional length As Integer = 0
) As IDbDataParameter
IDbDataParameter^ CreateParameter(
    String^ Name,
    Object^ Value,
    int length = 0
)
abstract CreateParameter :
        Name : string *
        Value : Object *
        ?length : int
(* Defaults:
        let _length = defaultArg length 0
*)
-> IDbDataParameter

Parameters

Name
Type: SystemString
参数
Value
Type: SystemObject
参数值
length (Optional)
Type: SystemInt32
长度 >0 有效

Return Value

Type: IDbDataParameter

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.CreateParameter(System.String,System.Object,System.Int32)"]

See Also

Reference

IDbFactory Interface
CreateParameter Overload
Adf.Db Namespace


IDbFactory.CreateParameter Method (String, Object, DbType, Int32)

IDbFactoryCreateParameter Method (String, Object, DbType, Int32)
创建一个参数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
IDbDataParameter CreateParameter(
    string Name,
    Object Value,
    DbType dbType,
    int length = 0
)
Function CreateParameter (
    Name As String,
    Value As Object,
    dbType As DbType,
    Optional length As Integer = 0
) As IDbDataParameter
IDbDataParameter^ CreateParameter(
    String^ Name,
    Object^ Value,
    DbType dbType,
    int length = 0
)
abstract CreateParameter :
        Name : string *
        Value : Object *
        dbType : DbType *
        ?length : int
(* Defaults:
        let _length = defaultArg length 0
*)
-> IDbDataParameter

Parameters

Name
Type: SystemString
参数
Value
Type: SystemObject
参数值
dbType
Type: System.DataDbType
参数类型
length (Optional)
Type: SystemInt32
长度 >0 有效

Return Value

Type: IDbDataParameter

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.CreateParameter(System.String,System.Object,System.Data.DbType,System.Int32)"]

See Also

Reference

IDbFactory Interface
CreateParameter Overload
Adf.Db Namespace


IDbFactory.Delete Method

IDbFactoryDelete Method
执行数据对象删除处理

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Delete(
    DbEntity where
)
Function Delete (
    where As DbEntity
) As Integer
int Delete(
    DbEntity^ where
)
abstract Delete :
        where : DbEntity -> int

Parameters

where
Type: Adf.DbDbEntity
对象

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.Delete(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Execute Method

IDbFactoryExecute Method
Overload List
 | Name | Description
Public method | Execute(String) | 执行一个语句或过程
Public method | Execute(DbEntity, String) | 执行一个语句或过程
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Execute Method (String)

IDbFactoryExecute Method (String)
执行一个语句或过程

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Execute(
    string sqlString
)
Function Execute (
    sqlString As String
) As Integer
int Execute(
    String^ sqlString
)
abstract Execute :
        sqlString : string -> int

Parameters

sqlString
Type: SystemString
要执行的操作语句

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.Execute(System.String)"]

See Also

Reference

IDbFactory Interface
Execute Overload
Adf.Db Namespace


IDbFactory.Execute Method (DbEntity, String)

IDbFactoryExecute Method (DbEntity, String)
执行一个语句或过程

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Execute(
    DbEntity entity,
    string storedProcedure
)
Function Execute (
    entity As DbEntity,
    storedProcedure As String
) As Integer
int Execute(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract Execute :
        entity : DbEntity *
        storedProcedure : string -> int

Parameters

entity
Type: Adf.DbDbEntity
实体
storedProcedure
Type: SystemString
存储过程名

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.Execute(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
Execute Overload
Adf.Db Namespace


IDbFactory.Execute Method (String, Boolean, IDbDataParameter[])

IDbFactoryExecute Method (String, Boolean, IDbDataParameter)
执行一个语句或过程

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Execute(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
Function Execute (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As Integer
int Execute(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract Execute :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> int

Parameters

sqlString
Type: SystemString
要执行的操作语句
storedProcedure
Type: SystemBoolean
是否以存储过程执行
parameters
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.Execute(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
Execute Overload
Adf.Db Namespace


IDbFactory.GetCount Method

IDbFactoryGetCount Method
Overload List
 | Name | Description
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(DbEntity) | 获取指定对象的记录数
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetCount Method (String)

IDbFactoryGetCount Method (String)
获取指定语句第一行第一例的Int类型数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int GetCount(
    string sqlString
)
Function GetCount (
    sqlString As String
) As Integer
int GetCount(
    String^ sqlString
)
abstract GetCount :
        sqlString : string -> int

Parameters

sqlString
Type: SystemString
执行语句

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetCount(System.String)"]

See Also

Reference

IDbFactory Interface
GetCount Overload
Adf.Db Namespace


IDbFactory.GetCount Method (DbEntity)

IDbFactoryGetCount Method (DbEntity)
获取指定对象的记录数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int GetCount(
    DbEntity entity
)
Function GetCount (
    entity As DbEntity
) As Integer
int GetCount(
    DbEntity^ entity
)
abstract GetCount :
        entity : DbEntity -> int

Parameters

entity
Type: Adf.DbDbEntity
对象

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetCount(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetCount Overload
Adf.Db Namespace


IDbFactory.GetCount Method (String, Boolean)

IDbFactoryGetCount Method (String, Boolean)
获取指定语句第一行第一例的Int类型数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int GetCount(
    string sqlString,
    bool storedProcedure
)
Function GetCount (
    sqlString As String,
    storedProcedure As Boolean
) As Integer
int GetCount(
    String^ sqlString,
    bool storedProcedure
)
abstract GetCount :
        sqlString : string *
        storedProcedure : bool -> int

Parameters

sqlString
Type: SystemString
执行语句
storedProcedure
Type: SystemBoolean
是否以过程执行

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetCount(System.String,System.Boolean)"]

See Also

Reference

IDbFactory Interface
GetCount Overload
Adf.Db Namespace


IDbFactory.GetCount Method (String, String)

IDbFactoryGetCount Method (String, String)
根据表与条件返回一个COUNT值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int GetCount(
    string tablename,
    string condition
)
Function GetCount (
    tablename As String,
    condition As String
) As Integer
int GetCount(
    String^ tablename,
    String^ condition
)
abstract GetCount :
        tablename : string *
        condition : string -> int

Parameters

tablename
Type: SystemString
表名
condition
Type: SystemString
条件

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetCount(System.String,System.String)"]

See Also

Reference

IDbFactory Interface
GetCount Overload
Adf.Db Namespace


IDbFactory.GetCount Method (DbEntity, String)

IDbFactoryGetCount Method (DbEntity, String)
获取指定对象的记录数

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int GetCount(
    DbEntity entity,
    string storedProcedure
)
Function GetCount (
    entity As DbEntity,
    storedProcedure As String
) As Integer
int GetCount(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetCount :
        entity : DbEntity *
        storedProcedure : string -> int

Parameters

entity
Type: Adf.DbDbEntity
对象
storedProcedure
Type: SystemString
存储过程名

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetCount(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetCount Overload
Adf.Db Namespace


IDbFactory.GetDataSet Method

IDbFactoryGetDataSet Method
Overload List
 | Name | Description
Public method | GetDataSet(String) | 返回一个数据集
Public method | GetDataSet(DbEntity) | 返回一个数据集
Public method | GetDataSet(DbEntity, String) | 返回一个数据集
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetDataSet Method (String)

IDbFactoryGetDataSet Method (String)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataSet GetDataSet(
    string sqlString
)
Function GetDataSet (
    sqlString As String
) As DataSet
DataSet^ GetDataSet(
    String^ sqlString
)
abstract GetDataSet :
        sqlString : string -> DataSet

Parameters

sqlString
Type: SystemString
要执行的语句

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataSet(System.String)"]

See Also

Reference

IDbFactory Interface
GetDataSet Overload
Adf.Db Namespace


IDbFactory.GetDataSet Method (DbEntity)

IDbFactoryGetDataSet Method (DbEntity)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataSet GetDataSet(
    DbEntity entity
)
Function GetDataSet (
    entity As DbEntity
) As DataSet
DataSet^ GetDataSet(
    DbEntity^ entity
)
abstract GetDataSet :
        entity : DbEntity -> DataSet

Parameters

entity
Type: Adf.DbDbEntity
数据对象

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataSet(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetDataSet Overload
Adf.Db Namespace


IDbFactory.GetDataSet Method (DbEntity, String)

IDbFactoryGetDataSet Method (DbEntity, String)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataSet GetDataSet(
    DbEntity entity,
    string storedProcedure
)
Function GetDataSet (
    entity As DbEntity,
    storedProcedure As String
) As DataSet
DataSet^ GetDataSet(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetDataSet :
        entity : DbEntity *
        storedProcedure : string -> DataSet

Parameters

entity
Type: Adf.DbDbEntity
数据对象
storedProcedure
Type: SystemString
存储过程名

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataSet(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetDataSet Overload
Adf.Db Namespace


IDbFactory.GetDataSet Method (String, Boolean, IDbDataParameter[])

IDbFactoryGetDataSet Method (String, Boolean, IDbDataParameter)
返回一个数据集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataSet GetDataSet(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
Function GetDataSet (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As DataSet
DataSet^ GetDataSet(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetDataSet :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> DataSet

Parameters

sqlString
Type: SystemString
要执行的语句或过程
storedProcedure
Type: SystemBoolean
是否为存储过程
parameters
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: DataSet

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataSet(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
GetDataSet Overload
Adf.Db Namespace


IDbFactory.GetDataTable Method

IDbFactoryGetDataTable Method
Overload List
 | Name | Description
Public method | GetDataTable(String) | 返回一个数据表
Public method | GetDataTable(DbEntity) | 返回一个数据表
Public method | GetDataTable(DbEntity, String) | 返回一个数据表
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetDataTable Method (String)

IDbFactoryGetDataTable Method (String)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataTable GetDataTable(
    string sqlString
)
Function GetDataTable (
    sqlString As String
) As DataTable
DataTable^ GetDataTable(
    String^ sqlString
)
abstract GetDataTable :
        sqlString : string -> DataTable

Parameters

sqlString
Type: SystemString
要执行的语句

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataTable(System.String)"]

See Also

Reference

IDbFactory Interface
GetDataTable Overload
Adf.Db Namespace


IDbFactory.GetDataTable Method (DbEntity)

IDbFactoryGetDataTable Method (DbEntity)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataTable GetDataTable(
    DbEntity entity
)
Function GetDataTable (
    entity As DbEntity
) As DataTable
DataTable^ GetDataTable(
    DbEntity^ entity
)
abstract GetDataTable :
        entity : DbEntity -> DataTable

Parameters

entity
Type: Adf.DbDbEntity
数据对象

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataTable(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetDataTable Overload
Adf.Db Namespace


IDbFactory.GetDataTable Method (DbEntity, String)

IDbFactoryGetDataTable Method (DbEntity, String)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataTable GetDataTable(
    DbEntity entity,
    string storedProcedure
)
Function GetDataTable (
    entity As DbEntity,
    storedProcedure As String
) As DataTable
DataTable^ GetDataTable(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetDataTable :
        entity : DbEntity *
        storedProcedure : string -> DataTable

Parameters

entity
Type: Adf.DbDbEntity
数据对象
storedProcedure
Type: SystemString
存储过程名

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataTable(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetDataTable Overload
Adf.Db Namespace


IDbFactory.GetDataTable Method (String, Boolean, IDbDataParameter[])

IDbFactoryGetDataTable Method (String, Boolean, IDbDataParameter)
返回一个数据表

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DataTable GetDataTable(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
Function GetDataTable (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As DataTable
DataTable^ GetDataTable(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetDataTable :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> DataTable

Parameters

sqlString
Type: SystemString
要执行的语句或过程
storedProcedure
Type: SystemBoolean
是否为存储过程
parameters
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: DataTable

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetDataTable(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
GetDataTable Overload
Adf.Db Namespace


IDbFactory.GetIdentity Method

IDbFactoryGetIdentity Method
Overload List
 | Name | Description
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值
Public method | GetIdentity | 返回最后一次产生的键值
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetIdentity(T) Method

IDbFactoryGetIdentityT Method
获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetIdentity<T>()

Function GetIdentity(Of T) As T
generic<typename T>
T GetIdentity()
abstract GetIdentity : unit -> 'T

Type Parameters

T
返回的数据类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetIdentity``1"]

See Also

Reference

IDbFactory Interface
GetIdentity Overload
Adf.Db Namespace


IDbFactory.GetIdentity Method

IDbFactoryGetIdentity Method
返回最后一次产生的键值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Object GetIdentity()
Function GetIdentity As Object
Object^ GetIdentity()
abstract GetIdentity : unit -> Object

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetIdentity"]

See Also

Reference

IDbFactory Interface
GetIdentity Overload
Adf.Db Namespace


IDbFactory.GetList Method

IDbFactoryGetList Method
Overload List
 | Name | Description
Public method | GetListT(String) | 返回一个数据对象集
Public method | GetListT(DbEntity) | 返回一个数据对象集
Public method | GetListT(DbEntity, String) | 返回一个数据对象集
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetList(T) Method (String)

IDbFactoryGetListT Method (String)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T> GetList<T>(
    string sqlString
)
where T : IDbEntity

Function GetList(Of T As IDbEntity) (
    sqlString As String
) As List(Of T)
generic<typename T>
where T : IDbEntity
List<T>^ GetList(
    String^ sqlString
)
abstract GetList :
        sqlString : string -> List<'T>  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetList``1(System.String)"]

See Also

Reference

IDbFactory Interface
GetList Overload
Adf.Db Namespace


IDbFactory.GetList(T) Method (DbEntity)

IDbFactoryGetListT Method (DbEntity)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T> GetList<T>(
    DbEntity entity
)
where T : IDbEntity

Function GetList(Of T As IDbEntity) (
    entity As DbEntity
) As List(Of T)
generic<typename T>
where T : IDbEntity
List<T>^ GetList(
    DbEntity^ entity
)
abstract GetList :
        entity : DbEntity -> List<'T>  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetList``1(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetList Overload
Adf.Db Namespace


IDbFactory.GetList(T) Method (DbEntity, String)

IDbFactoryGetListT Method (DbEntity, String)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T> GetList<T>(
    DbEntity entity,
    string storedProcedure
)
where T : IDbEntity

Function GetList(Of T As IDbEntity) (
    entity As DbEntity,
    storedProcedure As String
) As List(Of T)
generic<typename T>
where T : IDbEntity
List<T>^ GetList(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetList :
        entity : DbEntity *
        storedProcedure : string -> List<'T>  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象
storedProcedure
Type: SystemString
存储过程名

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetList``1(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetList Overload
Adf.Db Namespace


IDbFactory.GetList(T) Method (String, Boolean, IDbDataParameter[])

IDbFactoryGetListT Method (String, Boolean, IDbDataParameter)
返回一个数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T> GetList<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
where T : IDbEntity

Function GetList(Of T As IDbEntity) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As List(Of T)
generic<typename T>
where T : IDbEntity
List<T>^ GetList(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetList :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> List<'T>  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parameters
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetList``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
GetList Overload
Adf.Db Namespace


IDbFactory.GetLists Method

IDbFactoryGetLists Method
Overload List
 | Name | Description
Public method | GetListsT(String) | 返回一个多数据对象集
Public method | GetListsT(DbEntity) | 返回一个多数据对象集
Public method | GetListsT(DbEntity, String) | 返回一个多数据对象集
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个多数据对象集
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetLists(T) Method (String)

IDbFactoryGetListsT Method (String)
返回一个多数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T>[] GetLists<T>(
    string sqlString
)
where T : IDbEntity

Function GetLists(Of T As IDbEntity) (
    sqlString As String
) As List(Of T)()
generic<typename T>
where T : IDbEntity
array<List<T>^>^ GetLists(
    String^ sqlString
)
abstract GetLists :
        sqlString : string -> List<'T>[]  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetLists``1(System.String)"]

See Also

Reference

IDbFactory Interface
GetLists Overload
Adf.Db Namespace


IDbFactory.GetLists(T) Method (DbEntity)

IDbFactoryGetListsT Method (DbEntity)
返回一个多数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T>[] GetLists<T>(
    DbEntity entity
)
where T : IDbEntity

Function GetLists(Of T As IDbEntity) (
    entity As DbEntity
) As List(Of T)()
generic<typename T>
where T : IDbEntity
array<List<T>^>^ GetLists(
    DbEntity^ entity
)
abstract GetLists :
        entity : DbEntity -> List<'T>[]  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetLists``1(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetLists Overload
Adf.Db Namespace


IDbFactory.GetLists(T) Method (DbEntity, String)

IDbFactoryGetListsT Method (DbEntity, String)
返回一个多数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T>[] GetLists<T>(
    DbEntity entity,
    string storedProcedure
)
where T : IDbEntity

Function GetLists(Of T As IDbEntity) (
    entity As DbEntity,
    storedProcedure As String
) As List(Of T)()
generic<typename T>
where T : IDbEntity
array<List<T>^>^ GetLists(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetLists :
        entity : DbEntity *
        storedProcedure : string -> List<'T>[]  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询条件对象
storedProcedure
Type: SystemString
存储过程名

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetLists``1(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetLists Overload
Adf.Db Namespace


IDbFactory.GetLists(T) Method (String, Boolean, IDbDataParameter[])

IDbFactoryGetListsT Method (String, Boolean, IDbDataParameter)
返回一个多数据对象集

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T>[] GetLists<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
where T : IDbEntity

Function GetLists(Of T As IDbEntity) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As List(Of T)()
generic<typename T>
where T : IDbEntity
array<List<T>^>^ GetLists(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetLists :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> List<'T>[]  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parameters
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
对象类型

Return Value

Type: List T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetLists``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
GetLists Overload
Adf.Db Namespace


IDbFactory.GetRow Method

IDbFactoryGetRow Method
Overload List
 | Name | Description
Public method | GetRowT(String) | 返回一个数据对象
Public method | GetRowT(DbEntity) | 返回一个数据对象
Public method | GetRowT(DbEntity, String) | 返回一个数据对象
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetRow(T) Method (String)

IDbFactoryGetRowT Method (String)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetRow<T>(
    string sqlString
)
where T : IDbEntity

Function GetRow(Of T As IDbEntity) (
    sqlString As String
) As T
generic<typename T>
where T : IDbEntity
T GetRow(
    String^ sqlString
)
abstract GetRow :
        sqlString : string -> 'T  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句

Type Parameters

T
数据对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetRow``1(System.String)"]

See Also

Reference

IDbFactory Interface
GetRow Overload
Adf.Db Namespace


IDbFactory.GetRow(T) Method (DbEntity)

IDbFactoryGetRowT Method (DbEntity)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetRow<T>(
    DbEntity entity
)
where T : IDbEntity

Function GetRow(Of T As IDbEntity) (
    entity As DbEntity
) As T
generic<typename T>
where T : IDbEntity
T GetRow(
    DbEntity^ entity
)
abstract GetRow :
        entity : DbEntity -> 'T  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询对象

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetRow``1(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetRow Overload
Adf.Db Namespace


IDbFactory.GetRow(T) Method (DbEntity, String)

IDbFactoryGetRowT Method (DbEntity, String)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetRow<T>(
    DbEntity entity,
    string storedProcedure
)
where T : IDbEntity

Function GetRow(Of T As IDbEntity) (
    entity As DbEntity,
    storedProcedure As String
) As T
generic<typename T>
where T : IDbEntity
T GetRow(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetRow :
        entity : DbEntity *
        storedProcedure : string -> 'T  when 'T : IDbEntity

Parameters

entity
Type: Adf.DbDbEntity
查询对象
storedProcedure
Type: SystemString
存储过程名

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetRow``1(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetRow Overload
Adf.Db Namespace


IDbFactory.GetRow(T) Method (String, Boolean, IDbDataParameter[])

IDbFactoryGetRowT Method (String, Boolean, IDbDataParameter)
返回一个数据对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetRow<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
where T : IDbEntity

Function GetRow(Of T As IDbEntity) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As T
generic<typename T>
where T : IDbEntity
T GetRow(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetRow :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> 'T  when 'T : IDbEntity

Parameters

sqlString
Type: SystemString
查询语句或过程
storedProcedure
Type: SystemBoolean
是否以存储过程执行
parameters
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
数据对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetRow``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
GetRow Overload
Adf.Db Namespace


IDbFactory.GetScalar Method

IDbFactoryGetScalar Method
Overload List
 | Name | Description
Public method | GetScalar(String) | 获取第一行第一列的数据
Public method | GetScalarT(String) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity) | 获取第一行第一列的数据
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalarT(DbEntity, String) | 获取第一行第一列的数据
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Public method | GetScalarT(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.GetScalar Method (String)

IDbFactoryGetScalar Method (String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Object GetScalar(
    string sqlString
)
Function GetScalar (
    sqlString As String
) As Object
Object^ GetScalar(
    String^ sqlString
)
abstract GetScalar :
        sqlString : string -> Object

Parameters

sqlString
Type: SystemString
要执行的语句

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar(System.String)"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.GetScalar(T) Method (String)

IDbFactoryGetScalarT Method (String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetScalar<T>(
    string sqlString
)

Function GetScalar(Of T) (
    sqlString As String
) As T
generic<typename T>
T GetScalar(
    String^ sqlString
)
abstract GetScalar :
        sqlString : string -> 'T

Parameters

sqlString
Type: SystemString
要执行的语句

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar``1(System.String)"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.GetScalar Method (DbEntity)

IDbFactoryGetScalar Method (DbEntity)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Object GetScalar(
    DbEntity Object
)
Function GetScalar (
    Object As DbEntity
) As Object
Object^ GetScalar(
    DbEntity^ Object
)
abstract GetScalar :
        Object : DbEntity -> Object

Parameters

Object
Type: Adf.DbDbEntity
对象

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.GetScalar(T) Method (DbEntity)

IDbFactoryGetScalarT Method (DbEntity)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetScalar<T>(
    DbEntity entity
)

Function GetScalar(Of T) (
    entity As DbEntity
) As T
generic<typename T>
T GetScalar(
    DbEntity^ entity
)
abstract GetScalar :
        entity : DbEntity -> 'T

Parameters

entity
Type: Adf.DbDbEntity
对象

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar``1(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.GetScalar Method (DbEntity, String)

IDbFactoryGetScalar Method (DbEntity, String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Object GetScalar(
    DbEntity Object,
    string storedProcedure
)
Function GetScalar (
    Object As DbEntity,
    storedProcedure As String
) As Object
Object^ GetScalar(
    DbEntity^ Object,
    String^ storedProcedure
)
abstract GetScalar :
        Object : DbEntity *
        storedProcedure : string -> Object

Parameters

Object
Type: Adf.DbDbEntity
对象
storedProcedure
Type: SystemString
存储过程名

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.GetScalar(T) Method (DbEntity, String)

IDbFactoryGetScalarT Method (DbEntity, String)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetScalar<T>(
    DbEntity entity,
    string storedProcedure
)

Function GetScalar(Of T) (
    entity As DbEntity,
    storedProcedure As String
) As T
generic<typename T>
T GetScalar(
    DbEntity^ entity,
    String^ storedProcedure
)
abstract GetScalar :
        entity : DbEntity *
        storedProcedure : string -> 'T

Parameters

entity
Type: Adf.DbDbEntity
对象
storedProcedure
Type: SystemString
存储过程名

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar``1(Adf.Db.DbEntity,System.String)"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.GetScalar Method (String, Boolean, IDbDataParameter[])

IDbFactoryGetScalar Method (String, Boolean, IDbDataParameter)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Object GetScalar(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)
Function GetScalar (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As Object
Object^ GetScalar(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetScalar :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> Object

Parameters

sqlString
Type: SystemString
要执行的语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parameters
Type: System.DataIDbDataParameter
参数列表

Return Value

Type: Object

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.GetScalar(T) Method (String, Boolean, IDbDataParameter[])

IDbFactoryGetScalarT Method (String, Boolean, IDbDataParameter)
获取第一行第一列的数据

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T GetScalar<T>(
    string sqlString,
    bool storedProcedure,
    params IDbDataParameter[] parameters
)

Function GetScalar(Of T) (
    sqlString As String,
    storedProcedure As Boolean,
    ParamArray parameters As IDbDataParameter()
) As T
generic<typename T>
T GetScalar(
    String^ sqlString,
    bool storedProcedure,
    ... array<IDbDataParameter^>^ parameters
)
abstract GetScalar :
        sqlString : string *
        storedProcedure : bool *
        parameters : IDbDataParameter[] -> 'T

Parameters

sqlString
Type: SystemString
要执行的语句
storedProcedure
Type: SystemBoolean
是否为存储过程
parameters
Type: System.DataIDbDataParameter
参数列表

Type Parameters

T
对象类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.GetScalar``1(System.String,System.Boolean,System.Data.IDbDataParameter[])"]

See Also

Reference

IDbFactory Interface
GetScalar Overload
Adf.Db Namespace


IDbFactory.InjectReplace Method

IDbFactoryInjectReplace Method
SQL注入过滤

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string InjectReplace(
    string input
)
Function InjectReplace (
    input As String
) As String
String^ InjectReplace(
    String^ input
)
abstract InjectReplace :
        input : string -> string

Parameters

input
Type: SystemString
要过滤的数据

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.InjectReplace(System.String)"]

See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Insert Method

IDbFactoryInsert Method
执行数据对象插入请求

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Insert(
    DbEntity entity
)
Function Insert (
    entity As DbEntity
) As Integer
int Insert(
    DbEntity^ entity
)
abstract Insert :
        entity : DbEntity -> int

Parameters

entity
Type: Adf.DbDbEntity
数据对象

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.Insert(Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.PageSql(T) Method

IDbFactoryPageSqlT Method
返回一个分页列表对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
List<T> PageSql<T>(
    int pageindex,
    int pagesize,
    string fields,
    string tablename,
    string condition,
    string orderby,
    string key = "",
    string groupby = "",
    bool distinct = false
)
where T : IDbEntity

Function PageSql(Of T As IDbEntity) (
    pageindex As Integer,
    pagesize As Integer,
    fields As String,
    tablename As String,
    condition As String,
    orderby As String,
    Optional key As String = "",
    Optional groupby As String = "",
    Optional distinct As Boolean = false
) As List(Of T)
generic<typename T>
where T : IDbEntity
List<T>^ PageSql(
    int pageindex,
    int pagesize,
    String^ fields,
    String^ tablename,
    String^ condition,
    String^ orderby,
    String^ key = L"",
    String^ groupby = L"",
    bool distinct = false
)
abstract PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> List<'T>  when 'T : IDbEntity

Parameters

pageindex
Type: SystemInt32
页序
pagesize
Type: SystemInt32
页大小
fields
Type: SystemString
字段值,前后不带空格,位于 Select 与 From 之间的字段部表示
tablename
Type: SystemString
要进行查询的数据表,可为多个
condition
Type: SystemString
要进行查询的查询串,Where的后缀,如果未有,请设置为 null
orderby
Type: SystemString
排序方法,如果未有排序则为null
key (Optional)
Type: SystemString
键
groupby (Optional)
Type: SystemString
分组,分组请设置为null
distinct (Optional)
Type: SystemBoolean

[Missing <param name="distinct"/> documentation for "M:Adf.Db.IDbFactory.PageSql``1(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Db.IDbFactory.PageSql``1(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Type: List T
返回生成后的Sql语句
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Rollback Method

IDbFactoryRollback Method
回滚事务,当并行事务已回滚时则跳过

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
void Rollback()
Sub Rollback
void Rollback()
abstract Rollback : unit -> unit

Return Value

Type:
当并行事务时反回是否执行了回滚操作，非并行事务返回固定Boolean
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.ToSafeString Method

IDbFactoryToSafeString Method
Overload List
 | Name | Description
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.ToSafeString Method (Object)

IDbFactoryToSafeString Method (Object)
根据数据类型返回一个可以直接应用于SQL语句的安全字符串

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string ToSafeString(
    Object value
)
Function ToSafeString (
    value As Object
) As String
String^ ToSafeString(
    Object^ value
)
abstract ToSafeString :
        value : Object -> string

Parameters

value
Type: SystemObject
要添加的值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.ToSafeString(System.Object)"]

See Also

Reference

IDbFactory Interface
ToSafeString Overload
Adf.Db Namespace


IDbFactory.ToSafeString Method (Object, Type)

IDbFactoryToSafeString Method (Object, Type)
根据数据类型返回一个可以直接应用于SQL语句的安全字符串

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string ToSafeString(
    Object value,
    Type type
)
Function ToSafeString (
    value As Object,
    type As Type
) As String
String^ ToSafeString(
    Object^ value,
    Type^ type
)
abstract ToSafeString :
        value : Object *
        type : Type -> string

Parameters

value
Type: SystemObject
要添加的值
type
Type: SystemType
类型

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.ToSafeString(System.Object,System.Type)"]

See Also

Reference

IDbFactory Interface
ToSafeString Overload
Adf.Db Namespace


IDbFactory.Update Method

IDbFactoryUpdate Method
执行数据对象修改

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int Update(
    DbEntity update,
    DbEntity where
)
Function Update (
    update As DbEntity,
    where As DbEntity
) As Integer
int Update(
    DbEntity^ update,
    DbEntity^ where
)
abstract Update :
        update : DbEntity *
        where : DbEntity -> int

Parameters

update
Type: Adf.DbDbEntity
数据对象
where
Type: Adf.DbDbEntity
更新条件

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbFactory.Update(Adf.Db.DbEntity,Adf.Db.DbEntity)"]

See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory Properties

IDbFactory Properties

The IDbFactory type exposes the following members.

Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作
Public property | Connection | 获取当前数据库连接串
Public property | LastSql | 最后一个Command SQL
Public property | Name | 获取当前工厂名称描述
Public property | NestedTransaction | 获取是否为并行（嵌套）事务
Public property | SqlBuilder | 返回可用的SqlBuilder对象
Public property | Transaction | 获取当前正在执行的事务
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级
Top
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.CommandCount Property

IDbFactoryCommandCount Property
获取Command数，间接反应了执行了多少次数据操作

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int CommandCount { get; }
ReadOnly Property CommandCount As Integer
    Get
property int CommandCount {
    int get ();
}
abstract CommandCount : int with get

Property Value

Type: Int32
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Connection Property

IDbFactoryConnection Property
获取当前数据库连接串

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
IDbConnection Connection { get; }
ReadOnly Property Connection As IDbConnection
    Get
property IDbConnection^ Connection {
    IDbConnection^ get ();
}
abstract Connection : IDbConnection with get

Property Value

Type: IDbConnection
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.LastSql Property

IDbFactoryLastSql Property
最后一个Command SQL

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string LastSql { get; }
ReadOnly Property LastSql As String
    Get
property String^ LastSql {
    String^ get ();
}
abstract LastSql : string with get

Property Value

Type: String
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Name Property

IDbFactoryName Property
获取当前工厂名称描述

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
property String^ Name {
    String^ get ();
}
abstract Name : string with get

Property Value

Type: String
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.NestedTransaction Property

IDbFactoryNestedTransaction Property
获取是否为并行（嵌套）事务

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
bool NestedTransaction { get; }
ReadOnly Property NestedTransaction As Boolean
    Get
property bool NestedTransaction {
    bool get ();
}
abstract NestedTransaction : bool with get

Property Value

Type: Boolean
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.SqlBuilder Property

IDbFactorySqlBuilder Property
返回可用的SqlBuilder对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
SqlBuilder SqlBuilder { get; }
ReadOnly Property SqlBuilder As SqlBuilder
    Get
property SqlBuilder^ SqlBuilder {
    SqlBuilder^ get ();
}
abstract SqlBuilder : SqlBuilder with get

Property Value

Type: SqlBuilder
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.Transaction Property

IDbFactoryTransaction Property
获取当前正在执行的事务

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
IDbTransaction Transaction { get; }
ReadOnly Property Transaction As IDbTransaction
    Get
property IDbTransaction^ Transaction {
    IDbTransaction^ get ();
}
abstract Transaction : IDbTransaction with get

Property Value

Type: IDbTransaction
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbFactory.TransactionLayer Property

IDbFactoryTransactionLayer Property
获取为并行(嵌套)事务时的当前事务层级

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int TransactionLayer { get; }
ReadOnly Property TransactionLayer As Integer
    Get
property int TransactionLayer {
    int get ();
}
abstract TransactionLayer : int with get

Property Value

Type: Int32
See Also

Reference

IDbFactory Interface
Adf.Db Namespace


IDbReader Interface

IDbReader Interface
Data Object Reader Interface

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public interface IDbReader
Public Interface IDbReader
public interface class IDbReader
type IDbReader =  interface end

The IDbReader type exposes the following members.

Methods
 | Name | Description
Public method | Get(String) | get value
Public method | GetT(String) | get value
Public method | GetAsBoolean | Get To Boolean
Public method | GetAsByte | Get To Byte
Public method | GetAsDateTime | Get To DateTime
Public method | GetAsDecimail | Get To Decimal
Public method | GetAsDouble | Get To Double
Public method | GetAsInt16 | Get To Int16
Public method | GetAsInt32 | Get To Int32
Public method | GetAsInt64 | Get To Int64
Public method | GetAsSByte | Get To SByte
Public method | GetAsString | Get To String
Public method | GetAsUInt16 | Get To Uint16
Public method | GetAsUInt32 | Get To Uint32
Public method | GetAsUInt64 | Get To Uint64
Top
Properties
 | Name | Description
Public property | NameIndex | name index
Public property | Reader | get reader object
Top
See Also

Reference

Adf.Db Namespace


IDbReader Methods

IDbReader Methods

The IDbReader type exposes the following members.

Methods
 | Name | Description
Public method | Get(String) | get value
Public method | GetT(String) | get value
Public method | GetAsBoolean | Get To Boolean
Public method | GetAsByte | Get To Byte
Public method | GetAsDateTime | Get To DateTime
Public method | GetAsDecimail | Get To Decimal
Public method | GetAsDouble | Get To Double
Public method | GetAsInt16 | Get To Int16
Public method | GetAsInt32 | Get To Int32
Public method | GetAsInt64 | Get To Int64
Public method | GetAsSByte | Get To SByte
Public method | GetAsString | Get To String
Public method | GetAsUInt16 | Get To Uint16
Public method | GetAsUInt32 | Get To Uint32
Public method | GetAsUInt64 | Get To Uint64
Top
See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.Get Method

IDbReaderGet Method
Overload List
 | Name | Description
Public method | GetT(String) | get value
Public method | Get(String) | get value
Top
See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.Get(T) Method (String)

IDbReaderGetT Method (String)
get value

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
T Get<T>(
    string name
)

Function Get(Of T) (
    name As String
) As T
generic<typename T>
T Get(
    String^ name
)
abstract Get :
        name : string -> 'T

Parameters

name
Type: SystemString
field name

Type Parameters

T
value type

Return Value

Type: T
is T type value
See Also

Reference

IDbReader Interface
Get Overload
Adf.Db Namespace


IDbReader.Get Method (String)

IDbReaderGet Method (String)
get value

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Object Get(
    string name
)
Function Get (
    name As String
) As Object
Object^ Get(
    String^ name
)
abstract Get :
        name : string -> Object

Parameters

name
Type: SystemString
field name

Return Value

Type: Object
is T type value
See Also

Reference

IDbReader Interface
Get Overload
Adf.Db Namespace


IDbReader.GetAsBoolean Method

IDbReaderGetAsBoolean Method
Get To Boolean

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
bool GetAsBoolean(
    string name
)
Function GetAsBoolean (
    name As String
) As Boolean
bool GetAsBoolean(
    String^ name
)
abstract GetAsBoolean :
        name : string -> bool

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsBoolean(System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsBoolean(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsByte Method

IDbReaderGetAsByte Method
Get To Byte

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
byte GetAsByte(
    string name
)
Function GetAsByte (
    name As String
) As Byte
unsigned char GetAsByte(
    String^ name
)
abstract GetAsByte :
        name : string -> byte

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsByte(System.String)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsByte(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsDateTime Method

IDbReaderGetAsDateTime Method
Get To DateTime

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
DateTime GetAsDateTime(
    string name
)
Function GetAsDateTime (
    name As String
) As DateTime
DateTime GetAsDateTime(
    String^ name
)
abstract GetAsDateTime :
        name : string -> DateTime

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsDateTime(System.String)"]

Return Value

Type: DateTime

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsDateTime(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsDecimail Method

IDbReaderGetAsDecimail Method
Get To Decimal

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
decimal GetAsDecimail(
    string name
)
Function GetAsDecimail (
    name As String
) As Decimal
Decimal GetAsDecimail(
    String^ name
)
abstract GetAsDecimail :
        name : string -> decimal

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsDecimail(System.String)"]

Return Value

Type: Decimal

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsDecimail(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsDouble Method

IDbReaderGetAsDouble Method
Get To Double

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
double GetAsDouble(
    string name
)
Function GetAsDouble (
    name As String
) As Double
double GetAsDouble(
    String^ name
)
abstract GetAsDouble :
        name : string -> float

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsDouble(System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsDouble(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsInt16 Method

IDbReaderGetAsInt16 Method
Get To Int16

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
short GetAsInt16(
    string name
)
Function GetAsInt16 (
    name As String
) As Short
short GetAsInt16(
    String^ name
)
abstract GetAsInt16 :
        name : string -> int16

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsInt16(System.String)"]

Return Value

Type: Int16

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsInt16(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsInt32 Method

IDbReaderGetAsInt32 Method
Get To Int32

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
int GetAsInt32(
    string name
)
Function GetAsInt32 (
    name As String
) As Integer
int GetAsInt32(
    String^ name
)
abstract GetAsInt32 :
        name : string -> int

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsInt32(System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsInt32(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsInt64 Method

IDbReaderGetAsInt64 Method
Get To Int64

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
long GetAsInt64(
    string name
)
Function GetAsInt64 (
    name As String
) As Long
long long GetAsInt64(
    String^ name
)
abstract GetAsInt64 :
        name : string -> int64

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsInt64(System.String)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsInt64(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsSByte Method

IDbReaderGetAsSByte Method
Get To SByte

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
sbyte GetAsSByte(
    string name
)
Function GetAsSByte (
    name As String
) As SByte
signed char GetAsSByte(
    String^ name
)
abstract GetAsSByte :
        name : string -> sbyte

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsSByte(System.String)"]

Return Value

Type: SByte

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsSByte(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsString Method

IDbReaderGetAsString Method
Get To String

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
string GetAsString(
    string name
)
Function GetAsString (
    name As String
) As String
String^ GetAsString(
    String^ name
)
abstract GetAsString :
        name : string -> string

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsString(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsString(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsUInt16 Method

IDbReaderGetAsUInt16 Method
Get To Uint16

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
ushort GetAsUInt16(
    string name
)
Function GetAsUInt16 (
    name As String
) As UShort
unsigned short GetAsUInt16(
    String^ name
)
abstract GetAsUInt16 :
        name : string -> uint16

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsUInt16(System.String)"]

Return Value

Type: UInt16

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsUInt16(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsUInt32 Method

IDbReaderGetAsUInt32 Method
Get To Uint32

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
uint GetAsUInt32(
    string name
)
Function GetAsUInt32 (
    name As String
) As UInteger
unsigned int GetAsUInt32(
    String^ name
)
abstract GetAsUInt32 :
        name : string -> uint32

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsUInt32(System.String)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsUInt32(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.GetAsUInt64 Method

IDbReaderGetAsUInt64 Method
Get To Uint64

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
ulong GetAsUInt64(
    string name
)
Function GetAsUInt64 (
    name As String
) As ULong
unsigned long long GetAsUInt64(
    String^ name
)
abstract GetAsUInt64 :
        name : string -> uint64

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:Adf.Db.IDbReader.GetAsUInt64(System.String)"]

Return Value

Type: UInt64

[Missing <returns> documentation for "M:Adf.Db.IDbReader.GetAsUInt64(System.String)"]

See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader Properties

IDbReader Properties

The IDbReader type exposes the following members.

Properties
 | Name | Description
Public property | NameIndex | name index
Public property | Reader | get reader object
Top
See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.NameIndex Property

IDbReaderNameIndex Property
name index

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
Dictionary<string, int> NameIndex { get; }
ReadOnly Property NameIndex As Dictionary(Of String, Integer)
    Get
property Dictionary<String^, int>^ NameIndex {
    Dictionary<String^, int>^ get ();
}
abstract NameIndex : Dictionary<string, int> with get

Property Value

Type: Dictionary String, Int32
See Also

Reference

IDbReader Interface
Adf.Db Namespace


IDbReader.Reader Property

IDbReaderReader Property
get reader object

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
IDataReader Reader { get; }
ReadOnly Property Reader As IDataReader
    Get
property IDataReader^ Reader {
    IDataReader^ get ();
}
abstract Reader : IDataReader with get

Property Value

Type: IDataReader
See Also

Reference

IDbReader Interface
Adf.Db Namespace


MySql Class

MySql Class
MySql 数据操作类
Inheritance Hierarchy
SystemObject
Adf.DbDbFactory
Adf.DbMySql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class MySql : DbFactory
Public Class MySql
    Inherits DbFactory
public ref class MySql : public DbFactory
type MySql =
    class
        inherit DbFactory
    end

The MySql type exposes the following members.

Constructors
 | Name | Description
Public method | MySql | 初始化操作类型
Top
Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Overrides DbFactoryGetIdentityT.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取当前数据库连接串 (Inherited from DbFactory.)
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Overrides DbFactoryParameterChar.)
Public property | SqlBuilder | 已重载,语句创建 (Overrides DbFactorySqlBuilder.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

Adf.Db Namespace


MySql Constructor

MySql Constructor
初始化操作类型

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public MySql(
    DbProviderFactory factory,
    IDbConnection connection
)
Public Sub New (
    factory As DbProviderFactory,
    connection As IDbConnection
)
public:
MySql(
    DbProviderFactory^ factory,
    IDbConnection^ connection
)
new :
        factory : DbProviderFactory *
        connection : IDbConnection -> MySql

Parameters

factory
Type: System.Data.CommonDbProviderFactory
工厂
connection
Type: System.DataIDbConnection
对象连接
See Also

Reference

MySql Class
Adf.Db Namespace


MySql Methods

MySql Methods

The MySql type exposes the following members.

Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Overrides DbFactoryGetIdentityT.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
See Also

Reference

MySql Class
Adf.Db Namespace


MySql.GetIdentity(T) Method

MySqlGetIdentityT Method
获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override T GetIdentity<T>()

Public Overrides Function GetIdentity(Of T) As T
public:
generic<typename T>
virtual T GetIdentity() override
abstract GetIdentity : unit -> 'T
override GetIdentity : unit -> 'T

Type Parameters

T
返回的数据类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.MySql.GetIdentity``1"]

Implements

IDbFactoryGetIdentityT
See Also

Reference

MySql Class
Adf.Db Namespace


MySql Properties

MySql Properties

The MySql type exposes the following members.

Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取当前数据库连接串 (Inherited from DbFactory.)
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Overrides DbFactoryParameterChar.)
Public property | SqlBuilder | 已重载,语句创建 (Overrides DbFactorySqlBuilder.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

MySql Class
Adf.Db Namespace


MySql.Name Property

MySqlName Property
获取当前操作对象的名称描述

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDbFactoryName
See Also

Reference

MySql Class
Adf.Db Namespace


MySql.ParameterChar Property

MySqlParameterChar Property
获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected override string ParameterChar { get; }
Protected Overrides ReadOnly Property ParameterChar As String
    Get
protected:
virtual property String^ ParameterChar {
    String^ get () override;
}
abstract ParameterChar : string with get
override ParameterChar : string with get

Property Value

Type: String
See Also

Reference

MySql Class
Adf.Db Namespace


MySql.SqlBuilder Property

MySqlSqlBuilder Property
已重载,语句创建

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override SqlBuilder SqlBuilder { get; }
Public Overrides ReadOnly Property SqlBuilder As SqlBuilder
    Get
public:
virtual property SqlBuilder^ SqlBuilder {
    SqlBuilder^ get () override;
}
abstract SqlBuilder : SqlBuilder with get
override SqlBuilder : SqlBuilder with get

Property Value

Type: SqlBuilder

Implements

IDbFactorySqlBuilder
See Also

Reference

MySql Class
Adf.Db Namespace


MySqlBuilder Class

MySqlBuilder Class
MySql专用语句生成
Inheritance Hierarchy
SystemObject
Adf.DbSqlBuilder
Adf.DbMySqlBuilder

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class MySqlBuilder : SqlBuilder
Public Class MySqlBuilder
    Inherits SqlBuilder
public ref class MySqlBuilder : public SqlBuilder
type MySqlBuilder =
    class
        inherit SqlBuilder
    end

The MySqlBuilder type exposes the following members.

Constructors
 | Name | Description
Protected method | MySqlBuilder | 初始化新对象
Top
Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句 (Inherited from SqlBuilder.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql (Inherited from SqlBuilder.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql (Inherited from SqlBuilder.)
Public method | GetSelect | get select sql (Overrides SqlBuilderGetSelect(DbEntity, IDbDataParameter).)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql (Inherited from SqlBuilder.)
Public method | GetWhere | get object where (Inherited from SqlBuilder.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句 (Overrides SqlBuilderPageSql(Int32, Int32, String, String, String, String, String, String, Boolean).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | Factory | 工厂对象 (Inherited from SqlBuilder.)
Top
See Also

Reference

Adf.Db Namespace


MySqlBuilder Constructor

MySqlBuilder Constructor
初始化新对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected MySqlBuilder(
    DbFactory factory
)
Protected Sub New (
    factory As DbFactory
)
protected:
MySqlBuilder(
    DbFactory^ factory
)
new :
        factory : DbFactory -> MySqlBuilder

Parameters

factory
Type: Adf.DbDbFactory
当前操作对象
See Also

Reference

MySqlBuilder Class
Adf.Db Namespace


MySqlBuilder Methods

MySqlBuilder Methods

The MySqlBuilder type exposes the following members.

Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句 (Inherited from SqlBuilder.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql (Inherited from SqlBuilder.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql (Inherited from SqlBuilder.)
Public method | GetSelect | get select sql (Overrides SqlBuilderGetSelect(DbEntity, IDbDataParameter).)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql (Inherited from SqlBuilder.)
Public method | GetWhere | get object where (Inherited from SqlBuilder.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句 (Overrides SqlBuilderPageSql(Int32, Int32, String, String, String, String, String, String, Boolean).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

MySqlBuilder Class
Adf.Db Namespace


MySqlBuilder.GetSelect Method

MySqlBuilderGetSelect Method
get select sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string GetSelect(
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overrides Function GetSelect (
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetSelect(
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
) override
abstract GetSelect :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetSelect :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

where
Type: Adf.DbDbEntity

[Missing <param name="where"/> documentation for "M:Adf.Db.MySqlBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.MySqlBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.MySqlBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

MySqlBuilder Class
Adf.Db Namespace


MySqlBuilder.PageSql Method

MySqlBuilderPageSql Method
生成分页用Sql语句

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string PageSql(
    int pageindex,
    int pagesize,
    string fields,
    string tablename,
    string condition,
    string orderby,
    string key = "",
    string groupby = "",
    bool distinct = false
)
Public Overrides Function PageSql (
    pageindex As Integer,
    pagesize As Integer,
    fields As String,
    tablename As String,
    condition As String,
    orderby As String,
    Optional key As String = "",
    Optional groupby As String = "",
    Optional distinct As Boolean = false
) As String
public:
virtual String^ PageSql(
    int pageindex,
    int pagesize,
    String^ fields,
    String^ tablename,
    String^ condition,
    String^ orderby,
    String^ key = L"",
    String^ groupby = L"",
    bool distinct = false
) override
abstract PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string
override PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string

Parameters

pageindex
Type: SystemInt32
页序
pagesize
Type: SystemInt32
页大小
fields
Type: SystemString
字段值,前后不带空格,位于 Select 与 From 之间的字段部表示
tablename
Type: SystemString
要进行查询的数据表,可为多个
condition
Type: SystemString
要进行查询的查询串,Where的后缀,如果未有,请设置为 null
orderby
Type: SystemString
排序方法,如果未有排序则为null
key (Optional)
Type: SystemString
键
groupby (Optional)
Type: SystemString
分组,分组请设置为null
distinct (Optional)
Type: SystemBoolean

[Missing <param name="distinct"/> documentation for "M:Adf.Db.MySqlBuilder.PageSql(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Type: String
返回生成后的Sql语句
See Also

Reference

MySqlBuilder Class
Adf.Db Namespace


MySqlBuilder Properties

MySqlBuilder Properties

The MySqlBuilder type exposes the following members.

Properties
 | Name | Description
Protected property | Factory | 工厂对象 (Inherited from SqlBuilder.)
Top
See Also

Reference

MySqlBuilder Class
Adf.Db Namespace


SqlBuilder Class

SqlBuilder Class
将指定的对象转换为SQL语句
Inheritance Hierarchy
SystemObject
Adf.DbSqlBuilder
Adf.DbAccessSqlBuilder
Adf.DbMySqlBuilder
Adf.DbSqliteBuilder

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class SqlBuilder
Public Class SqlBuilder
public ref class SqlBuilder
type SqlBuilder =  class end

The SqlBuilder type exposes the following members.

Constructors
 | Name | Description
Protected method | SqlBuilder | 初始化新对象
Top
Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql
Public method | GetSelect | get select sql
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql
Public method | GetWhere | get object where
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | Factory | 工厂对象
Top
See Also

Reference

Adf.Db Namespace


SqlBuilder Constructor

SqlBuilder Constructor
初始化新对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected SqlBuilder(
    DbFactory factory
)
Protected Sub New (
    factory As DbFactory
)
protected:
SqlBuilder(
    DbFactory^ factory
)
new :
        factory : DbFactory -> SqlBuilder

Parameters

factory
Type: Adf.DbDbFactory
当前操作对象
See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder Methods

SqlBuilder Methods

The SqlBuilder type exposes the following members.

Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql
Public method | GetSelect | get select sql
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql
Public method | GetWhere | get object where
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.CountSql Method

SqlBuilderCountSql Method
生成分页用计Count语句

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string CountSql(
    string tablename,
    string condition
)
Public Overridable Function CountSql (
    tablename As String,
    condition As String
) As String
public:
virtual String^ CountSql(
    String^ tablename,
    String^ condition
)
abstract CountSql :
        tablename : string *
        condition : string -> string
override CountSql :
        tablename : string *
        condition : string -> string

Parameters

tablename
Type: SystemString
要进行查询的数据表,可为多个
condition
Type: SystemString
要进行查询的查询串,Where的后缀,如果未有,请设置为Empty

Return Value

Type: String
返回生成后的Sql语句
See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.GetDelete Method

SqlBuilderGetDelete Method
get delete sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string GetDelete(
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overridable Function GetDelete (
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetDelete(
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
)
abstract GetDelete :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetDelete :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

where
Type: Adf.DbDbEntity
实体
parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.SqlBuilder.GetDelete(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.SqlBuilder.GetDelete(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.GetInsert Method

SqlBuilderGetInsert Method
get insert sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string GetInsert(
    DbEntity entity,
    out IDbDataParameter[] parameters
)
Public Overridable Function GetInsert (
    entity As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetInsert(
    DbEntity^ entity,
    [OutAttribute] array<IDbDataParameter^>^% parameters
)
abstract GetInsert :
        entity : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetInsert :
        entity : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

entity
Type: Adf.DbDbEntity

[Missing <param name="entity"/> documentation for "M:Adf.Db.SqlBuilder.GetInsert(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.SqlBuilder.GetInsert(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.SqlBuilder.GetInsert(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.GetSelect Method

SqlBuilderGetSelect Method
get select sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string GetSelect(
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overridable Function GetSelect (
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetSelect(
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
)
abstract GetSelect :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetSelect :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

where
Type: Adf.DbDbEntity

[Missing <param name="where"/> documentation for "M:Adf.Db.SqlBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.SqlBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.SqlBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.GetUpdate Method

SqlBuilderGetUpdate Method
get update sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string GetUpdate(
    DbEntity update,
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overridable Function GetUpdate (
    update As DbEntity,
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetUpdate(
    DbEntity^ update,
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
)
abstract GetUpdate :
        update : DbEntity *
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetUpdate :
        update : DbEntity *
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

update
Type: Adf.DbDbEntity

[Missing <param name="update"/> documentation for "M:Adf.Db.SqlBuilder.GetUpdate(Adf.Db.DbEntity,Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

where
Type: Adf.DbDbEntity
更新条件
parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.SqlBuilder.GetUpdate(Adf.Db.DbEntity,Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.SqlBuilder.GetUpdate(Adf.Db.DbEntity,Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.GetWhere Method

SqlBuilderGetWhere Method
get object where

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string GetWhere(
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overridable Function GetWhere (
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetWhere(
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
)
abstract GetWhere :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetWhere :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

where
Type: Adf.DbDbEntity
指定的条件生成对象
parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.SqlBuilder.GetWhere(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.SqlBuilder.GetWhere(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.PageSql Method

SqlBuilderPageSql Method
生成分页用Sql语句

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual string PageSql(
    int pageindex,
    int pagesize,
    string fields,
    string tablename,
    string condition,
    string orderby,
    string key = "",
    string groupby = "",
    bool distinct = false
)
Public Overridable Function PageSql (
    pageindex As Integer,
    pagesize As Integer,
    fields As String,
    tablename As String,
    condition As String,
    orderby As String,
    Optional key As String = "",
    Optional groupby As String = "",
    Optional distinct As Boolean = false
) As String
public:
virtual String^ PageSql(
    int pageindex,
    int pagesize,
    String^ fields,
    String^ tablename,
    String^ condition,
    String^ orderby,
    String^ key = L"",
    String^ groupby = L"",
    bool distinct = false
)
abstract PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string
override PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string

Parameters

pageindex
Type: SystemInt32
页序
pagesize
Type: SystemInt32
页大小
fields
Type: SystemString
字段值,前后不带空格,位于 Select 与 From 之间的字段部表示
tablename
Type: SystemString
要进行查询的数据表,可为多个
condition
Type: SystemString
要进行查询的查询串,Where的后缀,如果未有,请设置为 null
orderby
Type: SystemString
排序方法,如果未有排序则为null
key (Optional)
Type: SystemString
键
groupby (Optional)
Type: SystemString
分组,分组请设置为null
distinct (Optional)
Type: SystemBoolean

[Missing <param name="distinct"/> documentation for "M:Adf.Db.SqlBuilder.PageSql(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Type: String
返回生成后的Sql语句
See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder Properties

SqlBuilder Properties

The SqlBuilder type exposes the following members.

Properties
 | Name | Description
Protected property | Factory | 工厂对象
Top
See Also

Reference

SqlBuilder Class
Adf.Db Namespace


SqlBuilder.Factory Property

SqlBuilderFactory Property
工厂对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected DbFactory Factory { get; }
Protected ReadOnly Property Factory As DbFactory
    Get
protected:
property DbFactory^ Factory {
    DbFactory^ get ();
}
member Factory : DbFactory with get

Property Value

Type: DbFactory
See Also

Reference

SqlBuilder Class
Adf.Db Namespace


Sqlite Class

Sqlite Class
Sqlite 数据操作类
Inheritance Hierarchy
SystemObject
Adf.DbDbFactory
Adf.DbSqlite

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class Sqlite : DbFactory
Public Class Sqlite
    Inherits DbFactory
public ref class Sqlite : public DbFactory
type Sqlite =
    class
        inherit DbFactory
    end

The Sqlite type exposes the following members.

Constructors
 | Name | Description
Public method | Sqlite | 初始化操作类型
Top
Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Overrides DbFactoryGetIdentityT.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取当前数据库连接串 (Inherited from DbFactory.)
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Inherited from DbFactory.)
Public property | SqlBuilder | 已重载,语句创建 (Overrides DbFactorySqlBuilder.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

Adf.Db Namespace


Sqlite Constructor

Sqlite Constructor
初始化操作类型

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Sqlite(
    DbProviderFactory factory,
    IDbConnection connection
)
Public Sub New (
    factory As DbProviderFactory,
    connection As IDbConnection
)
public:
Sqlite(
    DbProviderFactory^ factory,
    IDbConnection^ connection
)
new :
        factory : DbProviderFactory *
        connection : IDbConnection -> Sqlite

Parameters

factory
Type: System.Data.CommonDbProviderFactory
工厂
connection
Type: System.DataIDbConnection
对象连接
See Also

Reference

Sqlite Class
Adf.Db Namespace


Sqlite Methods

Sqlite Methods

The Sqlite type exposes the following members.

Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Overrides DbFactoryGetIdentityT.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
See Also

Reference

Sqlite Class
Adf.Db Namespace


Sqlite.GetIdentity(T) Method

SqliteGetIdentityT Method
获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override T GetIdentity<T>()

Public Overrides Function GetIdentity(Of T) As T
public:
generic<typename T>
virtual T GetIdentity() override
abstract GetIdentity : unit -> 'T
override GetIdentity : unit -> 'T

Type Parameters

T
返回的数据类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Db.Sqlite.GetIdentity``1"]

Implements

IDbFactoryGetIdentityT
See Also

Reference

Sqlite Class
Adf.Db Namespace


Sqlite Properties

Sqlite Properties

The Sqlite type exposes the following members.

Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取当前数据库连接串 (Inherited from DbFactory.)
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Inherited from DbFactory.)
Public property | SqlBuilder | 已重载,语句创建 (Overrides DbFactorySqlBuilder.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

Sqlite Class
Adf.Db Namespace


Sqlite.Name Property

SqliteName Property
获取当前操作对象的名称描述

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDbFactoryName
See Also

Reference

Sqlite Class
Adf.Db Namespace


Sqlite.SqlBuilder Property

SqliteSqlBuilder Property
已重载,语句创建

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override SqlBuilder SqlBuilder { get; }
Public Overrides ReadOnly Property SqlBuilder As SqlBuilder
    Get
public:
virtual property SqlBuilder^ SqlBuilder {
    SqlBuilder^ get () override;
}
abstract SqlBuilder : SqlBuilder with get
override SqlBuilder : SqlBuilder with get

Property Value

Type: SqlBuilder

Implements

IDbFactorySqlBuilder
See Also

Reference

Sqlite Class
Adf.Db Namespace


SqliteBuilder Class

SqliteBuilder Class
Sqlite专用语句生成
Inheritance Hierarchy
SystemObject
Adf.DbSqlBuilder
Adf.DbSqliteBuilder

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class SqliteBuilder : SqlBuilder
Public Class SqliteBuilder
    Inherits SqlBuilder
public ref class SqliteBuilder : public SqlBuilder
type SqliteBuilder =
    class
        inherit SqlBuilder
    end

The SqliteBuilder type exposes the following members.

Constructors
 | Name | Description
Protected method | SqliteBuilder | 初始化新对象
Top
Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句 (Inherited from SqlBuilder.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql (Inherited from SqlBuilder.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql (Inherited from SqlBuilder.)
Public method | GetSelect | get select sql (Overrides SqlBuilderGetSelect(DbEntity, IDbDataParameter).)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql (Inherited from SqlBuilder.)
Public method | GetWhere | get object where (Inherited from SqlBuilder.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句 (Overrides SqlBuilderPageSql(Int32, Int32, String, String, String, String, String, String, Boolean).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | Factory | 工厂对象 (Inherited from SqlBuilder.)
Top
See Also

Reference

Adf.Db Namespace


SqliteBuilder Constructor

SqliteBuilder Constructor
初始化新对象

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected SqliteBuilder(
    DbFactory factory
)
Protected Sub New (
    factory As DbFactory
)
protected:
SqliteBuilder(
    DbFactory^ factory
)
new :
        factory : DbFactory -> SqliteBuilder

Parameters

factory
Type: Adf.DbDbFactory
当前操作对象
See Also

Reference

SqliteBuilder Class
Adf.Db Namespace


SqliteBuilder Methods

SqliteBuilder Methods

The SqliteBuilder type exposes the following members.

Methods
 | Name | Description
Public method | CountSql | 生成分页用计Count语句 (Inherited from SqlBuilder.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetDelete | get delete sql (Inherited from SqlBuilder.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetInsert | get insert sql (Inherited from SqlBuilder.)
Public method | GetSelect | get select sql (Overrides SqlBuilderGetSelect(DbEntity, IDbDataParameter).)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetUpdate | get update sql (Inherited from SqlBuilder.)
Public method | GetWhere | get object where (Inherited from SqlBuilder.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSql | 生成分页用Sql语句 (Overrides SqlBuilderPageSql(Int32, Int32, String, String, String, String, String, String, Boolean).)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

SqliteBuilder Class
Adf.Db Namespace


SqliteBuilder.GetSelect Method

SqliteBuilderGetSelect Method
get select sql

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string GetSelect(
    DbEntity where,
    out IDbDataParameter[] parameters
)
Public Overrides Function GetSelect (
    where As DbEntity,
    <OutAttribute> ByRef parameters As IDbDataParameter()
) As String
public:
virtual String^ GetSelect(
    DbEntity^ where,
    [OutAttribute] array<IDbDataParameter^>^% parameters
) override
abstract GetSelect :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string
override GetSelect :
        where : DbEntity *
        parameters : IDbDataParameter[] byref -> string

Parameters

where
Type: Adf.DbDbEntity

[Missing <param name="where"/> documentation for "M:Adf.Db.SqliteBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

parameters
Type: System.DataIDbDataParameter

[Missing <param name="parameters"/> documentation for "M:Adf.Db.SqliteBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Db.SqliteBuilder.GetSelect(Adf.Db.DbEntity,System.Data.IDbDataParameter[]@)"]

See Also

Reference

SqliteBuilder Class
Adf.Db Namespace


SqliteBuilder.PageSql Method

SqliteBuilderPageSql Method
生成分页用Sql语句

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string PageSql(
    int pageindex,
    int pagesize,
    string fields,
    string tablename,
    string condition,
    string orderby,
    string key = "",
    string groupby = "",
    bool distinct = false
)
Public Overrides Function PageSql (
    pageindex As Integer,
    pagesize As Integer,
    fields As String,
    tablename As String,
    condition As String,
    orderby As String,
    Optional key As String = "",
    Optional groupby As String = "",
    Optional distinct As Boolean = false
) As String
public:
virtual String^ PageSql(
    int pageindex,
    int pagesize,
    String^ fields,
    String^ tablename,
    String^ condition,
    String^ orderby,
    String^ key = L"",
    String^ groupby = L"",
    bool distinct = false
) override
abstract PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string
override PageSql :
        pageindex : int *
        pagesize : int *
        fields : string *
        tablename : string *
        condition : string *
        orderby : string *
        ?key : string *
        ?groupby : string *
        ?distinct : bool
(* Defaults:
        let _key = defaultArg key ""
        let _groupby = defaultArg groupby ""
        let _distinct = defaultArg distinct false
*)
-> string

Parameters

pageindex
Type: SystemInt32
页序
pagesize
Type: SystemInt32
页大小
fields
Type: SystemString
字段值,前后不带空格,位于 Select 与 From 之间的字段部表示
tablename
Type: SystemString
要进行查询的数据表,可为多个
condition
Type: SystemString
要进行查询的查询串,Where的后缀,如果未有,请设置为 null
orderby
Type: SystemString
排序方法,如果未有排序则为null
key (Optional)
Type: SystemString
键
groupby (Optional)
Type: SystemString
分组,分组请设置为null
distinct (Optional)
Type: SystemBoolean

[Missing <param name="distinct"/> documentation for "M:Adf.Db.SqliteBuilder.PageSql(System.Int32,System.Int32,System.String,System.String,System.String,System.String,System.String,System.String,System.Boolean)"]

Return Value

Type: String
返回生成后的Sql语句
See Also

Reference

SqliteBuilder Class
Adf.Db Namespace


SqliteBuilder Properties

SqliteBuilder Properties

The SqliteBuilder type exposes the following members.

Properties
 | Name | Description
Protected property | Factory | 工厂对象 (Inherited from SqlBuilder.)
Top
See Also

Reference

SqliteBuilder Class
Adf.Db Namespace


SqlServer Class

SqlServer Class
MSSQL数据库基础操作
Inheritance Hierarchy
SystemObject
Adf.DbDbFactory
Adf.DbSqlServer

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class SqlServer : DbFactory, IDbFactory,
    IDisposable
Public Class SqlServer
    Inherits DbFactory
    Implements IDbFactory, IDisposable
public ref class SqlServer : public DbFactory,
    IDbFactory, IDisposable
type SqlServer =
    class
        inherit DbFactory
        interface IDbFactory
        interface IDisposable
    end

The SqlServer type exposes the following members.

Constructors
 | Name | Description
Public method | SqlServer(SqlConnection) | 创建新的实例
Public method | SqlServer(String) | 根据数据连接字符串创建一个新的数据实列
Top
Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Inherited from DbFactory.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取数据库连接
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Inherited from DbFactory.)
Public property | SqlBuilder | 返回可用的SqlBuilder对象 (Inherited from DbFactory.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

Adf.Db Namespace


SqlServer Constructor

SqlServer Constructor
Overload List
 | Name | Description
Public method | SqlServer(SqlConnection) | 创建新的实例
Public method | SqlServer(String) | 根据数据连接字符串创建一个新的数据实列
Top
See Also

Reference

SqlServer Class
Adf.Db Namespace


SqlServer Constructor (SqlConnection)

SqlServer Constructor (SqlConnection)
创建新的实例

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SqlServer(
    SqlConnection connection
)
Public Sub New (
    connection As SqlConnection
)
public:
SqlServer(
    SqlConnection^ connection
)
new :
        connection : SqlConnection -> SqlServer

Parameters

connection
Type: System.Data.SqlClientSqlConnection
数据库连接
See Also

Reference

SqlServer Class
SqlServer Overload
Adf.Db Namespace


SqlServer Constructor (String)

SqlServer Constructor (String)
根据数据连接字符串创建一个新的数据实列

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SqlServer(
    string connectionstring
)
Public Sub New (
    connectionstring As String
)
public:
SqlServer(
    String^ connectionstring
)
new :
        connectionstring : string -> SqlServer

Parameters

connectionstring
Type: SystemString
数据连接字符串
See Also

Reference

SqlServer Class
SqlServer Overload
Adf.Db Namespace


SqlServer Methods

SqlServer Methods

The SqlServer type exposes the following members.

Methods
 | Name | Description
Public method | Begin | 开始一个事务执行,当多个事务并行时，以最外层有效 (Inherited from DbFactory.)
Public method | Commit | 提交一个事务执行,并行事务时非最外层则跳过 (Inherited from DbFactory.)
Public method | Commit(Boolean) | 提交一个事务执行 (Inherited from DbFactory.)
Public method | CreateCommand | 根据指定数据返回Command对象,所有的数据操作均应执行此方法来获取Command对象 (Inherited from DbFactory.)
Protected method | CreateParameter(DbEntity) | 根据对象创建参数列表,使用ParameterChar所指定的参数前缀 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | CreateParameter(String, Object, DbType, Int32) | 创建一个参数 (Inherited from DbFactory.)
Public method | Delete | 执行数据对象删除处理 (Inherited from DbFactory.)
Public method | Dispose | 释放所占用的资源 (Inherited from DbFactory.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Public method | Execute(String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(DbEntity, String) | 执行一个语句或过程 (Inherited from DbFactory.)
Public method | Execute(String, Boolean, IDbDataParameter) | 执行一个语句或过程 (Inherited from DbFactory.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetCount(String) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(DbEntity) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetCount(String, Boolean) | 获取指定语句第一行第一例的Int类型数据 (Inherited from DbFactory.)
Public method | GetCount(String, String) | 根据表与条件返回一个COUNT值 (Inherited from DbFactory.)
Public method | GetCount(DbEntity, String) | 获取指定对象的记录数 (Inherited from DbFactory.)
Public method | GetDataSet(String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(DbEntity, String) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataSet(String, Boolean, IDbDataParameter) | 返回一个数据集 (Inherited from DbFactory.)
Public method | GetDataTable(String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(DbEntity, String) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetDataTable(String, Boolean, IDbDataParameter) | 返回一个数据表 (Inherited from DbFactory.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetIdentityT | 获取上一执行语句所产生的自增值(此功能不一定支持所有数据库服务器)，如果有误，返回为结果类型初始值 (Inherited from DbFactory.)
Public method | GetListT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(DbEntity, String) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetListsT(String, Boolean, IDbDataParameter) | 返回一个数据对象集 (Inherited from DbFactory.)
Public method | GetRowT(String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(DbEntity, String) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetRowT(String, Boolean, IDbDataParameter) | 返回一个数据对象 (Inherited from DbFactory.)
Public method | GetScalar(String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(DbEntity, String) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetScalar(String, Boolean, IDbDataParameter) | 获取第一行第一列的数据 (Inherited from DbFactory.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | InjectReplace | SQL注入过滤 (Inherited from DbFactory.)
Public method | Insert | 执行数据对象插入请求 (Inherited from DbFactory.)
Protected method | LogBuilder | 日志添加 (Inherited from DbFactory.)
Protected method | LogManagerInitialize | 日志管理器初始 (Inherited from DbFactory.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | PageSqlT | 返回一个分页列表对象 (Inherited from DbFactory.)
Public method | Rollback | 回滚事务,当并行事务已回滚时则跳过 (Inherited from DbFactory.)
Public method | ToSafeString(Object) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToSafeString(Object, Type) | 根据数据类型返回一个可以直接应用于SQL语句的安全字符串 (Inherited from DbFactory.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Public method | Update | 执行数据对象修改 (Inherited from DbFactory.)
Top
See Also

Reference

SqlServer Class
Adf.Db Namespace


SqlServer Properties

SqlServer Properties

The SqlServer type exposes the following members.

Properties
 | Name | Description
Public property | CommandCount | 获取Command数，间接反应了执行了多少次数据操作 (Inherited from DbFactory.)
Public property | Connection | 获取数据库连接
Protected property | DbProviderFactory | 获取当前数据数据处理方法集 (Inherited from DbFactory.)
Public property | LastSql | 获取最后一个查询SQL (Inherited from DbFactory.)
Public property | Logger | 日志撰写器 若启用日志,默认的日志管理实例受FlushInterval影响，若配置该值则应在程序执行结束后进行相应的Flush操作，Factory不会进行默认缓冲刷新 (Inherited from DbFactory.)
Public property | Name | 获取当前操作对象的名称描述 (Overrides DbFactoryName.)
Public property | NestedTransaction | 获取是否为并行（嵌套）事务 (Inherited from DbFactory.)
Protected property | ParameterChar | 获取创建参数时,使用的前缀,默认使用@符,如果当前操作引擎不是,请重写该属性 (Inherited from DbFactory.)
Public property | SqlBuilder | 返回可用的SqlBuilder对象 (Inherited from DbFactory.)
Public property | Transaction | 获取当前正在执行的事务 (Inherited from DbFactory.)
Public property | TransactionLayer | 获取为并行(嵌套)事务时的当前事务层级 (Inherited from DbFactory.)
Top
See Also

Reference

SqlServer Class
Adf.Db Namespace


SqlServer.Connection Property

SqlServerConnection Property
获取数据库连接

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public SqlConnection Connection { get; }
Public ReadOnly Property Connection As SqlConnection
    Get
public:
property SqlConnection^ Connection {
    SqlConnection^ get ();
}
member Connection : SqlConnection with get

Property Value

Type: SqlConnection
See Also

Reference

SqlServer Class
Adf.Db Namespace


SqlServer.Name Property

SqlServerName Property
获取当前操作对象的名称描述

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
public:
virtual property String^ Name {
    String^ get () override;
}
abstract Name : string with get
override Name : string with get

Property Value

Type: String

Implements

IDbFactoryName
IDbFactoryName
See Also

Reference

SqlServer Class
Adf.Db Namespace


WhereRelation Enumeration

WhereRelation Enumeration
查询关系

Namespace: Adf.Db
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public enum WhereRelation
Public Enumeration WhereRelation
public enum class WhereRelation
type WhereRelation
Members
Member name | Value | Description
AND | 0 | AND 关系
OR | 1 | OR 关系
See Also

Reference

Adf.Db Namespace


Adf.Image Namespace

Adf.Image Namespace

[Missing <summary> documentation for "N:Adf.Image"]

Classes
 | Class | Description
Public class | ImageHanlde | 图片处理
Public class | ImageMark | 为图片处理水印
Enumerations
 | Enumeration | Description
Public enumeration | ImageMarkPosition | 水印图片位置说明


ImageHanlde Class

ImageHanlde Class
图片处理
Inheritance Hierarchy
SystemObject
Adf.ImageImageHanlde

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ImageHanlde : IDisposable
Public Class ImageHanlde
    Implements IDisposable
public ref class ImageHanlde : IDisposable
type ImageHanlde =
    class
        interface IDisposable
    end

The ImageHanlde type exposes the following members.

Constructors
 | Name | Description
Public method | ImageHanlde(Stream) | 初始化图片
Public method | ImageHanlde(String) | 初始化图片
Top
Methods
 | Name | Description
Public method | CompressImage(Int32) | 图片宽高自动压缩处理
Public method | CompressImage(Int32, Int32) | 图片宽高自动压缩处理
 | ConvertFormat | 格式转换,返回文件名
Public method | CreateMark(ImageMark) | 创建一个水印图
Public method | CreateMark(ImageMark, Stream) | 创建一个水印图
Public method | CreateMark(ImageMark, String) | 创建一个水印图
Public method | Dispose | 释放所占用的资源
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Save | 保存当前图片,使用此方法必需保证是使用的ImageHanlde 重载方法
Public method | Save(Stream) | 将图片保存至指定路径
Public method | Save(String) | 将图片保存至指定路径
Public method | Save(String, ImageFormat) | 将图片保存至指定路径
Public method | SetQuality | 设置当前图片质量
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ImageFormat | 获取或设置当前图片的格式
 | JpegCodeinfo | 默认的Jpeg编辑器
Public property | Path | 获取正在处理图片的路径
Top
See Also

Reference

Adf.Image Namespace


ImageHanlde Constructor

ImageHanlde Constructor
Overload List
 | Name | Description
Public method | ImageHanlde(Stream) | 初始化图片
Public method | ImageHanlde(String) | 初始化图片
Top
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde Constructor (Stream)

ImageHanlde Constructor (Stream)
初始化图片

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ImageHanlde(
    Stream stream
)
Public Sub New (
    stream As Stream
)
public:
ImageHanlde(
    Stream^ stream
)
new :
        stream : Stream -> ImageHanlde

Parameters

stream
Type: System.IOStream
图片流
See Also

Reference

ImageHanlde Class
ImageHanlde Overload
Adf.Image Namespace


ImageHanlde Constructor (String)

ImageHanlde Constructor (String)
初始化图片

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ImageHanlde(
    string path
)
Public Sub New (
    path As String
)
public:
ImageHanlde(
    String^ path
)
new :
        path : string -> ImageHanlde

Parameters

path
Type: SystemString
图片地址
See Also

Reference

ImageHanlde Class
ImageHanlde Overload
Adf.Image Namespace


ImageHanlde Methods

ImageHanlde Methods

The ImageHanlde type exposes the following members.

Methods
 | Name | Description
Public method | CompressImage(Int32) | 图片宽高自动压缩处理
Public method | CompressImage(Int32, Int32) | 图片宽高自动压缩处理
 | ConvertFormat | 格式转换,返回文件名
Public method | CreateMark(ImageMark) | 创建一个水印图
Public method | CreateMark(ImageMark, Stream) | 创建一个水印图
Public method | CreateMark(ImageMark, String) | 创建一个水印图
Public method | Dispose | 释放所占用的资源
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Save | 保存当前图片,使用此方法必需保证是使用的ImageHanlde 重载方法
Public method | Save(Stream) | 将图片保存至指定路径
Public method | Save(String) | 将图片保存至指定路径
Public method | Save(String, ImageFormat) | 将图片保存至指定路径
Public method | SetQuality | 设置当前图片质量
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.CompressImage Method

ImageHanldeCompressImage Method
Overload List
 | Name | Description
Public method | CompressImage(Int32) | 图片宽高自动压缩处理
Public method | CompressImage(Int32, Int32) | 图片宽高自动压缩处理
Top
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.CompressImage Method (Int32)

ImageHanldeCompressImage Method (Int32)
图片宽高自动压缩处理

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void CompressImage(
    int width
)
Public Sub CompressImage (
    width As Integer
)
public:
void CompressImage(
    int width
)
member CompressImage :
        width : int -> unit

Parameters

width
Type: SystemInt32
图片最大宽度，当大于该宽度时图片将自动进行压缩处理
See Also

Reference

ImageHanlde Class
CompressImage Overload
Adf.Image Namespace


ImageHanlde.CompressImage Method (Int32, Int32)

ImageHanldeCompressImage Method (Int32, Int32)
图片宽高自动压缩处理

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void CompressImage(
    int width,
    int height
)
Public Sub CompressImage (
    width As Integer,
    height As Integer
)
public:
void CompressImage(
    int width,
    int height
)
member CompressImage :
        width : int *
        height : int -> unit

Parameters

width
Type: SystemInt32
图片最大宽度，当大于该宽度时图片将自动进行压缩处理,当值小于图片宽图时自动以高度缩放等比计算
height
Type: SystemInt32
图片最大高度，当值小于图片高度时自动以宽图缩放等比计算
See Also

Reference

ImageHanlde Class
CompressImage Overload
Adf.Image Namespace


ImageHanlde.ConvertFormat Method

ImageHanldeConvertFormat Method
格式转换,返回文件名

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static string ConvertFormat(
    string filepath,
    ImageFormat type
)
Public Shared Function ConvertFormat (
    filepath As String,
    type As ImageFormat
) As String
public:
static String^ ConvertFormat(
    String^ filepath,
    ImageFormat^ type
)
static member ConvertFormat :
        filepath : string *
        type : ImageFormat -> string

Parameters

filepath
Type: SystemString
路径
type
Type: System.Drawing.ImagingImageFormat
类型

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Image.ImageHanlde.ConvertFormat(System.String,System.Drawing.Imaging.ImageFormat)"]

See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.CreateMark Method

ImageHanldeCreateMark Method
Overload List
 | Name | Description
Public method | CreateMark(ImageMark) | 创建一个水印图
Public method | CreateMark(ImageMark, Stream) | 创建一个水印图
Public method | CreateMark(ImageMark, String) | 创建一个水印图
Top
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.CreateMark Method (ImageMark)

ImageHanldeCreateMark Method (ImageMark)
创建一个水印图

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void CreateMark(
    ImageMark mark
)
Public Sub CreateMark (
    mark As ImageMark
)
public:
void CreateMark(
    ImageMark^ mark
)
member CreateMark :
        mark : ImageMark -> unit

Parameters

mark
Type: Adf.ImageImageMark
水印对象
Exceptions
Exception | Condition
ApplicationException | Create Error
See Also

Reference

ImageHanlde Class
CreateMark Overload
Adf.Image Namespace


ImageHanlde.CreateMark Method (ImageMark, Stream)

ImageHanldeCreateMark Method (ImageMark, Stream)
创建一个水印图

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void CreateMark(
    ImageMark mark,
    Stream savestream
)
Public Sub CreateMark (
    mark As ImageMark,
    savestream As Stream
)
public:
void CreateMark(
    ImageMark^ mark,
    Stream^ savestream
)
member CreateMark :
        mark : ImageMark *
        savestream : Stream -> unit

Parameters

mark
Type: Adf.ImageImageMark
水印对象
savestream
Type: System.IOStream
要保存至的文件流
Exceptions
Exception | Condition
ApplicationException | Create Error
See Also

Reference

ImageHanlde Class
CreateMark Overload
Adf.Image Namespace


ImageHanlde.CreateMark Method (ImageMark, String)

ImageHanldeCreateMark Method (ImageMark, String)
创建一个水印图

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void CreateMark(
    ImageMark mark,
    string savepath
)
Public Sub CreateMark (
    mark As ImageMark,
    savepath As String
)
public:
void CreateMark(
    ImageMark^ mark,
    String^ savepath
)
member CreateMark :
        mark : ImageMark *
        savepath : string -> unit

Parameters

mark
Type: Adf.ImageImageMark
水印对象
savepath
Type: SystemString
要保存至的文件路径
Exceptions
Exception | Condition
ApplicationException | Create Error
See Also

Reference

ImageHanlde Class
CreateMark Overload
Adf.Image Namespace


ImageHanlde.Dispose Method

ImageHanldeDispose Method
释放所占用的资源

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IDisposableDispose
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.Save Method

ImageHanldeSave Method
Overload List
 | Name | Description
Public method | Save | 保存当前图片,使用此方法必需保证是使用的ImageHanlde 重载方法
Public method | Save(Stream) | 将图片保存至指定路径
Public method | Save(String) | 将图片保存至指定路径
Public method | Save(String, ImageFormat) | 将图片保存至指定路径
Top
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.Save Method

ImageHanldeSave Method
保存当前图片,使用此方法必需保证是使用的ImageHanlde 重载方法

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Save()
Public Sub Save
public:
void Save()
member Save : unit -> unit
See Also

Reference

ImageHanlde Class
Save Overload
Adf.Image Namespace


ImageHanlde.Save Method (Stream)

ImageHanldeSave Method (Stream)
将图片保存至指定路径

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Save(
    Stream outputStream
)
Public Sub Save (
    outputStream As Stream
)
public:
void Save(
    Stream^ outputStream
)
member Save :
        outputStream : Stream -> unit

Parameters

outputStream
Type: System.IOStream
输出流
See Also

Reference

ImageHanlde Class
Save Overload
Adf.Image Namespace


ImageHanlde.Save Method (String)

ImageHanldeSave Method (String)
将图片保存至指定路径

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Save(
    string path
)
Public Sub Save (
    path As String
)
public:
void Save(
    String^ path
)
member Save :
        path : string -> unit

Parameters

path
Type: SystemString
路径
See Also

Reference

ImageHanlde Class
Save Overload
Adf.Image Namespace


ImageHanlde.Save Method (String, ImageFormat)

ImageHanldeSave Method (String, ImageFormat)
将图片保存至指定路径

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void Save(
    string path,
    ImageFormat if
)
Public Sub Save (
    path As String,
    if As ImageFormat
)
public:
void Save(
    String^ path,
    ImageFormat^ if
)
member Save :
        path : string *
        if : ImageFormat -> unit

Parameters

path
Type: SystemString
路径
if
Type: System.Drawing.ImagingImageFormat
要保存的文件格式
See Also

Reference

ImageHanlde Class
Save Overload
Adf.Image Namespace


ImageHanlde.SetQuality Method

ImageHanldeSetQuality Method
设置当前图片质量

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public void SetQuality(
    int quality
)
Public Sub SetQuality (
    quality As Integer
)
public:
void SetQuality(
    int quality
)
member SetQuality :
        quality : int -> unit

Parameters

quality
Type: SystemInt32
质量等级，由 1-100的数字表示，建议设置在60以上
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde Properties

ImageHanlde Properties

The ImageHanlde type exposes the following members.

Properties
 | Name | Description
Public property | ImageFormat | 获取或设置当前图片的格式
 | JpegCodeinfo | 默认的Jpeg编辑器
Public property | Path | 获取正在处理图片的路径
Top
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.ImageFormat Property

ImageHanldeImageFormat Property
获取或设置当前图片的格式

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ImageFormat ImageFormat { get; set; }
Public Property ImageFormat As ImageFormat
    Get
    Set
public:
property ImageFormat^ ImageFormat {
    ImageFormat^ get ();
    void set (ImageFormat^ value);
}
member ImageFormat : ImageFormat with get, set

Property Value

Type: ImageFormat
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.JpegCodeinfo Property

ImageHanldeJpegCodeinfo Property
默认的Jpeg编辑器

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public static ImageCodecInfo JpegCodeinfo { get; }
Public Shared ReadOnly Property JpegCodeinfo As ImageCodecInfo
    Get
public:
static property ImageCodecInfo^ JpegCodeinfo {
    ImageCodecInfo^ get ();
}
static member JpegCodeinfo : ImageCodecInfo with get

Property Value

Type: ImageCodecInfo
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageHanlde.Path Property

ImageHanldePath Property
获取正在处理图片的路径

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string Path { get; }
Public ReadOnly Property Path As String
    Get
public:
property String^ Path {
    String^ get ();
}
member Path : string with get

Property Value

Type: String
See Also

Reference

ImageHanlde Class
Adf.Image Namespace


ImageMark Class

ImageMark Class
为图片处理水印
Inheritance Hierarchy
SystemObject
Adf.ImageImageMark

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public class ImageMark
Public Class ImageMark
public ref class ImageMark
type ImageMark =  class end

The ImageMark type exposes the following members.

Constructors
 | Name | Description
Public method | ImageMark(String) | 初始化
Public method | ImageMark(String, Int32) | 初始化
Top
Methods
 | Name | Description
Public method | Create(String) | 开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性
Public method | Create(Stream, Stream) | 创建一个水印
Public method | Create(String, String) | 开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Protected method | GetPosition | 计算水印位置
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | ErrorMessage | 获取创建时出现的异常文本
Public property | ImgMark | 获取水印图片对象路径(注:如果已设置TxtMark则此设置将无效)
Public property | Left | 获取或设置水印距左边宽度,默认为10
Public property | Margin | 获取或设置当Position 不等于Custom 时水印与图片的边距
Public property | Position | 获取或设置水印图生成位置
Public property | Top | 获取或设置水印距顶高度,默认为10
Public property | TxtAlpha | 获取或设置文字水印透明度,值由0-255，值越小越透明
Public property | TxtColor | 获取或设置文字水印色
Public property | TxtFont | 获取或设置水印文字的大小及字体
Public property | TxtMark | 获取文字水印文本
Top
See Also

Reference

Adf.Image Namespace


ImageMark Constructor

ImageMark Constructor
Overload List
 | Name | Description
Public method | ImageMark(String) | 初始化
Public method | ImageMark(String, Int32) | 初始化
Top
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark Constructor (String)

ImageMark Constructor (String)
初始化

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ImageMark(
    string imgMark
)
Public Sub New (
    imgMark As String
)
public:
ImageMark(
    String^ imgMark
)
new :
        imgMark : string -> ImageMark

Parameters

imgMark
Type: SystemString
水印图片
See Also

Reference

ImageMark Class
ImageMark Overload
Adf.Image Namespace


ImageMark Constructor (String, Int32)

ImageMark Constructor (String, Int32)
初始化

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ImageMark(
    string txtMark,
    int FontSize
)
Public Sub New (
    txtMark As String,
    FontSize As Integer
)
public:
ImageMark(
    String^ txtMark,
    int FontSize
)
new :
        txtMark : string *
        FontSize : int -> ImageMark

Parameters

txtMark
Type: SystemString
水印文字
FontSize
Type: SystemInt32
文字大小
See Also

Reference

ImageMark Class
ImageMark Overload
Adf.Image Namespace


ImageMark Methods

ImageMark Methods

The ImageMark type exposes the following members.

Methods
 | Name | Description
Public method | Create(String) | 开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性
Public method | Create(Stream, Stream) | 创建一个水印
Public method | Create(String, String) | 开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Protected method | GetPosition | 计算水印位置
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.Create Method

ImageMarkCreate Method
Overload List
 | Name | Description
Public method | Create(String) | 开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性
Public method | Create(Stream, Stream) | 创建一个水印
Public method | Create(String, String) | 开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性
Top
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.Create Method (String)

ImageMarkCreate Method (String)
开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool Create(
    string filepath
)
Public Overridable Function Create (
    filepath As String
) As Boolean
public:
virtual bool Create(
    String^ filepath
)
abstract Create :
        filepath : string -> bool
override Create :
        filepath : string -> bool

Parameters

filepath
Type: SystemString
要添加水印的图片路径

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Image.ImageMark.Create(System.String)"]

See Also

Reference

ImageMark Class
Create Overload
Adf.Image Namespace


ImageMark.Create Method (Stream, Stream)

ImageMarkCreate Method (Stream, Stream)
创建一个水印

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool Create(
    Stream stream,
    Stream savestream
)
Public Overridable Function Create (
    stream As Stream,
    savestream As Stream
) As Boolean
public:
virtual bool Create(
    Stream^ stream,
    Stream^ savestream
)
abstract Create :
        stream : Stream *
        savestream : Stream -> bool
override Create :
        stream : Stream *
        savestream : Stream -> bool

Parameters

stream
Type: System.IOStream
要创建水印的图片流
savestream
Type: System.IOStream
要保存至的流

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Image.ImageMark.Create(System.IO.Stream,System.IO.Stream)"]

See Also

Reference

ImageMark Class
Create Overload
Adf.Image Namespace


ImageMark.Create Method (String, String)

ImageMarkCreate Method (String, String)
开始创建,并返回创建是否成功,如果不成功其异常信息将写入Result属性

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public virtual bool Create(
    string filepath,
    string savefilepath
)
Public Overridable Function Create (
    filepath As String,
    savefilepath As String
) As Boolean
public:
virtual bool Create(
    String^ filepath,
    String^ savefilepath
)
abstract Create :
        filepath : string *
        savefilepath : string -> bool
override Create :
        filepath : string *
        savefilepath : string -> bool

Parameters

filepath
Type: SystemString
要添加水印的图片路径
savefilepath
Type: SystemString
水印添加后的保存路径

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Image.ImageMark.Create(System.String,System.String)"]

See Also

Reference

ImageMark Class
Create Overload
Adf.Image Namespace


ImageMark.GetPosition Method

ImageMarkGetPosition Method
计算水印位置

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
protected virtual int[] GetPosition(
    int imgwidth,
    int imgheight,
    int markwidth,
    int markheight
)
Protected Overridable Function GetPosition (
    imgwidth As Integer,
    imgheight As Integer,
    markwidth As Integer,
    markheight As Integer
) As Integer()
protected:
virtual array<int>^ GetPosition(
    int imgwidth,
    int imgheight,
    int markwidth,
    int markheight
)
abstract GetPosition :
        imgwidth : int *
        imgheight : int *
        markwidth : int *
        markheight : int -> int[]
override GetPosition :
        imgwidth : int *
        imgheight : int *
        markwidth : int *
        markheight : int -> int[]

Parameters

imgwidth
Type: SystemInt32
图片宽度
imgheight
Type: SystemInt32
图片高度
markwidth
Type: SystemInt32
水印宽度
markheight
Type: SystemInt32
水印高度

Return Value

Type: Int32
int[x,y]
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark Properties

ImageMark Properties

The ImageMark type exposes the following members.

Properties
 | Name | Description
Public property | ErrorMessage | 获取创建时出现的异常文本
Public property | ImgMark | 获取水印图片对象路径(注:如果已设置TxtMark则此设置将无效)
Public property | Left | 获取或设置水印距左边宽度,默认为10
Public property | Margin | 获取或设置当Position 不等于Custom 时水印与图片的边距
Public property | Position | 获取或设置水印图生成位置
Public property | Top | 获取或设置水印距顶高度,默认为10
Public property | TxtAlpha | 获取或设置文字水印透明度,值由0-255，值越小越透明
Public property | TxtColor | 获取或设置文字水印色
Public property | TxtFont | 获取或设置水印文字的大小及字体
Public property | TxtMark | 获取文字水印文本
Top
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.ErrorMessage Property

ImageMarkErrorMessage Property
获取创建时出现的异常文本

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; protected set; }
Public Property ErrorMessage As String
    Get
    Protected Set
public:
property String^ ErrorMessage {
    String^ get ();
    protected: void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.ImgMark Property

ImageMarkImgMark Property
获取水印图片对象路径(注:如果已设置TxtMark则此设置将无效)

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string ImgMark { get; protected set; }
Public Property ImgMark As String
    Get
    Protected Set
public:
property String^ ImgMark {
    String^ get ();
    protected: void set (String^ value);
}
member ImgMark : string with get, set

Property Value

Type: String
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.Left Property

ImageMarkLeft Property
获取或设置水印距左边宽度,默认为10

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Left { get; set; }
Public Property Left As Integer
    Get
    Set
public:
property int Left {
    int get ();
    void set (int value);
}
member Left : int with get, set

Property Value

Type: Int32
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.Margin Property

ImageMarkMargin Property
获取或设置当Position 不等于Custom 时水印与图片的边距

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Margin { get; set; }
Public Property Margin As Integer
    Get
    Set
public:
property int Margin {
    int get ();
    void set (int value);
}
member Margin : int with get, set

Property Value

Type: Int32
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.Position Property

ImageMarkPosition Property
获取或设置水印图生成位置

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public ImageMarkPosition Position { get; set; }
Public Property Position As ImageMarkPosition
    Get
    Set
public:
property ImageMarkPosition Position {
    ImageMarkPosition get ();
    void set (ImageMarkPosition value);
}
member Position : ImageMarkPosition with get, set

Property Value

Type: ImageMarkPosition
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.Top Property

ImageMarkTop Property
获取或设置水印距顶高度,默认为10

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int Top { get; set; }
Public Property Top As Integer
    Get
    Set
public:
property int Top {
    int get ();
    void set (int value);
}
member Top : int with get, set

Property Value

Type: Int32
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.TxtAlpha Property

ImageMarkTxtAlpha Property
获取或设置文字水印透明度,值由0-255，值越小越透明

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public int TxtAlpha { get; set; }
Public Property TxtAlpha As Integer
    Get
    Set
public:
property int TxtAlpha {
    int get ();
    void set (int value);
}
member TxtAlpha : int with get, set

Property Value

Type: Int32
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.TxtColor Property

ImageMarkTxtColor Property
获取或设置文字水印色

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Color TxtColor { get; set; }
Public Property TxtColor As Color
    Get
    Set
public:
property Color TxtColor {
    Color get ();
    void set (Color value);
}
member TxtColor : Color with get, set

Property Value

Type: Color
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.TxtFont Property

ImageMarkTxtFont Property
获取或设置水印文字的大小及字体

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public Font TxtFont { get; set; }
Public Property TxtFont As Font
    Get
    Set
public:
property Font^ TxtFont {
    Font^ get ();
    void set (Font^ value);
}
member TxtFont : Font with get, set

Property Value

Type: Font
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMark.TxtMark Property

ImageMarkTxtMark Property
获取文字水印文本

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public string TxtMark { get; protected set; }
Public Property TxtMark As String
    Get
    Protected Set
public:
property String^ TxtMark {
    String^ get ();
    protected: void set (String^ value);
}
member TxtMark : string with get, set

Property Value

Type: String
See Also

Reference

ImageMark Class
Adf.Image Namespace


ImageMarkPosition Enumeration

ImageMarkPosition Enumeration
水印图片位置说明

Namespace: Adf.Image
Assembly: Adf (in Adf.dll) Version: 4.1.5549.27750
Syntax
C#
VB
C++
F#
Copy
public enum ImageMarkPosition
Public Enumeration ImageMarkPosition
public enum class ImageMarkPosition
type ImageMarkPosition
Members
Member name | Value | Description
Bottom_Right | 0 | 右下角，可设置margin属性以设置边距
Bottom_Left | 1 | 左下角，可设置margin属性以设置边距
Top_Right | 2 | 右上角，可设置margin属性以设置边距
Top_Left | 3 | 左上角，可设置margin属性以设置边距
Center | 4 | 正中间
Custom | 5 | 定制，以Top与Left设置为准
See Also

Reference

Adf.Image Namespace


Adf.Web Namespace

Adf.Web Namespace

[Missing <summary> documentation for "N:Adf.Web"]

Classes
 | Class | Description
Public class | Authcode | 验证码基类
Public class | BrowserHelper | 浏览器助手
Public class | CacheSession | 缓存式会话信息
Public class | CompressModule | AspNet Compress Module
Public class | ContextCacheTClass | 一个当前请求线程内缓存描述
Public class | ControlHelper | 控件助手
Public class | Global | Global
Public class | HttpSingletonT | 应用单例
Public class | JsHelper | Javascript 助手
Public class | LinkQuery | 查询链接处理
Public class | Pager | 页序处理
Public class | QueryHelper | 查询参数助手
Public class | UrlHelper | 地址助手
Public class | UrlVirtual | Url虚拟化操作类


Authcode Class

Authcode Class
验证码基类
Inheritance Hierarchy
SystemObject
Adf.WebAuthcode

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class Authcode : IHttpHandler
Public Class Authcode
    Implements IHttpHandler
public ref class Authcode : IHttpHandler
type Authcode =
    class
        interface IHttpHandler
    end

The Authcode type exposes the following members.

Constructors
 | Name | Description
Public method | Authcode | Initializes a new instance of the Authcode class
Top
Methods
 | Name | Description
 | Check | 检验码是否正确
Protected method | CreateCode | 创建随机字符串
Protected method | CreateImage | 创建图片数据
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ProcessRequest | 进程输出
Protected method | StoreCode | 码存储
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | CodeExpires | 获取失效分钟数
Public property | IsReusable | 是否允许复用
Top
See Also

Reference

Adf.Web Namespace


Authcode Constructor

Authcode Constructor
Initializes a new instance of the Authcode class

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public Authcode()
Public Sub New
public:
Authcode()
new : unit -> Authcode
See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode Methods

Authcode Methods

The Authcode type exposes the following members.

Methods
 | Name | Description
 | Check | 检验码是否正确
Protected method | CreateCode | 创建随机字符串
Protected method | CreateImage | 创建图片数据
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ProcessRequest | 进程输出
Protected method | StoreCode | 码存储
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode.Check Method

AuthcodeCheck Method
检验码是否正确

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static bool Check(
    string code,
    bool isRemove
)
Public Shared Function Check (
    code As String,
    isRemove As Boolean
) As Boolean
public:
static bool Check(
    String^ code,
    bool isRemove
)
static member Check :
        code : string *
        isRemove : bool -> bool

Parameters

code
Type: SystemString

[Missing <param name="code"/> documentation for "M:Adf.Web.Authcode.Check(System.String,System.Boolean)"]

isRemove
Type: SystemBoolean

[Missing <param name="isRemove"/> documentation for "M:Adf.Web.Authcode.Check(System.String,System.Boolean)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Web.Authcode.Check(System.String,System.Boolean)"]

See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode.CreateCode Method

AuthcodeCreateCode Method
创建随机字符串

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual string CreateCode()
Protected Overridable Function CreateCode As String
protected:
virtual String^ CreateCode()
abstract CreateCode : unit -> string
override CreateCode : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Authcode.CreateCode"]

See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode.CreateImage Method

AuthcodeCreateImage Method
创建图片数据

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void CreateImage(
    HttpContext context,
    string code
)
Protected Overridable Sub CreateImage (
    context As HttpContext,
    code As String
)
protected:
virtual void CreateImage(
    HttpContext^ context,
    String^ code
)
abstract CreateImage :
        context : HttpContext *
        code : string -> unit
override CreateImage :
        context : HttpContext *
        code : string -> unit

Parameters

context
Type: System.WebHttpContext

[Missing <param name="context"/> documentation for "M:Adf.Web.Authcode.CreateImage(System.Web.HttpContext,System.String)"]

code
Type: SystemString
验证码
See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode.ProcessRequest Method

AuthcodeProcessRequest Method
进程输出

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual void ProcessRequest(
    HttpContext context
)
Public Overridable Sub ProcessRequest (
    context As HttpContext
)
public:
virtual void ProcessRequest(
    HttpContext^ context
)
abstract ProcessRequest :
        context : HttpContext -> unit
override ProcessRequest :
        context : HttpContext -> unit

Parameters

context
Type: System.WebHttpContext

[Missing <param name="context"/> documentation for "M:Adf.Web.Authcode.ProcessRequest(System.Web.HttpContext)"]

Implements

IHttpHandlerProcessRequest(HttpContext)
See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode.StoreCode Method

AuthcodeStoreCode Method
码存储

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void StoreCode(
    HttpContext context,
    string code
)
Protected Overridable Sub StoreCode (
    context As HttpContext,
    code As String
)
protected:
virtual void StoreCode(
    HttpContext^ context,
    String^ code
)
abstract StoreCode :
        context : HttpContext *
        code : string -> unit
override StoreCode :
        context : HttpContext *
        code : string -> unit

Parameters

context
Type: System.WebHttpContext

[Missing <param name="context"/> documentation for "M:Adf.Web.Authcode.StoreCode(System.Web.HttpContext,System.String)"]

code
Type: SystemString

[Missing <param name="code"/> documentation for "M:Adf.Web.Authcode.StoreCode(System.Web.HttpContext,System.String)"]

See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode Properties

Authcode Properties

The Authcode type exposes the following members.

Properties
 | Name | Description
Protected property | CodeExpires | 获取失效分钟数
Public property | IsReusable | 是否允许复用
Top
See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode.CodeExpires Property

AuthcodeCodeExpires Property
获取失效分钟数

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual TimeSpan CodeExpires { get; }
Protected Overridable ReadOnly Property CodeExpires As TimeSpan
    Get
protected:
virtual property TimeSpan CodeExpires {
    TimeSpan get ();
}
abstract CodeExpires : TimeSpan with get
override CodeExpires : TimeSpan with get

Property Value

Type: TimeSpan
See Also

Reference

Authcode Class
Adf.Web Namespace


Authcode.IsReusable Property

AuthcodeIsReusable Property
是否允许复用

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsReusable { get; }
Public Overridable ReadOnly Property IsReusable As Boolean
    Get
public:
virtual property bool IsReusable {
    bool get ();
}
abstract IsReusable : bool with get
override IsReusable : bool with get

Property Value

Type: Boolean

Implements

IHttpHandlerIsReusable
See Also

Reference

Authcode Class
Adf.Web Namespace


BrowserHelper Class

BrowserHelper Class
浏览器助手
Inheritance Hierarchy
SystemObject
Adf.WebBrowserHelper

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static class BrowserHelper
Public NotInheritable Class BrowserHelper
public ref class BrowserHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BrowserHelper =  class end

The BrowserHelper type exposes the following members.

Methods
Name | Description
Browser | 用户浏览器
Ip | 获取浏览器IP
Os | 系统
Top
See Also

Reference

Adf.Web Namespace


BrowserHelper Methods

BrowserHelper Methods

The BrowserHelper type exposes the following members.

Methods
Name | Description
Browser | 用户浏览器
Ip | 获取浏览器IP
Os | 系统
Top
See Also

Reference

BrowserHelper Class
Adf.Web Namespace


BrowserHelper.Browser Method

BrowserHelperBrowser Method
用户浏览器

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Browser()
Public Shared Function Browser As String
public:
static String^ Browser()
static member Browser : unit -> string

Return Value

Type: String
返回客户端浏览器版本
See Also

Reference

BrowserHelper Class
Adf.Web Namespace


BrowserHelper.Ip Method

BrowserHelperIp Method
获取浏览器IP

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Ip()
Public Shared Function Ip As String
public:
static String^ Ip()
static member Ip : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.BrowserHelper.Ip"]

See Also

Reference

BrowserHelper Class
Adf.Web Namespace


BrowserHelper.Os Method

BrowserHelperOs Method
系统

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Os()
Public Shared Function Os As String
public:
static String^ Os()
static member Os : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.BrowserHelper.Os"]

See Also

Reference

BrowserHelper Class
Adf.Web Namespace


CacheSession Class

CacheSession Class
缓存式会话信息
Inheritance Hierarchy
SystemObject
Adf.WebCacheSession

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public abstract class CacheSession
Public MustInherit Class CacheSession
public ref class CacheSession abstract
[<AbstractClassAttribute>]
type CacheSession =  class end

The CacheSession type exposes the following members.

Constructors
 | Name | Description
Protected method | CacheSession | Initializes a new instance of the CacheSession class
Top
Methods
 | Name | Description
Public method | Check | 检查查询是否符合
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Login | 登录
Public method | Logout | 使用当前登录帐户登出
Public method | Logout(Int64) | 登出
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | NewFlag | 工具方法，构建一个新的Flag
Protected method | OnCookie | 写Cookie时
Protected method | ReadCache | 登录读缓存
Protected method | RemoveCache | 移除缓存
Protected method | RemoveCookie | 登录写Cookie
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | WriteCache | 登录写缓存
Protected method | WriteCookie | 登录写Cookie
Top
Properties
 | Name | Description
Public property | CacheMinutes | 默认缓存器过期分钟数，默认 5 当缓存器过期通过check接口检查通过后会重建缓存 若此值为零则无缓存，每次登录验证均由check检查
Public property | CookieName | 会话客户端存储名,默认为 sess
Public property | Id | 标识
Public property | IsLogin | 是否已登录
Top
Remarks
一般在分布式布局中使用此类代替系统默认的SESSION，处理多机session同步问题
See Also

Reference

Adf.Web Namespace


CacheSession Constructor

CacheSession Constructor
Initializes a new instance of the CacheSession class

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected CacheSession()
Protected Sub New
protected:
CacheSession()
new : unit -> CacheSession
See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession Methods

CacheSession Methods

The CacheSession type exposes the following members.

Methods
 | Name | Description
Public method | Check | 检查查询是否符合
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Login | 登录
Public method | Logout | 使用当前登录帐户登出
Public method | Logout(Int64) | 登出
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | NewFlag | 工具方法，构建一个新的Flag
Protected method | OnCookie | 写Cookie时
Protected method | ReadCache | 登录读缓存
Protected method | RemoveCache | 移除缓存
Protected method | RemoveCookie | 登录写Cookie
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | WriteCache | 登录写缓存
Protected method | WriteCookie | 登录写Cookie
Top
See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.Check Method

CacheSessionCheck Method
检查查询是否符合

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public abstract bool Check(
    long id,
    string flag
)
Public MustOverride Function Check (
    id As Long,
    flag As String
) As Boolean
public:
virtual bool Check(
    long long id,
    String^ flag
) abstract
abstract Check :
        id : int64 *
        flag : string -> bool

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.Check(System.Int64,System.String)"]

flag
Type: SystemString

[Missing <param name="flag"/> documentation for "M:Adf.Web.CacheSession.Check(System.Int64,System.String)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Web.CacheSession.Check(System.Int64,System.String)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.Login Method

CacheSessionLogin Method
登录

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Login(
    long id,
    string flag
)
Public Sub Login (
    id As Long,
    flag As String
)
public:
void Login(
    long long id,
    String^ flag
)
member Login :
        id : int64 *
        flag : string -> unit

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.Login(System.Int64,System.String)"]

flag
Type: SystemString

[Missing <param name="flag"/> documentation for "M:Adf.Web.CacheSession.Login(System.Int64,System.String)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.Logout Method

CacheSessionLogout Method
Overload List
 | Name | Description
Public method | Logout | 使用当前登录帐户登出
Public method | Logout(Int64) | 登出
Top
See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.Logout Method

CacheSessionLogout Method
使用当前登录帐户登出

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Logout()
Public Sub Logout
public:
void Logout()
member Logout : unit -> unit
See Also

Reference

CacheSession Class
Logout Overload
Adf.Web Namespace


CacheSession.Logout Method (Int64)

CacheSessionLogout Method (Int64)
登出

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Logout(
    long id
)
Public Sub Logout (
    id As Long
)
public:
void Logout(
    long long id
)
member Logout :
        id : int64 -> unit

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.Logout(System.Int64)"]

See Also

Reference

CacheSession Class
Logout Overload
Adf.Web Namespace


CacheSession.NewFlag Method

CacheSessionNewFlag Method
工具方法，构建一个新的Flag

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string NewFlag()
Public Shared Function NewFlag As String
public:
static String^ NewFlag()
static member NewFlag : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.CacheSession.NewFlag"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.OnCookie Method

CacheSessionOnCookie Method
写Cookie时

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnCookie(
    HttpCookie cookie
)
Protected Overridable Sub OnCookie (
    cookie As HttpCookie
)
protected:
virtual void OnCookie(
    HttpCookie^ cookie
)
abstract OnCookie :
        cookie : HttpCookie -> unit
override OnCookie :
        cookie : HttpCookie -> unit

Parameters

cookie
Type: System.WebHttpCookie

[Missing <param name="cookie"/> documentation for "M:Adf.Web.CacheSession.OnCookie(System.Web.HttpCookie)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.ReadCache Method

CacheSessionReadCache Method
登录读缓存

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void ReadCache(
    long id,
    out string flag
)
Protected Overridable Sub ReadCache (
    id As Long,
    <OutAttribute> ByRef flag As String
)
protected:
virtual void ReadCache(
    long long id,
    [OutAttribute] String^% flag
)
abstract ReadCache :
        id : int64 *
        flag : string byref -> unit
override ReadCache :
        id : int64 *
        flag : string byref -> unit

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.ReadCache(System.Int64,System.String@)"]

flag
Type: SystemString

[Missing <param name="flag"/> documentation for "M:Adf.Web.CacheSession.ReadCache(System.Int64,System.String@)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.RemoveCache Method

CacheSessionRemoveCache Method
移除缓存

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void RemoveCache(
    long id
)
Protected Overridable Sub RemoveCache (
    id As Long
)
protected:
virtual void RemoveCache(
    long long id
)
abstract RemoveCache :
        id : int64 -> unit
override RemoveCache :
        id : int64 -> unit

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.RemoveCache(System.Int64)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.RemoveCookie Method

CacheSessionRemoveCookie Method
登录写Cookie

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void RemoveCookie(
    long id
)
Protected Overridable Sub RemoveCookie (
    id As Long
)
protected:
virtual void RemoveCookie(
    long long id
)
abstract RemoveCookie :
        id : int64 -> unit
override RemoveCookie :
        id : int64 -> unit

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.RemoveCookie(System.Int64)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.WriteCache Method

CacheSessionWriteCache Method
登录写缓存

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void WriteCache(
    long id,
    string flag
)
Protected Overridable Sub WriteCache (
    id As Long,
    flag As String
)
protected:
virtual void WriteCache(
    long long id,
    String^ flag
)
abstract WriteCache :
        id : int64 *
        flag : string -> unit
override WriteCache :
        id : int64 *
        flag : string -> unit

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.WriteCache(System.Int64,System.String)"]

flag
Type: SystemString

[Missing <param name="flag"/> documentation for "M:Adf.Web.CacheSession.WriteCache(System.Int64,System.String)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.WriteCookie Method

CacheSessionWriteCookie Method
登录写Cookie

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void WriteCookie(
    long id,
    string flag
)
Protected Overridable Sub WriteCookie (
    id As Long,
    flag As String
)
protected:
virtual void WriteCookie(
    long long id,
    String^ flag
)
abstract WriteCookie :
        id : int64 *
        flag : string -> unit
override WriteCookie :
        id : int64 *
        flag : string -> unit

Parameters

id
Type: SystemInt64

[Missing <param name="id"/> documentation for "M:Adf.Web.CacheSession.WriteCookie(System.Int64,System.String)"]

flag
Type: SystemString

[Missing <param name="flag"/> documentation for "M:Adf.Web.CacheSession.WriteCookie(System.Int64,System.String)"]

See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession Properties

CacheSession Properties

The CacheSession type exposes the following members.

Properties
 | Name | Description
Public property | CacheMinutes | 默认缓存器过期分钟数，默认 5 当缓存器过期通过check接口检查通过后会重建缓存 若此值为零则无缓存，每次登录验证均由check检查
Public property | CookieName | 会话客户端存储名,默认为 sess
Public property | Id | 标识
Public property | IsLogin | 是否已登录
Top
See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.CacheMinutes Property

CacheSessionCacheMinutes Property
默认缓存器过期分钟数，默认 5 当缓存器过期通过check接口检查通过后会重建缓存 若此值为零则无缓存，每次登录验证均由check检查

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int CacheMinutes { get; }
Public Overridable ReadOnly Property CacheMinutes As Integer
    Get
public:
virtual property int CacheMinutes {
    int get ();
}
abstract CacheMinutes : int with get
override CacheMinutes : int with get

Property Value

Type: Int32
See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.CookieName Property

CacheSessionCookieName Property
会话客户端存储名,默认为 sess

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string CookieName { get; }
Public ReadOnly Property CookieName As String
    Get
public:
property String^ CookieName {
    String^ get ();
}
member CookieName : string with get

Property Value

Type: String
See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.Id Property

CacheSessionId Property
标识

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public long Id { get; }
Public ReadOnly Property Id As Long
    Get
public:
property long long Id {
    long long get ();
}
member Id : int64 with get

Property Value

Type: Int64
See Also

Reference

CacheSession Class
Adf.Web Namespace


CacheSession.IsLogin Property

CacheSessionIsLogin Property
是否已登录

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public bool IsLogin { get; }
Public ReadOnly Property IsLogin As Boolean
    Get
public:
property bool IsLogin {
    bool get ();
}
member IsLogin : bool with get

Property Value

Type: Boolean
See Also

Reference

CacheSession Class
Adf.Web Namespace


CompressModule Class

CompressModule Class
AspNet Compress Module
Inheritance Hierarchy
SystemObject
Adf.WebCompressModule

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class CompressModule : IHttpModule
Public Class CompressModule
    Implements IHttpModule
public ref class CompressModule : IHttpModule
type CompressModule =
    class
        interface IHttpModule
    end

The CompressModule type exposes the following members.

Constructors
 | Name | Description
Public method | CompressModule | Initializes a new instance of the CompressModule class
Top
Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Init | 重载模块初始
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | NoCompress | 设置不进行压缩处理
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Adf.Web Namespace


CompressModule Constructor

CompressModule Constructor
Initializes a new instance of the CompressModule class

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public CompressModule()
Public Sub New
public:
CompressModule()
new : unit -> CompressModule
See Also

Reference

CompressModule Class
Adf.Web Namespace


CompressModule Methods

CompressModule Methods

The CompressModule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | 资源释放
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | Init | 重载模块初始
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | NoCompress | 设置不进行压缩处理
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

CompressModule Class
Adf.Web Namespace


CompressModule.Dispose Method

CompressModuleDispose Method
资源释放

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Dispose()
Public Sub Dispose
public:
virtual void Dispose() sealed
abstract Dispose : unit -> unit
override Dispose : unit -> unit

Implements

IHttpModuleDispose
See Also

Reference

CompressModule Class
Adf.Web Namespace


CompressModule.Init Method

CompressModuleInit Method
重载模块初始

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Init(
    HttpApplication context
)
Public Sub Init (
    context As HttpApplication
)
public:
virtual void Init(
    HttpApplication^ context
) sealed
abstract Init :
        context : HttpApplication -> unit
override Init :
        context : HttpApplication -> unit

Parameters

context
Type: System.WebHttpApplication
Http Context

Implements

IHttpModuleInit(HttpApplication)
See Also

Reference

CompressModule Class
Adf.Web Namespace


CompressModule.NoCompress Method

CompressModuleNoCompress Method
设置不进行压缩处理

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void NoCompress(
    HttpContext context
)
Public Shared Sub NoCompress (
    context As HttpContext
)
public:
static void NoCompress(
    HttpContext^ context
)
static member NoCompress :
        context : HttpContext -> unit

Parameters

context
Type: System.WebHttpContext
Http Context
See Also

Reference

CompressModule Class
Adf.Web Namespace


ContextCache(TClass) Class

ContextCacheTClass Class
一个当前请求线程内缓存描述
Inheritance Hierarchy
SystemObject
AdfCacheValue TClass
Adf.WebContextCacheTClass

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public abstract class ContextCache<TClass> : CacheValue<TClass>
where TClass : class

Public MustInherit Class ContextCache(Of TClass As Class)
    Inherits CacheValue(Of TClass)
generic<typename TClass>
where TClass : ref class
public ref class ContextCache abstract : public CacheValue<TClass>
[<AbstractClassAttribute>]
type ContextCache<'TClass when 'TClass : not struct> =
    class
        inherit CacheValue<'TClass>
    end

Type Parameters

TClass
缓存类型

The ContextCacheTClass type exposes the following members.

Constructors
 | Name | Description
Protected method | ContextCacheTClass | Initializes a new instance of the ContextCacheTClass class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetInstanceT | 获取当前实例
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetValue | 获取值并指定是否验证过期 (Inherited from CacheValueT.)
Protected method | Init | 初始化 (Inherited from CacheValueT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | OnInit | 触发初始化 (Inherited from CacheValueT.)
Public method | Remove | 移除实例值 (Inherited from CacheValueT.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Expire | 获取或设置失效时间 (Inherited from CacheValueT.)
Public property | InitTime | 获取数据初始时间 (Inherited from CacheValueT.)
Public property | IsNull | 获取结果是否为Null (Inherited from CacheValueT.)
Public property | Value | 获取值 (Inherited from CacheValueT.)
Top
Remarks
若派发多子线程时请注意线程互斥
See Also

Reference

Adf.Web Namespace


ContextCache(TClass) Constructor

ContextCacheTClass Constructor
Initializes a new instance of the ContextCacheTClass class

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected ContextCache()
Protected Sub New
protected:
ContextCache()
new : unit -> ContextCache
See Also

Reference

ContextCacheTClass Class
Adf.Web Namespace


ContextCache(TClass) Methods

ContextCacheTClass Methods

The ContextCacheTClass generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetInstanceT | 获取当前实例
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetValue | 获取值并指定是否验证过期 (Inherited from CacheValueT.)
Protected method | Init | 初始化 (Inherited from CacheValueT.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | OnInit | 触发初始化 (Inherited from CacheValueT.)
Public method | Remove | 移除实例值 (Inherited from CacheValueT.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ContextCacheTClass Class
Adf.Web Namespace


ContextCache(TClass).GetInstance(T) Method

ContextCacheTClassGetInstanceT Method
获取当前实例

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected static T GetInstance<T>(
    string cacheName
)
where T : new(), ContextCache<TClass>

Protected Shared Function GetInstance(Of T As {New, ContextCache(Of TClass)}) (
    cacheName As String
) As T
protected:
generic<typename T>
where T : gcnew(), ContextCache<TClass>
static T GetInstance(
    String^ cacheName
)
static member GetInstance :
        cacheName : string -> 'T  when 'T : new() and ContextCache<'TClass>

Parameters

cacheName
Type: SystemString
缓存名

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:Adf.Web.ContextCache`1.GetInstance``1(System.String)"]

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Web.ContextCache`1.GetInstance``1(System.String)"]

See Also

Reference

ContextCacheTClass Class
Adf.Web Namespace


ContextCache(TClass) Properties

ContextCacheTClass Properties

The ContextCacheTClass generic type exposes the following members.

Properties
 | Name | Description
Public property | Expire | 获取或设置失效时间 (Inherited from CacheValueT.)
Public property | InitTime | 获取数据初始时间 (Inherited from CacheValueT.)
Public property | IsNull | 获取结果是否为Null (Inherited from CacheValueT.)
Public property | Value | 获取值 (Inherited from CacheValueT.)
Top
See Also

Reference

ContextCacheTClass Class
Adf.Web Namespace


ControlHelper Class

ControlHelper Class
控件助手
Inheritance Hierarchy
SystemObject
Adf.WebControlHelper

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class ControlHelper
Public Class ControlHelper
public ref class ControlHelper
type ControlHelper =  class end

The ControlHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ControlHelper | Initializes a new instance of the ControlHelper class
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | GetControlContent | 获取Web控件中的内容
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetUserControlContent(String, Object) | 获取Web用户控件中的内容
 | GetUserControlContentT(String, Object) | 获取Web用户控件中的内容
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Adf.Web Namespace


ControlHelper Constructor

ControlHelper Constructor
Initializes a new instance of the ControlHelper class

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public ControlHelper()
Public Sub New
public:
ControlHelper()
new : unit -> ControlHelper
See Also

Reference

ControlHelper Class
Adf.Web Namespace


ControlHelper Methods

ControlHelper Methods

The ControlHelper type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | GetControlContent | 获取Web控件中的内容
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetUserControlContent(String, Object) | 获取Web用户控件中的内容
 | GetUserControlContentT(String, Object) | 获取Web用户控件中的内容
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

ControlHelper Class
Adf.Web Namespace


ControlHelper.GetControlContent Method

ControlHelperGetControlContent Method
获取Web控件中的内容

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetControlContent(
    Control ct
)
Public Shared Function GetControlContent (
    ct As Control
) As String
public:
static String^ GetControlContent(
    Control^ ct
)
static member GetControlContent :
        ct : Control -> string

Parameters

ct
Type: System.Web.UIControl
控件

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.ControlHelper.GetControlContent(System.Web.UI.Control)"]

See Also

Reference

ControlHelper Class
Adf.Web Namespace


ControlHelper.GetUserControlContent Method

ControlHelperGetUserControlContent Method
Overload List
Name | Description
GetUserControlContent(String, Object) | 获取Web用户控件中的内容
GetUserControlContentT(String, Object) | 获取Web用户控件中的内容
Top
See Also

Reference

ControlHelper Class
Adf.Web Namespace


ControlHelper.GetUserControlContent Method (String, Object[])

ControlHelperGetUserControlContent Method (String, Object)
获取Web用户控件中的内容

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetUserControlContent(
    string virtualPath,
    params Object[] format
)
Public Shared Function GetUserControlContent (
    virtualPath As String,
    ParamArray format As Object()
) As String
public:
static String^ GetUserControlContent(
    String^ virtualPath,
    ... array<Object^>^ format
)
static member GetUserControlContent :
        virtualPath : string *
        format : Object[] -> string

Parameters

virtualPath
Type: SystemString
虚拟路径
format
Type: SystemObject
格式化串

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.ControlHelper.GetUserControlContent(System.String,System.Object[])"]

See Also

Reference

ControlHelper Class
GetUserControlContent Overload
Adf.Web Namespace


ControlHelper.GetUserControlContent(T) Method (String, Object[])

ControlHelperGetUserControlContentT Method (String, Object)
获取Web用户控件中的内容

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetUserControlContent<T>(
    string virtualPath,
    params Object[] format
)

Public Shared Function GetUserControlContent(Of T) (
    virtualPath As String,
    ParamArray format As Object()
) As String
public:
generic<typename T>
static String^ GetUserControlContent(
    String^ virtualPath,
    ... array<Object^>^ format
)
static member GetUserControlContent :
        virtualPath : string *
        format : Object[] -> string

Parameters

virtualPath
Type: SystemString
虚拟地址
format
Type: SystemObject
格式化串

Type Parameters

T
控件所基于的基础网页类型，该类必需是由Page继承而来

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.ControlHelper.GetUserControlContent``1(System.String,System.Object[])"]

See Also

Reference

ControlHelper Class
GetUserControlContent Overload
Adf.Web Namespace


Global Class

Global Class
Global
Inheritance Hierarchy
SystemObject
System.WebHttpApplication
Adf.WebGlobal

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class Global : HttpApplication
Public Class Global
    Inherits HttpApplication
public ref class Global : public HttpApplication
type Global =
    class
        inherit HttpApplication
    end

The Global type exposes the following members.

Constructors
 | Name | Description
Public method | Global | Initialize
Top
Methods
 | Name | Description
Public method | AddOnAcquireRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 AcquireRequestState 事件添加到当前请求的异步 AcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAcquireRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 AcquireRequestState 事件添加到当前请求的异步 AcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthenticateRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 AuthenticateRequest 事件添加到当前请求的异步 AuthenticateRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthenticateRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 AuthenticateRequest 事件添加到当前请求的异步 AuthenticateRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthorizeRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 AuthorizeRequest 事件添加到当前请求的异步 AuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthorizeRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 AuthorizeRequest 事件添加到当前请求的异步 AuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnBeginRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 BeginRequest 事件添加到当前请求的异步 BeginRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnBeginRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 BeginRequest 事件添加到当前请求的异步 BeginRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnEndRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 EndRequest 事件添加到当前请求的异步 EndRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnEndRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 EndRequest 事件添加到当前请求的异步 EndRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnLogRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 LogRequest 事件添加到当前请求的异步 LogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnLogRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 LogRequest 事件添加到当前请求的异步 LogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnMapRequestHandlerAsync(BeginEventHandler, EndEventHandler) | 将指定的 MapRequestHandler 事件添加到当前请求的异步 MapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnMapRequestHandlerAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 MapRequestHandler 事件添加到当前请求的异步 MapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAcquireRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostAcquireRequestState 事件添加到当前请求的异步 PostAcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAcquireRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostAcquireRequestState 事件添加到当前请求的异步 PostAcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthenticateRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostAuthenticateRequest 事件添加到当前请求的异步 PostAuthenticateRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthenticateRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostAuthorizeRequest 事件添加到当前请求的异步 PostAuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthorizeRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostAuthorizeRequest 事件添加到当前请求的异步 PostAuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthorizeRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostAuthorizeRequest 添加到当前请求的异步 PostAuthorizeRequest 事件处理程序的集合中。 (Inherited from HttpApplication.)
Public method | AddOnPostLogRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostLogRequest 事件添加到当前请求的异步 PostLogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostLogRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostLogRequest 事件添加到当前请求的异步 PostLogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostMapRequestHandlerAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostMapRequestHandler 事件添加到当前请求的异步 PostMapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostMapRequestHandlerAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostMapRequestHandler 事件添加到当前请求的异步 PostMapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostReleaseRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostReleaseRequestState 事件添加到当前请求的异步 PostReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostReleaseRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostReleaseRequestState 事件添加到当前请求的异步 PostReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostRequestHandlerExecute 事件添加到当前请求的异步 PostRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostRequestHandlerExecute 事件添加到当前请求的异步 PostRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostResolveRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostResolveRequestCache 事件添加到当前请求的异步 PostResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostResolveRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostResolveRequestCache 事件添加到当前请求的异步 PostResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostUpdateRequestCache 事件添加到当前请求的异步 PostUpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostUpdateRequestCache 事件添加到当前请求的异步 PostUpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPreRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler) | 将指定的 PreRequestHandlerExecute 事件添加到当前请求的异步 PreRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPreRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PreRequestHandlerExecute 事件添加到当前请求的异步 PreRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnReleaseRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 ReleaseRequestState 事件添加到当前请求的异步 ReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnReleaseRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 ReleaseRequestState 事件添加到当前请求的异步 ReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnResolveRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 ResolveRequestCache 事件处理程序添加到当前请求的异步 ResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnResolveRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 ResolveRequestCache 事件处理程序添加到当前请求的异步 ResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 UpdateRequestCache 事件添加到当前请求的异步 UpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 UpdateRequestCache 事件添加到当前请求的异步 UpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Protected method | Application_End | 应用结束
Protected method | Application_Error | 应用异常
Public method | CompleteRequest | 使 ASP.NET 跳过 HTTP 执行管线链中的所有事件和筛选并直接执行 EndRequest 事件。 (Inherited from HttpApplication.)
Public method | Dispose | 处置 HttpApplication 实例。 (Inherited from HttpApplication.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetVaryByCustomString | 提供 VaryByCustom 属性在整个应用程序范围内的实现。 (Inherited from HttpApplication.)
Public method | Init | 在添加所有事件处理程序模块之后执行自定义初始化代码。 (Inherited from HttpApplication.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Application | 获取应用程序的当前状态。 (Inherited from HttpApplication.)
Public property | Context | 获取关于当前请求的 HTTP 特定信息。 (Inherited from HttpApplication.)
Protected property | Events | 获取处理所有应用程序事件的事件处理程序委托列表。 (Inherited from HttpApplication.)
 | Instance | 当前应用实例
Public property | Logger | Log Manager
Public property | Modules | 获取当前应用程序的模块集合。 (Inherited from HttpApplication.)
Public property | Request | 获取当前请求所对应的内部请求对象。 (Inherited from HttpApplication.)
Public property | Response | 获取当前请求所对应的内部响应对象。 (Inherited from HttpApplication.)
Public property | Server | 获取当前请求所对应的内部服务器对象。 (Inherited from HttpApplication.)
Public property | Session | 获取提供对会话数据的访问的内部会话对象。 (Inherited from HttpApplication.)
Public property | Site | 获取或设置 IComponent 实现的网站接口。 (Inherited from HttpApplication.)
Public property | User | 获取当前请求的内部用户对象。 (Inherited from HttpApplication.)
Top
Events
 | Name | Description
Public event | AcquireRequestState | 当 ASP.NET 获取与当前请求关联的当前状态（如会话状态）时发生。 (Inherited from HttpApplication.)
Public event | AuthenticateRequest | 当安全模块已建立用户标识时发生。 (Inherited from HttpApplication.)
Public event | AuthorizeRequest | 当安全模块已验证用户授权时发生。 (Inherited from HttpApplication.)
Public event | BeginRequest | 在 ASP.NET 响应请求时作为 HTTP 执行管线链中的第一个事件发生。 (Inherited from HttpApplication.)
Public event | Disposed | 在释放应用程序时发生。 (Inherited from HttpApplication.)
Public event | EndRequest | 在 ASP.NET 响应请求时作为 HTTP 执行管线链中的最后一个事件发生。 (Inherited from HttpApplication.)
Public event | Error | 当引发未处理的异常时发生。 (Inherited from HttpApplication.)
Public event | LogRequest | 恰好在 ASP.NET 为当前请求执行任何记录之前发生。 (Inherited from HttpApplication.)
Public event | MapRequestHandler | 在选择了用来响应请求的处理程序时发生。 (Inherited from HttpApplication.)
Public event | PostAcquireRequestState | 在已获得与当前请求关联的请求状态（例如会话状态）时发生。 (Inherited from HttpApplication.)
Public event | PostAuthenticateRequest | 当安全模块已建立用户标识时发生。 (Inherited from HttpApplication.)
Public event | PostAuthorizeRequest | 在当前请求的用户已获授权时发生。 (Inherited from HttpApplication.)
Public event | PostLogRequest | 在 ASP.NET 处理完 LogRequest 事件的所有事件处理程序后发生。 (Inherited from HttpApplication.)
Public event | PostMapRequestHandler | 在 ASP.NET 已将当前请求映射到相应的事件处理程序时发生。 (Inherited from HttpApplication.)
Public event | PostReleaseRequestState | 在 ASP.NET 已完成所有请求事件处理程序的执行并且请求状态数据已存储时发生。 (Inherited from HttpApplication.)
Public event | PostRequestHandlerExecute | 在 ASP.NET 事件处理程序（例如，某页或某个 XML Web service）执行完毕时发生。 (Inherited from HttpApplication.)
Public event | PostResolveRequestCache | 在 ASP.NET 跳过当前事件处理程序的执行并允许缓存模块满足来自缓存的请求时发生。 (Inherited from HttpApplication.)
Public event | PostUpdateRequestCache | 在 ASP.NET 完成缓存模块的更新并存储了用于从缓存中为后续请求提供服务的响应后，发生此事件。 (Inherited from HttpApplication.)
Public event | PreRequestHandlerExecute | 恰好在 ASP.NET 开始执行事件处理程序（例如，某页或某个 XML Web services）前发生。 (Inherited from HttpApplication.)
Public event | PreSendRequestContent | 恰好在 ASP.NET 向客户端发送内容之前发生。 (Inherited from HttpApplication.)
Public event | PreSendRequestHeaders | 恰好在 ASP.NET 向客户端发送 HTTP 标头之前发生。 (Inherited from HttpApplication.)
Public event | ReleaseRequestState | 在 ASP.NET 执行完所有请求事件处理程序后发生。该事件将使状态模块保存当前状态数据。 (Inherited from HttpApplication.)
Public event | ResolveRequestCache | 在 ASP.NET 完成授权事件以使缓存模块从缓存中为请求提供服务后发生，从而绕过事件处理程序（例如某个页或 XML Web services）的执行。 (Inherited from HttpApplication.)
Public event | UpdateRequestCache | 当 ASP.NET 执行完事件处理程序以使缓存模块存储将用于从缓存为后续请求提供服务的响应时发生。 (Inherited from HttpApplication.)
Top
See Also

Reference

Adf.Web Namespace


Global Constructor

Global Constructor
Initialize

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public Global()
Public Sub New
public:
Global()
new : unit -> Global
See Also

Reference

Global Class
Adf.Web Namespace


Global Methods

Global Methods

The Global type exposes the following members.

Methods
 | Name | Description
Public method | AddOnAcquireRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 AcquireRequestState 事件添加到当前请求的异步 AcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAcquireRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 AcquireRequestState 事件添加到当前请求的异步 AcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthenticateRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 AuthenticateRequest 事件添加到当前请求的异步 AuthenticateRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthenticateRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 AuthenticateRequest 事件添加到当前请求的异步 AuthenticateRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthorizeRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 AuthorizeRequest 事件添加到当前请求的异步 AuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnAuthorizeRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 AuthorizeRequest 事件添加到当前请求的异步 AuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnBeginRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 BeginRequest 事件添加到当前请求的异步 BeginRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnBeginRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 BeginRequest 事件添加到当前请求的异步 BeginRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnEndRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 EndRequest 事件添加到当前请求的异步 EndRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnEndRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 EndRequest 事件添加到当前请求的异步 EndRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnLogRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 LogRequest 事件添加到当前请求的异步 LogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnLogRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 LogRequest 事件添加到当前请求的异步 LogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnMapRequestHandlerAsync(BeginEventHandler, EndEventHandler) | 将指定的 MapRequestHandler 事件添加到当前请求的异步 MapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnMapRequestHandlerAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 MapRequestHandler 事件添加到当前请求的异步 MapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAcquireRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostAcquireRequestState 事件添加到当前请求的异步 PostAcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAcquireRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostAcquireRequestState 事件添加到当前请求的异步 PostAcquireRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthenticateRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostAuthenticateRequest 事件添加到当前请求的异步 PostAuthenticateRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthenticateRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostAuthorizeRequest 事件添加到当前请求的异步 PostAuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthorizeRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostAuthorizeRequest 事件添加到当前请求的异步 PostAuthorizeRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostAuthorizeRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostAuthorizeRequest 添加到当前请求的异步 PostAuthorizeRequest 事件处理程序的集合中。 (Inherited from HttpApplication.)
Public method | AddOnPostLogRequestAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostLogRequest 事件添加到当前请求的异步 PostLogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostLogRequestAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostLogRequest 事件添加到当前请求的异步 PostLogRequest 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostMapRequestHandlerAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostMapRequestHandler 事件添加到当前请求的异步 PostMapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostMapRequestHandlerAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostMapRequestHandler 事件添加到当前请求的异步 PostMapRequestHandler 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostReleaseRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostReleaseRequestState 事件添加到当前请求的异步 PostReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostReleaseRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostReleaseRequestState 事件添加到当前请求的异步 PostReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostRequestHandlerExecute 事件添加到当前请求的异步 PostRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostRequestHandlerExecute 事件添加到当前请求的异步 PostRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostResolveRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostResolveRequestCache 事件添加到当前请求的异步 PostResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostResolveRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostResolveRequestCache 事件添加到当前请求的异步 PostResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 PostUpdateRequestCache 事件添加到当前请求的异步 PostUpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPostUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PostUpdateRequestCache 事件添加到当前请求的异步 PostUpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPreRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler) | 将指定的 PreRequestHandlerExecute 事件添加到当前请求的异步 PreRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnPreRequestHandlerExecuteAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 PreRequestHandlerExecute 事件添加到当前请求的异步 PreRequestHandlerExecute 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnReleaseRequestStateAsync(BeginEventHandler, EndEventHandler) | 将指定的 ReleaseRequestState 事件添加到当前请求的异步 ReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnReleaseRequestStateAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 ReleaseRequestState 事件添加到当前请求的异步 ReleaseRequestState 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnResolveRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 ResolveRequestCache 事件处理程序添加到当前请求的异步 ResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnResolveRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 ResolveRequestCache 事件处理程序添加到当前请求的异步 ResolveRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler) | 将指定的 UpdateRequestCache 事件添加到当前请求的异步 UpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Public method | AddOnUpdateRequestCacheAsync(BeginEventHandler, EndEventHandler, Object) | 将指定的 UpdateRequestCache 事件添加到当前请求的异步 UpdateRequestCache 事件处理程序的集合。 (Inherited from HttpApplication.)
Protected method | Application_End | 应用结束
Protected method | Application_Error | 应用异常
Public method | CompleteRequest | 使 ASP.NET 跳过 HTTP 执行管线链中的所有事件和筛选并直接执行 EndRequest 事件。 (Inherited from HttpApplication.)
Public method | Dispose | 处置 HttpApplication 实例。 (Inherited from HttpApplication.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | GetVaryByCustomString | 提供 VaryByCustom 属性在整个应用程序范围内的实现。 (Inherited from HttpApplication.)
Public method | Init | 在添加所有事件处理程序模块之后执行自定义初始化代码。 (Inherited from HttpApplication.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Global Class
Adf.Web Namespace


Global.Application_End Method

GlobalApplication_End Method
应用结束

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void Application_End(
    Object obj,
    EventArgs e
)
Protected Overridable Sub Application_End (
    obj As Object,
    e As EventArgs
)
protected:
virtual void Application_End(
    Object^ obj,
    EventArgs^ e
)
abstract Application_End :
        obj : Object *
        e : EventArgs -> unit
override Application_End :
        obj : Object *
        e : EventArgs -> unit

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Adf.Web.Global.Application_End(System.Object,System.EventArgs)"]

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Adf.Web.Global.Application_End(System.Object,System.EventArgs)"]

See Also

Reference

Global Class
Adf.Web Namespace


Global.Application_Error Method

GlobalApplication_Error Method
应用异常

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void Application_Error(
    Object obj,
    EventArgs e
)
Protected Overridable Sub Application_Error (
    obj As Object,
    e As EventArgs
)
protected:
virtual void Application_Error(
    Object^ obj,
    EventArgs^ e
)
abstract Application_Error :
        obj : Object *
        e : EventArgs -> unit
override Application_Error :
        obj : Object *
        e : EventArgs -> unit

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:Adf.Web.Global.Application_Error(System.Object,System.EventArgs)"]

e
Type: SystemEventArgs

[Missing <param name="e"/> documentation for "M:Adf.Web.Global.Application_Error(System.Object,System.EventArgs)"]

See Also

Reference

Global Class
Adf.Web Namespace


Global Properties

Global Properties

The Global type exposes the following members.

Properties
 | Name | Description
Public property | Application | 获取应用程序的当前状态。 (Inherited from HttpApplication.)
Public property | Context | 获取关于当前请求的 HTTP 特定信息。 (Inherited from HttpApplication.)
Protected property | Events | 获取处理所有应用程序事件的事件处理程序委托列表。 (Inherited from HttpApplication.)
 | Instance | 当前应用实例
Public property | Logger | Log Manager
Public property | Modules | 获取当前应用程序的模块集合。 (Inherited from HttpApplication.)
Public property | Request | 获取当前请求所对应的内部请求对象。 (Inherited from HttpApplication.)
Public property | Response | 获取当前请求所对应的内部响应对象。 (Inherited from HttpApplication.)
Public property | Server | 获取当前请求所对应的内部服务器对象。 (Inherited from HttpApplication.)
Public property | Session | 获取提供对会话数据的访问的内部会话对象。 (Inherited from HttpApplication.)
Public property | Site | 获取或设置 IComponent 实现的网站接口。 (Inherited from HttpApplication.)
Public property | User | 获取当前请求的内部用户对象。 (Inherited from HttpApplication.)
Top
See Also

Reference

Global Class
Adf.Web Namespace


Global.Instance Property

GlobalInstance Property
当前应用实例

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static Global Instance { get; }
Public Shared ReadOnly Property Instance As Global
    Get
public:
static property Global^ Instance {
    Global^ get ();
}
static member Instance : Global with get

Property Value

Type: Global
See Also

Reference

Global Class
Adf.Web Namespace


Global.Logger Property

GlobalLogger Property
Log Manager

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public WebLogger Logger { get; }
Public ReadOnly Property Logger As WebLogger
    Get
public:
property WebLogger^ Logger {
    WebLogger^ get ();
}
member Logger : WebLogger with get

Property Value

Type: WebLogger
See Also

Reference

Global Class
Adf.Web Namespace


Global Events

Global Events

The Global type exposes the following members.

Events
 | Name | Description
Public event | AcquireRequestState | 当 ASP.NET 获取与当前请求关联的当前状态（如会话状态）时发生。 (Inherited from HttpApplication.)
Public event | AuthenticateRequest | 当安全模块已建立用户标识时发生。 (Inherited from HttpApplication.)
Public event | AuthorizeRequest | 当安全模块已验证用户授权时发生。 (Inherited from HttpApplication.)
Public event | BeginRequest | 在 ASP.NET 响应请求时作为 HTTP 执行管线链中的第一个事件发生。 (Inherited from HttpApplication.)
Public event | Disposed | 在释放应用程序时发生。 (Inherited from HttpApplication.)
Public event | EndRequest | 在 ASP.NET 响应请求时作为 HTTP 执行管线链中的最后一个事件发生。 (Inherited from HttpApplication.)
Public event | Error | 当引发未处理的异常时发生。 (Inherited from HttpApplication.)
Public event | LogRequest | 恰好在 ASP.NET 为当前请求执行任何记录之前发生。 (Inherited from HttpApplication.)
Public event | MapRequestHandler | 在选择了用来响应请求的处理程序时发生。 (Inherited from HttpApplication.)
Public event | PostAcquireRequestState | 在已获得与当前请求关联的请求状态（例如会话状态）时发生。 (Inherited from HttpApplication.)
Public event | PostAuthenticateRequest | 当安全模块已建立用户标识时发生。 (Inherited from HttpApplication.)
Public event | PostAuthorizeRequest | 在当前请求的用户已获授权时发生。 (Inherited from HttpApplication.)
Public event | PostLogRequest | 在 ASP.NET 处理完 LogRequest 事件的所有事件处理程序后发生。 (Inherited from HttpApplication.)
Public event | PostMapRequestHandler | 在 ASP.NET 已将当前请求映射到相应的事件处理程序时发生。 (Inherited from HttpApplication.)
Public event | PostReleaseRequestState | 在 ASP.NET 已完成所有请求事件处理程序的执行并且请求状态数据已存储时发生。 (Inherited from HttpApplication.)
Public event | PostRequestHandlerExecute | 在 ASP.NET 事件处理程序（例如，某页或某个 XML Web service）执行完毕时发生。 (Inherited from HttpApplication.)
Public event | PostResolveRequestCache | 在 ASP.NET 跳过当前事件处理程序的执行并允许缓存模块满足来自缓存的请求时发生。 (Inherited from HttpApplication.)
Public event | PostUpdateRequestCache | 在 ASP.NET 完成缓存模块的更新并存储了用于从缓存中为后续请求提供服务的响应后，发生此事件。 (Inherited from HttpApplication.)
Public event | PreRequestHandlerExecute | 恰好在 ASP.NET 开始执行事件处理程序（例如，某页或某个 XML Web services）前发生。 (Inherited from HttpApplication.)
Public event | PreSendRequestContent | 恰好在 ASP.NET 向客户端发送内容之前发生。 (Inherited from HttpApplication.)
Public event | PreSendRequestHeaders | 恰好在 ASP.NET 向客户端发送 HTTP 标头之前发生。 (Inherited from HttpApplication.)
Public event | ReleaseRequestState | 在 ASP.NET 执行完所有请求事件处理程序后发生。该事件将使状态模块保存当前状态数据。 (Inherited from HttpApplication.)
Public event | ResolveRequestCache | 在 ASP.NET 完成授权事件以使缓存模块从缓存中为请求提供服务后发生，从而绕过事件处理程序（例如某个页或 XML Web services）的执行。 (Inherited from HttpApplication.)
Public event | UpdateRequestCache | 当 ASP.NET 执行完事件处理程序以使缓存模块存储将用于从缓存为后续请求提供服务的响应时发生。 (Inherited from HttpApplication.)
Top
See Also

Reference

Global Class
Adf.Web Namespace


HttpSingleton(T) Class

HttpSingletonT Class
应用单例
Inheritance Hierarchy
SystemObject
Adf.WebHttpSingletonT

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static class HttpSingleton<T>
where T : new()

Public NotInheritable Class HttpSingleton(Of T As New)
generic<typename T>
where T : gcnew()
public ref class HttpSingleton abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type HttpSingleton<'T when 'T : new()> =  class end

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:Adf.Web.HttpSingleton`1"]

The HttpSingletonT type exposes the following members.

Properties
Name | Description
Instance | 获取实例
Top
See Also

Reference

Adf.Web Namespace


HttpSingleton(T) Properties

HttpSingletonT Properties

The HttpSingletonT generic type exposes the following members.

Properties
Name | Description
Instance | 获取实例
Top
See Also

Reference

HttpSingletonT Class
Adf.Web Namespace


HttpSingleton(T).Instance Property

HttpSingletonTInstance Property
获取实例

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static T Instance { get; }
Public Shared ReadOnly Property Instance As T
    Get
public:
static property T Instance {
    T get ();
}
static member Instance : 'T with get

Property Value

Type: T
See Also

Reference

HttpSingletonT Class
Adf.Web Namespace


JsHelper Class

JsHelper Class
Javascript 助手
Inheritance Hierarchy
SystemObject
Adf.WebJsHelper

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static class JsHelper
Public NotInheritable Class JsHelper
public ref class JsHelper abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type JsHelper =  class end
Methods
Name | Description
Alert(String) | 返回信息提示脚本
Alert(String, Object) | 返回信息提示脚本
AlertBack(String) | 弹出指定消息后,返回上页，并结束页运行
AlertBack(String, Object) | 弹出指定消息后,返回上页，并结束页运行
AlertClose(String) | 执行提交信息组并关闭窗体，并结束页运行
AlertClose(String, Object) | 执行提交信息并关闭窗体，并结束页运行
AlertRedirect(String, String) | 弹出指定的消息,返回指定的URL，并结束页运行
AlertRedirect(String, String, Object) | 弹出指定的消息,返回指定的URL，并结束页运行
AlertToControl(Control, String) | 将控件添加至指定的页面控件
AlertToControl(Control, String, Object) | 将控件添加至指定的页面控件,并返回Javascript控件
TopAlert(String, String) | 弹出指定的消息,并使框架页所有转向指定的URL
TopAlert(String, String, Object) | 弹出指定的消息,并使框架页所有转向指定的URL
Top
See Also

Reference

Adf.Web Namespace


JsHelper Methods

JsHelper Methods
Methods
Name | Description
Alert(String) | 返回信息提示脚本
Alert(String, Object) | 返回信息提示脚本
AlertBack(String) | 弹出指定消息后,返回上页，并结束页运行
AlertBack(String, Object) | 弹出指定消息后,返回上页，并结束页运行
AlertClose(String) | 执行提交信息组并关闭窗体，并结束页运行
AlertClose(String, Object) | 执行提交信息并关闭窗体，并结束页运行
AlertRedirect(String, String) | 弹出指定的消息,返回指定的URL，并结束页运行
AlertRedirect(String, String, Object) | 弹出指定的消息,返回指定的URL，并结束页运行
AlertToControl(Control, String) | 将控件添加至指定的页面控件
AlertToControl(Control, String, Object) | 将控件添加至指定的页面控件,并返回Javascript控件
TopAlert(String, String) | 弹出指定的消息,并使框架页所有转向指定的URL
TopAlert(String, String, Object) | 弹出指定的消息,并使框架页所有转向指定的URL
Top
See Also

Reference

JsHelper Class
Adf.Web Namespace


JsHelper.Alert Method

JsHelperAlert Method
Overload List
Name | Description
Alert(String) | 返回信息提示脚本
Alert(String, Object) | 返回信息提示脚本
Top
See Also

Reference

JsHelper Class
Adf.Web Namespace


JsHelper.Alert Method (String[])

JsHelperAlert Method (String)
返回信息提示脚本

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Alert(
    string[] msg
)
Public Shared Function Alert (
    msg As String()
) As String
public:
static String^ Alert(
    array<String^>^ msg
)
static member Alert :
        msg : string[] -> string

Parameters

msg
Type: SystemString
消息

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.JsHelper.Alert(System.String[])"]

See Also

Reference

JsHelper Class
Alert Overload
Adf.Web Namespace


JsHelper.Alert Method (String, Object[])

JsHelperAlert Method (String, Object)
返回信息提示脚本

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Alert(
    string msg,
    params Object[] format
)
Public Shared Function Alert (
    msg As String,
    ParamArray format As Object()
) As String
public:
static String^ Alert(
    String^ msg,
    ... array<Object^>^ format
)
static member Alert :
        msg : string *
        format : Object[] -> string

Parameters

msg
Type: SystemString
消息
format
Type: SystemObject
格式化串

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.JsHelper.Alert(System.String,System.Object[])"]

See Also

Reference

JsHelper Class
Alert Overload
Adf.Web Namespace


JsHelper.AlertBack Method

JsHelperAlertBack Method
Overload List
Name | Description
AlertBack(String) | 弹出指定消息后,返回上页，并结束页运行
AlertBack(String, Object) | 弹出指定消息后,返回上页，并结束页运行
Top
See Also

Reference

JsHelper Class
Adf.Web Namespace


JsHelper.AlertBack Method (String[])

JsHelperAlertBack Method (String)
弹出指定消息后,返回上页，并结束页运行

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void AlertBack(
    string[] msg
)
Public Shared Sub AlertBack (
    msg As String()
)
public:
static void AlertBack(
    array<String^>^ msg
)
static member AlertBack :
        msg : string[] -> unit

Parameters

msg
Type: SystemString
消息
See Also

Reference

JsHelper Class
AlertBack Overload
Adf.Web Namespace


JsHelper.AlertBack Method (String, Object[])

JsHelperAlertBack Method (String, Object)
弹出指定消息后,返回上页，并结束页运行

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void AlertBack(
    string msg,
    params Object[] format
)
Public Shared Sub AlertBack (
    msg As String,
    ParamArray format As Object()
)
public:
static void AlertBack(
    String^ msg,
    ... array<Object^>^ format
)
static member AlertBack :
        msg : string *
        format : Object[] -> unit

Parameters

msg
Type: SystemString
消息
format
Type: SystemObject
格式化串
See Also

Reference

JsHelper Class
AlertBack Overload
Adf.Web Namespace


JsHelper.AlertClose Method

JsHelperAlertClose Method
Overload List
Name | Description
AlertClose(String) | 执行提交信息组并关闭窗体，并结束页运行
AlertClose(String, Object) | 执行提交信息并关闭窗体，并结束页运行
Top
See Also

Reference

JsHelper Class
Adf.Web Namespace


JsHelper.AlertClose Method (String[])

JsHelperAlertClose Method (String)
执行提交信息组并关闭窗体，并结束页运行

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void AlertClose(
    string[] msg
)
Public Shared Sub AlertClose (
    msg As String()
)
public:
static void AlertClose(
    array<String^>^ msg
)
static member AlertClose :
        msg : string[] -> unit

Parameters

msg
Type: SystemString
信息组
See Also

Reference

JsHelper Class
AlertClose Overload
Adf.Web Namespace


JsHelper.AlertClose Method (String, Object[])

JsHelperAlertClose Method (String, Object)
执行提交信息并关闭窗体，并结束页运行

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void AlertClose(
    string msg,
    params Object[] format
)
Public Shared Sub AlertClose (
    msg As String,
    ParamArray format As Object()
)
public:
static void AlertClose(
    String^ msg,
    ... array<Object^>^ format
)
static member AlertClose :
        msg : string *
        format : Object[] -> unit

Parameters

msg
Type: SystemString
信息
format
Type: SystemObject
格式化串
See Also

Reference

JsHelper Class
AlertClose Overload
Adf.Web Namespace


JsHelper.AlertRedirect Method

JsHelperAlertRedirect Method
Overload List
Name | Description
AlertRedirect(String, String) | 弹出指定的消息,返回指定的URL，并结束页运行
AlertRedirect(String, String, Object) | 弹出指定的消息,返回指定的URL，并结束页运行
Top
See Also

Reference

JsHelper Class
Adf.Web Namespace


JsHelper.AlertRedirect Method (String[], String)

JsHelperAlertRedirect Method (String, String)
弹出指定的消息,返回指定的URL，并结束页运行

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void AlertRedirect(
    string[] msg,
    string url
)
Public Shared Sub AlertRedirect (
    msg As String(),
    url As String
)
public:
static void AlertRedirect(
    array<String^>^ msg,
    String^ url
)
static member AlertRedirect :
        msg : string[] *
        url : string -> unit

Parameters

msg
Type: SystemString
消息
url
Type: SystemString
URL
See Also

Reference

JsHelper Class
AlertRedirect Overload
Adf.Web Namespace


JsHelper.AlertRedirect Method (String, String, Object[])

JsHelperAlertRedirect Method (String, String, Object)
弹出指定的消息,返回指定的URL，并结束页运行

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void AlertRedirect(
    string msg,
    string url,
    params Object[] msgFormat
)
Public Shared Sub AlertRedirect (
    msg As String,
    url As String,
    ParamArray msgFormat As Object()
)
public:
static void AlertRedirect(
    String^ msg,
    String^ url,
    ... array<Object^>^ msgFormat
)
static member AlertRedirect :
        msg : string *
        url : string *
        msgFormat : Object[] -> unit

Parameters

msg
Type: SystemString
消息
url
Type: SystemString
URL
msgFormat
Type: SystemObject
格式化串
See Also

Reference

JsHelper Class
AlertRedirect Overload
Adf.Web Namespace


JsHelper.AlertToControl Method

JsHelperAlertToControl Method
Overload List
Name | Description
AlertToControl(Control, String) | 将控件添加至指定的页面控件
AlertToControl(Control, String, Object) | 将控件添加至指定的页面控件,并返回Javascript控件
Top
See Also

Reference

JsHelper Class
Adf.Web Namespace


JsHelper.AlertToControl Method (Control, String[])

JsHelperAlertToControl Method (Control, String)
将控件添加至指定的页面控件

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static Javascript AlertToControl(
    Control control,
    string[] msg
)
Public Shared Function AlertToControl (
    control As Control,
    msg As String()
) As Javascript
public:
static Javascript^ AlertToControl(
    Control^ control,
    array<String^>^ msg
)
static member AlertToControl :
        control : Control *
        msg : string[] -> Javascript

Parameters

control
Type: System.Web.UIControl
接收数据的控件
msg
Type: SystemString
消息

Return Value

Type: Javascript

[Missing <returns> documentation for "M:Adf.Web.JsHelper.AlertToControl(System.Web.UI.Control,System.String[])"]

See Also

Reference

JsHelper Class
AlertToControl Overload
Adf.Web Namespace


JsHelper.AlertToControl Method (Control, String, Object[])

JsHelperAlertToControl Method (Control, String, Object)
将控件添加至指定的页面控件,并返回Javascript控件

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static Javascript AlertToControl(
    Control control,
    string msg,
    params Object[] args
)
Public Shared Function AlertToControl (
    control As Control,
    msg As String,
    ParamArray args As Object()
) As Javascript
public:
static Javascript^ AlertToControl(
    Control^ control,
    String^ msg,
    ... array<Object^>^ args
)
static member AlertToControl :
        control : Control *
        msg : string *
        args : Object[] -> Javascript

Parameters

control
Type: System.Web.UIControl
接收数据的控件
msg
Type: SystemString
消息
args
Type: SystemObject
格式化数据

Return Value

Type: Javascript

[Missing <returns> documentation for "M:Adf.Web.JsHelper.AlertToControl(System.Web.UI.Control,System.String,System.Object[])"]

See Also

Reference

JsHelper Class
AlertToControl Overload
Adf.Web Namespace


JsHelper.TopAlert Method

JsHelperTopAlert Method
Overload List
Name | Description
TopAlert(String, String) | 弹出指定的消息,并使框架页所有转向指定的URL
TopAlert(String, String, Object) | 弹出指定的消息,并使框架页所有转向指定的URL
Top
See Also

Reference

JsHelper Class
Adf.Web Namespace


JsHelper.TopAlert Method (String[], String)

JsHelperTopAlert Method (String, String)
弹出指定的消息,并使框架页所有转向指定的URL

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void TopAlert(
    string[] msg,
    string url
)
Public Shared Sub TopAlert (
    msg As String(),
    url As String
)
public:
static void TopAlert(
    array<String^>^ msg,
    String^ url
)
static member TopAlert :
        msg : string[] *
        url : string -> unit

Parameters

msg
Type: SystemString
消息
url
Type: SystemString
URL
See Also

Reference

JsHelper Class
TopAlert Overload
Adf.Web Namespace


JsHelper.TopAlert Method (String, String, Object[])

JsHelperTopAlert Method (String, String, Object)
弹出指定的消息,并使框架页所有转向指定的URL

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void TopAlert(
    string msg,
    string url,
    params Object[] msgFormat
)
Public Shared Sub TopAlert (
    msg As String,
    url As String,
    ParamArray msgFormat As Object()
)
public:
static void TopAlert(
    String^ msg,
    String^ url,
    ... array<Object^>^ msgFormat
)
static member TopAlert :
        msg : string *
        url : string *
        msgFormat : Object[] -> unit

Parameters

msg
Type: SystemString
消息
url
Type: SystemString
URL
msgFormat
Type: SystemObject
消息格式化串
See Also

Reference

JsHelper Class
TopAlert Overload
Adf.Web Namespace


LinkQuery Class

LinkQuery Class
查询链接处理
Inheritance Hierarchy
SystemObject
Adf.WebLinkQuery

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class LinkQuery
Public Class LinkQuery
public ref class LinkQuery
type LinkQuery =  class end

The LinkQuery type exposes the following members.

Constructors
 | Name | Description
Public method | LinkQuery | 初始化
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetLink(String, Object) | 获取链接
Public method | GetLink(String, String) | 获取链接
Public method | GetLink(String, Object, String) | 获取链接
Public method | GetLink(String, String, String) | 获取链接
 | GetRmoveLink(NameValueCollection, String) | 获取查询中所有请求串
 | GetRmoveLink(HttpRequest, String) | 获取指定请求中所有请求串
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Remove(String) | 在当前实例中移除指定的项
Public method | Remove(String) | 在当前实例中移除指定的一组项
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Adf.Web Namespace


LinkQuery Constructor

LinkQuery Constructor
初始化

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public LinkQuery(
    HttpContext context
)
Public Sub New (
    context As HttpContext
)
public:
LinkQuery(
    HttpContext^ context
)
new :
        context : HttpContext -> LinkQuery

Parameters

context
Type: System.WebHttpContext
对象
See Also

Reference

LinkQuery Class
Adf.Web Namespace


LinkQuery Methods

LinkQuery Methods

The LinkQuery type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetLink(String, Object) | 获取链接
Public method | GetLink(String, String) | 获取链接
Public method | GetLink(String, Object, String) | 获取链接
Public method | GetLink(String, String, String) | 获取链接
 | GetRmoveLink(NameValueCollection, String) | 获取查询中所有请求串
 | GetRmoveLink(HttpRequest, String) | 获取指定请求中所有请求串
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | Remove(String) | 在当前实例中移除指定的项
Public method | Remove(String) | 在当前实例中移除指定的一组项
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

LinkQuery Class
Adf.Web Namespace


LinkQuery.GetLink Method

LinkQueryGetLink Method
Overload List
 | Name | Description
Public method | GetLink(String, Object) | 获取链接
Public method | GetLink(String, String) | 获取链接
Public method | GetLink(String, Object, String) | 获取链接
Public method | GetLink(String, String, String) | 获取链接
Top
See Also

Reference

LinkQuery Class
Adf.Web Namespace


LinkQuery.GetLink Method (String, Object)

LinkQueryGetLink Method (String, Object)
获取链接

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string GetLink(
    string name,
    Object value
)
Public Function GetLink (
    name As String,
    value As Object
) As String
public:
String^ GetLink(
    String^ name,
    Object^ value
)
member GetLink :
        name : string *
        value : Object -> string

Parameters

name
Type: SystemString
链接名
value
Type: SystemObject
链接当前值，该值可为Null

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.LinkQuery.GetLink(System.String,System.Object)"]

See Also

Reference

LinkQuery Class
GetLink Overload
Adf.Web Namespace


LinkQuery.GetLink Method (String, String)

LinkQueryGetLink Method (String, String)
获取链接

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string GetLink(
    string name,
    string value
)
Public Function GetLink (
    name As String,
    value As String
) As String
public:
String^ GetLink(
    String^ name,
    String^ value
)
member GetLink :
        name : string *
        value : string -> string

Parameters

name
Type: SystemString
链接名
value
Type: SystemString
链接当前值，该值可为Empty

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.LinkQuery.GetLink(System.String,System.String)"]

See Also

Reference

LinkQuery Class
GetLink Overload
Adf.Web Namespace


LinkQuery.GetLink Method (String, Object, String[])

LinkQueryGetLink Method (String, Object, String)
获取链接

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string GetLink(
    string name,
    Object value,
    params string[] removes
)
Public Function GetLink (
    name As String,
    value As Object,
    ParamArray removes As String()
) As String
public:
String^ GetLink(
    String^ name,
    Object^ value,
    ... array<String^>^ removes
)
member GetLink :
        name : string *
        value : Object *
        removes : string[] -> string

Parameters

name
Type: SystemString
查询名
value
Type: SystemObject
查询当前值，该值可为Empty
removes
Type: SystemString
要移除的一组查询名

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.LinkQuery.GetLink(System.String,System.Object,System.String[])"]

See Also

Reference

LinkQuery Class
GetLink Overload
Adf.Web Namespace


LinkQuery.GetLink Method (String, String, String[])

LinkQueryGetLink Method (String, String, String)
获取链接

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string GetLink(
    string name,
    string value,
    params string[] removes
)
Public Function GetLink (
    name As String,
    value As String,
    ParamArray removes As String()
) As String
public:
String^ GetLink(
    String^ name,
    String^ value,
    ... array<String^>^ removes
)
member GetLink :
        name : string *
        value : string *
        removes : string[] -> string

Parameters

name
Type: SystemString
查询名
value
Type: SystemString
查询当前值，该值可为Empty
removes
Type: SystemString
要移除的一组查询名

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.LinkQuery.GetLink(System.String,System.String,System.String[])"]

See Also

Reference

LinkQuery Class
GetLink Overload
Adf.Web Namespace


LinkQuery.GetRmoveLink Method

LinkQueryGetRmoveLink Method
Overload List
Name | Description
GetRmoveLink(NameValueCollection, String) | 获取查询中所有请求串
GetRmoveLink(HttpRequest, String) | 获取指定请求中所有请求串
Top
See Also

Reference

LinkQuery Class
Adf.Web Namespace


LinkQuery.GetRmoveLink Method (NameValueCollection, String)

LinkQueryGetRmoveLink Method (NameValueCollection, String)
获取查询中所有请求串

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetRmoveLink(
    NameValueCollection query,
    string remove
)
Public Shared Function GetRmoveLink (
    query As NameValueCollection,
    remove As String
) As String
public:
static String^ GetRmoveLink(
    NameValueCollection^ query,
    String^ remove
)
static member GetRmoveLink :
        query : NameValueCollection *
        remove : string -> string

Parameters

query
Type: System.Collections.SpecializedNameValueCollection
查询串
remove
Type: SystemString
要排除的项

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.LinkQuery.GetRmoveLink(System.Collections.Specialized.NameValueCollection,System.String)"]

See Also

Reference

LinkQuery Class
GetRmoveLink Overload
Adf.Web Namespace


LinkQuery.GetRmoveLink Method (HttpRequest, String)

LinkQueryGetRmoveLink Method (HttpRequest, String)
获取指定请求中所有请求串

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetRmoveLink(
    HttpRequest request,
    string remove
)
Public Shared Function GetRmoveLink (
    request As HttpRequest,
    remove As String
) As String
public:
static String^ GetRmoveLink(
    HttpRequest^ request,
    String^ remove
)
static member GetRmoveLink :
        request : HttpRequest *
        remove : string -> string

Parameters

request
Type: System.WebHttpRequest
请求对象
remove
Type: SystemString
要排除的项

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.LinkQuery.GetRmoveLink(System.Web.HttpRequest,System.String)"]

See Also

Reference

LinkQuery Class
GetRmoveLink Overload
Adf.Web Namespace


LinkQuery.Remove Method

LinkQueryRemove Method
Overload List
 | Name | Description
Public method | Remove(String) | 在当前实例中移除指定的项
Public method | Remove(String) | 在当前实例中移除指定的一组项
Top
See Also

Reference

LinkQuery Class
Adf.Web Namespace


LinkQuery.Remove Method (String)

LinkQueryRemove Method (String)
在当前实例中移除指定的项

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    string name
)
Public Sub Remove (
    name As String
)
public:
void Remove(
    String^ name
)
member Remove :
        name : string -> unit

Parameters

name
Type: SystemString
名称
See Also

Reference

LinkQuery Class
Remove Overload
Adf.Web Namespace


LinkQuery.Remove Method (String[])

LinkQueryRemove Method (String)
在当前实例中移除指定的一组项

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Remove(
    string[] names
)
Public Sub Remove (
    names As String()
)
public:
void Remove(
    array<String^>^ names
)
member Remove :
        names : string[] -> unit

Parameters

names
Type: SystemString
名称数组
See Also

Reference

LinkQuery Class
Remove Overload
Adf.Web Namespace


Pager Class

Pager Class
页序处理
Inheritance Hierarchy
SystemObject
AdfPager
Adf.WebPager

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class Pager : Pager
Public Class Pager
    Inherits Pager
public ref class Pager : public Pager
type Pager =
    class
        inherit Pager
    end

The Pager type exposes the following members.

Constructors
 | Name | Description
Public method | Pager | 初始化新实例 --用法: var pager = new Pager(); --数据处理 pager.Compute('总数'); --获取值
Top
Methods
 | Name | Description
Public method | Compute | 计算页序
Public method | Compute(Int32) | 计算页序 (Inherited from Pager.)
Public method | CreateLink(Int32, String) | 创建URL字符串
Public method | CreateLink(Int32, String, String) | 根据传入的querys参数名数组创建一个虚拟URL地址
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Protected property | Context | 当前上下文
Public property | IndexName | 页序名称
Public property | LastIndex | 获取总页数 (Inherited from Pager.)
Public property | NextIndex | 获取下一页索引 (Inherited from Pager.)
Public property | PageIndex | 获取或设置索引 (Inherited from Pager.)
Public property | PageSize | 获取或设置页大小 (Inherited from Pager.)
Public property | PrevIndex | 获取上一页索引 (Inherited from Pager.)
Public property | RecordIndex | 获取索引开始记录数 (Inherited from Pager.)
Public property | TotalCount | 获取总数 (Inherited from Pager.)
Public property | TotalName | 总量名称
Top
See Also

Reference

Adf.Web Namespace


Pager Constructor

Pager Constructor
初始化新实例 --用法: var pager = new Pager(); --数据处理 pager.Compute('总数'); --获取值

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public Pager(
    int pagesize
)
Public Sub New (
    pagesize As Integer
)
public:
Pager(
    int pagesize
)
new :
        pagesize : int -> Pager

Parameters

pagesize
Type: SystemInt32
页大小
See Also

Reference

Pager Class
Adf.Web Namespace


Pager Methods

Pager Methods

The Pager type exposes the following members.

Methods
 | Name | Description
Public method | Compute | 计算页序
Public method | Compute(Int32) | 计算页序 (Inherited from Pager.)
Public method | CreateLink(Int32, String) | 创建URL字符串
Public method | CreateLink(Int32, String, String) | 根据传入的querys参数名数组创建一个虚拟URL地址
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Pager Class
Adf.Web Namespace


Pager.Compute Method

PagerCompute Method
Overload List
 | Name | Description
Public method | Compute | 计算页序
Public method | Compute(Int32) | 计算页序 (Inherited from Pager.)
Top
See Also

Reference

Pager Class
Adf.Web Namespace


Pager.Compute Method

PagerCompute Method
计算页序

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Compute()
Public Sub Compute
public:
void Compute()
member Compute : unit -> unit
See Also

Reference

Pager Class
Compute Overload
Adf.Web Namespace


Pager.CreateLink Method

PagerCreateLink Method
Overload List
 | Name | Description
Public method | CreateLink(Int32, String) | 创建URL字符串
Public method | CreateLink(Int32, String, String) | 根据传入的querys参数名数组创建一个虚拟URL地址
Top
See Also

Reference

Pager Class
Adf.Web Namespace


Pager.CreateLink Method (Int32, String[])

PagerCreateLink Method (Int32, String)
创建URL字符串

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string CreateLink(
    int index,
    params string[] exclude
)
Public Function CreateLink (
    index As Integer,
    ParamArray exclude As String()
) As String
public:
String^ CreateLink(
    int index,
    ... array<String^>^ exclude
)
member CreateLink :
        index : int *
        exclude : string[] -> string

Parameters

index
Type: SystemInt32
索引
exclude
Type: SystemString
原始链接查询中的项排除

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pager.CreateLink(System.Int32,System.String[])"]

See Also

Reference

Pager Class
CreateLink Overload
Adf.Web Namespace


Pager.CreateLink Method (Int32, String[], String)

PagerCreateLink Method (Int32, String, String)
根据传入的querys参数名数组创建一个虚拟URL地址

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string CreateLink(
    int index,
    string[] querys,
    string compart
)
Public Function CreateLink (
    index As Integer,
    querys As String(),
    compart As String
) As String
public:
String^ CreateLink(
    int index,
    array<String^>^ querys,
    String^ compart
)
member CreateLink :
        index : int *
        querys : string[] *
        compart : string -> string

Parameters

index
Type: SystemInt32
索引
querys
Type: SystemString
要包含的查询组合
compart
Type: SystemString
分隔符，如： - 或 _ 等

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pager.CreateLink(System.Int32,System.String[],System.String)"]

See Also

Reference

Pager Class
CreateLink Overload
Adf.Web Namespace


Pager Properties

Pager Properties

The Pager type exposes the following members.

Properties
 | Name | Description
Protected property | Context | 当前上下文
Public property | IndexName | 页序名称
Public property | LastIndex | 获取总页数 (Inherited from Pager.)
Public property | NextIndex | 获取下一页索引 (Inherited from Pager.)
Public property | PageIndex | 获取或设置索引 (Inherited from Pager.)
Public property | PageSize | 获取或设置页大小 (Inherited from Pager.)
Public property | PrevIndex | 获取上一页索引 (Inherited from Pager.)
Public property | RecordIndex | 获取索引开始记录数 (Inherited from Pager.)
Public property | TotalCount | 获取总数 (Inherited from Pager.)
Public property | TotalName | 总量名称
Top
See Also

Reference

Pager Class
Adf.Web Namespace


Pager.Context Property

PagerContext Property
当前上下文

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected HttpContext Context { get; }
Protected ReadOnly Property Context As HttpContext
    Get
protected:
property HttpContext^ Context {
    HttpContext^ get ();
}
member Context : HttpContext with get

Property Value

Type: HttpContext
See Also

Reference

Pager Class
Adf.Web Namespace


Pager.IndexName Property

PagerIndexName Property
页序名称

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string IndexName { get; }
Public Overridable ReadOnly Property IndexName As String
    Get
public:
virtual property String^ IndexName {
    String^ get ();
}
abstract IndexName : string with get
override IndexName : string with get

Property Value

Type: String
See Also

Reference

Pager Class
Adf.Web Namespace


Pager.TotalName Property

PagerTotalName Property
总量名称

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string TotalName { get; }
Public Overridable ReadOnly Property TotalName As String
    Get
public:
virtual property String^ TotalName {
    String^ get ();
}
abstract TotalName : string with get
override TotalName : string with get

Property Value

Type: String
See Also

Reference

Pager Class
Adf.Web Namespace


QueryHelper Class

QueryHelper Class
查询参数助手
Inheritance Hierarchy
SystemObject
Adf.WebQueryHelper

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class QueryHelper
Public Class QueryHelper
public ref class QueryHelper
type QueryHelper =  class end

The QueryHelper type exposes the following members.

Constructors
 | Name | Description
Public method | QueryHelper | Initializes a new instance of the QueryHelper class
Top
Methods
 | Name | Description
 | Cookie | 获取一个Cookie值，此方法不会返回null
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | Get | 获取一个Get值，此方法不会返回null
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetPost | 获取通过QueryString或Form传递的参数，此方法不会返回null
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | Gpc | 获取通过Get或Post或Cookie传递的参数，此方法不会返回null
 | Gpcs | 获取通过Get或Post或Cookie或Session传递的参数，此方法不会返回null
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Post | 获取一个Post值，此方法不会返回null
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Adf.Web Namespace


QueryHelper Constructor

QueryHelper Constructor
Initializes a new instance of the QueryHelper class

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public QueryHelper()
Public Sub New
public:
QueryHelper()
new : unit -> QueryHelper
See Also

Reference

QueryHelper Class
Adf.Web Namespace


QueryHelper Methods

QueryHelper Methods

The QueryHelper type exposes the following members.

Methods
 | Name | Description
 | Cookie | 获取一个Cookie值，此方法不会返回null
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
 | Get | 获取一个Get值，此方法不会返回null
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
 | GetPost | 获取通过QueryString或Form传递的参数，此方法不会返回null
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | Gpc | 获取通过Get或Post或Cookie传递的参数，此方法不会返回null
 | Gpcs | 获取通过Get或Post或Cookie或Session传递的参数，此方法不会返回null
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | Post | 获取一个Post值，此方法不会返回null
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

QueryHelper Class
Adf.Web Namespace


QueryHelper.Cookie Method

QueryHelperCookie Method
获取一个Cookie值，此方法不会返回null

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Cookie(
    string name,
    string defaultValue = ""
)
Public Shared Function Cookie (
    name As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ Cookie(
    String^ name,
    String^ defaultValue = L""
)
static member Cookie :
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

name
Type: SystemString
参数名称
defaultValue (Optional)
Type: SystemString
未找到时的默认值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.QueryHelper.Cookie(System.String,System.String)"]

See Also

Reference

QueryHelper Class
Adf.Web Namespace


QueryHelper.Get Method

QueryHelperGet Method
获取一个Get值，此方法不会返回null

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Get(
    string name,
    string defaultValue = ""
)
Public Shared Function Get (
    name As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ Get(
    String^ name,
    String^ defaultValue = L""
)
static member Get :
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

name
Type: SystemString
参数名称
defaultValue (Optional)
Type: SystemString
未找到时的默认值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.QueryHelper.Get(System.String,System.String)"]

See Also

Reference

QueryHelper Class
Adf.Web Namespace


QueryHelper.GetPost Method

QueryHelperGetPost Method
获取通过QueryString或Form传递的参数，此方法不会返回null

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetPost(
    string name,
    string defaultValue = ""
)
Public Shared Function GetPost (
    name As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ GetPost(
    String^ name,
    String^ defaultValue = L""
)
static member GetPost :
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

name
Type: SystemString
参数名称
defaultValue (Optional)
Type: SystemString
未找到时的默认值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.QueryHelper.GetPost(System.String,System.String)"]

See Also

Reference

QueryHelper Class
Adf.Web Namespace


QueryHelper.Gpc Method

QueryHelperGpc Method
获取通过Get或Post或Cookie传递的参数，此方法不会返回null

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Gpc(
    string name,
    string defaultValue = ""
)
Public Shared Function Gpc (
    name As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ Gpc(
    String^ name,
    String^ defaultValue = L""
)
static member Gpc :
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

name
Type: SystemString
参数名称
defaultValue (Optional)
Type: SystemString
未找到时的默认值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.QueryHelper.Gpc(System.String,System.String)"]

See Also

Reference

QueryHelper Class
Adf.Web Namespace


QueryHelper.Gpcs Method

QueryHelperGpcs Method
获取通过Get或Post或Cookie或Session传递的参数，此方法不会返回null

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Gpcs(
    string name,
    string defaultValue = ""
)
Public Shared Function Gpcs (
    name As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ Gpcs(
    String^ name,
    String^ defaultValue = L""
)
static member Gpcs :
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

name
Type: SystemString
参数名称
defaultValue (Optional)
Type: SystemString
未找到时的默认值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.QueryHelper.Gpcs(System.String,System.String)"]

See Also

Reference

QueryHelper Class
Adf.Web Namespace


QueryHelper.Post Method

QueryHelperPost Method
获取一个Post值，此方法不会返回null

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Post(
    string name,
    string defaultValue = ""
)
Public Shared Function Post (
    name As String,
    Optional defaultValue As String = ""
) As String
public:
static String^ Post(
    String^ name,
    String^ defaultValue = L""
)
static member Post :
        name : string *
        ?defaultValue : string
(* Defaults:
        let _defaultValue = defaultArg defaultValue ""
*)
-> string

Parameters

name
Type: SystemString
参数名称
defaultValue (Optional)
Type: SystemString
未找到时的默认值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.QueryHelper.Post(System.String,System.String)"]

See Also

Reference

QueryHelper Class
Adf.Web Namespace


UrlHelper Class

UrlHelper Class
地址助手
Inheritance Hierarchy
SystemObject
Adf.WebUrlHelper

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class UrlHelper
Public Class UrlHelper
public ref class UrlHelper
type UrlHelper =  class end

The UrlHelper type exposes the following members.

Constructors
 | Name | Description
Public method | UrlHelper | Initializes a new instance of the UrlHelper class
Top
Methods
 | Name | Description
 | CheckWww | 检测是否为www开始的网址，若不是则自动添加
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetUrlPath | 返回完整的URL路径地址(不含文件名)
 | GetVirtualPath | 返回可用的虚拟目录根路径
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | MoveURL | 进行URL移动(HTTP 301 处理)，并结束页运行
 | Refurl | 判断是否有上一页返回,如果存在则返回为上一页绝对URL地址,不存在则返回所输入的新URL
 | ReplaceDomain | 替换网址域名(限http与https)
 | ToAbsolute(String, Object) | 处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值
 | ToAbsolute(String, Boolean, Object) | 处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

Adf.Web Namespace


UrlHelper Constructor

UrlHelper Constructor
Initializes a new instance of the UrlHelper class

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public UrlHelper()
Public Sub New
public:
UrlHelper()
new : unit -> UrlHelper
See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper Methods

UrlHelper Methods

The UrlHelper type exposes the following members.

Methods
 | Name | Description
 | CheckWww | 检测是否为www开始的网址，若不是则自动添加
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
 | GetUrlPath | 返回完整的URL路径地址(不含文件名)
 | GetVirtualPath | 返回可用的虚拟目录根路径
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
 | MoveURL | 进行URL移动(HTTP 301 处理)，并结束页运行
 | Refurl | 判断是否有上一页返回,如果存在则返回为上一页绝对URL地址,不存在则返回所输入的新URL
 | ReplaceDomain | 替换网址域名(限http与https)
 | ToAbsolute(String, Object) | 处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值
 | ToAbsolute(String, Boolean, Object) | 处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.CheckWww Method

UrlHelperCheckWww Method
检测是否为www开始的网址，若不是则自动添加

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static bool CheckWww(
    out string url
)
Public Shared Function CheckWww (
    <OutAttribute> ByRef url As String
) As Boolean
public:
static bool CheckWww(
    [OutAttribute] String^% url
)
static member CheckWww :
        url : string byref -> bool

Parameters

url
Type: SystemString
新的url地址(仅在返回为false时有效)

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Adf.Web.UrlHelper.CheckWww(System.String@)"]

See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.GetUrlPath Method

UrlHelperGetUrlPath Method
返回完整的URL路径地址(不含文件名)

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetUrlPath()
Public Shared Function GetUrlPath As String
public:
static String^ GetUrlPath()
static member GetUrlPath : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlHelper.GetUrlPath"]

See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.GetVirtualPath Method

UrlHelperGetVirtualPath Method
返回可用的虚拟目录根路径

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string GetVirtualPath()
Public Shared Function GetVirtualPath As String
public:
static String^ GetVirtualPath()
static member GetVirtualPath : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlHelper.GetVirtualPath"]

See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.MoveURL Method

UrlHelperMoveURL Method
进行URL移动(HTTP 301 处理)，并结束页运行

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static void MoveURL(
    string newUrl,
    params Object[] format
)
Public Shared Sub MoveURL (
    newUrl As String,
    ParamArray format As Object()
)
public:
static void MoveURL(
    String^ newUrl,
    ... array<Object^>^ format
)
static member MoveURL :
        newUrl : string *
        format : Object[] -> unit

Parameters

newUrl
Type: SystemString
新URL地址
format
Type: SystemObject
格式化串
See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.Refurl Method

UrlHelperRefurl Method
判断是否有上一页返回,如果存在则返回为上一页绝对URL地址,不存在则返回所输入的新URL

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string Refurl(
    string newUrl,
    params Object[] format
)
Public Shared Function Refurl (
    newUrl As String,
    ParamArray format As Object()
) As String
public:
static String^ Refurl(
    String^ newUrl,
    ... array<Object^>^ format
)
static member Refurl :
        newUrl : string *
        format : Object[] -> string

Parameters

newUrl
Type: SystemString
新的URL地址
format
Type: SystemObject
格式化串

Return Value

Type: String
返回URL地址
See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.ReplaceDomain Method

UrlHelperReplaceDomain Method
替换网址域名(限http与https)

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string ReplaceDomain(
    HttpContext context,
    string newDomain
)
Public Shared Function ReplaceDomain (
    context As HttpContext,
    newDomain As String
) As String
public:
static String^ ReplaceDomain(
    HttpContext^ context,
    String^ newDomain
)
static member ReplaceDomain :
        context : HttpContext *
        newDomain : string -> string

Parameters

context
Type: System.WebHttpContext

[Missing <param name="context"/> documentation for "M:Adf.Web.UrlHelper.ReplaceDomain(System.Web.HttpContext,System.String)"]

newDomain
Type: SystemString

[Missing <param name="newDomain"/> documentation for "M:Adf.Web.UrlHelper.ReplaceDomain(System.Web.HttpContext,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlHelper.ReplaceDomain(System.Web.HttpContext,System.String)"]

See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.ToAbsolute Method

UrlHelperToAbsolute Method
Overload List
Name | Description
ToAbsolute(String, Object) | 处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值
ToAbsolute(String, Boolean, Object) | 处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值
Top
See Also

Reference

UrlHelper Class
Adf.Web Namespace


UrlHelper.ToAbsolute Method (String, Object[])

UrlHelperToAbsolute Method (String, Object)
处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string ToAbsolute(
    string path,
    params Object[] format
)
Public Shared Function ToAbsolute (
    path As String,
    ParamArray format As Object()
) As String
public:
static String^ ToAbsolute(
    String^ path,
    ... array<Object^>^ format
)
static member ToAbsolute :
        path : string *
        format : Object[] -> string

Parameters

path
Type: SystemString
路径或Url地址
format
Type: SystemObject
格式化串

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlHelper.ToAbsolute(System.String,System.Object[])"]

See Also

Reference

UrlHelper Class
ToAbsolute Overload
Adf.Web Namespace


UrlHelper.ToAbsolute Method (String, Boolean, Object[])

UrlHelperToAbsolute Method (String, Boolean, Object)
处理一个路径为可用URL，如果该URL为~/程序路径或/根路径则进行转换处理，否则直接输出原值

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public static string ToAbsolute(
    string path,
    bool appendSlash,
    params Object[] format
)
Public Shared Function ToAbsolute (
    path As String,
    appendSlash As Boolean,
    ParamArray format As Object()
) As String
public:
static String^ ToAbsolute(
    String^ path,
    bool appendSlash,
    ... array<Object^>^ format
)
static member ToAbsolute :
        path : string *
        appendSlash : bool *
        format : Object[] -> string

Parameters

path
Type: SystemString
路径或Url地址
appendSlash
Type: SystemBoolean
如果地址末尾不存在/正斜杠则自动添加
format
Type: SystemObject
格式化串

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlHelper.ToAbsolute(System.String,System.Boolean,System.Object[])"]

See Also

Reference

UrlHelper Class
ToAbsolute Overload
Adf.Web Namespace


UrlVirtual Class

UrlVirtual Class
Url虚拟化操作类
Inheritance Hierarchy
SystemObject
Adf.WebUrlVirtual

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class UrlVirtual
Public Class UrlVirtual
public ref class UrlVirtual
type UrlVirtual =  class end

The UrlVirtual type exposes the following members.

Constructors
Name | Description
UrlVirtual | 初始化类型
Top
Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Protected method | FormatMatch | URL格式化时的替换规则
Public method | FormatUrl | 根据现有数据格式化一个URL地址
Protected method | GetEncode | 获取值编码
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | MatchingQuery | 根据URL规范自动匹配现有网页查询
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 获取生成的URL地址 (Overrides ObjectToString.)
Top
Fields
Name | Description
MatchRegex | 格式规范匹配正则
Top
Properties
 | Name | Description
Public property | Context | 获取当前操作的HttpContext对象
Protected property | IsMatchingQuery | 获取或设置是否已调用了MatchingQuery
Public property | Item | 获取或设置URL参数值
 | UrlCriterion | 获取或设置URL规范,其中的中{}扩起来的字符代表参数名
Top
See Also

Reference

Adf.Web Namespace


UrlVirtual Constructor

UrlVirtual Constructor
初始化类型

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public UrlVirtual(
    string urlcriterion
)
Public Sub New (
    urlcriterion As String
)
public:
UrlVirtual(
    String^ urlcriterion
)
new :
        urlcriterion : string -> UrlVirtual

Parameters

urlcriterion
Type: SystemString
URL的格式规范,其中的中{}扩起来的字符代表参数名
Examples
Copy
new UrlVirtual("list-{p1}-{p2}-{p3}.html");
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual Fields

UrlVirtual Fields

The UrlVirtual type exposes the following members.

Fields
Name | Description
MatchRegex | 格式规范匹配正则
Top
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.MatchRegex Field

UrlVirtualMatchRegex Field
格式规范匹配正则

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected static readonly Regex MatchRegex
Protected Shared ReadOnly MatchRegex As Regex
protected:
static initonly Regex^ MatchRegex
static val MatchRegex: Regex

Field Value

Type: Regex
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual Methods

UrlVirtual Methods

The UrlVirtual type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Protected method | FormatMatch | URL格式化时的替换规则
Public method | FormatUrl | 根据现有数据格式化一个URL地址
Protected method | GetEncode | 获取值编码
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | MatchingQuery | 根据URL规范自动匹配现有网页查询
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 获取生成的URL地址 (Overrides ObjectToString.)
Top
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.FormatMatch Method

UrlVirtualFormatMatch Method
URL格式化时的替换规则

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual string FormatMatch(
    Match m
)
Protected Overridable Function FormatMatch (
    m As Match
) As String
protected:
virtual String^ FormatMatch(
    Match^ m
)
abstract FormatMatch :
        m : Match -> string
override FormatMatch :
        m : Match -> string

Parameters

m
Type: System.Text.RegularExpressionsMatch
匹配

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlVirtual.FormatMatch(System.Text.RegularExpressions.Match)"]

See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.FormatUrl Method

UrlVirtualFormatUrl Method
根据现有数据格式化一个URL地址

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string FormatUrl(
    string name,
    string value
)
Public Overridable Function FormatUrl (
    name As String,
    value As String
) As String
public:
virtual String^ FormatUrl(
    String^ name,
    String^ value
)
abstract FormatUrl :
        name : string *
        value : string -> string
override FormatUrl :
        name : string *
        value : string -> string

Parameters

name
Type: SystemString
格式化查询名
value
Type: SystemString
格式化查询值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlVirtual.FormatUrl(System.String,System.String)"]

See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.GetEncode Method

UrlVirtualGetEncode Method
获取值编码

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual string GetEncode(
    string value
)
Protected Overridable Function GetEncode (
    value As String
) As String
protected:
virtual String^ GetEncode(
    String^ value
)
abstract GetEncode :
        value : string -> string
override GetEncode :
        value : string -> string

Parameters

value
Type: SystemString
值

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlVirtual.GetEncode(System.String)"]

See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.MatchingQuery Method

UrlVirtualMatchingQuery Method
根据URL规范自动匹配现有网页查询

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual void MatchingQuery()
Public Overridable Sub MatchingQuery
public:
virtual void MatchingQuery()
abstract MatchingQuery : unit -> unit
override MatchingQuery : unit -> unit
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.ToString Method

UrlVirtualToString Method
获取生成的URL地址

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
abstract ToString : unit -> string
override ToString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.UrlVirtual.ToString"]

See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual Properties

UrlVirtual Properties

The UrlVirtual type exposes the following members.

Properties
 | Name | Description
Public property | Context | 获取当前操作的HttpContext对象
Protected property | IsMatchingQuery | 获取或设置是否已调用了MatchingQuery
Public property | Item | 获取或设置URL参数值
 | UrlCriterion | 获取或设置URL规范,其中的中{}扩起来的字符代表参数名
Top
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.Context Property

UrlVirtualContext Property
获取当前操作的HttpContext对象

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual HttpContext Context { get; }
Public Overridable ReadOnly Property Context As HttpContext
    Get
public:
virtual property HttpContext^ Context {
    HttpContext^ get ();
}
abstract Context : HttpContext with get
override Context : HttpContext with get

Property Value

Type: HttpContext
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.IsMatchingQuery Property

UrlVirtualIsMatchingQuery Property
获取或设置是否已调用了MatchingQuery

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual bool IsMatchingQuery { get; set; }
Protected Overridable Property IsMatchingQuery As Boolean
    Get
    Set
protected:
virtual property bool IsMatchingQuery {
    bool get ();
    void set (bool value);
}
abstract IsMatchingQuery : bool with get, set
override IsMatchingQuery : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.Item Property

UrlVirtualItem Property
获取或设置URL参数值

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string this[
    string name
] { get; set; }
Public Overridable Default Property Item (
    name As String
) As String
    Get
    Set
public:
virtual property String^ default[String^ name] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}
abstract Item : string with get, set
override Item : string with get, set

Parameters

name
Type: SystemString
参数名称

Property Value

Type: String
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


UrlVirtual.UrlCriterion Property

UrlVirtualUrlCriterion Property
获取或设置URL规范,其中的中{}扩起来的字符代表参数名

Namespace: Adf.Web
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string UrlCriterion { get; set; }
Public Overridable Property UrlCriterion As String
    Get
    Set
public:
virtual property String^ UrlCriterion {
    String^ get ();
    void set (String^ value);
}
abstract UrlCriterion : string with get, set
override UrlCriterion : string with get, set

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | 属性值为空时引生
Examples
Copy
new UrlVirtual("list-{p1}-{p2}-{p3}.html");
See Also

Reference

UrlVirtual Class
Adf.Web Namespace


Adf.Web.Controls Namespace

Adf.Web.Controls Namespace

[Missing <summary> documentation for "N:Adf.Web.Controls"]

Classes
 | Class | Description
Public class | Javascript | JavaScript Web 控件


Javascript Class

Javascript Class
JavaScript Web 控件
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Adf.Web.ControlsJavascript

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class Javascript : WebControl
Public Class Javascript
    Inherits WebControl
public ref class Javascript : public WebControl
type Javascript =
    class
        inherit WebControl
    end

The Javascript type exposes the following members.

Constructors
 | Name | Description
Public method | Javascript | 初始化
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | 重写属性写入 (Overrides WebControlAddAttributesToRender(HtmlTextWriter).)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | Append | 增加控件新内容
Public method | AppendAlert(String) | 向控件增加提示消息 alert();
Public method | AppendAlert(String) | 向控件增加一组提示消息,消息每组一行
Public method | AppendBack | 向控件增加一个历史返回页 history.back()
Public method | AppendConfirm(String) | 向控件增加一个询问窗,当客户端用户确定时执行,否则取消执行
Public method | AppendConfirm(String, String, String) | 向控件增加一个询问窗
Public method | AppendEndFunction | 向内容增加一个函数结束
Public method | AppendFunction | 向内容增加一个函数开始
Public method | AppendGoUrl | 向控件增加一个转向地址,location.href
Public method | AppendLine | 增加控件新内容并自动增加换行符
Public method | AppendNext | 向控件增加一个历史前进页 history.go()
Public method | AppendWindowClose | 向控件增加一个窗体关闭信息 window.close();
Public method | AppendWrite | 向控件增加一个输出document.write();
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Public method | Clear | 清除所增加的所有数据
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetString | 获取控件输出数据
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发 Init 事件。 (Inherited from Control.)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 将控件的 HTML 开始标记呈现到指定的编写器中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 重载 (Overrides WebControlRenderContents(HtmlTextWriter).)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 将控件的 HTML 结束标记呈现到指定的编写器中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | Body | 获取Script的内容
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | CharSet | 获取或设置连接字符集
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | Function | 获取或设置函数名称,注:此属性设置后将使所有脚本均包含在这个函数中,如须在内容中增加函数,请使用AppendFunction与AppendEndFunction
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Src | 获取或设置连接串
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | Type | 获取或设置类别
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Top
Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

Adf.Web.Controls Namespace


Javascript Constructor

Javascript Constructor
初始化

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public Javascript()
Public Sub New
public:
Javascript()
new : unit -> Javascript
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript Methods

Javascript Methods

The Javascript type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | 重写属性写入 (Overrides WebControlAddAttributesToRender(HtmlTextWriter).)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | Append | 增加控件新内容
Public method | AppendAlert(String) | 向控件增加提示消息 alert();
Public method | AppendAlert(String) | 向控件增加一组提示消息,消息每组一行
Public method | AppendBack | 向控件增加一个历史返回页 history.back()
Public method | AppendConfirm(String) | 向控件增加一个询问窗,当客户端用户确定时执行,否则取消执行
Public method | AppendConfirm(String, String, String) | 向控件增加一个询问窗
Public method | AppendEndFunction | 向内容增加一个函数结束
Public method | AppendFunction | 向内容增加一个函数开始
Public method | AppendGoUrl | 向控件增加一个转向地址,location.href
Public method | AppendLine | 增加控件新内容并自动增加换行符
Public method | AppendNext | 向控件增加一个历史前进页 history.go()
Public method | AppendWindowClose | 向控件增加一个窗体关闭信息 window.close();
Public method | AppendWrite | 向控件增加一个输出document.write();
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Public method | Clear | 清除所增加的所有数据
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetString | 获取控件输出数据
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发 Init 事件。 (Inherited from Control.)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 将控件的 HTML 开始标记呈现到指定的编写器中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 重载 (Overrides WebControlRenderContents(HtmlTextWriter).)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 将控件的 HTML 结束标记呈现到指定的编写器中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AddAttributesToRender Method

JavascriptAddAttributesToRender Method
重写属性写入

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected override void AddAttributesToRender(
    HtmlTextWriter writer
)
Protected Overrides Sub AddAttributesToRender (
    writer As HtmlTextWriter
)
protected:
virtual void AddAttributesToRender(
    HtmlTextWriter^ writer
) override
abstract AddAttributesToRender :
        writer : HtmlTextWriter -> unit
override AddAttributesToRender :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
值
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.Append Method

JavascriptAppend Method
增加控件新内容

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Append(
    string script
)
Public Sub Append (
    script As String
)
public:
void Append(
    String^ script
)
member Append :
        script : string -> unit

Parameters

script
Type: SystemString
添加脚本内容
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendAlert Method

JavascriptAppendAlert Method
Overload List
 | Name | Description
Public method | AppendAlert(String) | 向控件增加提示消息 alert();
Public method | AppendAlert(String) | 向控件增加一组提示消息,消息每组一行
Top
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendAlert Method (String)

JavascriptAppendAlert Method (String)
向控件增加提示消息 alert();

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendAlert(
    string msg
)
Public Sub AppendAlert (
    msg As String
)
public:
void AppendAlert(
    String^ msg
)
member AppendAlert :
        msg : string -> unit

Parameters

msg
Type: SystemString
要写入的消息
See Also

Reference

Javascript Class
AppendAlert Overload
Adf.Web.Controls Namespace


Javascript.AppendAlert Method (String[])

JavascriptAppendAlert Method (String)
向控件增加一组提示消息,消息每组一行

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendAlert(
    string[] msg
)
Public Sub AppendAlert (
    msg As String()
)
public:
void AppendAlert(
    array<String^>^ msg
)
member AppendAlert :
        msg : string[] -> unit

Parameters

msg
Type: SystemString
消息组
See Also

Reference

Javascript Class
AppendAlert Overload
Adf.Web.Controls Namespace


Javascript.AppendBack Method

JavascriptAppendBack Method
向控件增加一个历史返回页 history.back()

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendBack(
    uint num
)
Public Sub AppendBack (
    num As UInteger
)
public:
void AppendBack(
    unsigned int num
)
member AppendBack :
        num : uint32 -> unit

Parameters

num
Type: SystemUInt32
返回的页数
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendConfirm Method

JavascriptAppendConfirm Method
Overload List
 | Name | Description
Public method | AppendConfirm(String) | 向控件增加一个询问窗,当客户端用户确定时执行,否则取消执行
Public method | AppendConfirm(String, String, String) | 向控件增加一个询问窗
Top
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendConfirm Method (String)

JavascriptAppendConfirm Method (String)
向控件增加一个询问窗,当客户端用户确定时执行,否则取消执行

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendConfirm(
    string msg
)
Public Sub AppendConfirm (
    msg As String
)
public:
void AppendConfirm(
    String^ msg
)
member AppendConfirm :
        msg : string -> unit

Parameters

msg
Type: SystemString
询问内容
See Also

Reference

Javascript Class
AppendConfirm Overload
Adf.Web.Controls Namespace


Javascript.AppendConfirm Method (String, String, String)

JavascriptAppendConfirm Method (String, String, String)
向控件增加一个询问窗

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendConfirm(
    string msg,
    string True,
    string False
)
Public Sub AppendConfirm (
    msg As String,
    True As String,
    False As String
)
public:
void AppendConfirm(
    String^ msg,
    String^ True,
    String^ False
)
member AppendConfirm :
        msg : string *
        True : string *
        False : string -> unit

Parameters

msg
Type: SystemString
询问内容
True
Type: SystemString
当点击确定时执行的操作,当为null时,执行return true;
False
Type: SystemString
当点击取消时执行的操作,当为null时,执行return false;
See Also

Reference

Javascript Class
AppendConfirm Overload
Adf.Web.Controls Namespace


Javascript.AppendEndFunction Method

JavascriptAppendEndFunction Method
向内容增加一个函数结束

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendEndFunction()
Public Sub AppendEndFunction
public:
void AppendEndFunction()
member AppendEndFunction : unit -> unit
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendFunction Method

JavascriptAppendFunction Method
向内容增加一个函数开始

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendFunction(
    string FunName
)
Public Sub AppendFunction (
    FunName As String
)
public:
void AppendFunction(
    String^ FunName
)
member AppendFunction :
        FunName : string -> unit

Parameters

FunName
Type: SystemString
函数名称
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendGoUrl Method

JavascriptAppendGoUrl Method
向控件增加一个转向地址,location.href

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendGoUrl(
    string url
)
Public Sub AppendGoUrl (
    url As String
)
public:
void AppendGoUrl(
    String^ url
)
member AppendGoUrl :
        url : string -> unit

Parameters

url
Type: SystemString
要转向的URL
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendLine Method

JavascriptAppendLine Method
增加控件新内容并自动增加换行符

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendLine(
    string script
)
Public Sub AppendLine (
    script As String
)
public:
void AppendLine(
    String^ script
)
member AppendLine :
        script : string -> unit

Parameters

script
Type: SystemString
添加脚本内容
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendNext Method

JavascriptAppendNext Method
向控件增加一个历史前进页 history.go()

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendNext(
    uint num
)
Public Sub AppendNext (
    num As UInteger
)
public:
void AppendNext(
    unsigned int num
)
member AppendNext :
        num : uint32 -> unit

Parameters

num
Type: SystemUInt32
前进的页数
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendWindowClose Method

JavascriptAppendWindowClose Method
向控件增加一个窗体关闭信息 window.close();

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendWindowClose()
Public Sub AppendWindowClose
public:
void AppendWindowClose()
member AppendWindowClose : unit -> unit
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.AppendWrite Method

JavascriptAppendWrite Method
向控件增加一个输出document.write();

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void AppendWrite(
    string input
)
Public Sub AppendWrite (
    input As String
)
public:
void AppendWrite(
    String^ input
)
member AppendWrite :
        input : string -> unit

Parameters

input
Type: SystemString
要输出的数据
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.Clear Method

JavascriptClear Method
清除所增加的所有数据

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void Clear()
Public Sub Clear
public:
void Clear()
member Clear : unit -> unit
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.GetString Method

JavascriptGetString Method
获取控件输出数据

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string GetString()
Public Function GetString As String
public:
String^ GetString()
member GetString : unit -> string

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Controls.Javascript.GetString"]

See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.RenderContents Method

JavascriptRenderContents Method
重载

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected override void RenderContents(
    HtmlTextWriter writer
)
Protected Overrides Sub RenderContents (
    writer As HtmlTextWriter
)
protected:
virtual void RenderContents(
    HtmlTextWriter^ writer
) override
abstract RenderContents :
        writer : HtmlTextWriter -> unit
override RenderContents :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
对象
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript Properties

Javascript Properties

The Javascript type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | Body | 获取Script的内容
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | CharSet | 获取或设置连接字符集
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | Function | 获取或设置函数名称,注:此属性设置后将使所有脚本均包含在这个函数中,如须在内容中增加函数,请使用AppendFunction与AppendEndFunction
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Src | 获取或设置连接串
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | Type | 获取或设置类别
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Top
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.Body Property

JavascriptBody Property
获取Script的内容

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string Body { get; }
Public ReadOnly Property Body As String
    Get
public:
property String^ Body {
    String^ get ();
}
member Body : string with get

Property Value

Type: String
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.CharSet Property

JavascriptCharSet Property
获取或设置连接字符集

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string CharSet { get; set; }
Public Property CharSet As String
    Get
    Set
public:
property String^ CharSet {
    String^ get ();
    void set (String^ value);
}
member CharSet : string with get, set

Property Value

Type: String
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.Function Property

JavascriptFunction Property
获取或设置函数名称,注:此属性设置后将使所有脚本均包含在这个函数中,如须在内容中增加函数,请使用AppendFunction与AppendEndFunction

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string Function { get; set; }
Public Property Function As String
    Get
    Set
public:
property String^ Function {
    String^ get ();
    void set (String^ value);
}
member Function : string with get, set

Property Value

Type: String
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.Src Property

JavascriptSrc Property
获取或设置连接串

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string Src { get; set; }
Public Property Src As String
    Get
    Set
public:
property String^ Src {
    String^ get ();
    void set (String^ value);
}
member Src : string with get, set

Property Value

Type: String
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript.Type Property

JavascriptType Property
获取或设置类别

Namespace: Adf.Web.Controls
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Javascript Events

Javascript Events

The Javascript type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

Javascript Class
Adf.Web.Controls Namespace


Adf.Web.Pagination Namespace

Adf.Web.Pagination Namespace

[Missing <summary> documentation for "N:Adf.Web.Pagination"]

Classes
 | Class | Description
Public class | DefaultTemplate | 默认的输出样式
Public class | GetPagination | URL传参分页控件
Public class | PaginationBase | 分页控件基础类
Public class | PostEventArgs | 分页控件更改页序时的事件数据
Public class | PostPagination | Post回发式分页控件
Public class | VirtualPagination | 虚拟URL，Get分页控件
Interfaces
 | Interface | Description
Public interface | ITemplate | 分页样式接口
Delegates
 | Delegate | Description
Public delegate | PostPaginationPageChangedEventHandler | 事件处理委托


DefaultTemplate Class

DefaultTemplate Class
默认的输出样式
Inheritance Hierarchy
SystemObject
Adf.Web.PaginationDefaultTemplate

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class DefaultTemplate : ITemplate
Public Class DefaultTemplate
    Implements ITemplate
public ref class DefaultTemplate : ITemplate
type DefaultTemplate =
    class
        interface ITemplate
    end

The DefaultTemplate type exposes the following members.

Constructors
 | Name | Description
Public method | DefaultTemplate | 初始化类型
Top
Methods
 | Name | Description
Public method | CreateButton(Int32, String) | 创建按钮
Public method | CreateButton(String, String) | 创建按钮
Public method | CreateButton(Int32, String, Boolean) | 创建按钮
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Protected method | GetClientClick | 获取客户端单击事件
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Jump1 | Jump样式1
Protected method | Jump2 | Jump样式2
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | ReaderJump | 输出Jump样式
Protected method | ReaderJumpScript | 输出Jump的脚本块
Public method | Render | 输出数据
Public method | RenderStyle | 默认的样式输出
Protected method | Template0 | 样式0
Protected method | Template1 | 样式1
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | JumpOptionCount | 下拉式Jump选项显示数，默认为50
Public property | JumpText | 获取Jump按钮显示文字
Public property | Pagination | 获取当前分页组件
Top
See Also

Reference

Adf.Web.Pagination Namespace


DefaultTemplate Constructor

DefaultTemplate Constructor
初始化类型

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public DefaultTemplate(
    PaginationBase pagation
)
Public Sub New (
    pagation As PaginationBase
)
public:
DefaultTemplate(
    PaginationBase^ pagation
)
new :
        pagation : PaginationBase -> DefaultTemplate

Parameters

pagation
Type: Adf.Web.PaginationPaginationBase
分页控件
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate Methods

DefaultTemplate Methods

The DefaultTemplate type exposes the following members.

Methods
 | Name | Description
Public method | CreateButton(Int32, String) | 创建按钮
Public method | CreateButton(String, String) | 创建按钮
Public method | CreateButton(Int32, String, Boolean) | 创建按钮
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Protected method | GetClientClick | 获取客户端单击事件
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | Jump1 | Jump样式1
Protected method | Jump2 | Jump样式2
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Protected method | ReaderJump | 输出Jump样式
Protected method | ReaderJumpScript | 输出Jump的脚本块
Public method | Render | 输出数据
Public method | RenderStyle | 默认的样式输出
Protected method | Template0 | 样式0
Protected method | Template1 | 样式1
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.CreateButton Method

DefaultTemplateCreateButton Method
Overload List
 | Name | Description
Public method | CreateButton(Int32, String) | 创建按钮
Public method | CreateButton(String, String) | 创建按钮
Public method | CreateButton(Int32, String, Boolean) | 创建按钮
Top
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.CreateButton Method (Int32, String)

DefaultTemplateCreateButton Method (Int32, String)
创建按钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string CreateButton(
    int index,
    string text
)
Public Function CreateButton (
    index As Integer,
    text As String
) As String
public:
String^ CreateButton(
    int index,
    String^ text
)
member CreateButton :
        index : int *
        text : string -> string

Parameters

index
Type: SystemInt32
索引
text
Type: SystemString
显示文字

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.DefaultTemplate.CreateButton(System.Int32,System.String)"]

See Also

Reference

DefaultTemplate Class
CreateButton Overload
Adf.Web.Pagination Namespace


DefaultTemplate.CreateButton Method (String, String)

DefaultTemplateCreateButton Method (String, String)
创建按钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string CreateButton(
    string href,
    string text
)
Public Overridable Function CreateButton (
    href As String,
    text As String
) As String
public:
virtual String^ CreateButton(
    String^ href,
    String^ text
)
abstract CreateButton :
        href : string *
        text : string -> string
override CreateButton :
        href : string *
        text : string -> string

Parameters

href
Type: SystemString
链接地址
text
Type: SystemString
显示文字

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.DefaultTemplate.CreateButton(System.String,System.String)"]

Implements

ITemplateCreateButton(String, String)
See Also

Reference

DefaultTemplate Class
CreateButton Overload
Adf.Web.Pagination Namespace


DefaultTemplate.CreateButton Method (Int32, String, Boolean)

DefaultTemplateCreateButton Method (Int32, String, Boolean)
创建按钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string CreateButton(
    int index,
    string text,
    bool nocurr
)
Public Overridable Function CreateButton (
    index As Integer,
    text As String,
    nocurr As Boolean
) As String
public:
virtual String^ CreateButton(
    int index,
    String^ text,
    bool nocurr
)
abstract CreateButton :
        index : int *
        text : string *
        nocurr : bool -> string
override CreateButton :
        index : int *
        text : string *
        nocurr : bool -> string

Parameters

index
Type: SystemInt32
索引
text
Type: SystemString
显示文字
nocurr
Type: SystemBoolean
是否禁止设置为当前状态

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.DefaultTemplate.CreateButton(System.Int32,System.String,System.Boolean)"]

See Also

Reference

DefaultTemplate Class
CreateButton Overload
Adf.Web.Pagination Namespace


DefaultTemplate.GetClientClick Method

DefaultTemplateGetClientClick Method
获取客户端单击事件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected string GetClientClick(
    int index
)
Protected Function GetClientClick (
    index As Integer
) As String
protected:
String^ GetClientClick(
    int index
)
member GetClientClick :
        index : int -> string

Parameters

index
Type: SystemInt32
索引

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.DefaultTemplate.GetClientClick(System.Int32)"]

See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.Jump1 Method

DefaultTemplateJump1 Method
Jump样式1

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void Jump1(
    HtmlTextWriter writer
)
Protected Overridable Sub Jump1 (
    writer As HtmlTextWriter
)
protected:
virtual void Jump1(
    HtmlTextWriter^ writer
)
abstract Jump1 :
        writer : HtmlTextWriter -> unit
override Jump1 :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.Jump2 Method

DefaultTemplateJump2 Method
Jump样式2

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void Jump2(
    HtmlTextWriter writer
)
Protected Overridable Sub Jump2 (
    writer As HtmlTextWriter
)
protected:
virtual void Jump2(
    HtmlTextWriter^ writer
)
abstract Jump2 :
        writer : HtmlTextWriter -> unit
override Jump2 :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.ReaderJump Method

DefaultTemplateReaderJump Method
输出Jump样式

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void ReaderJump(
    HtmlTextWriter writer
)
Protected Overridable Sub ReaderJump (
    writer As HtmlTextWriter
)
protected:
virtual void ReaderJump(
    HtmlTextWriter^ writer
)
abstract ReaderJump :
        writer : HtmlTextWriter -> unit
override ReaderJump :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.ReaderJumpScript Method

DefaultTemplateReaderJumpScript Method
输出Jump的脚本块

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void ReaderJumpScript(
    HtmlTextWriter writer
)
Protected Overridable Sub ReaderJumpScript (
    writer As HtmlTextWriter
)
protected:
virtual void ReaderJumpScript(
    HtmlTextWriter^ writer
)
abstract ReaderJumpScript :
        writer : HtmlTextWriter -> unit
override ReaderJumpScript :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.Render Method

DefaultTemplateRender Method
输出数据

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual void Render(
    HtmlTextWriter writer
)
Public Overridable Sub Render (
    writer As HtmlTextWriter
)
public:
virtual void Render(
    HtmlTextWriter^ writer
)
abstract Render :
        writer : HtmlTextWriter -> unit
override Render :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象

Implements

ITemplateRender(HtmlTextWriter)
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.RenderStyle Method

DefaultTemplateRenderStyle Method
默认的样式输出

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual void RenderStyle(
    HtmlTextWriter writer
)
Public Overridable Sub RenderStyle (
    writer As HtmlTextWriter
)
public:
virtual void RenderStyle(
    HtmlTextWriter^ writer
)
abstract RenderStyle :
        writer : HtmlTextWriter -> unit
override RenderStyle :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象

Implements

ITemplateRenderStyle(HtmlTextWriter)
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.Template0 Method

DefaultTemplateTemplate0 Method
样式0

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void Template0(
    HtmlTextWriter writer
)
Protected Overridable Sub Template0 (
    writer As HtmlTextWriter
)
protected:
virtual void Template0(
    HtmlTextWriter^ writer
)
abstract Template0 :
        writer : HtmlTextWriter -> unit
override Template0 :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.Template1 Method

DefaultTemplateTemplate1 Method
样式1

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void Template1(
    HtmlTextWriter writer
)
Protected Overridable Sub Template1 (
    writer As HtmlTextWriter
)
protected:
virtual void Template1(
    HtmlTextWriter^ writer
)
abstract Template1 :
        writer : HtmlTextWriter -> unit
override Template1 :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate Properties

DefaultTemplate Properties

The DefaultTemplate type exposes the following members.

Properties
 | Name | Description
Public property | JumpOptionCount | 下拉式Jump选项显示数，默认为50
Public property | JumpText | 获取Jump按钮显示文字
Public property | Pagination | 获取当前分页组件
Top
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.JumpOptionCount Property

DefaultTemplateJumpOptionCount Property
下拉式Jump选项显示数，默认为50

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int JumpOptionCount { get; }
Public Overridable ReadOnly Property JumpOptionCount As Integer
    Get
public:
virtual property int JumpOptionCount {
    int get ();
}
abstract JumpOptionCount : int with get
override JumpOptionCount : int with get

Property Value

Type: Int32
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.JumpText Property

DefaultTemplateJumpText Property
获取Jump按钮显示文字

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string JumpText { get; }
Public Overridable ReadOnly Property JumpText As String
    Get
public:
virtual property String^ JumpText {
    String^ get ();
}
abstract JumpText : string with get
override JumpText : string with get

Property Value

Type: String
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


DefaultTemplate.Pagination Property

DefaultTemplatePagination Property
获取当前分页组件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual PaginationBase Pagination { get; }
Public Overridable ReadOnly Property Pagination As PaginationBase
    Get
public:
virtual property PaginationBase^ Pagination {
    PaginationBase^ get ();
}
abstract Pagination : PaginationBase with get
override Pagination : PaginationBase with get

Property Value

Type: PaginationBase

Implements

ITemplatePagination
See Also

Reference

DefaultTemplate Class
Adf.Web.Pagination Namespace


GetPagination Class

GetPagination Class
URL传参分页控件
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Adf.Web.PaginationPaginationBase
Adf.Web.PaginationGetPagination
Adf.Web.PaginationVirtualPagination

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class GetPagination : PaginationBase
Public Class GetPagination
    Inherits PaginationBase
public ref class GetPagination : public PaginationBase
type GetPagination =
    class
        inherit PaginationBase
    end

The GetPagination type exposes the following members.

Constructors
 | Name | Description
Public method | GetPagination | Initializes a new instance of the GetPagination class
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | AddQuery | 添加一个新的查询串
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算 (Inherited from PaginationBase.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建一个新的查询链接 (Overrides PaginationBaseCreateLink(Int32).)
Protected method | CreateQueryString | 创建新的查询串
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Protected method | GetQueryData | 获取当前URL所传递的参数值
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量 (Inherited from PaginationBase.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发Load事件 (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Inherited from PaginationBase.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Inherited from PaginationBase.)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Inherited from PaginationBase.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量 (Inherited from PaginationBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Protected property | AppendQuery | 获取所添加的新查询串值
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个 (Inherited from PaginationBase.)
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数 (Inherited from PaginationBase.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | ExcludeName | 获取或设置不进行Url传递的查询参数，多个参数以逗号分隔
Public property | FileName | 获取当前请求的文件名称
Public property | FistText | 首页按钮 (Inherited from PaginationBase.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序 (Inherited from PaginationBase.)
Public property | IndexName | 获取或设置查询串中页索引查询名，当多个控件时请将此设置为控件间不相同
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算 (Inherited from PaginationBase.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 是否为回发组件 (Inherited from PaginationBase.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示 (Inherited from PaginationBase.)
Public property | LastIndex | 获取最后一页页序 (Inherited from PaginationBase.)
Public property | LastText | 尾页按钮 (Inherited from PaginationBase.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序 (Inherited from PaginationBase.)
Public property | NextText | 下一页铵钮 (Inherited from PaginationBase.)
Public property | OnClientClick | 获取或设置客户端单击事件方法 (Inherited from PaginationBase.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序 (Inherited from PaginationBase.)
Public property | PreText | 上一页按钮 (Inherited from PaginationBase.)
Protected property | QueryString | 获取或设置新的查询串
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值 (Inherited from PaginationBase.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10 (Inherited from PaginationBase.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类 (Inherited from PaginationBase.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0 (Inherited from PaginationBase.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | TotalName | 获取或设置查询串中数据总量查询名，当多个控件时请将此为控件间不相同
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表 (Inherited from PaginationBase.)
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Top
Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

Adf.Web.Pagination Namespace


GetPagination Constructor

GetPagination Constructor
Initializes a new instance of the GetPagination class

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public GetPagination()
Public Sub New
public:
GetPagination()
new : unit -> GetPagination
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination Methods

GetPagination Methods

The GetPagination type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | AddQuery | 添加一个新的查询串
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算 (Inherited from PaginationBase.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建一个新的查询链接 (Overrides PaginationBaseCreateLink(Int32).)
Protected method | CreateQueryString | 创建新的查询串
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Protected method | GetQueryData | 获取当前URL所传递的参数值
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量 (Inherited from PaginationBase.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发Load事件 (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Inherited from PaginationBase.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Inherited from PaginationBase.)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Inherited from PaginationBase.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量 (Inherited from PaginationBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.AddQuery Method

GetPaginationAddQuery Method
添加一个新的查询串

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual void AddQuery(
    string name,
    Object value
)
Public Overridable Sub AddQuery (
    name As String,
    value As Object
)
public:
virtual void AddQuery(
    String^ name,
    Object^ value
)
abstract AddQuery :
        name : string *
        value : Object -> unit
override AddQuery :
        name : string *
        value : Object -> unit

Parameters

name
Type: SystemString
查询串名称
value
Type: SystemObject
值
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.CreateLink Method

GetPaginationCreateLink Method
创建一个新的查询链接

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override string CreateLink(
    int index
)
Public Overrides Function CreateLink (
    index As Integer
) As String
public:
virtual String^ CreateLink(
    int index
) override
abstract CreateLink :
        index : int -> string
override CreateLink :
        index : int -> string

Parameters

index
Type: SystemInt32
索引

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.GetPagination.CreateLink(System.Int32)"]

See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.CreateQueryString Method

GetPaginationCreateQueryString Method
创建新的查询串

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void CreateQueryString()
Protected Overridable Sub CreateQueryString
protected:
virtual void CreateQueryString()
abstract CreateQueryString : unit -> unit
override CreateQueryString : unit -> unit
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.GetQueryData Method

GetPaginationGetQueryData Method
获取当前URL所传递的参数值

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void GetQueryData()
Protected Overridable Sub GetQueryData
protected:
virtual void GetQueryData()
abstract GetQueryData : unit -> unit
override GetQueryData : unit -> unit

Return Value

Type:
返回记录数
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.OnInit Method

GetPaginationOnInit Method
引发Load事件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
protected:
virtual void OnInit(
    EventArgs^ e
) override
abstract OnInit :
        e : EventArgs -> unit
override OnInit :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
事件数据
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination Properties

GetPagination Properties

The GetPagination type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Protected property | AppendQuery | 获取所添加的新查询串值
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个 (Inherited from PaginationBase.)
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数 (Inherited from PaginationBase.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | ExcludeName | 获取或设置不进行Url传递的查询参数，多个参数以逗号分隔
Public property | FileName | 获取当前请求的文件名称
Public property | FistText | 首页按钮 (Inherited from PaginationBase.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序 (Inherited from PaginationBase.)
Public property | IndexName | 获取或设置查询串中页索引查询名，当多个控件时请将此设置为控件间不相同
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算 (Inherited from PaginationBase.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 是否为回发组件 (Inherited from PaginationBase.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示 (Inherited from PaginationBase.)
Public property | LastIndex | 获取最后一页页序 (Inherited from PaginationBase.)
Public property | LastText | 尾页按钮 (Inherited from PaginationBase.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序 (Inherited from PaginationBase.)
Public property | NextText | 下一页铵钮 (Inherited from PaginationBase.)
Public property | OnClientClick | 获取或设置客户端单击事件方法 (Inherited from PaginationBase.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序 (Inherited from PaginationBase.)
Public property | PreText | 上一页按钮 (Inherited from PaginationBase.)
Protected property | QueryString | 获取或设置新的查询串
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值 (Inherited from PaginationBase.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10 (Inherited from PaginationBase.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类 (Inherited from PaginationBase.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0 (Inherited from PaginationBase.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | TotalName | 获取或设置查询串中数据总量查询名，当多个控件时请将此为控件间不相同
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表 (Inherited from PaginationBase.)
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Top
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.AppendQuery Property

GetPaginationAppendQuery Property
获取所添加的新查询串值

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual NameValueCollection AppendQuery { get; set; }
Protected Overridable Property AppendQuery As NameValueCollection
    Get
    Set
protected:
virtual property NameValueCollection^ AppendQuery {
    NameValueCollection^ get ();
    void set (NameValueCollection^ value);
}
abstract AppendQuery : NameValueCollection with get, set
override AppendQuery : NameValueCollection with get, set

Property Value

Type: NameValueCollection
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.ExcludeName Property

GetPaginationExcludeName Property
获取或设置不进行Url传递的查询参数，多个参数以逗号分隔

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string ExcludeName { get; set; }
Public Property ExcludeName As String
    Get
    Set
public:
property String^ ExcludeName {
    String^ get ();
    void set (String^ value);
}
member ExcludeName : string with get, set

Property Value

Type: String
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.FileName Property

GetPaginationFileName Property
获取当前请求的文件名称

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
public:
property String^ FileName {
    String^ get ();
}
member FileName : string with get

Property Value

Type: String
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.IndexName Property

GetPaginationIndexName Property
获取或设置查询串中页索引查询名，当多个控件时请将此设置为控件间不相同

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string IndexName { get; set; }
Public Property IndexName As String
    Get
    Set
public:
property String^ IndexName {
    String^ get ();
    void set (String^ value);
}
member IndexName : string with get, set

Property Value

Type: String
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.QueryString Property

GetPaginationQueryString Property
获取或设置新的查询串

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual string QueryString { get; set; }
Protected Overridable Property QueryString As String
    Get
    Set
protected:
virtual property String^ QueryString {
    String^ get ();
    void set (String^ value);
}
abstract QueryString : string with get, set
override QueryString : string with get, set

Property Value

Type: String
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination.TotalName Property

GetPaginationTotalName Property
获取或设置查询串中数据总量查询名，当多个控件时请将此为控件间不相同

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public string TotalName { get; set; }
Public Property TotalName As String
    Get
    Set
public:
property String^ TotalName {
    String^ get ();
    void set (String^ value);
}
member TotalName : string with get, set

Property Value

Type: String
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


GetPagination Events

GetPagination Events

The GetPagination type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

GetPagination Class
Adf.Web.Pagination Namespace


ITemplate Interface

ITemplate Interface
分页样式接口

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public interface ITemplate
Public Interface ITemplate
public interface class ITemplate
type ITemplate =  interface end

The ITemplate type exposes the following members.

Methods
 | Name | Description
Public method | CreateButton | 创建按钮
Public method | Render | 输出数据
Public method | RenderStyle | 当CssClass为空时输出的默认样式
Top
Properties
 | Name | Description
Public property | Pagination | 获取当前分页组件
Top
See Also

Reference

Adf.Web.Pagination Namespace


ITemplate Methods

ITemplate Methods

The ITemplate type exposes the following members.

Methods
 | Name | Description
Public method | CreateButton | 创建按钮
Public method | Render | 输出数据
Public method | RenderStyle | 当CssClass为空时输出的默认样式
Top
See Also

Reference

ITemplate Interface
Adf.Web.Pagination Namespace


ITemplate.CreateButton Method

ITemplateCreateButton Method
创建按钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
string CreateButton(
    string href,
    string text
)
Function CreateButton (
    href As String,
    text As String
) As String
String^ CreateButton(
    String^ href,
    String^ text
)
abstract CreateButton :
        href : string *
        text : string -> string

Parameters

href
Type: SystemString
链接地址
text
Type: SystemString
显示文字

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.ITemplate.CreateButton(System.String,System.String)"]

See Also

Reference

ITemplate Interface
Adf.Web.Pagination Namespace


ITemplate.Render Method

ITemplateRender Method
输出数据

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
void Render(
    HtmlTextWriter writer
)
Sub Render (
    writer As HtmlTextWriter
)
void Render(
    HtmlTextWriter^ writer
)
abstract Render :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

ITemplate Interface
Adf.Web.Pagination Namespace


ITemplate.RenderStyle Method

ITemplateRenderStyle Method
当CssClass为空时输出的默认样式

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
void RenderStyle(
    HtmlTextWriter writer
)
Sub RenderStyle (
    writer As HtmlTextWriter
)
void RenderStyle(
    HtmlTextWriter^ writer
)
abstract RenderStyle :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

ITemplate Interface
Adf.Web.Pagination Namespace


ITemplate Properties

ITemplate Properties

The ITemplate type exposes the following members.

Properties
 | Name | Description
Public property | Pagination | 获取当前分页组件
Top
See Also

Reference

ITemplate Interface
Adf.Web.Pagination Namespace


ITemplate.Pagination Property

ITemplatePagination Property
获取当前分页组件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
PaginationBase Pagination { get; }
ReadOnly Property Pagination As PaginationBase
    Get
property PaginationBase^ Pagination {
    PaginationBase^ get ();
}
abstract Pagination : PaginationBase with get

Property Value

Type: PaginationBase
See Also

Reference

ITemplate Interface
Adf.Web.Pagination Namespace


PaginationBase Class

PaginationBase Class
分页控件基础类
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Adf.Web.PaginationPaginationBase
Adf.Web.PaginationGetPagination
Adf.Web.PaginationPostPagination

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public abstract class PaginationBase : WebControl
Public MustInherit Class PaginationBase
    Inherits WebControl
public ref class PaginationBase abstract : public WebControl
[<AbstractClassAttribute>]
type PaginationBase =
    class
        inherit WebControl
    end

The PaginationBase type exposes the following members.

Constructors
 | Name | Description
Public method | PaginationBase | 初始化控件
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建URL链接
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发 Init 事件。 (Inherited from Control.)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Overrides WebControlRenderBeginTag(HtmlTextWriter).)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Overrides WebControlRenderContents(HtmlTextWriter).)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Overrides WebControlRenderEndTag(HtmlTextWriter).)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | FistText | 首页按钮
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 是否为回发组件
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示
Public property | LastIndex | 获取最后一页页序
Public property | LastText | 尾页按钮
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序
Public property | NextText | 下一页铵钮
Public property | OnClientClick | 获取或设置客户端单击事件方法
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序
Public property | PreText | 上一页按钮
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示
Top
Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

Adf.Web.Pagination Namespace


PaginationBase Constructor

PaginationBase Constructor
初始化控件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public PaginationBase()
Public Sub New
public:
PaginationBase()
new : unit -> PaginationBase
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase Methods

PaginationBase Methods

The PaginationBase type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建URL链接
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发 Init 事件。 (Inherited from Control.)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Overrides WebControlRenderBeginTag(HtmlTextWriter).)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Overrides WebControlRenderContents(HtmlTextWriter).)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Overrides WebControlRenderEndTag(HtmlTextWriter).)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.Compute Method

PaginationBaseCompute Method
进行数据处理计算

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual void Compute()
Public Overridable Sub Compute
public:
virtual void Compute()
abstract Compute : unit -> unit
override Compute : unit -> unit
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.CreateLink Method

PaginationBaseCreateLink Method
创建URL链接

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string CreateLink(
    int index
)
Public Overridable Function CreateLink (
    index As Integer
) As String
public:
virtual String^ CreateLink(
    int index
)
abstract CreateLink :
        index : int -> string
override CreateLink :
        index : int -> string

Parameters

index
Type: SystemInt32
索引,当为零时将以$PAGE$代替

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.PaginationBase.CreateLink(System.Int32)"]

See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.GetViewData(T) Method

PaginationBaseGetViewDataT Method
获取一个视图变量

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual T GetViewData<T>(
    string name,
    T default
)

Protected Overridable Function GetViewData(Of T) (
    name As String,
    default As T
) As T
protected:
generic<typename T>
virtual T GetViewData(
    String^ name,
    T default
)
abstract GetViewData :
        name : string *
        default : 'T -> 'T
override GetViewData :
        name : string *
        default : 'T -> 'T

Parameters

name
Type: SystemString
变量名称
default
Type: T
当未有设置时的默认值

Type Parameters

T
类型

Return Value

Type: T

[Missing <returns> documentation for "M:Adf.Web.Pagination.PaginationBase.GetViewData``1(System.String,``0)"]

See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.RenderBeginTag Method

PaginationBaseRenderBeginTag Method
重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override void RenderBeginTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderBeginTag (
    writer As HtmlTextWriter
)
public:
virtual void RenderBeginTag(
    HtmlTextWriter^ writer
) override
abstract RenderBeginTag :
        writer : HtmlTextWriter -> unit
override RenderBeginTag :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
对象
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.RenderContents Method

PaginationBaseRenderContents Method
输出控件内容

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected override void RenderContents(
    HtmlTextWriter writer
)
Protected Overrides Sub RenderContents (
    writer As HtmlTextWriter
)
protected:
virtual void RenderContents(
    HtmlTextWriter^ writer
) override
abstract RenderContents :
        writer : HtmlTextWriter -> unit
override RenderContents :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
输出对象
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.RenderEndTag Method

PaginationBaseRenderEndTag Method
重写尾值

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override void RenderEndTag(
    HtmlTextWriter writer
)
Public Overrides Sub RenderEndTag (
    writer As HtmlTextWriter
)
public:
virtual void RenderEndTag(
    HtmlTextWriter^ writer
) override
abstract RenderEndTag :
        writer : HtmlTextWriter -> unit
override RenderEndTag :
        writer : HtmlTextWriter -> unit

Parameters

writer
Type: System.Web.UIHtmlTextWriter
对象
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.SetViewData Method

PaginationBaseSetViewData Method
设置一个视图变量

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void SetViewData(
    string name,
    Object v
)
Protected Overridable Sub SetViewData (
    name As String,
    v As Object
)
protected:
virtual void SetViewData(
    String^ name,
    Object^ v
)
abstract SetViewData :
        name : string *
        v : Object -> unit
override SetViewData :
        name : string *
        v : Object -> unit

Parameters

name
Type: SystemString
变量名称
v
Type: SystemObject
变量值
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase Properties

PaginationBase Properties

The PaginationBase type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | FistText | 首页按钮
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 是否为回发组件
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示
Public property | LastIndex | 获取最后一页页序
Public property | LastText | 尾页按钮
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序
Public property | NextText | 下一页铵钮
Public property | OnClientClick | 获取或设置客户端单击事件方法
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序
Public property | PreText | 上一页按钮
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示
Top
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.Align Property

PaginationBaseAlign Property
当未有数据时,是否显示,默认为显示

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual HorizontalAlign Align { get; set; }
Public Overridable Property Align As HorizontalAlign
    Get
    Set
public:
virtual property HorizontalAlign Align {
    HorizontalAlign get ();
    void set (HorizontalAlign value);
}
abstract Align : HorizontalAlign with get, set
override Align : HorizontalAlign with get, set

Property Value

Type: HorizontalAlign
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.ButtonCount Property

PaginationBaseButtonCount Property
获取或设置Template所设置样式中的按钮数，默认显示0个

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int ButtonCount { get; set; }
Public Overridable Property ButtonCount As Integer
    Get
    Set
public:
virtual property int ButtonCount {
    int get ();
    void set (int value);
}
abstract ButtonCount : int with get, set
override ButtonCount : int with get, set

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.Count Property

PaginationBaseCount Property
获取或设置总记录数

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual long Count { get; set; }
Public Overridable Property Count As Long
    Get
    Set
public:
virtual property long long Count {
    long long get ();
    void set (long long value);
}
abstract Count : int64 with get, set
override Count : int64 with get, set

Property Value

Type: Int64
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.FistText Property

PaginationBaseFistText Property
首页按钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string FistText { get; set; }
Public Overridable Property FistText As String
    Get
    Set
public:
virtual property String^ FistText {
    String^ get ();
    void set (String^ value);
}
abstract FistText : string with get, set
override FistText : string with get, set

Property Value

Type: String
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.Index Property

PaginationBaseIndex Property
获取或设置当前页序

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int Index { get; set; }
Public Overridable Property Index As Integer
    Get
    Set
public:
virtual property int Index {
    int get ();
    void set (int value);
}
abstract Index : int with get, set
override Index : int with get, set

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.IsCompute Property

PaginationBaseIsCompute Property
获取是否已进行计算

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public bool IsCompute { get; }
Public ReadOnly Property IsCompute As Boolean
    Get
public:
property bool IsCompute {
    bool get ();
}
member IsCompute : bool with get

Property Value

Type: Boolean
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.IsPost Property

PaginationBaseIsPost Property
是否为回发组件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual bool IsPost { get; }
Public Overridable ReadOnly Property IsPost As Boolean
    Get
public:
virtual property bool IsPost {
    bool get ();
}
abstract IsPost : bool with get
override IsPost : bool with get

Property Value

Type: Boolean
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.JumpStyle Property

PaginationBaseJumpStyle Property
获取或设置出现跳转操作的样式,0则不显示，默认不显示

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int JumpStyle { get; set; }
Public Overridable Property JumpStyle As Integer
    Get
    Set
public:
virtual property int JumpStyle {
    int get ();
    void set (int value);
}
abstract JumpStyle : int with get, set
override JumpStyle : int with get, set

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.LastIndex Property

PaginationBaseLastIndex Property
获取最后一页页序

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int LastIndex { get; }
Public Overridable ReadOnly Property LastIndex As Integer
    Get
public:
virtual property int LastIndex {
    int get ();
}
abstract LastIndex : int with get
override LastIndex : int with get

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.LastText Property

PaginationBaseLastText Property
尾页按钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string LastText { get; set; }
Public Overridable Property LastText As String
    Get
    Set
public:
virtual property String^ LastText {
    String^ get ();
    void set (String^ value);
}
abstract LastText : string with get, set
override LastText : string with get, set

Property Value

Type: String
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.NextIndex Property

PaginationBaseNextIndex Property
获取下一页页序

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int NextIndex { get; }
Public Overridable ReadOnly Property NextIndex As Integer
    Get
public:
virtual property int NextIndex {
    int get ();
}
abstract NextIndex : int with get
override NextIndex : int with get

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.NextText Property

PaginationBaseNextText Property
下一页铵钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string NextText { get; set; }
Public Overridable Property NextText As String
    Get
    Set
public:
virtual property String^ NextText {
    String^ get ();
    void set (String^ value);
}
abstract NextText : string with get, set
override NextText : string with get, set

Property Value

Type: String
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.OnClientClick Property

PaginationBaseOnClientClick Property
获取或设置客户端单击事件方法

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string OnClientClick { get; set; }
Public Overridable Property OnClientClick As String
    Get
    Set
public:
virtual property String^ OnClientClick {
    String^ get ();
    void set (String^ value);
}
abstract OnClientClick : string with get, set
override OnClientClick : string with get, set

Property Value

Type: String
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.PreIndex Property

PaginationBasePreIndex Property
获取上一页页序

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int PreIndex { get; }
Public Overridable ReadOnly Property PreIndex As Integer
    Get
public:
virtual property int PreIndex {
    int get ();
}
abstract PreIndex : int with get
override PreIndex : int with get

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.PreText Property

PaginationBasePreText Property
上一页按钮

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual string PreText { get; set; }
Public Overridable Property PreText As String
    Get
    Set
public:
virtual property String^ PreText {
    String^ get ();
    void set (String^ value);
}
abstract PreText : string with get, set
override PreText : string with get, set

Property Value

Type: String
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.RecordIndex Property

PaginationBaseRecordIndex Property
获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual long RecordIndex { get; }
Public Overridable ReadOnly Property RecordIndex As Long
    Get
public:
virtual property long long RecordIndex {
    long long get ();
}
abstract RecordIndex : int64 with get
override RecordIndex : int64 with get

Property Value

Type: Int64
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.Size Property

PaginationBaseSize Property
获取或设置分页大小，默认为10

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int Size { get; set; }
Public Overridable Property Size As Integer
    Get
    Set
public:
virtual property int Size {
    int get ();
    void set (int value);
}
abstract Size : int with get, set
override Size : int with get, set

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.Template Property

PaginationBaseTemplate Property
获取或设置视图样式类

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual ITemplate Template { get; set; }
Public Overridable Property Template As ITemplate
    Get
    Set
public:
virtual property ITemplate^ Template {
    ITemplate^ get ();
    void set (ITemplate^ value);
}
abstract Template : ITemplate with get, set
override Template : ITemplate with get, set

Property Value

Type: ITemplate
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.TemplateIndex Property

PaginationBaseTemplateIndex Property
获取或设置Template属性设置中输出样式的序号,默认为 0

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual int TemplateIndex { get; set; }
Public Overridable Property TemplateIndex As Integer
    Get
    Set
public:
virtual property int TemplateIndex {
    int get ();
    void set (int value);
}
abstract TemplateIndex : int with get, set
override TemplateIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.WriteStyle Property

PaginationBaseWriteStyle Property
是否输出Template所设置样式中的CSS样式表

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual bool WriteStyle { get; set; }
Public Overridable Property WriteStyle As Boolean
    Get
    Set
public:
virtual property bool WriteStyle {
    bool get ();
    void set (bool value);
}
abstract WriteStyle : bool with get, set
override WriteStyle : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase.ZeroVisible Property

PaginationBaseZeroVisible Property
当未有数据时,是否显示,默认为显示

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public bool ZeroVisible { get; set; }
Public Property ZeroVisible As Boolean
    Get
    Set
public:
property bool ZeroVisible {
    bool get ();
    void set (bool value);
}
member ZeroVisible : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PaginationBase Events

PaginationBase Events

The PaginationBase type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

PaginationBase Class
Adf.Web.Pagination Namespace


PostEventArgs Class

PostEventArgs Class
分页控件更改页序时的事件数据
Inheritance Hierarchy
SystemObject
SystemEventArgs
Adf.Web.PaginationPostEventArgs

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class PostEventArgs : EventArgs
Public Class PostEventArgs
    Inherits EventArgs
public ref class PostEventArgs : public EventArgs
type PostEventArgs =
    class
        inherit EventArgs
    end

The PostEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
Properties
 | Name | Description
Public property | Index | 获取所选定项的页序
Public property | Pagination | 获取相关联的分页组件
Top
See Also

Reference

Adf.Web.Pagination Namespace


PostEventArgs Methods

PostEventArgs Methods

The PostEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Top
See Also

Reference

PostEventArgs Class
Adf.Web.Pagination Namespace


PostEventArgs Properties

PostEventArgs Properties

The PostEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | Index | 获取所选定项的页序
Public property | Pagination | 获取相关联的分页组件
Top
See Also

Reference

PostEventArgs Class
Adf.Web.Pagination Namespace


PostEventArgs.Index Property

PostEventArgsIndex Property
获取所选定项的页序

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
public:
property int Index {
    int get ();
}
member Index : int with get

Property Value

Type: Int32
Int类型值
See Also

Reference

PostEventArgs Class
Adf.Web.Pagination Namespace


PostEventArgs.Pagination Property

PostEventArgsPagination Property
获取相关联的分页组件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public PostPagination Pagination { get; }
Public ReadOnly Property Pagination As PostPagination
    Get
public:
property PostPagination^ Pagination {
    PostPagination^ get ();
}
member Pagination : PostPagination with get

Property Value

Type: PostPagination
See Also

Reference

PostEventArgs Class
Adf.Web.Pagination Namespace


PostPagination Class

PostPagination Class
Post回发式分页控件
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Adf.Web.PaginationPaginationBase
Adf.Web.PaginationPostPagination

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class PostPagination : PaginationBase,
    IPostBackEventHandler
Public Class PostPagination
    Inherits PaginationBase
    Implements IPostBackEventHandler
public ref class PostPagination : public PaginationBase,
    IPostBackEventHandler
type PostPagination =
    class
        inherit PaginationBase
        interface IPostBackEventHandler
    end

The PostPagination type exposes the following members.

Constructors
 | Name | Description
Public method | PostPagination | Initializes a new instance of the PostPagination class
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算 (Inherited from PaginationBase.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建链接 (Overrides PaginationBaseCreateLink(Int32).)
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量 (Inherited from PaginationBase.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 读取上一状态存储中的数据 (Overrides WebControlLoadViewState(Object).)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发Init事件 (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPageChanged | 引发页更改事件
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Public method | RaisePostBackEvent | 回发事件处理
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Inherited from PaginationBase.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Inherited from PaginationBase.)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Inherited from PaginationBase.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量 (Inherited from PaginationBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个 (Inherited from PaginationBase.)
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数 (Inherited from PaginationBase.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | FistText | 首页按钮 (Inherited from PaginationBase.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序 (Overrides PaginationBaseIndex.)
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算 (Inherited from PaginationBase.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 该值为定值，表示该组件为回发组件 (Overrides PaginationBaseIsPost.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示 (Inherited from PaginationBase.)
Public property | LastIndex | 获取最后一页页序 (Inherited from PaginationBase.)
Public property | LastText | 尾页按钮 (Inherited from PaginationBase.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序 (Inherited from PaginationBase.)
Public property | NextText | 下一页铵钮 (Inherited from PaginationBase.)
Public property | OnClientClick | 获取或设置客户端单击事件方法 (Inherited from PaginationBase.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序 (Inherited from PaginationBase.)
Public property | PreText | 上一页按钮 (Inherited from PaginationBase.)
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值 (Inherited from PaginationBase.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10 (Inherited from PaginationBase.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类 (Inherited from PaginationBase.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0 (Inherited from PaginationBase.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表 (Inherited from PaginationBase.)
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Top
Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PageChanged | 当更改页序时发生
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

Adf.Web.Pagination Namespace


PostPagination Constructor

PostPagination Constructor
Initializes a new instance of the PostPagination class

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public PostPagination()
Public Sub New
public:
PostPagination()
new : unit -> PostPagination
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination Methods

PostPagination Methods

The PostPagination type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算 (Inherited from PaginationBase.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建链接 (Overrides PaginationBaseCreateLink(Int32).)
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量 (Inherited from PaginationBase.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 读取上一状态存储中的数据 (Overrides WebControlLoadViewState(Object).)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发Init事件 (Overrides ControlOnInit(EventArgs).)
Protected method | OnLoad | 引发 Load 事件。 (Inherited from Control.)
Protected method | OnPageChanged | 引发页更改事件
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Public method | RaisePostBackEvent | 回发事件处理
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Inherited from PaginationBase.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Inherited from PaginationBase.)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Inherited from PaginationBase.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量 (Inherited from PaginationBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.CreateLink Method

PostPaginationCreateLink Method
创建链接

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override string CreateLink(
    int index
)
Public Overrides Function CreateLink (
    index As Integer
) As String
public:
virtual String^ CreateLink(
    int index
) override
abstract CreateLink :
        index : int -> string
override CreateLink :
        index : int -> string

Parameters

index
Type: SystemInt32
链接索引

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.PostPagination.CreateLink(System.Int32)"]

See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.LoadViewState Method

PostPaginationLoadViewState Method
读取上一状态存储中的数据

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected override void LoadViewState(
    Object savedState
)
Protected Overrides Sub LoadViewState (
    savedState As Object
)
protected:
virtual void LoadViewState(
    Object^ savedState
) override
abstract LoadViewState :
        savedState : Object -> unit
override LoadViewState :
        savedState : Object -> unit

Parameters

savedState
Type: SystemObject
状态对象
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.OnInit Method

PostPaginationOnInit Method
引发Init事件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected override void OnInit(
    EventArgs e
)
Protected Overrides Sub OnInit (
    e As EventArgs
)
protected:
virtual void OnInit(
    EventArgs^ e
) override
abstract OnInit :
        e : EventArgs -> unit
override OnInit :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
事件数据
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.OnPageChanged Method

PostPaginationOnPageChanged Method
引发页更改事件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected virtual void OnPageChanged(
    PostEventArgs e
)
Protected Overridable Sub OnPageChanged (
    e As PostEventArgs
)
protected:
virtual void OnPageChanged(
    PostEventArgs^ e
)
abstract OnPageChanged :
        e : PostEventArgs -> unit
override OnPageChanged :
        e : PostEventArgs -> unit

Parameters

e
Type: Adf.Web.PaginationPostEventArgs
事件数据
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.RaisePostBackEvent Method

PostPaginationRaisePostBackEvent Method
回发事件处理

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public void RaisePostBackEvent(
    string eventArgument
)
Public Sub RaisePostBackEvent (
    eventArgument As String
)
public:
virtual void RaisePostBackEvent(
    String^ eventArgument
) sealed
abstract RaisePostBackEvent :
        eventArgument : string -> unit
override RaisePostBackEvent :
        eventArgument : string -> unit

Parameters

eventArgument
Type: SystemString
事件数据

Implements

IPostBackEventHandlerRaisePostBackEvent(String)
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination Properties

PostPagination Properties

The PostPagination type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个 (Inherited from PaginationBase.)
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数 (Inherited from PaginationBase.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | FistText | 首页按钮 (Inherited from PaginationBase.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序 (Overrides PaginationBaseIndex.)
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算 (Inherited from PaginationBase.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 该值为定值，表示该组件为回发组件 (Overrides PaginationBaseIsPost.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示 (Inherited from PaginationBase.)
Public property | LastIndex | 获取最后一页页序 (Inherited from PaginationBase.)
Public property | LastText | 尾页按钮 (Inherited from PaginationBase.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序 (Inherited from PaginationBase.)
Public property | NextText | 下一页铵钮 (Inherited from PaginationBase.)
Public property | OnClientClick | 获取或设置客户端单击事件方法 (Inherited from PaginationBase.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序 (Inherited from PaginationBase.)
Public property | PreText | 上一页按钮 (Inherited from PaginationBase.)
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值 (Inherited from PaginationBase.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10 (Inherited from PaginationBase.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类 (Inherited from PaginationBase.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0 (Inherited from PaginationBase.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表 (Inherited from PaginationBase.)
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Top
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.Index Property

PostPaginationIndex Property
获取或设置当前页序

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override int Index { get; set; }
Public Overrides Property Index As Integer
    Get
    Set
public:
virtual property int Index {
    int get () override;
    void set (int value) override;
}
abstract Index : int with get, set
override Index : int with get, set

Property Value

Type: Int32
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.IsPost Property

PostPaginationIsPost Property
该值为定值，表示该组件为回发组件

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override bool IsPost { get; }
Public Overrides ReadOnly Property IsPost As Boolean
    Get
public:
virtual property bool IsPost {
    bool get () override;
}
abstract IsPost : bool with get
override IsPost : bool with get

Property Value

Type: Boolean
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination Events

PostPagination Events

The PostPagination type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PageChanged | 当更改页序时发生
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.PageChanged Event

PostPaginationPageChanged Event
当更改页序时发生

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public event PostPaginationPageChangedEventHandler PageChanged
Public Event PageChanged As PostPaginationPageChangedEventHandler
public:
 event PostPaginationPageChangedEventHandler^ PageChanged {
    void add (PostPaginationPageChangedEventHandler^ value);
    void remove (PostPaginationPageChangedEventHandler^ value);
}
member PageChanged : IEvent<PostPaginationPageChangedEventHandler,
    PostEventArgs>

Value

Type: Adf.Web.PaginationPostPaginationPageChangedEventHandler
See Also

Reference

PostPagination Class
Adf.Web.Pagination Namespace


PostPagination.PageChangedEventHandler Delegate

PostPaginationPageChangedEventHandler Delegate
事件处理委托

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public delegate void PageChangedEventHandler(
    Object src,
    PostEventArgs e
)
Public Delegate Sub PageChangedEventHandler (
    src As Object,
    e As PostEventArgs
)
public delegate void PageChangedEventHandler(
    Object^ src,
    PostEventArgs^ e
)
type PageChangedEventHandler =
    delegate of
        src : Object *
        e : PostEventArgs -> unit

Parameters

src
Type: SystemObject
e
Type: Adf.Web.PaginationPostEventArgs
See Also

Reference

Adf.Web.Pagination Namespace


VirtualPagination Class

VirtualPagination Class
虚拟URL，Get分页控件
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UI.WebControlsWebControl
Adf.Web.PaginationPaginationBase
Adf.Web.PaginationGetPagination
Adf.Web.PaginationVirtualPagination

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public class VirtualPagination : GetPagination
Public Class VirtualPagination
    Inherits GetPagination
public ref class VirtualPagination : public GetPagination
type VirtualPagination =
    class
        inherit GetPagination
    end

The VirtualPagination type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualPagination | Initializes a new instance of the VirtualPagination class
Top
Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | AddQuery | 添加一个新的查询串 (Inherited from GetPagination.)
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算 (Inherited from PaginationBase.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建Url地址 (Overrides GetPaginationCreateLink(Int32).)
Protected method | CreateQueryString | 创建新的查询串 (Inherited from GetPagination.)
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Protected method | GetQueryData | 获取当前URL所传递的参数值 (Inherited from GetPagination.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量 (Inherited from PaginationBase.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发Load事件 (Inherited from GetPagination.)
Protected method | OnLoad | 控件导入 (Overrides ControlOnLoad(EventArgs).)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Inherited from PaginationBase.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Inherited from PaginationBase.)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Inherited from PaginationBase.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量 (Inherited from PaginationBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Protected property | AppendQuery | 获取所添加的新查询串值 (Inherited from GetPagination.)
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个 (Inherited from PaginationBase.)
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数 (Inherited from PaginationBase.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | ExcludeName | 获取或设置不进行Url传递的查询参数，多个参数以逗号分隔 (Inherited from GetPagination.)
Public property | FileName | 获取当前请求的文件名称 (Inherited from GetPagination.)
Public property | FistText | 首页按钮 (Inherited from PaginationBase.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序 (Inherited from PaginationBase.)
Public property | IndexName | 获取或设置查询串中页索引查询名，当多个控件时请将此设置为控件间不相同 (Inherited from GetPagination.)
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算 (Inherited from PaginationBase.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 是否为回发组件 (Inherited from PaginationBase.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示 (Inherited from PaginationBase.)
Public property | LastIndex | 获取最后一页页序 (Inherited from PaginationBase.)
Public property | LastText | 尾页按钮 (Inherited from PaginationBase.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序 (Inherited from PaginationBase.)
Public property | NextText | 下一页铵钮 (Inherited from PaginationBase.)
Public property | OnClientClick | 获取或设置客户端单击事件方法 (Inherited from PaginationBase.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序 (Inherited from PaginationBase.)
Public property | PreText | 上一页按钮 (Inherited from PaginationBase.)
Protected property | QueryString | 获取或设置新的查询串 (Inherited from GetPagination.)
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值 (Inherited from PaginationBase.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10 (Inherited from PaginationBase.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类 (Inherited from PaginationBase.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0 (Inherited from PaginationBase.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | TotalName | 获取或设置查询串中数据总量查询名，当多个控件时请将此为控件间不相同 (Inherited from GetPagination.)
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Public property | UrlVirtual | 获取或设置虚拟化Url对象
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表 (Inherited from PaginationBase.)
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Top
Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

Adf.Web.Pagination Namespace


VirtualPagination Constructor

VirtualPagination Constructor
Initializes a new instance of the VirtualPagination class

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public VirtualPagination()
Public Sub New
public:
VirtualPagination()
new : unit -> VirtualPagination
See Also

Reference

VirtualPagination Class
Adf.Web.Pagination Namespace


VirtualPagination Methods

VirtualPagination Methods

The VirtualPagination type exposes the following members.

Methods
 | Name | Description
Protected method | AddAttributesToRender | 将需要呈现的 HTML 属性和样式添加到指定的 HtmlTextWriterTag 中。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | AddedControl | 在子控件添加到 Control 对象的 Controls 集合后调用。 (Inherited from Control.)
Protected method | AddParsedSubObject | 通知服务器控件某个元素（XML 或 HTML）已经过语法分析，并将该元素添加到服务器控件的 ControlCollection 对象。 (Inherited from Control.)
Public method | AddQuery | 添加一个新的查询串 (Inherited from GetPagination.)
Public method | ApplyStyle | 将指定样式的所有非空白元素复制到 Web 控件，覆盖控件的所有现有的样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | ApplyStyleSheetSkin | 将页样式表中定义的样式属性应用到控件。 (Inherited from Control.)
Protected method | BuildProfileTree | 收集有关服务器控件的信息并将该信息发送到 Trace 属性，在启用页的跟踪功能时将显示该属性。 (Inherited from Control.)
Protected method | ClearChildControlState | 删除服务器控件的子控件的控件状态信息。 (Inherited from Control.)
Protected method | ClearChildState | 删除服务器控件的所有子控件的视图状态和控件状态信息。 (Inherited from Control.)
Protected method | ClearChildViewState | 删除服务器控件的所有子控件的视图状态信息。 (Inherited from Control.)
Public method | Compute | 进行数据处理计算 (Inherited from PaginationBase.)
Public method | CopyBaseAttributes | 将 Style 对象未封装的属性从指定的 Web 服务器控件复制到从中调用此方法的 Web 服务器控件。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | CreateChildControls | 由 ASP.NET 页面框架调用，以通知使用基于合成的实现的服务器控件创建它们包含的任何子控件，以便为回发或呈现做准备。 (Inherited from Control.)
Protected method | CreateControlCollection | 创建一个新的 ControlCollection 对象来保存服务器控件的子控件（包括文本控件和服务器控件）。 (Inherited from Control.)
Protected method | CreateControlStyle | 创建由 WebControl 类在内部用来实现所有与样式有关的属性的样式对象。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Public method | CreateLink | 创建Url地址 (Overrides GetPaginationCreateLink(Int32).)
Protected method | CreateQueryString | 创建新的查询串 (Inherited from GetPagination.)
Public method | DataBind | 将数据源绑定到被调用的服务器控件及其所有子控件。 (Inherited from Control.)
Protected method | DataBind(Boolean) | 将数据源绑定到调用的服务器控件及其所有子控件，同时可以选择引发 DataBinding 事件。 (Inherited from Control.)
Protected method | DataBindChildren | 将数据源绑定到服务器控件的子控件。 (Inherited from Control.)
Public method | Dispose | 使服务器控件得以在从内存中释放之前执行最后的清理操作。 (Inherited from Control.)
Protected method | EnsureChildControls | 确定服务器控件是否包含子控件。如果不包含，则创建子控件。 (Inherited from Control.)
Protected method | EnsureID | 为尚未分配标识符的控件创建标识符。 (Inherited from Control.)
Public method | Equals | 确定指定的 Object 是否等于当前的 Object。 (Inherited from Object.)
Protected method | Finalize | 允许 Object 在“垃圾回收”回收 Object 之前尝试释放资源并执行其他清理操作。 (Inherited from Object.)
Public method | FindControl(String) | 在当前的命名容器中搜索带指定 id 参数的服务器控件。 (Inherited from Control.)
Protected method | FindControl(String, Int32) | 使用指定的 id 和 pathOffset 参数（该参数有助于搜索）中指定的整数在当前命名容器中搜索服务器控件。不应重写此版本的 FindControl 方法。 (Inherited from Control.)
Public method | Focus | 为控件设置输入焦点。 (Inherited from Control.)
Protected method | GetDesignModeState | 获取控件的设计时数据。 (Inherited from Control.)
Public method | GetHashCode | 用作特定类型的哈希函数。 (Inherited from Object.)
Protected method | GetQueryData | 获取当前URL所传递的参数值 (Inherited from GetPagination.)
Public method | GetType | 获取当前实例的 Type。 (Inherited from Object.)
Protected method | GetViewDataT | 获取一个视图变量 (Inherited from PaginationBase.)
Public method | HasControls | 确定服务器控件是否包含任何子控件。 (Inherited from Control.)
Protected method | HasEvents | 返回一个值，该值指示是否为控件或任何子控件注册事件。 (Inherited from Control.)
Protected method | IsLiteralContent | 确定服务器控件是否只包含文字内容。 (Inherited from Control.)
Protected method | LoadControlState | 从 SaveControlState 方法保存的上一个页请求还原控件状态信息。 (Inherited from Control.)
Protected method | LoadViewState | 从用 SaveViewState 方法保存的上一个请求还原视图状态信息。 (Inherited from WebControl.)
Protected method | MapPathSecure | 检索虚拟路径（绝对的或相对的）映射到的物理路径。 (Inherited from Control.)
Protected method | MemberwiseClone | 创建当前 Object 的浅表副本。 (Inherited from Object.)
Public method | MergeStyle | 将指定样式的所有非空白元素复制到 Web 控件，但不覆盖该控件现有的任何样式元素。此方法主要由控件开发人员使用。 (Inherited from WebControl.)
Protected method | OnBubbleEvent | 确定服务器控件的事件是否沿页的 UI 服务器控件层次结构向上传递。 (Inherited from Control.)
Protected method | OnDataBinding | 引发 DataBinding 事件。 (Inherited from Control.)
Protected method | OnInit | 引发Load事件 (Inherited from GetPagination.)
Protected method | OnLoad | 控件导入 (Overrides ControlOnLoad(EventArgs).)
Protected method | OnPreRender | 引发 PreRender 事件。 (Inherited from Control.)
Protected method | OnUnload | 引发 Unload 事件。 (Inherited from Control.)
Protected method | OpenFile | 获取用于读取文件的 Stream。 (Inherited from Control.)
Protected method | RaiseBubbleEvent | 将所有事件源及其信息分配给控件的父级。 (Inherited from Control.)
Protected method | RemovedControl | 在子控件从 Control 对象的 Controls 集合中移除后调用。 (Inherited from Control.)
Protected method | Render | 将控件呈现给指定的 HTML 编写器。 (Inherited from WebControl.)
Public method | RenderBeginTag | 重写始值，并自动判断是否通过数据计算，如果未有则进行数据计算Compute (Inherited from PaginationBase.)
Protected method | RenderChildren | 将服务器控件子级的内容输出到提供的 HtmlTextWriter 对象，此对象编写将在客户端呈现的内容。 (Inherited from Control.)
Protected method | RenderContents | 输出控件内容 (Inherited from PaginationBase.)
Public method | RenderControl(HtmlTextWriter) | 将服务器控件的内容输出到所提供的 HtmlTextWriter 对象中；如果已启用跟踪功能，则存储有关控件的跟踪信息。 (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | 使用提供的 ControlAdapter 对象将服务器控件内容输出到提供的 HtmlTextWriter 对象。 (Inherited from Control.)
Public method | RenderEndTag | 重写尾值 (Inherited from PaginationBase.)
Protected method | ResolveAdapter | 获取负责呈现指定控件的控件适配器。 (Inherited from Control.)
Public method | ResolveClientUrl | 获取浏览器可以使用的 URL。 (Inherited from Control.)
Public method | ResolveUrl | 将 URL 转换为在请求客户端可用的 URL。 (Inherited from Control.)
Protected method | SaveControlState | 保存自页回发到服务器后发生的任何服务器控件状态更改。 (Inherited from Control.)
Protected method | SaveViewState | 保存调用 TrackViewState 方法之后修改的所有状态。 (Inherited from WebControl.)
Protected method | SetDesignModeState | 设置控件的设计时数据。 (Inherited from Control.)
Public method | SetRenderMethodDelegate | 分配事件处理程序委托，以将服务器控件及其内容呈现到父控件中。 (Inherited from Control.)
Protected method | SetViewData | 设置一个视图变量 (Inherited from PaginationBase.)
Public method | ToString | 返回表示当前 Object 的 String。 (Inherited from Object.)
Protected method | TrackViewState | 使控件跟踪其视图状态的更改，以便可以将这些更改存储在对象的 ViewState 属性中。 (Inherited from WebControl.)
Top
See Also

Reference

VirtualPagination Class
Adf.Web.Pagination Namespace


VirtualPagination.CreateLink Method

VirtualPaginationCreateLink Method
创建Url地址

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public override string CreateLink(
    int index
)
Public Overrides Function CreateLink (
    index As Integer
) As String
public:
virtual String^ CreateLink(
    int index
) override
abstract CreateLink :
        index : int -> string
override CreateLink :
        index : int -> string

Parameters

index
Type: SystemInt32
索引

Return Value

Type: String

[Missing <returns> documentation for "M:Adf.Web.Pagination.VirtualPagination.CreateLink(System.Int32)"]

See Also

Reference

VirtualPagination Class
Adf.Web.Pagination Namespace


VirtualPagination.OnLoad Method

VirtualPaginationOnLoad Method
控件导入

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
protected override void OnLoad(
    EventArgs e
)
Protected Overrides Sub OnLoad (
    e As EventArgs
)
protected:
virtual void OnLoad(
    EventArgs^ e
) override
abstract OnLoad :
        e : EventArgs -> unit
override OnLoad :
        e : EventArgs -> unit

Parameters

e
Type: SystemEventArgs
事件
See Also

Reference

VirtualPagination Class
Adf.Web.Pagination Namespace


VirtualPagination Properties

VirtualPagination Properties

The VirtualPagination type exposes the following members.

Properties
 | Name | Description
Public property | AccessKey | 获取或设置使您得以快速导航到 Web 服务器控件的访问键。 (Inherited from WebControl.)
Protected property | Adapter | 获取控件的浏览器特定适配器。 (Inherited from Control.)
Public property | Align | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Protected property | AppendQuery | 获取所添加的新查询串值 (Inherited from GetPagination.)
Public property | AppRelativeTemplateSourceDirectory | 获取或设置包含该控件的 Page 或 UserControl 对象的应用程序相对虚拟目录。 (Inherited from Control.)
Public property | Attributes | 获取与控件的属性不对应的任意特性（只用于呈现）的集合。 (Inherited from WebControl.)
Public property | BackColor | 获取或设置 Web 服务器控件的背景色。 (Inherited from WebControl.)
Public property | BindingContainer | 获取包含该控件的数据绑定的控件。 (Inherited from Control.)
Public property | BorderColor | 获取或设置 Web 控件的边框颜色。 (Inherited from WebControl.)
Public property | BorderStyle | 获取或设置 Web 服务器控件的边框样式。 (Inherited from WebControl.)
Public property | BorderWidth | 获取或设置 Web 服务器控件的边框宽度。 (Inherited from WebControl.)
Public property | ButtonCount | 获取或设置Template所设置样式中的按钮数，默认显示0个 (Inherited from PaginationBase.)
Protected property | ChildControlsCreated | 获取一个值，该值指示是否已创建服务器控件的子控件。 (Inherited from Control.)
Public property | ClientID | 获取由 ASP.NET 生成的服务器控件标识符。 (Inherited from Control.)
Protected property | ClientIDSeparator | 获取一个字符值，该值表示 ClientID 属性中使用的分隔符字符。 (Inherited from Control.)
Protected property | Context | 为当前 Web 请求获取与服务器控件关联的 HttpContext 对象。 (Inherited from Control.)
Public property | Controls | 获取 ControlCollection 对象，该对象表示 UI 层次结构中指定服务器控件的子控件。 (Inherited from Control.)
Public property | ControlStyle | 获取 Web 服务器控件的样式。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | ControlStyleCreated | 获取一个值，该值指示是否已为 ControlStyle 属性创建了 Style 对象。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Count | 获取或设置总记录数 (Inherited from PaginationBase.)
Public property | CssClass | 获取或设置由 Web 服务器控件在客户端呈现的级联样式表 (CSS) 类。 (Inherited from WebControl.)
Protected property | DesignMode | 获取一个值，该值指示是否正在使用设计图面上的一个控件。 (Inherited from Control.)
Public property | Enabled | 获取或设置一个值，该值指示是否启用 Web 服务器控件。 (Inherited from WebControl.)
Public property | EnableTheming | 获取或设置一个值，该值指示是否对此控件应用主题。 (Inherited from WebControl.)
Public property | EnableViewState | 获取或设置一个值，该值指示服务器控件是否向发出请求的客户端保持自己的视图状态以及它所包含的任何子控件的视图状态。 (Inherited from Control.)
Protected property | Events | 获取控件的事件处理程序委托列表。此属性为只读。 (Inherited from Control.)
Public property | ExcludeName | 获取或设置不进行Url传递的查询参数，多个参数以逗号分隔 (Inherited from GetPagination.)
Public property | FileName | 获取当前请求的文件名称 (Inherited from GetPagination.)
Public property | FistText | 首页按钮 (Inherited from PaginationBase.)
Public property | Font | 获取与 Web 服务器控件关联的字体属性。 (Inherited from WebControl.)
Public property | ForeColor | 获取或设置 Web 服务器控件的前景色（通常是文本颜色）。 (Inherited from WebControl.)
Public property | HasAttributes | 获取一个值，该值指示控件是否具有属性集。 (Inherited from WebControl.)
Protected property | HasChildViewState | 获取一个值，该值指示当前服务器控件的子控件是否具有任何已保存的视图状态设置。 (Inherited from Control.)
Public property | Height | 获取或设置 Web 服务器控件的高度。 (Inherited from WebControl.)
Public property | ID | 获取或设置分配给服务器控件的编程标识符。 (Inherited from Control.)
Protected property | IdSeparator | 获取用于分隔控件标识符的字符。 (Inherited from Control.)
Public property | Index | 获取或设置当前页序 (Inherited from PaginationBase.)
Public property | IndexName | 获取或设置查询串中页索引查询名，当多个控件时请将此设置为控件间不相同 (Inherited from GetPagination.)
Protected property | IsChildControlStateCleared | 获取一个值，该值指示该控件中包含的控件是否具有控件状态。 (Inherited from Control.)
Public property | IsCompute | 获取是否已进行计算 (Inherited from PaginationBase.)
Protected property | IsEnabled | 获取一个值，该值指示是否启用控件。 (Inherited from WebControl.)
Public property | IsPost | 是否为回发组件 (Inherited from PaginationBase.)
Protected property | IsTrackingViewState | 获取一个值，用于指示服务器控件是否会将更改保存到其视图状态中。 (Inherited from Control.)
Protected property | IsViewStateEnabled | 获取一个值，该值指示是否为该控件启用了视图状态。 (Inherited from Control.)
Public property | JumpStyle | 获取或设置出现跳转操作的样式,0则不显示，默认不显示 (Inherited from PaginationBase.)
Public property | LastIndex | 获取最后一页页序 (Inherited from PaginationBase.)
Public property | LastText | 尾页按钮 (Inherited from PaginationBase.)
Protected property | LoadViewStateByID | 获取一个值，该值指示控件是否通过 ID 而不是索引参与加载其视图状态。 (Inherited from Control.)
Public property | NamingContainer | 获取对服务器控件的命名容器的引用，此引用创建唯一的命名空间，以区分具有相同 ID 属性值的服务器控件。 (Inherited from Control.)
Public property | NextIndex | 获取下一页页序 (Inherited from PaginationBase.)
Public property | NextText | 下一页铵钮 (Inherited from PaginationBase.)
Public property | OnClientClick | 获取或设置客户端单击事件方法 (Inherited from PaginationBase.)
Public property | Page | 获取对包含服务器控件的 Page 实例的引用。 (Inherited from Control.)
Public property | Parent | 获取对页 UI 层次结构中服务器控件的父控件的引用。 (Inherited from Control.)
Public property | PreIndex | 获取上一页页序 (Inherited from PaginationBase.)
Public property | PreText | 上一页按钮 (Inherited from PaginationBase.)
Protected property | QueryString | 获取或设置新的查询串 (Inherited from GetPagination.)
Public property | RecordIndex | 获取进行数据处理后当前页当前最大数值，该值可做为数据处理索引开始值 (Inherited from PaginationBase.)
Public property | Site | 获取容器信息，该容器在呈现于设计图面上时承载当前控件。 (Inherited from Control.)
Public property | Size | 获取或设置分页大小，默认为10 (Inherited from PaginationBase.)
Public property | SkinID | 获取或设置要应用于控件的外观。 (Inherited from WebControl.)
Public property | Style | 获取将在 Web 服务器控件的外部标记上呈现为样式属性的文本属性的集合。 (Inherited from WebControl.)
Public property | TabIndex | 获取或设置 Web 服务器控件的选项卡索引。 (Inherited from WebControl.)
Protected property | TagKey | 获取与此 Web 服务器控件相对应的 HtmlTextWriterTag 值。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Protected property | TagName | 获取控件标记的名称。此属性主要由控件开发人员使用。 (Inherited from WebControl.)
Public property | Template | 获取或设置视图样式类 (Inherited from PaginationBase.)
Public property | TemplateControl | 获取或设置对包含该控件的模板的引用。 (Inherited from Control.)
Public property | TemplateIndex | 获取或设置Template属性设置中输出样式的序号,默认为 0 (Inherited from PaginationBase.)
Public property | TemplateSourceDirectory | 获取包含当前服务器控件的 Page 或 UserControl 的虚拟目录。 (Inherited from Control.)
Public property | ToolTip | 获取或设置当鼠标指针悬停在 Web 服务器控件上时显示的文本。 (Inherited from WebControl.)
Public property | TotalName | 获取或设置查询串中数据总量查询名，当多个控件时请将此为控件间不相同 (Inherited from GetPagination.)
Public property | UniqueID | 获取服务器控件的唯一的、以分层形式限定的标识符。 (Inherited from Control.)
Public property | UrlVirtual | 获取或设置虚拟化Url对象
Protected property | ViewState | 获取状态信息的字典，这些信息使您可以在同一页的多个请求间保存和还原服务器控件的视图状态。 (Inherited from Control.)
Protected property | ViewStateIgnoresCase | 获取一个值，该值指示 StateBag 对象是否不区分大小写。 (Inherited from Control.)
Public property | Visible | 获取或设置一个值，该值指示服务器控件是否作为 UI 呈现在页上。 (Inherited from Control.)
Public property | Width | 获取或设置 Web 服务器控件的宽度。 (Inherited from WebControl.)
Public property | WriteStyle | 是否输出Template所设置样式中的CSS样式表 (Inherited from PaginationBase.)
Public property | ZeroVisible | 当未有数据时,是否显示,默认为显示 (Inherited from PaginationBase.)
Top
See Also

Reference

VirtualPagination Class
Adf.Web.Pagination Namespace


VirtualPagination.UrlVirtual Property

VirtualPaginationUrlVirtual Property
获取或设置虚拟化Url对象

Namespace: Adf.Web.Pagination
Assembly: Adf.Web (in Adf.Web.dll) Version: 4.1.5463.29815
Syntax
C#
VB
C++
F#
Copy
public virtual UrlVirtual UrlVirtual { get; set; }
Public Overridable Property UrlVirtual As UrlVirtual
    Get
    Set
public:
virtual property UrlVirtual^ UrlVirtual {
    UrlVirtual^ get ();
    void set (UrlVirtual^ value);
}
abstract UrlVirtual : UrlVirtual with get, set
override UrlVirtual : UrlVirtual with get, set

Property Value

Type: UrlVirtual
See Also

Reference

VirtualPagination Class
Adf.Web.Pagination Namespace


VirtualPagination Events

VirtualPagination Events

The VirtualPagination type exposes the following members.

Events
 | Name | Description
Public event | DataBinding | 当服务器控件绑定到数据源时发生。 (Inherited from Control.)
Public event | Disposed | 当从内存释放服务器控件时发生，这是请求 ASP.NET 页时服务器控件生存期的最后阶段。 (Inherited from Control.)
Public event | Init | 当服务器控件初始化时发生；初始化是控件生存期的第一步。 (Inherited from Control.)
Public event | Load | 当服务器控件加载到 Page 对象中时发生。 (Inherited from Control.)
Public event | PreRender | 在加载 Control 对象之后、呈现之前发生。 (Inherited from Control.)
Public event | Unload | 当服务器控件从内存中卸载时发生。 (Inherited from Control.)
Top
See Also

Reference

VirtualPagination Class
Adf.Web.Pagination Namespace